source: projects/specs/branches/6/p/pyOpenSSL/pyOpenSSL-vl.spec @ 2508

Revision 2508, 6.2 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with openssl-1.0.0c

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define pkg_release     3%{?_dist_release}
4
5Summary: Python wrapper module around the OpenSSL library
6Summary(ja): OpenSSL ライブラリの Python ラッパーモジュール
7Name: pyOpenSSL
8Version: 0.7
9Release: %{pkg_release}
10Source0: http://pyopenssl.sf.net/%{name}-%{version}.tar.gz
11Patch0: pyOpenSSL-0.7-openssl.patch
12Patch2: pyOpenSSL-elinks.patch
13Patch3: pyOpenSSL-nopdfout.patch
14Patch4: pyOpenSSL-threadsafe.patch
15License: LGPLv2+
16Group: Development/Libraries
17URL: http://pyopenssl.sourceforge.net/
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: openssl-devel, python-devel
21BuildRequires: latex2html
22
23%description
24High-level wrapper around a subset of the OpenSSL library, includes
25 * SSL.Connection objects, wrapping the methods of Python's portable
26   sockets
27 * Callbacks written in Python
28 * Extensive error-handling mechanism, mirroring OpenSSL's error codes
29...  and much more ;)
30
31
32%prep
33%setup -q
34%patch0 -p1 -b .openssl097
35%patch2 -p1 -b .elinks
36%patch3 -p1 -b .nopdfout
37%patch4 -p1 -b .threadsafe
38# Fix permissions for debuginfo package
39%{__chmod} -x src/ssl/connection.c
40
41%build
42CFLAGS="%{optflags}" %{__python} setup.py build
43%{__make} -C doc ps
44%{__make} -C doc text html
45
46%install
47%{__rm} -rf %{buildroot}
48%{__python} setup.py install -O1 --skip-build --root %{buildroot}
49
50%clean
51%{__rm} -rf %{buildroot}
52
53%files
54%defattr(-,root,root,-)
55%doc README doc/pyOpenSSL.ps
56%doc doc/pyOpenSSL.txt doc/html
57%{python_sitearch}/OpenSSL/
58%{python_sitearch}/%{name}*.egg-info
59
60%changelog
61* Sat Jan 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7-3
62- rebuilt with openssl-1.0.0c
63- remove BuildRequires: tetex
64
65* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.7-2
66- rebuilt with python-2.6.4
67
68* Tue Dec 23 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.7-1
69- initial build for Vine Linux based on fedora package
70
71* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.7-3
72- Rebuild for Python 2.6
73
74* Fri Sep 19 2008 Dennis Gilmore <dennis@ausil.us> - 0.7-2
75- update threadsafe  patch
76- bug#462807
77
78* Mon Sep 15 2008 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7-1
79- bump to new release
80- the inevitable patch fixes
81
82
83* Wed Mar 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.6-4
84- fix horrific release tag
85- fix license tag
86- add egg-info
87
88* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6-3.p24.9
89- Autorebuild for GCC 4.3
90
91* Wed Dec  5 2007 Jeremy Katz <katzj@redhat.com> - 0.6-2.p24.9
92- rebuild for new openssl
93
94* Mon Dec 11 2006 Paul Howarth <paul@city-fan.org> - 0.6-1.p24.9
95- add missing buildreq latex2html, needed to build HTML docs
96- rewrite to be more in line with Fedora python spec template and use
97  %%{python_sitearch} rather than a script-generated %%files list
98- package is not relocatable - drop Prefix: tag
99- buildreq perl not necessary
100- fix permissions for files going into debuginfo package
101
102* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 0.6-1.p24.8
103- rebuild for python 2.5
104
105* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.6-1.p24.7.2.2
106- rebuild
107
108* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6-1.p24.7.2.1
109- bump again for double-long bug on ppc(64)
110
111* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6-1.p24.7.2
112- rebuilt for new gcc4.1 snapshot and glibc changes
113
114* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
115- rebuilt
116
117* Wed Nov  9 2005 Mihai Ibanescu <misa@redhat.com> - 0.6-1.p24.7
118- rebuilt against newer openssl
119
120* Wed Aug 24 2005 Jeremy Katz <katzj@redhat.com> - 0.6-1.p24.6
121- add dcbw's patch to fix some threading problems
122
123* Wed Aug 03 2005 Karsten Hopp <karsten@redhat.de> 0.6-1.p24.5
124- current rpm creates .pyo files, include them in filelist
125
126* Thu Mar 17 2005 Mihai Ibanescu <misa@redhat.com> 0.6-1.p24.4
127- rebuilt
128
129* Mon Mar 14 2005 Mihai Ibanescu <misa@redhat.com> 0.6-1.p24.3
130- rebuilt
131
132* Mon Mar  7 2005 Tomas Mraz <tmraz@redhat.com> 0.6-1.p23.2
133- rebuild with openssl-0.9.7e
134
135* Tue Nov  9 2004 Nalin Dahyabhai <nalin@redhat.com> 0.6-1.p23.1
136- rebuild
137
138* Fri Aug 13 2004 Mihai Ibanescu <misa@redhat.com> 0.6-1
139- 0.6 is out
140
141* Tue Aug 10 2004 Mihai Ibanescu <misa@redhat.com> 0.6-0.90.rc1
142- release candidate
143
144* Thu Jun 24 2004 Mihai Ibanescu <misa@redhat.com> 0.5.1-24
145- rebuilt
146
147* Mon Jun 21 2004 Mihai Ibanescu <misa@redhat.com> 0.5.1-23
148- rebuilt
149
150* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
151- rebuilt
152
153* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
154- rebuilt
155
156* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
157- rebuilt
158
159* Wed Nov  5 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-20
160- rebuilt against python 2.3.2
161
162* Fri Aug  8 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-12
163- lynx no longer supported, using elinks instead (patch from
164  Michael Redinger <michael.redinger@uibk.ac.at>, bug #101947 )
165
166* Wed Jun  4 2003 Elliot Lee <sopwith@redhat.com> 0.5.1-11
167- Rebuilt
168
169* Wed Jun  4 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-10.7.x
170- Built on 7.x
171
172* Mon Mar  3 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-9
173- bug #73967: Added Requires: python
174
175* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
176- rebuilt
177
178* Fri Feb 21 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-7
179- bug #84803: Added patch to expose more flags
180
181* Fri Jan 31 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-5
182- installing to %%{_libdir}
183
184* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
185- rebuilt
186
187* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 0.5.1-3
188- rebuild
189
190* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
191- Add -I and -L flags for finding Kerberos headers and libraries, in case
192  they're referenced
193
194* Tue Dec  3 2002 Mihai Ibanescu <misa@redhat.com>
195- Fix for bug 73967: site-packages/OpenSSL not owned by this package
196- Adding hacks around the lack of latex2html on ia64
197
198* Tue Sep 24 2002 Mihai Ibanescu <misa@redhat.com>
199- 0.5.1
200
201* Thu Aug 29 2002 Mihai Ibanescu <misa@redhat.com>
202- Building 0.5.1rc1 with version number 0.5.0.91 (this should also fix the big
203  error of pushing 0.5pre previously, since it breaks rpm's version comparison
204  algorithm).
205- We use %%{__python}. Too bad I can't pass --define's to distutils.
206
207* Fri Aug 16 2002 Mihai Ibanescu <misa@redhat.com>
208- Building 0.5
209
210* Fri Jun 14 2002 Mihai Ibanescu <misa@redhat.com>
211- Added documentation
Note: See TracBrowser for help on using the repository browser.