source: projects/specs/trunk/p/pyOpenSSL/pyOpenSSL-vl.spec @ 11922

Revision 11922, 7.6 KB checked in by tomop, 5 years ago (diff)

pyOpenSSL-18.0.0-1

Line 
1%define pkg_release     1%{?_dist_release}
2
3Summary: Python wrapper module around the OpenSSL library
4Summary(ja): OpenSSL ライブラリの Python ラッパーモジュール
5Name: pyOpenSSL
6Version: 18.0.0
7Release: %{pkg_release}
8Source0: https://files.pythonhosted.org/packages/source/p/pyOpenSSL/pyOpenSSL-%{version}.tar.gz
9License: LGPLv2+
10Group: Development/Libraries
11URL: https://pyopenssl.readthedocs.org/
12Vendor: Project Vine
13Distribution: Vine Linux
14BuildArch: noarch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: openssl-devel
18BuildRequires: python-devel
19BuildRequires: python3-devel
20BuildRequires: python-rpm-macros
21BuildRequires: python3-rpm-macros
22BuildRequires: python-setuptools
23BuildRequires: python3-setuptools
24BuildRequires: python-cryptography
25BuildRequires: python3-cryptography
26#BuildRequires: latex2html
27
28%description
29High-level wrapper around a subset of the OpenSSL library, includes
30 * SSL.Connection objects, wrapping the methods of Python's portable
31   sockets
32 * Callbacks written in Python
33 * Extensive error-handling mechanism, mirroring OpenSSL's error codes
34...  and much more ;)
35
36
37%package -n python-pyOpenSSL
38Summary: Python2 wrapper module around the OpenSSL library
39Obsoletes: pyOpenSSL < %{version}-%{release}
40Provides: pyOpenSSL = %{version}-%{release}
41Requires: python-cryptography
42%{?python_provide:%python_provide python-pyOpenSSL}
43
44%description -n python-pyOpenSSL
45High-level wrapper around a subset of the OpenSSL library, includes among others
46
47 * SSL.Connection objects, wrapping the methods of Python's portable
48   sockets
49 * Callbacks written in Python
50 * Extensive error-handling mechanism, mirroring OpenSSL's error codes
51
52
53%package -n python3-pyOpenSSL
54Summary: Python 3 wrapper module around the OpenSSL library
55Requires: python3-cryptography
56%{?python_provide:%python_provide python3-pyOpenSSL}
57
58%description -n python3-pyOpenSSL
59High-level wrapper around a subset of the OpenSSL library, includes among others
60
61 * SSL.Connection objects, wrapping the methods of Python's portable
62   sockets
63 * Callbacks written in Python
64 * Extensive error-handling mechanism, mirroring OpenSSL's error codes
65
66
67%prep
68%setup -q
69
70%build
71%py_build
72%py3_build
73
74%install
75%{__rm} -rf %{buildroot}
76%py_install
77%py3_install
78
79%clean
80%{__rm} -rf %{buildroot}
81
82%files -n python-pyOpenSSL
83%license LICENSE
84%doc README* CHANGELOG*
85%{python_sitelib}/OpenSSL/
86%{python_sitelib}/pyOpenSSL-*.egg-info
87
88%files -n python3-pyOpenSSL
89%license LICENSE
90%doc README* CHANGELOG*
91%{python3_sitelib}/OpenSSL/
92%{python3_sitelib}/pyOpenSSL-*.egg-info
93
94%changelog
95* Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 18.0.0-1
96- new upstream release.
97- dropped Patch2-3.
98- changed name to python{,3}-pyOpenSSL.
99- added python3 support.
100
101* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
102- new upstream release
103- remove Patch0 (pyOpenSSL-0.7-openssl.patch)
104- remove Patch4 (pyOpenSSL-threadsafe.patch)
105
106* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7-4
107- rebuild with python-2.7.2
108
109* Sat Jan 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7-3
110- rebuilt with openssl-1.0.0c
111- remove BuildRequires: tetex
112
113* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.7-2
114- rebuilt with python-2.6.4
115
116* Tue Dec 23 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.7-1
117- initial build for Vine Linux based on fedora package
118
119* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.7-3
120- Rebuild for Python 2.6
121
122* Fri Sep 19 2008 Dennis Gilmore <dennis@ausil.us> - 0.7-2
123- update threadsafe  patch
124- bug#462807
125
126* Mon Sep 15 2008 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7-1
127- bump to new release
128- the inevitable patch fixes
129
130
131* Wed Mar 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.6-4
132- fix horrific release tag
133- fix license tag
134- add egg-info
135
136* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6-3.p24.9
137- Autorebuild for GCC 4.3
138
139* Wed Dec  5 2007 Jeremy Katz <katzj@redhat.com> - 0.6-2.p24.9
140- rebuild for new openssl
141
142* Mon Dec 11 2006 Paul Howarth <paul@city-fan.org> - 0.6-1.p24.9
143- add missing buildreq latex2html, needed to build HTML docs
144- rewrite to be more in line with Fedora python spec template and use
145  %%{python_sitearch} rather than a script-generated %%files list
146- package is not relocatable - drop Prefix: tag
147- buildreq perl not necessary
148- fix permissions for files going into debuginfo package
149
150* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 0.6-1.p24.8
151- rebuild for python 2.5
152
153* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.6-1.p24.7.2.2
154- rebuild
155
156* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6-1.p24.7.2.1
157- bump again for double-long bug on ppc(64)
158
159* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6-1.p24.7.2
160- rebuilt for new gcc4.1 snapshot and glibc changes
161
162* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
163- rebuilt
164
165* Wed Nov  9 2005 Mihai Ibanescu <misa@redhat.com> - 0.6-1.p24.7
166- rebuilt against newer openssl
167
168* Wed Aug 24 2005 Jeremy Katz <katzj@redhat.com> - 0.6-1.p24.6
169- add dcbw's patch to fix some threading problems
170
171* Wed Aug 03 2005 Karsten Hopp <karsten@redhat.de> 0.6-1.p24.5
172- current rpm creates .pyo files, include them in filelist
173
174* Thu Mar 17 2005 Mihai Ibanescu <misa@redhat.com> 0.6-1.p24.4
175- rebuilt
176
177* Mon Mar 14 2005 Mihai Ibanescu <misa@redhat.com> 0.6-1.p24.3
178- rebuilt
179
180* Mon Mar  7 2005 Tomas Mraz <tmraz@redhat.com> 0.6-1.p23.2
181- rebuild with openssl-0.9.7e
182
183* Tue Nov  9 2004 Nalin Dahyabhai <nalin@redhat.com> 0.6-1.p23.1
184- rebuild
185
186* Fri Aug 13 2004 Mihai Ibanescu <misa@redhat.com> 0.6-1
187- 0.6 is out
188
189* Tue Aug 10 2004 Mihai Ibanescu <misa@redhat.com> 0.6-0.90.rc1
190- release candidate
191
192* Thu Jun 24 2004 Mihai Ibanescu <misa@redhat.com> 0.5.1-24
193- rebuilt
194
195* Mon Jun 21 2004 Mihai Ibanescu <misa@redhat.com> 0.5.1-23
196- rebuilt
197
198* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
199- rebuilt
200
201* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
202- rebuilt
203
204* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
205- rebuilt
206
207* Wed Nov  5 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-20
208- rebuilt against python 2.3.2
209
210* Fri Aug  8 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-12
211- lynx no longer supported, using elinks instead (patch from
212  Michael Redinger <michael.redinger@uibk.ac.at>, bug #101947 )
213
214* Wed Jun  4 2003 Elliot Lee <sopwith@redhat.com> 0.5.1-11
215- Rebuilt
216
217* Wed Jun  4 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-10.7.x
218- Built on 7.x
219
220* Mon Mar  3 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-9
221- bug #73967: Added Requires: python
222
223* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
224- rebuilt
225
226* Fri Feb 21 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-7
227- bug #84803: Added patch to expose more flags
228
229* Fri Jan 31 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-5
230- installing to %%{_libdir}
231
232* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
233- rebuilt
234
235* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 0.5.1-3
236- rebuild
237
238* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
239- Add -I and -L flags for finding Kerberos headers and libraries, in case
240  they're referenced
241
242* Tue Dec  3 2002 Mihai Ibanescu <misa@redhat.com>
243- Fix for bug 73967: site-packages/OpenSSL not owned by this package
244- Adding hacks around the lack of latex2html on ia64
245
246* Tue Sep 24 2002 Mihai Ibanescu <misa@redhat.com>
247- 0.5.1
248
249* Thu Aug 29 2002 Mihai Ibanescu <misa@redhat.com>
250- Building 0.5.1rc1 with version number 0.5.0.91 (this should also fix the big
251  error of pushing 0.5pre previously, since it breaks rpm's version comparison
252  algorithm).
253- We use %%{__python}. Too bad I can't pass --define's to distutils.
254
255* Fri Aug 16 2002 Mihai Ibanescu <misa@redhat.com>
256- Building 0.5
257
258* Fri Jun 14 2002 Mihai Ibanescu <misa@redhat.com>
259- Added documentation
Note: See TracBrowser for help on using the repository browser.