source: projects/specs/trunk/p/pyOpenSSL/pyOpenSSL-vl.spec @ 521

Revision 521, 6.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define pkg_release     2%{?_dist_release}
4
5Summary: Python wrapper module around the OpenSSL library
6Summary(ja): OpenSSL ライブラリの Python ラッパーモジュール
7Name: pyOpenSSL
8Version: 0.7
9Release: %{pkg_release}
10Source0: http://pyopenssl.sf.net/%{name}-%{version}.tar.gz
11Patch0: pyOpenSSL-0.7-openssl.patch
12Patch2: pyOpenSSL-elinks.patch
13Patch3: pyOpenSSL-nopdfout.patch
14Patch4: pyOpenSSL-threadsafe.patch
15License: LGPLv2+
16Group: Development/Libraries
17URL: http://pyopenssl.sourceforge.net/
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: openssl-devel, python-devel
21BuildRequires: tetex, latex2html
22
23%description
24High-level wrapper around a subset of the OpenSSL library, includes
25 * SSL.Connection objects, wrapping the methods of Python's portable
26   sockets
27 * Callbacks written in Python
28 * Extensive error-handling mechanism, mirroring OpenSSL's error codes
29...  and much more ;)
30
31
32%prep
33%setup -q
34%patch0 -p1 -b .openssl097
35%patch2 -p1 -b .elinks
36%patch3 -p1 -b .nopdfout
37%patch4 -p1 -b .threadsafe
38# Fix permissions for debuginfo package
39%{__chmod} -x src/ssl/connection.c
40
41%build
42CFLAGS="%{optflags}" %{__python} setup.py build
43%{__make} -C doc ps
44%{__make} -C doc text html
45
46%install
47%{__rm} -rf %{buildroot}
48%{__python} setup.py install -O1 --skip-build --root %{buildroot}
49
50%clean
51%{__rm} -rf %{buildroot}
52
53%files
54%defattr(-,root,root,-)
55%doc README doc/pyOpenSSL.ps
56%doc doc/pyOpenSSL.txt doc/html
57%{python_sitearch}/OpenSSL/
58%{python_sitearch}/%{name}*.egg-info
59
60%changelog
61* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.7-2
62- rebuilt with python-2.6.4
63
64* Tue Dec 23 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.7-1
65- initial build for Vine Linux based on fedora package
66
67* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.7-3
68- Rebuild for Python 2.6
69
70* Fri Sep 19 2008 Dennis Gilmore <dennis@ausil.us> - 0.7-2
71- update threadsafe  patch
72- bug#462807
73
74* Mon Sep 15 2008 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7-1
75- bump to new release
76- the inevitable patch fixes
77
78
79* Wed Mar 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.6-4
80- fix horrific release tag
81- fix license tag
82- add egg-info
83
84* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6-3.p24.9
85- Autorebuild for GCC 4.3
86
87* Wed Dec  5 2007 Jeremy Katz <katzj@redhat.com> - 0.6-2.p24.9
88- rebuild for new openssl
89
90* Mon Dec 11 2006 Paul Howarth <paul@city-fan.org> - 0.6-1.p24.9
91- add missing buildreq latex2html, needed to build HTML docs
92- rewrite to be more in line with Fedora python spec template and use
93  %%{python_sitearch} rather than a script-generated %%files list
94- package is not relocatable - drop Prefix: tag
95- buildreq perl not necessary
96- fix permissions for files going into debuginfo package
97
98* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 0.6-1.p24.8
99- rebuild for python 2.5
100
101* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.6-1.p24.7.2.2
102- rebuild
103
104* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6-1.p24.7.2.1
105- bump again for double-long bug on ppc(64)
106
107* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6-1.p24.7.2
108- rebuilt for new gcc4.1 snapshot and glibc changes
109
110* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
111- rebuilt
112
113* Wed Nov  9 2005 Mihai Ibanescu <misa@redhat.com> - 0.6-1.p24.7
114- rebuilt against newer openssl
115
116* Wed Aug 24 2005 Jeremy Katz <katzj@redhat.com> - 0.6-1.p24.6
117- add dcbw's patch to fix some threading problems
118
119* Wed Aug 03 2005 Karsten Hopp <karsten@redhat.de> 0.6-1.p24.5
120- current rpm creates .pyo files, include them in filelist
121
122* Thu Mar 17 2005 Mihai Ibanescu <misa@redhat.com> 0.6-1.p24.4
123- rebuilt
124
125* Mon Mar 14 2005 Mihai Ibanescu <misa@redhat.com> 0.6-1.p24.3
126- rebuilt
127
128* Mon Mar  7 2005 Tomas Mraz <tmraz@redhat.com> 0.6-1.p23.2
129- rebuild with openssl-0.9.7e
130
131* Tue Nov  9 2004 Nalin Dahyabhai <nalin@redhat.com> 0.6-1.p23.1
132- rebuild
133
134* Fri Aug 13 2004 Mihai Ibanescu <misa@redhat.com> 0.6-1
135- 0.6 is out
136
137* Tue Aug 10 2004 Mihai Ibanescu <misa@redhat.com> 0.6-0.90.rc1
138- release candidate
139
140* Thu Jun 24 2004 Mihai Ibanescu <misa@redhat.com> 0.5.1-24
141- rebuilt
142
143* Mon Jun 21 2004 Mihai Ibanescu <misa@redhat.com> 0.5.1-23
144- rebuilt
145
146* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
147- rebuilt
148
149* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
150- rebuilt
151
152* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
153- rebuilt
154
155* Wed Nov  5 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-20
156- rebuilt against python 2.3.2
157
158* Fri Aug  8 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-12
159- lynx no longer supported, using elinks instead (patch from
160  Michael Redinger <michael.redinger@uibk.ac.at>, bug #101947 )
161
162* Wed Jun  4 2003 Elliot Lee <sopwith@redhat.com> 0.5.1-11
163- Rebuilt
164
165* Wed Jun  4 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-10.7.x
166- Built on 7.x
167
168* Mon Mar  3 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-9
169- bug #73967: Added Requires: python
170
171* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
172- rebuilt
173
174* Fri Feb 21 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-7
175- bug #84803: Added patch to expose more flags
176
177* Fri Jan 31 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-5
178- installing to %%{_libdir}
179
180* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
181- rebuilt
182
183* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 0.5.1-3
184- rebuild
185
186* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
187- Add -I and -L flags for finding Kerberos headers and libraries, in case
188  they're referenced
189
190* Tue Dec  3 2002 Mihai Ibanescu <misa@redhat.com>
191- Fix for bug 73967: site-packages/OpenSSL not owned by this package
192- Adding hacks around the lack of latex2html on ia64
193
194* Tue Sep 24 2002 Mihai Ibanescu <misa@redhat.com>
195- 0.5.1
196
197* Thu Aug 29 2002 Mihai Ibanescu <misa@redhat.com>
198- Building 0.5.1rc1 with version number 0.5.0.91 (this should also fix the big
199  error of pushing 0.5pre previously, since it breaks rpm's version comparison
200  algorithm).
201- We use %%{__python}. Too bad I can't pass --define's to distutils.
202
203* Fri Aug 16 2002 Mihai Ibanescu <misa@redhat.com>
204- Building 0.5
205
206* Fri Jun 14 2002 Mihai Ibanescu <misa@redhat.com>
207- Added documentation
Note: See TracBrowser for help on using the repository browser.