source: projects/specs/branches/6/p/perl-Gtk2/perl-Gtk2-vl.spec @ 3176

Revision 3176, 5.5 KB checked in by iwaim, 13 years ago (diff)

perl-Gtk2-1.202-2

Line 
1#
2# Rebuild option:
3#
4#   --with testsuite         - run the test suite (requires X)
5#
6
7Name:           perl-Gtk2
8Version:        1.202
9Release:        2%{?_dist_release}
10Summary:        Perl interface to the GTK+2
11Summary(ja):    GTK+2 用の Perl インタフェース
12
13Group:          Development/Libraries
14License:        LGPLv2+
15URL:            http://search.cpan.org/dist/Gtk2/
16Source0:        http://www.cpan.org/authors/id/T/TS/TSCH/Gtk2-%{version}.tar.gz
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18
19BuildRequires:  perl >= 5.8.0
20BuildRequires:  gtk2-devel
21BuildRequires:  perl(ExtUtils::Depends), perl(ExtUtils::PkgConfig)
22BuildRequires:  perl(Glib) >= 1.160
23BuildRequires:  perl(Cairo) >= 1.00
24Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
25Requires:       perl(Glib)
26Requires:       perl(Cairo)
27
28Vendor: Project Vine
29Distribution: Vine Linux
30
31%description
32This module allows you to write Gtk+ graphical user interfaces in a
33perlish and object-oriented way, freeing you from the casting and
34memory management in C, yet remaining very close in spirit to original
35API.  Find out more about Gtk+ at http://www.gtk.org.
36
37
38%prep
39%setup -q -n Gtk2-%{version}
40
41iconv -f iso-8859-1 -t utf-8 -o pm/Helper.pm{.utf8,}
42mv pm/Helper.pm{.utf8,}
43
44# Provides: exclude perl(main)
45cat <<__EOF__ > %{name}-perl.prov
46#!/bin/sh
47/usr/lib/rpm/perl.prov \$* | grep -v '^perl(main)$'
48__EOF__
49%define __perl_provides %{_builddir}/Gtk2-%{version}/%{name}-perl.prov
50chmod +x %{__perl_provides}
51
52# Requires: exclude unversioned perl(Glib)
53cat <<__EOF__ > %{name}-perl.req
54#!/bin/sh
55/usr/lib/rpm/perl.req \$* | grep -v '^perl(Glib)$'
56__EOF__
57%define __perl_requires %{_builddir}/Gtk2-%{version}/%{name}-perl.req
58chmod +x %{__perl_requires}
59
60
61%build
62%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
63make %{?_smp_mflags}
64
65
66%install
67rm -rf $RPM_BUILD_ROOT
68make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
69find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
70find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
71find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null ';'
72chmod -R u+w $RPM_BUILD_ROOT/*
73
74
75%check
76%{?_with_testsuite:make test}
77
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82
83%files
84%defattr(-,root,root,-)
85%doc AUTHORS ChangeLog LICENSE NEWS README TODO
86%doc examples/ gtk-demo/
87%{perl_vendorarch}/auto/Gtk2/
88%{perl_vendorarch}/Gtk2*
89%{_mandir}/man3/*.3pm*
90
91
92%changelog
93* Mon Mar 28 2011 IWAI, Masaharu <iwai@alib.jp> 1.202-2vl6
94- build with perl 5.12.3
95- add Vendor and Distribution tags
96
97* Tue Nov 04 2008 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 1.202-1
98- new upstream release
99
100* Mon Jul 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.162-1
101- initial build for Vine Linux
102
103* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.162-4
104- Rebuild for perl 5.10 (again)
105
106* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.162-3
107- Autorebuild for GCC 4.3
108
109* Tue Feb  5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.162-2
110- rebuild for new perl
111
112* Wed Dec 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.162-1
113- Update to 1.162
114
115* Sun Mar 18 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.144-1
116- Update to 1.144.
117
118* Mon Feb 26 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.143-1
119- Update to 1.143.
120
121* Sun Jan 21 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.142-1
122- Update to 1.142.
123
124* Wed Nov 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.141-1
125- Update to 1.141.
126
127* Wed Sep  6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.140-1
128- Update to 1.140.
129
130* Mon May 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.122-1
131- Update to 1.122.
132
133* Mon May  1 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.121-2
134- Requires perl(Cairo)  (distro >= FC-5).
135
136* Tue Apr 11 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.121-1
137- Update to 1.121.
138
139* Tue Mar 14 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.120-1
140- Update to 1.120.
141
142* Mon Feb 20 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.104-1
143- Update to 1.104.
144- Requires perl(Glib) >= 1.105 (1.104 had problems with perl 5.8.8).
145
146* Thu Jan 19 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.103-1
147- Update to 1.103.
148- Converted the Gtk2::Helper man page to utf8 (#177802).
149- Provides list: filtered out perl(main) (#177802).
150
151* Wed Nov 30 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.102-1
152- Update to 1.102.
153
154* Thu Oct  6 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.101-1
155- Update to 1.101.
156
157* Thu Sep  8 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.100-1
158- Update to 1.100.
159
160* Fri Jul 29 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.083-1
161- Update to 1.083.
162
163* Mon Jun 27 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.082-1
164- Update to 1.082.
165
166* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
167- rebuilt
168
169* Thu Mar 10 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.080-2
170- Use perl-Glib for versioning control (patch by Ville Skyttä).
171
172* Tue Mar  8 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.080-1
173- Update to 1.080.
174
175* Tue Feb 15 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.062-1
176- Update to 1.062.
177
178* Mon Oct 25 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.061-0.fdr.2
179- Removed irrelevant or duplicated documentation files.
180- Description simplified (as suggested by Ville Skyttä).
181
182* Tue Oct  5 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.061-0.fdr.1
183- Update to 1.061.
184
185* Tue Oct  5 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.043-0.fdr.2
186- make test commented: needs X.
187
188* Sun Jul 18 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.043-0.fdr.1
189- First build.
Note: See TracBrowser for help on using the repository browser.