source: projects/specs/trunk/p/perl-Gtk2/perl-Gtk2-vl.spec @ 521

Revision 521, 5.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1#
2# Rebuild option:
3#
4#   --with testsuite         - run the test suite (requires X)
5#
6
7Name:           perl-Gtk2
8Version:        1.202
9Release:        1%{?_dist_release}
10Summary:        Perl interface to the GTK+2
11Summary(ja):    GTK+2 用の Perl インタフェース
12
13Group:          Development/Libraries
14License:        LGPLv2+
15URL:            http://search.cpan.org/dist/Gtk2/
16Source0:        http://www.cpan.org/authors/id/T/TS/TSCH/Gtk2-%{version}.tar.gz
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18
19BuildRequires:  perl >= 5.8.0
20BuildRequires:  gtk2-devel
21BuildRequires:  perl(ExtUtils::Depends), perl(ExtUtils::PkgConfig)
22BuildRequires:  perl(Glib) >= 1.160
23BuildRequires:  perl(Cairo) >= 1.00
24Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
25Requires:       perl(Glib)
26Requires:       perl(Cairo)
27
28%description
29This module allows you to write Gtk+ graphical user interfaces in a
30perlish and object-oriented way, freeing you from the casting and
31memory management in C, yet remaining very close in spirit to original
32API.  Find out more about Gtk+ at http://www.gtk.org.
33
34
35%prep
36%setup -q -n Gtk2-%{version}
37
38iconv -f iso-8859-1 -t utf-8 -o pm/Helper.pm{.utf8,}
39mv pm/Helper.pm{.utf8,}
40
41# Provides: exclude perl(main)
42cat <<__EOF__ > %{name}-perl.prov
43#!/bin/sh
44/usr/lib/rpm/perl.prov \$* | grep -v '^perl(main)$'
45__EOF__
46%define __perl_provides %{_builddir}/Gtk2-%{version}/%{name}-perl.prov
47chmod +x %{__perl_provides}
48
49# Requires: exclude unversioned perl(Glib)
50cat <<__EOF__ > %{name}-perl.req
51#!/bin/sh
52/usr/lib/rpm/perl.req \$* | grep -v '^perl(Glib)$'
53__EOF__
54%define __perl_requires %{_builddir}/Gtk2-%{version}/%{name}-perl.req
55chmod +x %{__perl_requires}
56
57
58%build
59%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
60make %{?_smp_mflags}
61
62
63%install
64rm -rf $RPM_BUILD_ROOT
65make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
66find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
67find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
68find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null ';'
69chmod -R u+w $RPM_BUILD_ROOT/*
70
71
72%check
73%{?_with_testsuite:make test}
74
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79
80%files
81%defattr(-,root,root,-)
82%doc AUTHORS ChangeLog LICENSE NEWS README TODO
83%doc examples/ gtk-demo/
84%{perl_vendorarch}/auto/Gtk2/
85%{perl_vendorarch}/Gtk2*
86%{_mandir}/man3/*.3pm*
87
88
89%changelog
90* Tue Nov 04 2008 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 1.202-1
91- new upstream release
92
93* Mon Jul 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.162-1
94- initial build for Vine Linux
95
96* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.162-4
97- Rebuild for perl 5.10 (again)
98
99* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.162-3
100- Autorebuild for GCC 4.3
101
102* Tue Feb  5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.162-2
103- rebuild for new perl
104
105* Wed Dec 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.162-1
106- Update to 1.162
107
108* Sun Mar 18 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.144-1
109- Update to 1.144.
110
111* Mon Feb 26 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.143-1
112- Update to 1.143.
113
114* Sun Jan 21 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.142-1
115- Update to 1.142.
116
117* Wed Nov 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.141-1
118- Update to 1.141.
119
120* Wed Sep  6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.140-1
121- Update to 1.140.
122
123* Mon May 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.122-1
124- Update to 1.122.
125
126* Mon May  1 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.121-2
127- Requires perl(Cairo)  (distro >= FC-5).
128
129* Tue Apr 11 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.121-1
130- Update to 1.121.
131
132* Tue Mar 14 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.120-1
133- Update to 1.120.
134
135* Mon Feb 20 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.104-1
136- Update to 1.104.
137- Requires perl(Glib) >= 1.105 (1.104 had problems with perl 5.8.8).
138
139* Thu Jan 19 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.103-1
140- Update to 1.103.
141- Converted the Gtk2::Helper man page to utf8 (#177802).
142- Provides list: filtered out perl(main) (#177802).
143
144* Wed Nov 30 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.102-1
145- Update to 1.102.
146
147* Thu Oct  6 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.101-1
148- Update to 1.101.
149
150* Thu Sep  8 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.100-1
151- Update to 1.100.
152
153* Fri Jul 29 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.083-1
154- Update to 1.083.
155
156* Mon Jun 27 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.082-1
157- Update to 1.082.
158
159* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
160- rebuilt
161
162* Thu Mar 10 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.080-2
163- Use perl-Glib for versioning control (patch by Ville Skyttä).
164
165* Tue Mar  8 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.080-1
166- Update to 1.080.
167
168* Tue Feb 15 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.062-1
169- Update to 1.062.
170
171* Mon Oct 25 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.061-0.fdr.2
172- Removed irrelevant or duplicated documentation files.
173- Description simplified (as suggested by Ville Skyttä).
174
175* Tue Oct  5 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.061-0.fdr.1
176- Update to 1.061.
177
178* Tue Oct  5 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.043-0.fdr.2
179- make test commented: needs X.
180
181* Sun Jul 18 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.043-0.fdr.1
182- First build.
Note: See TracBrowser for help on using the repository browser.