source: projects/specs/branches/6/o/openssl/openssl-vl.spec @ 8528

Revision 8528, 25.4 KB checked in by iwamoto, 10 years ago (diff)

openssl: new upstream release 1.0.0m

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 10
3%define version 1.0.0m
4%define release 1%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl
8Version: %{version}
9Release: %{release}
10
11Source: openssl-%{version}.tar.gz
12Source2: Makefile.certificate
13Source6: make-dummy-cert
14Source7: renew-dummy-cert
15
16Patch0: openssl-1.0.0-soversion.patch
17Patch2: openssl-1.0.0-rpm_opt.patch
18Patch4: openssl-1.0.0-enginesdir.patch
19
20# security fix
21# Patch10: openssl-1.0.0_CVE-2014-0076.patch
22# Patch11: openssl-1.0.0l_CVE-2010-5298.patch
23# Patch12: openssl-1.0.0_CVE-2014-0198.patch
24
25License: OpenSSL
26Group: System Environment/Libraries
27URL: http://www.openssl.org/
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: perl, sed
30BuildRequires: zlib-devel, krb5-devel
31Requires: mktemp
32Requires: ca-certificates
33
34Packager: daisuke
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
39
40%description
41The OpenSSL certificate management tool and the shared libraries that
42provide various cryptographic algorithms and protocols.
43
44%package devel
45Summary: OpenSSL libraries and development headers.
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48Requires: krb5-devel
49
50%description devel
51The static libraries and include files needed to compile apps
52with support for various the cryptographic algorithms and protocols
53supported by OpenSSL.
54
55Patches for many networking apps can be found at:
56ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
57
58%package static
59Summary:  Libraries for static linking of applications which will use OpenSSL
60Group: Development/Libraries
61Requires: %{name}-devel = %{version}-%{release}
62
63%description static
64OpenSSL is a toolkit for supporting cryptography. The openssl-static
65package contains static libraries needed for static linking of
66applications which support various cryptographic algorithms and
67protocols.
68
69%package perl
70Summary: OpenSSL scripts which require Perl.
71Group: Applications/Internet
72Requires: perl
73Requires: %{name} = %{version}-%{release}
74
75%description perl
76Perl scripts provided with OpenSSL for converting certificates and keys
77from other formats to those used by OpenSSL.
78
79## to build compat32 for x86_64 architecture support
80%package -n compat32-%{name}
81Summary: Secure Sockets Layer Toolkit
82Group: System Environment/Libraries
83Requires: %{name} = %{version}-%{release}
84%description -n compat32-%{name}
85The OpenSSL certificate management tool and the shared libraries that
86provide various cryptographic algorithms and protocols.
87
88%package -n compat32-%{name}-devel
89Summary: OpenSSL libraries and development headers.
90Group: Development/Libraries
91Requires: compat32-%{name} = %{version}-%{release}
92Requires: compat32-krb5-devel
93%description -n compat32-%{name}-devel
94The static libraries and include files needed to compile apps
95with support for various the cryptographic algorithms and protocols
96supported by OpenSSL.
97
98%prep
99%setup -q -n openssl-%{version}
100%patch0 -p1 -b .soversion
101%patch2 -p1 -b .rpm_opt
102%patch4 -p1 -b .enginesdir
103
104# security fix
105# %patch10 -p1 -b .CVE-2014-0076
106# %patch11 -p1 -b .CVE-2010-0098
107# %patch12 -p1 -b .CVE-2014-0198
108
109chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
110chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
111chmod 644 doc/openssl_button.html doc/openssl_button.gif
112chmod 644 doc/ssleay.txt
113
114# Link the configuration header to the one we're going to make.
115ln -sf ../../crypto/opensslconf.h include/openssl/
116
117%build
118PATH=${PATH}:${PWD}/bin
119TOPDIR=${PWD}
120LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
121
122# Figure out which flags we want to use.  Can't use assembler because it's
123# not lowest-common-denominator in most cases.
124perl util/perlpath.pl `dirname %{__perl}`
125%ifarch %ix86
126sslarch=linux-elf
127sslflags="no-asm 386"
128%endif
129%ifarch ppc
130sslarch=linux-ppc
131sslflags=no-asm
132%endif
133%ifarch sparc
134sslarch=linux-sparcv9
135sslflags=no-asm
136%endif
137%ifarch ia64
138sslarch=linux-ia64
139sslflags=no-asm
140%endif
141%ifarch alpha
142sslarch=linux-alpha-gcc
143sslflags=no-asm
144%endif
145%ifarch s390
146sslarch=linux-s390
147%endif
148%ifarch s390x
149sslarch=linux-s390x
150%endif
151%ifarch mipsel
152sslarch=linux-mips
153sslflags=no-asm
154%endif
155## to build for x86_64 architecture support
156%ifarch x86_64
157sslarch=linux-x86_64
158sslflags=no-asm
159%endif
160
161# Configure the build tree.  Override OpenSSL defaults with known-good defaults
162# usable on all platforms.  The Configure script already knows to use -fPIC and
163# RPM_OPT_FLAGS, so we can skip specifiying them here.
164./Configure  \
165         --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
166         zlib-dynamic enable-rfc3779 \
167         --enginesdir=%{_libdir}/openssl/engines \
168        --with-krb5-flavor=MIT  --with-krb5-dir=/usr \
169         shared ${sslarch}
170
171# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
172# marked as not requiring an executable stack.
173RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
174make depend
175make all build-shared
176
177# Generate hashes for the included certs.
178LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
179export LD_LIBRARY_PATH
180make rehash build-shared
181
182# Verify that what was compiled actually works.
183make -C test apps tests
184
185# Relink the main binary to get it dynamically linked.
186rm apps/openssl
187make all build-shared
188
189%install
190[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
191# Install OpenSSL.
192install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
193make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
194install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
195# added for lib64
196# mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
197mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
198# mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
199mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
200mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man/* $RPM_BUILD_ROOT%{_mandir}
201rmdir $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man
202rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
203for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
204        chmod 755 ${lib}
205        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
206        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
207done
208# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
209
210# Install a makefile for generating keys and self-signed certs, and a script
211# for generating them on the fly.
212mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
213install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/Makefile
214install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/make-dummy-cert
215install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
216
217# Make sure we actually include the headers we built against.
218for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
219        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
220                install -m644 include/openssl/`basename ${header}` ${header}
221        fi
222done
223
224# Rename man pages so that they don't conflict with system man pages.  We used
225# to change the file extensions, but that only prevents file conflicts.  The
226# man viewer still can't select either of the two unless we physically change
227# the directory.
228for section in 1 2 3 4 5 6 7 8 ; do
229        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
230                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
231                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
232        fi
233done
234
235# Pick a CA script.
236pushd  $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc
237mv CA.sh CA
238popd
239
240mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
241mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
242mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
243mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
244mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
245
246# Ensure the openssl.cnf timestamp is identical across builds to avoid
247# mulitlib conflicts and unnecessary renames on upgrade
248touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
249
250# Fix libdir.
251#sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
252# sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
253#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
254#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
255# cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
256#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
257# rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
258
259%clean
260[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
261
262%files
263%defattr(-,root,root)
264%doc FAQ LICENSE CHANGES NEWS INSTALL README
265%doc doc/README doc/c-indentation.el doc/openssl.txt
266%doc doc/openssl_button.html doc/openssl_button.gif
267%doc doc/ssleay.txt
268
269%{_sysconfdir}/pki/tls/certs/make-dummy-cert
270%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
271%{_sysconfdir}/pki/tls/certs/Makefile
272%{_sysconfdir}/pki/tls/misc/CA
273%dir %{_sysconfdir}/pki/CA
274%dir %{_sysconfdir}/pki/CA/private
275%dir %{_sysconfdir}/pki/CA/certs
276%dir %{_sysconfdir}/pki/CA/crl
277%dir %{_sysconfdir}/pki/CA/newcerts
278%{_sysconfdir}/pki/tls/misc/c_*
279%dir %{_sysconfdir}/pki/tls
280%dir %{_sysconfdir}/pki/tls/certs
281%dir %{_sysconfdir}/pki/tls/misc
282%dir %{_sysconfdir}/pki/tls/private
283
284%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
285
286%attr(0755,root,root) %{_bindir}/openssl
287%attr(0755,root,root) /%{_lib}/*.so.*
288%attr(0755,root,root) %{_libdir}/openssl/engines/*.so
289%attr(0755,root,root) %dir %{_mandir}/man1*
290%attr(0644,root,root) %{_mandir}/man1*/*
291%attr(0755,root,root) %dir %{_mandir}/man5*
292%attr(0644,root,root) %{_mandir}/man5*/*
293%attr(0755,root,root) %dir %{_mandir}/man7*
294%attr(0644,root,root) %{_mandir}/man7*/*
295
296%files devel
297%defattr(-,root,root)
298%{_prefix}/include/openssl
299%exclude %{_libdir}/lib*.a
300%attr(0755,root,root) %{_libdir}/*.so
301%attr(0755,root,root) %dir %{_mandir}/man3*
302%attr(0644,root,root) %{_mandir}/man3*/*
303%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
304
305%files static
306%defattr(-,root,root)
307%attr(0644,root,root) %{_libdir}/*.a
308
309%files perl
310%defattr(-,root,root)
311%attr(0755,root,root) %{_bindir}/c_rehash
312%attr(0755,root,root) %dir %{_mandir}/man1*
313%attr(0644,root,root) %{_mandir}/man1*/*.pl*
314%{_sysconfdir}/pki/tls/misc/*.pl
315#%{_sysconfdir}/pki/tls/misc/tsget
316%doc apps/tsget
317
318## to build compat32 for x86_64 architecture support
319%if %{build_compat32}
320%files -n compat32-%{name}
321%defattr(-,root,root)
322%attr(0755,root,root) /%{_lib}/*.so.*
323
324%files -n compat32-%{name}-devel
325%defattr(-,root,root)
326%exclude %{_libdir}/lib*.a
327%attr(0755,root,root) %{_libdir}/*.so
328%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
329%endif
330
331%post -p /sbin/ldconfig
332
333%postun -p /sbin/ldconfig
334
335%post -n compat32-%{name} -p /sbin/ldconfig
336
337%postun -n compat32-%{name} -p /sbin/ldconfig
338
339%changelog
340* Thu Jun  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0m-1
341- new upstream release with security fixes
342- drop patch10-12 (are included in new release)
343
344* Mon May 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-4
345- add patch12 CVE-2014-0198
346
347* Mon Apr 21 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-3
348- add patch11 for fix CVE-2010-0098
349
350* Fri Mar 28 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-2
351- add patch10 for fix CVE-2014-0076
352
353* Tue Jan  7 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-1
354- new upstream release with security fix (CVE-2013-6450)
355
356* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0k-2
357- move root CA bundle to ca-certificates package
358
359* Wed Feb  6 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0k-1
360- new upstream release with security fix (CVE-2013-0166, 0169)
361
362* Sat May 12 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0j-1
363- new upstream release with security fix (CVE-2012-2333) 
364
365* Fri Apr 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0i-1
366- new upstream release with security fix (CVE-2012-2110)
367
368* Sat Mar 31 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0h-1
369- new upstream release with security fix (CVE-2012-0884)
370
371* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
372- new upstream release with security fix (CVE-2012-0050)
373
374* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
375- new upstream release with security fix
376  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
377
378* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
379- new upstream release with security fix (CVE-2011-3207, 3210)
380
381* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
382- rebuild with krb5-libs 1.8
383
384* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
385- new upstream release with security fix
386
387* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
388- use upstream openssl.pc instead of vine original one (SOURCE6)
389
390* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
391- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
392
393* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
394- add R: krb5-devel into devel pkg
395- add R: compat32-krb5-devel into compat32-devel pkg
396
397* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
398- new upstream release 1.0.0x
399- separate static libs into static package
400- change configure options
401- change so version 10
402- add tsget into perl package
403- update all patches
404
405* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
406- fix changelog typo...
407
408* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
409- new upstream release with security fix (CVE-2010-4180)
410
411* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
412- new upstream release with security fix (CVE-2010-3864)
413- drop patches included in new release
414- update patch4
415
416* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
417- add patch12 for fix CVE-2009-3555 (renegotiation)
418
419* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
420- add patch11 for fix CVE-2009-4355 (memory leak)
421
422* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
423- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
424
425* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
426- removed unnecessary %%if %{build_compat32} statements
427- removed lib*.a from devel package
428
429* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
430- new upstream release with security fix (CVE-2000-0590,0591,0789)
431
432* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
433- new upstream release with security fix (CVE-2008-5077)
434
435* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
436- new upstream release
437
438* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
439- new upstream release
440- new versioning policy
441
442* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
443- new upstream release
444- drop patch10,20 which is merged in upstream
445
446* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
447- add security patch in advance for CVE-2007-5135
448  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
449  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
450
451* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
452- add security patch for CVE-2007-3108
453  (http://openssl.org/news/patch-CVE-2007-3108.txt)
454
455* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
456- new upstream release
457
458* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
459- update (fix) openssl.pc <BTS:437>
460
461* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
462- new upstream release (with security fix)
463
464* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
465- new upstream release
466- add patch2 to use RPM_OPT macro
467
468* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
469- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
470
471* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
472- added compat32-* packages for x86_64 architecture support
473- added openssl-0.9.7i.Configure-compat32.patch
474- changed '/lib' to '/%{_lib}'
475
476* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
477- new upstream release
478
479* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
480- rebuild on VineSeed
481
482* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
483- added a security patch from Gentoo.
484  - Patch1: openssl-0.9.7c-tempfile.patch
485
486* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
487- sslarch for ppc was missing... added.
488
489* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
490- use sslarch=linux-alpha-gcc instead of alpha-gcc
491
492* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
493- new upstream version
494- clean up of spec file
495        -- removed old patches
496
497* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
498- new upstream release
499- SECURITY fix.
500  - http://www.openssl.org/news/secadv_20040317.txt
501
502* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
503- new upstream release
504- [Security fix]
505  - Vulnerabilities in ASN.1 parsing
506    http://www.openssl.org/news/secadv_20030930.txt
507- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
508
509* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
510- add openssl.pc for pkgconfig
511
512* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
513- New upstream version
514- dropped patch10, 11
515        -- merged upstream version
516
517* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
518- rebuild for VineSeed
519
520* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
521- [Security Fix]
522  - Timing-based attacks on RSA keys
523    http://www.openssl.org/news/secadv_20030317.txt
524  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
525    http://www.openssl.org/news/secadv_20030317.txt
526
527* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
528- new upstream release 0.9.6i
529- [Security Fix]
530- build for Vine Linux 2.6 errata
531
532* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
533- new upstream release 0.9.6h
534
535* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
536- new upstream release 0.9.6g
537
538* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
539- SECURITY: CAN-2002-0659 fixed
540  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
541    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
542    - update asn patch to fix accidental reversal of a logic check
543    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
544    - update asn patch to reduce chance that compiler optimization will remove
545      one of the added tests
546    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
547    - rebuild
548    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
549    - add patch to fix ASN.1 vulnerabilities
550
551* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
552- rename spec file name
553- SECURITY: CA-2002-23 fixed
554  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
555    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
556    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
557
558* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
559- added ${PATH} in LD_LIBRARY_PATH
560- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
561 
562* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
563- remove --no-<cipher>
564
565* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
566- add Patch10 for mipsel shared ( Configure )
567
568* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
569- build for Vine Linux
570- use openssl-engine-0.9.6b.tar.gz
571
572* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
573- update to 0.9.6b
574
575* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
576- move .so symlinks back to %%{_libdir}
577
578* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
579- move shared libraries to /lib (#38410)
580
581* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
582- switch to engine code base
583
584* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
585- add a script for creating dummy certificates
586- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
587
588* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
589- add s390x support
590
591* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
592- change two memcpy() calls to memmove()
593- don't define L_ENDIAN on alpha
594
595* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
596- make subpackages depend on the main package
597
598* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
599- adjust the hobble script to not disturb symlinks in include/ (fix from
600  Joe Orton)
601
602* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
603- drop the m2crypo patch we weren't using
604
605* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
606- configure using "shared" as well
607
608* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
609- update to 0.9.6a
610- use the build-shared target to build shared libraries
611- bump the soversion to 2 because we're no longer compatible with
612  our 0.9.5a packages or our 0.9.6 packages
613- drop the patch for making rsatest a no-op when rsa null support is used
614- put all man pages into <section>ssl instead of <section>
615- break the m2crypto modules into a separate package
616
617* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
618- use BN_LLONG on s390
619
620* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
621- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
622
623* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
624- move c_rehash to the perl subpackage, because it's a perl script now
625
626* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
627- update to 0.9.6
628- enable MD2
629- use the libcrypto.so and libssl.so targets to build shared libs with
630- bump the soversion to 1 because we're no longer compatible with any of
631  the various 0.9.5a packages circulating around, which provide lib*.so.0
632
633* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
634- change hobble-openssl for disabling MD2 again
635
636* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
637- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
638  bytes or so, causing EVP_DigestInit() to zero out stack variables in
639  apps built against a version of the library without it
640
641* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
642- disable some inline assembly, which on x86 is Pentium-specific
643- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
644
645* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
646- fix s390 patch
647
648* Fri Dec 8 2000 Than Ngo <than@redhat.com>
649- added support s390
650
651* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
652- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
653- add the CA.pl man page to the perl subpackage
654
655* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
656- always build with -mcpu=ev5 on alpha
657
658* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
659- add a symlink from cert.pem to ca-bundle.crt
660
661* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
662- add a ca-bundle file for packages like Samba to reference for CA certificates
663
664* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
665- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
666
667* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
668- add unzip as a buildprereq (#17662)
669- update m2crypto to 0.05-snap4
670
671* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
672- fix some issues in building when it's not installed
673
674* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
675- make sure the headers we include are the ones we built with (aaaaarrgh!)
676
677* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
678- add Richard Henderson's patch for BN on ia64
679- clean up the changelog
680
681* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
682- fix the building of python modules without openssl-devel already installed
683
684* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
685- byte-compile python extensions without the build-root
686- adjust the makefile to not remove temporary files (like .key files when
687  building .csr files) by marking them as .PRECIOUS
688
689* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
690- break out python extensions into a subpackage
691
692* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
693- tweak the makefile some more
694
695* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
696- disable MD2 support
697
698* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
699- disable MDC2 support
700
701* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
702- tweak the disabling of RC5, IDEA support
703- tweak the makefile
704
705* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
706- strip binaries and libraries
707- rework certificate makefile to have the right parts for Apache
708
709* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
710- use %%{_perl} instead of /usr/bin/perl
711- disable alpha until it passes its own test suite
712
713* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
714- move the passwd.1 man page out of the passwd package's way
715
716* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
717- update to 0.9.5a, modified for U.S.
718- add perl as a build-time requirement
719- move certificate makefile to another package
720- disable RC5, IDEA, RSA support
721- remove optimizations for now
722
723* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
724- Bero told me to move the Makefile into this package
725
726* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
727- add lib*.so symlinks to link dynamically against shared libs
728
729* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
730- update to 0.9.5
731- run ldconfig directly in post/postun
732- add FAQ
733
734* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
735- Fix build on non-x86 platforms
736
737* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
738- move /usr/share/ssl/* from -devel to main package
739
740* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
741- inital packaging
742- changes from base:
743  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
744  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.