source: projects/specs/branches/6/o/openssl/openssl-vl.spec @ 8457

Revision 8457, 25.3 KB checked in by iwamoto, 10 years ago (diff)

openssl: fix CVE-2014-0198

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 10
3%define version 1.0.0l
4%define release 4%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl
8Version: %{version}
9Release: %{release}
10
11Source: openssl-%{version}.tar.gz
12Source2: Makefile.certificate
13Source6: make-dummy-cert
14Source7: renew-dummy-cert
15
16Patch0: openssl-1.0.0-soversion.patch
17Patch2: openssl-1.0.0-rpm_opt.patch
18Patch4: openssl-1.0.0-enginesdir.patch
19
20# security fix
21Patch10: openssl-1.0.0_CVE-2014-0076.patch
22Patch11: openssl-1.0.0l_CVE-2010-5298.patch
23Patch12: openssl-1.0.0_CVE-2014-0198.patch
24
25License: OpenSSL
26Group: System Environment/Libraries
27URL: http://www.openssl.org/
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: perl, sed
30BuildRequires: zlib-devel, krb5-devel
31Requires: mktemp
32Requires: ca-certificates
33
34Packager: daisuke
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
39
40%description
41The OpenSSL certificate management tool and the shared libraries that
42provide various cryptographic algorithms and protocols.
43
44%package devel
45Summary: OpenSSL libraries and development headers.
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48Requires: krb5-devel
49
50%description devel
51The static libraries and include files needed to compile apps
52with support for various the cryptographic algorithms and protocols
53supported by OpenSSL.
54
55Patches for many networking apps can be found at:
56ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
57
58%package static
59Summary:  Libraries for static linking of applications which will use OpenSSL
60Group: Development/Libraries
61Requires: %{name}-devel = %{version}-%{release}
62
63%description static
64OpenSSL is a toolkit for supporting cryptography. The openssl-static
65package contains static libraries needed for static linking of
66applications which support various cryptographic algorithms and
67protocols.
68
69%package perl
70Summary: OpenSSL scripts which require Perl.
71Group: Applications/Internet
72Requires: perl
73Requires: %{name} = %{version}-%{release}
74
75%description perl
76Perl scripts provided with OpenSSL for converting certificates and keys
77from other formats to those used by OpenSSL.
78
79## to build compat32 for x86_64 architecture support
80%package -n compat32-%{name}
81Summary: Secure Sockets Layer Toolkit
82Group: System Environment/Libraries
83Requires: %{name} = %{version}-%{release}
84%description -n compat32-%{name}
85The OpenSSL certificate management tool and the shared libraries that
86provide various cryptographic algorithms and protocols.
87
88%package -n compat32-%{name}-devel
89Summary: OpenSSL libraries and development headers.
90Group: Development/Libraries
91Requires: compat32-%{name} = %{version}-%{release}
92Requires: compat32-krb5-devel
93%description -n compat32-%{name}-devel
94The static libraries and include files needed to compile apps
95with support for various the cryptographic algorithms and protocols
96supported by OpenSSL.
97
98%prep
99%setup -q -n openssl-%{version}
100%patch0 -p1 -b .soversion
101%patch2 -p1 -b .rpm_opt
102%patch4 -p1 -b .enginesdir
103
104# security fix
105%patch10 -p1 -b .CVE-2014-0076
106%patch11 -p1 -b .CVE-2010-0098
107%patch12 -p1 -b .CVE-2014-0198
108
109chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
110chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
111chmod 644 doc/openssl_button.html doc/openssl_button.gif
112chmod 644 doc/ssleay.txt
113
114# Link the configuration header to the one we're going to make.
115ln -sf ../../crypto/opensslconf.h include/openssl/
116
117%build
118PATH=${PATH}:${PWD}/bin
119TOPDIR=${PWD}
120LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
121
122# Figure out which flags we want to use.  Can't use assembler because it's
123# not lowest-common-denominator in most cases.
124perl util/perlpath.pl `dirname %{__perl}`
125%ifarch %ix86
126sslarch=linux-elf
127sslflags="no-asm 386"
128%endif
129%ifarch ppc
130sslarch=linux-ppc
131sslflags=no-asm
132%endif
133%ifarch sparc
134sslarch=linux-sparcv9
135sslflags=no-asm
136%endif
137%ifarch ia64
138sslarch=linux-ia64
139sslflags=no-asm
140%endif
141%ifarch alpha
142sslarch=linux-alpha-gcc
143sslflags=no-asm
144%endif
145%ifarch s390
146sslarch=linux-s390
147%endif
148%ifarch s390x
149sslarch=linux-s390x
150%endif
151%ifarch mipsel
152sslarch=linux-mips
153sslflags=no-asm
154%endif
155## to build for x86_64 architecture support
156%ifarch x86_64
157sslarch=linux-x86_64
158sslflags=no-asm
159%endif
160
161# Configure the build tree.  Override OpenSSL defaults with known-good defaults
162# usable on all platforms.  The Configure script already knows to use -fPIC and
163# RPM_OPT_FLAGS, so we can skip specifiying them here.
164./Configure  \
165         --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
166         zlib-dynamic enable-rfc3779 \
167         --enginesdir=%{_libdir}/openssl/engines \
168        --with-krb5-flavor=MIT  --with-krb5-dir=/usr \
169         shared ${sslarch}
170
171# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
172# marked as not requiring an executable stack.
173RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
174make depend
175make all build-shared
176
177# Generate hashes for the included certs.
178LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
179export LD_LIBRARY_PATH
180make rehash build-shared
181
182# Verify that what was compiled actually works.
183make -C test apps tests
184
185# Relink the main binary to get it dynamically linked.
186rm apps/openssl
187make all build-shared
188
189%install
190[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
191# Install OpenSSL.
192install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
193make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
194install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
195# added for lib64
196# mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
197mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
198# mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
199mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
200mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man/* $RPM_BUILD_ROOT%{_mandir}
201rmdir $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man
202rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
203for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
204        chmod 755 ${lib}
205        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
206        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
207done
208# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
209
210# Install a makefile for generating keys and self-signed certs, and a script
211# for generating them on the fly.
212mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
213install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/Makefile
214install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/make-dummy-cert
215install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
216
217# Make sure we actually include the headers we built against.
218for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
219        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
220                install -m644 include/openssl/`basename ${header}` ${header}
221        fi
222done
223
224# Rename man pages so that they don't conflict with system man pages.  We used
225# to change the file extensions, but that only prevents file conflicts.  The
226# man viewer still can't select either of the two unless we physically change
227# the directory.
228for section in 1 2 3 4 5 6 7 8 ; do
229        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
230                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
231                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
232        fi
233done
234
235# Pick a CA script.
236pushd  $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc
237mv CA.sh CA
238popd
239
240mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
241mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
242mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
243mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
244mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
245
246# Ensure the openssl.cnf timestamp is identical across builds to avoid
247# mulitlib conflicts and unnecessary renames on upgrade
248touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
249
250# Fix libdir.
251#sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
252# sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
253#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
254#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
255# cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
256#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
257# rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
258
259%clean
260[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
261
262%files
263%defattr(-,root,root)
264%doc FAQ LICENSE CHANGES NEWS INSTALL README
265%doc doc/README doc/c-indentation.el doc/openssl.txt
266%doc doc/openssl_button.html doc/openssl_button.gif
267%doc doc/ssleay.txt
268
269%{_sysconfdir}/pki/tls/certs/make-dummy-cert
270%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
271%{_sysconfdir}/pki/tls/certs/Makefile
272%{_sysconfdir}/pki/tls/misc/CA
273%dir %{_sysconfdir}/pki/CA
274%dir %{_sysconfdir}/pki/CA/private
275%dir %{_sysconfdir}/pki/CA/certs
276%dir %{_sysconfdir}/pki/CA/crl
277%dir %{_sysconfdir}/pki/CA/newcerts
278%{_sysconfdir}/pki/tls/misc/c_*
279%dir %{_sysconfdir}/pki/tls
280%dir %{_sysconfdir}/pki/tls/certs
281%dir %{_sysconfdir}/pki/tls/misc
282%dir %{_sysconfdir}/pki/tls/private
283
284%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
285
286%attr(0755,root,root) %{_bindir}/openssl
287%attr(0755,root,root) /%{_lib}/*.so.*
288%attr(0755,root,root) %{_libdir}/openssl/engines/*.so
289%attr(0755,root,root) %dir %{_mandir}/man1*
290%attr(0644,root,root) %{_mandir}/man1*/*
291%attr(0755,root,root) %dir %{_mandir}/man5*
292%attr(0644,root,root) %{_mandir}/man5*/*
293%attr(0755,root,root) %dir %{_mandir}/man7*
294%attr(0644,root,root) %{_mandir}/man7*/*
295
296%files devel
297%defattr(-,root,root)
298%{_prefix}/include/openssl
299%exclude %{_libdir}/lib*.a
300%attr(0755,root,root) %{_libdir}/*.so
301%attr(0755,root,root) %dir %{_mandir}/man3*
302%attr(0644,root,root) %{_mandir}/man3*/*
303%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
304
305%files static
306%defattr(-,root,root)
307%attr(0644,root,root) %{_libdir}/*.a
308
309%files perl
310%defattr(-,root,root)
311%attr(0755,root,root) %{_bindir}/c_rehash
312%attr(0755,root,root) %dir %{_mandir}/man1*
313%attr(0644,root,root) %{_mandir}/man1*/*.pl*
314%{_sysconfdir}/pki/tls/misc/*.pl
315#%{_sysconfdir}/pki/tls/misc/tsget
316%doc apps/tsget
317
318## to build compat32 for x86_64 architecture support
319%if %{build_compat32}
320%files -n compat32-%{name}
321%defattr(-,root,root)
322%attr(0755,root,root) /%{_lib}/*.so.*
323
324%files -n compat32-%{name}-devel
325%defattr(-,root,root)
326%exclude %{_libdir}/lib*.a
327%attr(0755,root,root) %{_libdir}/*.so
328%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
329%endif
330
331%post -p /sbin/ldconfig
332
333%postun -p /sbin/ldconfig
334
335%post -n compat32-%{name} -p /sbin/ldconfig
336
337%postun -n compat32-%{name} -p /sbin/ldconfig
338
339%changelog
340* Mon May 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-4
341- add patch12 CVE-2014-0198
342
343* Mon Apr 21 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-3
344- add patch11 for fix CVE-2010-0098
345
346* Fri Mar 28 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-2
347- add patch10 for fix CVE-2014-0076
348
349* Tue Jan  7 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-1
350- new upstream release with security fix (CVE-2013-6450)
351
352* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0k-2
353- move root CA bundle to ca-certificates package
354
355* Wed Feb  6 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0k-1
356- new upstream release with security fix (CVE-2013-0166, 0169)
357
358* Sat May 12 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0j-1
359- new upstream release with security fix (CVE-2012-2333) 
360
361* Fri Apr 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0i-1
362- new upstream release with security fix (CVE-2012-2110)
363
364* Sat Mar 31 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0h-1
365- new upstream release with security fix (CVE-2012-0884)
366
367* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
368- new upstream release with security fix (CVE-2012-0050)
369
370* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
371- new upstream release with security fix
372  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
373
374* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
375- new upstream release with security fix (CVE-2011-3207, 3210)
376
377* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
378- rebuild with krb5-libs 1.8
379
380* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
381- new upstream release with security fix
382
383* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
384- use upstream openssl.pc instead of vine original one (SOURCE6)
385
386* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
387- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
388
389* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
390- add R: krb5-devel into devel pkg
391- add R: compat32-krb5-devel into compat32-devel pkg
392
393* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
394- new upstream release 1.0.0x
395- separate static libs into static package
396- change configure options
397- change so version 10
398- add tsget into perl package
399- update all patches
400
401* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
402- fix changelog typo...
403
404* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
405- new upstream release with security fix (CVE-2010-4180)
406
407* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
408- new upstream release with security fix (CVE-2010-3864)
409- drop patches included in new release
410- update patch4
411
412* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
413- add patch12 for fix CVE-2009-3555 (renegotiation)
414
415* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
416- add patch11 for fix CVE-2009-4355 (memory leak)
417
418* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
419- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
420
421* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
422- removed unnecessary %%if %{build_compat32} statements
423- removed lib*.a from devel package
424
425* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
426- new upstream release with security fix (CVE-2000-0590,0591,0789)
427
428* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
429- new upstream release with security fix (CVE-2008-5077)
430
431* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
432- new upstream release
433
434* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
435- new upstream release
436- new versioning policy
437
438* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
439- new upstream release
440- drop patch10,20 which is merged in upstream
441
442* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
443- add security patch in advance for CVE-2007-5135
444  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
445  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
446
447* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
448- add security patch for CVE-2007-3108
449  (http://openssl.org/news/patch-CVE-2007-3108.txt)
450
451* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
452- new upstream release
453
454* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
455- update (fix) openssl.pc <BTS:437>
456
457* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
458- new upstream release (with security fix)
459
460* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
461- new upstream release
462- add patch2 to use RPM_OPT macro
463
464* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
465- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
466
467* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
468- added compat32-* packages for x86_64 architecture support
469- added openssl-0.9.7i.Configure-compat32.patch
470- changed '/lib' to '/%{_lib}'
471
472* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
473- new upstream release
474
475* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
476- rebuild on VineSeed
477
478* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
479- added a security patch from Gentoo.
480  - Patch1: openssl-0.9.7c-tempfile.patch
481
482* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
483- sslarch for ppc was missing... added.
484
485* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
486- use sslarch=linux-alpha-gcc instead of alpha-gcc
487
488* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
489- new upstream version
490- clean up of spec file
491        -- removed old patches
492
493* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
494- new upstream release
495- SECURITY fix.
496  - http://www.openssl.org/news/secadv_20040317.txt
497
498* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
499- new upstream release
500- [Security fix]
501  - Vulnerabilities in ASN.1 parsing
502    http://www.openssl.org/news/secadv_20030930.txt
503- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
504
505* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
506- add openssl.pc for pkgconfig
507
508* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
509- New upstream version
510- dropped patch10, 11
511        -- merged upstream version
512
513* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
514- rebuild for VineSeed
515
516* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
517- [Security Fix]
518  - Timing-based attacks on RSA keys
519    http://www.openssl.org/news/secadv_20030317.txt
520  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
521    http://www.openssl.org/news/secadv_20030317.txt
522
523* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
524- new upstream release 0.9.6i
525- [Security Fix]
526- build for Vine Linux 2.6 errata
527
528* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
529- new upstream release 0.9.6h
530
531* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
532- new upstream release 0.9.6g
533
534* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
535- SECURITY: CAN-2002-0659 fixed
536  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
537    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
538    - update asn patch to fix accidental reversal of a logic check
539    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
540    - update asn patch to reduce chance that compiler optimization will remove
541      one of the added tests
542    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
543    - rebuild
544    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
545    - add patch to fix ASN.1 vulnerabilities
546
547* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
548- rename spec file name
549- SECURITY: CA-2002-23 fixed
550  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
551    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
552    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
553
554* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
555- added ${PATH} in LD_LIBRARY_PATH
556- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
557 
558* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
559- remove --no-<cipher>
560
561* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
562- add Patch10 for mipsel shared ( Configure )
563
564* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
565- build for Vine Linux
566- use openssl-engine-0.9.6b.tar.gz
567
568* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
569- update to 0.9.6b
570
571* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
572- move .so symlinks back to %%{_libdir}
573
574* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
575- move shared libraries to /lib (#38410)
576
577* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
578- switch to engine code base
579
580* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
581- add a script for creating dummy certificates
582- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
583
584* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
585- add s390x support
586
587* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
588- change two memcpy() calls to memmove()
589- don't define L_ENDIAN on alpha
590
591* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
592- make subpackages depend on the main package
593
594* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
595- adjust the hobble script to not disturb symlinks in include/ (fix from
596  Joe Orton)
597
598* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
599- drop the m2crypo patch we weren't using
600
601* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
602- configure using "shared" as well
603
604* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
605- update to 0.9.6a
606- use the build-shared target to build shared libraries
607- bump the soversion to 2 because we're no longer compatible with
608  our 0.9.5a packages or our 0.9.6 packages
609- drop the patch for making rsatest a no-op when rsa null support is used
610- put all man pages into <section>ssl instead of <section>
611- break the m2crypto modules into a separate package
612
613* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
614- use BN_LLONG on s390
615
616* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
617- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
618
619* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
620- move c_rehash to the perl subpackage, because it's a perl script now
621
622* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
623- update to 0.9.6
624- enable MD2
625- use the libcrypto.so and libssl.so targets to build shared libs with
626- bump the soversion to 1 because we're no longer compatible with any of
627  the various 0.9.5a packages circulating around, which provide lib*.so.0
628
629* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
630- change hobble-openssl for disabling MD2 again
631
632* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
633- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
634  bytes or so, causing EVP_DigestInit() to zero out stack variables in
635  apps built against a version of the library without it
636
637* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
638- disable some inline assembly, which on x86 is Pentium-specific
639- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
640
641* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
642- fix s390 patch
643
644* Fri Dec 8 2000 Than Ngo <than@redhat.com>
645- added support s390
646
647* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
648- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
649- add the CA.pl man page to the perl subpackage
650
651* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
652- always build with -mcpu=ev5 on alpha
653
654* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
655- add a symlink from cert.pem to ca-bundle.crt
656
657* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
658- add a ca-bundle file for packages like Samba to reference for CA certificates
659
660* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
661- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
662
663* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
664- add unzip as a buildprereq (#17662)
665- update m2crypto to 0.05-snap4
666
667* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
668- fix some issues in building when it's not installed
669
670* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
671- make sure the headers we include are the ones we built with (aaaaarrgh!)
672
673* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
674- add Richard Henderson's patch for BN on ia64
675- clean up the changelog
676
677* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
678- fix the building of python modules without openssl-devel already installed
679
680* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
681- byte-compile python extensions without the build-root
682- adjust the makefile to not remove temporary files (like .key files when
683  building .csr files) by marking them as .PRECIOUS
684
685* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
686- break out python extensions into a subpackage
687
688* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
689- tweak the makefile some more
690
691* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
692- disable MD2 support
693
694* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
695- disable MDC2 support
696
697* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
698- tweak the disabling of RC5, IDEA support
699- tweak the makefile
700
701* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
702- strip binaries and libraries
703- rework certificate makefile to have the right parts for Apache
704
705* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
706- use %%{_perl} instead of /usr/bin/perl
707- disable alpha until it passes its own test suite
708
709* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
710- move the passwd.1 man page out of the passwd package's way
711
712* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
713- update to 0.9.5a, modified for U.S.
714- add perl as a build-time requirement
715- move certificate makefile to another package
716- disable RC5, IDEA, RSA support
717- remove optimizations for now
718
719* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
720- Bero told me to move the Makefile into this package
721
722* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
723- add lib*.so symlinks to link dynamically against shared libs
724
725* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
726- update to 0.9.5
727- run ldconfig directly in post/postun
728- add FAQ
729
730* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
731- Fix build on non-x86 platforms
732
733* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
734- move /usr/share/ssl/* from -devel to main package
735
736* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
737- inital packaging
738- changes from base:
739  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
740  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.