source: projects/specs/branches/6/o/openssl/openssl-vl.spec @ 11231

Revision 11231, 27.7 KB checked in by iwamoto, 6 years ago (diff)

openssl: CVE-2016-7056,CVE-2016-8610,CVE-2017-3731,CVE-2017-3735

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 10
3%define version 1.0.1u
4%define release 4%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl
8Version: %{version}
9Release: %{release}
10
11Source: openssl-%{version}.tar.gz
12Source2: Makefile.certificate
13Source6: make-dummy-cert
14Source7: renew-dummy-cert
15
16Patch0: openssl-1.0.0-soversion.patch
17Patch2: openssl-1.0.1-rpm_opt.patch
18Patch4: openssl-1.0.0-enginesdir.patch
19Patch5: openssl-1.0.1m-version-add-engines.patch
20Patch8: openssl-1.0.1c-perlfind.patch
21
22# woakaround against the time bomb
23# Patch500: update-expired-smime-test-certs.patch
24
25# security fix
26Patch1000: CVE-2016-7056.patch
27Patch1001: CVE-2016-8610.patch
28Patch1010: CVE-2017-3731.patch
29Patch1011: CVE-2017-3735.patch
30
31License: BSDish
32Group: System Environment/Libraries
33URL: http://www.openssl.org/
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35BuildRequires: perl, sed
36BuildRequires: zlib-devel, krb5-devel
37Requires: mktemp
38Requires: ca-certificates
39
40Packager: daisuke
41Vendor: Project Vine
42Distribution: Vine Linux
43
44%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
45
46%description
47The OpenSSL certificate management tool and the shared libraries that
48provide various cryptographic algorithms and protocols.
49
50%package devel
51Summary: OpenSSL libraries and development headers.
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54Requires: krb5-devel
55
56%description devel
57The static libraries and include files needed to compile apps
58with support for various the cryptographic algorithms and protocols
59supported by OpenSSL.
60
61Patches for many networking apps can be found at:
62ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
63
64%package static
65Summary:  Libraries for static linking of applications which will use OpenSSL
66Group: Development/Libraries
67Requires: %{name}-devel = %{version}-%{release}
68
69%description static
70OpenSSL is a toolkit for supporting cryptography. The openssl-static
71package contains static libraries needed for static linking of
72applications which support various cryptographic algorithms and
73protocols.
74
75%package perl
76Summary: OpenSSL scripts which require Perl.
77Group: Applications/Internet
78Requires: perl
79Requires: %{name} = %{version}-%{release}
80
81%description perl
82Perl scripts provided with OpenSSL for converting certificates and keys
83from other formats to those used by OpenSSL.
84
85## to build compat32 for x86_64 architecture support
86%package -n compat32-%{name}
87Summary: Secure Sockets Layer Toolkit
88Group: System Environment/Libraries
89Requires: %{name} = %{version}-%{release}
90%description -n compat32-%{name}
91The OpenSSL certificate management tool and the shared libraries that
92provide various cryptographic algorithms and protocols.
93
94%package -n compat32-%{name}-devel
95Summary: OpenSSL libraries and development headers.
96Group: Development/Libraries
97Requires: compat32-%{name} = %{version}-%{release}
98Requires: compat32-krb5-devel
99%description -n compat32-%{name}-devel
100The static libraries and include files needed to compile apps
101with support for various the cryptographic algorithms and protocols
102supported by OpenSSL.
103
104%prep
105%setup -q -n openssl-%{version}
106%patch0 -p1 -b .soversion
107%patch2 -p1 -b .rpm_opt
108%patch4 -p1 -b .enginesdir
109%patch5 -p1 -b .version-add-engines
110%patch8 -p1 -b .perlfind
111
112# %patch500 -p1 -b .expired-certificates
113
114# security fix
115%patch1000 -p1 -b .CVE-2016-7056
116%patch1001 -p1 -b .CVE-2016-8610
117%patch1010 -p1 -b .CVE-2017-3731
118%patch1011 -p1 -b .CVE-2017-3735
119
120chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
121chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
122chmod 644 doc/openssl_button.html doc/openssl_button.gif
123chmod 644 doc/ssleay.txt
124
125# Link the configuration header to the one we're going to make.
126# ln -sf ../../crypto/opensslconf.h include/openssl/
127
128%build
129PATH=${PATH}:${PWD}/bin
130TOPDIR=${PWD}
131LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
132
133# Modify the various perl scripts to reference perl in the right location.
134perl util/perlpath.pl `dirname %{__perl}`
135
136# Generate a table with the compile settings for my perusal.
137touch Makefile
138make TABLE PERL=%{__perl}
139
140# Figure out which flags we want to use.
141# default
142sslarch=%{_os}-%{_target_cpu}
143#
144%ifarch %ix86
145sslarch=linux-elf
146if ! echo %{_target} | grep -q i686 ; then
147   sslflags="no-asm 386"
148fi
149%endif
150%ifarch sparcv9
151sslarch=linux-sparcv9
152sslflags=no-asm
153%endif
154%ifarch sparc64
155sslarch=linux64-sparcv9
156sslflags=no-asm
157%endif
158%ifarch alpha alphaev56 alphaev6 alphaev67
159sslarch=linux-alpha-gcc
160%endif
161%ifarch s390 sh3eb sh4eb
162sslarch="linux-generic32 -DB_ENDIAN"
163%endif
164%ifarch s390x
165sslarch="linux64-s390x"
166%endif
167%ifarch %{arm} sh3 sh4
168sslarch=linux-generic32
169%endif
170# ia64/x86_64/ppc\ppc64 are OK by default.
171
172# Configure the build tree.  Override OpenSSL defaults with known-good defaults
173# usable on all platforms.  The Configure script already knows to use -fPIC and
174# RPM_OPT_FLAGS, so we can skip specifiying them here.
175./Configure  \
176         --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
177         zlib-dynamic enable-camellia enable-seed enable-tlsext \
178         enable-rfc3779 enable-cms enable-md2 \
179         --enginesdir=%{_libdir}/openssl/engines \
180         --with-krb5-flavor=MIT --with-krb5-dir=/usr \
181         shared ${sslarch}
182
183# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
184# marked as not requiring an executable stack.
185RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
186make depend
187make all build-shared
188
189# Generate hashes for the included certs.
190LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
191export LD_LIBRARY_PATH
192make rehash build-shared
193
194# Verify that what was compiled actually works.
195make -C test apps tests
196
197# Relink the main binary to get it dynamically linked.
198rm apps/openssl
199make all build-shared
200
201%install
202[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
203# Install OpenSSL.
204install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
205make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
206install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
207# added for lib64
208# mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
209mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
210# mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
211mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
212mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man/* $RPM_BUILD_ROOT%{_mandir}
213rmdir $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man
214rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
215for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
216        chmod 755 ${lib}
217        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
218        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
219done
220# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
221
222# Install a makefile for generating keys and self-signed certs, and a script
223# for generating them on the fly.
224mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
225install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/Makefile
226install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/make-dummy-cert
227install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
228
229# Make sure we actually include the headers we built against.
230for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
231        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
232                install -m644 include/openssl/`basename ${header}` ${header}
233        fi
234done
235
236# Rename man pages so that they don't conflict with system man pages.  We used
237# to change the file extensions, but that only prevents file conflicts.  The
238# man viewer still can't select either of the two unless we physically change
239# the directory.
240for section in 1 2 3 4 5 6 7 8 ; do
241        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
242                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
243                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
244        fi
245done
246
247# Pick a CA script.
248pushd  $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc
249mv CA.sh CA
250popd
251
252mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
253mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
254mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
255mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
256mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
257
258# Ensure the openssl.cnf timestamp is identical across builds to avoid
259# mulitlib conflicts and unnecessary renames on upgrade
260touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
261
262%clean
263[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
264
265%files
266%defattr(-,root,root)
267%doc FAQ LICENSE CHANGES NEWS INSTALL README
268%doc doc/README doc/c-indentation.el doc/openssl.txt
269%doc doc/openssl_button.html doc/openssl_button.gif
270%doc doc/ssleay.txt
271
272%{_sysconfdir}/pki/tls/certs/make-dummy-cert
273%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
274%{_sysconfdir}/pki/tls/certs/Makefile
275%{_sysconfdir}/pki/tls/misc/CA
276%dir %{_sysconfdir}/pki/CA
277%dir %{_sysconfdir}/pki/CA/private
278%dir %{_sysconfdir}/pki/CA/certs
279%dir %{_sysconfdir}/pki/CA/crl
280%dir %{_sysconfdir}/pki/CA/newcerts
281%{_sysconfdir}/pki/tls/misc/c_*
282%dir %{_sysconfdir}/pki/tls
283%dir %{_sysconfdir}/pki/tls/certs
284%dir %{_sysconfdir}/pki/tls/misc
285%dir %{_sysconfdir}/pki/tls/private
286%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
287
288%attr(0755,root,root) %{_bindir}/openssl
289%attr(0755,root,root) /%{_lib}/*.so.*
290%attr(0755,root,root) %{_libdir}/openssl/engines/*.so
291%attr(0755,root,root) %dir %{_mandir}/man1*
292%attr(0644,root,root) %{_mandir}/man1*/*
293%attr(0755,root,root) %dir %{_mandir}/man5*
294%attr(0644,root,root) %{_mandir}/man5*/*
295%attr(0755,root,root) %dir %{_mandir}/man7*
296%attr(0644,root,root) %{_mandir}/man7*/*
297
298%files devel
299%defattr(-,root,root)
300%{_prefix}/include/openssl
301%exclude %{_libdir}/lib*.a
302%attr(0755,root,root) %{_libdir}/*.so
303%attr(0755,root,root) %dir %{_mandir}/man3*
304%attr(0644,root,root) %{_mandir}/man3*/*
305%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
306
307%files static
308%defattr(-,root,root)
309%attr(0644,root,root) %{_libdir}/*.a
310
311%files perl
312%defattr(-,root,root)
313%attr(0755,root,root) %{_bindir}/c_rehash
314%attr(0755,root,root) %dir %{_mandir}/man1*
315%attr(0644,root,root) %{_mandir}/man1*/*.pl*
316%{_sysconfdir}/pki/tls/misc/*.pl
317#%{_sysconfdir}/pki/tls/misc/tsget
318%doc apps/tsget
319
320## to build compat32 for x86_64 architecture support
321%if %{build_compat32}
322%files -n compat32-%{name}
323%defattr(-,root,root)
324%attr(0755,root,root) /%{_lib}/*.so.*
325
326%files -n compat32-%{name}-devel
327%defattr(-,root,root)
328%exclude %{_libdir}/lib*.a
329%attr(0755,root,root) %{_libdir}/*.so
330%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
331%endif
332
333%post -p /sbin/ldconfig
334
335%postun -p /sbin/ldconfig
336
337%post -n compat32-%{name} -p /sbin/ldconfig
338
339%postun -n compat32-%{name} -p /sbin/ldconfig
340
341%changelog
342* Mon Nov 13 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1u-4
343- add patch1000,1001,1010,1011
344  (CVE-2016-7056,CVE-2016-8610,CVE-2017-3731,CVE-2017-3735)
345- 1.0.1u-3 was skipped (used internal)
346
347* Fri Oct 14 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1u-2
348- rebuilt with Vine6.3 environment (w/o p-u)
349
350* Sun Sep 25 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1u-1
351- new upstream release with security fixes
352- drop Patch500, Patch1000-1003 (are included in new release)
353
354* Mon Aug  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1t-3
355- added Patch1003 to fix CVE-2016-2180.
356
357* Sun Jul 31 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1t-2
358- added Patch500 to renew the expired certificates for test.
359- added Patch1000-1002 to fix vulnerabilities.
360  - CVE-2016-2177
361  - CVE-2016-2178
362
363* Wed May  4 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1t-1
364- new upstream release with security fixes
365
366* Wed Mar  2 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1s-1
367- new upstream release with security fixes
368
369* Fri Jan 29 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1r-1
370- new upstream release with security fixes 
371
372* Fri Dec  4 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1q-1
373- new upstream release with security fixes
374
375* Fri Jul 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1p-1
376- new upstream release with security fixes
377
378* Mon Jun 15 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1o-1
379- new upstream release with security fixes 
380
381* Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1m-1
382- new upstream release with security fixes 
383- update Patch2,5
384
385* Wed Feb 11 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1l-1
386- rebuild for VineLinux 6.x
387
388* Sun Feb  8 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1l-0.1
389- test package for VineLinux 6.x
390
391* Sat Jan 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0p-1
392- new upstream release with security fixes 
393
394* Sun Oct 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0o-1
395- new upstream release with security fixes (CVE-2014-3566,3567,3568)
396
397* Thu Aug  7 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0n-1
398- new upstream release with security fixes
399
400* Thu Jun  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0m-1
401- new upstream release with security fixes
402- drop patch10-12 (are included in new release)
403
404* Mon May 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-4
405- add patch12 CVE-2014-0198
406
407* Mon Apr 21 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-3
408- add patch11 for fix CVE-2010-0098
409
410* Fri Mar 28 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-2
411- add patch10 for fix CVE-2014-0076
412
413* Tue Jan  7 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-1
414- new upstream release with security fix (CVE-2013-6450)
415
416* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0k-2
417- move root CA bundle to ca-certificates package
418
419* Wed Feb  6 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0k-1
420- new upstream release with security fix (CVE-2013-0166, 0169)
421
422* Sat May 12 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0j-1
423- new upstream release with security fix (CVE-2012-2333) 
424
425* Fri Apr 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0i-1
426- new upstream release with security fix (CVE-2012-2110)
427
428* Sat Mar 31 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0h-1
429- new upstream release with security fix (CVE-2012-0884)
430
431* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
432- new upstream release with security fix (CVE-2012-0050)
433
434* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
435- new upstream release with security fix
436  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
437
438* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
439- new upstream release with security fix (CVE-2011-3207, 3210)
440
441* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
442- rebuild with krb5-libs 1.8
443
444* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
445- new upstream release with security fix
446
447* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
448- use upstream openssl.pc instead of vine original one (SOURCE6)
449
450* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
451- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
452
453* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
454- add R: krb5-devel into devel pkg
455- add R: compat32-krb5-devel into compat32-devel pkg
456
457* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
458- new upstream release 1.0.0x
459- separate static libs into static package
460- change configure options
461- change so version 10
462- add tsget into perl package
463- update all patches
464
465* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
466- fix changelog typo...
467
468* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
469- new upstream release with security fix (CVE-2010-4180)
470
471* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
472- new upstream release with security fix (CVE-2010-3864)
473- drop patches included in new release
474- update patch4
475
476* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
477- add patch12 for fix CVE-2009-3555 (renegotiation)
478
479* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
480- add patch11 for fix CVE-2009-4355 (memory leak)
481
482* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
483- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
484
485* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
486- removed unnecessary %%if %{build_compat32} statements
487- removed lib*.a from devel package
488
489* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
490- new upstream release with security fix (CVE-2000-0590,0591,0789)
491
492* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
493- new upstream release with security fix (CVE-2008-5077)
494
495* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
496- new upstream release
497
498* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
499- new upstream release
500- new versioning policy
501
502* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
503- new upstream release
504- drop patch10,20 which is merged in upstream
505
506* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
507- add security patch in advance for CVE-2007-5135
508  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
509  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
510
511* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
512- add security patch for CVE-2007-3108
513  (http://openssl.org/news/patch-CVE-2007-3108.txt)
514
515* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
516- new upstream release
517
518* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
519- update (fix) openssl.pc <BTS:437>
520
521* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
522- new upstream release (with security fix)
523
524* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
525- new upstream release
526- add patch2 to use RPM_OPT macro
527
528* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
529- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
530
531* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
532- added compat32-* packages for x86_64 architecture support
533- added openssl-0.9.7i.Configure-compat32.patch
534- changed '/lib' to '/%{_lib}'
535
536* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
537- new upstream release
538
539* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
540- rebuild on VineSeed
541
542* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
543- added a security patch from Gentoo.
544  - Patch1: openssl-0.9.7c-tempfile.patch
545
546* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
547- sslarch for ppc was missing... added.
548
549* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
550- use sslarch=linux-alpha-gcc instead of alpha-gcc
551
552* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
553- new upstream version
554- clean up of spec file
555        -- removed old patches
556
557* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
558- new upstream release
559- SECURITY fix.
560  - http://www.openssl.org/news/secadv_20040317.txt
561
562* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
563- new upstream release
564- [Security fix]
565  - Vulnerabilities in ASN.1 parsing
566    http://www.openssl.org/news/secadv_20030930.txt
567- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
568
569* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
570- add openssl.pc for pkgconfig
571
572* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
573- New upstream version
574- dropped patch10, 11
575        -- merged upstream version
576
577* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
578- rebuild for VineSeed
579
580* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
581- [Security Fix]
582  - Timing-based attacks on RSA keys
583    http://www.openssl.org/news/secadv_20030317.txt
584  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
585    http://www.openssl.org/news/secadv_20030317.txt
586
587* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
588- new upstream release 0.9.6i
589- [Security Fix]
590- build for Vine Linux 2.6 errata
591
592* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
593- new upstream release 0.9.6h
594
595* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
596- new upstream release 0.9.6g
597
598* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
599- SECURITY: CAN-2002-0659 fixed
600  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
601    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
602    - update asn patch to fix accidental reversal of a logic check
603    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
604    - update asn patch to reduce chance that compiler optimization will remove
605      one of the added tests
606    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
607    - rebuild
608    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
609    - add patch to fix ASN.1 vulnerabilities
610
611* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
612- rename spec file name
613- SECURITY: CA-2002-23 fixed
614  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
615    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
616    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
617
618* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
619- added ${PATH} in LD_LIBRARY_PATH
620- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
621 
622* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
623- remove --no-<cipher>
624
625* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
626- add Patch10 for mipsel shared ( Configure )
627
628* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
629- build for Vine Linux
630- use openssl-engine-0.9.6b.tar.gz
631
632* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
633- update to 0.9.6b
634
635* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
636- move .so symlinks back to %%{_libdir}
637
638* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
639- move shared libraries to /lib (#38410)
640
641* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
642- switch to engine code base
643
644* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
645- add a script for creating dummy certificates
646- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
647
648* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
649- add s390x support
650
651* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
652- change two memcpy() calls to memmove()
653- don't define L_ENDIAN on alpha
654
655* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
656- make subpackages depend on the main package
657
658* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
659- adjust the hobble script to not disturb symlinks in include/ (fix from
660  Joe Orton)
661
662* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
663- drop the m2crypo patch we weren't using
664
665* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
666- configure using "shared" as well
667
668* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
669- update to 0.9.6a
670- use the build-shared target to build shared libraries
671- bump the soversion to 2 because we're no longer compatible with
672  our 0.9.5a packages or our 0.9.6 packages
673- drop the patch for making rsatest a no-op when rsa null support is used
674- put all man pages into <section>ssl instead of <section>
675- break the m2crypto modules into a separate package
676
677* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
678- use BN_LLONG on s390
679
680* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
681- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
682
683* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
684- move c_rehash to the perl subpackage, because it's a perl script now
685
686* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
687- update to 0.9.6
688- enable MD2
689- use the libcrypto.so and libssl.so targets to build shared libs with
690- bump the soversion to 1 because we're no longer compatible with any of
691  the various 0.9.5a packages circulating around, which provide lib*.so.0
692
693* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
694- change hobble-openssl for disabling MD2 again
695
696* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
697- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
698  bytes or so, causing EVP_DigestInit() to zero out stack variables in
699  apps built against a version of the library without it
700
701* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
702- disable some inline assembly, which on x86 is Pentium-specific
703- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
704
705* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
706- fix s390 patch
707
708* Fri Dec 8 2000 Than Ngo <than@redhat.com>
709- added support s390
710
711* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
712- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
713- add the CA.pl man page to the perl subpackage
714
715* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
716- always build with -mcpu=ev5 on alpha
717
718* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
719- add a symlink from cert.pem to ca-bundle.crt
720
721* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
722- add a ca-bundle file for packages like Samba to reference for CA certificates
723
724* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
725- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
726
727* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
728- add unzip as a buildprereq (#17662)
729- update m2crypto to 0.05-snap4
730
731* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
732- fix some issues in building when it's not installed
733
734* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
735- make sure the headers we include are the ones we built with (aaaaarrgh!)
736
737* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
738- add Richard Henderson's patch for BN on ia64
739- clean up the changelog
740
741* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
742- fix the building of python modules without openssl-devel already installed
743
744* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
745- byte-compile python extensions without the build-root
746- adjust the makefile to not remove temporary files (like .key files when
747  building .csr files) by marking them as .PRECIOUS
748
749* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
750- break out python extensions into a subpackage
751
752* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
753- tweak the makefile some more
754
755* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
756- disable MD2 support
757
758* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
759- disable MDC2 support
760
761* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
762- tweak the disabling of RC5, IDEA support
763- tweak the makefile
764
765* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
766- strip binaries and libraries
767- rework certificate makefile to have the right parts for Apache
768
769* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
770- use %%{_perl} instead of /usr/bin/perl
771- disable alpha until it passes its own test suite
772
773* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
774- move the passwd.1 man page out of the passwd package's way
775
776* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
777- update to 0.9.5a, modified for U.S.
778- add perl as a build-time requirement
779- move certificate makefile to another package
780- disable RC5, IDEA, RSA support
781- remove optimizations for now
782
783* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
784- Bero told me to move the Makefile into this package
785
786* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
787- add lib*.so symlinks to link dynamically against shared libs
788
789* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
790- update to 0.9.5
791- run ldconfig directly in post/postun
792- add FAQ
793
794* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
795- Fix build on non-x86 platforms
796
797* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
798- move /usr/share/ssl/* from -devel to main package
799
800* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
801- inital packaging
802- changes from base:
803  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
804  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.