source: projects/specs/branches/6/o/openssl/openssl-vl.spec @ 10723

Revision 10723, 27.0 KB checked in by tomop, 8 years ago (diff)

openssl-1.0.1t-2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 10
3%define version 1.0.1t
4%define release 2%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl
8Version: %{version}
9Release: %{release}
10
11Source: openssl-%{version}.tar.gz
12Source2: Makefile.certificate
13Source6: make-dummy-cert
14Source7: renew-dummy-cert
15
16Patch0: openssl-1.0.0-soversion.patch
17Patch2: openssl-1.0.1-rpm_opt.patch
18Patch4: openssl-1.0.0-enginesdir.patch
19Patch5: openssl-1.0.1m-version-add-engines.patch
20Patch8: openssl-1.0.1c-perlfind.patch
21
22# woakaround against the time bomb
23Patch500: update-expired-smime-test-certs.patch
24
25# security fix
26Patch1000: CVE-2016-2177.patch
27Patch1001: CVE-2016-2178-1.patch
28Patch1002: CVE-2016-2178-2.patch
29
30License: BSDish
31Group: System Environment/Libraries
32URL: http://www.openssl.org/
33BuildRoot: %{_tmppath}/%{name}-%{version}-root
34BuildRequires: perl, sed
35BuildRequires: zlib-devel, krb5-devel
36Requires: mktemp
37Requires: ca-certificates
38
39Packager: daisuke
40Vendor: Project Vine
41Distribution: Vine Linux
42
43%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
44
45%description
46The OpenSSL certificate management tool and the shared libraries that
47provide various cryptographic algorithms and protocols.
48
49%package devel
50Summary: OpenSSL libraries and development headers.
51Group: Development/Libraries
52Requires: %{name} = %{version}-%{release}
53Requires: krb5-devel
54
55%description devel
56The static libraries and include files needed to compile apps
57with support for various the cryptographic algorithms and protocols
58supported by OpenSSL.
59
60Patches for many networking apps can be found at:
61ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
62
63%package static
64Summary:  Libraries for static linking of applications which will use OpenSSL
65Group: Development/Libraries
66Requires: %{name}-devel = %{version}-%{release}
67
68%description static
69OpenSSL is a toolkit for supporting cryptography. The openssl-static
70package contains static libraries needed for static linking of
71applications which support various cryptographic algorithms and
72protocols.
73
74%package perl
75Summary: OpenSSL scripts which require Perl.
76Group: Applications/Internet
77Requires: perl
78Requires: %{name} = %{version}-%{release}
79
80%description perl
81Perl scripts provided with OpenSSL for converting certificates and keys
82from other formats to those used by OpenSSL.
83
84## to build compat32 for x86_64 architecture support
85%package -n compat32-%{name}
86Summary: Secure Sockets Layer Toolkit
87Group: System Environment/Libraries
88Requires: %{name} = %{version}-%{release}
89%description -n compat32-%{name}
90The OpenSSL certificate management tool and the shared libraries that
91provide various cryptographic algorithms and protocols.
92
93%package -n compat32-%{name}-devel
94Summary: OpenSSL libraries and development headers.
95Group: Development/Libraries
96Requires: compat32-%{name} = %{version}-%{release}
97Requires: compat32-krb5-devel
98%description -n compat32-%{name}-devel
99The static libraries and include files needed to compile apps
100with support for various the cryptographic algorithms and protocols
101supported by OpenSSL.
102
103%prep
104%setup -q -n openssl-%{version}
105%patch0 -p1 -b .soversion
106%patch2 -p1 -b .rpm_opt
107%patch4 -p1 -b .enginesdir
108%patch5 -p1 -b .version-add-engines
109%patch8 -p1 -b .perlfind
110
111%patch500 -p1 -b .expired-certificates
112
113# security fix
114%patch1000 -p1 -b .CVE-2016-2177
115%patch1001 -p1 -b .CVE-2016-2178-1
116%patch1002 -p1 -b .CVE-2016-2178-2
117
118chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
119chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
120chmod 644 doc/openssl_button.html doc/openssl_button.gif
121chmod 644 doc/ssleay.txt
122
123# Link the configuration header to the one we're going to make.
124# ln -sf ../../crypto/opensslconf.h include/openssl/
125
126%build
127PATH=${PATH}:${PWD}/bin
128TOPDIR=${PWD}
129LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
130
131# Modify the various perl scripts to reference perl in the right location.
132perl util/perlpath.pl `dirname %{__perl}`
133
134# Generate a table with the compile settings for my perusal.
135touch Makefile
136make TABLE PERL=%{__perl}
137
138# Figure out which flags we want to use.
139# default
140sslarch=%{_os}-%{_target_cpu}
141#
142%ifarch %ix86
143sslarch=linux-elf
144if ! echo %{_target} | grep -q i686 ; then
145   sslflags="no-asm 386"
146fi
147%endif
148%ifarch sparcv9
149sslarch=linux-sparcv9
150sslflags=no-asm
151%endif
152%ifarch sparc64
153sslarch=linux64-sparcv9
154sslflags=no-asm
155%endif
156%ifarch alpha alphaev56 alphaev6 alphaev67
157sslarch=linux-alpha-gcc
158%endif
159%ifarch s390 sh3eb sh4eb
160sslarch="linux-generic32 -DB_ENDIAN"
161%endif
162%ifarch s390x
163sslarch="linux64-s390x"
164%endif
165%ifarch %{arm} sh3 sh4
166sslarch=linux-generic32
167%endif
168# ia64/x86_64/ppc\ppc64 are OK by default.
169
170# Configure the build tree.  Override OpenSSL defaults with known-good defaults
171# usable on all platforms.  The Configure script already knows to use -fPIC and
172# RPM_OPT_FLAGS, so we can skip specifiying them here.
173./Configure  \
174         --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
175         zlib-dynamic enable-camellia enable-seed enable-tlsext \
176         enable-rfc3779 enable-cms enable-md2 \
177         --enginesdir=%{_libdir}/openssl/engines \
178         --with-krb5-flavor=MIT --with-krb5-dir=/usr \
179         shared ${sslarch}
180
181# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
182# marked as not requiring an executable stack.
183RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
184make depend
185make all build-shared
186
187# Generate hashes for the included certs.
188LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
189export LD_LIBRARY_PATH
190make rehash build-shared
191
192# Verify that what was compiled actually works.
193make -C test apps tests
194
195# Relink the main binary to get it dynamically linked.
196rm apps/openssl
197make all build-shared
198
199%install
200[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
201# Install OpenSSL.
202install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
203make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
204install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
205# added for lib64
206# mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
207mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
208# mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
209mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
210mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man/* $RPM_BUILD_ROOT%{_mandir}
211rmdir $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man
212rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
213for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
214        chmod 755 ${lib}
215        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
216        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
217done
218# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
219
220# Install a makefile for generating keys and self-signed certs, and a script
221# for generating them on the fly.
222mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
223install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/Makefile
224install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/make-dummy-cert
225install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
226
227# Make sure we actually include the headers we built against.
228for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
229        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
230                install -m644 include/openssl/`basename ${header}` ${header}
231        fi
232done
233
234# Rename man pages so that they don't conflict with system man pages.  We used
235# to change the file extensions, but that only prevents file conflicts.  The
236# man viewer still can't select either of the two unless we physically change
237# the directory.
238for section in 1 2 3 4 5 6 7 8 ; do
239        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
240                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
241                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
242        fi
243done
244
245# Pick a CA script.
246pushd  $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc
247mv CA.sh CA
248popd
249
250mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
251mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
252mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
253mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
254mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
255
256# Ensure the openssl.cnf timestamp is identical across builds to avoid
257# mulitlib conflicts and unnecessary renames on upgrade
258touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
259
260%clean
261[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
262
263%files
264%defattr(-,root,root)
265%doc FAQ LICENSE CHANGES NEWS INSTALL README
266%doc doc/README doc/c-indentation.el doc/openssl.txt
267%doc doc/openssl_button.html doc/openssl_button.gif
268%doc doc/ssleay.txt
269
270%{_sysconfdir}/pki/tls/certs/make-dummy-cert
271%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
272%{_sysconfdir}/pki/tls/certs/Makefile
273%{_sysconfdir}/pki/tls/misc/CA
274%dir %{_sysconfdir}/pki/CA
275%dir %{_sysconfdir}/pki/CA/private
276%dir %{_sysconfdir}/pki/CA/certs
277%dir %{_sysconfdir}/pki/CA/crl
278%dir %{_sysconfdir}/pki/CA/newcerts
279%{_sysconfdir}/pki/tls/misc/c_*
280%dir %{_sysconfdir}/pki/tls
281%dir %{_sysconfdir}/pki/tls/certs
282%dir %{_sysconfdir}/pki/tls/misc
283%dir %{_sysconfdir}/pki/tls/private
284%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
285
286%attr(0755,root,root) %{_bindir}/openssl
287%attr(0755,root,root) /%{_lib}/*.so.*
288%attr(0755,root,root) %{_libdir}/openssl/engines/*.so
289%attr(0755,root,root) %dir %{_mandir}/man1*
290%attr(0644,root,root) %{_mandir}/man1*/*
291%attr(0755,root,root) %dir %{_mandir}/man5*
292%attr(0644,root,root) %{_mandir}/man5*/*
293%attr(0755,root,root) %dir %{_mandir}/man7*
294%attr(0644,root,root) %{_mandir}/man7*/*
295
296%files devel
297%defattr(-,root,root)
298%{_prefix}/include/openssl
299%exclude %{_libdir}/lib*.a
300%attr(0755,root,root) %{_libdir}/*.so
301%attr(0755,root,root) %dir %{_mandir}/man3*
302%attr(0644,root,root) %{_mandir}/man3*/*
303%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
304
305%files static
306%defattr(-,root,root)
307%attr(0644,root,root) %{_libdir}/*.a
308
309%files perl
310%defattr(-,root,root)
311%attr(0755,root,root) %{_bindir}/c_rehash
312%attr(0755,root,root) %dir %{_mandir}/man1*
313%attr(0644,root,root) %{_mandir}/man1*/*.pl*
314%{_sysconfdir}/pki/tls/misc/*.pl
315#%{_sysconfdir}/pki/tls/misc/tsget
316%doc apps/tsget
317
318## to build compat32 for x86_64 architecture support
319%if %{build_compat32}
320%files -n compat32-%{name}
321%defattr(-,root,root)
322%attr(0755,root,root) /%{_lib}/*.so.*
323
324%files -n compat32-%{name}-devel
325%defattr(-,root,root)
326%exclude %{_libdir}/lib*.a
327%attr(0755,root,root) %{_libdir}/*.so
328%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
329%endif
330
331%post -p /sbin/ldconfig
332
333%postun -p /sbin/ldconfig
334
335%post -n compat32-%{name} -p /sbin/ldconfig
336
337%postun -n compat32-%{name} -p /sbin/ldconfig
338
339%changelog
340* Sun Jul 31 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1t-2
341- added Patch500 to renew the expired certificates for test.
342- added Patch1000-1002 to fix vulnerabilities.
343  - CVE-2016-2177
344  - CVE-2016-2178
345
346* Wed May  4 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1t-1
347- new upstream release with security fixes
348
349* Wed Mar  2 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1s-1
350- new upstream release with security fixes
351
352* Fri Jan 29 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1r-1
353- new upstream release with security fixes 
354
355* Fri Dec  4 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1q-1
356- new upstream release with security fixes
357
358* Fri Jul 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1p-1
359- new upstream release with security fixes
360
361* Mon Jun 15 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1o-1
362- new upstream release with security fixes 
363
364* Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1m-1
365- new upstream release with security fixes 
366- update Patch2,5
367
368* Wed Feb 11 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1l-1
369- rebuild for VineLinux 6.x
370
371* Sun Feb  8 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1l-0.1
372- test package for VineLinux 6.x
373
374* Sat Jan 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0p-1
375- new upstream release with security fixes 
376
377* Sun Oct 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0o-1
378- new upstream release with security fixes (CVE-2014-3566,3567,3568)
379
380* Thu Aug  7 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0n-1
381- new upstream release with security fixes
382
383* Thu Jun  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0m-1
384- new upstream release with security fixes
385- drop patch10-12 (are included in new release)
386
387* Mon May 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-4
388- add patch12 CVE-2014-0198
389
390* Mon Apr 21 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-3
391- add patch11 for fix CVE-2010-0098
392
393* Fri Mar 28 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-2
394- add patch10 for fix CVE-2014-0076
395
396* Tue Jan  7 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-1
397- new upstream release with security fix (CVE-2013-6450)
398
399* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0k-2
400- move root CA bundle to ca-certificates package
401
402* Wed Feb  6 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0k-1
403- new upstream release with security fix (CVE-2013-0166, 0169)
404
405* Sat May 12 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0j-1
406- new upstream release with security fix (CVE-2012-2333) 
407
408* Fri Apr 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0i-1
409- new upstream release with security fix (CVE-2012-2110)
410
411* Sat Mar 31 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0h-1
412- new upstream release with security fix (CVE-2012-0884)
413
414* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
415- new upstream release with security fix (CVE-2012-0050)
416
417* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
418- new upstream release with security fix
419  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
420
421* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
422- new upstream release with security fix (CVE-2011-3207, 3210)
423
424* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
425- rebuild with krb5-libs 1.8
426
427* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
428- new upstream release with security fix
429
430* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
431- use upstream openssl.pc instead of vine original one (SOURCE6)
432
433* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
434- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
435
436* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
437- add R: krb5-devel into devel pkg
438- add R: compat32-krb5-devel into compat32-devel pkg
439
440* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
441- new upstream release 1.0.0x
442- separate static libs into static package
443- change configure options
444- change so version 10
445- add tsget into perl package
446- update all patches
447
448* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
449- fix changelog typo...
450
451* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
452- new upstream release with security fix (CVE-2010-4180)
453
454* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
455- new upstream release with security fix (CVE-2010-3864)
456- drop patches included in new release
457- update patch4
458
459* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
460- add patch12 for fix CVE-2009-3555 (renegotiation)
461
462* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
463- add patch11 for fix CVE-2009-4355 (memory leak)
464
465* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
466- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
467
468* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
469- removed unnecessary %%if %{build_compat32} statements
470- removed lib*.a from devel package
471
472* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
473- new upstream release with security fix (CVE-2000-0590,0591,0789)
474
475* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
476- new upstream release with security fix (CVE-2008-5077)
477
478* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
479- new upstream release
480
481* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
482- new upstream release
483- new versioning policy
484
485* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
486- new upstream release
487- drop patch10,20 which is merged in upstream
488
489* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
490- add security patch in advance for CVE-2007-5135
491  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
492  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
493
494* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
495- add security patch for CVE-2007-3108
496  (http://openssl.org/news/patch-CVE-2007-3108.txt)
497
498* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
499- new upstream release
500
501* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
502- update (fix) openssl.pc <BTS:437>
503
504* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
505- new upstream release (with security fix)
506
507* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
508- new upstream release
509- add patch2 to use RPM_OPT macro
510
511* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
512- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
513
514* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
515- added compat32-* packages for x86_64 architecture support
516- added openssl-0.9.7i.Configure-compat32.patch
517- changed '/lib' to '/%{_lib}'
518
519* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
520- new upstream release
521
522* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
523- rebuild on VineSeed
524
525* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
526- added a security patch from Gentoo.
527  - Patch1: openssl-0.9.7c-tempfile.patch
528
529* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
530- sslarch for ppc was missing... added.
531
532* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
533- use sslarch=linux-alpha-gcc instead of alpha-gcc
534
535* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
536- new upstream version
537- clean up of spec file
538        -- removed old patches
539
540* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
541- new upstream release
542- SECURITY fix.
543  - http://www.openssl.org/news/secadv_20040317.txt
544
545* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
546- new upstream release
547- [Security fix]
548  - Vulnerabilities in ASN.1 parsing
549    http://www.openssl.org/news/secadv_20030930.txt
550- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
551
552* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
553- add openssl.pc for pkgconfig
554
555* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
556- New upstream version
557- dropped patch10, 11
558        -- merged upstream version
559
560* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
561- rebuild for VineSeed
562
563* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
564- [Security Fix]
565  - Timing-based attacks on RSA keys
566    http://www.openssl.org/news/secadv_20030317.txt
567  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
568    http://www.openssl.org/news/secadv_20030317.txt
569
570* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
571- new upstream release 0.9.6i
572- [Security Fix]
573- build for Vine Linux 2.6 errata
574
575* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
576- new upstream release 0.9.6h
577
578* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
579- new upstream release 0.9.6g
580
581* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
582- SECURITY: CAN-2002-0659 fixed
583  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
584    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
585    - update asn patch to fix accidental reversal of a logic check
586    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
587    - update asn patch to reduce chance that compiler optimization will remove
588      one of the added tests
589    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
590    - rebuild
591    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
592    - add patch to fix ASN.1 vulnerabilities
593
594* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
595- rename spec file name
596- SECURITY: CA-2002-23 fixed
597  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
598    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
599    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
600
601* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
602- added ${PATH} in LD_LIBRARY_PATH
603- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
604 
605* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
606- remove --no-<cipher>
607
608* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
609- add Patch10 for mipsel shared ( Configure )
610
611* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
612- build for Vine Linux
613- use openssl-engine-0.9.6b.tar.gz
614
615* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
616- update to 0.9.6b
617
618* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
619- move .so symlinks back to %%{_libdir}
620
621* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
622- move shared libraries to /lib (#38410)
623
624* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
625- switch to engine code base
626
627* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
628- add a script for creating dummy certificates
629- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
630
631* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
632- add s390x support
633
634* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
635- change two memcpy() calls to memmove()
636- don't define L_ENDIAN on alpha
637
638* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
639- make subpackages depend on the main package
640
641* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
642- adjust the hobble script to not disturb symlinks in include/ (fix from
643  Joe Orton)
644
645* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
646- drop the m2crypo patch we weren't using
647
648* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
649- configure using "shared" as well
650
651* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
652- update to 0.9.6a
653- use the build-shared target to build shared libraries
654- bump the soversion to 2 because we're no longer compatible with
655  our 0.9.5a packages or our 0.9.6 packages
656- drop the patch for making rsatest a no-op when rsa null support is used
657- put all man pages into <section>ssl instead of <section>
658- break the m2crypto modules into a separate package
659
660* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
661- use BN_LLONG on s390
662
663* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
664- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
665
666* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
667- move c_rehash to the perl subpackage, because it's a perl script now
668
669* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
670- update to 0.9.6
671- enable MD2
672- use the libcrypto.so and libssl.so targets to build shared libs with
673- bump the soversion to 1 because we're no longer compatible with any of
674  the various 0.9.5a packages circulating around, which provide lib*.so.0
675
676* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
677- change hobble-openssl for disabling MD2 again
678
679* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
680- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
681  bytes or so, causing EVP_DigestInit() to zero out stack variables in
682  apps built against a version of the library without it
683
684* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
685- disable some inline assembly, which on x86 is Pentium-specific
686- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
687
688* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
689- fix s390 patch
690
691* Fri Dec 8 2000 Than Ngo <than@redhat.com>
692- added support s390
693
694* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
695- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
696- add the CA.pl man page to the perl subpackage
697
698* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
699- always build with -mcpu=ev5 on alpha
700
701* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
702- add a symlink from cert.pem to ca-bundle.crt
703
704* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
705- add a ca-bundle file for packages like Samba to reference for CA certificates
706
707* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
708- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
709
710* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
711- add unzip as a buildprereq (#17662)
712- update m2crypto to 0.05-snap4
713
714* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
715- fix some issues in building when it's not installed
716
717* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
718- make sure the headers we include are the ones we built with (aaaaarrgh!)
719
720* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
721- add Richard Henderson's patch for BN on ia64
722- clean up the changelog
723
724* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
725- fix the building of python modules without openssl-devel already installed
726
727* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
728- byte-compile python extensions without the build-root
729- adjust the makefile to not remove temporary files (like .key files when
730  building .csr files) by marking them as .PRECIOUS
731
732* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
733- break out python extensions into a subpackage
734
735* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
736- tweak the makefile some more
737
738* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
739- disable MD2 support
740
741* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
742- disable MDC2 support
743
744* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
745- tweak the disabling of RC5, IDEA support
746- tweak the makefile
747
748* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
749- strip binaries and libraries
750- rework certificate makefile to have the right parts for Apache
751
752* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
753- use %%{_perl} instead of /usr/bin/perl
754- disable alpha until it passes its own test suite
755
756* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
757- move the passwd.1 man page out of the passwd package's way
758
759* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
760- update to 0.9.5a, modified for U.S.
761- add perl as a build-time requirement
762- move certificate makefile to another package
763- disable RC5, IDEA, RSA support
764- remove optimizations for now
765
766* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
767- Bero told me to move the Makefile into this package
768
769* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
770- add lib*.so symlinks to link dynamically against shared libs
771
772* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
773- update to 0.9.5
774- run ldconfig directly in post/postun
775- add FAQ
776
777* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
778- Fix build on non-x86 platforms
779
780* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
781- move /usr/share/ssl/* from -devel to main package
782
783* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
784- inital packaging
785- changes from base:
786  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
787  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.