source: projects/specs/branches/6/o/openssl/openssl-vl.spec @ 10244

Revision 10244, 26.5 KB checked in by iwamoto, 8 years ago (diff)

openssl: update to 1.0.1t

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 10
3%define version 1.0.1t
4%define release 1%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl
8Version: %{version}
9Release: %{release}
10
11Source: openssl-%{version}.tar.gz
12Source2: Makefile.certificate
13Source6: make-dummy-cert
14Source7: renew-dummy-cert
15
16Patch0: openssl-1.0.0-soversion.patch
17Patch2: openssl-1.0.1-rpm_opt.patch
18Patch4: openssl-1.0.0-enginesdir.patch
19Patch5: openssl-1.0.1m-version-add-engines.patch
20Patch8: openssl-1.0.1c-perlfind.patch
21
22# security fix
23# nothing ;-)
24
25License: BSDish
26Group: System Environment/Libraries
27URL: http://www.openssl.org/
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: perl, sed
30BuildRequires: zlib-devel, krb5-devel
31Requires: mktemp
32Requires: ca-certificates
33
34Packager: daisuke
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
39
40%description
41The OpenSSL certificate management tool and the shared libraries that
42provide various cryptographic algorithms and protocols.
43
44%package devel
45Summary: OpenSSL libraries and development headers.
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48Requires: krb5-devel
49
50%description devel
51The static libraries and include files needed to compile apps
52with support for various the cryptographic algorithms and protocols
53supported by OpenSSL.
54
55Patches for many networking apps can be found at:
56ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
57
58%package static
59Summary:  Libraries for static linking of applications which will use OpenSSL
60Group: Development/Libraries
61Requires: %{name}-devel = %{version}-%{release}
62
63%description static
64OpenSSL is a toolkit for supporting cryptography. The openssl-static
65package contains static libraries needed for static linking of
66applications which support various cryptographic algorithms and
67protocols.
68
69%package perl
70Summary: OpenSSL scripts which require Perl.
71Group: Applications/Internet
72Requires: perl
73Requires: %{name} = %{version}-%{release}
74
75%description perl
76Perl scripts provided with OpenSSL for converting certificates and keys
77from other formats to those used by OpenSSL.
78
79## to build compat32 for x86_64 architecture support
80%package -n compat32-%{name}
81Summary: Secure Sockets Layer Toolkit
82Group: System Environment/Libraries
83Requires: %{name} = %{version}-%{release}
84%description -n compat32-%{name}
85The OpenSSL certificate management tool and the shared libraries that
86provide various cryptographic algorithms and protocols.
87
88%package -n compat32-%{name}-devel
89Summary: OpenSSL libraries and development headers.
90Group: Development/Libraries
91Requires: compat32-%{name} = %{version}-%{release}
92Requires: compat32-krb5-devel
93%description -n compat32-%{name}-devel
94The static libraries and include files needed to compile apps
95with support for various the cryptographic algorithms and protocols
96supported by OpenSSL.
97
98%prep
99%setup -q -n openssl-%{version}
100%patch0 -p1 -b .soversion
101%patch2 -p1 -b .rpm_opt
102%patch4 -p1 -b .enginesdir
103%patch5 -p1 -b .version-add-engines
104%patch8 -p1 -b .perlfind
105
106# security fix
107# nothing ;-)
108
109chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
110chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
111chmod 644 doc/openssl_button.html doc/openssl_button.gif
112chmod 644 doc/ssleay.txt
113
114# Link the configuration header to the one we're going to make.
115# ln -sf ../../crypto/opensslconf.h include/openssl/
116
117%build
118PATH=${PATH}:${PWD}/bin
119TOPDIR=${PWD}
120LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
121
122# Modify the various perl scripts to reference perl in the right location.
123perl util/perlpath.pl `dirname %{__perl}`
124
125# Generate a table with the compile settings for my perusal.
126touch Makefile
127make TABLE PERL=%{__perl}
128
129# Figure out which flags we want to use.
130# default
131sslarch=%{_os}-%{_target_cpu}
132#
133%ifarch %ix86
134sslarch=linux-elf
135if ! echo %{_target} | grep -q i686 ; then
136   sslflags="no-asm 386"
137fi
138%endif
139%ifarch sparcv9
140sslarch=linux-sparcv9
141sslflags=no-asm
142%endif
143%ifarch sparc64
144sslarch=linux64-sparcv9
145sslflags=no-asm
146%endif
147%ifarch alpha alphaev56 alphaev6 alphaev67
148sslarch=linux-alpha-gcc
149%endif
150%ifarch s390 sh3eb sh4eb
151sslarch="linux-generic32 -DB_ENDIAN"
152%endif
153%ifarch s390x
154sslarch="linux64-s390x"
155%endif
156%ifarch %{arm} sh3 sh4
157sslarch=linux-generic32
158%endif
159# ia64/x86_64/ppc\ppc64 are OK by default.
160
161# Configure the build tree.  Override OpenSSL defaults with known-good defaults
162# usable on all platforms.  The Configure script already knows to use -fPIC and
163# RPM_OPT_FLAGS, so we can skip specifiying them here.
164./Configure  \
165         --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
166         zlib-dynamic enable-camellia enable-seed enable-tlsext \
167         enable-rfc3779 enable-cms enable-md2 \
168         --enginesdir=%{_libdir}/openssl/engines \
169         --with-krb5-flavor=MIT --with-krb5-dir=/usr \
170         shared ${sslarch}
171
172# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
173# marked as not requiring an executable stack.
174RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
175make depend
176make all build-shared
177
178# Generate hashes for the included certs.
179LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
180export LD_LIBRARY_PATH
181make rehash build-shared
182
183# Verify that what was compiled actually works.
184make -C test apps tests
185
186# Relink the main binary to get it dynamically linked.
187rm apps/openssl
188make all build-shared
189
190%install
191[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
192# Install OpenSSL.
193install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
194make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
195install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
196# added for lib64
197# mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
198mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
199# mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
200mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
201mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man/* $RPM_BUILD_ROOT%{_mandir}
202rmdir $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man
203rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
204for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
205        chmod 755 ${lib}
206        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
207        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
208done
209# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
210
211# Install a makefile for generating keys and self-signed certs, and a script
212# for generating them on the fly.
213mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
214install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/Makefile
215install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/make-dummy-cert
216install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
217
218# Make sure we actually include the headers we built against.
219for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
220        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
221                install -m644 include/openssl/`basename ${header}` ${header}
222        fi
223done
224
225# Rename man pages so that they don't conflict with system man pages.  We used
226# to change the file extensions, but that only prevents file conflicts.  The
227# man viewer still can't select either of the two unless we physically change
228# the directory.
229for section in 1 2 3 4 5 6 7 8 ; do
230        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
231                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
232                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
233        fi
234done
235
236# Pick a CA script.
237pushd  $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc
238mv CA.sh CA
239popd
240
241mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
242mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
243mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
244mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
245mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
246
247# Ensure the openssl.cnf timestamp is identical across builds to avoid
248# mulitlib conflicts and unnecessary renames on upgrade
249touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
250
251%clean
252[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
253
254%files
255%defattr(-,root,root)
256%doc FAQ LICENSE CHANGES NEWS INSTALL README
257%doc doc/README doc/c-indentation.el doc/openssl.txt
258%doc doc/openssl_button.html doc/openssl_button.gif
259%doc doc/ssleay.txt
260
261%{_sysconfdir}/pki/tls/certs/make-dummy-cert
262%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
263%{_sysconfdir}/pki/tls/certs/Makefile
264%{_sysconfdir}/pki/tls/misc/CA
265%dir %{_sysconfdir}/pki/CA
266%dir %{_sysconfdir}/pki/CA/private
267%dir %{_sysconfdir}/pki/CA/certs
268%dir %{_sysconfdir}/pki/CA/crl
269%dir %{_sysconfdir}/pki/CA/newcerts
270%{_sysconfdir}/pki/tls/misc/c_*
271%dir %{_sysconfdir}/pki/tls
272%dir %{_sysconfdir}/pki/tls/certs
273%dir %{_sysconfdir}/pki/tls/misc
274%dir %{_sysconfdir}/pki/tls/private
275%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
276
277%attr(0755,root,root) %{_bindir}/openssl
278%attr(0755,root,root) /%{_lib}/*.so.*
279%attr(0755,root,root) %{_libdir}/openssl/engines/*.so
280%attr(0755,root,root) %dir %{_mandir}/man1*
281%attr(0644,root,root) %{_mandir}/man1*/*
282%attr(0755,root,root) %dir %{_mandir}/man5*
283%attr(0644,root,root) %{_mandir}/man5*/*
284%attr(0755,root,root) %dir %{_mandir}/man7*
285%attr(0644,root,root) %{_mandir}/man7*/*
286
287%files devel
288%defattr(-,root,root)
289%{_prefix}/include/openssl
290%exclude %{_libdir}/lib*.a
291%attr(0755,root,root) %{_libdir}/*.so
292%attr(0755,root,root) %dir %{_mandir}/man3*
293%attr(0644,root,root) %{_mandir}/man3*/*
294%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
295
296%files static
297%defattr(-,root,root)
298%attr(0644,root,root) %{_libdir}/*.a
299
300%files perl
301%defattr(-,root,root)
302%attr(0755,root,root) %{_bindir}/c_rehash
303%attr(0755,root,root) %dir %{_mandir}/man1*
304%attr(0644,root,root) %{_mandir}/man1*/*.pl*
305%{_sysconfdir}/pki/tls/misc/*.pl
306#%{_sysconfdir}/pki/tls/misc/tsget
307%doc apps/tsget
308
309## to build compat32 for x86_64 architecture support
310%if %{build_compat32}
311%files -n compat32-%{name}
312%defattr(-,root,root)
313%attr(0755,root,root) /%{_lib}/*.so.*
314
315%files -n compat32-%{name}-devel
316%defattr(-,root,root)
317%exclude %{_libdir}/lib*.a
318%attr(0755,root,root) %{_libdir}/*.so
319%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
320%endif
321
322%post -p /sbin/ldconfig
323
324%postun -p /sbin/ldconfig
325
326%post -n compat32-%{name} -p /sbin/ldconfig
327
328%postun -n compat32-%{name} -p /sbin/ldconfig
329
330%changelog
331* Wed May  4 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1t-1
332- new upstream release with security fixes
333
334* Wed Mar  2 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1s-1
335- new upstream release with security fixes
336
337* Fri Jan 29 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1r-1
338- new upstream release with security fixes 
339
340* Fri Dec  4 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1q-1
341- new upstream release with security fixes
342
343* Fri Jul 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1p-1
344- new upstream release with security fixes
345
346* Mon Jun 15 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1o-1
347- new upstream release with security fixes 
348
349* Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1m-1
350- new upstream release with security fixes 
351- update Patch2,5
352
353* Wed Feb 11 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1l-1
354- rebuild for VineLinux 6.x
355
356* Sun Feb  8 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1l-0.1
357- test package for VineLinux 6.x
358
359* Sat Jan 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0p-1
360- new upstream release with security fixes 
361
362* Sun Oct 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0o-1
363- new upstream release with security fixes (CVE-2014-3566,3567,3568)
364
365* Thu Aug  7 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0n-1
366- new upstream release with security fixes
367
368* Thu Jun  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0m-1
369- new upstream release with security fixes
370- drop patch10-12 (are included in new release)
371
372* Mon May 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-4
373- add patch12 CVE-2014-0198
374
375* Mon Apr 21 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-3
376- add patch11 for fix CVE-2010-0098
377
378* Fri Mar 28 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-2
379- add patch10 for fix CVE-2014-0076
380
381* Tue Jan  7 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-1
382- new upstream release with security fix (CVE-2013-6450)
383
384* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0k-2
385- move root CA bundle to ca-certificates package
386
387* Wed Feb  6 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0k-1
388- new upstream release with security fix (CVE-2013-0166, 0169)
389
390* Sat May 12 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0j-1
391- new upstream release with security fix (CVE-2012-2333) 
392
393* Fri Apr 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0i-1
394- new upstream release with security fix (CVE-2012-2110)
395
396* Sat Mar 31 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0h-1
397- new upstream release with security fix (CVE-2012-0884)
398
399* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
400- new upstream release with security fix (CVE-2012-0050)
401
402* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
403- new upstream release with security fix
404  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
405
406* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
407- new upstream release with security fix (CVE-2011-3207, 3210)
408
409* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
410- rebuild with krb5-libs 1.8
411
412* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
413- new upstream release with security fix
414
415* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
416- use upstream openssl.pc instead of vine original one (SOURCE6)
417
418* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
419- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
420
421* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
422- add R: krb5-devel into devel pkg
423- add R: compat32-krb5-devel into compat32-devel pkg
424
425* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
426- new upstream release 1.0.0x
427- separate static libs into static package
428- change configure options
429- change so version 10
430- add tsget into perl package
431- update all patches
432
433* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
434- fix changelog typo...
435
436* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
437- new upstream release with security fix (CVE-2010-4180)
438
439* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
440- new upstream release with security fix (CVE-2010-3864)
441- drop patches included in new release
442- update patch4
443
444* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
445- add patch12 for fix CVE-2009-3555 (renegotiation)
446
447* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
448- add patch11 for fix CVE-2009-4355 (memory leak)
449
450* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
451- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
452
453* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
454- removed unnecessary %%if %{build_compat32} statements
455- removed lib*.a from devel package
456
457* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
458- new upstream release with security fix (CVE-2000-0590,0591,0789)
459
460* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
461- new upstream release with security fix (CVE-2008-5077)
462
463* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
464- new upstream release
465
466* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
467- new upstream release
468- new versioning policy
469
470* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
471- new upstream release
472- drop patch10,20 which is merged in upstream
473
474* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
475- add security patch in advance for CVE-2007-5135
476  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
477  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
478
479* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
480- add security patch for CVE-2007-3108
481  (http://openssl.org/news/patch-CVE-2007-3108.txt)
482
483* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
484- new upstream release
485
486* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
487- update (fix) openssl.pc <BTS:437>
488
489* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
490- new upstream release (with security fix)
491
492* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
493- new upstream release
494- add patch2 to use RPM_OPT macro
495
496* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
497- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
498
499* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
500- added compat32-* packages for x86_64 architecture support
501- added openssl-0.9.7i.Configure-compat32.patch
502- changed '/lib' to '/%{_lib}'
503
504* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
505- new upstream release
506
507* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
508- rebuild on VineSeed
509
510* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
511- added a security patch from Gentoo.
512  - Patch1: openssl-0.9.7c-tempfile.patch
513
514* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
515- sslarch for ppc was missing... added.
516
517* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
518- use sslarch=linux-alpha-gcc instead of alpha-gcc
519
520* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
521- new upstream version
522- clean up of spec file
523        -- removed old patches
524
525* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
526- new upstream release
527- SECURITY fix.
528  - http://www.openssl.org/news/secadv_20040317.txt
529
530* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
531- new upstream release
532- [Security fix]
533  - Vulnerabilities in ASN.1 parsing
534    http://www.openssl.org/news/secadv_20030930.txt
535- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
536
537* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
538- add openssl.pc for pkgconfig
539
540* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
541- New upstream version
542- dropped patch10, 11
543        -- merged upstream version
544
545* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
546- rebuild for VineSeed
547
548* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
549- [Security Fix]
550  - Timing-based attacks on RSA keys
551    http://www.openssl.org/news/secadv_20030317.txt
552  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
553    http://www.openssl.org/news/secadv_20030317.txt
554
555* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
556- new upstream release 0.9.6i
557- [Security Fix]
558- build for Vine Linux 2.6 errata
559
560* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
561- new upstream release 0.9.6h
562
563* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
564- new upstream release 0.9.6g
565
566* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
567- SECURITY: CAN-2002-0659 fixed
568  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
569    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
570    - update asn patch to fix accidental reversal of a logic check
571    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
572    - update asn patch to reduce chance that compiler optimization will remove
573      one of the added tests
574    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
575    - rebuild
576    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
577    - add patch to fix ASN.1 vulnerabilities
578
579* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
580- rename spec file name
581- SECURITY: CA-2002-23 fixed
582  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
583    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
584    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
585
586* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
587- added ${PATH} in LD_LIBRARY_PATH
588- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
589 
590* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
591- remove --no-<cipher>
592
593* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
594- add Patch10 for mipsel shared ( Configure )
595
596* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
597- build for Vine Linux
598- use openssl-engine-0.9.6b.tar.gz
599
600* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
601- update to 0.9.6b
602
603* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
604- move .so symlinks back to %%{_libdir}
605
606* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
607- move shared libraries to /lib (#38410)
608
609* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
610- switch to engine code base
611
612* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
613- add a script for creating dummy certificates
614- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
615
616* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
617- add s390x support
618
619* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
620- change two memcpy() calls to memmove()
621- don't define L_ENDIAN on alpha
622
623* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
624- make subpackages depend on the main package
625
626* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
627- adjust the hobble script to not disturb symlinks in include/ (fix from
628  Joe Orton)
629
630* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
631- drop the m2crypo patch we weren't using
632
633* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
634- configure using "shared" as well
635
636* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
637- update to 0.9.6a
638- use the build-shared target to build shared libraries
639- bump the soversion to 2 because we're no longer compatible with
640  our 0.9.5a packages or our 0.9.6 packages
641- drop the patch for making rsatest a no-op when rsa null support is used
642- put all man pages into <section>ssl instead of <section>
643- break the m2crypto modules into a separate package
644
645* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
646- use BN_LLONG on s390
647
648* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
649- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
650
651* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
652- move c_rehash to the perl subpackage, because it's a perl script now
653
654* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
655- update to 0.9.6
656- enable MD2
657- use the libcrypto.so and libssl.so targets to build shared libs with
658- bump the soversion to 1 because we're no longer compatible with any of
659  the various 0.9.5a packages circulating around, which provide lib*.so.0
660
661* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
662- change hobble-openssl for disabling MD2 again
663
664* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
665- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
666  bytes or so, causing EVP_DigestInit() to zero out stack variables in
667  apps built against a version of the library without it
668
669* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
670- disable some inline assembly, which on x86 is Pentium-specific
671- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
672
673* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
674- fix s390 patch
675
676* Fri Dec 8 2000 Than Ngo <than@redhat.com>
677- added support s390
678
679* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
680- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
681- add the CA.pl man page to the perl subpackage
682
683* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
684- always build with -mcpu=ev5 on alpha
685
686* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
687- add a symlink from cert.pem to ca-bundle.crt
688
689* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
690- add a ca-bundle file for packages like Samba to reference for CA certificates
691
692* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
693- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
694
695* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
696- add unzip as a buildprereq (#17662)
697- update m2crypto to 0.05-snap4
698
699* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
700- fix some issues in building when it's not installed
701
702* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
703- make sure the headers we include are the ones we built with (aaaaarrgh!)
704
705* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
706- add Richard Henderson's patch for BN on ia64
707- clean up the changelog
708
709* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
710- fix the building of python modules without openssl-devel already installed
711
712* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
713- byte-compile python extensions without the build-root
714- adjust the makefile to not remove temporary files (like .key files when
715  building .csr files) by marking them as .PRECIOUS
716
717* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
718- break out python extensions into a subpackage
719
720* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
721- tweak the makefile some more
722
723* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
724- disable MD2 support
725
726* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
727- disable MDC2 support
728
729* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
730- tweak the disabling of RC5, IDEA support
731- tweak the makefile
732
733* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
734- strip binaries and libraries
735- rework certificate makefile to have the right parts for Apache
736
737* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
738- use %%{_perl} instead of /usr/bin/perl
739- disable alpha until it passes its own test suite
740
741* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
742- move the passwd.1 man page out of the passwd package's way
743
744* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
745- update to 0.9.5a, modified for U.S.
746- add perl as a build-time requirement
747- move certificate makefile to another package
748- disable RC5, IDEA, RSA support
749- remove optimizations for now
750
751* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
752- Bero told me to move the Makefile into this package
753
754* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
755- add lib*.so symlinks to link dynamically against shared libs
756
757* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
758- update to 0.9.5
759- run ldconfig directly in post/postun
760- add FAQ
761
762* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
763- Fix build on non-x86 platforms
764
765* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
766- move /usr/share/ssl/* from -devel to main package
767
768* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
769- inital packaging
770- changes from base:
771  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
772  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.