source: projects/specs/branches/6/o/openssh/openssh-vl.spec @ 8337

Revision 8337, 26.0 KB checked in by iwamoto, 10 years ago (diff)

openssh: fix CVE-2014-2532,2653

Line 
1%define ver 5.8p2
2%define rel 3%{_dist_release}
3
4# SELinux
5%define WITH_SELINUX 0
6
7# OpenSSH privilege separation requires a user & group ID
8%define sshd_uid    74
9%define sshd_gid    74
10
11# Version of ssh-askpass
12%define aversion 1.2.4.1
13
14# Do we want to disable building of gnome-askpass? (1=yes 0=no)
15%define no_gnome_askpass 0
16
17# Use GTK2 for gnome-ssh-askpass
18%define gtk2 1
19
20# Build position-independent executables (requires toolchain support)?
21%define pie 1
22
23# Do we want to link against a static libcrypto? (1=yes 0=no)
24%define static_libcrypto 0
25
26# Do we want smartcard support (1=yes 0=no)
27%define scard 0
28
29# Disable IPv6 (avoids DNS hangs on some glibc versions)
30%define noip6 0
31
32# Do we want kerberos5 support (1=yes 0=no)
33%define kerberos5 0
34
35# Reserve options to override askpass settings with:
36# rpm -ba|--rebuild --define 'skip_xxx 1'
37%{?skip_gnome_askpass:%define no_gnome_askpass 1}
38
39# Options for static OpenSSL link:
40# rpm -ba|--rebuild --define "static_openssl 1"
41%{?static_openssl:%define static_libcrypto 1}
42
43# Options for Smartcard support: (needs libsectok and openssl-engine)
44# rpm -ba|--rebuild --define "smartcard 1"
45%{?smartcard:%define scard 1}
46
47# Option to disable ipv6
48# rpm -ba|--rebuild --define "noipv6 1"
49%{?noipv6:%define noip6 1}
50
51# Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
52%define rescue 0
53%{?build_rescue:%define rescue 1}
54
55# Turn off some stuff for resuce builds
56%if %{rescue}
57%define kerberos5 0
58%endif
59
60Summary: The OpenSSH implementation of SSH.
61Summary(ja): OpenSSH - フリーの Secure Shell (SSH) の実装
62Name: openssh
63Version: %{ver}
64Release: %{rel}
65URL: http://www.openssh.com/portable.html
66
67Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
68
69Patch0: openssh-5.5p1-vine.patch
70Patch4: openssh-5.2p1-vendor.patch
71Patch12: openssh-selinux.patch
72Patch20: openssh-3.9p1-gssapimitm.patch
73Patch21: openssh-3.9p1-safe-stop.patch
74Patch24: openssh-5.7p1-fromto-remote.patch
75Patch26: openssh-5.2p1-pam-no-stack.patch
76Patch27: openssh-5.1p1-log-in-chroot.patch
77Patch30: openssh-4.0p1-exit-deadlock.patch
78# Patch31: openssh-3.9p1-skip-used.patch
79Patch35: openssh-4.2p1-askpass-progress.patch
80
81# Vine Source
82Source100: sshd.init
83Source110: sshd.sysconfig
84
85# Vine Patch
86Patch100: openssh-norootlogin.patch
87
88# security patches
89Patch1000: openssh-5.8p2_CVE-2010-5107.patch
90Patch1010: openssh-5.8p2_CVE-2014-2532.patch
91Patch1020: openssh-5.8p2_CVE-2014-2653.patch
92
93License: BSD
94Group: Applications/Internet
95BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
96
97Obsoletes: ssh
98
99BuildRequires: perl, openssl-devel, sharutils, tcp_wrappers
100BuildRequires: util-linux
101BuildRequires: db4-devel
102BuildRequires: pam-devel
103BuildRequires: zlib-devel
104%if ! %{no_gnome_askpass}
105BuildRequires: libX11-devel
106BuildRequires: gtk2-devel
107%endif
108BuildRequires: xorg-x11-xauth
109BuildRequires: groff
110BuildRequires: libedit-devel
111
112Vendor: Project Vine
113Distribution: Vine Linux
114Packager: daisuke
115
116%package clients
117Summary: OpenSSH clients.
118Summary(ja): OpenSSH Secure Shell プロトコルクライアント
119Requires: openssh = %{version}-%{release}
120Group: Applications/Internet
121Obsoletes: ssh-clients
122Obsoletes: openssh-contrib
123
124%package server
125Summary: The OpenSSH server daemon.
126Summary(ja): OpenSSH Secure Shell プロトコルサーバ (sshd)
127Group: System Environment/Daemons
128Obsoletes: ssh-server
129Requires(post): openssh = %{version}-%{release}
130Requires(post): chkconfig
131Requires(pre): shadow-utils
132Requires(post): initscripts >= 5.20
133Requires: pam
134
135%package askpass-gnome
136Summary: A passphrase dialog for OpenSSH, X, and GNOME.
137Summary(ja): OpenSSH GNOME パスフレーズ入力ダイアログ
138Group: Applications/Internet
139Requires: openssh = %{version}-%{release}
140Obsoletes: ssh-extras
141Obsoletes: openssh-askpass < 5.5p1-3vl6
142Provides: openssh-askpass = %{version}-%{release}
143
144%description
145SSH (Secure SHell) is a program for logging into and executing
146commands on a remote machine. SSH is intended to replace rlogin and
147rsh, and to provide secure encrypted communications between two
148untrusted hosts over an insecure network. X11 connections and
149arbitrary TCP/IP ports can also be forwarded over the secure channel.
150
151OpenSSH is OpenBSD's version of the last free version of SSH, bringing
152it up to date in terms of security and features, as well as removing
153all patented algorithms to separate libraries.
154
155This package includes the core files necessary for both the OpenSSH
156client and server. To make this package useful, you should also
157install openssh-clients, openssh-server, or both.
158
159#'
160%description -l ja
161OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
162Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
163するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
164ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
165可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
166な通信路の中を通すことができます。
167
168OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
169最新のセキュリティと機能を提供しています。またすべての特許がからむ
170アルゴリズムは分割したライブラリにわかれています。
171
172このパッケージは OpenSSH のクライアントとサーバの両方で必要とされる
173コアのファイルを含んでいます。実際に使用するにはこのパッケージの他に
174openssh-clients および/または openssh-server が必要です。
175
176%description clients
177OpenSSH is a free version of SSH (Secure SHell), a program for logging
178into and executing commands on a remote machine. This package includes
179the clients necessary to make encrypted connections to SSH servers.
180You'll also need to install the openssh package on OpenSSH clients.
181
182#'
183%description -l ja clients
184OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
185Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
186するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
187ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
188可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
189な通信路の中を通すことができます。
190
191OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
192最新のセキュリティと機能を提供しています。またすべての特許がからむ
193アルゴリズムは分割したライブラリにわかれています。
194
195このパッケージは OpenSSH をクライアントとして使用する場合に
196必要なものを含んでいます。
197
198
199%description server
200OpenSSH is a free version of SSH (Secure SHell), a program for logging
201into and executing commands on a remote machine. This package contains
202the secure shell daemon (sshd). The sshd daemon allows SSH clients to
203securely connect to your SSH server. You also need to have the openssh
204package installed.
205
206%description -l ja server
207OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
208Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
209するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
210ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
211可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
212な通信路の中を通すことができます。
213
214OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
215最新のセキュリティと機能を提供しています。またすべての特許がからむ
216アルゴリズムは分割したライブラリにわかれています。
217
218このパッケージは OpenSSH をサーバとして使用する場合に必要な
219デーモンなどを含んでいます。
220
221%description askpass-gnome
222OpenSSH is a free version of SSH (Secure SHell), a program for logging
223into and executing commands on a remote machine. This package contains
224an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
225environment.
226
227%description -l ja askpass-gnome
228OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
229Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
230するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
231ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
232可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
233な通信路の中を通すことができます。
234
235OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
236最新のセキュリティと機能を提供しています。またすべての特許がからむ
237アルゴリズムは分割したライブラリにわかれています。
238
239このパッケージは GNOME 用のパスフレーズ入力ダイアログを含んでいます。
240
241%prep
242
243%setup -q
244%patch0 -p1 -b .vine
245%patch4 -p1 -b .vendor
246
247%if %{WITH_SELINUX}
248#SELinux
249%patch12 -p1 -b .selinux
250%endif
251
252%patch21 -p1 -b .safe-stop
253%patch24 -p1 -b .fromto-remote
254%patch26 -p1 -b .stack
255%patch27 -p1 -b .log-chroot
256%patch30 -p1 -b .exit-deadlock
257%patch35 -p1 -b .progress
258
259%patch100 -p1 -b .norootlogin
260
261%patch1000 -p1 -b .CVE-2010-5107
262%patch1010 -p1 -b .CVE-2014-2532
263%patch1020 -p1 -b .CVE-2014-2653
264
265autoreconf
266
267
268%build
269CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
270%if %{rescue}
271CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
272%endif
273%if %{pie}
274%ifarch s390 s390x sparc sparc64
275CFLAGS="$CFLAGS -fPIE"
276%else
277CFLAGS="$CFLAGS -fpie"
278%endif
279export CFLAGS
280LDFLAGS="$LDFLAGS -pie"; export LDFLAGS
281%endif
282
283%configure \
284        --sysconfdir=%{_sysconfdir}/ssh \
285        --libexecdir=%{_libexecdir}/openssh \
286        --datadir=%{_datadir}/openssh \
287        --with-tcp-wrappers \
288        --with-default-path=/usr/local/bin:/bin:/usr/bin \
289        --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
290        --with-privsep-path=%{_var}/empty/sshd \
291        --enable-vendor-patchlevel="VL-%{version}-%{release}" \
292        --with-libedit \
293%if %{scard}
294        --with-smartcard \
295%endif
296%if %{noip6}
297        --with-ipv4-default \
298%endif
299%if %{rescue}
300        --without-pam --with-md5-passwords
301%else
302        --with-pam
303%endif
304
305%if %{static_libcrypto}
306perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
307%endif
308
309make
310
311%if %{gtk2}
312        gtk2=yes
313%else
314        gtk2=no
315%endif
316
317%if ! %{no_gnome_askpass}
318pushd contrib
319if [ $gtk2 = yes ]; then
320        make gnome-ssh-askpass2
321        mv gnome-ssh-askpass2 gnome-ssh-askpass
322else
323        make gnome-ssh-askpass1
324        mv gnome-ssh-askpass1 gnome-ssh-askpass
325fi
326popd
327%endif
328
329%install
330rm -rf $RPM_BUILD_ROOT
331mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
332mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
333mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
334mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd/etc
335
336make install DESTDIR=$RPM_BUILD_ROOT
337
338touch $RPM_BUILD_ROOT%{_var}/empty/sshd/etc/localtime
339install -d $RPM_BUILD_ROOT/etc/pam.d/
340install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
341install -d $RPM_BUILD_ROOT/etc/sysconfig/
342install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
343install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
344install -m755 %{SOURCE100} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
345install -m644 %{SOURCE110} $RPM_BUILD_ROOT/etc/sysconfig/sshd
346
347%if ! %{scard}
348        rm -f $RPM_BUILD_ROOT%{_datadir}/openssh/Ssh.bin
349%endif
350
351%if ! %{no_gnome_askpass}
352install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
353install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
354install -m 755 contrib/redhat/gnome-ssh-askpass.{sh,csh} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
355%endif
356
357%if %{no_gnome_askpass}
358rm -f $RPM_BUILD_ROOT/etc/profile.d/gnome-ssh-askpass.*
359%endif
360
361# for contrib package
362install -m 0755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
363install -m 0644 contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
364mv contrib/README contrib/README.contrib
365
366perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
367
368%clean
369rm -rf $RPM_BUILD_ROOT
370
371%triggerun server -- ssh-server
372if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
373        touch /var/run/sshd.restart
374fi
375
376%triggerun server -- openssh-server < 2.5.0p1
377# Count the number of HostKey and HostDsaKey statements we have.
378gawk    'BEGIN {IGNORECASE=1}
379         /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
380         END {exit sawhostkey}' /etc/ssh/sshd_config
381# And if we only found one, we know the client was relying on the old default
382# behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
383# specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
384# one nullifies the default, which would have loaded both.
385if [ $? -eq 1 ] ; then
386        echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
387        echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
388fi
389
390%triggerpostun server -- ssh-server
391if [ "$1" != 0 ] ; then
392        /sbin/chkconfig --add sshd
393        if test -f /var/run/sshd.restart ; then
394                rm -f /var/run/sshd.restart
395                # /sbin/service sshd start > /dev/null 2>&1 || :
396                /sbin/service sshd start
397        fi
398fi
399
400%pre server
401%{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
402%{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
403        -g sshd -M -r sshd 2>/dev/null || :
404
405%post server
406/sbin/chkconfig --add sshd
407
408%postun server
409# /sbin/service sshd condrestart > /dev/null 2>&1 || :
410/sbin/service sshd condrestart
411exit 0
412
413%preun server
414if [ "$1" = 0 ]
415then
416        /sbin/service sshd stop > /dev/null 2>&1 || :
417        /sbin/chkconfig --del sshd
418fi
419
420%files
421%defattr(-,root,root)
422%doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* RFC* TODO WARNING*
423%attr(0755,root,root) %{_bindir}/scp
424%attr(0644,root,root) %{_mandir}/man1/scp.1*
425%attr(0755,root,root) %dir %{_sysconfdir}/ssh
426%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
427%attr(644,root,root) %{_mandir}/man5/moduli.5*
428%if ! %{rescue}
429%attr(0755,root,root) %{_bindir}/ssh-keygen
430%attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
431%attr(0755,root,root) %dir %{_libexecdir}/openssh
432%attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
433%attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
434%endif
435%if %{scard}
436%attr(0755,root,root) %dir %{_datadir}/openssh
437%attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
438%endif
439
440%files clients
441%defattr(-,root,root)
442%attr(0755,root,root) %{_bindir}/ssh
443%attr(0644,root,root) %{_mandir}/man1/ssh.1*
444%attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
445%attr(0644,root,root) %{_mandir}/man1/slogin.1*
446%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
447%attr(-,root,root) %{_bindir}/slogin
448%if ! %{rescue}
449%attr(0755,root,root) %{_bindir}/ssh-agent
450%attr(0755,root,root) %{_bindir}/ssh-add
451%attr(0755,root,root) %{_bindir}/ssh-keyscan
452%attr(0755,root,root) %{_bindir}/sftp
453%attr(0755,root,root) %{_bindir}/ssh-copy-id
454%attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
455%attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
456%attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
457%attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
458%attr(0644,root,root) %{_mandir}/man1/sftp.1*
459%attr(0644,root,root) %{_mandir}/man1/ssh-copy-id.1*
460%attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
461%endif
462
463%if ! %{rescue}
464%files server
465%defattr(-,root,root)
466%dir %attr(0711,root,root) %{_var}/empty/sshd
467%dir %attr(0755,root,root) %{_var}/empty/sshd/etc
468%ghost %verify(not md5 size mtime) %{_var}/empty/sshd/etc/localtime
469%attr(0755,root,root) %{_sbindir}/sshd
470%attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
471%attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
472%attr(0644,root,root) %{_mandir}/man8/sshd.8*
473%attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
474%attr(0755,root,root) %dir %{_sysconfdir}/ssh
475%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
476%attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
477%attr(0755,root,root) %config /etc/rc.d/init.d/sshd
478%attr(0755,root,root) %config /etc/sysconfig/sshd
479%endif
480
481%if ! %{no_gnome_askpass}
482%files askpass-gnome
483%defattr(-,root,root)
484%attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
485%attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
486%endif
487
488
489%changelog
490* Tue Apr  8 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.8p2-3
491- add patch1010 for fix CVE-2014-2532 (wildcards on AcceptEnv)
492- add patch1020 for fix CVE-2014-2653 (SSHFP DNS RR)
493
494* Wed Mar 13 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.8p2-2
495- add patch1000 for fix CVE-2010-5107 (login interval)
496
497* Sun May  8 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.8p2-1
498- new upstream release
499
500* Tue Apr 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-2
501- add our own sshd.init based on fedora's sshd.init
502  - generate ECDSA host key.
503
504* Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-1
505- new upstream release
506
507* Tue Jan 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.7p1-1
508- new upstream release
509
510* Mon Jan 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.6p1-1
511- new upstream release
512- obsolete contrib subpackage, move ssh-copy-id to client subpackage
513
514* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.5p1-4
515- rebuilt with openssl 1.0.0c
516
517* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-3
518- drop x11-askpass, add Obsoletes: openssh-askpass
519- add BR: groff
520- enable --with-libedit option, add BR: libedit-devel
521- remove unrecognized option '--with-rsh'
522
523* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-2
524- add BR: xorg-x11-xauth for X11 forwarding support
525
526* Thu Apr 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-1
527- new upstream release
528- update patch0,2
529- drop patch3,22
530
531* Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2p1-1
532- new upstream release
533
534* Tue Jul 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1p1-1
535- new upstream release
536
537* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0p1-2
538- rebuild with xorg-x11-7.3
539
540* Fri Apr 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.0p1-1
541- new upstream release with security fix (CVE-2008-1483)
542- drop patch31 which is included in new release (This was for CVE-2008-1483)
543
544* Tue Apr 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.9p1-1
545- new upstream release with security fix ("ForceCommand" Directive)
546- turn on daemon restart message
547- new versioning policy
548
549* Mon Nov 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.7p1-0vl2
550- add /var/empty/sshd/etc/localtime to fix secure log bad timestamps
551
552* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7p1-0vl1
553- new upstream release
554
555* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl2
556- build with -fpie/-pie by default.
557- enable ipv6 by default.
558
559* Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl1
560- new upstream release
561
562* Wed Nov 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.5p1-0vl1
563- new upstream release
564
565* Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4p1-0vl1
566- new upstream release
567
568* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p2-0vl1
569- new upstream release
570
571* Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p1-0vl1
572- new upstream release
573- remove build6x stuff
574- remove libgnome-devel from BuildRequires
575- cleanup BuildRequires
576- drop Patch200, it is merged in upstream.
577- import patches(25-35) from FC-devel
578
579* Mon Apr 10 2006 IWAI, Masaharu <iwai@alib.jp> 4.2p1-0vl3
580- SECURITY FIX: CVE-2006-0225
581  - add scp no system patch ( Patch200 ): from Fedora Core 4 4.2p1-fc4.10
582- update BuildPreReq: s/XFree86-devel/XOrg-devel/
583- fix BuildPreReq for GNOME: gnome-libs-devel ( GNOME1 ) was always used
584  - When GNOME2 is used, using libgnome-devel
585  - add BuildPreReq: gtk2-devel for GNOME2
586
587* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl2
588- rebuild with gtk+-2.8 final
589
590* Sun Sep  4 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl1
591- new upstream release
592- build with gtk+-2.7
593
594* Sun May 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1p1-0vl1
595- new upstream release
596
597* Fri Apr 01 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 4.0p1-0vl2
598- cleanup obsolete patches and added patches from fedora
599
600* Wed Mar 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0p1-0vl1
601- new upstream release
602
603* Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9pl1-0vl1
604- new upstream release
605
606* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.1p1-0vl1
607- new upstream release
608
609* Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl2
610- rebuild with openssl-0.9.7d
611
612* Fri Feb 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl1
613- new upstream release
614
615* Thu Oct  2 2003 IWAI, Masaharu <iwai@alib.jp> 3.7.1p2-0vl2
616- create contrib package
617
618* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p2-0vl1
619- new upstream release
620- fix security issue: http://www.openssh.com/txt/sshpam.adv
621
622* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p1-0vl1
623- new upstream release
624- fix security issue: http://www.openssh.com/txt/buffer.adv
625
626* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7p1-0vl1
627- new upstream release
628
629* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1.1
630- rebuild with gtk2
631
632* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1
633- new upstream release
634
635* Sat Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.5p1-0vl2
636- rebuild with new tool chain
637
638* Tue Oct 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5p1-0vl1
639- new upstream release
640- merge with upstream spec (drop anonymous mmap patch, suid of ssh)
641
642* Tue Aug 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl3
643- change some defines in spec files
644
645* Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl2
646- add patch110 ( 3.4p1 does not include mmap-fallback patch )
647
648* Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl1
649- new upstream release
650  - security fix
651- drop patch10
652
653* Wed Jun 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl2
654- add patch from Solar Designer to make privsep work with a 2.2 kernel.
655
656* Sun Jun 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl1
657- new upstream release
658- add {sshd,ssh}_config.5 manpages
659- add ssh-keysign
660
661* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.3p1-0vl1
662- new upstream release
663
664* Sat May 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2p1-0vl1
665- new upstream release
666- drop patch1
667
668* Fri Mar 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1p1-2vl1
669- new upstream release
670- merged with rawhide release.
671- drop Patch101 (merged in upstream)
672
673* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 3.0.2p1-2vl2
674- seurity patch for off-by-one bug
675
676* Wed Jan 30 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.2p-2vl1
677- merged with Rawhide 3.0.2p1-2
678
679* Sun Dec 02 2001 Toru Sagami <sagami@vinelinux.org>
680- updated to 3.0.2p1
681
682* Mon Nov 19 2001 Toru Sagami <sagami@vinelinux.org>
683- updated to 3.0.1p1
684
685* Thu Nov 08 2001 Toru Sagami <sagami@vinelinux.org> 3.0p1-0vl0
686- updated to 3.0p1
687
688* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl2
689- add japanese summery and descriptions.
690- update x11-askpass 1.2.5
691
692* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl1
693- update to openssh-2.9.9p2
694
695* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org> 2.5.2p2-0vl3
696- rebuilt with openssl-0.9.6b
697
698* Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 2.5.2p2-0vl2
699- do not Permit RootLogin
700
701* Tue Mar 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p2-0vl1
702- update to openssh-2.5.2p2
703
704* Wed Mar 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p1-0vl1
705- update to openssh-2.5.2p1
706
707* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
708- update to openssh-2.5.1p2
709
710* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
711- update to openssh-2.5.1p1
712
713* Wed Feb 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p1-0vl1
714- update to openssh-2.5.1p1
715
716* Thu Dec 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl4
717- remove suid bit from ssh
718
719* Tue Dec 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl3
720- moved man dir to /usr/share/man
721
722* Wed Dec 06 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl2
723- fixed askpass's link in ssh-add
724- partially used rpmmacros
725
726* Fri Nov 10 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl1
727- update to 2.3.0p1
728- update x11-askpass 1.0.3
729
730* Mon Oct 18 2000 Damien Miller <djm@mindrot.org>
731- Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the
732  Redhat 7.0 spec file
733
734* Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0p2-2vl1
735- rebuild for Vine Linux
736
737* Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
738- Use RPM configure macro
739* Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
740- Some surgery to sshd.init (generate keys at runtime)
741- Cleanup of groups and removal of keygen calls
742* Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
743- Make building of X11-askpass and gnome-askpass optional
744* Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
745- Glob manpages to catch compressed files
746* Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
747- Updated for new location
748- Updated for new gnome-ssh-askpass build
749* Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
750- Added Jim Knoble's <jmknoble@pobox.com> askpass
751* Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
752- Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
753* Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
754- Added 'Obsoletes' directives
755* Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
756- Use make install
757- Subpackages
758* Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
759- Added links for slogin
760- Fixed perms on manpages
761* Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
762- Renamed init script
763* Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
764- Back to old binary names
765* Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
766- Use autoconf
767- New binary names
768* Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
769- Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
770
Note: See TracBrowser for help on using the repository browser.