source: projects/specs/branches/6/o/openssh/openssh-vl.spec @ 9957

Revision 9957, 26.4 KB checked in by iwamoto, 8 years ago (diff)

openssh: fix CVE-2016-0777, 0778

Line 
1%define ver 5.8p2
2%define rel 5%{_dist_release}
3
4# SELinux
5%define WITH_SELINUX 0
6
7# OpenSSH privilege separation requires a user & group ID
8%define sshd_uid    74
9%define sshd_gid    74
10
11# Version of ssh-askpass
12%define aversion 1.2.4.1
13
14# Do we want to disable building of gnome-askpass? (1=yes 0=no)
15%define no_gnome_askpass 0
16
17# Use GTK2 for gnome-ssh-askpass
18%define gtk2 1
19
20# Build position-independent executables (requires toolchain support)?
21%define pie 1
22
23# Do we want to link against a static libcrypto? (1=yes 0=no)
24%define static_libcrypto 0
25
26# Do we want smartcard support (1=yes 0=no)
27%define scard 0
28
29# Disable IPv6 (avoids DNS hangs on some glibc versions)
30%define noip6 0
31
32# Do we want kerberos5 support (1=yes 0=no)
33%define kerberos5 0
34
35# Reserve options to override askpass settings with:
36# rpm -ba|--rebuild --define 'skip_xxx 1'
37%{?skip_gnome_askpass:%define no_gnome_askpass 1}
38
39# Options for static OpenSSL link:
40# rpm -ba|--rebuild --define "static_openssl 1"
41%{?static_openssl:%define static_libcrypto 1}
42
43# Options for Smartcard support: (needs libsectok and openssl-engine)
44# rpm -ba|--rebuild --define "smartcard 1"
45%{?smartcard:%define scard 1}
46
47# Option to disable ipv6
48# rpm -ba|--rebuild --define "noipv6 1"
49%{?noipv6:%define noip6 1}
50
51# Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
52%define rescue 0
53%{?build_rescue:%define rescue 1}
54
55# Turn off some stuff for resuce builds
56%if %{rescue}
57%define kerberos5 0
58%endif
59
60Summary: The OpenSSH implementation of SSH.
61Summary(ja): OpenSSH - フリーの Secure Shell (SSH) の実装
62Name: openssh
63Version: %{ver}
64Release: %{rel}
65URL: http://www.openssh.com/portable.html
66
67Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
68
69Patch0: openssh-5.5p1-vine.patch
70Patch4: openssh-5.2p1-vendor.patch
71Patch12: openssh-selinux.patch
72Patch20: openssh-3.9p1-gssapimitm.patch
73Patch21: openssh-3.9p1-safe-stop.patch
74Patch24: openssh-5.7p1-fromto-remote.patch
75Patch26: openssh-5.2p1-pam-no-stack.patch
76Patch27: openssh-5.1p1-log-in-chroot.patch
77Patch30: openssh-4.0p1-exit-deadlock.patch
78# Patch31: openssh-3.9p1-skip-used.patch
79Patch35: openssh-4.2p1-askpass-progress.patch
80
81# Vine Source
82Source100: sshd.init
83Source110: sshd.sysconfig
84
85# Vine Patch
86Patch100: openssh-norootlogin.patch
87
88# security patches
89Patch1000: openssh-5.8p2_CVE-2010-5107.patch
90Patch1010: openssh-5.8p2_CVE-2014-2532.patch
91Patch1020: openssh-5.8p2_CVE-2014-2653.patch
92Patch1030: openssh-5.8p2_CVE-2016-0777_0778.patch
93
94License: BSD
95Group: Applications/Internet
96BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
97
98Obsoletes: ssh
99
100BuildRequires: perl, openssl-devel, sharutils, tcp_wrappers
101BuildRequires: util-linux
102BuildRequires: db4-devel
103BuildRequires: pam-devel
104BuildRequires: zlib-devel
105%if ! %{no_gnome_askpass}
106BuildRequires: libX11-devel
107BuildRequires: gtk2-devel
108%endif
109BuildRequires: xorg-x11-xauth
110BuildRequires: groff
111BuildRequires: libedit-devel
112
113Vendor: Project Vine
114Distribution: Vine Linux
115Packager: daisuke
116
117%package clients
118Summary: OpenSSH clients.
119Summary(ja): OpenSSH Secure Shell プロトコルクライアント
120Requires: openssh = %{version}-%{release}
121Group: Applications/Internet
122Obsoletes: ssh-clients
123Obsoletes: openssh-contrib
124
125%package server
126Summary: The OpenSSH server daemon.
127Summary(ja): OpenSSH Secure Shell プロトコルサーバ (sshd)
128Group: System Environment/Daemons
129Obsoletes: ssh-server
130Requires(post): openssh = %{version}-%{release}
131Requires(post): chkconfig
132Requires(pre): shadow-utils
133Requires(post): initscripts >= 5.20
134Requires: pam
135
136%package askpass-gnome
137Summary: A passphrase dialog for OpenSSH, X, and GNOME.
138Summary(ja): OpenSSH GNOME パスフレーズ入力ダイアログ
139Group: Applications/Internet
140Requires: openssh = %{version}-%{release}
141Obsoletes: ssh-extras
142Obsoletes: openssh-askpass < 5.5p1-3vl6
143Provides: openssh-askpass = %{version}-%{release}
144
145%description
146SSH (Secure SHell) is a program for logging into and executing
147commands on a remote machine. SSH is intended to replace rlogin and
148rsh, and to provide secure encrypted communications between two
149untrusted hosts over an insecure network. X11 connections and
150arbitrary TCP/IP ports can also be forwarded over the secure channel.
151
152OpenSSH is OpenBSD's version of the last free version of SSH, bringing
153it up to date in terms of security and features, as well as removing
154all patented algorithms to separate libraries.
155
156This package includes the core files necessary for both the OpenSSH
157client and server. To make this package useful, you should also
158install openssh-clients, openssh-server, or both.
159
160#'
161%description -l ja
162OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
163Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
164するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
165ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
166可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
167な通信路の中を通すことができます。
168
169OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
170最新のセキュリティと機能を提供しています。またすべての特許がからむ
171アルゴリズムは分割したライブラリにわかれています。
172
173このパッケージは OpenSSH のクライアントとサーバの両方で必要とされる
174コアのファイルを含んでいます。実際に使用するにはこのパッケージの他に
175openssh-clients および/または openssh-server が必要です。
176
177%description clients
178OpenSSH is a free version of SSH (Secure SHell), a program for logging
179into and executing commands on a remote machine. This package includes
180the clients necessary to make encrypted connections to SSH servers.
181You'll also need to install the openssh package on OpenSSH clients.
182
183#'
184%description -l ja clients
185OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
186Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
187するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
188ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
189可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
190な通信路の中を通すことができます。
191
192OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
193最新のセキュリティと機能を提供しています。またすべての特許がからむ
194アルゴリズムは分割したライブラリにわかれています。
195
196このパッケージは OpenSSH をクライアントとして使用する場合に
197必要なものを含んでいます。
198
199
200%description server
201OpenSSH is a free version of SSH (Secure SHell), a program for logging
202into and executing commands on a remote machine. This package contains
203the secure shell daemon (sshd). The sshd daemon allows SSH clients to
204securely connect to your SSH server. You also need to have the openssh
205package installed.
206
207%description -l ja server
208OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
209Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
210するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
211ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
212可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
213な通信路の中を通すことができます。
214
215OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
216最新のセキュリティと機能を提供しています。またすべての特許がからむ
217アルゴリズムは分割したライブラリにわかれています。
218
219このパッケージは OpenSSH をサーバとして使用する場合に必要な
220デーモンなどを含んでいます。
221
222%description askpass-gnome
223OpenSSH is a free version of SSH (Secure SHell), a program for logging
224into and executing commands on a remote machine. This package contains
225an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
226environment.
227
228%description -l ja askpass-gnome
229OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
230Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
231するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
232ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
233可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
234な通信路の中を通すことができます。
235
236OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
237最新のセキュリティと機能を提供しています。またすべての特許がからむ
238アルゴリズムは分割したライブラリにわかれています。
239
240このパッケージは GNOME 用のパスフレーズ入力ダイアログを含んでいます。
241
242%prep
243
244%setup -q
245%patch0 -p1 -b .vine
246%patch4 -p1 -b .vendor
247
248%if %{WITH_SELINUX}
249#SELinux
250%patch12 -p1 -b .selinux
251%endif
252
253%patch21 -p1 -b .safe-stop
254%patch24 -p1 -b .fromto-remote
255%patch26 -p1 -b .stack
256%patch27 -p1 -b .log-chroot
257%patch30 -p1 -b .exit-deadlock
258%patch35 -p1 -b .progress
259
260%patch100 -p1 -b .norootlogin
261
262%patch1000 -p1 -b .CVE-2010-5107
263%patch1010 -p1 -b .CVE-2014-2532
264%patch1020 -p1 -b .CVE-2014-2653
265%patch1030 -p1 -b .CVE-2016-0777_0778
266
267autoreconf
268
269
270%build
271CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
272%if %{rescue}
273CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
274%endif
275%if %{pie}
276%ifarch s390 s390x sparc sparc64
277CFLAGS="$CFLAGS -fPIE"
278%else
279CFLAGS="$CFLAGS -fpie"
280%endif
281export CFLAGS
282LDFLAGS="$LDFLAGS -pie"; export LDFLAGS
283%endif
284
285%configure \
286        --sysconfdir=%{_sysconfdir}/ssh \
287        --libexecdir=%{_libexecdir}/openssh \
288        --datadir=%{_datadir}/openssh \
289        --with-tcp-wrappers \
290        --with-default-path=/usr/local/bin:/bin:/usr/bin \
291        --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
292        --with-privsep-path=%{_var}/empty/sshd \
293        --enable-vendor-patchlevel="VL-%{version}-%{release}" \
294        --with-libedit \
295%if %{scard}
296        --with-smartcard \
297%endif
298%if %{noip6}
299        --with-ipv4-default \
300%endif
301%if %{rescue}
302        --without-pam --with-md5-passwords
303%else
304        --with-pam
305%endif
306
307%if %{static_libcrypto}
308perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
309%endif
310
311make
312
313%if %{gtk2}
314        gtk2=yes
315%else
316        gtk2=no
317%endif
318
319%if ! %{no_gnome_askpass}
320pushd contrib
321if [ $gtk2 = yes ]; then
322        make gnome-ssh-askpass2
323        mv gnome-ssh-askpass2 gnome-ssh-askpass
324else
325        make gnome-ssh-askpass1
326        mv gnome-ssh-askpass1 gnome-ssh-askpass
327fi
328popd
329%endif
330
331%install
332rm -rf $RPM_BUILD_ROOT
333mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
334mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
335mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
336mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd/etc
337
338make install DESTDIR=$RPM_BUILD_ROOT
339
340touch $RPM_BUILD_ROOT%{_var}/empty/sshd/etc/localtime
341install -d $RPM_BUILD_ROOT/etc/pam.d/
342install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
343install -d $RPM_BUILD_ROOT/etc/sysconfig/
344install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
345install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
346install -m755 %{SOURCE100} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
347install -m644 %{SOURCE110} $RPM_BUILD_ROOT/etc/sysconfig/sshd
348
349%if ! %{scard}
350        rm -f $RPM_BUILD_ROOT%{_datadir}/openssh/Ssh.bin
351%endif
352
353%if ! %{no_gnome_askpass}
354install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
355install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
356install -m 755 contrib/redhat/gnome-ssh-askpass.{sh,csh} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
357%endif
358
359%if %{no_gnome_askpass}
360rm -f $RPM_BUILD_ROOT/etc/profile.d/gnome-ssh-askpass.*
361%endif
362
363# for contrib package
364install -m 0755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
365install -m 0644 contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
366mv contrib/README contrib/README.contrib
367
368perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
369
370%clean
371rm -rf $RPM_BUILD_ROOT
372
373%triggerun server -- ssh-server
374if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
375        touch /var/run/sshd.restart
376fi
377
378%triggerun server -- openssh-server < 2.5.0p1
379# Count the number of HostKey and HostDsaKey statements we have.
380gawk    'BEGIN {IGNORECASE=1}
381         /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
382         END {exit sawhostkey}' /etc/ssh/sshd_config
383# And if we only found one, we know the client was relying on the old default
384# behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
385# specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
386# one nullifies the default, which would have loaded both.
387if [ $? -eq 1 ] ; then
388        echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
389        echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
390fi
391
392%triggerpostun server -- ssh-server
393if [ "$1" != 0 ] ; then
394        /sbin/chkconfig --add sshd
395        if test -f /var/run/sshd.restart ; then
396                rm -f /var/run/sshd.restart
397                # /sbin/service sshd start > /dev/null 2>&1 || :
398                /sbin/service sshd start
399        fi
400fi
401
402%pre server
403%{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
404%{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
405        -g sshd -M -r sshd 2>/dev/null || :
406
407%post server
408/sbin/chkconfig --add sshd
409
410%postun server
411# /sbin/service sshd condrestart > /dev/null 2>&1 || :
412/sbin/service sshd condrestart
413exit 0
414
415%preun server
416if [ "$1" = 0 ]
417then
418        /sbin/service sshd stop > /dev/null 2>&1 || :
419        /sbin/chkconfig --del sshd
420fi
421
422%files
423%defattr(-,root,root)
424%doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* RFC* TODO WARNING*
425%attr(0755,root,root) %{_bindir}/scp
426%attr(0644,root,root) %{_mandir}/man1/scp.1*
427%attr(0755,root,root) %dir %{_sysconfdir}/ssh
428%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
429%attr(644,root,root) %{_mandir}/man5/moduli.5*
430%if ! %{rescue}
431%attr(0755,root,root) %{_bindir}/ssh-keygen
432%attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
433%attr(0755,root,root) %dir %{_libexecdir}/openssh
434%attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
435%attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
436%endif
437%if %{scard}
438%attr(0755,root,root) %dir %{_datadir}/openssh
439%attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
440%endif
441
442%files clients
443%defattr(-,root,root)
444%attr(0755,root,root) %{_bindir}/ssh
445%attr(0644,root,root) %{_mandir}/man1/ssh.1*
446%attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
447%attr(0644,root,root) %{_mandir}/man1/slogin.1*
448%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
449%attr(-,root,root) %{_bindir}/slogin
450%if ! %{rescue}
451%attr(0755,root,root) %{_bindir}/ssh-agent
452%attr(0755,root,root) %{_bindir}/ssh-add
453%attr(0755,root,root) %{_bindir}/ssh-keyscan
454%attr(0755,root,root) %{_bindir}/sftp
455%attr(0755,root,root) %{_bindir}/ssh-copy-id
456%attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
457%attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
458%attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
459%attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
460%attr(0644,root,root) %{_mandir}/man1/sftp.1*
461%attr(0644,root,root) %{_mandir}/man1/ssh-copy-id.1*
462%attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
463%endif
464
465%if ! %{rescue}
466%files server
467%defattr(-,root,root)
468%dir %attr(0711,root,root) %{_var}/empty/sshd
469%dir %attr(0755,root,root) %{_var}/empty/sshd/etc
470%ghost %verify(not md5 size mtime) %{_var}/empty/sshd/etc/localtime
471%attr(0755,root,root) %{_sbindir}/sshd
472%attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
473%attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
474%attr(0644,root,root) %{_mandir}/man8/sshd.8*
475%attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
476%attr(0755,root,root) %dir %{_sysconfdir}/ssh
477%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
478%attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
479%attr(0755,root,root) %config /etc/rc.d/init.d/sshd
480%attr(0755,root,root) %config /etc/sysconfig/sshd
481%endif
482
483%if ! %{no_gnome_askpass}
484%files askpass-gnome
485%defattr(-,root,root)
486%attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
487%attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
488%endif
489
490
491%changelog
492* Fri Jan 15 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.8p2-5
493- add patch1030 for fix CVE-2016-0777, 0778(roaming)
494
495* Wed Feb 11 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.8p2-4
496- rebuild with openssl 1.0.1l (2nd)
497
498* Mon Feb  9 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.8p2-3.1
499- rebuild with openssl 1.0.1l
500
501* Tue Apr  8 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.8p2-3
502- add patch1010 for fix CVE-2014-2532 (wildcards on AcceptEnv)
503- add patch1020 for fix CVE-2014-2653 (SSHFP DNS RR)
504
505* Wed Mar 13 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.8p2-2
506- add patch1000 for fix CVE-2010-5107 (login interval)
507
508* Sun May  8 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.8p2-1
509- new upstream release
510
511* Tue Apr 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-2
512- add our own sshd.init based on fedora's sshd.init
513  - generate ECDSA host key.
514
515* Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-1
516- new upstream release
517
518* Tue Jan 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.7p1-1
519- new upstream release
520
521* Mon Jan 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.6p1-1
522- new upstream release
523- obsolete contrib subpackage, move ssh-copy-id to client subpackage
524
525* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.5p1-4
526- rebuilt with openssl 1.0.0c
527
528* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-3
529- drop x11-askpass, add Obsoletes: openssh-askpass
530- add BR: groff
531- enable --with-libedit option, add BR: libedit-devel
532- remove unrecognized option '--with-rsh'
533
534* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-2
535- add BR: xorg-x11-xauth for X11 forwarding support
536
537* Thu Apr 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-1
538- new upstream release
539- update patch0,2
540- drop patch3,22
541
542* Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2p1-1
543- new upstream release
544
545* Tue Jul 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1p1-1
546- new upstream release
547
548* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0p1-2
549- rebuild with xorg-x11-7.3
550
551* Fri Apr 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.0p1-1
552- new upstream release with security fix (CVE-2008-1483)
553- drop patch31 which is included in new release (This was for CVE-2008-1483)
554
555* Tue Apr 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.9p1-1
556- new upstream release with security fix ("ForceCommand" Directive)
557- turn on daemon restart message
558- new versioning policy
559
560* Mon Nov 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.7p1-0vl2
561- add /var/empty/sshd/etc/localtime to fix secure log bad timestamps
562
563* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7p1-0vl1
564- new upstream release
565
566* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl2
567- build with -fpie/-pie by default.
568- enable ipv6 by default.
569
570* Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl1
571- new upstream release
572
573* Wed Nov 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.5p1-0vl1
574- new upstream release
575
576* Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4p1-0vl1
577- new upstream release
578
579* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p2-0vl1
580- new upstream release
581
582* Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p1-0vl1
583- new upstream release
584- remove build6x stuff
585- remove libgnome-devel from BuildRequires
586- cleanup BuildRequires
587- drop Patch200, it is merged in upstream.
588- import patches(25-35) from FC-devel
589
590* Mon Apr 10 2006 IWAI, Masaharu <iwai@alib.jp> 4.2p1-0vl3
591- SECURITY FIX: CVE-2006-0225
592  - add scp no system patch ( Patch200 ): from Fedora Core 4 4.2p1-fc4.10
593- update BuildPreReq: s/XFree86-devel/XOrg-devel/
594- fix BuildPreReq for GNOME: gnome-libs-devel ( GNOME1 ) was always used
595  - When GNOME2 is used, using libgnome-devel
596  - add BuildPreReq: gtk2-devel for GNOME2
597
598* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl2
599- rebuild with gtk+-2.8 final
600
601* Sun Sep  4 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl1
602- new upstream release
603- build with gtk+-2.7
604
605* Sun May 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1p1-0vl1
606- new upstream release
607
608* Fri Apr 01 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 4.0p1-0vl2
609- cleanup obsolete patches and added patches from fedora
610
611* Wed Mar 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0p1-0vl1
612- new upstream release
613
614* Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9pl1-0vl1
615- new upstream release
616
617* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.1p1-0vl1
618- new upstream release
619
620* Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl2
621- rebuild with openssl-0.9.7d
622
623* Fri Feb 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl1
624- new upstream release
625
626* Thu Oct  2 2003 IWAI, Masaharu <iwai@alib.jp> 3.7.1p2-0vl2
627- create contrib package
628
629* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p2-0vl1
630- new upstream release
631- fix security issue: http://www.openssh.com/txt/sshpam.adv
632
633* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p1-0vl1
634- new upstream release
635- fix security issue: http://www.openssh.com/txt/buffer.adv
636
637* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7p1-0vl1
638- new upstream release
639
640* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1.1
641- rebuild with gtk2
642
643* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1
644- new upstream release
645
646* Sat Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.5p1-0vl2
647- rebuild with new tool chain
648
649* Tue Oct 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5p1-0vl1
650- new upstream release
651- merge with upstream spec (drop anonymous mmap patch, suid of ssh)
652
653* Tue Aug 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl3
654- change some defines in spec files
655
656* Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl2
657- add patch110 ( 3.4p1 does not include mmap-fallback patch )
658
659* Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl1
660- new upstream release
661  - security fix
662- drop patch10
663
664* Wed Jun 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl2
665- add patch from Solar Designer to make privsep work with a 2.2 kernel.
666
667* Sun Jun 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl1
668- new upstream release
669- add {sshd,ssh}_config.5 manpages
670- add ssh-keysign
671
672* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.3p1-0vl1
673- new upstream release
674
675* Sat May 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2p1-0vl1
676- new upstream release
677- drop patch1
678
679* Fri Mar 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1p1-2vl1
680- new upstream release
681- merged with rawhide release.
682- drop Patch101 (merged in upstream)
683
684* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 3.0.2p1-2vl2
685- seurity patch for off-by-one bug
686
687* Wed Jan 30 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.2p-2vl1
688- merged with Rawhide 3.0.2p1-2
689
690* Sun Dec 02 2001 Toru Sagami <sagami@vinelinux.org>
691- updated to 3.0.2p1
692
693* Mon Nov 19 2001 Toru Sagami <sagami@vinelinux.org>
694- updated to 3.0.1p1
695
696* Thu Nov 08 2001 Toru Sagami <sagami@vinelinux.org> 3.0p1-0vl0
697- updated to 3.0p1
698
699* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl2
700- add japanese summery and descriptions.
701- update x11-askpass 1.2.5
702
703* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl1
704- update to openssh-2.9.9p2
705
706* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org> 2.5.2p2-0vl3
707- rebuilt with openssl-0.9.6b
708
709* Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 2.5.2p2-0vl2
710- do not Permit RootLogin
711
712* Tue Mar 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p2-0vl1
713- update to openssh-2.5.2p2
714
715* Wed Mar 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p1-0vl1
716- update to openssh-2.5.2p1
717
718* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
719- update to openssh-2.5.1p2
720
721* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
722- update to openssh-2.5.1p1
723
724* Wed Feb 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p1-0vl1
725- update to openssh-2.5.1p1
726
727* Thu Dec 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl4
728- remove suid bit from ssh
729
730* Tue Dec 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl3
731- moved man dir to /usr/share/man
732
733* Wed Dec 06 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl2
734- fixed askpass's link in ssh-add
735- partially used rpmmacros
736
737* Fri Nov 10 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl1
738- update to 2.3.0p1
739- update x11-askpass 1.0.3
740
741* Mon Oct 18 2000 Damien Miller <djm@mindrot.org>
742- Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the
743  Redhat 7.0 spec file
744
745* Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0p2-2vl1
746- rebuild for Vine Linux
747
748* Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
749- Use RPM configure macro
750* Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
751- Some surgery to sshd.init (generate keys at runtime)
752- Cleanup of groups and removal of keygen calls
753* Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
754- Make building of X11-askpass and gnome-askpass optional
755* Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
756- Glob manpages to catch compressed files
757* Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
758- Updated for new location
759- Updated for new gnome-ssh-askpass build
760* Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
761- Added Jim Knoble's <jmknoble@pobox.com> askpass
762* Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
763- Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
764* Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
765- Added 'Obsoletes' directives
766* Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
767- Use make install
768- Subpackages
769* Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
770- Added links for slogin
771- Fixed perms on manpages
772* Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
773- Renamed init script
774* Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
775- Back to old binary names
776* Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
777- Use autoconf
778- New binary names
779* Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
780- Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
781
Note: See TracBrowser for help on using the repository browser.