source: projects/specs/branches/6/o/openssh/openssh-vl.spec @ 11236

Revision 11236, 27.2 KB checked in by iwamoto, 6 years ago (diff)

openssh: fix CVE-2017-15906

Line 
1%define ver 7.2p2
2%define rel 3%{_dist_release}
3
4# SELinux
5%define WITH_SELINUX 0
6
7# OpenSSH privilege separation requires a user & group ID
8%define sshd_uid    74
9%define sshd_gid    74
10
11# Version of ssh-askpass
12%define aversion 1.2.4.1
13
14# Do we want to disable building of gnome-askpass? (1=yes 0=no)
15%define no_gnome_askpass 0
16
17# Use GTK2 for gnome-ssh-askpass
18%define gtk2 1
19
20# Build position-independent executables (requires toolchain support)?
21%define pie 1
22
23# Do we want to link against a static libcrypto? (1=yes 0=no)
24%define static_libcrypto 0
25
26# Do we want smartcard support (1=yes 0=no)
27%define scard 0
28
29# Disable IPv6 (avoids DNS hangs on some glibc versions)
30%define noip6 0
31
32# Do we want kerberos5 support (1=yes 0=no)
33%define kerberos5 0
34
35# Reserve options to override askpass settings with:
36# rpm -ba|--rebuild --define 'skip_xxx 1'
37%{?skip_gnome_askpass:%define no_gnome_askpass 1}
38
39# Options for static OpenSSL link:
40# rpm -ba|--rebuild --define "static_openssl 1"
41%{?static_openssl:%define static_libcrypto 1}
42
43# Options for Smartcard support: (needs libsectok and openssl-engine)
44# rpm -ba|--rebuild --define "smartcard 1"
45%{?smartcard:%define scard 1}
46
47# Option to disable ipv6
48# rpm -ba|--rebuild --define "noipv6 1"
49%{?noipv6:%define noip6 1}
50
51# Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
52%define rescue 0
53%{?build_rescue:%define rescue 1}
54
55# Turn off some stuff for resuce builds
56%if %{rescue}
57%define kerberos5 0
58%endif
59
60Summary: The OpenSSH implementation of SSH.
61Summary(ja): OpenSSH - フリーの Secure Shell (SSH) の実装
62Name: openssh
63Version: %{ver}
64Release: %{rel}
65URL: http://www.openssh.com/portable.html
66
67Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
68
69Patch0: openssh-6.4p1-vine.patch
70Patch4: openssh-7.0p1-vendor.patch
71Patch12: openssh-selinux.patch
72Patch20: openssh-3.9p1-gssapimitm.patch
73Patch21: openssh-3.9p1-safe-stop.patch
74Patch24: openssh-5.7p1-fromto-remote.patch
75Patch26: openssh-5.2p1-pam-no-stack.patch
76# Patch27: openssh-5.1p1-log-in-chroot.patch
77Patch30: openssh-5.6p1-exit-deadlock.patch
78# Patch31: openssh-3.9p1-skip-used.patch
79Patch35: openssh-5.1p1-askpass-progress.patch
80
81# secuirty
82Patch100: openssh-7.2p2_CVE-2017-15906.patch
83
84# Vine Source
85Source100: sshd.init.vine
86Source110: sshd.sysconfig.vine
87
88License: BSD
89Group: Applications/Internet
90BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
91
92Obsoletes: ssh
93
94BuildRequires: perl, openssl-devel, tcp_wrappers
95BuildRequires: util-linux
96%if "%{_dist_release}" >= "vl7"
97BuildRequires: libdb-devel
98%else
99BuildRequires: db4-devel
100%endif
101BuildRequires: pam-devel
102BuildRequires: zlib-devel
103%if ! %{no_gnome_askpass}
104BuildRequires: libX11-devel
105BuildRequires: gtk2-devel
106%endif
107BuildRequires: xorg-x11-xauth
108BuildRequires: groff
109BuildRequires: libedit-devel
110
111Vendor: Project Vine
112Distribution: Vine Linux
113Packager: daisuke
114
115%package clients
116Summary: OpenSSH clients.
117Summary(ja): OpenSSH Secure Shell プロトコルクライアント
118Requires: openssh = %{version}-%{release}
119Group: Applications/Internet
120Obsoletes: ssh-clients
121Obsoletes: openssh-contrib
122
123%package server
124Summary: The OpenSSH server daemon.
125Summary(ja): OpenSSH Secure Shell プロトコルサーバ (sshd)
126Group: System Environment/Daemons
127Obsoletes: ssh-server
128Requires(post): openssh = %{version}-%{release}
129Requires(post): chkconfig
130Requires(pre): shadow-utils
131Requires(post): initscripts >= 5.20
132Requires: pam
133
134%package askpass-gnome
135Summary: A passphrase dialog for OpenSSH, X, and GNOME.
136Summary(ja): OpenSSH GNOME パスフレーズ入力ダイアログ
137Group: Applications/Internet
138Requires: openssh = %{version}-%{release}
139Obsoletes: ssh-extras
140Obsoletes: openssh-askpass < 5.5p1-3vl6
141Provides: openssh-askpass = %{version}-%{release}
142
143%description
144SSH (Secure SHell) is a program for logging into and executing
145commands on a remote machine. SSH is intended to replace rlogin and
146rsh, and to provide secure encrypted communications between two
147untrusted hosts over an insecure network. X11 connections and
148arbitrary TCP/IP ports can also be forwarded over the secure channel.
149
150OpenSSH is OpenBSD's version of the last free version of SSH, bringing
151it up to date in terms of security and features, as well as removing
152all patented algorithms to separate libraries.
153
154This package includes the core files necessary for both the OpenSSH
155client and server. To make this package useful, you should also
156install openssh-clients, openssh-server, or both.
157
158#'
159%description -l ja
160OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
161Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
162するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
163ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
164可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
165な通信路の中を通すことができます。
166
167OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
168最新のセキュリティと機能を提供しています。またすべての特許がからむ
169アルゴリズムは分割したライブラリにわかれています。
170
171このパッケージは OpenSSH のクライアントとサーバの両方で必要とされる
172コアのファイルを含んでいます。実際に使用するにはこのパッケージの他に
173openssh-clients および/または openssh-server が必要です。
174
175%description clients
176OpenSSH is a free version of SSH (Secure SHell), a program for logging
177into and executing commands on a remote machine. This package includes
178the clients necessary to make encrypted connections to SSH servers.
179You'll also need to install the openssh package on OpenSSH clients.
180
181#'
182%description -l ja clients
183OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
184Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
185するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
186ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
187可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
188な通信路の中を通すことができます。
189
190OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
191最新のセキュリティと機能を提供しています。またすべての特許がからむ
192アルゴリズムは分割したライブラリにわかれています。
193
194このパッケージは OpenSSH をクライアントとして使用する場合に
195必要なものを含んでいます。
196
197
198%description server
199OpenSSH is a free version of SSH (Secure SHell), a program for logging
200into and executing commands on a remote machine. This package contains
201the secure shell daemon (sshd). The sshd daemon allows SSH clients to
202securely connect to your SSH server. You also need to have the openssh
203package installed.
204
205%description -l ja server
206OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
207Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
208するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
209ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
210可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
211な通信路の中を通すことができます。
212
213OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
214最新のセキュリティと機能を提供しています。またすべての特許がからむ
215アルゴリズムは分割したライブラリにわかれています。
216
217このパッケージは OpenSSH をサーバとして使用する場合に必要な
218デーモンなどを含んでいます。
219
220%description askpass-gnome
221OpenSSH is a free version of SSH (Secure SHell), a program for logging
222into and executing commands on a remote machine. This package contains
223an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
224environment.
225
226%description -l ja askpass-gnome
227OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
228Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
229するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
230ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
231可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
232な通信路の中を通すことができます。
233
234OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
235最新のセキュリティと機能を提供しています。またすべての特許がからむ
236アルゴリズムは分割したライブラリにわかれています。
237
238このパッケージは GNOME 用のパスフレーズ入力ダイアログを含んでいます。
239
240%prep
241
242%setup -q
243%patch0 -p1 -b .vine
244%patch4 -p1 -b .vendor
245
246%if %{WITH_SELINUX}
247#SELinux
248%patch12 -p1 -b .selinux
249%endif
250
251%patch21 -p1 -b .safe-stop
252%patch24 -p1 -b .fromto-remote
253%patch26 -p1 -b .stack
254# %patch27 -p1 -b .log-chroot
255%patch30 -p1 -b .exit-deadlock
256%patch35 -p1 -b .progress
257
258%patch100 -p1 -b .CVE-2017-15906
259
260autoreconf
261
262
263%build
264CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
265%if %{rescue}
266CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
267%endif
268%if %{pie}
269%ifarch s390 s390x sparc sparc64
270CFLAGS="$CFLAGS -fPIE"
271%else
272CFLAGS="$CFLAGS -fpie"
273%endif
274export CFLAGS
275LDFLAGS="$LDFLAGS -pie"; export LDFLAGS
276%endif
277
278%configure \
279        --sysconfdir=%{_sysconfdir}/ssh \
280        --libexecdir=%{_libexecdir}/openssh \
281        --datadir=%{_datadir}/openssh \
282        --with-tcp-wrappers \
283        --with-default-path=/usr/local/bin:/bin:/usr/bin \
284        --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
285        --with-privsep-path=%{_var}/empty/sshd \
286        --enable-vendor-patchlevel="VL-%{version}-%{release}" \
287        --with-libedit \
288        --with-xauth=/usr/bin/xauth \
289%if %{scard}
290        --with-smartcard \
291%endif
292%if %{noip6}
293        --with-ipv4-default \
294%endif
295%if %{rescue}
296        --without-pam --with-md5-passwords
297%else
298        --with-pam
299%endif
300
301%if %{static_libcrypto}
302perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
303%endif
304
305make
306
307%if %{gtk2}
308        gtk2=yes
309%else
310        gtk2=no
311%endif
312
313%if ! %{no_gnome_askpass}
314pushd contrib
315if [ $gtk2 = yes ]; then
316        make gnome-ssh-askpass2
317        mv gnome-ssh-askpass2 gnome-ssh-askpass
318else
319        make gnome-ssh-askpass1
320        mv gnome-ssh-askpass1 gnome-ssh-askpass
321fi
322popd
323%endif
324
325%install
326rm -rf $RPM_BUILD_ROOT
327mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
328mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
329mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
330mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd/etc
331
332make install DESTDIR=$RPM_BUILD_ROOT
333
334touch $RPM_BUILD_ROOT%{_var}/empty/sshd/etc/localtime
335install -d $RPM_BUILD_ROOT/etc/pam.d/
336install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
337install -d $RPM_BUILD_ROOT/etc/sysconfig/
338install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
339install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
340install -m755 %{SOURCE100} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
341install -m644 %{SOURCE110} $RPM_BUILD_ROOT/etc/sysconfig/sshd
342
343%if ! %{scard}
344        rm -f $RPM_BUILD_ROOT%{_datadir}/openssh/Ssh.bin
345%endif
346
347%if ! %{no_gnome_askpass}
348install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
349install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
350install -m 755 contrib/redhat/gnome-ssh-askpass.{sh,csh} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
351%endif
352
353%if %{no_gnome_askpass}
354rm -f $RPM_BUILD_ROOT/etc/profile.d/gnome-ssh-askpass.*
355%endif
356
357# for contrib package
358install -m 0755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
359install -m 0644 contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
360mv contrib/README contrib/README.contrib
361
362perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
363
364%clean
365rm -rf $RPM_BUILD_ROOT
366
367%triggerun server -- ssh-server
368if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
369        touch /var/run/sshd.restart
370fi
371
372%triggerun server -- openssh-server < 2.5.0p1
373# Count the number of HostKey and HostDsaKey statements we have.
374gawk    'BEGIN {IGNORECASE=1}
375         /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
376         END {exit sawhostkey}' /etc/ssh/sshd_config
377# And if we only found one, we know the client was relying on the old default
378# behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
379# specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
380# one nullifies the default, which would have loaded both.
381if [ $? -eq 1 ] ; then
382        echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
383        echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
384fi
385
386%triggerpostun server -- ssh-server
387if [ "$1" != 0 ] ; then
388        /sbin/chkconfig --add sshd
389        if test -f /var/run/sshd.restart ; then
390                rm -f /var/run/sshd.restart
391                # /sbin/service sshd start > /dev/null 2>&1 || :
392                /sbin/service sshd start
393        fi
394fi
395
396%pre server
397%{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
398%{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
399        -g sshd -M -r sshd 2>/dev/null || :
400
401%post server
402/sbin/chkconfig --add sshd
403
404%postun server
405# /sbin/service sshd condrestart > /dev/null 2>&1 || :
406/sbin/service sshd condrestart
407exit 0
408
409%preun server
410if [ "$1" = 0 ]
411then
412        /sbin/service sshd stop > /dev/null 2>&1 || :
413        /sbin/chkconfig --del sshd
414fi
415
416%files
417%defattr(-,root,root)
418%doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* RFC* TODO WARNING*
419%attr(0755,root,root) %{_bindir}/scp
420%attr(0644,root,root) %{_mandir}/man1/scp.1*
421%attr(0755,root,root) %dir %{_sysconfdir}/ssh
422%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
423%attr(644,root,root) %{_mandir}/man5/moduli.5*
424%if ! %{rescue}
425%attr(0755,root,root) %{_bindir}/ssh-keygen
426%attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
427%attr(0755,root,root) %dir %{_libexecdir}/openssh
428%attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
429%attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
430%endif
431%if %{scard}
432%attr(0755,root,root) %dir %{_datadir}/openssh
433%attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
434%endif
435
436%files clients
437%defattr(-,root,root)
438%attr(0755,root,root) %{_bindir}/ssh
439%attr(0644,root,root) %{_mandir}/man1/ssh.1*
440%attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
441# %attr(0644,root,root) %{_mandir}/man1/slogin.1*
442%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
443# %attr(-,root,root) %{_bindir}/slogin
444%if ! %{rescue}
445%attr(0755,root,root) %{_bindir}/ssh-agent
446%attr(0755,root,root) %{_bindir}/ssh-add
447%attr(0755,root,root) %{_bindir}/ssh-keyscan
448%attr(0755,root,root) %{_bindir}/sftp
449%attr(0755,root,root) %{_bindir}/ssh-copy-id
450%attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
451%attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
452%attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
453%attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
454%attr(0644,root,root) %{_mandir}/man1/sftp.1*
455%attr(0644,root,root) %{_mandir}/man1/ssh-copy-id.1*
456%attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
457%endif
458
459%if ! %{rescue}
460%files server
461%defattr(-,root,root)
462%dir %attr(0711,root,root) %{_var}/empty/sshd
463%dir %attr(0755,root,root) %{_var}/empty/sshd/etc
464%ghost %verify(not md5 size mtime) %{_var}/empty/sshd/etc/localtime
465%attr(0755,root,root) %{_sbindir}/sshd
466%attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
467%attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
468%attr(0644,root,root) %{_mandir}/man8/sshd.8*
469%attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
470%attr(0755,root,root) %dir %{_sysconfdir}/ssh
471%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
472%attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
473%attr(0755,root,root) %config /etc/rc.d/init.d/sshd
474%attr(0755,root,root) %config /etc/sysconfig/sshd
475%endif
476
477%if ! %{no_gnome_askpass}
478%files askpass-gnome
479%defattr(-,root,root)
480%attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
481%attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
482%endif
483
484
485%changelog
486* Tue Nov 14 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.2p2-3
487- add Patch100 for fix CVE-2017-15906 (sftp-server)
488
489* Fri Aug  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.2p2-2
490- disabled rsa1 hostkey generation.
491
492* Sat Jul 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.2p2-1
493- new upstream release.
494
495* Wed Mar  9 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.2p1-1
496- new upstream release
497- built with openssl 1.0.2g
498- drop slogin command and manual, this is upstream change.
499
500* Sun Jan 17 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 7.1p2-1
501- update to 7.1p2
502
503* Mon Dec 28 2015 Daisuke SUZUKI <daisuke@vinelinux.org> 7.1p1-1
504- update to 7.1p1
505- remove patch100 to use default value "prohibit-password" for PermitRootLogin
506
507* Tue Oct 14 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.7p1-1
508- update to 6.7p1
509- fix sshd.init
510
511* Thu Aug 07 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.6p1-1
512- update to 6.6p1
513- remove BR: sharutils
514- add BR: libdb-devel instead of db4-devel
515
516* Tue Feb 04 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 6.5p1-1
517- update to 6.5p1
518- update sshd_config
519  - generate ED25519 host key.
520
521* Tue Nov 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 6.4p1-1
522- update to 6.4p1
523
524* Mon May 20 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2p2-1
525- update to 6.2p2
526
527* Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2p1-1
528- update to 6.2p1
529
530* Fri Nov  2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.1p1-1
531- new upstream release
532- add -with-xauth option in configure
533- patch4, 30, 35 are updated from fc18
534
535* Mon May 07 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0p1-1
536- new upstream release
537
538* Tue Mar 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 5.9p1-1
539- new upstream release
540
541* Sun May  8 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.8p2-1
542- new upstream release
543
544* Tue Apr 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-2
545- add our own sshd.init based on fedora's sshd.init
546  - generate ECDSA host key.
547
548* Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-1
549- new upstream release
550
551* Tue Jan 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.7p1-1
552- new upstream release
553
554* Mon Jan 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.6p1-1
555- new upstream release
556- obsolete contrib subpackage, move ssh-copy-id to client subpackage
557
558* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.5p1-4
559- rebuilt with openssl 1.0.0c
560
561* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-3
562- drop x11-askpass, add Obsoletes: openssh-askpass
563- add BR: groff
564- enable --with-libedit option, add BR: libedit-devel
565- remove unrecognized option '--with-rsh'
566
567* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-2
568- add BR: xorg-x11-xauth for X11 forwarding support
569
570* Thu Apr 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-1
571- new upstream release
572- update patch0,2
573- drop patch3,22
574
575* Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2p1-1
576- new upstream release
577
578* Tue Jul 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1p1-1
579- new upstream release
580
581* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0p1-2
582- rebuild with xorg-x11-7.3
583
584* Fri Apr 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.0p1-1
585- new upstream release with security fix (CVE-2008-1483)
586- drop patch31 which is included in new release (This was for CVE-2008-1483)
587
588* Tue Apr 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.9p1-1
589- new upstream release with security fix ("ForceCommand" Directive)
590- turn on daemon restart message
591- new versioning policy
592
593* Mon Nov 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.7p1-0vl2
594- add /var/empty/sshd/etc/localtime to fix secure log bad timestamps
595
596* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7p1-0vl1
597- new upstream release
598
599* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl2
600- build with -fpie/-pie by default.
601- enable ipv6 by default.
602
603* Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl1
604- new upstream release
605
606* Wed Nov 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.5p1-0vl1
607- new upstream release
608
609* Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4p1-0vl1
610- new upstream release
611
612* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p2-0vl1
613- new upstream release
614
615* Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p1-0vl1
616- new upstream release
617- remove build6x stuff
618- remove libgnome-devel from BuildRequires
619- cleanup BuildRequires
620- drop Patch200, it is merged in upstream.
621- import patches(25-35) from FC-devel
622
623* Mon Apr 10 2006 IWAI, Masaharu <iwai@alib.jp> 4.2p1-0vl3
624- SECURITY FIX: CVE-2006-0225
625  - add scp no system patch ( Patch200 ): from Fedora Core 4 4.2p1-fc4.10
626- update BuildPreReq: s/XFree86-devel/XOrg-devel/
627- fix BuildPreReq for GNOME: gnome-libs-devel ( GNOME1 ) was always used
628  - When GNOME2 is used, using libgnome-devel
629  - add BuildPreReq: gtk2-devel for GNOME2
630
631* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl2
632- rebuild with gtk+-2.8 final
633
634* Sun Sep  4 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl1
635- new upstream release
636- build with gtk+-2.7
637
638* Sun May 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1p1-0vl1
639- new upstream release
640
641* Fri Apr 01 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 4.0p1-0vl2
642- cleanup obsolete patches and added patches from fedora
643
644* Wed Mar 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0p1-0vl1
645- new upstream release
646
647* Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9pl1-0vl1
648- new upstream release
649
650* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.1p1-0vl1
651- new upstream release
652
653* Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl2
654- rebuild with openssl-0.9.7d
655
656* Fri Feb 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl1
657- new upstream release
658
659* Thu Oct  2 2003 IWAI, Masaharu <iwai@alib.jp> 3.7.1p2-0vl2
660- create contrib package
661
662* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p2-0vl1
663- new upstream release
664- fix security issue: http://www.openssh.com/txt/sshpam.adv
665
666* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p1-0vl1
667- new upstream release
668- fix security issue: http://www.openssh.com/txt/buffer.adv
669
670* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7p1-0vl1
671- new upstream release
672
673* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1.1
674- rebuild with gtk2
675
676* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1
677- new upstream release
678
679* Sun Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.5p1-0vl2
680- rebuild with new tool chain
681
682* Tue Oct 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5p1-0vl1
683- new upstream release
684- merge with upstream spec (drop anonymous mmap patch, suid of ssh)
685
686* Tue Aug 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl3
687- change some defines in spec files
688
689* Thu Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl2
690- add patch110 ( 3.4p1 does not include mmap-fallback patch )
691
692* Thu Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl1
693- new upstream release
694  - security fix
695- drop patch10
696
697* Wed Jun 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl2
698- add patch from Solar Designer to make privsep work with a 2.2 kernel.
699
700* Sun Jun 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl1
701- new upstream release
702- add {sshd,ssh}_config.5 manpages
703- add ssh-keysign
704
705* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.3p1-0vl1
706- new upstream release
707
708* Sat May 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2p1-0vl1
709- new upstream release
710- drop patch1
711
712* Fri Mar 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1p1-2vl1
713- new upstream release
714- merged with rawhide release.
715- drop Patch101 (merged in upstream)
716
717* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 3.0.2p1-2vl2
718- seurity patch for off-by-one bug
719
720* Wed Jan 30 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.2p-2vl1
721- merged with Rawhide 3.0.2p1-2
722
723* Sun Dec 02 2001 Toru Sagami <sagami@vinelinux.org>
724- updated to 3.0.2p1
725
726* Mon Nov 19 2001 Toru Sagami <sagami@vinelinux.org>
727- updated to 3.0.1p1
728
729* Thu Nov 08 2001 Toru Sagami <sagami@vinelinux.org> 3.0p1-0vl0
730- updated to 3.0p1
731
732* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl2
733- add japanese summery and descriptions.
734- update x11-askpass 1.2.5
735
736* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl1
737- update to openssh-2.9.9p2
738
739* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org> 2.5.2p2-0vl3
740- rebuilt with openssl-0.9.6b
741
742* Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 2.5.2p2-0vl2
743- do not Permit RootLogin
744
745* Tue Mar 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p2-0vl1
746- update to openssh-2.5.2p2
747
748* Wed Mar 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p1-0vl1
749- update to openssh-2.5.2p1
750
751* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
752- update to openssh-2.5.1p2
753
754* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
755- update to openssh-2.5.1p1
756
757* Wed Feb 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p1-0vl1
758- update to openssh-2.5.1p1
759
760* Thu Dec 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl4
761- remove suid bit from ssh
762
763* Tue Dec 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl3
764- moved man dir to /usr/share/man
765
766* Wed Dec 06 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl2
767- fixed askpass's link in ssh-add
768- partially used rpmmacros
769
770* Fri Nov 10 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl1
771- update to 2.3.0p1
772- update x11-askpass 1.0.3
773
774* Wed Oct 18 2000 Damien Miller <djm@mindrot.org>
775- Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the
776  Redhat 7.0 spec file
777
778* Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0p2-2vl1
779- rebuild for Vine Linux
780
781* Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
782- Use RPM configure macro
783* Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
784- Some surgery to sshd.init (generate keys at runtime)
785- Cleanup of groups and removal of keygen calls
786* Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
787- Make building of X11-askpass and gnome-askpass optional
788* Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
789- Glob manpages to catch compressed files
790* Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
791- Updated for new location
792- Updated for new gnome-ssh-askpass build
793* Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
794- Added Jim Knoble's <jmknoble@pobox.com> askpass
795* Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
796- Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
797* Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
798- Added 'Obsoletes' directives
799* Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
800- Use make install
801- Subpackages
802* Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
803- Added links for slogin
804- Fixed perms on manpages
805* Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
806- Renamed init script
807* Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
808- Back to old binary names
809* Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
810- Use autoconf
811- New binary names
812* Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
813- Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
814
815
Note: See TracBrowser for help on using the repository browser.