source: projects/specs/branches/6/m/mono/mono-vl.spec @ 3807

Revision 3807, 27.7 KB checked in by owa, 13 years ago (diff)

update:mono,xsp,python-imaging

Line 
1Summary: .NET runtime environment
2Summary(ja): .NET ランタイム環境
3Name: mono
4Version: 2.10.2
5Release: 1%{?_dist_release}
6Group: Development/Languages
7License: GPL, LGPL, MIT X11
8URL: http://www.mono-project.com/
9Source0: http://ftp.novell.com/pub/mono/sources/mono/%{name}-%{version}.tar.bz2
10Source1: monodir.c
11Patch1: mono-2.10.1-ppc-len.patch
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: bison
14BuildRequires: glib2-devel
15BuildRequires: pkgconfig
16BuildRequires: libicu-devel
17BuildRequires: libgdiplus-devel >= 2.0
18BuildRequires: zlib-devel
19# JIT only availible on these:
20ExclusiveArch: %{ix86} x86_64 ppc ia64 s390 s390x armv4l sparc
21Obsoletes: %{name}-jscript < 2.8
22Obsoletes: %{name}-data-sybase < 2.8
23Obsoletes: %{name}-data-firebird < 2.8
24Obsoletes: bytefx-data-mysql < 2.8
25Distribution: Vine Linux
26Vendor: Project Vine
27Packager: owa
28
29%description
30The Mono runtime implements a JIT engine for the ECMA CLI
31virtual machine (as well as a byte code interpreter, the
32class loader, the garbage collector, threading system and
33metadata access libraries.
34
35%description -l ja
36Mono ランタイムは ECMA CLI 仮想機械用 JIT エンジンの実装です。バイト
37コードインタプリタ、クラスローダ、ガベージコレクタ、スレッドシステム
38およびメタデータアクセスライブラリの機能を持ちます。
39
40%package core
41Summary: The Mono CIL runtime, suitable for running .NET code
42Summary(ja): .NET の実行に適した Mono CIL ランタイム
43Group: Development/Languages
44Requires: libgdiplus
45
46%description core
47This package contains the core of the Mono runtime including its
48Virtual Machine, Just-in-time compiler, C# compiler, security
49tools and libraries (corlib, XML, System.Security, ZipLib,
50I18N, Cairo and Mono.*).
51
52%package devel
53Summary:        Development tools for Mono
54Summary(ja):    Mono 開発ツール
55Group:          Development/Languages
56Requires:       mono-core = %{version}-%{release}
57Requires:       glib2-devel
58
59%description devel
60This package completes the Mono developer toolchain with the mono profiler,
61assembler and other various tools.
62
63%package nunit
64Summary:        NUnit Testing Framework
65Summary(ja):    NUnit テストフレームワーク
66Group:          Development/Languages
67Requires:       mono-core = %{version}-%{release}
68Requires:       glib2-devel
69
70%description nunit
71NUnit is a unit-testing framework for all .NET languages. Initially
72ported from JUnit, the current release, version 2.2, is the fourth
73major release of this Unit based unit testing tool for Microsoft .NET.
74It is written entirely in C# and  has been completely redesigned to
75take advantage of many .NET language features, for example
76custom attributes and other reflection related capabilities. NUnit
77brings xUnit to all .NET languages.
78
79%package locale-extras
80Summary:        Extra locale information for Mono
81Summary(ja):    Mono 用追加ロケール情報
82Group:          Development/Languages
83Requires:       mono-core = %{version}-%{release}
84
85%description locale-extras
86This package contains assemblies to support I18N applications for
87non-latin alphabets.
88
89%package extras
90Summary:        Provides the infrastructure for running and building daemons and services with Mono as well as various stub assemblies
91Group:          Development/Languages
92Requires:       mono-core = %{version}-%{release}
93
94%description extras
95This package provides the libary and application to run services
96and daemons with Mono. It also includes stubs for the following
97.NET 1.1 and 2.0 assemblies: Microsoft.Vsa,
98System.Configuration.Install, System.Management, System.Messaging.
99
100%package winforms
101Summary:        Windows Forms implementation for Mono
102Group:          Development/Languages
103Requires:       mono-core = %{version}-%{release}
104
105%description winforms
106This package provides a fully managed implementation of
107System.Windows.Forms, the default graphical toolkit for .NET
108applications.
109
110%package web
111Summary:        ASP.NET, Remoting, and Web Services for Mono
112Group:          Development/Languages
113Requires:       mono-core = %{version}-%{release}
114
115%description web
116This package provides the ASP.NET libraries and runtime for
117development of web application, web services and remoting support.
118
119%package data
120Summary:        Database connectivity for Mono
121Group:          Development/Languages
122Requires:       mono-core = %{version}-%{release}
123
124%description data
125This package provides a Mono assembly to facilitate data access
126and manipulation with databases, LDAP compatible directory servers
127and/or XML data exchange. Beyond the ADO.NET, Novell.LDAP and
128System.DirectoryServices assemblies, it also includes a command
129line sql application as well as the Microsoft SQL Server and ODBC
130data providers.
131
132%package data-sqlite
133Summary:        sqlite database connectivity for Mono
134Group:          Development/Languages
135Requires:       mono-core = %{version}-%{release}
136Requires:       sqlite
137
138%description data-sqlite
139This package contains the ADO.NET Data provider for the sqlite
140database.
141
142%package data-oracle
143Summary:        Oracle database connectivity for Mono
144Group:          Development/Languages
145Requires:       mono-core = %{version}-%{release}
146
147%description data-oracle
148This package contains the ADO.NET Data provider for the Oracle
149database.
150
151%package data-postgresql
152Summary:        Postgresql database connectivity for Mono
153Group:          Development/Languages
154Requires:       mono-core = %{version}-%{release}
155
156%description data-postgresql
157This package contains the ADO.NET Data provider for the PostgreSQL
158database.
159
160%package -n ibm-data-db2
161Summary:        IBM DB2 database connectivity for Mono
162Group:          Development/Languages
163Requires:       mono-core = %{version}-%{release}
164
165%description -n ibm-data-db2
166This package contains the ADO.NET Data provider for the IBM DB2
167Universal database.
168
169%package -n monodoc
170Summary:        The Mono documentation system
171Group:          Development/Tools
172Requires:       mono-core = %{version}-%{release}
173Requires:       libgluezilla >= 2.4
174Obsoletes:      monodoc-core <= 2.0-1vl5
175
176%description -n monodoc
177monodoc is the documentation package for the mono .NET environment
178
179## macros
180%define mono_dir %{_prefix}/lib/mono
181%define mono_doc %{_prefix}/lib/monodoc
182%define bin_and_exe(bin, exe) %{_bindir}/%{1} \
183        %{mono_dir}/%{2}.exe \
184        %{mono_dir}/%{2}.exe.* \
185        %{nil}
186%define gac_and_1dll(dll)  %{mono_dir}/gac/%{1} \
187        %{mono_dir}/%{2}/%{1}.dll \
188        %{nil}
189%define gac_and_2dll(dll)  %{mono_dir}/gac/%{1} \
190        %{mono_dir}/%{2}/%{1}.dll \
191        %{mono_dir}/%{3}/%{1}.dll \
192        %{nil}
193%define gac_and_3dll(dll)  %{mono_dir}/gac/%{1} \
194        %{mono_dir}/%{2}/%{1}.dll \
195        %{mono_dir}/%{3}/%{1}.dll \
196        %{mono_dir}/%{4}/%{1}.dll \
197        %{nil}
198
199
200%prep
201%setup -q
202##%patch1 -p1
203
204## These are only needed if there are patches to the runtime
205#rm -f libgc/libtool.m4
206#autoreconf --force --install
207#autoreconf --force --install libgc
208
209## Remove prebuilt binaries
210#rm -rf mcs/class/lib/monolite/*
211
212%build
213gcc -o monodir %{SOURCE1} -DMONODIR=\"%{mono_dir}\"
214
215export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
216%configure \
217        --with-jit=yes \
218        --with-ikvm-native=yes \
219        --with-sigaltstack=no \
220        --with-sgen=no \
221%ifarch ppc
222        --disable-system-aot \
223%endif
224        ;
225
226# don't use parallel builds
227# make %{?_smp_mflags}
228make
229
230
231%install
232[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %{__rm} -rf %{buildroot}
233make install DESTDIR=%{buildroot}
234
235install monodir %{buildroot}%{_bindir}
236
237## Remove unused files
238%{__rm} -f %{buildroot}%{_libdir}/*.la
239%{__rm} -f %{buildroot}%{_libdir}/*.a
240%{__rm} -f %{buildroot}%{_bindir}/mono-find-provides
241%{__rm} -f %{buildroot}%{_bindir}/mono-find-requires
242
243## This was removed upstream:
244%{__rm} -rf %{buildroot}%{_datadir}/mono-2.0/mono/cil
245%{__rm} -f %{buildroot}%{_bindir}/prj2make
246%{__rm} -f %{buildroot}%{_mandir}/man1/prj2make.*
247%{__rm} -f %{buildroot}%{_mandir}/man1/cilc.*
248## This was referring to fedora:
249%{__rm} -rf %{buildroot}%{mono_dir}/gac/Mono.Security.Win32
250%{__rm} -rf %{buildroot}%{mono_dir}/2.0/Mono.Security.Win32.dll
251%{__rm} -rf %{buildroot}%{mono_dir}/4.0/Mono.Security.Win32.dll
252%{__rm} -rf %{buildroot}%{mono_dir}/xbuild/Microsoft
253%{__rm} -f %{buildroot}%{mono_dir}/2.0/mcs.exe.so
254%{__rm} -f %{buildroot}%{mono_dir}/2.0/mscorlib.dll.so
255%{__rm} -f %{buildroot}%{_datadir}/libgc-mono/README*
256%{__rm} -f %{buildroot}%{_datadir}/libgc-mono/barrett_diagram
257%{__rm} -f %{buildroot}%{_datadir}/libgc-mono/*.html
258%{__rm} -f %{buildroot}%{_datadir}/libgc-mono/gc.man
259%{__rm} -rf %{buildroot}%{_bindir}/mono-configuration-crypto
260%{__rm} -rf %{buildroot}%{_mandir}/man?/mono-configuration-crypto*
261
262
263%find_lang mcs
264
265
266%clean
267[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %{__rm} -rf %{buildroot}
268
269%post core -p /sbin/ldconfig
270%postun core -p /sbin/ldconfig
271%post devel -p /sbin/ldconfig
272%postun devel -p /sbin/ldconfig
273
274
275%files core -f mcs.lang
276%defattr(-,root,root,-)
277%doc AUTHORS COPYING.LIB ChangeLog NEWS README
278%{_bindir}/mcs
279%{_bindir}/mono
280%{_bindir}/monodir
281%{_bindir}/mono-api-*
282%{_bindir}/mono-heapviz
283%{_bindir}/peverify
284%{_bindir}/mprof-report
285%{_bindir}/mono-test-install
286%{_libdir}/libMonoPosixHelper.so
287%{_libdir}/libmono-2.0.so.*
288%{_libdir}/libmono-profiler-aot.so.*
289%{_libdir}/libmono-profiler-cov.so.*
290%{_libdir}/libmono-profiler-iomap.so.*
291%{_libdir}/libmono-profiler-log.so*
292%dir %{mono_dir}
293%dir %{mono_dir}/4.0
294%dir %{mono_dir}/3.5
295%dir %{mono_dir}/2.0
296%dir %{mono_dir}/gac
297%dir %{mono_dir}/compat-2.0
298%bin_and_exe ccrewrite 4.0/ccrewrite
299%bin_and_exe csharp 4.0/csharp
300%bin_and_exe csharp2 2.0/csharp
301%bin_and_exe certmgr 4.0/certmgr
302%bin_and_exe chktrust 4.0/chktrust
303%bin_and_exe dmcs 4.0/dmcs
304%bin_and_exe lc 4.0/lc
305%bin_and_exe gacutil 4.0/gacutil
306%bin_and_exe gacutil2 2.0/gacutil
307%bin_and_exe gmcs 2.0/gmcs
308%bin_and_exe installvst 4.0/installvst
309%bin_and_exe mconfig 4.0/mconfig
310%ifarch ppc
311%{mono_dir}/2.0/mcs.exe
312%else
313%{mono_dir}/2.0/mcs.exe
314%endif
315%bin_and_exe mod 4.0/mod
316%bin_and_exe mono-cil-strip 4.0/mono-cil-strip
317%bin_and_exe monolinker 2.0/monolinker
318%bin_and_exe mozroots 4.0/mozroots
319%bin_and_exe setreg 4.0/setreg
320%bin_and_exe sn 4.0/sn
321%bin_and_exe sqlmetal 4.0/sqlmetal
322%bin_and_exe svcutil 4.0/svcutil
323%{mono_dir}/4.0/browsercaps-updater.exe*
324%{mono_dir}/4.0/monolinker.exe*
325%{mono_dir}/4.0/ictool.exe*
326%{mono_dir}/4.0/installutil.exe*
327%{mono_dir}/4.0/mono-api-info.exe
328%{mono_dir}/4.0/mscorlib.dll*
329%{mono_dir}/2.0/mscorlib.dll*
330%{mono_dir}/3.5/Microsoft.Build.*
331%{mono_dir}/4.0/Microsoft.CSharp.targets
332%{mono_dir}/3.5/Microsoft.CSharp.targets
333%{mono_dir}/2.0/Microsoft.CSharp.targets
334%{mono_dir}/4.0/Microsoft.Common.targets
335%{mono_dir}/3.5/Microsoft.Common.targets
336%{mono_dir}/2.0/Microsoft.Common.targets
337%{mono_dir}/4.0/Microsoft.VisualBasic.targets
338%{mono_dir}/3.5/Microsoft.VisualBasic.targets
339%{mono_dir}/2.0/Microsoft.VisualBasic.targets
340%{mono_dir}/compat-*/ICSharpCode.SharpZipLib.dll
341%{mono_dir}/gac/Mono.Cecil
342%{mono_dir}/gac/Mono.Cecil.Mdb
343%{mono_dir}/mono-configuration-crypto/4.0/Mono.Configuration.Crypto.dll*
344%{mono_dir}/mono-configuration-crypto/4.0/mono-configuration-crypto.exe*
345%gac_and_2dll cscompmgd 4.0 2.0
346%gac_and_2dll Commons.Xml.Relaxng 4.0 2.0
347%gac_and_2dll CustomMarshalers 4.0 2.0
348%gac_and_2dll I18N 4.0 2.0
349%gac_and_2dll I18N.West 4.0 2.0
350%gac_and_2dll ICSharpCode.SharpZipLib 4.0 2.0
351%gac_and_1dll Microsoft.CSharp 4.0
352%gac_and_2dll Mono.C5 4.0 2.0
353%gac_and_2dll Mono.Cairo 4.0 2.0
354%gac_and_2dll Mono.CompilerServices.SymbolWriter 4.0 2.0
355%gac_and_2dll Mono.Posix 4.0 2.0
356%gac_and_2dll Mono.Security 4.0 2.0
357%gac_and_2dll Mono.CSharp 4.0 2.0
358%gac_and_1dll Mono.CodeContracts 4.0
359%gac_and_2dll Mono.Debugger.Soft 4.0 2.0
360%gac_and_2dll Mono.Management 4.0 2.0
361%gac_and_2dll Mono.Simd 4.0 2.0
362%gac_and_2dll Mono.Tasklets 4.0 2.0
363%gac_and_2dll System 4.0 2.0
364%gac_and_2dll System.Configuration 4.0 2.0
365%gac_and_1dll System.Dynamic 4.0
366%gac_and_2dll System.Drawing 4.0 2.0
367%gac_and_2dll System.Core 4.0 2.0
368%gac_and_1dll System.ComponentModel.Composition 4.0
369%gac_and_2dll System.ComponentModel.DataAnnotations 4.0 2.0
370%gac_and_2dll System.IdentityModel 4.0 2.0
371%gac_and_2dll System.IdentityModel.Selectors 4.0 2.0
372%gac_and_2dll System.Net 4.0 2.0
373%gac_and_1dll System.Numerics 4.0
374%gac_and_1dll System.Runtime.Caching 4.0
375%gac_and_1dll System.Runtime.DurableInstancing 4.0
376%gac_and_2dll System.Runtime.Serialization 4.0 2.0
377%gac_and_2dll System.Runtime.Serialization.Formatters.Soap 4.0 2.0
378%gac_and_2dll System.Security 4.0 2.0
379%gac_and_1dll System.Xaml 4.0
380%gac_and_2dll System.Xml 4.0 2.0
381%gac_and_2dll System.Xml.Linq 4.0 2.0
382%gac_and_2dll OpenSystem.C 4.0 2.0
383%gac_and_2dll WindowsBase 4.0 2.0
384%dir %{_sysconfdir}/mono
385%dir %{_sysconfdir}/mono/4.0
386%dir %{_sysconfdir}/mono/2.0
387%dir %{_sysconfdir}/mono/mconfig
388%config (noreplace) %{_sysconfdir}/mono/config
389%config (noreplace) %{_sysconfdir}/mono/2.0/machine.config
390%config (noreplace) %{_sysconfdir}/mono/4.0/machine.config
391%config (noreplace) %{_sysconfdir}/mono/mconfig/config.xml
392%config (noreplace) %{_sysconfdir}/mono/2.0/settings.map
393%config (noreplace) %{_sysconfdir}/mono/4.0/settings.map
394%{_prefix}/lib/mono-source-libs/
395%{_mandir}/man1/ccrewrite.1.gz
396%{_mandir}/man1/certmgr.1.gz
397%{_mandir}/man1/chktrust.1.gz
398%{_mandir}/man1/csharp.1.gz
399%{_mandir}/man1/gacutil.1.gz
400%{_mandir}/man1/lc.1.gz
401%{_mandir}/man1/mconfig.1.gz
402%{_mandir}/man1/mcs.1.gz
403%{_mandir}/man1/mono.1.gz
404%{_mandir}/man1/monolinker.1.gz
405%{_mandir}/man1/mozroots.1.gz
406%{_mandir}/man1/mprof-report.1.gz
407%{_mandir}/man1/setreg.1.gz
408%{_mandir}/man1/sn.1.gz
409%{_mandir}/man1/resgen.1.gz
410%{_mandir}/man1/mono-api-info.1.gz
411%{_mandir}/man1/mono-cil-strip.1.gz
412%{_mandir}/man5/mono-config.5.gz
413
414%files devel
415%defattr(-,root,root,-)
416%{_bindir}/genxs
417%{_bindir}/mkbundle
418%{_bindir}/mono-gdb.py
419%{_bindir}/monodis
420%{_bindir}/monograph
421%{_bindir}/pedump
422%{_bindir}/xbuild
423%{_libdir}/libmono-2.0.so
424%{_libdir}/libmono-profiler-aot.so
425%{_libdir}/libmono-profiler-cov.so
426%{_libdir}/libmono-profiler-iomap.so
427%{_libdir}/libMonoSupportW.so
428%{_libdir}/libikvm-native.so
429%{mono_dir}/4.0/mkbundle.exe*
430%{mono_dir}/2.0/mkbundle.exe*
431%{mono_dir}/4.0/genxs.exe*
432%{mono_dir}/2.0/genxs.exe*
433%{mono_dir}/2.0/ilasm.exe*
434%bin_and_exe al 4.0/al
435%bin_and_exe al2 2.0/al
436%bin_and_exe caspol 4.0/caspol
437%bin_and_exe cert2spc 4.0/cert2spc
438%bin_and_exe dtd2xsd 4.0/dtd2xsd
439%bin_and_exe dtd2rng 4.0/dtd2rng
440%bin_and_exe sgen 4.0/sgen
441%bin_and_exe ilasm 4.0/ilasm
442%bin_and_exe macpack 4.0/macpack
443%bin_and_exe makecert 4.0/makecert
444%bin_and_exe monop 4.0/monop
445%bin_and_exe monop2 2.0/monop
446%bin_and_exe mono-shlib-cop 4.0/mono-shlib-cop
447%bin_and_exe mono-xmltool 4.0/mono-xmltool
448%bin_and_exe pdb2mdb 4.0/pdb2mdb
449%bin_and_exe permview 4.0/permview
450%bin_and_exe resgen 4.0/resgen
451%bin_and_exe resgen2 2.0/resgen
452%bin_and_exe secutil 4.0/secutil
453%bin_and_exe signcode 4.0/signcode
454%{mono_dir}/xbuild
455%{mono_dir}/xbuild-frameworks
456%{mono_dir}/4.0/xbuild.*
457%{mono_dir}/3.5/xbuild.*
458%{mono_dir}/2.0/xbuild.*
459%{mono_dir}/4.0/culevel.exe*
460%{mono_dir}/2.0/culevel.exe*
461%{mono_dir}/4.0/MSBuild/*.xsd
462%{mono_dir}/3.5/MSBuild/*.xsd
463%{mono_dir}/2.0/MSBuild/*.xsd
464%{mono_dir}/4.0/Microsoft.Build.xsd
465%{mono_dir}/3.5/Microsoft.Build.xsd
466%{mono_dir}/2.0/Microsoft.Build.xsd
467%{mono_dir}/4.0/Microsoft.*.targets
468%{mono_dir}/3.5/Microsoft.*.targets
469%{mono_dir}/2.0/Microsoft.*.targets
470%{mono_dir}/4.0/Microsoft.Common.tasks
471%{mono_dir}/3.5/Microsoft.Common.tasks
472%{mono_dir}/2.0/Microsoft.Common.tasks
473%gac_and_2dll PEAPI 4.0 2.0
474%gac_and_3dll Microsoft.Build.Engine 4.0 3.5 2.0
475%gac_and_3dll Microsoft.Build.Framework 4.0 3.5 2.0
476%gac_and_1dll Microsoft.Build.Tasks 2.0
477%gac_and_1dll Microsoft.Build.Tasks.v4.0 4.0
478%gac_and_1dll Microsoft.Build.Tasks.v3.5 3.5
479%gac_and_1dll Microsoft.Build.Utilities 2.0
480%gac_and_1dll Microsoft.Build.Utilities.v4.0 4.0
481%gac_and_1dll Microsoft.Build.Utilities.v3.5 3.5
482%gac_and_2dll Microsoft.VisualC 4.0 2.0
483%{_libdir}/pkgconfig/cecil.pc
484%{_libdir}/pkgconfig/dotnet.pc
485%{_libdir}/pkgconfig/dotnet35.pc
486%{_libdir}/pkgconfig/mono-cairo.pc
487%{_libdir}/pkgconfig/mono.pc
488%{_libdir}/pkgconfig/mono-2.pc
489%{_libdir}/pkgconfig/mono-lineeditor.pc
490%{_libdir}/pkgconfig/mono-options.pc
491%{_libdir}/pkgconfig/wcf.pc
492%{_includedir}/mono-2.0
493%{_mandir}/man1/al.1.gz
494%{_mandir}/man1/cert2spc.1.gz
495%{_mandir}/man1/dtd2xsd.1.gz
496%{_mandir}/man1/genxs.1.gz
497%{_mandir}/man1/ilasm.1.gz
498%{_mandir}/man1/macpack.1.gz
499%{_mandir}/man1/makecert.1.gz
500%{_mandir}/man1/mkbundle.1.gz
501%{_mandir}/man1/mono-shlib-cop.1.gz
502%{_mandir}/man1/mono-xmltool.1.gz
503%{_mandir}/man1/monodis.1.gz
504%{_mandir}/man1/monop.1.gz
505%{_mandir}/man1/pdb2mdb.1.gz
506%{_mandir}/man1/permview.1.gz
507%{_mandir}/man1/secutil.1.gz
508%{_mandir}/man1/sgen.1.gz
509%{_mandir}/man1/signcode.1.gz
510%{_mandir}/man1/xbuild.1.gz
511
512%files nunit
513%defattr(-,root,root,-)
514%bin_and_exe nunit-console 4.0/nunit-console
515%bin_and_exe nunit-console2 2.0/nunit-console
516%gac_and_2dll nunit.core 4.0 2.0
517%gac_and_2dll nunit.framework 4.0 2.0
518%gac_and_2dll nunit.util 4.0 2.0
519%gac_and_2dll nunit.mocks 4.0 2.0
520%gac_and_2dll nunit-console-runner 4.0 2.0
521%gac_and_2dll nunit.core.extensions 4.0 2.0
522%gac_and_2dll nunit.core.interfaces 4.0 2.0
523%gac_and_2dll nunit.framework.extensions 4.0 2.0
524%{_libdir}/pkgconfig/mono-nunit.pc
525
526%files locale-extras
527%defattr(-,root,root,-)
528%gac_and_2dll I18N.MidEast 4.0 2.0
529%gac_and_2dll I18N.Rare 4.0 2.0
530%gac_and_2dll I18N.CJK 4.0 2.0
531%gac_and_2dll I18N.Other 4.0 2.0
532
533%files extras
534%defattr(-,root,root,-)
535%{_mandir}/man1/mono-service.1.gz
536%bin_and_exe mono-service 4.0/mono-service
537%bin_and_exe mono-service2 2.0/mono-service
538%{mono_dir}/gac/mono-service
539%gac_and_2dll System.Configuration.Install 4.0 2.0
540%gac_and_2dll System.Management 4.0 2.0
541%gac_and_2dll System.Messaging 4.0 2.0
542%gac_and_2dll System.ServiceProcess 4.0 2.0
543%gac_and_2dll System.ServiceModel 4.0 2.0
544%gac_and_1dll System.ServiceModel.Discovery 4.0
545%gac_and_1dll System.ServiceModel.Routing 4.0
546%gac_and_2dll Mono.Messaging.RabbitMQ 4.0 2.0
547%gac_and_2dll Mono.Messaging 4.0 2.0
548%gac_and_2dll RabbitMQ.Client 4.0 2.0
549%{mono_dir}/4.0/RabbitMQ.Client.Apigen.exe*
550%{mono_dir}/2.0/RabbitMQ.Client.Apigen.exe*
551
552%files winforms
553%defattr(-,root,root,-)
554%gac_and_2dll Accessibility 4.0 2.0
555%gac_and_2dll System.Design 4.0 2.0
556%gac_and_2dll System.Drawing.Design 4.0 2.0
557%gac_and_2dll System.Windows.Forms 4.0 2.0
558%gac_and_1dll System.Windows.Forms.DataVisualization 4.0
559
560%files web
561%defattr(-,root,root,-)
562%{mono_dir}/2.0/xsd.exe*
563%{mono_dir}/compat-2.0/System.Web.Extensions*dll
564%{mono_dir}/compat-2.0/System.Web.Mvc.dll
565%bin_and_exe disco 4.0/disco
566%bin_and_exe soapsuds 4.0/soapsuds
567%bin_and_exe xsd 4.0/xsd
568%bin_and_exe wsdl 4.0/wsdl
569%bin_and_exe wsdl2 2.0/wsdl
570%bin_and_exe httpcfg 4.0/httpcfg
571%gac_and_2dll Mono.Http 4.0 2.0
572%gac_and_2dll Mono.Web 4.0 2.0
573%gac_and_2dll Mono.WebBrowser 4.0 2.0
574%gac_and_2dll System.Runtime.Remoting 4.0 2.0
575%gac_and_2dll System.Runtime.Serialization.Formatters.Soap 4.0 2.0
576%gac_and_2dll System.ServiceModel.Web 4.0 2.0
577%gac_and_2dll System.Web 4.0 2.0
578%gac_and_1dll System.Web.ApplicationServices 4.0
579%gac_and_2dll System.Web.Abstractions 4.0 2.0
580%gac_and_2dll System.Web.DynamicData 4.0 2.0
581%gac_and_1dll System.Web.Mvc 2.0
582%gac_and_2dll System.Web.Routing 4.0 2.0
583%gac_and_2dll System.Web.Services 4.0 2.0
584%gac_and_2dll System.Web.Extensions.Design 4.0 2.0
585%gac_and_2dll System.Web.Extensions 4.0 2.0
586%gac_and_1dll Microsoft.Web.Infrastructure 4.0
587%gac_and_1dll WebMatrix.Data 4.0
588%{_mandir}/man1/disco.1.gz
589%{_mandir}/man1/soapsuds.1.gz
590%{_mandir}/man1/wsdl.1.gz
591%{_mandir}/man1/xsd.1.gz
592%config (noreplace) %{_sysconfdir}/mono/browscap.ini
593%config (noreplace) %{_sysconfdir}/mono/2.0/Browsers/Compat.browser
594%config (noreplace) %{_sysconfdir}/mono/4.0/DefaultWsdlHelpGenerator.aspx
595%config (noreplace) %{_sysconfdir}/mono/2.0/DefaultWsdlHelpGenerator.aspx
596%config (noreplace) %{_sysconfdir}/mono/4.0/web.config
597%config (noreplace) %{_sysconfdir}/mono/2.0/web.config
598%{_mandir}/man1/httpcfg.1.gz
599%{_libdir}/pkgconfig/mono.web.pc
600%{_libdir}/pkgconfig/system.web.extensions_1.0.pc
601%{_libdir}/pkgconfig/system.web.extensions.design_1.0.pc
602%{_libdir}/pkgconfig/system.web.mvc.pc
603%{_libdir}/pkgconfig/system.web.mvc2.pc
604
605%files data
606%defattr(-,root,root,-)
607%bin_and_exe sqlsharp 4.0/sqlsharp
608%gac_and_2dll Mono.Data.Tds 4.0 2.0
609%gac_and_2dll Novell.Directory.Ldap 4.0 2.0
610%gac_and_2dll System.Data 4.0 2.0
611%gac_and_2dll System.Data.DataSetExtensions 4.0 2.0
612%gac_and_2dll System.Data.Linq 4.0 2.0
613%gac_and_2dll System.Data.Services 4.0 2.0
614%gac_and_2dll System.Data.Services.Client 4.0 2.0
615%gac_and_2dll System.DirectoryServices 4.0 2.0
616%gac_and_2dll System.EnterpriseServices 4.0 2.0
617%gac_and_2dll System.Transactions 4.0 2.0
618%{_mandir}/man1/sqlsharp.1.gz
619
620%files data-sqlite
621%defattr(-,root,root,-)
622%gac_and_2dll Mono.Data.Sqlite 4.0 2.0
623
624%files data-oracle
625%defattr(-,root,root,-)
626%gac_and_2dll System.Data.OracleClient 4.0 2.0
627
628%files data-postgresql
629%defattr(-,root,root,-)
630%gac_and_2dll Npgsql 4.0 2.0
631
632%files -n ibm-data-db2
633%defattr(-,root,root,-)
634%gac_and_2dll IBM.Data.DB2 4.0 2.0
635
636%files -n monodoc
637%defattr(-, root, root)
638%bin_and_exe mdoc 2.0/mdoc
639%{_bindir}/mdoc-*
640%{_bindir}/mdass*
641%{_bindir}/mdval*
642%{_bindir}/mod
643%{_bindir}/monodoc*
644%{mono_dir}/gac/monodoc
645%{mono_dir}/monodoc/monodoc.dll
646%{mono_doc}/*
647%{_mandir}/man1/md*
648%{_mandir}/man1/monodoc*
649%{_mandir}/man5/mdoc*
650%{_libdir}/pkgconfig/monodoc.pc
651
652
653%changelog
654* Sat May 07 2011 Shu KONNO <owa@bg.wakwak.com> 2.10.2-1
655- updated mono to 2.10.2
656- dropt Patch1: mono-2.10.1-ppc-len.patch (fixed in the upstream)
657
658* Sun Apr 24 2011 Shu KONNO <owa@bg.wakwak.com> 2.10.1-3
659- added '--with-sgen=no' to all arch
660- dropt %%{mono_dir}/2.0/{mcs.exe,mscorlib.dll}.so
661
662* Sat Apr 16 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.10.1-2
663- remove the old ppc patch (similar codes already in the upstream)
664- add Patch1 (from Gentoo)
665- mono/2.0/mcs.exe.so not available on ppc - remove from the filelist
666  (TODO: see the Fedora's srpm - removing mono/2.0/{mcs,gmcs}.exe.so etc.)
667
668* Sun Apr 03 2011 Shu KONNO <owa@bg.wakwak.com> 2.10.1-1
669- updated mono to 2.10.1
670
671* Sat Jan 08 2011 Shu KONNO <owa@bg.wakwak.com> 2.8.2-1
672- updated mono to 2.8.2
673
674* Tue Dec 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-2
675- add Patch0 (mono-2.8.1-ppc.patch)
676- add configure option "--with-sgen=no" and "--disable-system-aot" (ppc only)
677- fix %%files (add %%ifnarch ppc)
678
679* Sun Nov 21 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.1-1
680- updated mono to 2.8.1
681
682* Sat Nov 06 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-2
683- comment out script that removes prebuilt binaries, because gmcs.exe require
684
685* Fri Oct 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-1
686- updated mono to 2.8
687- modified macros used in %%files
688- removed below:
689  - packages:
690    %{name}-jscript, %{name}-data-sybase, %{name}-data-firebird, bytefx-data-mysql
691  - libraries:
692    ByteFX.Data, FirebirdSql.Data.Firebird
693    Mono.Data Mono.Data.TdsClient, Mono.Data.SybaseClient, Mono.Data.SqliteClient
694    Microsoft.JScript, Microsoft.Vsa
695  - commands:
696    cilc, mjs, prj2make (replaced by xbuild)
697
698* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.6.7-2
699- build with rpm-4.8.1-1 for pkg-config file
700
701* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.7-1
702- updated mono to 2.6.7
703
704* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
705- updated mono to 2.6.4
706
707* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.3-1
708- updated mono to 2.6.3
709  added RabbitMQ.Client.Apigen.exe
710
711* Thu Dec 31 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.1-2
712- unuse _smp_mflags
713
714* Sat Dec 26 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.1-1
715- updated mono to 2.6.1
716- simplified macros
717
718* Mon Dec 14 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-1
719- updated mono to 2.4.3
720  added %%{mono_dir}/2.0/lc.exe*
721  added %%gac_dll System.Web.Mvc
722  added %%{mono_dir}/xbuild/*
723  added %%{_mandir}/man1/lc.1.gz
724  added %%{_mandir}/man1/xbuild.1.gz
725
726* Wed Jul 29 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2.3-1
727- updated mono to 2.4.2.3
728
729* Fri Jul 24 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2.2-1
730- updated mono to 2.4.2.2
731
732* Tue Jul 07 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.2.1-1
733- new upstream release
734- build with latest rpm to update mono-dependencies
735
736* Thu Jul 02 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2-1
737- updated mono to 2.4.2
738
739* Mon Apr 27 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4-3
740- fix temporary workaround against build failure on ppc,
741  from RH bugzilla #494026
742  - statically link mono to libmono: remove "--disable-static" from configure
743  - ensure removing *.a files in the install section
744- remove prebuilt binaries under mcs/class/lib/monolite/ before building
745
746* Sun Apr  5 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
747- fixed paths using %%mono_dir, %%mono_doc macros
748- added Requires:libgluezilla >= 2.4 in monodoc
749
750* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
751- new upstream release
752- added monodoc package (Obsoletes: monodoc-core <= 2.0-1vl5)
753
754* Mon Nov 03 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1
755- new upstream release
756- dropt %%{_bindir}/mono-find-{provides,requires}
757- added --with-libgdiplus=installed
758
759* Mon Oct 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-3
760- update to mono-2.0 released source
761- BR: libgdiplus-devel >= 2.0
762
763* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-2vl5
764- removed *.la
765
766* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1vl5
767- updated mono to 2.0
768- updated url
769- changed macro %%monodir to %%mono_dir
770- dropt mono-1.1.13.4-selinux-ia64.patch
771- dropt mono-1.1.13.4-ppc-threading.patch
772- dropt mono-1.2.3-use-monodir.patch
773
774* Tue Aug 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.5.1-1vl5
775- applied new versioning policy, spec in utf-8
776- dropt mono-1.2.5-libdir.patch
777- reverted monodir macro to using %%{_prefix}/lib/mono
778
779* Sat Dec 29 2007 Shu KONNO <owa@bg.wakwak.com> 1.2.5.1-0vl2
780- updated monodir to %%{_libdir}/mono
781
782* Sat Sep 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5.1-0vl1
783- new upstream release
784- splited mono-basic package
785
786* Sat Oct 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.8.1-0vl1
787- new upstream release
788
789* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.6-0vl1
790- new upstream release
791
792* Thu Apr 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.13.4-2vl2
793- disabled Patch2 on Vine/ppc environment
794
795* Wed Mar 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.4-2vl1
796- updated source and sub-packages based on Fedora packages
797  * Tue Feb 22 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.6-0vl1
798  - new upstream version(mono-1.0.6)
799  * Sun Jan 16 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.5-0vl1
800  - new upstream version(mono-1.0.5)
801  * Sat Nov 06 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.4-0vl1
802  - new upstream version(mono-1.0.4)
803        -- changed to use configure
804  * Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
805  - rebuild for Vine Linux (based on mono.spec inside src archive)
806  - Fixed BuildRequires: gc-devel, libicu-devel
807  - add Japanese translation
808
809* Fri Mar 10 2006 Bill Nottingham <notting@redhat.com> - 1.1.13.4-2
810- rebuild for ppc TLS issue (#184446)
811
812* Fri Mar  3 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.4-1
813- Update to 1.1.13.4
814- Add patch so mono doesn't segfault on PPC SMP machines
815- Minor spec cleanup
816
817* Thu Mar  2 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-5
818- Updated patch from Jakub (1.1.13.2-3 to 1.1.13.2-5 are
819  for bug 182965)
820
821* Tue Feb 28 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-4
822- Updated patch from Paolo Molaro <lupus@ximian.com>
823
824* Mon Feb 27 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-3
825- Patch from Jakub to make work with SELinux better
826
827* Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.2-2
828- Rebuild
829
830* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.1.13.2-1.1
831- rebuilt for new gcc4.1 snapshot and glibc changes
832
833* Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.2-1
834- Update to 1.1.13.2
835
836* Fri Jan 13 2006 Alexander Larsson <alexl@redhat.com> - 1.1.13-1
837- Update to 1.13
838- Add libgdiplus dep to mono-core
839- Add s390x to build
840
841* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 1.1.12.1-1
842- Update to 1.1.12.1
843
844* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 1.1.10-4
845- rebuild
846
847* Fri Nov 18 2005 Alexander Larsson <alexl@redhat.com> 1.1.10-3
848- Disable s390 due to some build failure
849
850* Thu Nov 17 2005 Alexander Larsson <alexl@redhat.com> 1.1.10-2
851- Build on s390 and x86-64 now
852
853* Tue Nov 15 2005 Alexander Larsson <alexl@redhat.com> - 1.1.10-1
854- Initial version
Note: See TracBrowser for help on using the repository browser.