source: projects/specs/trunk/m/mono/mono-vl.spec @ 4933

Revision 4933, 27.7 KB checked in by Takemikaduchi, 13 years ago (diff)

NEW: latexila, latexmk, rubber
mono, NetworkManager: new upstream release
control-center: rebuild with NetworkManager-0.9

Line 
1%bcond_with firstbuild
2
3Summary: .NET runtime environment
4Summary(ja): .NET ランタイム環境
5Name: mono
6Version: 2.10.6
7Release: 1%{?_dist_release}
8Group: Development/Languages
9License: GPL, LGPL, MIT X11
10URL: http://www.mono-project.com/
11Source0: http://ftp.novell.com/pub/mono/sources/mono/%{name}-%{version}.tar.bz2
12Source1: monodir.c
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: bison
15BuildRequires: glib2-devel
16BuildRequires: pkgconfig
17BuildRequires: libicu-devel
18BuildRequires: libgdiplus-devel >= 2.0
19BuildRequires: zlib-devel
20%{!?with_firstbuild:BuildRequires: mono-devel}
21# JIT only availible on these:
22ExclusiveArch: %{ix86} x86_64 ppc ia64 s390 s390x armv4l sparc
23Obsoletes: %{name}-jscript < 2.8
24Obsoletes: %{name}-data-sybase < 2.8
25Obsoletes: %{name}-data-firebird < 2.8
26Obsoletes: bytefx-data-mysql < 2.8
27Distribution: Vine Linux
28Vendor: Project Vine
29Packager: owa
30
31%description
32The Mono runtime implements a JIT engine for the ECMA CLI
33virtual machine (as well as a byte code interpreter, the
34class loader, the garbage collector, threading system and
35metadata access libraries.
36
37%description -l ja
38Mono ランタイムは ECMA CLI 仮想機械用 JIT エンジンの実装です。バイト
39コードインタプリタ、クラスローダ、ガベージコレクタ、スレッドシステム
40およびメタデータアクセスライブラリの機能を持ちます。
41
42%package core
43Summary: The Mono CIL runtime, suitable for running .NET code
44Summary(ja): .NET の実行に適した Mono CIL ランタイム
45Group: Development/Languages
46Requires: libgdiplus
47
48%description core
49This package contains the core of the Mono runtime including its
50Virtual Machine, Just-in-time compiler, C# compiler, security
51tools and libraries (corlib, XML, System.Security, ZipLib,
52I18N, Cairo and Mono.*).
53
54%package devel
55Summary:        Development tools for Mono
56Summary(ja):    Mono 開発ツール
57Group:          Development/Languages
58Requires:       mono-core = %{version}-%{release}
59Requires:       glib2-devel
60
61%description devel
62This package completes the Mono developer toolchain with the mono profiler,
63assembler and other various tools.
64
65%package nunit
66Summary:        NUnit Testing Framework
67Summary(ja):    NUnit テストフレームワーク
68Group:          Development/Languages
69Requires:       mono-core = %{version}-%{release}
70Requires:       glib2-devel
71
72%description nunit
73NUnit is a unit-testing framework for all .NET languages. Initially
74ported from JUnit, the current release, version 2.2, is the fourth
75major release of this Unit based unit testing tool for Microsoft .NET.
76It is written entirely in C# and  has been completely redesigned to
77take advantage of many .NET language features, for example
78custom attributes and other reflection related capabilities. NUnit
79brings xUnit to all .NET languages.
80
81%package locale-extras
82Summary:        Extra locale information for Mono
83Summary(ja):    Mono 用追加ロケール情報
84Group:          Development/Languages
85Requires:       mono-core = %{version}-%{release}
86
87%description locale-extras
88This package contains assemblies to support I18N applications for
89non-latin alphabets.
90
91%package extras
92Summary:        Provides the infrastructure for running and building daemons and services with Mono as well as various stub assemblies
93Group:          Development/Languages
94Requires:       mono-core = %{version}-%{release}
95
96%description extras
97This package provides the libary and application to run services
98and daemons with Mono. It also includes stubs for the following
99.NET 1.1 and 2.0 assemblies: Microsoft.Vsa,
100System.Configuration.Install, System.Management, System.Messaging.
101
102%package winforms
103Summary:        Windows Forms implementation for Mono
104Group:          Development/Languages
105Requires:       mono-core = %{version}-%{release}
106
107%description winforms
108This package provides a fully managed implementation of
109System.Windows.Forms, the default graphical toolkit for .NET
110applications.
111
112%package web
113Summary:        ASP.NET, Remoting, and Web Services for Mono
114Group:          Development/Languages
115Requires:       mono-core = %{version}-%{release}
116
117%description web
118This package provides the ASP.NET libraries and runtime for
119development of web application, web services and remoting support.
120
121%package data
122Summary:        Database connectivity for Mono
123Group:          Development/Languages
124Requires:       mono-core = %{version}-%{release}
125
126%description data
127This package provides a Mono assembly to facilitate data access
128and manipulation with databases, LDAP compatible directory servers
129and/or XML data exchange. Beyond the ADO.NET, Novell.LDAP and
130System.DirectoryServices assemblies, it also includes a command
131line sql application as well as the Microsoft SQL Server and ODBC
132data providers.
133
134%package data-sqlite
135Summary:        sqlite database connectivity for Mono
136Group:          Development/Languages
137Requires:       mono-core = %{version}-%{release}
138Requires:       sqlite
139
140%description data-sqlite
141This package contains the ADO.NET Data provider for the sqlite
142database.
143
144%package data-oracle
145Summary:        Oracle database connectivity for Mono
146Group:          Development/Languages
147Requires:       mono-core = %{version}-%{release}
148
149%description data-oracle
150This package contains the ADO.NET Data provider for the Oracle
151database.
152
153%package data-postgresql
154Summary:        Postgresql database connectivity for Mono
155Group:          Development/Languages
156Requires:       mono-core = %{version}-%{release}
157
158%description data-postgresql
159This package contains the ADO.NET Data provider for the PostgreSQL
160database.
161
162%package -n ibm-data-db2
163Summary:        IBM DB2 database connectivity for Mono
164Group:          Development/Languages
165Requires:       mono-core = %{version}-%{release}
166
167%description -n ibm-data-db2
168This package contains the ADO.NET Data provider for the IBM DB2
169Universal database.
170
171%package -n monodoc
172Summary:        The Mono documentation system
173Group:          Development/Tools
174Requires:       mono-core = %{version}-%{release}
175Requires:       libgluezilla >= 2.4
176Obsoletes:      monodoc-core <= 2.0-1vl5
177
178%description -n monodoc
179monodoc is the documentation package for the mono .NET environment
180
181## macros
182%define mono_dir %{_prefix}/lib/mono
183%define mono_doc %{_prefix}/lib/monodoc
184%define bin_and_exe(bin, exe) %{_bindir}/%{1} \
185        %{mono_dir}/%{2}.exe \
186        %{mono_dir}/%{2}.exe.* \
187        %{nil}
188%define gac_and_1dll(dll)  %{mono_dir}/gac/%{1} \
189        %{mono_dir}/%{2}/%{1}.dll \
190        %{nil}
191%define gac_and_2dll(dll)  %{mono_dir}/gac/%{1} \
192        %{mono_dir}/%{2}/%{1}.dll \
193        %{mono_dir}/%{3}/%{1}.dll \
194        %{nil}
195%define gac_and_3dll(dll)  %{mono_dir}/gac/%{1} \
196        %{mono_dir}/%{2}/%{1}.dll \
197        %{mono_dir}/%{3}/%{1}.dll \
198        %{mono_dir}/%{4}/%{1}.dll \
199        %{nil}
200
201
202%prep
203%setup -q
204
205## These are only needed if there are patches to the runtime
206#rm -f libgc/libtool.m4
207#autoreconf --force --install
208#autoreconf --force --install libgc
209
210## Remove prebuilt binaries
211#rm -rf mcs/class/lib/monolite/*
212
213%build
214gcc -o monodir %{SOURCE1} -DMONODIR=\"%{mono_dir}\"
215
216export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
217%configure \
218        --with-jit=yes \
219        --with-ikvm-native=yes \
220        --with-sigaltstack=no \
221        --with-sgen=no \
222        ;
223
224# don't use parallel builds
225# make %{?_smp_mflags}
226make
227
228
229%install
230[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %{__rm} -rf %{buildroot}
231make install DESTDIR=%{buildroot}
232
233install monodir %{buildroot}%{_bindir}
234
235## Remove unused files
236%{__rm} -f %{buildroot}%{_libdir}/*.la
237%{__rm} -f %{buildroot}%{_libdir}/*.a
238%{__rm} -f %{buildroot}%{_bindir}/mono-find-provides
239%{__rm} -f %{buildroot}%{_bindir}/mono-find-requires
240
241## This was removed upstream:
242%{__rm} -rf %{buildroot}%{_datadir}/mono-2.0/mono/cil
243%{__rm} -f %{buildroot}%{_bindir}/prj2make
244%{__rm} -f %{buildroot}%{_mandir}/man1/prj2make.*
245%{__rm} -f %{buildroot}%{_mandir}/man1/cilc.*
246## This was referring to fedora:
247%{__rm} -rf %{buildroot}%{mono_dir}/gac/Mono.Security.Win32
248%{__rm} -rf %{buildroot}%{mono_dir}/2.0/Mono.Security.Win32.dll
249%{__rm} -rf %{buildroot}%{mono_dir}/4.0/Mono.Security.Win32.dll
250%{__rm} -rf %{buildroot}%{mono_dir}/xbuild/Microsoft
251%{__rm} -f %{buildroot}%{mono_dir}/2.0/mcs.exe.so
252%{__rm} -f %{buildroot}%{mono_dir}/2.0/mscorlib.dll.so
253%{__rm} -f %{buildroot}%{_datadir}/libgc-mono/README*
254%{__rm} -f %{buildroot}%{_datadir}/libgc-mono/barrett_diagram
255%{__rm} -f %{buildroot}%{_datadir}/libgc-mono/*.html
256%{__rm} -f %{buildroot}%{_datadir}/libgc-mono/gc.man
257%{__rm} -rf %{buildroot}%{_bindir}/mono-configuration-crypto
258%{__rm} -rf %{buildroot}%{_mandir}/man?/mono-configuration-crypto*
259
260
261%find_lang mcs
262
263
264%clean
265[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %{__rm} -rf %{buildroot}
266
267%post core -p /sbin/ldconfig
268%postun core -p /sbin/ldconfig
269%post devel -p /sbin/ldconfig
270%postun devel -p /sbin/ldconfig
271
272
273%files core -f mcs.lang
274%defattr(-,root,root,-)
275%doc AUTHORS COPYING.LIB ChangeLog NEWS README
276%{_bindir}/mcs
277%{_bindir}/mono
278%{_bindir}/monodir
279%{_bindir}/mono-api-*
280%{_bindir}/mono-heapviz
281%{_bindir}/peverify
282%{_bindir}/mprof-report
283%{_bindir}/mono-test-install
284%{_libdir}/libMonoPosixHelper.so
285%{_libdir}/libmono-2.0.so.*
286%{_libdir}/libmono-profiler-aot.so.*
287%{_libdir}/libmono-profiler-cov.so.*
288%{_libdir}/libmono-profiler-iomap.so.*
289%{_libdir}/libmono-profiler-log.so*
290%dir %{mono_dir}
291%dir %{mono_dir}/4.0
292%dir %{mono_dir}/3.5
293%dir %{mono_dir}/2.0
294%dir %{mono_dir}/gac
295%dir %{mono_dir}/compat-2.0
296%bin_and_exe ccrewrite 4.0/ccrewrite
297%bin_and_exe csharp 4.0/csharp
298%bin_and_exe csharp2 2.0/csharp
299%bin_and_exe certmgr 4.0/certmgr
300%bin_and_exe chktrust 4.0/chktrust
301%bin_and_exe dmcs 4.0/dmcs
302%bin_and_exe lc 4.0/lc
303%bin_and_exe gacutil 4.0/gacutil
304%bin_and_exe gacutil2 2.0/gacutil
305%bin_and_exe gmcs 2.0/gmcs
306%bin_and_exe installvst 4.0/installvst
307%bin_and_exe mconfig 4.0/mconfig
308%{mono_dir}/2.0/mcs.exe
309%bin_and_exe mod 4.0/mod
310%bin_and_exe mono-cil-strip 4.0/mono-cil-strip
311%bin_and_exe monolinker 2.0/monolinker
312%bin_and_exe mozroots 4.0/mozroots
313%bin_and_exe setreg 4.0/setreg
314%bin_and_exe sn 4.0/sn
315%bin_and_exe sqlmetal 4.0/sqlmetal
316%bin_and_exe svcutil 4.0/svcutil
317%{mono_dir}/4.0/browsercaps-updater.exe*
318%{mono_dir}/4.0/monolinker.exe*
319%{mono_dir}/4.0/ictool.exe*
320%{mono_dir}/4.0/installutil.exe*
321%{mono_dir}/4.0/mono-api-info.exe
322%{mono_dir}/4.0/mscorlib.dll*
323%{mono_dir}/2.0/mscorlib.dll*
324%{mono_dir}/3.5/Microsoft.Build.*
325%{mono_dir}/4.0/Microsoft.CSharp.targets
326%{mono_dir}/3.5/Microsoft.CSharp.targets
327%{mono_dir}/2.0/Microsoft.CSharp.targets
328%{mono_dir}/4.0/Microsoft.Common.targets
329%{mono_dir}/3.5/Microsoft.Common.targets
330%{mono_dir}/2.0/Microsoft.Common.targets
331%{mono_dir}/4.0/Microsoft.VisualBasic.targets
332%{mono_dir}/3.5/Microsoft.VisualBasic.targets
333%{mono_dir}/2.0/Microsoft.VisualBasic.targets
334%{mono_dir}/compat-*/ICSharpCode.SharpZipLib.dll
335%{mono_dir}/gac/Mono.Cecil
336%{mono_dir}/gac/Mono.Cecil.Mdb
337%{mono_dir}/mono-configuration-crypto/4.0/Mono.Configuration.Crypto.dll*
338%{mono_dir}/mono-configuration-crypto/4.0/mono-configuration-crypto.exe*
339%gac_and_2dll cscompmgd 4.0 2.0
340%gac_and_2dll Commons.Xml.Relaxng 4.0 2.0
341%gac_and_2dll CustomMarshalers 4.0 2.0
342%gac_and_2dll I18N 4.0 2.0
343%gac_and_2dll I18N.West 4.0 2.0
344%gac_and_2dll ICSharpCode.SharpZipLib 4.0 2.0
345%gac_and_1dll Microsoft.CSharp 4.0
346%gac_and_2dll Mono.C5 4.0 2.0
347%gac_and_2dll Mono.Cairo 4.0 2.0
348%gac_and_2dll Mono.CompilerServices.SymbolWriter 4.0 2.0
349%gac_and_2dll Mono.Posix 4.0 2.0
350%gac_and_2dll Mono.Security 4.0 2.0
351%gac_and_2dll Mono.CSharp 4.0 2.0
352%gac_and_1dll Mono.CodeContracts 4.0
353%gac_and_2dll Mono.Debugger.Soft 4.0 2.0
354%gac_and_2dll Mono.Management 4.0 2.0
355%gac_and_2dll Mono.Simd 4.0 2.0
356%gac_and_2dll Mono.Tasklets 4.0 2.0
357%gac_and_2dll System 4.0 2.0
358%gac_and_2dll System.Configuration 4.0 2.0
359%gac_and_1dll System.Dynamic 4.0
360%gac_and_2dll System.Drawing 4.0 2.0
361%gac_and_2dll System.Core 4.0 2.0
362%gac_and_1dll System.ComponentModel.Composition 4.0
363%gac_and_2dll System.ComponentModel.DataAnnotations 4.0 2.0
364%gac_and_2dll System.IdentityModel 4.0 2.0
365%gac_and_2dll System.IdentityModel.Selectors 4.0 2.0
366%gac_and_2dll System.Net 4.0 2.0
367%gac_and_1dll System.Numerics 4.0
368%gac_and_1dll System.Runtime.Caching 4.0
369%gac_and_1dll System.Runtime.DurableInstancing 4.0
370%gac_and_2dll System.Runtime.Serialization 4.0 2.0
371%gac_and_2dll System.Runtime.Serialization.Formatters.Soap 4.0 2.0
372%gac_and_2dll System.Security 4.0 2.0
373%gac_and_1dll System.Xaml 4.0
374%gac_and_2dll System.Xml 4.0 2.0
375%gac_and_2dll System.Xml.Linq 4.0 2.0
376%gac_and_2dll OpenSystem.C 4.0 2.0
377%gac_and_2dll WindowsBase 4.0 2.0
378%dir %{_sysconfdir}/mono
379%dir %{_sysconfdir}/mono/4.0
380%dir %{_sysconfdir}/mono/2.0
381%dir %{_sysconfdir}/mono/mconfig
382%config (noreplace) %{_sysconfdir}/mono/config
383%config (noreplace) %{_sysconfdir}/mono/2.0/machine.config
384%config (noreplace) %{_sysconfdir}/mono/4.0/machine.config
385%config (noreplace) %{_sysconfdir}/mono/mconfig/config.xml
386%config (noreplace) %{_sysconfdir}/mono/2.0/settings.map
387%config (noreplace) %{_sysconfdir}/mono/4.0/settings.map
388%{_prefix}/lib/mono-source-libs/
389%{_mandir}/man1/ccrewrite.1.gz
390%{_mandir}/man1/certmgr.1.gz
391%{_mandir}/man1/chktrust.1.gz
392%{_mandir}/man1/csharp.1.gz
393%{_mandir}/man1/gacutil.1.gz
394%{_mandir}/man1/lc.1.gz
395%{_mandir}/man1/mconfig.1.gz
396%{_mandir}/man1/mcs.1.gz
397%{_mandir}/man1/mono.1.gz
398%{_mandir}/man1/monolinker.1.gz
399%{_mandir}/man1/mozroots.1.gz
400%{_mandir}/man1/mprof-report.1.gz
401%{_mandir}/man1/setreg.1.gz
402%{_mandir}/man1/sn.1.gz
403%{_mandir}/man1/resgen.1.gz
404%{_mandir}/man1/mono-api-info.1.gz
405%{_mandir}/man1/mono-cil-strip.1.gz
406%{_mandir}/man5/mono-config.5.gz
407
408%files devel
409%defattr(-,root,root,-)
410%{_bindir}/genxs
411%{_bindir}/mkbundle
412%{_bindir}/mono-gdb.py
413%{_bindir}/monodis
414%{_bindir}/monograph
415%{_bindir}/pedump
416%{_bindir}/xbuild
417%{_libdir}/libmono-2.0.so
418%{_libdir}/libmono-profiler-aot.so
419%{_libdir}/libmono-profiler-cov.so
420%{_libdir}/libmono-profiler-iomap.so
421%{_libdir}/libMonoSupportW.so
422%{_libdir}/libikvm-native.so
423%{mono_dir}/4.0/mkbundle.exe*
424%{mono_dir}/2.0/mkbundle.exe*
425%{mono_dir}/4.0/genxs.exe*
426%{mono_dir}/2.0/genxs.exe*
427%{mono_dir}/2.0/ilasm.exe*
428%bin_and_exe al 4.0/al
429%bin_and_exe al2 2.0/al
430%bin_and_exe caspol 4.0/caspol
431%bin_and_exe cert2spc 4.0/cert2spc
432%bin_and_exe dtd2xsd 4.0/dtd2xsd
433%bin_and_exe dtd2rng 4.0/dtd2rng
434%bin_and_exe sgen 4.0/sgen
435%bin_and_exe ilasm 4.0/ilasm
436%bin_and_exe macpack 4.0/macpack
437%bin_and_exe makecert 4.0/makecert
438%bin_and_exe monop 4.0/monop
439%bin_and_exe monop2 2.0/monop
440%bin_and_exe mono-shlib-cop 4.0/mono-shlib-cop
441%bin_and_exe mono-xmltool 4.0/mono-xmltool
442%bin_and_exe pdb2mdb 4.0/pdb2mdb
443%bin_and_exe permview 4.0/permview
444%bin_and_exe resgen 4.0/resgen
445%bin_and_exe resgen2 2.0/resgen
446%bin_and_exe secutil 4.0/secutil
447%bin_and_exe signcode 4.0/signcode
448%{mono_dir}/xbuild
449%{mono_dir}/xbuild-frameworks
450%{mono_dir}/4.0/xbuild.*
451%{mono_dir}/3.5/xbuild.*
452%{mono_dir}/2.0/xbuild.*
453%{mono_dir}/4.0/culevel.exe*
454%{mono_dir}/2.0/culevel.exe*
455%{mono_dir}/4.0/MSBuild/*.xsd
456%{mono_dir}/3.5/MSBuild/*.xsd
457%{mono_dir}/2.0/MSBuild/*.xsd
458%{mono_dir}/4.0/Microsoft.Build.xsd
459%{mono_dir}/3.5/Microsoft.Build.xsd
460%{mono_dir}/2.0/Microsoft.Build.xsd
461%{mono_dir}/4.0/Microsoft.*.targets
462%{mono_dir}/3.5/Microsoft.*.targets
463%{mono_dir}/2.0/Microsoft.*.targets
464%{mono_dir}/4.0/Microsoft.Common.tasks
465%{mono_dir}/3.5/Microsoft.Common.tasks
466%{mono_dir}/2.0/Microsoft.Common.tasks
467%gac_and_2dll PEAPI 4.0 2.0
468%gac_and_3dll Microsoft.Build.Engine 4.0 3.5 2.0
469%gac_and_3dll Microsoft.Build.Framework 4.0 3.5 2.0
470%gac_and_1dll Microsoft.Build.Tasks 2.0
471%gac_and_1dll Microsoft.Build.Tasks.v4.0 4.0
472%gac_and_1dll Microsoft.Build.Tasks.v3.5 3.5
473%gac_and_1dll Microsoft.Build.Utilities 2.0
474%gac_and_1dll Microsoft.Build.Utilities.v4.0 4.0
475%gac_and_1dll Microsoft.Build.Utilities.v3.5 3.5
476%gac_and_2dll Microsoft.VisualC 4.0 2.0
477%{_libdir}/pkgconfig/cecil.pc
478%{_libdir}/pkgconfig/dotnet.pc
479%{_libdir}/pkgconfig/dotnet35.pc
480%{_libdir}/pkgconfig/mono-cairo.pc
481%{_libdir}/pkgconfig/mono.pc
482%{_libdir}/pkgconfig/mono-2.pc
483%{_libdir}/pkgconfig/mono-lineeditor.pc
484%{_libdir}/pkgconfig/mono-options.pc
485%{_libdir}/pkgconfig/wcf.pc
486%{_includedir}/mono-2.0
487%{_mandir}/man1/al.1.gz
488%{_mandir}/man1/cert2spc.1.gz
489%{_mandir}/man1/dtd2xsd.1.gz
490%{_mandir}/man1/genxs.1.gz
491%{_mandir}/man1/ilasm.1.gz
492%{_mandir}/man1/macpack.1.gz
493%{_mandir}/man1/makecert.1.gz
494%{_mandir}/man1/mkbundle.1.gz
495%{_mandir}/man1/mono-shlib-cop.1.gz
496%{_mandir}/man1/mono-xmltool.1.gz
497%{_mandir}/man1/monodis.1.gz
498%{_mandir}/man1/monop.1.gz
499%{_mandir}/man1/pdb2mdb.1.gz
500%{_mandir}/man1/permview.1.gz
501%{_mandir}/man1/secutil.1.gz
502%{_mandir}/man1/sgen.1.gz
503%{_mandir}/man1/signcode.1.gz
504%{_mandir}/man1/xbuild.1.gz
505
506%files nunit
507%defattr(-,root,root,-)
508%bin_and_exe nunit-console 4.0/nunit-console
509%bin_and_exe nunit-console2 2.0/nunit-console
510%gac_and_2dll nunit.core 4.0 2.0
511%gac_and_2dll nunit.framework 4.0 2.0
512%gac_and_2dll nunit.util 4.0 2.0
513%gac_and_2dll nunit.mocks 4.0 2.0
514%gac_and_2dll nunit-console-runner 4.0 2.0
515%gac_and_2dll nunit.core.extensions 4.0 2.0
516%gac_and_2dll nunit.core.interfaces 4.0 2.0
517%gac_and_2dll nunit.framework.extensions 4.0 2.0
518%{_libdir}/pkgconfig/mono-nunit.pc
519
520%files locale-extras
521%defattr(-,root,root,-)
522%gac_and_2dll I18N.MidEast 4.0 2.0
523%gac_and_2dll I18N.Rare 4.0 2.0
524%gac_and_2dll I18N.CJK 4.0 2.0
525%gac_and_2dll I18N.Other 4.0 2.0
526
527%files extras
528%defattr(-,root,root,-)
529%{_mandir}/man1/mono-service.1.gz
530%bin_and_exe mono-service 4.0/mono-service
531%bin_and_exe mono-service2 2.0/mono-service
532%{mono_dir}/gac/mono-service
533%gac_and_2dll System.Configuration.Install 4.0 2.0
534%gac_and_2dll System.Management 4.0 2.0
535%gac_and_2dll System.Messaging 4.0 2.0
536%gac_and_2dll System.ServiceProcess 4.0 2.0
537%gac_and_2dll System.ServiceModel 4.0 2.0
538%gac_and_1dll System.ServiceModel.Discovery 4.0
539%gac_and_1dll System.ServiceModel.Routing 4.0
540%gac_and_2dll Mono.Messaging.RabbitMQ 4.0 2.0
541%gac_and_2dll Mono.Messaging 4.0 2.0
542%gac_and_2dll RabbitMQ.Client 4.0 2.0
543%{mono_dir}/4.0/RabbitMQ.Client.Apigen.exe*
544%{mono_dir}/2.0/RabbitMQ.Client.Apigen.exe*
545
546%files winforms
547%defattr(-,root,root,-)
548%gac_and_2dll Accessibility 4.0 2.0
549%gac_and_2dll System.Design 4.0 2.0
550%gac_and_2dll System.Drawing.Design 4.0 2.0
551%gac_and_2dll System.Windows.Forms 4.0 2.0
552%gac_and_1dll System.Windows.Forms.DataVisualization 4.0
553
554%files web
555%defattr(-,root,root,-)
556%{mono_dir}/2.0/xsd.exe*
557%{mono_dir}/compat-2.0/System.Web.Extensions*dll
558%{mono_dir}/compat-2.0/System.Web.Mvc.dll
559%bin_and_exe disco 4.0/disco
560%bin_and_exe soapsuds 4.0/soapsuds
561%bin_and_exe xsd 4.0/xsd
562%bin_and_exe wsdl 4.0/wsdl
563%bin_and_exe wsdl2 2.0/wsdl
564%bin_and_exe httpcfg 4.0/httpcfg
565%gac_and_2dll Mono.Http 4.0 2.0
566%gac_and_2dll Mono.Web 4.0 2.0
567%gac_and_2dll Mono.WebBrowser 4.0 2.0
568%gac_and_2dll System.Runtime.Remoting 4.0 2.0
569%gac_and_2dll System.Runtime.Serialization.Formatters.Soap 4.0 2.0
570%gac_and_2dll System.ServiceModel.Web 4.0 2.0
571%gac_and_2dll System.Web 4.0 2.0
572%gac_and_1dll System.Web.ApplicationServices 4.0
573%gac_and_2dll System.Web.Abstractions 4.0 2.0
574%gac_and_2dll System.Web.DynamicData 4.0 2.0
575%gac_and_1dll System.Web.Mvc 2.0
576%gac_and_2dll System.Web.Routing 4.0 2.0
577%gac_and_2dll System.Web.Services 4.0 2.0
578%gac_and_2dll System.Web.Extensions.Design 4.0 2.0
579%gac_and_2dll System.Web.Extensions 4.0 2.0
580%gac_and_1dll Microsoft.Web.Infrastructure 4.0
581%gac_and_1dll WebMatrix.Data 4.0
582%{_mandir}/man1/disco.1.gz
583%{_mandir}/man1/soapsuds.1.gz
584%{_mandir}/man1/wsdl.1.gz
585%{_mandir}/man1/xsd.1.gz
586%config (noreplace) %{_sysconfdir}/mono/browscap.ini
587%config (noreplace) %{_sysconfdir}/mono/2.0/Browsers/Compat.browser
588%config (noreplace) %{_sysconfdir}/mono/4.0/DefaultWsdlHelpGenerator.aspx
589%config (noreplace) %{_sysconfdir}/mono/2.0/DefaultWsdlHelpGenerator.aspx
590%config (noreplace) %{_sysconfdir}/mono/4.0/web.config
591%config (noreplace) %{_sysconfdir}/mono/2.0/web.config
592%{_mandir}/man1/httpcfg.1.gz
593%{_libdir}/pkgconfig/mono.web.pc
594%{_libdir}/pkgconfig/system.web.extensions_1.0.pc
595%{_libdir}/pkgconfig/system.web.extensions.design_1.0.pc
596%{_libdir}/pkgconfig/system.web.mvc.pc
597%{_libdir}/pkgconfig/system.web.mvc2.pc
598
599%files data
600%defattr(-,root,root,-)
601%bin_and_exe sqlsharp 4.0/sqlsharp
602%gac_and_2dll Mono.Data.Tds 4.0 2.0
603%gac_and_2dll Novell.Directory.Ldap 4.0 2.0
604%gac_and_2dll System.Data 4.0 2.0
605%gac_and_2dll System.Data.DataSetExtensions 4.0 2.0
606%gac_and_2dll System.Data.Linq 4.0 2.0
607%gac_and_2dll System.Data.Services 4.0 2.0
608%gac_and_2dll System.Data.Services.Client 4.0 2.0
609%gac_and_2dll System.DirectoryServices 4.0 2.0
610%gac_and_2dll System.EnterpriseServices 4.0 2.0
611%gac_and_2dll System.Transactions 4.0 2.0
612%{_mandir}/man1/sqlsharp.1.gz
613
614%files data-sqlite
615%defattr(-,root,root,-)
616%gac_and_2dll Mono.Data.Sqlite 4.0 2.0
617
618%files data-oracle
619%defattr(-,root,root,-)
620%gac_and_2dll System.Data.OracleClient 4.0 2.0
621
622%files data-postgresql
623%defattr(-,root,root,-)
624%gac_and_2dll Npgsql 4.0 2.0
625
626%files -n ibm-data-db2
627%defattr(-,root,root,-)
628%gac_and_2dll IBM.Data.DB2 4.0 2.0
629
630%files -n monodoc
631%defattr(-, root, root)
632%bin_and_exe mdoc 2.0/mdoc
633%{_bindir}/mdoc-*
634%{_bindir}/mdass*
635%{_bindir}/mdval*
636%{_bindir}/mod
637%{_bindir}/monodoc*
638%{mono_dir}/gac/monodoc
639%{mono_dir}/monodoc/monodoc.dll
640%{mono_doc}/*
641%{_mandir}/man1/md*
642%{_mandir}/man1/monodoc*
643%{_mandir}/man5/mdoc*
644%{_libdir}/pkgconfig/monodoc.pc
645
646
647%changelog
648* Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.6-1
649- updated mono to 2.10.6
650
651* Sat May 07 2011 Shu KONNO <owa@bg.wakwak.com> 2.10.2-1
652- updated mono to 2.10.2
653- dropt Patch1: mono-2.10.1-ppc-len.patch (fixed in the upstream)
654
655* Sun Apr 24 2011 Shu KONNO <owa@bg.wakwak.com> 2.10.1-3
656- added '--with-sgen=no' to all arch
657- dropt %%{mono_dir}/2.0/{mcs.exe,mscorlib.dll}.so
658
659* Sat Apr 16 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.10.1-2
660- remove the old ppc patch (similar codes already in the upstream)
661- add Patch1 (from Gentoo)
662- mono/2.0/mcs.exe.so not available on ppc - remove from the filelist
663  (TODO: see the Fedora's srpm - removing mono/2.0/{mcs,gmcs}.exe.so etc.)
664
665* Sun Apr 03 2011 Shu KONNO <owa@bg.wakwak.com> 2.10.1-1
666- updated mono to 2.10.1
667
668* Sat Jan 08 2011 Shu KONNO <owa@bg.wakwak.com> 2.8.2-1
669- updated mono to 2.8.2
670
671* Tue Dec 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-2
672- add Patch0 (mono-2.8.1-ppc.patch)
673- add configure option "--with-sgen=no" and "--disable-system-aot" (ppc only)
674- fix %%files (add %%ifnarch ppc)
675
676* Sun Nov 21 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.1-1
677- updated mono to 2.8.1
678
679* Sat Nov 06 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-2
680- comment out script that removes prebuilt binaries, because gmcs.exe require
681
682* Fri Oct 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-1
683- updated mono to 2.8
684- modified macros used in %%files
685- removed below:
686  - packages:
687    %{name}-jscript, %{name}-data-sybase, %{name}-data-firebird, bytefx-data-mysql
688  - libraries:
689    ByteFX.Data, FirebirdSql.Data.Firebird
690    Mono.Data Mono.Data.TdsClient, Mono.Data.SybaseClient, Mono.Data.SqliteClient
691    Microsoft.JScript, Microsoft.Vsa
692  - commands:
693    cilc, mjs, prj2make (replaced by xbuild)
694
695* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.6.7-2
696- build with rpm-4.8.1-1 for pkg-config file
697
698* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.7-1
699- updated mono to 2.6.7
700
701* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
702- updated mono to 2.6.4
703
704* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.3-1
705- updated mono to 2.6.3
706  added RabbitMQ.Client.Apigen.exe
707
708* Thu Dec 31 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.1-2
709- unuse _smp_mflags
710
711* Sat Dec 26 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.1-1
712- updated mono to 2.6.1
713- simplified macros
714
715* Mon Dec 14 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-1
716- updated mono to 2.4.3
717  added %%{mono_dir}/2.0/lc.exe*
718  added %%gac_dll System.Web.Mvc
719  added %%{mono_dir}/xbuild/*
720  added %%{_mandir}/man1/lc.1.gz
721  added %%{_mandir}/man1/xbuild.1.gz
722
723* Wed Jul 29 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2.3-1
724- updated mono to 2.4.2.3
725
726* Fri Jul 24 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2.2-1
727- updated mono to 2.4.2.2
728
729* Tue Jul 07 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.2.1-1
730- new upstream release
731- build with latest rpm to update mono-dependencies
732
733* Thu Jul 02 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2-1
734- updated mono to 2.4.2
735
736* Mon Apr 27 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4-3
737- fix temporary workaround against build failure on ppc,
738  from RH bugzilla #494026
739  - statically link mono to libmono: remove "--disable-static" from configure
740  - ensure removing *.a files in the install section
741- remove prebuilt binaries under mcs/class/lib/monolite/ before building
742
743* Sun Apr  5 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
744- fixed paths using %%mono_dir, %%mono_doc macros
745- added Requires:libgluezilla >= 2.4 in monodoc
746
747* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
748- new upstream release
749- added monodoc package (Obsoletes: monodoc-core <= 2.0-1vl5)
750
751* Mon Nov 03 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1
752- new upstream release
753- dropt %%{_bindir}/mono-find-{provides,requires}
754- added --with-libgdiplus=installed
755
756* Mon Oct 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-3
757- update to mono-2.0 released source
758- BR: libgdiplus-devel >= 2.0
759
760* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-2vl5
761- removed *.la
762
763* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1vl5
764- updated mono to 2.0
765- updated url
766- changed macro %%monodir to %%mono_dir
767- dropt mono-1.1.13.4-selinux-ia64.patch
768- dropt mono-1.1.13.4-ppc-threading.patch
769- dropt mono-1.2.3-use-monodir.patch
770
771* Tue Aug 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.5.1-1vl5
772- applied new versioning policy, spec in utf-8
773- dropt mono-1.2.5-libdir.patch
774- reverted monodir macro to using %%{_prefix}/lib/mono
775
776* Sat Dec 29 2007 Shu KONNO <owa@bg.wakwak.com> 1.2.5.1-0vl2
777- updated monodir to %%{_libdir}/mono
778
779* Sat Sep 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5.1-0vl1
780- new upstream release
781- splited mono-basic package
782
783* Sat Oct 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.8.1-0vl1
784- new upstream release
785
786* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.6-0vl1
787- new upstream release
788
789* Thu Apr 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.13.4-2vl2
790- disabled Patch2 on Vine/ppc environment
791
792* Wed Mar 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.4-2vl1
793- updated source and sub-packages based on Fedora packages
794  * Tue Feb 22 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.6-0vl1
795  - new upstream version(mono-1.0.6)
796  * Sun Jan 16 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.5-0vl1
797  - new upstream version(mono-1.0.5)
798  * Sat Nov 06 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.4-0vl1
799  - new upstream version(mono-1.0.4)
800        -- changed to use configure
801  * Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
802  - rebuild for Vine Linux (based on mono.spec inside src archive)
803  - Fixed BuildRequires: gc-devel, libicu-devel
804  - add Japanese translation
805
806* Fri Mar 10 2006 Bill Nottingham <notting@redhat.com> - 1.1.13.4-2
807- rebuild for ppc TLS issue (#184446)
808
809* Fri Mar  3 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.4-1
810- Update to 1.1.13.4
811- Add patch so mono doesn't segfault on PPC SMP machines
812- Minor spec cleanup
813
814* Thu Mar  2 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-5
815- Updated patch from Jakub (1.1.13.2-3 to 1.1.13.2-5 are
816  for bug 182965)
817
818* Tue Feb 28 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-4
819- Updated patch from Paolo Molaro <lupus@ximian.com>
820
821* Mon Feb 27 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-3
822- Patch from Jakub to make work with SELinux better
823
824* Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.2-2
825- Rebuild
826
827* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.1.13.2-1.1
828- rebuilt for new gcc4.1 snapshot and glibc changes
829
830* Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.2-1
831- Update to 1.1.13.2
832
833* Fri Jan 13 2006 Alexander Larsson <alexl@redhat.com> - 1.1.13-1
834- Update to 1.13
835- Add libgdiplus dep to mono-core
836- Add s390x to build
837
838* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 1.1.12.1-1
839- Update to 1.1.12.1
840
841* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 1.1.10-4
842- rebuild
843
844* Fri Nov 18 2005 Alexander Larsson <alexl@redhat.com> 1.1.10-3
845- Disable s390 due to some build failure
846
847* Thu Nov 17 2005 Alexander Larsson <alexl@redhat.com> 1.1.10-2
848- Build on s390 and x86-64 now
849
850* Tue Nov 15 2005 Alexander Larsson <alexl@redhat.com> - 1.1.10-1
851- Initial version
Note: See TracBrowser for help on using the repository browser.