source: projects/specs/branches/6/lib/libm/libmusicbrainz3/libmusicbrainz3-vl.spec @ 2041

Revision 2041, 7.2 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1
2# Fedora package review: http://bugzilla.redhat.com/451643
3
4# do unit tests
5%define _with_check 0
6
7Summary: Library for accessing MusicBrainz servers
8Name: libmusicbrainz3
9Version: 3.0.2
10Release: 1%{?_dist_release}
11License: LGPLv2+
12Group: System Environment/Libraries
13URL: http://www.musicbrainz.org/
14Source0: ftp://ftp.musicbrainz.org/pub/musicbrainz/libmusicbrainz-%{version}.tar.gz
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16
17Source10: doxygen-footer.html
18
19# upstreamed: http://lists.musicbrainz.org/pipermail/musicbrainz-devel/2008-September/002575.html
20# updated to comment out even Requires.private for now, to avoid needless deps
21# (re)introduced by recent fedora pkgconfig behavior change
22Patch2: libmusicbrainz-3.0.1-private.patch
23Patch3: libmusicbrainz-3.0.2-gcc44.patch
24
25BuildRequires: cmake
26%if 0%{?_with_check}
27BuildRequires: cppunit-devel
28%endif
29BuildRequires: doxygen
30BuildRequires: libdiscid-devel
31BuildRequires: neon-devel
32BuildRequires: pkgconfig
33
34%description
35The MusicBrainz client library allows applications to make metadata
36lookup to a MusicBrainz server, generate signatures from WAV data and
37create CD Index Disk ids from audio CD roms.
38
39%package devel
40Summary: Headers for developing programs that will use %{name}
41Group: Development/Libraries
42Requires: %{name} = %{version}-%{release}
43Requires: pkgconfig
44# patch2 removes the need for these
45#Requires: libdiscid-devel neon-devel
46%description devel
47This package contains the headers that programmers will need to develop
48applications which will use %{name}.
49
50
51%prep
52%setup -q -n libmusicbrainz-%{version}
53
54%patch2 -p1 -b .private
55%patch3 -p1 -b .gcc44
56
57# until doxygen is fixed, something like
58# http://bugzilla.gnome.org/show_bug.cgi?id=579303 , hack out
59# mulitilib-conflicting doxygen footers
60install -p %{SOURCE10} doxygen-footer.html
61echo "HTML_FOOTER         = doxygen-footer.html" >> Doxygen
62
63
64%build
65%{cmake} .
66
67make %{?_smp_mflags} all docs
68
69
70%install
71rm -rf %{buildroot}
72
73make install/fast DESTDIR=%{buildroot}
74
75rm -f docs/installdox
76
77
78%check
79%if %{?_with_check}
80make check
81%endif
82
83
84%clean
85rm -rf %{buildroot}
86
87
88%post -p /sbin/ldconfig
89
90%postun -p /sbin/ldconfig
91
92
93%files
94%defattr(-,root,root,-)
95%doc AUTHORS.txt COPYING.txt NEWS.txt README.txt
96%{_libdir}/libmusicbrainz3.so.*
97
98%files devel
99%defattr(-,root,root,-)
100%doc docs/*
101%{_includedir}/musicbrainz3/
102%{_libdir}/libmusicbrainz3.so
103%{_libdir}/pkgconfig/libmusicbrainz3.pc
104
105
106%changelog
107* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
108- initial build for Vine Linux
109
110
111* Tue May 25 2010 Bastien Nocera <bnocera@redhat.com> 3.0.2-7
112- Remove script from devel docs
113
114* Tue Nov 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 3.0.2-7
115- fix/enable unit tests
116
117* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.2-6
118- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
119
120* Mon Jun 29 2009 Rex Dieter <rdieter@fedoraproject.org> - 3.0.2-5
121- fix doxygen-induced multilib conflicts (#480378)
122- add %%check section (disabled by default, pending cppunit detection issues)
123
124* Wed Feb 25 2009 Rex Dieter <rdieter@fedoraproject.org> - 3.0.2-4
125- work harder to omit extraneous pkgconfig deps
126- gcc44 patch
127
128* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.2-3
129- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
130
131* Fri Dec 12 2008 Rex Dieter <rdieter@fedoraproject.org> 3.0.2-2
132- rebuild for pkgconfig deps
133
134* Tue Sep 16 2008 Rex Dieter <rdieter@fedoraproject.org> 3.0.2-1
135- libmusicbrainz3-3.0.2
136
137* Fri Sep 05 2008 Rex Dieter <rdieter@fedoraproject.org> 3.0.1-4
138- Build docs (#461238)
139- -devel: drop extraneous Requires
140
141* Fri Jul 25 2008 Rex Dieter <rdieter@fedoraproject.org> 3.0.1-3
142- fix recursive linking against libdiscid neon
143
144* Thu Jul 24 2008 Rex Dieter <rdieter@fedoraproject.org> 3.0.1-2
145- BR: libdiscid-devel
146- -devel: Requires: libdiscid-devel neon-devel
147
148* Mon Jun 16 2008 Rex Dieter <rdieter@fedoraproject.org> 3.0.1-1
149- libmusicbrainz3-3.0.1
150
151* Sun Jun 15 2008 Rex Dieter <rdieter@fedoraproject.org> 2.1.5-7
152- Provides: libmusicbrainz2(-devel), prepare for libmusicbrainz3
153
154* Fri Feb 22 2008 Rex Dieter <rdieter@fedoraproject.org> 2.1.5-6
155- gcc43 patch (#434127)
156
157* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.1.5-5
158- Autorebuild for GCC 4.3
159
160* Mon Feb 18 2008 Rex Dieter <rdieter@fedoraproject.org> - 2.1.5-4
161- specfile cosmetics
162
163* Thu Nov 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 2.1.5-3
164- use versioned Obsoletes
165- drop (Build)Requires: libstdc++-devel
166- License: LGPLv2+
167
168* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> - 2.1.5-2
169- Rebuild for PPC toolchain bug
170
171* Thu Jun 21 2007 - Bastien Nocera <bnocera@redhat.com> - 2.1.5-1
172- Update to 2.1.5
173
174* Mon Oct 23 2006 Matthias Clasen <mclasen@redhat.com> - 2.1.4-1
175- Update to 2.1.4
176
177* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.1.1-4.1
178- rebuild
179
180* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 2.1.1-4
181- rebuild for -devel deps
182
183* Tue Apr 18 2006 Matthias Clasen <mclasen@redhat.com> - 2.1.1-3
184- apply .spec file cleanups from Matthias Saou (#172926)
185
186* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.1.1-2.1
187- bump again for double-long bug on ppc(64)
188
189* Tue Feb  7 2006 Christopher Aillon <caillon@redhat.com> - 2.1.1-2
190- Stop shipping the .a file in the main package
191
192* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.1.1-1.2
193- rebuilt for new gcc4.1 snapshot and glibc changes
194
195* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
196- rebuilt
197
198* Wed Mar 23 2005 John (J5) Palmieri <johnp@redhat.com> 2.1.1-1
199- Update to upstream version 2.1.1
200- Removed libmusicbrainz-2.0.2-missing-return.patch
201- Removed libmusicbrainz-2.0.2-conf.patch
202
203* Wed Mar 03 2005 John (J5) Palmieri <johnp@redhat.com> 2.0.2-14
204- Add patch to fix percision cast error to compile correctly on s390x
205 
206* Wed Mar 03 2005 John (J5) Palmieri <johnp@redhat.com> 2.0.2-13
207- rebuild with gcc 4.0
208
209* Mon Nov 08 2004 Colin Walters <walters@redhat.com> 2.0.2-12
210- Add libmusicbrainz-2.0.2-missing-return.patch (bug #137289)
211
212* Thu Oct 07 2004 Colin Walters <walters@redhat.com> 2.0.2-11
213- BuildRequire expat-devel
214
215* Tue Sep 28 2004 Colin Walters <walters@redhat.com> 2.0.2-10
216- Move .so symlink to -devel package
217
218* Tue Aug 31 2004 Colin Walters <walters@redhat.com> 2.0.2-9
219- Add ldconfig calls (bz #131281)
220
221* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
222- rebuilt
223
224* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
225- rebuilt
226
227* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
228- rebuilt
229
230* Thu Dec 18 2003 Brent Fox <bfox@redhat.com> 2.0.2-6
231- add a BuildPreReq for libstdc++-devel and gcc-c++ (bug #106556)
232- add a Requires for libstdc++-devel for libmusicbrainz-devel
233
234* Mon Sep  1 2003 Bill Nottingham <notting@redhat.com>
235- Obsoletes musicbrainz-devel too
236
237* Mon Sep  1 2003 Jonathan Blandford <jrb@redhat.com>
238- Obsoletes musicbrainz
239
240* Fri Aug 22 2003 Bill Nottingham <notting@redhat.com> 2.0.2-5
241- fix autoconf/libtool weirdness, remove exclusivearch
242
243* Fri Aug 22 2003 Brent Fox <bfox@redhat.com> 2.0.2-4
244- add ExcludeArch for s390x (something is really broken)
245
246* Fri Aug 22 2003 Brent Fox <bfox@redhat.com> 2.0.2-3
247- add ExcludeArch for ppc64
248
249* Fri Aug 22 2003 Brent Fox <bfox@redhat.com> 2.0.2-2
250- add ExcludeArch for x86_64 for now
251
252* Thu Aug 21 2003 Brent Fox <bfox@redhat.com>
253- Initial build.
254
255
Note: See TracBrowser for help on using the repository browser.