source: projects/specs/trunk/lib/libm/libmusicbrainz3/libmusicbrainz3-vl.spec @ 8758

Revision 8758, 6.9 KB checked in by Takemikaduchi, 10 years ago (diff)

update or rebuild

Line 
1
2# Fedora package review: http://bugzilla.redhat.com/451643
3
4# do unit tests
5%define _with_check 0
6
7Summary: Library for accessing MusicBrainz servers
8Name: libmusicbrainz3
9Version: 3.0.3
10Release: 1%{?_dist_release}
11License: LGPLv2+
12Group: System Environment/Libraries
13URL: http://www.musicbrainz.org/
14Source0: ftp://ftp.musicbrainz.org/pub/musicbrainz/libmusicbrainz-%{version}.tar.gz
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16
17Source10: doxygen-footer.html
18
19BuildRequires: cmake
20%if 0%{?_with_check}
21BuildRequires: cppunit-devel
22%endif
23BuildRequires: doxygen
24BuildRequires: libdiscid-devel
25BuildRequires: neon-devel
26BuildRequires: pkgconfig
27
28%description
29The MusicBrainz client library allows applications to make metadata
30lookup to a MusicBrainz server, generate signatures from WAV data and
31create CD Index Disk ids from audio CD roms.
32
33%package devel
34Summary: Headers for developing programs that will use %{name}
35Group: Development/Libraries
36Requires: %{name} = %{version}-%{release}
37Requires: pkgconfig
38%description devel
39This package contains the headers that programmers will need to develop
40applications which will use %{name}.
41
42
43%prep
44%setup -q -n libmusicbrainz-%{version}
45
46# until doxygen is fixed, something like
47# http://bugzilla.gnome.org/show_bug.cgi?id=579303 , hack out
48# mulitilib-conflicting doxygen footers
49install -p %{SOURCE10} doxygen-footer.html
50echo "HTML_FOOTER         = doxygen-footer.html" >> Doxygen
51
52
53%build
54%{cmake} .
55
56make %{?_smp_mflags} all docs
57
58
59%install
60rm -rf %{buildroot}
61
62make install/fast DESTDIR=%{buildroot}
63
64rm -f docs/installdox
65
66
67%check
68%if %{?_with_check}
69make check
70%endif
71
72
73%clean
74rm -rf %{buildroot}
75
76
77%post -p /sbin/ldconfig
78
79%postun -p /sbin/ldconfig
80
81
82%files
83%defattr(-,root,root,-)
84%doc AUTHORS.txt COPYING.txt NEWS.txt README.txt
85%{_libdir}/libmusicbrainz3.so.*
86
87%files devel
88%defattr(-,root,root,-)
89%doc docs/*
90%{_includedir}/musicbrainz3/
91%{_libdir}/libmusicbrainz3.so
92%{_libdir}/pkgconfig/libmusicbrainz3.pc
93
94
95%changelog
96* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
97- update to 3.0.3
98- remove all patches
99
100* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
101- initial build for Vine Linux
102
103
104* Tue May 25 2010 Bastien Nocera <bnocera@redhat.com> 3.0.2-7
105- Remove script from devel docs
106
107* Tue Nov 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 3.0.2-7
108- fix/enable unit tests
109
110* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.2-6
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
112
113* Mon Jun 29 2009 Rex Dieter <rdieter@fedoraproject.org> - 3.0.2-5
114- fix doxygen-induced multilib conflicts (#480378)
115- add %%check section (disabled by default, pending cppunit detection issues)
116
117* Wed Feb 25 2009 Rex Dieter <rdieter@fedoraproject.org> - 3.0.2-4
118- work harder to omit extraneous pkgconfig deps
119- gcc44 patch
120
121* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.2-3
122- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
123
124* Fri Dec 12 2008 Rex Dieter <rdieter@fedoraproject.org> 3.0.2-2
125- rebuild for pkgconfig deps
126
127* Tue Sep 16 2008 Rex Dieter <rdieter@fedoraproject.org> 3.0.2-1
128- libmusicbrainz3-3.0.2
129
130* Fri Sep 05 2008 Rex Dieter <rdieter@fedoraproject.org> 3.0.1-4
131- Build docs (#461238)
132- -devel: drop extraneous Requires
133
134* Fri Jul 25 2008 Rex Dieter <rdieter@fedoraproject.org> 3.0.1-3
135- fix recursive linking against libdiscid neon
136
137* Thu Jul 24 2008 Rex Dieter <rdieter@fedoraproject.org> 3.0.1-2
138- BR: libdiscid-devel
139- -devel: Requires: libdiscid-devel neon-devel
140
141* Mon Jun 16 2008 Rex Dieter <rdieter@fedoraproject.org> 3.0.1-1
142- libmusicbrainz3-3.0.1
143
144* Sun Jun 15 2008 Rex Dieter <rdieter@fedoraproject.org> 2.1.5-7
145- Provides: libmusicbrainz2(-devel), prepare for libmusicbrainz3
146
147* Fri Feb 22 2008 Rex Dieter <rdieter@fedoraproject.org> 2.1.5-6
148- gcc43 patch (#434127)
149
150* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.1.5-5
151- Autorebuild for GCC 4.3
152
153* Mon Feb 18 2008 Rex Dieter <rdieter@fedoraproject.org> - 2.1.5-4
154- specfile cosmetics
155
156* Thu Nov 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 2.1.5-3
157- use versioned Obsoletes
158- drop (Build)Requires: libstdc++-devel
159- License: LGPLv2+
160
161* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> - 2.1.5-2
162- Rebuild for PPC toolchain bug
163
164* Thu Jun 21 2007 - Bastien Nocera <bnocera@redhat.com> - 2.1.5-1
165- Update to 2.1.5
166
167* Mon Oct 23 2006 Matthias Clasen <mclasen@redhat.com> - 2.1.4-1
168- Update to 2.1.4
169
170* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.1.1-4.1
171- rebuild
172
173* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 2.1.1-4
174- rebuild for -devel deps
175
176* Tue Apr 18 2006 Matthias Clasen <mclasen@redhat.com> - 2.1.1-3
177- apply .spec file cleanups from Matthias Saou (#172926)
178
179* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.1.1-2.1
180- bump again for double-long bug on ppc(64)
181
182* Tue Feb  7 2006 Christopher Aillon <caillon@redhat.com> - 2.1.1-2
183- Stop shipping the .a file in the main package
184
185* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.1.1-1.2
186- rebuilt for new gcc4.1 snapshot and glibc changes
187
188* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
189- rebuilt
190
191* Wed Mar 23 2005 John (J5) Palmieri <johnp@redhat.com> 2.1.1-1
192- Update to upstream version 2.1.1
193- Removed libmusicbrainz-2.0.2-missing-return.patch
194- Removed libmusicbrainz-2.0.2-conf.patch
195
196* Thu Mar 03 2005 John (J5) Palmieri <johnp@redhat.com> 2.0.2-14
197- Add patch to fix percision cast error to compile correctly on s390x
198 
199* Thu Mar 03 2005 John (J5) Palmieri <johnp@redhat.com> 2.0.2-13
200- rebuild with gcc 4.0
201
202* Mon Nov 08 2004 Colin Walters <walters@redhat.com> 2.0.2-12
203- Add libmusicbrainz-2.0.2-missing-return.patch (bug #137289)
204
205* Thu Oct 07 2004 Colin Walters <walters@redhat.com> 2.0.2-11
206- BuildRequire expat-devel
207
208* Tue Sep 28 2004 Colin Walters <walters@redhat.com> 2.0.2-10
209- Move .so symlink to -devel package
210
211* Tue Aug 31 2004 Colin Walters <walters@redhat.com> 2.0.2-9
212- Add ldconfig calls (bz #131281)
213
214* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
215- rebuilt
216
217* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
218- rebuilt
219
220* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
221- rebuilt
222
223* Thu Dec 18 2003 Brent Fox <bfox@redhat.com> 2.0.2-6
224- add a BuildPreReq for libstdc++-devel and gcc-c++ (bug #106556)
225- add a Requires for libstdc++-devel for libmusicbrainz-devel
226
227* Mon Sep  1 2003 Bill Nottingham <notting@redhat.com>
228- Obsoletes musicbrainz-devel too
229
230* Mon Sep  1 2003 Jonathan Blandford <jrb@redhat.com>
231- Obsoletes musicbrainz
232
233* Fri Aug 22 2003 Bill Nottingham <notting@redhat.com> 2.0.2-5
234- fix autoconf/libtool weirdness, remove exclusivearch
235
236* Fri Aug 22 2003 Brent Fox <bfox@redhat.com> 2.0.2-4
237- add ExcludeArch for s390x (something is really broken)
238
239* Fri Aug 22 2003 Brent Fox <bfox@redhat.com> 2.0.2-3
240- add ExcludeArch for ppc64
241
242* Fri Aug 22 2003 Brent Fox <bfox@redhat.com> 2.0.2-2
243- add ExcludeArch for x86_64 for now
244
245* Thu Aug 21 2003 Brent Fox <bfox@redhat.com>
246- Initial build.
247
248
Note: See TracBrowser for help on using the repository browser.