source: projects/specs/branches/6/lib/libi/libidn/libidn-vl.spec @ 1896

Revision 1896, 6.2 KB checked in by inagaki, 14 years ago (diff)

update: libidn

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: libidn
4Summary: Internationalized Domain Name support library
5Version: 1.19
6Release: 1%{?_dist_release}
7
8Group: System Environment/Libraries
9License: GPLv3+
10URL: http://www.gnu.org/software/libidn/
11
12Source0: http://josefsson.org/libidn/releases/libidn-%{version}.tar.gz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: pkgconfig, gettext
16Requires(post): /sbin/install-info
17Requires(preun): /sbin/install-info
18
19%description
20GNU Libidn is an implementation of the Stringprep, Punycode and
21IDNA specifications defined by the IETF Internationalized Domain
22Names (IDN) working group, used for internationalized domain
23names.
24
25%package devel
26Summary: Development files for the libidn library
27Group: Development/Libraries
28Requires: %{name} = %{version}-%{release}
29
30%description devel
31This package includes header files and libraries necessary for
32developing programs which use the GNU libidn library.
33
34# compat32
35%package -n compat32-%{name}
36Summary: Internationalized Domain Name support library
37Group: System Environment/Libraries
38Requires: %{name} = %{version}-%{release}
39
40%description -n compat32-%{name}
41GNU Libidn is an implementation of the Stringprep, Punycode and
42IDNA specifications defined by the IETF Internationalized Domain
43Names (IDN) working group, used for internationalized domain
44names.
45
46%package -n compat32-%{name}-devel
47Summary: Development files for the libidn library
48Group: Development/Libraries
49Requires: compat32-%{name} = %{version}-%{release}
50Requires: %{name}-devel = %{version}-%{release}
51
52%description -n compat32-%{name}-devel
53This package includes header files and libraries necessary for
54developing programs which use the GNU libidn library.
55
56%prep
57%setup -q
58
59# Disable static library creation by default.
60%define with_static 0
61
62%build
63%configure --disable-csharp --disable-java \
64%if ! %{with_static}
65           --disable-static
66%endif
67make %{?_smp_mflags}
68
69make %{?_smp_mflags} -C tests check
70
71%install
72[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
73%makeinstall
74
75rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.la
76
77# provide more examples
78make %{?_smp_mflags} -C examples distclean
79
80# clean up docs
81find doc -name "Makefile*" | xargs rm
82rm -rf $RPM_BUILD_ROOT%{_datadir}/info/dir
83
84%find_lang %{name}
85
86%post
87/sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir
88/sbin/ldconfig
89
90%preun
91if [ $1 = 0 ]; then
92    /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir
93fi
94
95%postun -p /sbin/ldconfig
96
97%post -n compat32-%{name} -p /sbin/ldconfig
98
99%postun -n compat32-%{name} -p /sbin/ldconfig
100
101%clean
102[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
103
104%files -f %{name}.lang
105%defattr(-,root,root)
106%doc ChangeLog NEWS FAQ README THANKS COPYING*
107%{_bindir}/idn
108%{_mandir}/man1/idn.1*
109%{_datadir}/emacs/site-lisp
110%{_libdir}/libidn.so.*
111#{_libdir}/libidn.la
112%{_infodir}/*.info.gz
113
114%files devel
115%defattr(0644,root,root,755)
116%doc doc/libidn.html doc/libidn-components.png examples contrib
117%{_libdir}/libidn.so
118%if %{with_static}
119%{_libdir}/libidn.a
120%endif
121%{_includedir}/*.h
122%{_libdir}/pkgconfig/*.pc
123%{_mandir}/man3/*
124
125# compat32
126%if %{build_compat32}
127%files -n compat32-%{name}
128%defattr(-,root,root)
129%{_libdir}/libidn.so.*
130#{_libdir}/libidn.la
131
132%files -n compat32-%{name}-devel
133%defattr(0644,root,root,755)
134%{_libdir}/libidn.so
135%if %{with_static}
136%{_libdir}/libidn.a
137%endif
138%{_libdir}/pkgconfig/*.pc
139%endif
140
141%changelog
142* Sat Sep 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.19-1
143- new upstream release
144- built with rpm-4.8.1
145
146* Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.11-2
147- added compat32 package for x86_64 arch support.
148- disabled static library creation by default.
149
150* Mon Nov 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.11-1
151- new upstream release
152
153* Thu Jun 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8-1
154- new upstream release
155- applied new versioning policy
156- added --disable-csharp and --disable-java options to %%configure
157
158* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.14-0vl1
159- new upstream release
160
161* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.9-0vl1
162- new upstream release
163
164* Wed Aug 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.18-0vl2
165- rebuild for VineSeed
166
167* Wed Aug 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.18-0vl1
168- new upstream release
169
170* Thu Dec 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.12-0vl2
171- rebuild for VineSeed
172
173* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.12-0vl1
174- new upstream release
175- build for Vine Linux 3.1
176
177* Thu Oct  7 2004 Joe Orton <jorton@redhat.com> 0.5.6-1
178- update to 0.5.6 (#134343)
179
180* Thu Sep 30 2004 Miloslav Trmac <mitr@redhat.com> - 0.5.4-3
181- Fix Group: (#134068)
182
183* Tue Aug 31 2004 Joe Orton <jorton@redhat.com> 0.5.4-2
184- move ldconfig from preun to postun (#131280)
185
186* Sun Aug  8 2004 Joe Orton <jorton@redhat.com> 0.5.4-1
187- update to 0.5.4 (#129341)
188
189* Thu Jul 15 2004 Robert Scheck <redhat@linuxnetz.de> 0.5.2-1
190- upgrade to 0.5.2, enabled i18n support and info files (#127906)
191
192* Fri Jul  9 2004 Joe Orton <jorton@redhat.com> 0.5.1-1
193- update to 0.5.1 (#127496)
194
195* Mon Jun 28 2004 Joe Orton <jorton@redhat.com> 0.5.0-1
196- update to 0.5.0 (#126836)
197
198* Tue Jun 22 2004 Than Ngo <than@redhat.com> 0.4.9-2
199- add prereq: /sbin/ldconfig
200- move la file in main package
201
202* Tue Jun 15 2004 Robert Scheck <redhat@linuxnetz.de> 0.4.9-1
203- upgrade to 0.4.9 (#126353)
204
205* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
206- rebuilt
207
208* Thu Apr 29 2004 Joe Orton <jorton@redhat.com> 0.4.4-1
209- update to 0.4.4; remove contrib from -devel docs
210
211* Thu Apr 29 2004 Joe Orton <jorton@redhat.com> 0.4.3-1
212- update to 0.4.3, remove -rpath patch
213
214* Tue Jan 27 2004 Joe Orton <jorton@redhat.com> 0.3.7-1
215- update to 0.3.7, simplify
216
217* Wed Jan 07 2004 Lenny Cartier <lenny@mandrakesoft.com> 0.3.6-1mdk
218- 0.3.6
219
220* Mon Dec 15 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.5-1mdk
221- 0.3.5
222
223* Sun Oct 19 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.3-2mdk
224- drop the "soname fix" and use the correct way...
225
226* Sat Oct 18 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.3-1mdk
227- 0.3.3
228
229* Mon Oct 13 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.2-1mdk
230- initial cooker contrib
231- used the package from PLD as a start point
Note: See TracBrowser for help on using the repository browser.