source: projects/specs/trunk/lib/libi/libidn/libidn-vl.spec @ 521

Revision 521, 6.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Internationalized Domain Name support library
4Name: libidn
5Version: 1.11
6Release: 2%{?_dist_release}
7URL: http://www.gnu.org/software/libidn/
8License: LGPL
9Source0: http://josefsson.org/libidn/releases/libidn-%{version}.tar.gz
10Group: System Environment/Libraries
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: pkgconfig, gettext
13Requires(post): /sbin/install-info
14Requires(preun): /sbin/install-info
15
16%description
17GNU Libidn is an implementation of the Stringprep, Punycode and
18IDNA specifications defined by the IETF Internationalized Domain
19Names (IDN) working group, used for internationalized domain
20names.
21
22%package devel
23Summary: Development files for the libidn library
24Group: Development/Libraries
25Requires: %{name} = %{version}-%{release}
26Requires: pkgconfig
27
28%description devel
29This package includes header files and libraries necessary for
30developing programs which use the GNU libidn library.
31
32# compat32
33%package -n compat32-%{name}
34Summary: Internationalized Domain Name support library
35Group: System Environment/Libraries
36Requires: %{name} = %{version}-%{release}
37
38%description -n compat32-%{name}
39GNU Libidn is an implementation of the Stringprep, Punycode and
40IDNA specifications defined by the IETF Internationalized Domain
41Names (IDN) working group, used for internationalized domain
42names.
43
44%package -n compat32-%{name}-devel
45Summary: Development files for the libidn library
46Group: Development/Libraries
47Requires: compat32-%{name} = %{version}-%{release}
48Requires: %{name}-devel = %{version}-%{release}
49
50%description -n compat32-%{name}-devel
51This package includes header files and libraries necessary for
52developing programs which use the GNU libidn library.
53
54%prep
55%setup -q
56
57# Disable static library creation by default.
58%define with_static 0
59
60%build
61%configure --disable-csharp --disable-java \
62%if ! %{with_static}
63           --disable-static
64%endif
65make %{?_smp_mflags}
66
67make %{?_smp_mflags} -C tests check
68
69%install
70[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
71%makeinstall
72
73rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.la
74
75# provide more examples
76make %{?_smp_mflags} -C examples distclean
77
78# clean up docs
79find doc -name "Makefile*" | xargs rm
80rm -rf $RPM_BUILD_ROOT%{_datadir}/info/dir
81
82%find_lang %{name}
83
84%post
85/sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir
86/sbin/ldconfig
87
88%preun
89if [ $1 = 0 ]; then
90    /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir
91fi
92
93%postun -p /sbin/ldconfig
94
95%post -n compat32-%{name} -p /sbin/ldconfig
96
97%postun -n compat32-%{name} -p /sbin/ldconfig
98
99%clean
100[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
101
102%files -f %{name}.lang
103%defattr(-,root,root)
104%doc ChangeLog NEWS FAQ README THANKS COPYING*
105%{_bindir}/idn
106%{_mandir}/man1/idn.1*
107%{_datadir}/emacs/site-lisp
108%{_libdir}/libidn.so.*
109#{_libdir}/libidn.la
110%{_infodir}/*.info.gz
111
112%files devel
113%defattr(0644,root,root,755)
114%doc doc/libidn.html doc/libidn-components.png examples contrib
115%{_libdir}/libidn.so
116%if %{with_static}
117%{_libdir}/libidn.a
118%endif
119%{_includedir}/*.h
120%{_libdir}/pkgconfig/*.pc
121%{_mandir}/man3/*
122
123# compat32
124%if %{build_compat32}
125%files -n compat32-%{name}
126%defattr(-,root,root)
127%{_libdir}/libidn.so.*
128#{_libdir}/libidn.la
129
130%files -n compat32-%{name}-devel
131%defattr(0644,root,root,755)
132%{_libdir}/libidn.so
133%if %{with_static}
134%{_libdir}/libidn.a
135%endif
136%{_libdir}/pkgconfig/*.pc
137%endif
138
139%changelog
140* Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.11-2
141- added compat32 package for x86_64 arch support.
142- disabled static library creation by default.
143
144* Mon Nov 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.11-1
145- new upstream release
146
147* Thu Jun 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8-1
148- new upstream release
149- applied new versioning policy
150- added --disable-csharp and --disable-java options to %%configure
151
152* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.14-0vl1
153- new upstream release
154
155* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.9-0vl1
156- new upstream release
157
158* Wed Aug 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.18-0vl2
159- rebuild for VineSeed
160
161* Wed Aug 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.18-0vl1
162- new upstream release
163
164* Thu Dec 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.12-0vl2
165- rebuild for VineSeed
166
167* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.12-0vl1
168- new upstream release
169- build for Vine Linux 3.1
170
171* Thu Oct  7 2004 Joe Orton <jorton@redhat.com> 0.5.6-1
172- update to 0.5.6 (#134343)
173
174* Thu Sep 30 2004 Miloslav Trmac <mitr@redhat.com> - 0.5.4-3
175- Fix Group: (#134068)
176
177* Tue Aug 31 2004 Joe Orton <jorton@redhat.com> 0.5.4-2
178- move ldconfig from preun to postun (#131280)
179
180* Sun Aug  8 2004 Joe Orton <jorton@redhat.com> 0.5.4-1
181- update to 0.5.4 (#129341)
182
183* Thu Jul 15 2004 Robert Scheck <redhat@linuxnetz.de> 0.5.2-1
184- upgrade to 0.5.2, enabled i18n support and info files (#127906)
185
186* Fri Jul  9 2004 Joe Orton <jorton@redhat.com> 0.5.1-1
187- update to 0.5.1 (#127496)
188
189* Mon Jun 28 2004 Joe Orton <jorton@redhat.com> 0.5.0-1
190- update to 0.5.0 (#126836)
191
192* Tue Jun 22 2004 Than Ngo <than@redhat.com> 0.4.9-2
193- add prereq: /sbin/ldconfig
194- move la file in main package
195
196* Tue Jun 15 2004 Robert Scheck <redhat@linuxnetz.de> 0.4.9-1
197- upgrade to 0.4.9 (#126353)
198
199* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
200- rebuilt
201
202* Thu Apr 29 2004 Joe Orton <jorton@redhat.com> 0.4.4-1
203- update to 0.4.4; remove contrib from -devel docs
204
205* Thu Apr 29 2004 Joe Orton <jorton@redhat.com> 0.4.3-1
206- update to 0.4.3, remove -rpath patch
207
208* Tue Jan 27 2004 Joe Orton <jorton@redhat.com> 0.3.7-1
209- update to 0.3.7, simplify
210
211* Wed Jan 07 2004 Lenny Cartier <lenny@mandrakesoft.com> 0.3.6-1mdk
212- 0.3.6
213
214* Mon Dec 15 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.5-1mdk
215- 0.3.5
216
217* Sun Oct 19 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.3-2mdk
218- drop the "soname fix" and use the correct way...
219
220* Sat Oct 18 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.3-1mdk
221- 0.3.3
222
223* Mon Oct 13 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.2-1mdk
224- initial cooker contrib
225- used the package from PLD as a start point
Note: See TracBrowser for help on using the repository browser.