source: projects/specs/trunk/lib/libi/libidn/libidn-vl.spec @ 4856

Revision 4856, 6.3 KB checked in by inagaki, 13 years ago (diff)

update: libidn, ebook-tools

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: libidn
4Summary: Internationalized Domain Name support library
5Version: 1.22
6Release: 1%{?_dist_release}
7
8Group: System Environment/Libraries
9License: GPLv3+
10URL: http://www.gnu.org/software/libidn/
11
12Source0: http://josefsson.org/libidn/releases/libidn-%{version}.tar.gz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: gettext
16BuildRequires: pkgconfig
17Requires(post): /sbin/install-info
18Requires(preun): /sbin/install-info
19
20%description
21GNU Libidn is an implementation of the Stringprep, Punycode and
22IDNA specifications defined by the IETF Internationalized Domain
23Names (IDN) working group, used for internationalized domain
24names.
25
26%package devel
27Summary: Development files for the libidn library
28Group: Development/Libraries
29Requires: %{name} = %{version}-%{release}
30
31%description devel
32This package includes header files and libraries necessary for
33developing programs which use the GNU libidn library.
34
35# compat32
36%package -n compat32-%{name}
37Summary: Internationalized Domain Name support library
38Group: System Environment/Libraries
39Requires: %{name} = %{version}-%{release}
40
41%description -n compat32-%{name}
42GNU Libidn is an implementation of the Stringprep, Punycode and
43IDNA specifications defined by the IETF Internationalized Domain
44Names (IDN) working group, used for internationalized domain
45names.
46
47%package -n compat32-%{name}-devel
48Summary: Development files for the libidn library
49Group: Development/Libraries
50Requires: compat32-%{name} = %{version}-%{release}
51Requires: %{name}-devel = %{version}-%{release}
52
53%description -n compat32-%{name}-devel
54This package includes header files and libraries necessary for
55developing programs which use the GNU libidn library.
56
57%prep
58%setup -q
59
60# Disable static library creation by default.
61%define with_static 0
62
63%build
64%configure --disable-csharp --disable-java \
65%if ! %{with_static}
66           --disable-static
67%endif
68make %{?_smp_mflags}
69
70make %{?_smp_mflags} -C tests check
71
72%install
73[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
74%makeinstall
75
76rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.la
77
78# provide more examples
79make %{?_smp_mflags} -C examples distclean
80
81# clean up docs
82find doc -name "Makefile*" | xargs rm
83rm -rf $RPM_BUILD_ROOT%{_datadir}/info/dir
84
85%find_lang %{name}
86
87%post
88/sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir
89/sbin/ldconfig
90
91%preun
92if [ $1 = 0 ]; then
93    /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir
94fi
95
96%postun -p /sbin/ldconfig
97
98%post -n compat32-%{name} -p /sbin/ldconfig
99
100%postun -n compat32-%{name} -p /sbin/ldconfig
101
102%clean
103[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
104
105%files -f %{name}.lang
106%defattr(-,root,root)
107%doc ChangeLog NEWS FAQ README THANKS COPYING*
108%{_bindir}/idn
109%{_mandir}/man1/idn.1*
110%{_datadir}/emacs/site-lisp
111%{_libdir}/libidn.so.*
112#{_libdir}/libidn.la
113%{_infodir}/*
114
115%files devel
116%defattr(0644,root,root,755)
117%doc doc/libidn.html doc/libidn-components.png examples contrib
118%{_libdir}/libidn.so
119%if %{with_static}
120%{_libdir}/libidn.a
121%endif
122%{_includedir}/*.h
123%{_libdir}/pkgconfig/*.pc
124%{_mandir}/man3/*
125
126# compat32
127%if %{build_compat32}
128%files -n compat32-%{name}
129%defattr(-,root,root)
130%{_libdir}/libidn.so.*
131#{_libdir}/libidn.la
132
133%files -n compat32-%{name}-devel
134%defattr(0644,root,root,755)
135%{_libdir}/libidn.so
136%if %{with_static}
137%{_libdir}/libidn.a
138%endif
139%{_libdir}/pkgconfig/*.pc
140%endif
141
142%changelog
143* Sat Oct  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.22-1
144- new upstream release
145
146* Sat Sep 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.19-1
147- new upstream release
148- built with rpm-4.8.1
149
150* Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.11-2
151- added compat32 package for x86_64 arch support.
152- disabled static library creation by default.
153
154* Mon Nov 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.11-1
155- new upstream release
156
157* Thu Jun 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8-1
158- new upstream release
159- applied new versioning policy
160- added --disable-csharp and --disable-java options to %%configure
161
162* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.14-0vl1
163- new upstream release
164
165* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.9-0vl1
166- new upstream release
167
168* Wed Aug 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.18-0vl2
169- rebuild for VineSeed
170
171* Wed Aug 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.18-0vl1
172- new upstream release
173
174* Thu Dec 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.12-0vl2
175- rebuild for VineSeed
176
177* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.12-0vl1
178- new upstream release
179- build for Vine Linux 3.1
180
181* Thu Oct  7 2004 Joe Orton <jorton@redhat.com> 0.5.6-1
182- update to 0.5.6 (#134343)
183
184* Thu Sep 30 2004 Miloslav Trmac <mitr@redhat.com> - 0.5.4-3
185- Fix Group: (#134068)
186
187* Tue Aug 31 2004 Joe Orton <jorton@redhat.com> 0.5.4-2
188- move ldconfig from preun to postun (#131280)
189
190* Sun Aug  8 2004 Joe Orton <jorton@redhat.com> 0.5.4-1
191- update to 0.5.4 (#129341)
192
193* Thu Jul 15 2004 Robert Scheck <redhat@linuxnetz.de> 0.5.2-1
194- upgrade to 0.5.2, enabled i18n support and info files (#127906)
195
196* Fri Jul  9 2004 Joe Orton <jorton@redhat.com> 0.5.1-1
197- update to 0.5.1 (#127496)
198
199* Mon Jun 28 2004 Joe Orton <jorton@redhat.com> 0.5.0-1
200- update to 0.5.0 (#126836)
201
202* Tue Jun 22 2004 Than Ngo <than@redhat.com> 0.4.9-2
203- add prereq: /sbin/ldconfig
204- move la file in main package
205
206* Tue Jun 15 2004 Robert Scheck <redhat@linuxnetz.de> 0.4.9-1
207- upgrade to 0.4.9 (#126353)
208
209* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
210- rebuilt
211
212* Thu Apr 29 2004 Joe Orton <jorton@redhat.com> 0.4.4-1
213- update to 0.4.4; remove contrib from -devel docs
214
215* Thu Apr 29 2004 Joe Orton <jorton@redhat.com> 0.4.3-1
216- update to 0.4.3, remove -rpath patch
217
218* Tue Jan 27 2004 Joe Orton <jorton@redhat.com> 0.3.7-1
219- update to 0.3.7, simplify
220
221* Wed Jan 07 2004 Lenny Cartier <lenny@mandrakesoft.com> 0.3.6-1mdk
222- 0.3.6
223
224* Mon Dec 15 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.5-1mdk
225- 0.3.5
226
227* Sun Oct 19 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.3-2mdk
228- drop the "soname fix" and use the correct way...
229
230* Sat Oct 18 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.3-1mdk
231- 0.3.3
232
233* Mon Oct 13 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.2-1mdk
234- initial cooker contrib
235- used the package from PLD as a start point
Note: See TracBrowser for help on using the repository browser.