source: projects/specs/branches/6/k/kdevelop/kdevelop-vl.spec @ 4232

Revision 4232, 14.8 KB checked in by inagaki, 13 years ago (diff)

update: kdevplatform, kdevelop

Line 
1Name: kdevelop
2Summary: Integrated Development Environment for C++/C
3Summary(ja): C++/C 向け統合開発環境
4Version: 4.2.3
5Release: 1%{?_dist_release}
6
7License: GPLv2
8URL: http://www.kdevelop.org/
9Group: Applications/Development
10
11Source0: ftp://ftp.kde.org/pub/kde/stable/kdevelop/%{version}/src/kdevelop-%{version}.tar.bz2
12Source1: ftp://ftp.kde.org/pub/kde/stable/kdevelop/%{version}/src/kdevelop-%{version}.md5sum
13
14# fixing https://bugs.kde.org/show_bug.cgi?id=236315
15Patch100: kdevelop-4.0.0-qmake_qt4.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: desktop-file-utils
19BuildRequires: gettext
20BuildRequires: kdebase-workspace-devel
21BuildRequires: kdevplatform-devel >= 1.2.0
22BuildRequires: kdelibs4-devel
23BuildRequires: kdesdk-devel
24BuildRequires: soprano-devel
25BuildRequires: valgrind
26
27Requires: %{name}-libs = %{version}-%{release}
28Requires: kdevplatform >= 1.2.0
29
30#Conflicts: kdevelop
31
32%description
33The KDevelop Integrated Development Environment provides many features
34that developers need as well as providing a unified interface to programs
35like gdb, the C/C++ compiler, and make. KDevelop manages or provides:
36
37All development tools needed for C++ programming like Compiler,
38Linker, automake and autoconf; KAppWizard, which generates complete,
39ready-to-go sample applications; Classgenerator, for creating new
40classes and integrating them into the current project; File management
41for sources, headers, documentation etc. to be included in the
42project; The creation of User-Handbooks written with SGML and the
43automatic generation of HTML-output with the KDE look and feel;
44Automatic HTML-based API-documentation for your project's classes with
45cross-references to the used libraries; Internationalization support
46for your application, allowing translators to easily add their target
47language to a project;
48
49KDevelop also includes WYSIWYG (What you see is what you get)-creation
50of user interfaces with a built-in dialog editor; Debugging your
51application by integrating KDbg; Editing of project-specific pixmaps
52with KIconEdit; The inclusion of any other program you need for
53development by adding it to the "Tools"-menu according to your
54individual needs.
55
56%package libs
57Summary: %{name} runtime libraries
58Summary(ja): %{name} のランタイムライブラリ
59Group:   System Environment/Libraries
60#Requires: %{name} = %{version}-%{release}
61Requires: kdelibs4
62
63%description libs
64%{summary}.
65
66
67%package devel
68Summary: Development files for %{name}
69Summary(ja): %{name} の開発用ファイル
70Group: Development/Libraries
71Requires: %{name}-libs = %{version}-%{release}
72
73%description devel
74%{summary}.
75
76
77%prep
78%setup -q -n kdevelop-%{version}
79#patch100 -p1 -b .qmake_qt4
80
81%build
82mkdir -p %{_target_platform}
83pushd %{_target_platform}
84unset QTDIR || : ; . /etc/profile.d/qt4.sh
85%cmake \
86    -DCMAKE_BUILD_TYPE=release \
87    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
88    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
89    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
90    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
91    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
92    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
93    ..
94popd
95
96make %{?_smp_mflags} -C %{_target_platform}
97
98
99%install
100rm -rf $RPM_BUILD_ROOT
101
102make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
103
104%find_lang %{name} --all-name --with-kde
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109
110%post
111touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
112
113%postun
114if [ $1 -eq 0 ] ; then
115touch --no-create %{_datadir}/icons/hicolor &> /dev/null
116gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
117update-desktop-database -q &> /dev/null
118update-mime-database %{_datadir}/mime &> /dev/null
119fi
120
121%posttrans
122gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
123update-desktop-database -q &> /dev/null
124update-mime-database %{_datadir}/mime &> /dev/null
125
126%post libs -p /sbin/ldconfig
127
128%postun libs -p /sbin/ldconfig
129
130%files -f %{name}.lang
131%defattr(-,root,root)
132%{_bindir}/*
133%config %{_datadir}/config/kdeveloprc
134%{_datadir}/applications/kde4/*.desktop
135%{_datadir}/kde4/apps/kdev*/
136%{_datadir}/kde4/services/*.desktop
137%{_datadir}/icons/hicolor/*/*/*
138%{_datadir}/mime/packages/kdevelop.xml
139#{_datadir}/servicetypes/*
140#doc %{_datadir}/doc/HTML/en/*
141
142%files libs
143%defattr(-,root,root,-)
144%{_libdir}/lib*.so
145%{_libdir}/kde4/*.so
146
147%files devel
148%defattr(-,root,root,-)
149%{_datadir}/kde4/apps/cmake/modules/FindKDevelop.cmake
150%{_includedir}/kde4/kdevelop/
151
152
153%changelog
154* Sat Jun 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.3-1
155- new upstream release
156
157* Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.0-2
158- add BuildRequires: kdesdk-devel, soprano-devel
159
160* Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.0-1
161- new upstream release
162
163* Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.2-1
164- new upstream release
165
166* Sat May  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.0-1
167- new upstream release
168- split shared libraries and header files
169
170* Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-1
171- new upstream release
172- applied new versioning policy, spec in UTF-8
173- changed Group to Applications/Development
174
175* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl2
176- rebuild for VineSeed
177
178* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl1
179- new upstream release
180
181* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl2
182- rebuild for VineSeed
183
184* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl1
185- new upstream release
186
187* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl2
188- rebuild for VineSeed
189
190* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl1
191- new upstream release
192- use ap?-config for Vine3.x and use ap?-1-config for VineSeed
193
194* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
195- rebuild for VineSeed
196
197* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
198- new upstream release
199
200* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
201- rebuild for VineSeed
202
203* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
204- new upstream release
205
206* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl2
207- rebuild for VineSeed
208
209* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl1
210- new upstream release
211- add BuildPrereq: apache2-devel subversion-devel
212
213* Tue Nov 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl0.rc1
214- new upstream release
215
216* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.92-0vl1
217- new upstream release
218- delete Patch0
219
220* Thu Sep 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.91-0vl1
221- new upstream release
222- add Patch0
223- update %%files
224
225* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl2
226- rebuild for VineSeed
227
228* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
229- new upstream release
230
231* Tue Jul  5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
232- rebuild for VineSeed
233
234* Tue Jul  5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
235- new upstream release
236- add --disable-rpath to configure option
237- remove BuildPrereq: qt-static
238
239* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl2
240- rebuild for VineSeed
241
242* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
243- new upstream release
244- update %%files
245- add +w to %%{_prefix}/kdevbdb/*
246
247* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
248- rebuild for VineSeed
249
250* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
251- new upstream release
252- update %%files
253
254* Thu Oct 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
255- source upgrade
256- add BuildPrereq: qt-static
257
258* Wed Aug 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
259- rebuild with qt32
260
261* Wed Jun 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
262- source upgrade
263- remove lines about vine26
264
265* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
266- source upgrade
267- add Requires: ctags
268
269* Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.2-0vl1
270- source upgrade
271- remove all patches
272- remove c references
273- add Requires: htdig
274
275* Fri Feb 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl0
276- change spec to build both VineSeed and Vine2.5/2.6
277- change configure options
278- add %%clean section
279- add Requires: kdbg kdoc kdegraphics kdeutils kdesdk
280
281* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl1
282- source upgrade
283- change spec to build both VineSeed and Vine2.5/2.6
284- change configure option (add -enable--final, remove -enable--debug)
285- update %%files section
286
287* Thu Oct 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.3-0vl1
288- source upgrade
289- remove patch1 (rejected)
290
291* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl2
292- BuildPrereq: autoconf253 objprelink2 instead of autoconf252 objprelink
293
294* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.2-0vl1
295- source upgrade
296- revised Source1
297- remove Patch1 and Patch4
298
299* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.1-3vl1
300- merged with rawhide 2.1.1-3
301- clean up spec
302- add BuildPrereq: objprelink (i386 only)
303- remove Obsoletes: kdevelop-c_c++_ref
304- add BuildPrereq: autoconf252 automake15
305- There is Vine's previous changes, hacked for Vine
306 -- Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0.2-2vl1
307  - build for VineSeed
308  - delete Epoch
309  - update Patch1 and delete Patch2
310
311* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
312- automated rebuild
313
314* Wed Jun 19 2002 Than Ngo <than@redhat.com> 2.1.1-2
315- don't forcibly strip binaries
316
317* Sun Jun  2 2002 Than Ngo <than@redhat.com> 2.1.1-1
318- 2.1.1
319
320* Sun May 26 2002 Tim Powers <timp@redhat.com>
321- automated rebuild
322
323* Thu May 23 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-3
324- Use automake15
325
326* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-2
327- Change sonames
328
329* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-1
330- final
331
332* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-0.cvs20020326.1
333- update
334
335* Wed Mar 20 2002 Than Ngo <than@redhat.com> 2.1rc3-1
336- update to 2.1rc3
337
338* Sun Mar 17 2002 Than Ngo <than@redhat.com> 2.1rc2-1
339- update to 2.1rc2
340
341* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-3
342- rebuild against new kdelibs
343
344* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-2
345- fixed Strange characters appear in the output window (bug #59217)
346- fixed return-line feed sign in Kdevelop setup tool (bug #55032)
347
348* Wed Mar  8 2002 Than Ngo <than@redhat.com> 2.1beta2-1
349- update to 2.1beta2
350
351* Wed Jan 16 2002 Than Ngo <than@redhat.com> 2.1beta1-2
352- rebuild against new kdelibs
353
354* Wed Jan  9 2002 Than Ngo <than@redhat.com> 2.1beta1-1
355- update to 2.1 beta1
356- fix build against gcc 3
357- fix some typo bugs
358- get rid of libkfile
359- update c_cpp_reference to 2.0.1
360
361* Mon Oct 22 2001 Than Ngo <than@redhat.com> 2.0-1
362- add patch to show non lattin1 font in build-in editor correct (bug #54457)
363
364* Sat Sep 22 2001 Than Ngo <than@redhat.com> 2.0-2
365- fix a bug in creating documentation index when running KDevelop Setup (bug #52760)
366- backport some major bugfixes from 2.0.1
367
368* Mon Jul 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010730.1
369- Don't crash on startup
370
371* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010724.1
372- Fix file list
373
374* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010723.1
375- Update
376
377* Mon Feb 26 2001 Bernhard Rosenkraenzer <bero@redhat.com>
378- Yet another respin - printing was broken.
379
380* Sat Feb 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
381- Update the C/C++ reference guide docs. The older version had a
382  couple of examples that won't work with gcc 2.96-*
383
384* Thu Feb 22 2001 Than Ngo <than@redhat.com>
385- fix version number
386
387* Wed Feb 21 2001 Than Ngo <than@redhat.com>
388- 1.4-respin
389
390* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
391- 1.4
392
393* Wed Feb 14 2001 Than Ngo <than@redhat.com>
394- update (only bugfixes)
395- fix up kdelibs documentation path
396- fix a dependency problem with kde-i18n package (Bug #27675)
397- add qt-designer into requires
398
399* Sun Feb 11 2001 Than Ngo <than@redhat.com>
400- fixed to build on s390
401
402* Tue Feb 06 2001 Than Ngo <than@redhat.com>
403- update, only bugfixes
404
405* Wed Jan 24 2001 Than Ngo <than@redhat.com>
406- hacked for building of KDE references
407
408* Tue Jan 23 2001 Than Ngo <than@redhat.com>
409- work-around to build on alpha
410
411* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
412- Update
413
414* Wed Jan 10 2001 Than Ngo <than@redhat.com>
415- update new snapshot, only require KDE2/Qt2
416
417* Fri Dec 22 2000 Than Ngo <than@redhat.com>
418- fixed dependency problem with kde-i18n
419
420* Thu Dec 21 2000 Than Ngo <than@redhat.com>
421- updated to 1.4beta1 with KDE2 support
422- fixed to build on s390
423- fixed some broken codes
424 
425* Fri Dec 8 2000 Than Ngo <than@redhat.com>
426- fixed for building on ia64
427 
428* Wed Nov 15 2000 Than Ngo <than@redhat.com>
429- build snapshot 20001112, it works now with KDE2 and kde1-compat
430- fix libtool to build on sparc and alpha
431- don't use make -j
432 
433* Sun Aug 13 2000 Than Ngo <than@redhat.com>
434- fix kdelibsdoc-dir to show kdelibs-1.1.2 html docu correct
435 
436* Tue Aug 01 2000 Than Ngo <than@redhat.de>
437- add missing ldconfig in %post and %postun section (Bug #14924)
438- add missing C references stuff to kdevelop
439 
440* Sun Jul 30 2000 Than Ngo <than@redhat.de>
441- rebuilt against compat-egcs-c++, put KDE1 under /usr
442- cleanup specfile
443 
444* Tue Jul 25 2000 Than Ngo <than@redhat.de>
445- fix dependency problem
446 
447* Wed Jul 19 2000 Than Ngo <than@redhat.de>
448- rebuilt against compat-libstdc++
449 
450* Mon Jul 17 2000 Than Ngo <than@redhat.de>
451- install under /usr/share instead /usr/lib/kde1-compat/share,
452  fix dependency problem
453 
454* Sat Jul 15 2000 Than Ngo <than@redhat.de>
455- rebuilt with egcs-c++-1.1.2
456
457* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
458- automatic rebuild
459 
460* Mon Jul 03 2000 Than Ngo <than@redhat.de>
461- fix docdir
462- add requires kdebase
463 
464* Sun Jul 02 2000 Than Ngo <than@redhat.de>
465- rebuilt with  kde1-compat
466 
467* Sun Jun 18 2000 Than Ngo <than@redhat.de>
468- rebuilt in the new build environment, fix docdir
469- FHS packaging
470 
471* Thu Jun 08 2000 Than Ngo <than@redhat.de>
472- update to 1.2
473- move from powertools to main CD
474- use %%configure
475 
476* Mon Apr 3 2000 Ngo Than <than@redhat.de>
477- fix up reference (Bug #10368)
478 
479* Tue Feb 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
480- Fix up documentation path (Bug #7291)
481- Update to current stable branch - this should fix up the debugger problem
482- clean up spec file
483 
484* Fri Jan  6 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
485- Update to current stable branch
486- Adapt to 6.2 Qt libraries
487- Use BuildPrereq
488 
489* Wed Jan 05 2000 Ngo Than <than@redhat.de>
490- added patch for alpha
491 
492* Tue Dec 21 1999 Ngo Than <than@redhat.de>
493- updated kdevelop-1.0 release
494 
495* Tue Nov 16 1999 Preston Brown <pbrown@redhat.com>
496- kdevelop 1.0beta4.1, docdir added, using DESTDIR env. variable.
497 
498* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
499- initial packaging for 6.1.
Note: See TracBrowser for help on using the repository browser.