source: projects/specs/branches/6/k/kBuild/kBuild-vl.spec @ 858

Revision 858, 3.7 KB checked in by daisuke, 14 years ago (diff)

kBuild: update to 0.1.5p2

Line 
1%define origver 0.1.5-p2
2
3Summary:        A cross-platform build environment
4Summary(ja):    クロスプラットフォームビルド環境
5
6Name:           kBuild
7Version:        0.1.5p2
8Release:        1%{?_dist_release}
9
10Group:          Development/Tools
11License:        BSD and GPLv2+
12# most tools are from NetBSD, some are from FreeBSD,
13# and make and sed are from GNU
14URL:            http://svn.netlabs.org/kbuild
15Source0:        ftp://ftp.netlabs.org/pub/kbuild/%{name}-%{origver}-src.tar.gz
16Patch0:         kBuild-0.1.3-escape.patch
17Patch1:         kBuild-0.1.5-dprintf.patch
18Patch2:         kBuild-0.1.5-pthread.patch
19BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20
21BuildRequires:  byacc libacl-devel flex
22BuildRequires:  autoconf automake gettext-devel cvs
23
24
25%description
26This is a GNU make fork with a set of scripts to simplify
27complex tasks and portable versions of various UNIX tools to
28ensure cross-platform portability.
29
30It is used mainly to build VirtualBox OSE packages for RPM Fusion
31repository.
32
33
34%prep
35%setup -q -n %{name}-%{origver}
36%patch0 -p1 -b .escape
37%patch1 -p1 -b .dprintf
38%patch2 -p1 -b .pthreads
39
40# Remove prebuilt stuff
41rm -rf kBuild/bin/*
42
43
44%build
45%define bootstrap_mflags %{_smp_mflags} \\\
46        CFLAGS="%{optflags}"            \\\
47        KBUILD_VERBOSE=2
48
49%define mflags %{bootstrap_mflags}      \\\
50        NIX_INSTALL_DIR=%{_prefix}      \\\
51        BUILD_TYPE=release              \\\
52        MY_INST_MODE=0644               \\\
53        MY_INST_BIN_MODE=0755
54
55# The bootstrap would probably not be needed if we depended on ourselves,
56# yet it is not guarranteed that new versions are compilable with older
57# kmk versions, so with this we are on a safer side
58kBuild/env.sh --full make -f bootstrap.gmk %{bootstrap_mflags}
59
60kBuild/env.sh kmk %{mflags} rebuild
61
62
63%install
64rm -rf $RPM_BUILD_ROOT
65export KBUILD_VERBOSE=2
66kBuild/env.sh kmk %{mflags} PATH_INS=$RPM_BUILD_ROOT install
67# These are included later in files section
68rm -r $RPM_BUILD_ROOT%{_docdir}
69
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74
75%files
76%defattr(-,root,root,-)
77%{_bindir}/*
78%{_datadir}/*
79%doc COPYING ChangeLog
80%doc kBuild/doc/COPYING-FDL-1.3 kBuild/doc/QuickReference*
81
82
83%changelog
84* Sun Apr 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.5p2-1
85- update to 0.1.5-p2
86- add patch2 to fix build
87
88* Fri May 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.5-1
89- initial build for Vine Linux
90
91* Mon Apr 13 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-4
92- Fix typoes (Robert P. J. Day, #495393)
93- Comment out the colliding dprintf
94
95* Sun Mar 1 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-3
96- Fix up BRs
97
98* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.5-2
99- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
100
101* Sat Jan 24 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-1
102- Update to new upstream release
103
104* Tue Dec 30 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-0.1.20081106svn
105- Update to build VirtualBox OSE 2.1.0
106
107* Fri Sep 19 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.4-1
108- New upstream release
109
110* Thu Aug 28 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.3-2
111- Add gettext-devel to BRs for autopoint
112
113* Sun Aug 17 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.3-1
114- New upstream version
115- Install into FHS hierarchy
116- Honour optflags
117- No need to be arch specific
118
119* Tue Oct 30 2007 Till Maas <opensource till name> - 0.1.0-0.3.20070627svn
120- add support for x86_64
121- add BR: autoconf, automake
122
123* Wed Jun 27 2007 Till Maas <opensource till name> - 0.1.0-0.2.20070627svn
124- Update to a new version
125- just copy the bin files to %%{_libexecdir}, kmk install does not work
126
127* Sun Feb 18 2007 Till Maas <opensource till name> - 0.1.0-0.1.20070218svn
128- Initial spec for fedora extras
Note: See TracBrowser for help on using the repository browser.