source: projects/specs/trunk/k/kBuild/kBuild-vl.spec @ 521

Revision 521, 3.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        A cross-platform build environment
2Summary(ja):    クロスプラットフォームビルド環境
3
4Name:           kBuild
5Version:        0.1.5
6Release:        1%{?_dist_release}
7
8Group:          Development/Tools
9License:        BSD and GPLv2+
10# most tools are from NetBSD, some are from FreeBSD,
11# and make and sed are from GNU
12URL:            http://svn.netlabs.org/kbuild
13Source0:        ftp://ftp.netlabs.org/pub/kbuild/%{name}-%{version}-src.tar.gz
14Patch0:         kBuild-0.1.3-escape.patch
15Patch1:         kBuild-0.1.5-dprintf.patch
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17
18BuildRequires:  byacc libacl-devel flex
19BuildRequires:  autoconf automake gettext-devel cvs
20
21
22%description
23This is a GNU make fork with a set of scripts to simplify
24complex tasks and portable versions of various UNIX tools to
25ensure cross-platform portability.
26
27It is used mainly to build VirtualBox OSE packages for RPM Fusion
28repository.
29
30
31%prep
32%setup -q
33%patch0 -p1 -b .escape
34%patch1 -p1 -b .dprintf
35
36# Remove prebuilt stuff
37rm -rf kBuild/bin/*
38
39
40%build
41%define bootstrap_mflags %{_smp_mflags} \\\
42        CFLAGS="%{optflags}"            \\\
43        KBUILD_VERBOSE=2
44
45%define mflags %{bootstrap_mflags}      \\\
46        NIX_INSTALL_DIR=%{_prefix}      \\\
47        BUILD_TYPE=release              \\\
48        MY_INST_MODE=0644               \\\
49        MY_INST_BIN_MODE=0755
50
51# The bootstrap would probably not be needed if we depended on ourselves,
52# yet it is not guarranteed that new versions are compilable with older
53# kmk versions, so with this we are on a safer side
54kBuild/env.sh --full make -f bootstrap.gmk %{bootstrap_mflags}
55
56kBuild/env.sh kmk %{mflags} rebuild
57
58
59%install
60rm -rf $RPM_BUILD_ROOT
61export KBUILD_VERBOSE=2
62kBuild/env.sh kmk %{mflags} PATH_INS=$RPM_BUILD_ROOT install
63# These are included later in files section
64rm -r $RPM_BUILD_ROOT%{_docdir}
65
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70
71%files
72%defattr(-,root,root,-)
73%{_bindir}/*
74%{_datadir}/*
75%doc COPYING ChangeLog
76%doc kBuild/doc/COPYING-FDL-1.3 kBuild/doc/QuickReference*
77
78
79%changelog
80* Fri May 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.5-1
81- initial build for Vine Linux
82
83* Mon Apr 13 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-4
84- Fix typoes (Robert P. J. Day, #495393)
85- Comment out the colliding dprintf
86
87* Sun Mar 1 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-3
88- Fix up BRs
89
90* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.5-2
91- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
92
93* Sat Jan 24 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-1
94- Update to new upstream release
95
96* Tue Dec 30 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-0.1.20081106svn
97- Update to build VirtualBox OSE 2.1.0
98
99* Fri Sep 19 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.4-1
100- New upstream release
101
102* Thu Aug 28 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.3-2
103- Add gettext-devel to BRs for autopoint
104
105* Sun Aug 17 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.3-1
106- New upstream version
107- Install into FHS hierarchy
108- Honour optflags
109- No need to be arch specific
110
111* Tue Oct 30 2007 Till Maas <opensource till name> - 0.1.0-0.3.20070627svn
112- add support for x86_64
113- add BR: autoconf, automake
114
115* Wed Jun 27 2007 Till Maas <opensource till name> - 0.1.0-0.2.20070627svn
116- Update to a new version
117- just copy the bin files to %%{_libexecdir}, kmk install does not work
118
119* Sun Feb 18 2007 Till Maas <opensource till name> - 0.1.0-0.1.20070218svn
120- Initial spec for fedora extras
Note: See TracBrowser for help on using the repository browser.