source: projects/specs/trunk/k/kBuild/kBuild-vl.spec @ 4649

Revision 4649, 3.9 KB checked in by shaolin, 13 years ago (diff)
Line 
1%define origver 0.1.9998
2%define svnrev 2543
3
4Summary:        A cross-platform build environment
5Summary(ja):    クロスプラットフォームビルド環境
6
7Name:           kBuild
8Version:        0.1.9998
9Release:        1.svn%{svnrev}%{?_dist_release}
10
11Group:          Development/Tools
12License:        BSD and GPLv2+
13# most tools are from NetBSD, some are from FreeBSD,
14# and make and sed are from GNU
15URL:            http://svn.netlabs.org/kbuild
16#Source0:        ftp://ftp.netlabs.org/pub/kbuild/%{name}-%{origver}-src.tar.gz
17Source0:        kBuild-0.1.9998.svn%{svnrev}.tar.gz
18Patch0:         kBuild-0.1.3-escape.patch
19Patch1:         kBuild-0.1.5-dprintf.patch
20Patch2:         kBuild-0.1.5-pthread.patch
21BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23BuildRequires:  byacc libacl-devel flex
24BuildRequires:  autoconf automake gettext-devel cvs
25
26
27%description
28This is a GNU make fork with a set of scripts to simplify
29complex tasks and portable versions of various UNIX tools to
30ensure cross-platform portability.
31
32It is used mainly to build VirtualBox OSE packages for RPM Fusion
33repository.
34
35
36%prep
37%setup -q -n %{name}-%{origver}.svn%{svnrev}
38%patch0 -p1 -b .escape
39%patch1 -p1 -b .dprintf
40%patch2 -p1 -b .pthreads
41
42# Remove prebuilt stuff
43rm -rf kBuild/bin/*
44
45
46%build
47%define bootstrap_mflags %{_smp_mflags} \\\
48        CFLAGS="%{optflags}"            \\\
49        KBUILD_VERBOSE=2
50
51%define mflags %{bootstrap_mflags}      \\\
52        NIX_INSTALL_DIR=%{_prefix}      \\\
53        BUILD_TYPE=release              \\\
54        MY_INST_MODE=0644               \\\
55        MY_INST_BIN_MODE=0755
56
57# The bootstrap would probably not be needed if we depended on ourselves,
58# yet it is not guarranteed that new versions are compilable with older
59# kmk versions, so with this we are on a safer side
60kBuild/env.sh --full make -f bootstrap.gmk %{bootstrap_mflags}
61
62kBuild/env.sh kmk %{mflags} rebuild
63
64
65%install
66rm -rf $RPM_BUILD_ROOT
67export KBUILD_VERBOSE=2
68kBuild/env.sh kmk %{mflags} PATH_INS=$RPM_BUILD_ROOT install
69# These are included later in files section
70rm -r $RPM_BUILD_ROOT%{_docdir}
71
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76
77%files
78%defattr(-,root,root,-)
79%{_bindir}/*
80%{_datadir}/*
81%doc COPYING ChangeLog
82%doc kBuild/doc/COPYING-FDL-1.3 kBuild/doc/QuickReference*
83
84
85%changelog
86* Wed Aug 24 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.1.9998-1.svn2543
87- updated to 0.1.9998 (svn rev 2543)
88
89* Sun Apr 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.5p2-1
90- update to 0.1.5-p2
91- add patch2 to fix build
92
93* Fri May 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.5-1
94- initial build for Vine Linux
95
96* Mon Apr 13 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-4
97- Fix typoes (Robert P. J. Day, #495393)
98- Comment out the colliding dprintf
99
100* Sun Mar 1 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-3
101- Fix up BRs
102
103* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.5-2
104- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
105
106* Sat Jan 24 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-1
107- Update to new upstream release
108
109* Tue Dec 30 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-0.1.20081106svn
110- Update to build VirtualBox OSE 2.1.0
111
112* Fri Sep 19 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.4-1
113- New upstream release
114
115* Thu Aug 28 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.3-2
116- Add gettext-devel to BRs for autopoint
117
118* Sun Aug 17 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.3-1
119- New upstream version
120- Install into FHS hierarchy
121- Honour optflags
122- No need to be arch specific
123
124* Tue Oct 30 2007 Till Maas <opensource till name> - 0.1.0-0.3.20070627svn
125- add support for x86_64
126- add BR: autoconf, automake
127
128* Wed Jun 27 2007 Till Maas <opensource till name> - 0.1.0-0.2.20070627svn
129- Update to a new version
130- just copy the bin files to %%{_libexecdir}, kmk install does not work
131
132* Sun Feb 18 2007 Till Maas <opensource till name> - 0.1.0-0.1.20070218svn
133- Initial spec for fedora extras
Note: See TracBrowser for help on using the repository browser.