source: projects/specs/branches/6/g/gnome-panel/gnome-panel-vl.spec @ 4034

Revision 4034, 26.8 KB checked in by daisuke, 13 years ago (diff)

gnome-panel: remove bottom panel

Line 
1%define use_eds 1
2
3%define gettext_package gnome-panel-2.0
4
5%define gnome_desktop_version 2.32.1
6%define glib2_version 2.26.1
7%define gtk2_version 2.22.1
8%define libgnome_version 2.32.0
9%define libbonoboui_version 2.24.4
10%define orbit_version 2.14.19
11%define libwnck_version 2.30.5
12%define gconf_version 2.32.0
13%define gnome_menus_version 2.30.4
14%define evolution_data_server_version 2.32.0
15%define cairo_version 1.10.0
16%define dbus_version 1.4.0
17%define dbus_glib_version 0.88
18%define gnome_doc_utils_version 0.3.2
19%define libgweather_version 2.30.3
20%define libcanberra_version 0.25
21%define gobject_introspection_version 0.9.8
22
23Summary: GNOME panel
24Summary(ja): GNOME パネル
25Name: gnome-panel
26Version: 2.32.1
27Release: 4%{_dist_release}
28URL: http://www.gnome.org/
29License: GPL
30Group: User Interface/Desktops
31
32Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-panel/2.32/%{name}-%{version}.tar.bz2
33# Remove this line and next line when upstream adopt Source1
34# clock.gnome-2.32ja.po
35#  (http://l10n.gnome.org/POT/gnome-panel.master/docs/clock.master.ja.po)
36Source1: clock.gnome-2-32.ja.po
37Source2: vine6-panel-default-setup.entries
38Source5: vine-panel-backwards-compat-config.schemas
39Source10: add-translations.sh
40Source12: gnome-compiler-flags.m4
41
42Patch0: gnome-panel-2.28.0-vendor.patch
43Patch1: gnome-panel-2.10.1-speak-to-us-ye-old-wise-fish.patch
44Patch2: gnome-panel-2.28.0-about-vine.patch
45
46# the next three patches belong together
47# http://bugzilla.gnome.org/show_bug.cgi?id=470966
48Patch8: launcher-desktop-files.patch
49Patch9: desktop-file-monitoring.patch
50Patch10: preferred-apps.patch
51
52# don't pop up an error dialog if an applet from the
53# default configuration is missing; we don't want to
54# add a hard dependency on e.g. tomboy
55Patch11: applet-error.patch
56
57BuildRoot: %{_tmppath}/%{name}-%{version}-root
58
59Requires: %{name}-libs = %{version}-%{release}
60Requires: gnome-desktop >= %{gnome_desktop_version}
61Requires: libwnck >= %{libwnck_version}
62Requires: gnome-menus >= %{gnome_menus_version}
63Requires: vine-menus >= 1.1
64Requires(post,postun): scrollkeeper, gtk2
65Requires(post,pre,preun): GConf2
66
67%if %{use_eds}
68Requires: evolution-data-server >= 2.30.2
69%endif
70Requires: libSM
71
72BuildRequires: libxml2-python
73BuildRequires: intltool
74BuildRequires: gettext
75BuildRequires: automake
76BuildRequires: autoconf
77BuildRequires: libtool
78BuildRequires: scrollkeeper
79BuildRequires: libxslt
80BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
81BuildRequires: gtk2-devel >= %{gtk2_version}
82BuildRequires: libgnome-devel >= %{libgnome_version}
83BuildRequires: libbonoboui-devel >= %{libbonoboui_version}
84BuildRequires: libwnck-devel >= %{libwnck_version}
85BuildRequires: GConf2-devel >= %{gconf_version}
86BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
87BuildRequires: cairo-devel >= %{cairo_version}
88BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
89BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
90BuildRequires: gtk-doc
91BuildRequires: pango-devel
92BuildRequires: libbonobo-devel
93BuildRequires: libX11-devel
94BuildRequires: libXau-devel
95%if %{use_eds}
96BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
97BuildRequires: ORBit2-devel >= %{orbit_version}
98BuildRequires: dbus-devel >= %{dbus_version}
99%endif
100BuildRequires: libgweather-devel >= %{libgweather_version}
101BuildRequires: libcanberra-devel >= %{libcanberra_versino}
102BuildRequires: librsvg2-devel
103BuildRequires: polkit-gnome-devel
104BuildRequires: NetworkManager-devel
105BuildRequires: libSM-devel
106BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
107BuildRequires(install): desktop-file-utils
108
109%description
110
111The GNOME panel provides the window list, workspace switcher, menus, and other
112features for the GNOME desktop.
113
114%description -l ja
115
116GNOME パネルは、ウィンドウ一覧・ワークスペース切り換え器・メニューその他の
117特徴を GNOME デスクトップに提供します。
118
119%package libs
120Summary: Libraries for use in panel applets of GNOME
121Summary(ja): GNOME のパネルアップレットで使用するライブラリ
122Group: System Environment/Libraries
123
124%description libs
125Libraries for use in panel applets of GNOME.
126
127%description libs -l ja
128GNOME のパネルアップレットで使用するライブラリ
129
130%package devel
131Summary: Development environment for panel applets of GNOME
132Summary(ja): GNOME のパネルアップレット用開発環境
133Group: Development/Libraries
134Requires: %{name}-libs = %{version}-%{release}
135Requires: pkgconfig
136Requires: gtk2-devel >= %{gtk2_version}
137Requires: libbonoboui-devel >= %{libbonoboui_version}
138Requires: GConf2-devel >= %{gconf_version}
139
140%description devel
141Header files and libraries for building a panel applets of GNOME.
142
143%description devel -l ja
144GNOME のパネルアップレットをビルドするためのヘッダファイル及びライブラリ集
145
146
147%prep
148%setup -q
149
150# Remove this line and next line when upstream adopt Source1
151cp -f %{SOURCE1} help/clock/ja/ja.po
152
153cp -f %{SOURCE2} gnome-panel/panel-default-setup.entries
154cp -f %{SOURCE12} m4
155cp -f %{SOURCE5} gnome-panel/panel-compatibility.schemas
156
157%patch0 -p1 -b .vendor
158%patch1 -p1 -b .speak-to-us-ye-old-wise-fish
159%patch2 -p1 -b .about-vine
160%patch8 -p1 -b .launcher-desktop-files
161%patch9 -p1 -b .desktop-file-monitoring
162%patch10 -p1 -b .preferred-apps
163## %patch11 -p1 -b .applet-error
164
165libtoolize --force --copy
166
167. %{SOURCE10}
168
169%build
170# gpm-integration patches Makefile.am and configure.in
171aclocal -I m4
172automake --add-missing
173autoheader
174autoconf
175%configure --disable-scrollkeeper \
176           --disable-schemas-install \
177           --disable-gtk-doc \
178           --with-in-process-applets=clock:fish \
179           --enable-introspection=yes \
180%if %{use_eds}
181           --enable-eds=yes
182%else
183           --enable-eds=no
184%endif
185make
186
187%install
188rm -rf $RPM_BUILD_ROOT
189
190export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
191make install DESTDIR=$RPM_BUILD_ROOT
192unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
193
194#
195# Create pager and tasklist schemas for compatibility with older
196# configurations which reference the old schema names
197#
198sed -e 's|/schemas/apps/window_list_applet/prefs/|/schemas/apps/tasklist_applet/prefs/|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/window-list.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/tasklist.schemas
199sed -e 's|/schemas/apps/workspace_switcher_applet/prefs/|/schemas/apps/pager_applet/prefs/|; s|<default>1</default>|<default>2</default>|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/workspace-switcher.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/pager.schemas
200
201
202## blow away stuff we don't want
203/bin/rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
204#rmdir --ignore-fail-on-non-empty $RPM_BUILD_ROOT/var
205/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
206
207/bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
208
209sed -i -e "s/NoDisplay=True/NoDisplay=true/" $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
210
211desktop-file-install --delete-original \
212  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
213  $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
214
215%find_lang %{gettext_package} --all-name --with-gnome
216#grep -q '/usr/share/locale' %{gettext_package}.lang || exit 1
217
218%clean
219rm -rf $RPM_BUILD_ROOT
220
221%post
222touch --no-create %{_datadir}/icons/hicolor
223if [ -x /usr/bin/gtk-update-icon-cache ]; then
224  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
225fi
226
227export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
228
229#
230# Clear out the old defaults
231#
232gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /apps/panel > /dev/null || :
233gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /schemas/apps/panel > /dev/null || :
234
235# install schemas
236SCHEMAS="clock.schemas fish.schemas pager.schemas \
237        panel-compatibility.schemas panel-general.schemas \
238        panel-global.schemas panel-object.schemas panel-toplevel.schemas \
239        tasklist.schemas window-list.schemas workspace-switcher.schemas"
240for S in $SCHEMAS; do
241    echo %{_sysconfdir}/gconf/schemas/$S ; done \
242    | xargs gconftool-2 --makefile-install-rule >& /dev/null ||:
243
244#
245# Install the default setup into /apps/panel and /apps/panel/default_setup
246#
247gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/panel-default-setup.entries > /dev/null || :
248gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/panel-default-setup.entries /apps/panel > /dev/null || :
249
250/sbin/ldconfig
251scrollkeeper-update > /dev/null 2>&1 || :
252
253%pre
254if [ "$1" -gt 1 ]; then
255  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
256  SCHEMAS="clock.schemas fish.schemas pager.schemas \
257          panel-compatibility.schemas panel-general.schemas \
258          panel-global.schemas panel-object.schemas panel-toplevel.schemas \
259          tasklist.schemas window-list.schemas workspace-switcher.schemas"
260  for S in $SCHEMAS; do
261      echo %{_sysconfdir}/gconf/schemas/$S ; done \
262      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
263fi
264
265%preun
266if [ "$1" -eq 0 ]; then
267  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
268  SCHEMAS="clock.schemas fish.schemas pager.schemas \
269          panel-compatibility.schemas panel-general.schemas \
270          panel-global.schemas panel-object.schemas panel-toplevel.schemas \
271          tasklist.schemas window-list.schemas workspace-switcher.schemas"
272  for S in $SCHEMAS; do
273      echo %{_sysconfdir}/gconf/schemas/$S ; done \
274      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
275fi
276
277%postun
278/sbin/ldconfig
279scrollkeeper-update > /dev/null 2>&1 || :
280touch --no-create %{_datadir}/icons/hicolor
281if [ -x /usr/bin/gtk-update-icon-cache ]; then
282  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
283fi
284 
285%files -f %{gettext_package}.lang
286%defattr(-,root,root)
287%doc AUTHORS COPYING COPYING.LIB COPYING-DOCS NEWS README
288%{_datadir}/applications/*.desktop
289%{_datadir}/icons/*
290%{_datadir}/gnome-panel
291%exclude %{_datadir}/gnome-panelrc
292%{_datadir}/idl/gnome-panel-2.0
293%{_datadir}/gnome-2.0/ui/*
294%{_mandir}/man*/*
295%{_bindir}/*
296%exclude %{_bindir}/panel-test-applets
297%{_libexecdir}/*
298%{_libdir}/gnome-panel/modules/libpanel-applets-bonobo.*
299%{_sysconfdir}/gconf/schemas/*.schemas
300%{_sysconfdir}/gconf/schemas/*.entries
301%{_datadir}/dbus-1/services/org.gnome.panel.applet.ClockAppletFactory.service
302%{_datadir}/dbus-1/services/org.gnome.panel.applet.FishAppletFactory.service
303%{_datadir}/dbus-1/services/org.gnome.panel.applet.NotificationAreaAppletFactory.service
304%{_datadir}/dbus-1/services/org.gnome.panel.applet.WnckletFactory.service
305
306%files libs
307%{_libdir}/*.so.*
308%{_libdir}/girepository-1.0
309
310%files devel
311%{_bindir}/panel-test-applets
312%{_libdir}/pkgconfig/*.pc
313%{_includedir}/gnome-panel-3.0
314%{_includedir}/panel-2.0
315%{_libdir}/*.so
316%{_datadir}/gtk-doc
317%{_datadir}/gir-1.0
318
319
320%changelog
321* Fri Jun 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-4
322- update SOURCE2(vine6-panel-default-setup.entries)
323  - remove bottom panel
324  - move window_list and workspace_switcher applet to top panel
325
326* Sat Dec 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-3
327- update Source1 (clock.gnome-2.32.ja.po)
328
329* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
330- remove Provides: gnome-panel-devel
331
332* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
333- new upstream release
334
335* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.2-1
336- new upstream release
337- add BuildRequires: gobject-introspection-devel
338- remove BuildRequires: libgnomeui-devel
339- remove SOURCE3 and SOURCE4
340- drop Patch11
341- add configure option (--enable-introspection=yes)
342
343* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
344- rebuild with rpm-4.8.1 for pkg-config file
345
346* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
347- create -libs and -devel package
348
349* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
350- new upstream release
351
352* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
353- rebuild with evolution-data-server-2.30.2
354
355* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
356- new upstream release
357- update Patch8, Patch9 (from FC package)
358- add BuildRequires: libcanberra-devel
359
360* Sat Mar 27 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-4
361- update translation of clock applet manual
362- add translation of fish applet manual
363
364* Fri Mar 26 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-3
365- add libSM(-devel) to (Build)Requires
366- add desktop-file-utils to BuildRequires
367
368* Thu Mar 25 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-2
369- update translation of clock applet manual
370
371* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
372- new upstream release
373- updated Patch0 and 2
374
375* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
376- new upstream release
377
378* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-3
379- rebuild with gtk2-2.16.3
380
381* Thu Jun 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
382- add empty gconf entries to vine-panel-default-setup.entries
383
384* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
385- new upstream release
386
387* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
388- new upstream release
389
390* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
391- update vine-panel-default-setup.entries again..
392
393* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
394- update vine-panel-default-setup.entries
395
396* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
397- remove mixer applets from default panel setup
398
399* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
400- new upstream release
401
402* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
403- new upstream release
404- added BuildRequires: PolicyKit-gnome-devel
405
406* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
407- new upstream release
408
409* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
410- new upstream release
411
412* Tue Jun  3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
413- new upstream release
414
415* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.3-1
416- new upstream release
417
418* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.2-1vl5
419- new upstream release
420- removed Patch25,26,27,29 and 30 (merged into upstream)
421
422* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-2vl5
423- added Patches from FC
424  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-8
425  - Fix editing of locations in the clock applet
426  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-7
427  - Convert the edit and find location windows to dialogs
428  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-6
429  - Improve the time settings window
430  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-5
431  - Make the find-location window of the clock larger
432  * Sat Mar 15 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-4
433  - Only save the session when the users wants it
434  * Fri Mar 14 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-3
435  - Populate the location list before showing the preference window
436  * Sat Mar  8 2008 Will Woods <wwoods@redhat.com> - 2.21.92-6
437  - Add "About This Computer" item to System menu if it exists
438  * Wed Feb 20 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-6
439  - Try harder to avoid resizing the popup
440- updated BuildRequires
441
442* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
443- new upstream release
444- added BuildRequires: libgweather-devel
445
446* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
447- new upstream release
448- updated %post and %postun section
449- added %pre and %preun section
450- added Patches from Fedora
451  * Fri Oct 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-4
452  - Sharper icons
453  * Wed Oct  3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-3
454  - Make it possible to start s-c-d from the clock menu again (#316921)
455  * Fri Sep 21 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-2
456  - Don't pop up an error if an applet from the default
457    configuration is missing 
458  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-6
459  - Turns out we need requires for applets in the default config (#293261)
460  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-5
461  - Drop the requires for fast-user-switch-applet (#253831)
462
463* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
464- new upstream release
465- dropped Patch22 (merged into upstream)
466
467* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
468- new upstream release
469
470* Mon Oct 30 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl2
471- add missing BuildRequires to gnome-menus-devel (<BTS:319>)
472
473* Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
474- new upstream release
475- fix panel-default-setup.entries to change the name of
476  firefox desktopfile (<BTS:229>)
477
478* Thu Jul 20 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.2-0vl2
479- add patch 11 to fix disappearing of recent documents list.
480  <BTS:VineLinux:81>, http://bugzilla.gnome.org/show_bug.cgi?id=343812
481
482* Sat Jun  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
483- new upstream release
484
485* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
486- new upstream release
487
488* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
489- run gtk-update-icon-cache in %%post script.
490
491* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
492- new upstream release
493
494* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl2
495- update vine-panel-default-setup.entries
496  - replace mozilla by firefox
497  - remove nautilus
498  - add notification area applet on top panel
499  - add trashbox applet on bottom panel
500- cleanup %%post script
501
502* Thu Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl1
503- new upstream release
504
505* Sun Feb 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
506- new upstream release
507- added Prereq: scroolkeeper, GConf2
508
509* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
510- new upstream release
511
512* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
513- new upstream release
514
515* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
516- new upstream release
517
518* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
519- new upstream release
520
521* Thu Jul 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
522- new upstream release
523
524* Sat Apr 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
525- disable evolution-data-server
526
527* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
528- new upstream release
529
530* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
531- add Patch10 to fix hard-coded desktop file name.
532
533* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
534- new upstream version
535
536* Fri Feb 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
537- new upstream release
538- run scrollkeeper at %post, %postun
539
540* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
541- new upstream release
542
543* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
544- add Patch10 to fix egg-recent-model.c.
545  save old umask value before create ".recently-used" file.
546 
547* Sun Oct 24 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.4.2-0vl2
548- fix location of nautilus launcher in panel-default-setup.entries.
549- do not add wireless monitor in %%post when no interfaces are available.
550- add Japanese summary and description
551- add BuildRequires: startup-notification-devel, gcc-c++.
552- disable libtoolize: version mismatch is bad
553
554* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
555- new upstream release
556
557* Sat Dec 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
558- new upstream release
559
560* Sat Dec 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl3
561- rebuilt against new toolchain
562
563* Fri Sep 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
564- add --disable-schemas-install option to %%configure
565
566* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
567- new upstream release
568
569* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl2
570- add missing files
571- add vine default panel entries
572
573* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl1
574- new upstream release
575
576* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
577- new upstream release
578
579* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-0vl1
580- new upstream release
581
582* Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl2
583- remove vine's panel-per-panel-config.schemas
584  This should be added again in a future version.
585
586* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl1
587- new upstream release
588
589* Tue Apr 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
590- new upstream release
591- remove old ja.po
592
593* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
594- new upstream release
595
596* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
597- remove clockaddon, system-tray-applet
598
599* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
600- new upstream release
601
602* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl2
603- add patch1 from rawhide package.
604
605* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl1
606- new upstream release
607
608* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
609- add system-tray-applet
610- modify default panel menu.
611- update ja.po
612
613* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
614- add Requires: vine-menus
615
616* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
617- new upstream release
618
619* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
620- remove redhatize patch.
621
622* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
623- build for Vine Linux
624- new upstream release from gnome-2.1.4
625
626* Mon Oct 14 2002 Florian La Roche <Florian.LaRoche@redhat.de>
627- fix postun script
628
629* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
630- 2.0.9 with menu edit stuff
631- system-tray-applet 0.15 that doesn't crash all the time
632- merge/remove patches as appropriate
633
634* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
635- Fix problem with "hold down print screen" (71432)
636
637* Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
638- panel-properties OnlyShowIn=GNOME;
639- somehow the po file got screwed up.  Works now
640- update po files
641
642* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
643- fix from #71762 for clock applet popdown key
644- no WIN_POS_MOUSE fixes #72167
645- fix for #72540 from George
646
647* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
648- system tray applet 0.11 with a small memleak fix and a couple translations
649
650* Thu Aug 15 2002 Jonathan Blandford <jrb@redhat.com>
651- menu tweaks
652
653* Wed Aug 14 2002 Tim Powers <timp@redhat.com>
654- bump release
655
656* Wed Aug 14 2002 Preston Brown <pbrown@redhat.com>
657- put battery applet on panel for laptops (#67296)
658
659* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
660- 2.0.6 final from gnome 2.0.1
661- remove gnome-panel-screenshot patch now upstream
662
663* Thu Aug  8 2002 Jonathan Blandford <jrb@redhat.com>
664- new system-tray-applet version
665- Fix gnome-panel-screenshot
666
667* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
668- 2.0.4
669- replace gnome-logo-icon-transparent.png with redhat-main-menu.png
670  for the foot menu
671
672* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
673- fix desktop (logout/lock) menu item location
674  in Alt+F1 and in new menu applets
675- remove Screenshot... menu item
676
677* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
678- move around default applets, remove some of them
679- system tray 0.9
680- change default menu flags
681- blow unpackaged files out of build root
682
683* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
684- 2.0.3
685- own libexecdir stuff
686
687* Thu Jul 25 2002 Havoc Pennington <hp@redhat.com>
688- new system tray that's prettier and doesn't clip the icon
689
690* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
691- system tray 0.7 that doesn't crash on startup
692- get Mozilla desktop file right so we get web browser launcher
693
694* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
695- system tray 0.6 with server file fixed (work dammit)
696
697* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
698- tweak applet positions but I think it's just broken
699- system tray 0.5 moved back to libdir not libexecdir
700
701* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
702- remove ltmain.sh hack
703- new system-tray-applet that works
704
705* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
706- put office suite stuff on the panel
707
708* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
709- 2.0.2.90 cvs snap
710
711* Wed Jul 10 2002 Havoc Pennington <hp@redhat.com>
712- update the clock patch to be a little smarter in a couple ways
713
714* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
715- Fix problem where system tray applet was being looked for in /unst
716- Fix a crash in the system tray applet
717
718* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
719- Fix typo in the pt_BR translation that was causing GConf problems
720
721* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
722- add the system tray applet
723- add system tray applet by default
724- add more launcher by default
725
726* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
727- automated rebuild
728
729* Thu Jun 20 2002 Havoc Pennington <hp@redhat.com>
730- use correct gettext package name, and add check for missing translations
731
732* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
733- add the calendar and configuration patch
734
735* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
736- 2.0.0
737- add control center desktop file to file list
738- add gnome-panelrc to file list
739- try fixing panel size (blind, no text box at home)
740
741* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
742- rebuild in different environment
743
744* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
745- updates to default configuration
746
747* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
748- fix schemas installation
749
750* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
751- unset old panel schemas when installing new ones
752- put in a broken panel config to see errors about
753- add a patch to give some decent error messages about what's wrong
754  with the default panel config
755
756* Sun Jun 09 2002 Havoc Pennington <hp@redhat.com>
757- rebuild in different environment
758
759* Sun Jun  9 2002 Havoc Pennington <hp@redhat.com>
760- don't provide/obsolete gnome-core
761
762* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
763- rebuild in different environment
764
765* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
766- 1.5.24
767- ldconfig
768
769* Mon Jun 03 2002 Havoc Pennington <hp@redhat.com>
770- rebuild in different environment
771
772* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
773- 1.5.23
774
775* Sun May 26 2002 Tim Powers <timp@redhat.com>
776- automated rebuild
777
778* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
779- rebuild in different environment
780
781* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
782- 1.5.22
783- provide gnome-core
784- add a bunch of extra build requires so build system
785  won't get confused
786
787* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
788- 1.5.19
789
790* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
791- add the keep-libtool-from-relinking hack so
792  we get the gen util applet
793
794* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
795- obsoletes gnome-core-devel
796- include libdir/*.so
797
798* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
799- get libpanel-applet in the package
800
801* Tue Apr 16 2002 Havoc Pennington <hp@redhat.com>
802- Initial build.
803
804
Note: See TracBrowser for help on using the repository browser.