source: projects/specs/trunk/g/gnome-panel/gnome-panel-vl.spec @ 4616

Revision 4616, 25.4 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define use_eds 1
2
3%define gettext_package gnome-panel-2.0
4
5%define gnome_desktop3_version 3.0.0
6%define glib2_version 2.26.0
7%define gtk2_version 2.22.0
8%define libgnome_version 2.32.0
9%define libbonoboui_version 2.24.4
10%define orbit_version 2.14.19
11%define libwnck3_version 3.0.0
12%define gconf_version 2.32.0
13%define gnome_menus_version 2.30.4
14%define evolution_data_server_version 2.32.0
15%define cairo_version 1.10.0
16%define dbus_version 1.4.0
17%define dbus_glib_version 0.88
18%define gnome_doc_utils_version 0.3.2
19%define libgweather_version 2.30.3
20%define libcanberra_version 0.25
21%define gobject_introspection_version 0.9.8
22
23Summary: GNOME panel
24Summary(ja): GNOME パネル
25Name: gnome-panel
26Version: 3.0.2
27Release: 1%{_dist_release}
28URL: http://www.gnome.org/
29License: GPL
30Group: User Interface/Desktops
31
32Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-panel/3.0/%{name}-%{version}.tar.bz2
33# Remove this line and next line when upstream adopt Source1
34Source1: clock.gnome-2-32.ja.po
35Source2: vine6-panel-default-setup.entries
36Source5: vine-panel-backwards-compat-config.schemas
37Source10: add-translations.sh
38Source12: gnome-compiler-flags.m4
39
40BuildRoot: %{_tmppath}/%{name}-%{version}-root
41
42Requires: %{name}-libs = %{version}-%{release}
43Requires: gnome-desktop3 >= %{gnome_desktop3_version}
44Requires: libwnck3 >= %{libwnck3_version}
45Requires: gnome-menus >= %{gnome_menus_version}
46Requires: vine-menus >= 1.1
47Requires(post,postun): scrollkeeper, gtk2
48Requires(post,pre,preun): GConf2
49
50%if %{use_eds}
51Requires: evolution-data-server >= 2.30.2
52%endif
53Requires: libSM
54
55BuildRequires: libxml2-python
56BuildRequires: intltool
57BuildRequires: gettext
58BuildRequires: automake
59BuildRequires: autoconf
60BuildRequires: libtool
61BuildRequires: scrollkeeper
62BuildRequires: libxslt
63BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
64BuildRequires: gtk3-devel >= %{gtk3_version}
65BuildRequires: libgnome-devel >= %{libgnome_version}
66BuildRequires: libbonoboui-devel >= %{libbonoboui_version}
67BuildRequires: libwnck3-devel >= %{libwnck3_version}
68BuildRequires: GConf2-devel >= %{gconf_version}
69BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
70BuildRequires: cairo-devel >= %{cairo_version}
71BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
72BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
73BuildRequires: gtk-doc
74BuildRequires: pango-devel
75BuildRequires: libbonobo-devel
76BuildRequires: libX11-devel
77BuildRequires: libXau-devel
78%if %{use_eds}
79BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
80BuildRequires: ORBit2-devel >= %{orbit_version}
81BuildRequires: dbus-devel >= %{dbus_version}
82%endif
83BuildRequires: libgweather-devel >= %{libgweather_version}
84BuildRequires: libcanberra-devel >= %{libcanberra_versino}
85BuildRequires: librsvg2-devel
86BuildRequires: polkit-gnome-devel
87BuildRequires: NetworkManager-devel
88BuildRequires: libSM-devel
89BuildRequires: gobject-introspection-devel >= %{gobject_introspection_version}
90BuildRequires: dconf-devel
91BuildRequires(install): desktop-file-utils
92
93Obsoletes: gnome-netstatus < 2.29
94
95%description
96
97The GNOME panel provides the window list, workspace switcher, menus, and other
98features for the GNOME desktop.
99
100%description -l ja
101
102GNOME パネルは、ウィンドウ一覧・ワークスペース切り換え器・メニューその他の
103特徴を GNOME デスクトップに提供します。
104
105%package libs
106Summary: Libraries for use in panel applets of GNOME
107Summary(ja): GNOME のパネルアップレットで使用するライブラリ
108Group: System Environment/Libraries
109
110%description libs
111Libraries for use in panel applets of GNOME.
112
113%description libs -l ja
114GNOME のパネルアップレットで使用するライブラリ
115
116%package devel
117Summary: Development environment for panel applets of GNOME
118Summary(ja): GNOME のパネルアップレット用開発環境
119Group: Development/Libraries
120Requires: %{name}-libs = %{version}-%{release}
121Requires: pkgconfig
122Requires: gtk2-devel >= %{gtk2_version}
123Requires: libbonoboui-devel >= %{libbonoboui_version}
124Requires: GConf2-devel >= %{gconf_version}
125
126%description devel
127Header files and libraries for building a panel applets of GNOME.
128
129%description devel -l ja
130GNOME のパネルアップレットをビルドするためのヘッダファイル及びライブラリ集
131
132
133%prep
134%setup -q
135
136# Remove this line and next line when upstream adopt Source1
137cp -f %{SOURCE1} help/clock/ja/ja.po
138
139cp -f %{SOURCE2} gnome-panel/panel-default-setup.entries
140cp -f %{SOURCE12} m4
141cp -f %{SOURCE5} gnome-panel/panel-compatibility.schemas
142
143. %{SOURCE10}
144
145%build
146# gpm-integration patches Makefile.am and configure.in
147#aclocal -I m4
148#automake --add-missing
149#autoheader
150#autoconf
151autoreconf -if
152%configure --disable-scrollkeeper \
153           --disable-schemas-install \
154           --disable-gtk-doc \
155           --with-in-process-applets=clock:fish \
156           --enable-introspection=yes \
157           --enable-telepathy-glib=yes \
158%if %{use_eds}
159           --enable-eds=yes
160%else
161           --enable-eds=no
162%endif
163make
164
165%install
166rm -rf $RPM_BUILD_ROOT
167
168export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
169make install DESTDIR=$RPM_BUILD_ROOT
170unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
171
172#
173# Create pager and tasklist schemas for compatibility with older
174# configurations which reference the old schema names
175#
176#sed -e 's|/schemas/apps/window_list_applet/prefs/|/schemas/apps/tasklist_applet/prefs/|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/window-list.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/tasklist.schemas
177#sed -e 's|/schemas/apps/workspace_switcher_applet/prefs/|/schemas/apps/pager_applet/prefs/|; s|<default>1</default>|<default>2</default>|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/workspace-switcher.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/pager.schemas
178
179
180## blow away stuff we don't want
181/bin/rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
182#rmdir --ignore-fail-on-non-empty $RPM_BUILD_ROOT/var
183/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
184
185/bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
186
187sed -i -e "s/NoDisplay=True/NoDisplay=true/" $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
188
189desktop-file-install --delete-original \
190  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
191  $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
192
193%find_lang %{gettext_package} --all-name --with-gnome
194#grep -q '/usr/share/locale' %{gettext_package}.lang || exit 1
195
196%clean
197rm -rf $RPM_BUILD_ROOT
198
199%post
200touch --no-create %{_datadir}/icons/hicolor
201if [ -x /usr/bin/gtk-update-icon-cache ]; then
202  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
203fi
204
205export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
206
207#
208# Clear out the old defaults
209#
210gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /apps/panel > /dev/null || :
211gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /schemas/apps/panel > /dev/null || :
212
213# install schemas
214SCHEMAS="clock.schemas"
215for S in $SCHEMAS; do
216    echo %{_sysconfdir}/gconf/schemas/$S ; done \
217    | xargs gconftool-2 --makefile-install-rule >& /dev/null 2>&1 ||:
218
219#
220# Install the default setup into /apps/panel and /apps/panel/default_setup
221#
222gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/clock.schemas > /dev/null 2>&1 || :
223
224/sbin/ldconfig
225scrollkeeper-update > /dev/null 2>&1 || :
226
227%pre
228if [ "$1" -gt 1 ]; then
229  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
230  SCHEMAS="clock.schemas"
231  for S in $SCHEMAS; do
232      echo %{_sysconfdir}/gconf/schemas/$S ; done \
233      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null 2>&1 ||:
234fi
235
236%preun
237if [ "$1" -eq 0 ]; then
238  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
239  SCHEMAS="clock.schemas"
240  for S in $SCHEMAS; do
241      echo %{_sysconfdir}/gconf/schemas/$S ; done \
242      | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null 2>&1 ||:
243fi
244
245%postun
246/sbin/ldconfig
247scrollkeeper-update > /dev/null 2>&1 || :
248touch --no-create %{_datadir}/icons/hicolor
249if [ -x /usr/bin/gtk-update-icon-cache ]; then
250  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
251fi
252 
253%files -f %{gettext_package}.lang
254%defattr(-,root,root)
255%doc AUTHORS COPYING COPYING.LIB COPYING-DOCS NEWS README
256%{_bindir}/*
257%exclude %{_bindir}/panel-test-applets
258%{_libexecdir}/*
259%{_sysconfdir}/gconf/schemas/*.schemas
260%{_datadir}/applications/*.desktop
261%{_datadir}/icons/hicolor/*/*/*
262%{_datadir}/glib-2.0/schemas/*.xml
263%{_datadir}/gnome-panel
264%{_datadir}/dbus-1/services/org.gnome.panel.applet.ClockAppletFactory.service
265%{_datadir}/dbus-1/services/org.gnome.panel.applet.FishAppletFactory.service
266%{_datadir}/dbus-1/services/org.gnome.panel.applet.NotificationAreaAppletFactory.service
267%{_datadir}/dbus-1/services/org.gnome.panel.applet.WnckletFactory.service
268%{_mandir}/man*/*
269
270%files libs
271%{_libdir}/*.so.*
272%{_libdir}/girepository-1.0/*.typelib
273
274%files devel
275%{_bindir}/panel-test-applets
276%{_libdir}/pkgconfig/*.pc
277%{_includedir}/gnome-panel*
278%{_libdir}/*.so
279%{_datadir}/gtk-doc
280%{_datadir}/gir-1.0/*.gir
281
282
283%changelog
284* Sat Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
285- new upstream release
286- drop old Patches
287- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
288- change BuildRequires: libwnck3-devel instead of libwnck-devel
289- add BuildRequires: dconf-devel
290- add Obsoletes: gnome-netstatus
291
292* Thu Jun 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-4
293- update SOURCE2(vine6-panel-default-setup.entries)
294  - remove bottom panel
295  - move window_list and workspace_switcher applet to top panel
296
297* Sat Dec 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-3
298- update Source1 (clock.gnome-2.32.ja.po)
299
300* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
301- remove Provides: gnome-panel-devel
302
303* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
304- new upstream release
305
306* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.2-1
307- new upstream release
308- add BuildRequires: gobject-introspection-devel
309- remove BuildRequires: libgnomeui-devel
310- remove SOURCE3 and SOURCE4
311- drop Patch11
312- add configure option (--enable-introspection=yes)
313
314* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
315- rebuild with rpm-4.8.1 for pkg-config file
316
317* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
318- create -libs and -devel package
319
320* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
321- new upstream release
322
323* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
324- rebuild with evolution-data-server-2.30.2
325
326* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
327- new upstream release
328- update Patch8, Patch9 (from FC package)
329- add BuildRequires: libcanberra-devel
330
331* Sat Mar 27 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-4
332- update translation of clock applet manual
333- add translation of fish applet manual
334
335* Fri Mar 26 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-3
336- add libSM(-devel) to (Build)Requires
337- add desktop-file-utils to BuildRequires
338
339* Thu Mar 25 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-2
340- update translation of clock applet manual
341
342* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
343- new upstream release
344- updated Patch0 and 2
345
346* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
347- new upstream release
348
349* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-3
350- rebuild with gtk2-2.16.3
351
352* Thu Jun 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
353- add empty gconf entries to vine-panel-default-setup.entries
354
355* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
356- new upstream release
357
358* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
359- new upstream release
360
361* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
362- update vine-panel-default-setup.entries again..
363
364* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
365- update vine-panel-default-setup.entries
366
367* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
368- remove mixer applets from default panel setup
369
370* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
371- new upstream release
372
373* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
374- new upstream release
375- added BuildRequires: PolicyKit-gnome-devel
376
377* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
378- new upstream release
379
380* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
381- new upstream release
382
383* Tue Jun  3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
384- new upstream release
385
386* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.3-1
387- new upstream release
388
389* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.2-1vl5
390- new upstream release
391- removed Patch25,26,27,29 and 30 (merged into upstream)
392
393* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-2vl5
394- added Patches from FC
395  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-8
396  - Fix editing of locations in the clock applet
397  * Fri Mar 28 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-7
398  - Convert the edit and find location windows to dialogs
399  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-6
400  - Improve the time settings window
401  * Thu Mar 27 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-5
402  - Make the find-location window of the clock larger
403  * Sat Mar 15 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-4
404  - Only save the session when the users wants it
405  * Fri Mar 14 2008 Matthias Clasen  <mclasen@redhat.com> - 2.22.0-3
406  - Populate the location list before showing the preference window
407  * Sat Mar  8 2008 Will Woods <wwoods@redhat.com> - 2.21.92-6
408  - Add "About This Computer" item to System menu if it exists
409  * Wed Feb 20 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-6
410  - Try harder to avoid resizing the popup
411- updated BuildRequires
412
413* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
414- new upstream release
415- added BuildRequires: libgweather-devel
416
417* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
418- new upstream release
419- updated %post and %postun section
420- added %pre and %preun section
421- added Patches from Fedora
422  * Fri Oct 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-4
423  - Sharper icons
424  * Wed Oct  3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-3
425  - Make it possible to start s-c-d from the clock menu again (#316921)
426  * Fri Sep 21 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-2
427  - Don't pop up an error if an applet from the default
428    configuration is missing 
429  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-6
430  - Turns out we need requires for applets in the default config (#293261)
431  * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-5
432  - Drop the requires for fast-user-switch-applet (#253831)
433
434* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
435- new upstream release
436- dropped Patch22 (merged into upstream)
437
438* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
439- new upstream release
440
441* Mon Oct 30 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl2
442- add missing BuildRequires to gnome-menus-devel (<BTS:319>)
443
444* Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
445- new upstream release
446- fix panel-default-setup.entries to change the name of
447  firefox desktopfile (<BTS:229>)
448
449* Thu Jul 20 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.2-0vl2
450- add patch 11 to fix disappearing of recent documents list.
451  <BTS:VineLinux:81>, http://bugzilla.gnome.org/show_bug.cgi?id=343812
452
453* Sat Jun  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
454- new upstream release
455
456* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
457- new upstream release
458
459* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
460- run gtk-update-icon-cache in %%post script.
461
462* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
463- new upstream release
464
465* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl2
466- update vine-panel-default-setup.entries
467  - replace mozilla by firefox
468  - remove nautilus
469  - add notification area applet on top panel
470  - add trashbox applet on bottom panel
471- cleanup %%post script
472
473* Thu Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl1
474- new upstream release
475
476* Sun Feb 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
477- new upstream release
478- added Prereq: scroolkeeper, GConf2
479
480* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
481- new upstream release
482
483* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
484- new upstream release
485
486* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
487- new upstream release
488
489* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
490- new upstream release
491
492* Thu Jul 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
493- new upstream release
494
495* Sat Apr 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
496- disable evolution-data-server
497
498* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
499- new upstream release
500
501* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
502- add Patch10 to fix hard-coded desktop file name.
503
504* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
505- new upstream version
506
507* Fri Feb 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
508- new upstream release
509- run scrollkeeper at %post, %postun
510
511* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
512- new upstream release
513
514* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
515- add Patch10 to fix egg-recent-model.c.
516  save old umask value before create ".recently-used" file.
517 
518* Sun Oct 24 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.4.2-0vl2
519- fix location of nautilus launcher in panel-default-setup.entries.
520- do not add wireless monitor in %%post when no interfaces are available.
521- add Japanese summary and description
522- add BuildRequires: startup-notification-devel, gcc-c++.
523- disable libtoolize: version mismatch is bad
524
525* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
526- new upstream release
527
528* Sat Dec 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
529- new upstream release
530
531* Sat Dec 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl3
532- rebuilt against new toolchain
533
534* Fri Sep 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
535- add --disable-schemas-install option to %%configure
536
537* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
538- new upstream release
539
540* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl2
541- add missing files
542- add vine default panel entries
543
544* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl1
545- new upstream release
546
547* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
548- new upstream release
549
550* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-0vl1
551- new upstream release
552
553* Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl2
554- remove vine's panel-per-panel-config.schemas
555  This should be added again in a future version.
556
557* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl1
558- new upstream release
559
560* Tue Apr 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
561- new upstream release
562- remove old ja.po
563
564* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
565- new upstream release
566
567* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
568- remove clockaddon, system-tray-applet
569
570* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
571- new upstream release
572
573* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl2
574- add patch1 from rawhide package.
575
576* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl1
577- new upstream release
578
579* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
580- add system-tray-applet
581- modify default panel menu.
582- update ja.po
583
584* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
585- add Requires: vine-menus
586
587* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
588- new upstream release
589
590* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
591- remove redhatize patch.
592
593* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
594- build for Vine Linux
595- new upstream release from gnome-2.1.4
596
597* Mon Oct 14 2002 Florian La Roche <Florian.LaRoche@redhat.de>
598- fix postun script
599
600* Tue Oct  8 2002 Havoc Pennington <hp@redhat.com>
601- 2.0.9 with menu edit stuff
602- system-tray-applet 0.15 that doesn't crash all the time
603- merge/remove patches as appropriate
604
605* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
606- Fix problem with "hold down print screen" (71432)
607
608* Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
609- panel-properties OnlyShowIn=GNOME;
610- somehow the po file got screwed up.  Works now
611- update po files
612
613* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
614- fix from #71762 for clock applet popdown key
615- no WIN_POS_MOUSE fixes #72167
616- fix for #72540 from George
617
618* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
619- system tray applet 0.11 with a small memleak fix and a couple translations
620
621* Thu Aug 15 2002 Jonathan Blandford <jrb@redhat.com>
622- menu tweaks
623
624* Wed Aug 14 2002 Tim Powers <timp@redhat.com>
625- bump release
626
627* Wed Aug 14 2002 Preston Brown <pbrown@redhat.com>
628- put battery applet on panel for laptops (#67296)
629
630* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
631- 2.0.6 final from gnome 2.0.1
632- remove gnome-panel-screenshot patch now upstream
633
634* Thu Aug  8 2002 Jonathan Blandford <jrb@redhat.com>
635- new system-tray-applet version
636- Fix gnome-panel-screenshot
637
638* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
639- 2.0.4
640- replace gnome-logo-icon-transparent.png with redhat-main-menu.png
641  for the foot menu
642
643* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
644- fix desktop (logout/lock) menu item location
645  in Alt+F1 and in new menu applets
646- remove Screenshot... menu item
647
648* Fri Aug  2 2002 Havoc Pennington <hp@redhat.com>
649- move around default applets, remove some of them
650- system tray 0.9
651- change default menu flags
652- blow unpackaged files out of build root
653
654* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
655- 2.0.3
656- own libexecdir stuff
657
658* Thu Jul 25 2002 Havoc Pennington <hp@redhat.com>
659- new system tray that's prettier and doesn't clip the icon
660
661* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
662- system tray 0.7 that doesn't crash on startup
663- get Mozilla desktop file right so we get web browser launcher
664
665* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
666- system tray 0.6 with server file fixed (work dammit)
667
668* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
669- tweak applet positions but I think it's just broken
670- system tray 0.5 moved back to libdir not libexecdir
671
672* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
673- remove ltmain.sh hack
674- new system-tray-applet that works
675
676* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
677- put office suite stuff on the panel
678
679* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
680- 2.0.2.90 cvs snap
681
682* Wed Jul 10 2002 Havoc Pennington <hp@redhat.com>
683- update the clock patch to be a little smarter in a couple ways
684
685* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
686- Fix problem where system tray applet was being looked for in /unst
687- Fix a crash in the system tray applet
688
689* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
690- Fix typo in the pt_BR translation that was causing GConf problems
691
692* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
693- add the system tray applet
694- add system tray applet by default
695- add more launcher by default
696
697* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
698- automated rebuild
699
700* Thu Jun 20 2002 Havoc Pennington <hp@redhat.com>
701- use correct gettext package name, and add check for missing translations
702
703* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
704- add the calendar and configuration patch
705
706* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
707- 2.0.0
708- add control center desktop file to file list
709- add gnome-panelrc to file list
710- try fixing panel size (blind, no text box at home)
711
712* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
713- rebuild in different environment
714
715* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
716- updates to default configuration
717
718* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
719- fix schemas installation
720
721* Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
722- unset old panel schemas when installing new ones
723- put in a broken panel config to see errors about
724- add a patch to give some decent error messages about what's wrong
725  with the default panel config
726
727* Sun Jun 09 2002 Havoc Pennington <hp@redhat.com>
728- rebuild in different environment
729
730* Sun Jun  9 2002 Havoc Pennington <hp@redhat.com>
731- don't provide/obsolete gnome-core
732
733* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
734- rebuild in different environment
735
736* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
737- 1.5.24
738- ldconfig
739
740* Mon Jun 03 2002 Havoc Pennington <hp@redhat.com>
741- rebuild in different environment
742
743* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
744- 1.5.23
745
746* Sun May 26 2002 Tim Powers <timp@redhat.com>
747- automated rebuild
748
749* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
750- rebuild in different environment
751
752* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
753- 1.5.22
754- provide gnome-core
755- add a bunch of extra build requires so build system
756  won't get confused
757
758* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
759- 1.5.19
760
761* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
762- add the keep-libtool-from-relinking hack so
763  we get the gen util applet
764
765* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
766- obsoletes gnome-core-devel
767- include libdir/*.so
768
769* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
770- get libpanel-applet in the package
771
772* Tue Apr 16 2002 Havoc Pennington <hp@redhat.com>
773- Initial build.
774
775
Note: See TracBrowser for help on using the repository browser.