source: projects/specs/branches/6/f/freeciv/freeciv-vl.spec @ 3339

Revision 3339, 13.6 KB checked in by iwaim, 13 years ago (diff)

freeciv-2.2.5-1

Line 
1# include fallback defs for _ggz_config, _ggz_datadir macros
2# feel free to drop when ggz-client-lib including these is deployed everywhere
3%{!?_ggz_config:%define _ggz_config %{_bindir}/ggz-config}
4%{!?_ggz_datadir:%define _ggz_datadir %(%{_ggz_config} --datadir >& /dev/null ||:)}
5
6Name:           freeciv
7Version:        2.2.5
8Release:        1%{?_dist_release}
9Summary:        A multi-player strategy game
10
11Group:          Amusements/Games
12License:        GPLv2+
13URL:            http://freeciv.wikia.com/index.php/Freeciv
14Source0:        http://download.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
15Source1:        freeciv-2.2.5-fixed-tutorial_ja.po
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18##Fix DSO patch
19Patch10:        freeciv-client-fix-DSO.patch
20
21BuildRequires:  gtk2-devel
22BuildRequires:  readline-devel
23BuildRequires:  zlib-devel
24BuildRequires:  SDL_mixer-devel
25BuildRequires:  esound-devel
26BuildRequires:  ncurses-devel
27BuildRequires:  ggz-client-libs-devel
28BuildRequires:  desktop-file-utils
29BuildRequires:  gettext
30
31Requires(post): ggz-client-libs
32Requires(preun): ggz-client-libs
33
34Vendor: Project Vine
35Distribution: Vine Linux
36Packager: iwaim
37
38%description
39Freeciv is a turn-based, multi-player, X based strategy game. Freeciv
40is generally comparable to, and has compatible rules with, the
41Civilization II(R) game by Microprose(R). In Freeciv, each player is
42the leader of a civilization, and is competing with the other players
43in order to become the leader of the greatest civilization.
44
45
46%prep
47%setup -q -n %{name}-%{version}
48%patch10 -p0
49%__rm -f po/ja.{po,gmo}
50%__cp -p %{SOURCE1} po/ja.po
51
52%build
53%configure --enable-client=gtk --disable-static
54make %{?_smp_mflags}
55
56%install
57rm -rf $RPM_BUILD_ROOT
58make install DESTDIR=$RPM_BUILD_ROOT
59%find_lang %{name}
60
61desktop-file-install --vendor vine --delete-original    \
62        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
63        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
64
65desktop-file-install --vendor vine --delete-original \
66        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
67        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}-server.desktop
68
69# Remove civmanual
70rm $RPM_BUILD_ROOT%{_bindir}/civmanual
71# ggz config
72# omit ggz.modules, to register at install, not build, time.
73if [ -e $RPM_BUILD_ROOT%{_sysconfdir}/ggz.modules ]; then
74rm $RPM_BUILD_ROOT%{_sysconfdir}/ggz.modules
75fi
76# include .dsc files
77install -p -D -m644 data/civclient.dsc $RPM_BUILD_ROOT%{_ggz_datadir}/civclient.dsc
78find $RPM_BUILD_ROOT -name '*.la' -delete
79find $RPM_BUILD_ROOT -name '*.a' -delete
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%post
85%{_ggz_config} --install --force --modfile=%{_ggz_datadir}/civclient.dsc || :
86touch --no-create %{_datadir}/icons/hicolor
87if [ -x %{_bindir}/gtk-update-icon-cache ]; then
88  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
89fi
90
91%preun
92if [ $1 -eq 0 ]; then
93%{_ggz_config} --remove --modfile=%{_ggz_datadir}/civclient.dsc || :
94fi
95
96%postun
97touch --no-create %{_datadir}/icons/hicolor
98if [ -x %{_bindir}/gtk-update-icon-cache ]; then
99  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
100fi
101
102
103%files -f %{name}.lang
104%defattr(-,root,root)
105%doc COPYING NEWS doc/BUGS doc/HOWTOPLAY doc/README
106%doc doc/README.AI doc/README.agents doc/README.attributes doc/README.cma
107%doc doc/README.delta doc/README.effects doc/README.ftwl doc/HACKING
108%doc doc/README.scorelog doc/TODO
109%doc doc/README.graphics doc/README.sound
110%{_bindir}/freeciv-server
111%{_bindir}/freeciv-gtk2
112%{_datadir}/%{name}/
113%{_datadir}/applications/vine-*.desktop
114%{_datadir}/icons/hicolor/*/apps/*.png
115%{_datadir}/pixmaps/%{name}-client.png
116%{_mandir}/man6/freeciv*6*
117%{_ggz_datadir}/civclient.dsc
118
119
120%changelog
121* Thu Apr  7 2011 IWAI, Masaharu <iwai@alib.jp> 2.2.5-1
122- new upstream release
123- update ja.po (Source1): fixed upstream ja.po bug
124
125* Tue Dec 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.3-2
126- rebuild with SDL_mixer-1.2.11-2
127
128* Fri Sep 17 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.3-1
129- new upstream release
130- update ja.po (Source1): fixed upstream ja.po
131
132* Wed Sep  1 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.2-1
133- build for Vine Linux: from Fedora 2.2.2-1
134 - change BuildRequires: ggz-gtk-client-devel to gz-client-libs-devel
135- add ja.po (Source1) from http://loda.jp/freeciv/?id=81
136
137* Mon Aug 02 2010 Thomas Janssen <thomasj@fedoraproject.org> 2.2.2-1
138- security fix https://www.redhat.com/security/data/cve/CVE-2010-2445.html
139- fixes #612296
140
141* Sun Jun 06 2010 Thomas Janssen <thomasj@fedoraproject.org> 2.2.0-2
142- security fix http://gna.org/bugs/?15624
143- #600742 #600743 #600744
144
145* Tue Mar 02 2010 Thomas Janssen <thomasj@fedoraproject.org> 2.2.0-1
146- New upstream source 2.2.0
147
148* Fri Jan 29 2010 Brian Pepple <bpepple@fedoraproject.org> - 2.1.11-1
149- Update to 2.1.11.
150
151* Fri Dec 11 2009 Brian Pepple <bpepple@fedoraproject.org> - 2.1.10-1
152- Update to 2.1.10.
153
154* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.9-2
155- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
156
157* Sun Apr  5 2009 Brian Pepple <bpepple@fedoraproject.org> - 2.1.9-1
158- Update to 2.1.9.
159
160* Mon Mar 09 2009 Adam Tkac <atkac redhat com> - 2.1.8-3
161- drop bind-devel BuildReq, it is not needed
162
163* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.8-2
164- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
165
166* Thu Dec  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.8-1
167- Update to 2.1.8.
168
169* Wed Nov 26 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.7-1
170- Update to 2.1.7.
171
172* Sat Nov 22 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.6-2
173- Simplify summary.
174
175* Sat Aug 23 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.6-1
176- Update to 2.1.6.
177
178* Thu Jun 19 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.5-1
179- Update to 2.1.5.
180
181* Tue Apr 29 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.4-1
182- Update to 2.1.4.
183
184* Sat Feb  9 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> 2.1.3-4
185- Fix up typo.
186
187* Fri Feb  8 2008 Rex Dieter <rdieter@fedoraproject.org> 2.1.3-3
188- fixup ggz integration (#431726)
189
190* Mon Feb  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.3-2
191- Add ggz gaming support.
192
193* Sat Jan 26 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.3-1
194- Update to 2.1.3.
195
196* Tue Dec 25 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.1.2-1
197- Update to 2.1.2.
198
199* Thu Nov 29 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.1.1-1
200- Update to 2.1.1.
201- Drop buffer overflow patch. fixed upstream.
202- Drop open file patch. fixed upstream.
203
204* Sat Nov 24 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.1.0-2
205- Add patch to fix buffer overflow. (#397531)
206
207* Sun Oct 28 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.1.0-1
208- Update to 2.1.0.
209- Update urls.
210- Update aifill & open patches.
211- Remove old freeciv pixmap.
212- Remove desktop patch.
213
214* Sun Sep 16 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.0.9-4
215- Add patch to fix open function build bug.
216
217* Tue Aug 21 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.0.9-3
218- Rebuild.
219
220* Thu Aug  2 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.0.9-2
221- Update license tag.
222
223* Tue Feb 13 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.0.9-1
224- Update to 2.0.9.
225- Drop button patch, fixed upstream.
226- Drop security patch, fixed upstream.
227- Drop X-Fedora category from desktop files.
228
229* Thu Sep  7 2006 Brian Pepple <bpepple@fedoraproject.org> - 2.0.8-7
230- Rebuild for FC6.
231
232* Wed Aug  2 2006 Brian Pepple <bpepple@fedoraproject.org> - 2.0.8-6
233- Update security patch.
234- Add patch to fix turn done buttons style.
235
236* Tue Aug  1 2006 Brian Pepple <bpepple@fedoraproject.org> - 2.0.8-5
237- Add patch to fix CVE-2006-3913 vulnerability. (#200545)
238- Replace desktop file category 'Strategy' with 'StrategyGame'. (#198086)
239
240* Mon Mar  6 2006 Brian Pepple <bdpepple@ameritech.net> - 2.0.8-2
241- Update to 2.0.8.
242
243* Thu Feb 16 2006 Brian Pepple <bdpepple@ameritech.net> - 2.0.7-6
244- Remove unnecessary BR (alsa-lib-devel & SDL-devel).
245
246* Mon Feb 13 2006 Brian Pepple <bdpepple@ameritech.net> - 2.0.7-5
247- rebuilt for new gcc4.1 snapshot and glibc changes
248
249* Sun Dec  4 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.7-4
250- Rebuild for new bind.
251
252* Sun Nov  6 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.7-3
253- Update to 2.0.7.
254- Modify desktop patch for upstream fixes.
255- Drop the %%config from .desktop files.
256
257* Mon Sep 26 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.6-3
258- Update to 2.0.6.
259
260* Fri Sep  2 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.5-3
261- Update to 2.0.5.
262- Enable debug info.
263
264* Tue Aug 16 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.4-4
265- Rebuild for cairo dep.
266
267* Thu Jul 28 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.4-2
268- Update to 2.0.4.
269- Use new stdsounds.
270
271* Fri Jul 15 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.3-2
272- Bump release.
273
274* Thu Jul 14 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.3-1
275- Update to 2.0.3.
276
277* Tue Jun 14 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.2-1
278- Update to 2.0.2.
279- Add dist tag.
280
281* Tue Apr 26 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.1-1.fc4
282- Update to 2.0.1.
283
284* Mon Apr 18 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.0-3.fc4
285- Re-add patch to set aifill to 5 on new servers to get some opponents.
286
287* Mon Apr 18 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.0-2.fc4
288- remove redundant --dir* options in %%configure & %%makeinstall.
289
290* Mon Apr 18 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.0-1.fc4
291- Update to 2.0.0.
292- Drop 1.14 patches.
293- Add new BR's for 2.0.0.
294
295* Sat Mar 26 2005 Brian Pepple <bdpepple@ameritech.net> - 1.14.2-7
296- Fixed typos.
297
298* Sat Mar 26 2005 Brian Pepple <bdpepple@ameritech.net> - 1.14.2-6
299- Added more macros.
300- Replaced BuildPrereq with BuildRequires.
301- Drop version of gtk2-devel, since FC3 & later meet minimum needed.
302
303* Wed Mar 23 2005 Brian Pepple <bdpepple@ameritech.net> - 1.14.2-5
304- Changed X-Red-Hat-Extra to X-Fedora.
305- Added URL.
306- Changed BuildRoot to preferred value.
307- Removed period from summary.
308
309* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> 1.14.2-4
310- Rebuilt for new readline.
311
312* Tue Oct 26 2004 Daniel Reed <djr@redhat.com> 1.14.2-3
313- [136921] Try a little harder to run as nobody
314
315* Mon Oct 25 2004 Daniel Reed <djr@redhat.com> 1.14.2-2
316- [136921] Provide the user with the opportunity to run FreeCiv as root if unable to su to nobody, and throw up an error message if everything fails
317
318* Mon Sep 13 2004 Karsten Hopp <karsten@redhat.de> 1.14.2-1
319- update to latest stable version
320
321* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
322- rebuilt
323
324* Mon Feb 23 2004 Karsten Hopp <karsten@redhat.de> 1.14.1-3
325- rebuild with new chown syntax
326
327* Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com>
328- Use ':' instead of '.' as separator for chown.
329
330* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
331- rebuilt
332
333* Wed Dec 03 2003 Karsten Hopp <karsten@redhat.de> 1.14.1-1
334- update to bugfix release 1.14.1
335
336* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
337- rebuilt
338
339* Thu May 08 2003 Karsten Hopp <karsten@redhat.de> 1.14.0-1
340- update
341
342* Thu Feb 20 2003 Karsten Hopp <karsten@redhat.de> 1.13.0-6
343- remove last patch (obsolete)
344
345* Wed Feb 19 2003 Karsten Hopp <karsten@redhat.de>
346- fix message translation (#84599)
347
348* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
349- rebuilt
350
351* Thu Nov 07 2002 Karsten Hopp <karsten@redhat.de>
352- spelling fix (#75021)
353- set aifill to 5 on new servers to get some opponents (#72586)
354
355* Thu Aug 01 2002 Karsten Hopp <karsten@redhat.de>
356- desktop fixes (#69391)
357
358* Wed Jul 24 2002 Karsten Hopp <karsten@redhat.de>
359- 0.1.13
360- s/Games/Game in desktop-file-install
361- fix URL
362- add standard sounds
363
364* Wed Jul 17 2002 Karsten Hopp <karsten@redhat.de> 1.12.0-6
365- fix path to datafiles if FREECIV_PATH is not set (#67922)
366- fix desktop files (#67920)
367- use desktop-file-install
368
369* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
370- automated rebuild
371
372* Thu May 23 2002 Tim Powers <timp@redhat.com>
373- automated rebuild
374
375* Thu Jan 24 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.12.0-2
376- Rebuild in current environment
377
378* Thu Aug 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.12.0-1
379- 1.12.0 (non-beta)
380
381* Tue Jul 31 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.11.4-9
382- Rebuild - the fix for #49442 didn't seem to get in last time.
383
384* Mon Jul 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.11.4-8
385- Fix up demographics (#50119)
386
387* Wed Jun 27 2001 Than Ngo <than@redhat.com>
388- support new gettext
389- add patch to build against new libtool
390
391* Tue Mar 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
392- use gtk-config instead of glib-config
393
394* Sun Feb 25 2001 Bernhard Rosenkraenzer <bero@redhat.com>
395- Fix up civclient-wrapper so it doesn't fail silently when started as
396  potentially harmful user (Bug #28928)
397
398* Tue Aug  1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
399- Fix warning in civclient-wrapper (Bug 14860)
400
401* Fri Jul 21 2000 Trond Eivind Glomsrød <teg@redhat.com>
402- 1.11.4
403- move to /usr/bin and /usr/share/freeciv (no more /usr/games)
404
405* Wed Jul 12 2000 Trond Eivind Glomsrød <teg@redhat.com>
406- remove icon, glint is obsoleted
407- don't use find to build file lists, it claimed to own
408  lots of directories
409- use %%{_tmppath}
410
411* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
412- automatic rebuild
413
414* Mon Jul 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
415- 1.11.0 (Bug #13610)
416- Add .desktop files (Bug #13610)
417- Add BuildPrereq: lines
418- fix build
419
420* Thu Jun  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
421- move to dist
422- update
423- clean up the spec file
424- fix build with gcc 2.96
425- make the gtk client default; it's better than the Xaw one by now.
426
427* Thu Feb 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
428- 1.10.0
429
430* Fri Feb  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
431- 1.9.2
432- use the configure macro
433
434* Sun Nov  7 1999 Bernhard Rosenkraenzer <bero@redhat.com>
435- redo RPM for 1.9.0 (many changes to build/install procedure)
Note: See TracBrowser for help on using the repository browser.