source: projects/specs/trunk/f/freeciv/freeciv-vl.spec @ 2409

Revision 2409, 13.4 KB checked in by Takemikaduchi, 13 years ago (diff)

add BuildRequires?

Line 
1# include fallback defs for _ggz_config, _ggz_datadir macros
2# feel free to drop when ggz-client-lib including these is deployed everywhere
3%{!?_ggz_config:%define _ggz_config %{_bindir}/ggz-config}
4%{!?_ggz_datadir:%define _ggz_datadir %(%{_ggz_config} --datadir >& /dev/null ||:)}
5
6Name:           freeciv
7Version:        2.2.3
8Release:        2%{?_dist_release}
9Summary:        A multi-player strategy game
10
11Group:          Amusements/Games
12License:        GPLv2+
13URL:            http://freeciv.wikia.com/index.php/Freeciv
14Source0:        http://download.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
15Source1:        freeciv-ja_2.2.3-fixed.po
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18##Fix DSO patch
19Patch10:        freeciv-client-fix-DSO.patch
20
21BuildRequires:  gtk2-devel
22BuildRequires:  readline-devel
23BuildRequires:  zlib-devel
24BuildRequires:  SDL_mixer-devel
25BuildRequires:  esound-devel
26BuildRequires:  ncurses-devel
27BuildRequires:  ggz-client-libs-devel
28BuildRequires:  desktop-file-utils
29BuildRequires:  gettext
30
31Requires(post): ggz-client-libs
32Requires(preun): ggz-client-libs
33
34Vendor: Project Vine
35Distribution: Vine Linux
36Packager: iwaim
37
38%description
39Freeciv is a turn-based, multi-player, X based strategy game. Freeciv
40is generally comparable to, and has compatible rules with, the
41Civilization II(R) game by Microprose(R). In Freeciv, each player is
42the leader of a civilization, and is competing with the other players
43in order to become the leader of the greatest civilization.
44
45
46%prep
47%setup -q -n %{name}-%{version}
48%patch10 -p0
49%__rm -f po/ja.{po,gmo}
50%__cp -p %{SOURCE1} po/ja.po
51
52%build
53%configure --enable-client=gtk --disable-static
54make %{?_smp_mflags}
55
56%install
57rm -rf $RPM_BUILD_ROOT
58make install DESTDIR=$RPM_BUILD_ROOT
59%find_lang %{name}
60
61desktop-file-install --vendor vine --delete-original    \
62        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
63        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
64
65desktop-file-install --vendor vine --delete-original \
66        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
67        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}-server.desktop
68
69# Remove civmanual
70rm $RPM_BUILD_ROOT%{_bindir}/civmanual
71# ggz config
72# omit ggz.modules, to register at install, not build, time.
73if [ -e $RPM_BUILD_ROOT%{_sysconfdir}/ggz.modules ]; then
74rm $RPM_BUILD_ROOT%{_sysconfdir}/ggz.modules
75fi
76# include .dsc files
77install -p -D -m644 data/civclient.dsc $RPM_BUILD_ROOT%{_ggz_datadir}/civclient.dsc
78find $RPM_BUILD_ROOT -name '*.la' -delete
79find $RPM_BUILD_ROOT -name '*.a' -delete
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%post
85%{_ggz_config} --install --force --modfile=%{_ggz_datadir}/civclient.dsc || :
86touch --no-create %{_datadir}/icons/hicolor
87if [ -x %{_bindir}/gtk-update-icon-cache ]; then
88  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
89fi
90
91%preun
92if [ $1 -eq 0 ]; then
93%{_ggz_config} --remove --modfile=%{_ggz_datadir}/civclient.dsc || :
94fi
95
96%postun
97touch --no-create %{_datadir}/icons/hicolor
98if [ -x %{_bindir}/gtk-update-icon-cache ]; then
99  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
100fi
101
102
103%files -f %{name}.lang
104%defattr(-,root,root)
105%doc COPYING NEWS doc/BUGS doc/HOWTOPLAY doc/README
106%doc doc/README.AI doc/README.agents doc/README.attributes doc/README.cma
107%doc doc/README.delta doc/README.effects doc/README.ftwl doc/HACKING
108%doc doc/README.scorelog doc/TODO
109%doc doc/README.graphics doc/README.sound
110%{_bindir}/freeciv-server
111%{_bindir}/freeciv-gtk2
112%{_datadir}/%{name}/
113%{_datadir}/applications/vine-*.desktop
114%{_datadir}/icons/hicolor/*/apps/*.png
115%{_datadir}/pixmaps/%{name}-client.png
116%{_mandir}/man6/freeciv*6*
117%{_ggz_datadir}/civclient.dsc
118
119
120%changelog
121* Tue Dec 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp 2.2.3-2
122- rebuild with SDL_mixer-1.2.11-2
123
124* Fri Sep 17 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.3-1
125- new upstream release
126- update ja.po (Source1): fixed upstream ja.po
127
128* Wed Sep  1 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.2-1
129- build for Vine Linux: from Fedora 2.2.2-1
130 - change BuildRequires: ggz-gtk-client-devel to gz-client-libs-devel
131- add ja.po (Source1) from http://loda.jp/freeciv/?id=81
132
133* Mon Aug 02 2010 Thomas Janssen <thomasj@fedoraproject.org> 2.2.2-1
134- security fix https://www.redhat.com/security/data/cve/CVE-2010-2445.html
135- fixes #612296
136
137* Sun Jun 06 2010 Thomas Janssen <thomasj@fedoraproject.org> 2.2.0-2
138- security fix http://gna.org/bugs/?15624
139- #600742 #600743 #600744
140
141* Tue Mar 02 2010 Thomas Janssen <thomasj@fedoraproject.org> 2.2.0-1
142- New upstream source 2.2.0
143
144* Fri Jan 29 2010 Brian Pepple <bpepple@fedoraproject.org> - 2.1.11-1
145- Update to 2.1.11.
146
147* Fri Dec 11 2009 Brian Pepple <bpepple@fedoraproject.org> - 2.1.10-1
148- Update to 2.1.10.
149
150* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.9-2
151- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
152
153* Sun Apr  5 2009 Brian Pepple <bpepple@fedoraproject.org> - 2.1.9-1
154- Update to 2.1.9.
155
156* Mon Mar 09 2009 Adam Tkac <atkac redhat com> - 2.1.8-3
157- drop bind-devel BuildReq, it is not needed
158
159* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.8-2
160- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
161
162* Thu Dec  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.8-1
163- Update to 2.1.8.
164
165* Wed Nov 26 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.7-1
166- Update to 2.1.7.
167
168* Sat Nov 22 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.6-2
169- Simplify summary.
170
171* Sat Aug 23 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.6-1
172- Update to 2.1.6.
173
174* Thu Jun 19 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.5-1
175- Update to 2.1.5.
176
177* Tue Apr 29 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.4-1
178- Update to 2.1.4.
179
180* Sat Feb  9 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> 2.1.3-4
181- Fix up typo.
182
183* Fri Feb  8 2008 Rex Dieter <rdieter@fedoraproject.org> 2.1.3-3
184- fixup ggz integration (#431726)
185
186* Mon Feb  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.3-2
187- Add ggz gaming support.
188
189* Sat Jan 26 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.3-1
190- Update to 2.1.3.
191
192* Tue Dec 25 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.1.2-1
193- Update to 2.1.2.
194
195* Thu Nov 29 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.1.1-1
196- Update to 2.1.1.
197- Drop buffer overflow patch. fixed upstream.
198- Drop open file patch. fixed upstream.
199
200* Sat Nov 24 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.1.0-2
201- Add patch to fix buffer overflow. (#397531)
202
203* Sun Oct 28 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.1.0-1
204- Update to 2.1.0.
205- Update urls.
206- Update aifill & open patches.
207- Remove old freeciv pixmap.
208- Remove desktop patch.
209
210* Sun Sep 16 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.0.9-4
211- Add patch to fix open function build bug.
212
213* Tue Aug 21 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.0.9-3
214- Rebuild.
215
216* Thu Aug  2 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.0.9-2
217- Update license tag.
218
219* Tue Feb 13 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.0.9-1
220- Update to 2.0.9.
221- Drop button patch, fixed upstream.
222- Drop security patch, fixed upstream.
223- Drop X-Fedora category from desktop files.
224
225* Thu Sep  7 2006 Brian Pepple <bpepple@fedoraproject.org> - 2.0.8-7
226- Rebuild for FC6.
227
228* Wed Aug  2 2006 Brian Pepple <bpepple@fedoraproject.org> - 2.0.8-6
229- Update security patch.
230- Add patch to fix turn done buttons style.
231
232* Tue Aug  1 2006 Brian Pepple <bpepple@fedoraproject.org> - 2.0.8-5
233- Add patch to fix CVE-2006-3913 vulnerability. (#200545)
234- Replace desktop file category 'Strategy' with 'StrategyGame'. (#198086)
235
236* Mon Mar  6 2006 Brian Pepple <bdpepple@ameritech.net> - 2.0.8-2
237- Update to 2.0.8.
238
239* Thu Feb 16 2006 Brian Pepple <bdpepple@ameritech.net> - 2.0.7-6
240- Remove unnecessary BR (alsa-lib-devel & SDL-devel).
241
242* Mon Feb 13 2006 Brian Pepple <bdpepple@ameritech.net> - 2.0.7-5
243- rebuilt for new gcc4.1 snapshot and glibc changes
244
245* Sun Dec  4 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.7-4
246- Rebuild for new bind.
247
248* Sun Nov  6 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.7-3
249- Update to 2.0.7.
250- Modify desktop patch for upstream fixes.
251- Drop the %%config from .desktop files.
252
253* Mon Sep 26 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.6-3
254- Update to 2.0.6.
255
256* Fri Sep  2 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.5-3
257- Update to 2.0.5.
258- Enable debug info.
259
260* Tue Aug 16 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.4-4
261- Rebuild for cairo dep.
262
263* Thu Jul 28 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.4-2
264- Update to 2.0.4.
265- Use new stdsounds.
266
267* Fri Jul 15 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.3-2
268- Bump release.
269
270* Thu Jul 14 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.3-1
271- Update to 2.0.3.
272
273* Tue Jun 14 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.2-1
274- Update to 2.0.2.
275- Add dist tag.
276
277* Tue Apr 26 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.1-1.fc4
278- Update to 2.0.1.
279
280* Mon Apr 18 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.0-3.fc4
281- Re-add patch to set aifill to 5 on new servers to get some opponents.
282
283* Mon Apr 18 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.0-2.fc4
284- remove redundant --dir* options in %%configure & %%makeinstall.
285
286* Mon Apr 18 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.0-1.fc4
287- Update to 2.0.0.
288- Drop 1.14 patches.
289- Add new BR's for 2.0.0.
290
291* Sat Mar 26 2005 Brian Pepple <bdpepple@ameritech.net> - 1.14.2-7
292- Fixed typos.
293
294* Sat Mar 26 2005 Brian Pepple <bdpepple@ameritech.net> - 1.14.2-6
295- Added more macros.
296- Replaced BuildPrereq with BuildRequires.
297- Drop version of gtk2-devel, since FC3 & later meet minimum needed.
298
299* Wed Mar 23 2005 Brian Pepple <bdpepple@ameritech.net> - 1.14.2-5
300- Changed X-Red-Hat-Extra to X-Fedora.
301- Added URL.
302- Changed BuildRoot to preferred value.
303- Removed period from summary.
304
305* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> 1.14.2-4
306- Rebuilt for new readline.
307
308* Tue Oct 26 2004 Daniel Reed <djr@redhat.com> 1.14.2-3
309- [136921] Try a little harder to run as nobody
310
311* Mon Oct 25 2004 Daniel Reed <djr@redhat.com> 1.14.2-2
312- [136921] Provide the user with the opportunity to run FreeCiv as root if unable to su to nobody, and throw up an error message if everything fails
313
314* Mon Sep 13 2004 Karsten Hopp <karsten@redhat.de> 1.14.2-1
315- update to latest stable version
316
317* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
318- rebuilt
319
320* Mon Feb 23 2004 Karsten Hopp <karsten@redhat.de> 1.14.1-3
321- rebuild with new chown syntax
322
323* Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com>
324- Use ':' instead of '.' as separator for chown.
325
326* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
327- rebuilt
328
329* Wed Dec 03 2003 Karsten Hopp <karsten@redhat.de> 1.14.1-1
330- update to bugfix release 1.14.1
331
332* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
333- rebuilt
334
335* Thu May 08 2003 Karsten Hopp <karsten@redhat.de> 1.14.0-1
336- update
337
338* Thu Feb 20 2003 Karsten Hopp <karsten@redhat.de> 1.13.0-6
339- remove last patch (obsolete)
340
341* Wed Feb 19 2003 Karsten Hopp <karsten@redhat.de>
342- fix message translation (#84599)
343
344* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
345- rebuilt
346
347* Thu Nov 07 2002 Karsten Hopp <karsten@redhat.de>
348- spelling fix (#75021)
349- set aifill to 5 on new servers to get some opponents (#72586)
350
351* Thu Aug 01 2002 Karsten Hopp <karsten@redhat.de>
352- desktop fixes (#69391)
353
354* Wed Jul 24 2002 Karsten Hopp <karsten@redhat.de>
355- 0.1.13
356- s/Games/Game in desktop-file-install
357- fix URL
358- add standard sounds
359
360* Wed Jul 17 2002 Karsten Hopp <karsten@redhat.de> 1.12.0-6
361- fix path to datafiles if FREECIV_PATH is not set (#67922)
362- fix desktop files (#67920)
363- use desktop-file-install
364
365* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
366- automated rebuild
367
368* Thu May 23 2002 Tim Powers <timp@redhat.com>
369- automated rebuild
370
371* Thu Jan 24 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.12.0-2
372- Rebuild in current environment
373
374* Thu Aug 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.12.0-1
375- 1.12.0 (non-beta)
376
377* Tue Jul 31 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.11.4-9
378- Rebuild - the fix for #49442 didn't seem to get in last time.
379
380* Mon Jul 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.11.4-8
381- Fix up demographics (#50119)
382
383* Wed Jun 27 2001 Than Ngo <than@redhat.com>
384- support new gettext
385- add patch to build against new libtool
386
387* Tue Mar 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
388- use gtk-config instead of glib-config
389
390* Sun Feb 25 2001 Bernhard Rosenkraenzer <bero@redhat.com>
391- Fix up civclient-wrapper so it doesn't fail silently when started as
392  potentially harmful user (Bug #28928)
393
394* Tue Aug  1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
395- Fix warning in civclient-wrapper (Bug 14860)
396
397* Fri Jul 21 2000 Trond Eivind Glomsrød <teg@redhat.com>
398- 1.11.4
399- move to /usr/bin and /usr/share/freeciv (no more /usr/games)
400
401* Wed Jul 12 2000 Trond Eivind Glomsrød <teg@redhat.com>
402- remove icon, glint is obsoleted
403- don't use find to build file lists, it claimed to own
404  lots of directories
405- use %%{_tmppath}
406
407* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
408- automatic rebuild
409
410* Mon Jul 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
411- 1.11.0 (Bug #13610)
412- Add .desktop files (Bug #13610)
413- Add BuildPrereq: lines
414- fix build
415
416* Thu Jun  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
417- move to dist
418- update
419- clean up the spec file
420- fix build with gcc 2.96
421- make the gtk client default; it's better than the Xaw one by now.
422
423* Thu Feb 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
424- 1.10.0
425
426* Fri Feb  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
427- 1.9.2
428- use the configure macro
429
430* Sun Nov  7 1999 Bernhard Rosenkraenzer <bero@redhat.com>
431- redo RPM for 1.9.0 (many changes to build/install procedure)
Note: See TracBrowser for help on using the repository browser.