source: projects/specs/trunk/f/freeciv/freeciv-vl.spec @ 9052

Revision 9052, 13.7 KB checked in by inagaki, 9 years ago (diff)

2014-11-02 Ryoichi INAGAKI <ryo1@…>

  • freeciv, imake, lasem, lua, mate-icon-theme: changed Group


Line 
1# include fallback defs for _ggz_config, _ggz_datadir macros
2# feel free to drop when ggz-client-lib including these is deployed everywhere
3%{!?_ggz_config:%define _ggz_config %{_bindir}/ggz-config}
4%{!?_ggz_datadir:%define _ggz_datadir %(%{_ggz_config} --datadir >& /dev/null ||:)}
5
6Name:           freeciv
7Version:        2.2.5
8Release:        2%{?_dist_release}
9Summary:        A multi-player strategy game
10Summary(ja):    多人数戦略ゲーム
11
12Group:          Applications/Games
13License:        GPLv2+
14URL:            http://freeciv.wikia.com/index.php/Freeciv
15Source0:        http://download.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
16Source1:        freeciv-2.2.5-fixed-tutorial_ja.po
17BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
18
19##Fix DSO patch
20Patch10:        freeciv-client-fix-DSO.patch
21
22BuildRequires:  gtk2-devel
23BuildRequires:  readline-devel
24BuildRequires:  zlib-devel
25BuildRequires:  SDL_mixer-devel
26BuildRequires:  esound-devel
27BuildRequires:  ncurses-devel
28BuildRequires:  ggz-client-libs-devel
29BuildRequires:  desktop-file-utils
30BuildRequires:  gettext
31
32Requires(post): ggz-client-libs
33Requires(preun): ggz-client-libs
34
35Vendor: Project Vine
36Distribution: Vine Linux
37Packager: iwaim
38
39%description
40Freeciv is a turn-based, multi-player, X based strategy game. Freeciv
41is generally comparable to, and has compatible rules with, the
42Civilization II(R) game by Microprose(R). In Freeciv, each player is
43the leader of a civilization, and is competing with the other players
44in order to become the leader of the greatest civilization.
45
46
47%prep
48%setup -q -n %{name}-%{version}
49%patch10 -p0
50%__rm -f po/ja.{po,gmo}
51%__cp -p %{SOURCE1} po/ja.po
52
53%build
54%configure --enable-client=gtk --disable-static
55make %{?_smp_mflags}
56
57%install
58rm -rf $RPM_BUILD_ROOT
59make install DESTDIR=$RPM_BUILD_ROOT
60%find_lang %{name}
61
62desktop-file-install --vendor vine --delete-original    \
63        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
64        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
65
66desktop-file-install --vendor vine --delete-original \
67        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
68        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}-server.desktop
69
70# Remove civmanual
71rm $RPM_BUILD_ROOT%{_bindir}/civmanual
72# ggz config
73# omit ggz.modules, to register at install, not build, time.
74if [ -e $RPM_BUILD_ROOT%{_sysconfdir}/ggz.modules ]; then
75rm $RPM_BUILD_ROOT%{_sysconfdir}/ggz.modules
76fi
77# include .dsc files
78install -p -D -m644 data/civclient.dsc $RPM_BUILD_ROOT%{_ggz_datadir}/civclient.dsc
79find $RPM_BUILD_ROOT -name '*.la' -delete
80find $RPM_BUILD_ROOT -name '*.a' -delete
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%post
86%{_ggz_config} --install --force --modfile=%{_ggz_datadir}/civclient.dsc || :
87touch --no-create %{_datadir}/icons/hicolor
88if [ -x %{_bindir}/gtk-update-icon-cache ]; then
89  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
90fi
91
92%preun
93if [ $1 -eq 0 ]; then
94%{_ggz_config} --remove --modfile=%{_ggz_datadir}/civclient.dsc || :
95fi
96
97%postun
98touch --no-create %{_datadir}/icons/hicolor
99if [ -x %{_bindir}/gtk-update-icon-cache ]; then
100  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
101fi
102
103
104%files -f %{name}.lang
105%defattr(-,root,root)
106%doc COPYING NEWS doc/BUGS doc/HOWTOPLAY doc/README
107%doc doc/README.AI doc/README.agents doc/README.attributes doc/README.cma
108%doc doc/README.delta doc/README.effects doc/README.ftwl doc/HACKING
109%doc doc/README.scorelog doc/TODO
110%doc doc/README.graphics doc/README.sound
111%{_bindir}/freeciv-server
112%{_bindir}/freeciv-gtk2
113%{_datadir}/%{name}/
114%{_datadir}/applications/vine-*.desktop
115%{_datadir}/icons/hicolor/*/apps/*.png
116%{_datadir}/pixmaps/%{name}-client.png
117%{_mandir}/man6/freeciv*6*
118%{_ggz_datadir}/civclient.dsc
119
120
121%changelog
122* Sun Nov  2 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.2.5-2
123- moved to Applications/Games
124
125* Thu Apr  7 2011 IWAI, Masaharu <iwai@alib.jp> 2.2.5-1
126- new upstream release
127- update ja.po (Source1): fixed upstream ja.po bug
128
129* Tue Dec 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.3-2
130- rebuild with SDL_mixer-1.2.11-2
131
132* Fri Sep 17 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.3-1
133- new upstream release
134- update ja.po (Source1): fixed upstream ja.po
135
136* Wed Sep  1 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.2-1
137- build for Vine Linux: from Fedora 2.2.2-1
138 - change BuildRequires: ggz-gtk-client-devel to gz-client-libs-devel
139- add ja.po (Source1) from http://loda.jp/freeciv/?id=81
140
141* Mon Aug 02 2010 Thomas Janssen <thomasj@fedoraproject.org> 2.2.2-1
142- security fix https://www.redhat.com/security/data/cve/CVE-2010-2445.html
143- fixes #612296
144
145* Sun Jun 06 2010 Thomas Janssen <thomasj@fedoraproject.org> 2.2.0-2
146- security fix http://gna.org/bugs/?15624
147- #600742 #600743 #600744
148
149* Tue Mar 02 2010 Thomas Janssen <thomasj@fedoraproject.org> 2.2.0-1
150- New upstream source 2.2.0
151
152* Fri Jan 29 2010 Brian Pepple <bpepple@fedoraproject.org> - 2.1.11-1
153- Update to 2.1.11.
154
155* Fri Dec 11 2009 Brian Pepple <bpepple@fedoraproject.org> - 2.1.10-1
156- Update to 2.1.10.
157
158* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.9-2
159- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
160
161* Sun Apr  5 2009 Brian Pepple <bpepple@fedoraproject.org> - 2.1.9-1
162- Update to 2.1.9.
163
164* Mon Mar 09 2009 Adam Tkac <atkac redhat com> - 2.1.8-3
165- drop bind-devel BuildReq, it is not needed
166
167* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.8-2
168- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
169
170* Thu Dec  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.8-1
171- Update to 2.1.8.
172
173* Wed Nov 26 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.7-1
174- Update to 2.1.7.
175
176* Sat Nov 22 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.6-2
177- Simplify summary.
178
179* Sat Aug 23 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.6-1
180- Update to 2.1.6.
181
182* Thu Jun 19 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.5-1
183- Update to 2.1.5.
184
185* Tue Apr 29 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.4-1
186- Update to 2.1.4.
187
188* Sat Feb  9 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> 2.1.3-4
189- Fix up typo.
190
191* Fri Feb  8 2008 Rex Dieter <rdieter@fedoraproject.org> 2.1.3-3
192- fixup ggz integration (#431726)
193
194* Mon Feb  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.3-2
195- Add ggz gaming support.
196
197* Sat Jan 26 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.3-1
198- Update to 2.1.3.
199
200* Tue Dec 25 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.1.2-1
201- Update to 2.1.2.
202
203* Thu Nov 29 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.1.1-1
204- Update to 2.1.1.
205- Drop buffer overflow patch. fixed upstream.
206- Drop open file patch. fixed upstream.
207
208* Sat Nov 24 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.1.0-2
209- Add patch to fix buffer overflow. (#397531)
210
211* Sun Oct 28 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.1.0-1
212- Update to 2.1.0.
213- Update urls.
214- Update aifill & open patches.
215- Remove old freeciv pixmap.
216- Remove desktop patch.
217
218* Sun Sep 16 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.0.9-4
219- Add patch to fix open function build bug.
220
221* Tue Aug 21 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.0.9-3
222- Rebuild.
223
224* Thu Aug  2 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.0.9-2
225- Update license tag.
226
227* Tue Feb 13 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.0.9-1
228- Update to 2.0.9.
229- Drop button patch, fixed upstream.
230- Drop security patch, fixed upstream.
231- Drop X-Fedora category from desktop files.
232
233* Thu Sep  7 2006 Brian Pepple <bpepple@fedoraproject.org> - 2.0.8-7
234- Rebuild for FC6.
235
236* Wed Aug  2 2006 Brian Pepple <bpepple@fedoraproject.org> - 2.0.8-6
237- Update security patch.
238- Add patch to fix turn done buttons style.
239
240* Tue Aug  1 2006 Brian Pepple <bpepple@fedoraproject.org> - 2.0.8-5
241- Add patch to fix CVE-2006-3913 vulnerability. (#200545)
242- Replace desktop file category 'Strategy' with 'StrategyGame'. (#198086)
243
244* Mon Mar  6 2006 Brian Pepple <bdpepple@ameritech.net> - 2.0.8-2
245- Update to 2.0.8.
246
247* Thu Feb 16 2006 Brian Pepple <bdpepple@ameritech.net> - 2.0.7-6
248- Remove unnecessary BR (alsa-lib-devel & SDL-devel).
249
250* Mon Feb 13 2006 Brian Pepple <bdpepple@ameritech.net> - 2.0.7-5
251- rebuilt for new gcc4.1 snapshot and glibc changes
252
253* Sun Dec  4 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.7-4
254- Rebuild for new bind.
255
256* Sun Nov  6 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.7-3
257- Update to 2.0.7.
258- Modify desktop patch for upstream fixes.
259- Drop the %%config from .desktop files.
260
261* Mon Sep 26 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.6-3
262- Update to 2.0.6.
263
264* Fri Sep  2 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.5-3
265- Update to 2.0.5.
266- Enable debug info.
267
268* Tue Aug 16 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.4-4
269- Rebuild for cairo dep.
270
271* Thu Jul 28 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.4-2
272- Update to 2.0.4.
273- Use new stdsounds.
274
275* Fri Jul 15 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.3-2
276- Bump release.
277
278* Thu Jul 14 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.3-1
279- Update to 2.0.3.
280
281* Tue Jun 14 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.2-1
282- Update to 2.0.2.
283- Add dist tag.
284
285* Tue Apr 26 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.1-1.fc4
286- Update to 2.0.1.
287
288* Mon Apr 18 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.0-3.fc4
289- Re-add patch to set aifill to 5 on new servers to get some opponents.
290
291* Mon Apr 18 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.0-2.fc4
292- remove redundant --dir* options in %%configure & %%makeinstall.
293
294* Mon Apr 18 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.0-1.fc4
295- Update to 2.0.0.
296- Drop 1.14 patches.
297- Add new BR's for 2.0.0.
298
299* Sat Mar 26 2005 Brian Pepple <bdpepple@ameritech.net> - 1.14.2-7
300- Fixed typos.
301
302* Sat Mar 26 2005 Brian Pepple <bdpepple@ameritech.net> - 1.14.2-6
303- Added more macros.
304- Replaced BuildPrereq with BuildRequires.
305- Drop version of gtk2-devel, since FC3 & later meet minimum needed.
306
307* Wed Mar 23 2005 Brian Pepple <bdpepple@ameritech.net> - 1.14.2-5
308- Changed X-Red-Hat-Extra to X-Fedora.
309- Added URL.
310- Changed BuildRoot to preferred value.
311- Removed period from summary.
312
313* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> 1.14.2-4
314- Rebuilt for new readline.
315
316* Tue Oct 26 2004 Daniel Reed <djr@redhat.com> 1.14.2-3
317- [136921] Try a little harder to run as nobody
318
319* Mon Oct 25 2004 Daniel Reed <djr@redhat.com> 1.14.2-2
320- [136921] Provide the user with the opportunity to run FreeCiv as root if unable to su to nobody, and throw up an error message if everything fails
321
322* Mon Sep 13 2004 Karsten Hopp <karsten@redhat.de> 1.14.2-1
323- update to latest stable version
324
325* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
326- rebuilt
327
328* Mon Feb 23 2004 Karsten Hopp <karsten@redhat.de> 1.14.1-3
329- rebuild with new chown syntax
330
331* Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com>
332- Use ':' instead of '.' as separator for chown.
333
334* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
335- rebuilt
336
337* Wed Dec 03 2003 Karsten Hopp <karsten@redhat.de> 1.14.1-1
338- update to bugfix release 1.14.1
339
340* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
341- rebuilt
342
343* Thu May 08 2003 Karsten Hopp <karsten@redhat.de> 1.14.0-1
344- update
345
346* Thu Feb 20 2003 Karsten Hopp <karsten@redhat.de> 1.13.0-6
347- remove last patch (obsolete)
348
349* Wed Feb 19 2003 Karsten Hopp <karsten@redhat.de>
350- fix message translation (#84599)
351
352* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
353- rebuilt
354
355* Thu Nov 07 2002 Karsten Hopp <karsten@redhat.de>
356- spelling fix (#75021)
357- set aifill to 5 on new servers to get some opponents (#72586)
358
359* Thu Aug 01 2002 Karsten Hopp <karsten@redhat.de>
360- desktop fixes (#69391)
361
362* Wed Jul 24 2002 Karsten Hopp <karsten@redhat.de>
363- 0.1.13
364- s/Games/Game in desktop-file-install
365- fix URL
366- add standard sounds
367
368* Wed Jul 17 2002 Karsten Hopp <karsten@redhat.de> 1.12.0-6
369- fix path to datafiles if FREECIV_PATH is not set (#67922)
370- fix desktop files (#67920)
371- use desktop-file-install
372
373* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
374- automated rebuild
375
376* Thu May 23 2002 Tim Powers <timp@redhat.com>
377- automated rebuild
378
379* Thu Jan 24 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.12.0-2
380- Rebuild in current environment
381
382* Thu Aug 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.12.0-1
383- 1.12.0 (non-beta)
384
385* Tue Jul 31 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.11.4-9
386- Rebuild - the fix for #49442 didn't seem to get in last time.
387
388* Mon Jul 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.11.4-8
389- Fix up demographics (#50119)
390
391* Wed Jun 27 2001 Than Ngo <than@redhat.com>
392- support new gettext
393- add patch to build against new libtool
394
395* Tue Mar 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
396- use gtk-config instead of glib-config
397
398* Sun Feb 25 2001 Bernhard Rosenkraenzer <bero@redhat.com>
399- Fix up civclient-wrapper so it doesn't fail silently when started as
400  potentially harmful user (Bug #28928)
401
402* Tue Aug  1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
403- Fix warning in civclient-wrapper (Bug 14860)
404
405* Fri Jul 21 2000 Trond Eivind Glomsrød <teg@redhat.com>
406- 1.11.4
407- move to /usr/bin and /usr/share/freeciv (no more /usr/games)
408
409* Wed Jul 12 2000 Trond Eivind Glomsrød <teg@redhat.com>
410- remove icon, glint is obsoleted
411- don't use find to build file lists, it claimed to own
412  lots of directories
413- use %%{_tmppath}
414
415* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
416- automatic rebuild
417
418* Mon Jul 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
419- 1.11.0 (Bug #13610)
420- Add .desktop files (Bug #13610)
421- Add BuildPrereq: lines
422- fix build
423
424* Thu Jun  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
425- move to dist
426- update
427- clean up the spec file
428- fix build with gcc 2.96
429- make the gtk client default; it's better than the Xaw one by now.
430
431* Thu Feb 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
432- 1.10.0
433
434* Fri Feb  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
435- 1.9.2
436- use the configure macro
437
438* Sun Nov  7 1999 Bernhard Rosenkraenzer <bero@redhat.com>
439- redo RPM for 1.9.0 (many changes to build/install procedure)
Note: See TracBrowser for help on using the repository browser.