source: projects/specs/branches/6/f/fontconfig/fontconfig-vl.spec @ 1851

Revision 1851, 23.0 KB checked in by iwaim, 14 years ago (diff)

build with rpm-4.8.1-1; see [VineSeed:21790]

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define freetype_version 2.3.11
3
4Summary: Font configuration and customization library
5Summary(ja): フォント設定/カスタマイズライブラリ
6Name: fontconfig
7Version: 2.8.0
8Release: 2%{?_dist_release}
9License: MIT
10Group: System Environment/Libraries
11URL: http://fontconfig.org/
12
13Source: http://fontconfig.org/release/fontconfig-%{version}.tar.gz
14Source10: 70-prefer-ja-font.conf
15Source11: 59-morisawa-font-alias.conf
16
17Patch1: fontconfig-2.2.1-AppleRoman-DynaFont.patch
18Patch4: fontconfig-2.3.2-subst-ja-font.patch
19Patch10: fontconfig-2.6.0-vine.patch
20
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: gawk
24BuildRequires: expat-devel
25BuildRequires: freetype2-devel >= %{freetype_version}
26BuildRequires: perl
27
28PreReq: freetype2 >= %{freetype_version}, coreutils
29Conflicts: XOrg-libs <= 6.9.0
30Obsoletes: XOrg-libs <= 6.9.0
31Conflicts: XOrg-font-utils <= 6.9.0
32Obsoletes: XOrg-font-utils <= 6.9.0
33
34%description
35Fontconfig is designed to locate fonts within the
36system and select them according to requirements specified by
37applications.
38
39%description -l ja
40Fontconfig は、システム内のフォントを把握し、アプリケーション
41が指定した要求に応じてそれらを選択するためのライブラリです。
42
43%package devel
44Summary: Development files for %{name}
45Summary(ja): Fontconfig の開発ファイル
46Group: Development/Libraries
47Requires: fontconfig = %{version}-%{release}
48Requires: freetype2-devel >= %{freetype_version}
49Requires: pkgconfig
50Conflicts: XOrg-devel <= 6.9.0
51Obsoletes: XOrg-devel <= 6.9.0
52
53%description devel
54The fontconfig-devel package includes the header files,
55and developer docs for the fontconfig package.
56
57%description -l ja devel
58fontconfig-devel パッケージには fontconfig を使ったソフトウエア
59を開発するために必要なヘッダファイルやライブラリ、開発用ドキュメ
60ントが含まれています。
61
62# compat32
63%package -n compat32-%{name}
64Summary: Font configuration and customization library
65Summary(ja): フォント設定/カスタマイズライブラリ
66Group: System Environment/Libraries
67
68%description -n compat32-%{name}
69Fontconfig is designed to locate fonts within the
70system and select them according to requirements specified by
71applications.
72
73%description -l ja -n compat32-%{name}
74Fontconfig は、システム内のフォントを把握し、アプリケーション
75が指定した要求に応じてそれらを選択するためのライブラリです。
76
77%package -n compat32-%{name}-devel
78Summary: Font configuration and customization library
79Group: Development/Libraries
80Requires: compat32-%{name} = %{version}-%{release}
81Requires: %{name}-devel = %{version}-%{release}
82Requires: compat32-freetype2-devel >= %{freetype_version}
83
84%description -n compat32-%{name}-devel
85The fontconfig-devel package includes the header files,
86and developer docs for the fontconfig package.
87
88%description -l ja -n compat32-%{name}-devel
89fontconfig-devel パッケージには fontconfig を使ったソフトウエア
90を開発するために必要なヘッダファイルやライブラリ、開発用ドキュメ
91ントが含まれています。
92
93%prep
94%setup -q
95%patch1 -p1 -b .fontconfig-AppleRoman-DynaFont
96%patch4 -p1 -b .subst-ja-font
97%patch10 -p1 -b .vine
98
99%build
100
101# We don't want to rebuild the docs, but we want to install the included ones.
102export HASDOCBOOK=no
103
104%configure \
105  --with-add-fonts=/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/TTF,/usr/local/share/fonts
106
107%__make %{?_smp_mflags}
108
109%install
110rm -rf $RPM_BUILD_ROOT
111
112%__make install DESTDIR=$RPM_BUILD_ROOT
113
114ln -s ../conf.avail/25-unhint-nonlatin.conf $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.d
115
116install -m664 %{SOURCE10} %{SOURCE11} $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.avail/
117for i in 70-prefer-ja-font.conf 59-morisawa-font-alias.conf
118do
119  ln -sf ../conf.avail/$i $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.d/
120done
121
122# move installed doc files back to build directory to package themm
123# in the right place
124mv $RPM_BUILD_ROOT%{_docdir}/fontconfig/* .
125rmdir $RPM_BUILD_ROOT%{_docdir}/fontconfig/
126
127# All font packages depend on this package, so we create
128# and own /usr/share/fonts
129mkdir -p $RPM_BUILD_ROOT%{_datadir}/fonts
130
131# Remove unpackaged files
132rm $RPM_BUILD_ROOT%{_libdir}/*.la
133rm $RPM_BUILD_ROOT%{_libdir}/*.a
134
135%clean
136rm -rf $RPM_BUILD_ROOT
137
138%post
139/sbin/ldconfig
140umask 0022
141# Remove stale caches
142rm -f %{_localstatedir}/cache/fontconfig/????????????????????????????????-*.cache-2
143HOME=/root /usr/bin/fc-cache -f -s >& /dev/null
144
145
146%postun -p /sbin/ldconfig
147
148%post -n compat32-%{name} -p /sbin/ldconfig
149
150%postun -n compat32-%{name} -p /sbin/ldconfig
151
152%files
153%defattr(-, root, root)
154%doc README AUTHORS COPYING
155%doc fontconfig-user.txt fontconfig-user.html
156%{_libdir}/libfontconfig.so.*
157%{_bindir}/fc-cache
158%{_bindir}/fc-list
159%{_bindir}/fc-match
160%{_bindir}/fc-cat
161%{_bindir}/fc-query
162%{_bindir}/fc-scan
163%dir %{_sysconfdir}/fonts/conf.avail
164%dir %{_datadir}/fonts
165%{_sysconfdir}/fonts/fonts.dtd
166%config %{_sysconfdir}/fonts/fonts.conf
167%doc %{_sysconfdir}/fonts/conf.d/README
168%config %{_sysconfdir}/fonts/conf.avail/*.conf
169%config(noreplace) %{_sysconfdir}/fonts/conf.d/*.conf
170%dir %{_localstatedir}/cache/fontconfig
171
172%{_mandir}/man1/*
173%{_mandir}/man5/*
174
175%files devel
176%defattr(-, root, root)
177%doc fontconfig-devel.txt fontconfig-devel
178%{_libdir}/libfontconfig.so
179%{_libdir}/pkgconfig/*
180%{_includedir}/fontconfig
181%{_mandir}/man3/*
182
183# compat32
184%if %{build_compat32}
185%files -n compat32-%{name}
186%defattr(-, root, root)
187%{_libdir}/libfontconfig.so.*
188
189%files -n compat32-%{name}-devel
190%defattr(-, root, root)
191%{_libdir}/libfontconfig.so
192%{_libdir}/pkgconfig/*
193%endif
194
195%changelog
196* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.0-2
197- build with rpm-4.8.1-1 for pkg-config file
198
199* Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-1
200- new upstream release
201- remove static libs
202
203* Sun Aug 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-3
204- update %%post
205
206* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-2
207- add translated summary and description
208
209* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-1
210- new upstream release
211
212* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-2
213- add fc-query and fc-scan to %%files
214
215* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
216- new upstream release
217- update 59-morisawa-font-alias.conf
218
219* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.0-3
220- added compat32 package for x86_64 arch support
221
222* Tue Jan 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-2
223- update 59-morisawa-font-alias.conf
224  - add FutoMin, FutoGo, Jun alias
225
226* Thu Jun 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-1
227- new upstream release
228- rename 10-prefer-ja-font.conf to 70-prefer-ja-font.conf
229
230* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-3
231- add 10-prefer-ja-font.conf to prefer Japanese fonts.
232- add 59-morisawa-font-alias.conf
233  - bind Ryumin to serif and GothicBBB to sans-serif
234
235* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
236- add legacy font path for compatibility
237
238* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
239- add Conflits/Obsoletes: XOrg-font-utils <= 6.9.0
240
241* Mon Dec 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-0vl1
242- initial build for Vine Linux
243  - splitted from XOrg package.
244
245* Thu Nov 13 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.5.0-1
246- Update to 2.5.0.
247
248* Thu Nov 06 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.92-1
249- Update to 2.4.92.
250- Mark /etc/fonts/conf.d/* as config(noreplace).
251- Remove most of our conf file, all upstreamed except for
252  75-blacklist-fedora.conf that I'm happily dropping.  Who has
253  Hershey fonts these days...
254- ln upstream'ed 25-unhint-nonlatin.conf from conf.avail in conf.d
255- Add 25-no-bitmap-fedora.conf which is the tiny remaining bit
256  of conf that didn't end up upstream.  Can get rid of it in the
257  future, but not just yet.
258
259* Thu Oct 25 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.91-1
260- Update to 2.4.91.
261- Add /usr/local/share/fonts to default config. (#147004)
262- Don't rebuild docs, to fix multilib conflicts. (#313011)
263- Remove docbook and elinks BuildRequires and stuff as we don't
264  rebuild docs.
265
266* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 2.4.2-5
267- Rebuild for PPC toolchain bug
268- Add BuildRequires: gawk
269
270* Sun Jun 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.4.2-4
271- /etc/fonts/conf.d is now owned by filesystem
272
273* Fri May 11 2007 Matthias Clasen <mclasen@redhat.com> - 2.4.2-3
274- Add Liberation fonts to 30-aliases-fedora.conf
275
276* Fri Jan 12 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.2-2
277- Change /usr/share/X11/fonts/OTF to /usr/share/X11/fonts/TTF
278- Resolves: #220809
279
280* Tue Dec  5 2006 Matthias Clasen <mclasen@redhat.com> - 2.4.2-1
281- Update to 2.4.2
282
283* Wed Oct  4 2006 Matthias Clasen <mclasen@redhat.com> - 2.4.1-4
284- Fix a multilib upgrade problem (#208151)
285
286* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 2.4.1-3
287- rebuilt for unwind info generation, broken in gcc-4.1.1-21
288
289* Fri Sep 22 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.1-2
290- Update 30-aliases-fedora.conf to correctly alias MS and StarOffice
291  fonts. (#207460)
292
293* Fri Sep 15 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.1-1
294- Update to 2.4.1, a public API was dropped from 2.4.0
295- Remove upstreamed patch
296
297* Mon Sep 11 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.0-1
298- Update to 2.4.0
299- Rename/order our configuration stuff to match the new scheme.
300  Breaks expected :-(
301
302* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-3
303- Add missing file.  Previous update didn't go through
304
305* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-2
306- Add fontconfig-2.3.97-ppc64.patch, for ppc64 arch signature
307
308* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-1
309- update to 2.3.97
310- Drop upstreamed patches
311- Regenerate defaultconfig patch
312- Don't touch stamp as it was not ever needed
313
314* Thu Aug 17 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.95-11
315- inclusion of zhong yi font and rearranged font prefer list. (bug# 201300)
316
317* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-10
318- use "%5x" instead of " %4x" to support 64k instead of
319  clamping.  Idea from Behdad.
320
321* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-9
322- tweak last patch to give a more reasonable page size
323  value if 64k page size is in effect.
324
325* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-8
326- maybe fix buffer overflow (bug 202152).
327
328* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-7
329- Update configs to provide better openoffice/staroffice
330  compatibility (bug 200723)
331
332* Thu Jul 27 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.95-6
333- Do umask 0022 in post
334- Update configs to reflect addition of new Indic fonts (#200381, #200397)
335
336* Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-5
337- Plug a small memory leak
338
339* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.3.95-4.1.1
340- rebuild
341
342* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.3.95-4.1
343- rebuild
344
345* Fri Jun  2 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-4
346- Fix the handling of TTF font collections
347
348* Thu May 18 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-3
349- Apply a patch by David Turner to speed up cache generation
350
351* Wed Apr 26 2006 Bill Nottingham <notting@redhat.com> - 2.3.95-2
352- fix fonts.conf typo
353
354* Wed Apr 26 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-1
355- Update to 2.3.95
356
357* Fri Feb 24 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.94-1
358- Update to 2.3.94
359
360* Wed Feb 11 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060211-1
361- Newer cvs snapshot
362
363* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.3.93.cvs20060208-1.1
364- bump again for double-long bug on ppc(64)
365
366* Wed Feb  8 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060208-1
367- Newer cvs snapshot
368
369* Tue Feb  7 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060207-1
370- Newer cvs snapshot
371- Drop upstreamed patches, pick up some new ones
372
373* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.3.93.cvs20060131-3.1
374- rebuilt for new gcc4.1 snapshot and glibc changes
375
376* Thu Feb  2 2006 Ray Strode <rstrode@redhat.com> - 2.3.93.cvs20060131-3
377- Move user cache to a subdirectory (bug 160275)
378
379* Thu Feb  2 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060131-2
380- Accumulated patches
381
382* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060131-1
383- Newer cvs snapshot
384
385* Tue Jan 24 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060124-1
386- Newer cvs snapshot
387
388* Tue Jan 17 2006 Ray Strode <rstrode@redhat.com> - 2.3.93-4
389- apply patch from Tim Mayberry to correct aliasing and disable
390  hinting for the two Chinese font names AR PL ShanHeiSun Uni
391  and AR PL Zenkai Uni
392
393* Tue Jan 10 2006 Bill Nottingham <notting@redhat.com> - 2.3.93-3
394- prereq coreutils for mkdir/touch in %%post
395
396* Wed Dec 21 2005 Carl Worth <cworth@redhat.com> - 2.3.93-2
397- Fix to create /var/cache/fontconfig/stamp in the post install stage.
398
399* Wed Dec 21 2005 Carl Worth <cworth@redhat.com> - 2.3.93-1
400- New upstream version.
401
402* Tue Dec 13 2005 Carl Worth <cworth@redhat.com> - 2.3.92.cvs20051129-3
403- Disable hinting for Lohit Gujarati
404
405* Fri Dec  9 2005 Carl Worth <cworth@redhat.com> - 2.3.92.cvs20051129-2
406- Add two new Chinese font names to the default fonts.conf file:
407        AR PL ShanHeiSun Uni
408        AR PL Zenkai Uni
409
410* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
411- rebuilt
412
413* Sat Nov 28 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92.cvs20051129-1
414- Update to a newer cvs snapshot
415
416* Sat Nov 19 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92.cvs20051119-1
417- Update to a newer cvs snapshot
418
419* Wed Nov 16 2005 Bill Nottingham <notting@redhat.com> - 2.3.93-3
420- modular X moved fonts from /usr/X11R6/lib/X11/fonts to
421  /usr/share/X11/fonts, adjust %%configure accordingly and
422  conflict with older font packages
423
424* Wed Nov  9 2005 Carl Worth <cworth@redhat.com> - 2.3.92-2
425- Remove inadvertent rejection of Luxi Mono from 40-blacklist-fonts.conf.
426  Fixes #172437
427
428* Fri Nov  4 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92-1
429- Update to 2.3.92
430
431* Fri Oct 31 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051031-1
432- Update to a newer cvs snapshot
433- Add a patch which should help to understand broken cache problems
434
435* Fri Oct 21 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051017-2
436- Add new Chinese fonts
437- Fix the 40-blacklist-fonts.conf file to use the documented
438  fonts.conf syntax, and exclude the Hershey fonts by family
439  name.
440
441* Fri Oct 14 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051017-1
442- Update to the mmap branch of fontconfig
443
444* Fri Jul 22 2005 Kristian H淡gsberg <krh@redhat.com> - 2.3.2-1
445- Update to fontconfig-2.3.2.  Drop
446
447        fontconfig-2.1-slighthint.patch,
448        fontconfig-2.2.3-timestamp.patch,
449        fontconfig-2.2.3-names.patch,
450        fontconfig-2.2.3-ta-pa-orth.patch, and
451        fontconfig-2.2.3-timestamp.patch,
452
453  as they are now merged upstream.
454
455- Fold fontconfig-2.2.3-add-sazanami.patch into
456  fontconfig-2.3.2-defaultconfig.patch and split rules to disable CJK
457  hinting out into /etc/fonts/conf.d/50-no-hint-fonts.conf.
458
459- Drop fontconfig-0.0.1.020826.1330-blacklist.patch and use the new
460  rejectfont directive to reject those fonts in 40-blacklist-fonts.conf.
461
462- Add fontconfig-2.3.2-only-parse-conf-files.patch to avoid parsing
463  .rpmsave files.
464
465- Renable s390 documentation now that #97079 has been fixed and add
466  BuildRequires: for docbook-utils and docbook-utils-pdf.
467
468- Drop code to iconv and custom install man pages, upstream does the
469  right thing now.
470
471- Add workaround from hell to make elinks cooperate so we can build
472  txt documentation.
473
474* Tue Apr 19 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-13
475- Add another font family name Sazanami Gothic/Mincho (#148748)
476
477* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-12
478- Rebuild
479
480* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-11
481- Rebuild
482
483* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-10
484- Rebuild
485
486* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-9
487- Disable docs for s390 for now
488
489* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-8
490- Rebuild
491
492* Wed Dec  1 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-6
493- Sleep a second before the exit of fc-cache to fix problems with fast
494  serial installs of fonts (#140335)
495- Turn off hinting for Lohit Hindi/Bengali/Punjabi (#139816)
496
497* Tue Oct 19 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-5
498- Add Lohit fonts for Indic languages (#134492)
499- Add Punjabi converage, fix Tamil coverage
500
501* Wed Sep 22 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-4
502- Update fonts-hebrew names to include CLM suffix
503
504* Thu Sep  2 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-3
505- Backport code from head branch of fontconfig CVS to parse names
506  for postscript fonts (fixes #127500, J. J. Ramsey)
507- Own /usr/share/fonts (#110956, David K. Levine)
508- Add KacstQura to serif/sans-serif/monospace aliases (#101182)
509
510* Mon Aug 16 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-2
511- Don't run fc-cache if the binary isn't there (#128072, tracked
512  down by Jay Turner)
513
514* Tue Aug  3 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-1
515- Upgrade to 2.2.3
516- Convert man pages to UTF-8 (#108730, Peter van Egdom)
517- Renable docs on s390
518
519* Mon Jul 26 2004 Owen Taylor <otaylor@redhat.com> - 2.2.1-12
520- Rebuild for RHEL
521- Back freetype required version down to 2.1.4
522
523* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
524- rebuilt
525
526* Mon Apr 19 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-10
527- Require recent freetype (#109592, Peter Oliver)
528- Remove fonts.conf timestamp to fix multiarch conflict (#118182)
529- Disable hinting for Mukti Narrow (#120915, Sayamindu Dasgupta)
530
531* Wed Mar 10 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-8.1
532- Rebuild
533
534* Wed Mar 10 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-8.0
535- Add Albany/Cumberland/Thorndale as fallbacks for Microsoft core fonts and
536  as non-preferred alternatives for Sans/Serif/Monospace
537- Fix FreeType includes for recent FreeType
538
539* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
540- rebuilt
541
542* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
543- rebuilt
544
545* Mon Sep 22 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-6.0
546- Should have been passing --with-add-fonts, not --with-add-dirs to
547  configure ... caused wrong version of Luxi to be used. (#100862)
548
549* Fri Sep 19 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-5.0
550- Tweak fonts.conf to get right hinting for CJK fonts (#97337)
551
552* Tue Jun 17 2003 Bill Nottingham <notting@redhat.com> 2.2.1-3
553- handle null config->cache correctly
554
555* Thu Jun 12 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-2
556- Update default config to include Hebrew fonts (#90501, Dov Grobgeld)
557
558* Tue Jun 10 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-2
559- As a workaround disable doc builds on s390
560
561* Mon Jun  9 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-1
562- Version 2.2.1
563
564* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
565- rebuilt
566
567* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
568- debuginfo rebuild
569
570* Mon Feb 24 2003 Owen Taylor <otaylor@redhat.com> 2.1-8
571- Fix segfault in fc-cache from .dircache patch
572
573* Mon Feb 24 2003 Owen Taylor <otaylor@redhat.com>
574- Back out patch that wrote fonts.conf entries that crash RH-8.0
575  gnome-terminal, go with patch from fontconfig CVS instead.
576  (#84863)
577
578* Tue Feb 11 2003 Owen Taylor <otaylor@redhat.com>
579- Move fontconfig man page to main package, since it contains non-devel
580  information (#76189)
581- Look in the OTF subdirectory of /usr/X11R6/lib/fonts as well
582  so we find Syriac fonts (#82627)
583
584* Thu Feb  6 2003 Matt Wilson <msw@redhat.com> 2.1-5
585- modified fontconfig-0.0.1.020626.1517-fontdir.patch to hard code
586  /usr/X11R6/lib/X11/fonts instead of using $(X_FONT_DIR).  This is
587  because on lib64 machines, fonts are not in /usr/X11R6/lib64/....
588
589* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
590- rebuilt
591
592* Wed Jan 15 2003 Owen Taylor <otaylor@redhat.com>
593- Try a different tack when fixing cache problem
594
595* Tue Jan 14 2003 Owen Taylor <otaylor@redhat.com>
596- Try to fix bug where empty cache entries would be found in
597  ~/.fonts.cache-1 during scanning (#81335)
598
599* Thu Nov 21 2002 Mike A. Harris <mharris@redhat.com> 2.1-1
600- Updated to version 2.1
601- Updated slighthint patch to fontconfig-2.1-slighthint.patch
602- Updated freetype version required to 2.1.2-7
603
604* Mon Sep  2 2002 Owen Taylor <otaylor@redhat.com>
605- Version 2.0
606- Correct capitalization/spacing for ZYSong18030 name (#73272)
607
608* Fri Aug 30 2002 Owen Taylor <otaylor@redhat.com>
609- Blacklist fonts from ghostscript-fonts that don't render correctly
610
611* Mon Aug 26 2002 Owen Taylor <otaylor@redhat.com>
612- Upgrade to fcpackage rc3
613- Fix bug in comparisons for xx_XX language tags
614- Compensate for a minor config file change in rc3
615
616* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
617- Add an explicit PreReq for freetype
618- Move fonts we don't ship to the end of the fonts.conf aliases so
619  installing them doesn't change the look.
620
621* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
622- Memory leak fix when parsing config files
623- Set rh_prefer_bitmaps for .ja fonts to key off of in Xft
624- Fix some groff warnings for fontconfig.man (#72138)
625
626* Thu Aug 15 2002 Owen Taylor <otaylor@redhat.com>
627- Try once more to get the right default Sans-serif font :-(
628- Switch the Sans/Monospace aliases for Korean to Gulim, not Dotum
629
630* Wed Aug 14 2002 Owen Taylor <otaylor@redhat.com>
631- Fix %%post
632
633* Tue Aug 13 2002 Owen Taylor <otaylor@redhat.com>
634- Fix lost Luxi Sans default
635
636* Mon Aug 12 2002 Owen Taylor <otaylor@redhat.com>
637- Upgrade to rc2
638- Turn off hinting for all CJK fonts
639- Fix typo in %%post
640- Remove the custom language tag stuff in favor of Keith's standard
641  solution.
642
643* Mon Jul 15 2002 Owen Taylor <otaylor@redhat.com>
644- Prefer Luxi Sans to Nimbus Sans again
645
646* Fri Jul 12 2002 Owen Taylor <otaylor@redhat.com>
647- Add FC_HINT_STYLE to FcBaseObjectTypes
648- Switch Chinese fonts to always using Sung-ti / Ming-ti, and never Kai-ti
649- Add ZYSong18030 to aliases (#68428)
650
651* Wed Jul 10 2002 Owen Taylor <otaylor@redhat.com>
652- Fix a typo in the langtag patch (caught by Erik van der Poel)
653
654* Wed Jul  3 2002 Owen Taylor <otaylor@redhat.com>
655- Add FC_HINT_STYLE tag
656
657* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
658- New upstream version, with fix for problems with
659  ghostscript-fonts (Fonts don't work for Qt+CJK,
660  etc.)
661
662* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
663- New upstream version, fixing locale problem
664
665* Mon Jun 24 2002 Owen Taylor <otaylor@redhat.com>
666- Add a hack where we set the "language" fontconfig property based on the locale, then
667  we conditionalize base on that in the fonts.conf file.
668
669* Sun Jun 23 2002 Owen Taylor <otaylor@redhat.com>
670- New upstream version
671
672* Tue Jun 18 2002 Owen Taylor <otaylor@redhat.com>
673- Fix crash from FcObjectSetAdd
674
675* Tue Jun 11 2002 Owen Taylor <otaylor@redhat.com>
676- make fonts.conf %%config, not %%config(noreplace)
677- Another try at the CJK aliases
678- Add some CJK fonts to the config
679- Prefer Luxi Mono to Nimbus Mono
680
681* Mon Jun 10 2002 Owen Taylor <otaylor@redhat.com>
682- New upstream version
683- Fix matching for bitmap fonts
684
685* Mon Jun  3 2002 Owen Taylor <otaylor@redhat.com>
686- New version, new upstream mega-tarball
687
688* Tue May 28 2002 Owen Taylor <otaylor@redhat.com>
689- Fix problem with FcConfigSort
690
691* Fri May 24 2002 Owen Taylor <otaylor@redhat.com>
692- Initial specfile
693
Note: See TracBrowser for help on using the repository browser.