source: projects/specs/trunk/f/fontconfig/fontconfig-vl.spec @ 521

Revision 521, 22.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define freetype_version 2.3.11
3
4Summary: Font configuration and customization library
5Summary(ja): フォント設定/カスタマイズライブラリ
6Name: fontconfig
7Version: 2.8.0
8Release: 1%{?_dist_release}
9License: MIT
10Group: System Environment/Libraries
11URL: http://fontconfig.org/
12
13Source: http://fontconfig.org/release/fontconfig-%{version}.tar.gz
14Source10: 70-prefer-ja-font.conf
15Source11: 59-morisawa-font-alias.conf
16
17Patch1: fontconfig-2.2.1-AppleRoman-DynaFont.patch
18Patch4: fontconfig-2.3.2-subst-ja-font.patch
19Patch10: fontconfig-2.6.0-vine.patch
20
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: gawk
24BuildRequires: expat-devel
25BuildRequires: freetype2-devel >= %{freetype_version}
26BuildRequires: perl
27
28PreReq: freetype2 >= %{freetype_version}, coreutils
29Conflicts: XOrg-libs <= 6.9.0
30Obsoletes: XOrg-libs <= 6.9.0
31Conflicts: XOrg-font-utils <= 6.9.0
32Obsoletes: XOrg-font-utils <= 6.9.0
33
34%description
35Fontconfig is designed to locate fonts within the
36system and select them according to requirements specified by
37applications.
38
39%description -l ja
40Fontconfig は、システム内のフォントを把握し、アプリケーション
41が指定した要求に応じてそれらを選択するためのライブラリです。
42
43%package devel
44Summary: Development files for %{name}
45Summary(ja): Fontconfig の開発ファイル
46Group: Development/Libraries
47Requires: fontconfig = %{version}-%{release}
48Requires: freetype2-devel >= %{freetype_version}
49Requires: pkgconfig
50Conflicts: XOrg-devel <= 6.9.0
51Obsoletes: XOrg-devel <= 6.9.0
52
53%description devel
54The fontconfig-devel package includes the header files,
55and developer docs for the fontconfig package.
56
57%description -l ja devel
58fontconfig-devel パッケージには fontconfig を使ったソフトウエア
59を開発するために必要なヘッダファイルやライブラリ、開発用ドキュメ
60ントが含まれています。
61
62# compat32
63%package -n compat32-%{name}
64Summary: Font configuration and customization library
65Summary(ja): フォント設定/カスタマイズライブラリ
66Group: System Environment/Libraries
67
68%description -n compat32-%{name}
69Fontconfig is designed to locate fonts within the
70system and select them according to requirements specified by
71applications.
72
73%description -l ja -n compat32-%{name}
74Fontconfig は、システム内のフォントを把握し、アプリケーション
75が指定した要求に応じてそれらを選択するためのライブラリです。
76
77%package -n compat32-%{name}-devel
78Summary: Font configuration and customization library
79Group: Development/Libraries
80Requires: compat32-%{name} = %{version}-%{release}
81Requires: %{name}-devel = %{version}-%{release}
82Requires: compat32-freetype2-devel >= %{freetype_version}
83
84%description -n compat32-%{name}-devel
85The fontconfig-devel package includes the header files,
86and developer docs for the fontconfig package.
87
88%description -l ja -n compat32-%{name}-devel
89fontconfig-devel パッケージには fontconfig を使ったソフトウエア
90を開発するために必要なヘッダファイルやライブラリ、開発用ドキュメ
91ントが含まれています。
92
93%prep
94%setup -q
95%patch1 -p1 -b .fontconfig-AppleRoman-DynaFont
96%patch4 -p1 -b .subst-ja-font
97%patch10 -p1 -b .vine
98
99%build
100
101# We don't want to rebuild the docs, but we want to install the included ones.
102export HASDOCBOOK=no
103
104%configure \
105  --with-add-fonts=/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/TTF,/usr/local/share/fonts
106
107%__make %{?_smp_mflags}
108
109%install
110rm -rf $RPM_BUILD_ROOT
111
112%__make install DESTDIR=$RPM_BUILD_ROOT
113
114ln -s ../conf.avail/25-unhint-nonlatin.conf $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.d
115
116install -m664 %{SOURCE10} %{SOURCE11} $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.avail/
117for i in 70-prefer-ja-font.conf 59-morisawa-font-alias.conf
118do
119  ln -sf ../conf.avail/$i $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.d/
120done
121
122# move installed doc files back to build directory to package themm
123# in the right place
124mv $RPM_BUILD_ROOT%{_docdir}/fontconfig/* .
125rmdir $RPM_BUILD_ROOT%{_docdir}/fontconfig/
126
127# All font packages depend on this package, so we create
128# and own /usr/share/fonts
129mkdir -p $RPM_BUILD_ROOT%{_datadir}/fonts
130
131# Remove unpackaged files
132rm $RPM_BUILD_ROOT%{_libdir}/*.la
133rm $RPM_BUILD_ROOT%{_libdir}/*.a
134
135%clean
136rm -rf $RPM_BUILD_ROOT
137
138%post
139/sbin/ldconfig
140umask 0022
141# Remove stale caches
142rm -f %{_localstatedir}/cache/fontconfig/????????????????????????????????-*.cache-2
143HOME=/root /usr/bin/fc-cache -f -s >& /dev/null
144
145
146%postun -p /sbin/ldconfig
147
148%post -n compat32-%{name} -p /sbin/ldconfig
149
150%postun -n compat32-%{name} -p /sbin/ldconfig
151
152%files
153%defattr(-, root, root)
154%doc README AUTHORS COPYING
155%doc fontconfig-user.txt fontconfig-user.html
156%{_libdir}/libfontconfig.so.*
157%{_bindir}/fc-cache
158%{_bindir}/fc-list
159%{_bindir}/fc-match
160%{_bindir}/fc-cat
161%{_bindir}/fc-query
162%{_bindir}/fc-scan
163%dir %{_sysconfdir}/fonts/conf.avail
164%dir %{_datadir}/fonts
165%{_sysconfdir}/fonts/fonts.dtd
166%config %{_sysconfdir}/fonts/fonts.conf
167%doc %{_sysconfdir}/fonts/conf.d/README
168%config %{_sysconfdir}/fonts/conf.avail/*.conf
169%config(noreplace) %{_sysconfdir}/fonts/conf.d/*.conf
170%dir %{_localstatedir}/cache/fontconfig
171
172%{_mandir}/man1/*
173%{_mandir}/man5/*
174
175%files devel
176%defattr(-, root, root)
177%doc fontconfig-devel.txt fontconfig-devel
178%{_libdir}/libfontconfig.so
179%{_libdir}/pkgconfig/*
180%{_includedir}/fontconfig
181%{_mandir}/man3/*
182
183# compat32
184%if %{build_compat32}
185%files -n compat32-%{name}
186%defattr(-, root, root)
187%{_libdir}/libfontconfig.so.*
188
189%files -n compat32-%{name}-devel
190%defattr(-, root, root)
191%{_libdir}/libfontconfig.so
192%{_libdir}/pkgconfig/*
193%endif
194
195%changelog
196* Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-1
197- new upstream release
198- remove static libs
199
200* Sun Aug 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-3
201- update %%post
202
203* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-2
204- add translated summary and description
205
206* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-1
207- new upstream release
208
209* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-2
210- add fc-query and fc-scan to %%files
211
212* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
213- new upstream release
214- update 59-morisawa-font-alias.conf
215
216* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.0-3
217- added compat32 package for x86_64 arch support
218
219* Tue Jan 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-2
220- update 59-morisawa-font-alias.conf
221  - add FutoMin, FutoGo, Jun alias
222
223* Thu Jun 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-1
224- new upstream release
225- rename 10-prefer-ja-font.conf to 70-prefer-ja-font.conf
226
227* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-3
228- add 10-prefer-ja-font.conf to prefer Japanese fonts.
229- add 59-morisawa-font-alias.conf
230  - bind Ryumin to serif and GothicBBB to sans-serif
231
232* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
233- add legacy font path for compatibility
234
235* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
236- add Conflits/Obsoletes: XOrg-font-utils <= 6.9.0
237
238* Mon Dec 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-0vl1
239- initial build for Vine Linux
240  - splitted from XOrg package.
241
242* Thu Nov 13 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.5.0-1
243- Update to 2.5.0.
244
245* Thu Nov 06 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.92-1
246- Update to 2.4.92.
247- Mark /etc/fonts/conf.d/* as config(noreplace).
248- Remove most of our conf file, all upstreamed except for
249  75-blacklist-fedora.conf that I'm happily dropping.  Who has
250  Hershey fonts these days...
251- ln upstream'ed 25-unhint-nonlatin.conf from conf.avail in conf.d
252- Add 25-no-bitmap-fedora.conf which is the tiny remaining bit
253  of conf that didn't end up upstream.  Can get rid of it in the
254  future, but not just yet.
255
256* Thu Oct 25 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.91-1
257- Update to 2.4.91.
258- Add /usr/local/share/fonts to default config. (#147004)
259- Don't rebuild docs, to fix multilib conflicts. (#313011)
260- Remove docbook and elinks BuildRequires and stuff as we don't
261  rebuild docs.
262
263* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 2.4.2-5
264- Rebuild for PPC toolchain bug
265- Add BuildRequires: gawk
266
267* Sun Jun 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.4.2-4
268- /etc/fonts/conf.d is now owned by filesystem
269
270* Fri May 11 2007 Matthias Clasen <mclasen@redhat.com> - 2.4.2-3
271- Add Liberation fonts to 30-aliases-fedora.conf
272
273* Fri Jan 12 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.2-2
274- Change /usr/share/X11/fonts/OTF to /usr/share/X11/fonts/TTF
275- Resolves: #220809
276
277* Tue Dec  5 2006 Matthias Clasen <mclasen@redhat.com> - 2.4.2-1
278- Update to 2.4.2
279
280* Wed Oct  4 2006 Matthias Clasen <mclasen@redhat.com> - 2.4.1-4
281- Fix a multilib upgrade problem (#208151)
282
283* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 2.4.1-3
284- rebuilt for unwind info generation, broken in gcc-4.1.1-21
285
286* Fri Sep 22 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.1-2
287- Update 30-aliases-fedora.conf to correctly alias MS and StarOffice
288  fonts. (#207460)
289
290* Fri Sep 15 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.1-1
291- Update to 2.4.1, a public API was dropped from 2.4.0
292- Remove upstreamed patch
293
294* Mon Sep 11 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.0-1
295- Update to 2.4.0
296- Rename/order our configuration stuff to match the new scheme.
297  Breaks expected :-(
298
299* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-3
300- Add missing file.  Previous update didn't go through
301
302* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-2
303- Add fontconfig-2.3.97-ppc64.patch, for ppc64 arch signature
304
305* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-1
306- update to 2.3.97
307- Drop upstreamed patches
308- Regenerate defaultconfig patch
309- Don't touch stamp as it was not ever needed
310
311* Thu Aug 17 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.95-11
312- inclusion of zhong yi font and rearranged font prefer list. (bug# 201300)
313
314* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-10
315- use "%5x" instead of " %4x" to support 64k instead of
316  clamping.  Idea from Behdad.
317
318* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-9
319- tweak last patch to give a more reasonable page size
320  value if 64k page size is in effect.
321
322* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-8
323- maybe fix buffer overflow (bug 202152).
324
325* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-7
326- Update configs to provide better openoffice/staroffice
327  compatibility (bug 200723)
328
329* Thu Jul 27 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.95-6
330- Do umask 0022 in post
331- Update configs to reflect addition of new Indic fonts (#200381, #200397)
332
333* Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-5
334- Plug a small memory leak
335
336* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.3.95-4.1.1
337- rebuild
338
339* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.3.95-4.1
340- rebuild
341
342* Fri Jun  2 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-4
343- Fix the handling of TTF font collections
344
345* Thu May 18 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-3
346- Apply a patch by David Turner to speed up cache generation
347
348* Wed Apr 26 2006 Bill Nottingham <notting@redhat.com> - 2.3.95-2
349- fix fonts.conf typo
350
351* Wed Apr 26 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-1
352- Update to 2.3.95
353
354* Fri Feb 24 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.94-1
355- Update to 2.3.94
356
357* Wed Feb 11 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060211-1
358- Newer cvs snapshot
359
360* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.3.93.cvs20060208-1.1
361- bump again for double-long bug on ppc(64)
362
363* Wed Feb  8 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060208-1
364- Newer cvs snapshot
365
366* Tue Feb  7 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060207-1
367- Newer cvs snapshot
368- Drop upstreamed patches, pick up some new ones
369
370* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.3.93.cvs20060131-3.1
371- rebuilt for new gcc4.1 snapshot and glibc changes
372
373* Thu Feb  2 2006 Ray Strode <rstrode@redhat.com> - 2.3.93.cvs20060131-3
374- Move user cache to a subdirectory (bug 160275)
375
376* Thu Feb  2 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060131-2
377- Accumulated patches
378
379* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060131-1
380- Newer cvs snapshot
381
382* Tue Jan 24 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060124-1
383- Newer cvs snapshot
384
385* Tue Jan 17 2006 Ray Strode <rstrode@redhat.com> - 2.3.93-4
386- apply patch from Tim Mayberry to correct aliasing and disable
387  hinting for the two Chinese font names AR PL ShanHeiSun Uni
388  and AR PL Zenkai Uni
389
390* Tue Jan 10 2006 Bill Nottingham <notting@redhat.com> - 2.3.93-3
391- prereq coreutils for mkdir/touch in %%post
392
393* Wed Dec 21 2005 Carl Worth <cworth@redhat.com> - 2.3.93-2
394- Fix to create /var/cache/fontconfig/stamp in the post install stage.
395
396* Wed Dec 21 2005 Carl Worth <cworth@redhat.com> - 2.3.93-1
397- New upstream version.
398
399* Tue Dec 13 2005 Carl Worth <cworth@redhat.com> - 2.3.92.cvs20051129-3
400- Disable hinting for Lohit Gujarati
401
402* Fri Dec  9 2005 Carl Worth <cworth@redhat.com> - 2.3.92.cvs20051129-2
403- Add two new Chinese font names to the default fonts.conf file:
404        AR PL ShanHeiSun Uni
405        AR PL Zenkai Uni
406
407* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
408- rebuilt
409
410* Sat Nov 28 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92.cvs20051129-1
411- Update to a newer cvs snapshot
412
413* Sat Nov 19 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92.cvs20051119-1
414- Update to a newer cvs snapshot
415
416* Wed Nov 16 2005 Bill Nottingham <notting@redhat.com> - 2.3.93-3
417- modular X moved fonts from /usr/X11R6/lib/X11/fonts to
418  /usr/share/X11/fonts, adjust %%configure accordingly and
419  conflict with older font packages
420
421* Wed Nov  9 2005 Carl Worth <cworth@redhat.com> - 2.3.92-2
422- Remove inadvertent rejection of Luxi Mono from 40-blacklist-fonts.conf.
423  Fixes #172437
424
425* Fri Nov  4 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92-1
426- Update to 2.3.92
427
428* Fri Oct 31 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051031-1
429- Update to a newer cvs snapshot
430- Add a patch which should help to understand broken cache problems
431
432* Fri Oct 21 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051017-2
433- Add new Chinese fonts
434- Fix the 40-blacklist-fonts.conf file to use the documented
435  fonts.conf syntax, and exclude the Hershey fonts by family
436  name.
437
438* Fri Oct 14 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051017-1
439- Update to the mmap branch of fontconfig
440
441* Fri Jul 22 2005 Kristian H淡gsberg <krh@redhat.com> - 2.3.2-1
442- Update to fontconfig-2.3.2.  Drop
443
444        fontconfig-2.1-slighthint.patch,
445        fontconfig-2.2.3-timestamp.patch,
446        fontconfig-2.2.3-names.patch,
447        fontconfig-2.2.3-ta-pa-orth.patch, and
448        fontconfig-2.2.3-timestamp.patch,
449
450  as they are now merged upstream.
451
452- Fold fontconfig-2.2.3-add-sazanami.patch into
453  fontconfig-2.3.2-defaultconfig.patch and split rules to disable CJK
454  hinting out into /etc/fonts/conf.d/50-no-hint-fonts.conf.
455
456- Drop fontconfig-0.0.1.020826.1330-blacklist.patch and use the new
457  rejectfont directive to reject those fonts in 40-blacklist-fonts.conf.
458
459- Add fontconfig-2.3.2-only-parse-conf-files.patch to avoid parsing
460  .rpmsave files.
461
462- Renable s390 documentation now that #97079 has been fixed and add
463  BuildRequires: for docbook-utils and docbook-utils-pdf.
464
465- Drop code to iconv and custom install man pages, upstream does the
466  right thing now.
467
468- Add workaround from hell to make elinks cooperate so we can build
469  txt documentation.
470
471* Tue Apr 19 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-13
472- Add another font family name Sazanami Gothic/Mincho (#148748)
473
474* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-12
475- Rebuild
476
477* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-11
478- Rebuild
479
480* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-10
481- Rebuild
482
483* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-9
484- Disable docs for s390 for now
485
486* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-8
487- Rebuild
488
489* Wed Dec  1 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-6
490- Sleep a second before the exit of fc-cache to fix problems with fast
491  serial installs of fonts (#140335)
492- Turn off hinting for Lohit Hindi/Bengali/Punjabi (#139816)
493
494* Tue Oct 19 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-5
495- Add Lohit fonts for Indic languages (#134492)
496- Add Punjabi converage, fix Tamil coverage
497
498* Wed Sep 22 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-4
499- Update fonts-hebrew names to include CLM suffix
500
501* Thu Sep  2 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-3
502- Backport code from head branch of fontconfig CVS to parse names
503  for postscript fonts (fixes #127500, J. J. Ramsey)
504- Own /usr/share/fonts (#110956, David K. Levine)
505- Add KacstQura to serif/sans-serif/monospace aliases (#101182)
506
507* Mon Aug 16 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-2
508- Don't run fc-cache if the binary isn't there (#128072, tracked
509  down by Jay Turner)
510
511* Tue Aug  3 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-1
512- Upgrade to 2.2.3
513- Convert man pages to UTF-8 (#108730, Peter van Egdom)
514- Renable docs on s390
515
516* Mon Jul 26 2004 Owen Taylor <otaylor@redhat.com> - 2.2.1-12
517- Rebuild for RHEL
518- Back freetype required version down to 2.1.4
519
520* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
521- rebuilt
522
523* Mon Apr 19 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-10
524- Require recent freetype (#109592, Peter Oliver)
525- Remove fonts.conf timestamp to fix multiarch conflict (#118182)
526- Disable hinting for Mukti Narrow (#120915, Sayamindu Dasgupta)
527
528* Wed Mar 10 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-8.1
529- Rebuild
530
531* Wed Mar 10 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-8.0
532- Add Albany/Cumberland/Thorndale as fallbacks for Microsoft core fonts and
533  as non-preferred alternatives for Sans/Serif/Monospace
534- Fix FreeType includes for recent FreeType
535
536* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
537- rebuilt
538
539* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
540- rebuilt
541
542* Mon Sep 22 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-6.0
543- Should have been passing --with-add-fonts, not --with-add-dirs to
544  configure ... caused wrong version of Luxi to be used. (#100862)
545
546* Fri Sep 19 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-5.0
547- Tweak fonts.conf to get right hinting for CJK fonts (#97337)
548
549* Tue Jun 17 2003 Bill Nottingham <notting@redhat.com> 2.2.1-3
550- handle null config->cache correctly
551
552* Thu Jun 12 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-2
553- Update default config to include Hebrew fonts (#90501, Dov Grobgeld)
554
555* Tue Jun 10 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-2
556- As a workaround disable doc builds on s390
557
558* Mon Jun  9 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-1
559- Version 2.2.1
560
561* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
562- rebuilt
563
564* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
565- debuginfo rebuild
566
567* Mon Feb 24 2003 Owen Taylor <otaylor@redhat.com> 2.1-8
568- Fix segfault in fc-cache from .dircache patch
569
570* Mon Feb 24 2003 Owen Taylor <otaylor@redhat.com>
571- Back out patch that wrote fonts.conf entries that crash RH-8.0
572  gnome-terminal, go with patch from fontconfig CVS instead.
573  (#84863)
574
575* Tue Feb 11 2003 Owen Taylor <otaylor@redhat.com>
576- Move fontconfig man page to main package, since it contains non-devel
577  information (#76189)
578- Look in the OTF subdirectory of /usr/X11R6/lib/fonts as well
579  so we find Syriac fonts (#82627)
580
581* Thu Feb  6 2003 Matt Wilson <msw@redhat.com> 2.1-5
582- modified fontconfig-0.0.1.020626.1517-fontdir.patch to hard code
583  /usr/X11R6/lib/X11/fonts instead of using $(X_FONT_DIR).  This is
584  because on lib64 machines, fonts are not in /usr/X11R6/lib64/....
585
586* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
587- rebuilt
588
589* Wed Jan 15 2003 Owen Taylor <otaylor@redhat.com>
590- Try a different tack when fixing cache problem
591
592* Tue Jan 14 2003 Owen Taylor <otaylor@redhat.com>
593- Try to fix bug where empty cache entries would be found in
594  ~/.fonts.cache-1 during scanning (#81335)
595
596* Thu Nov 21 2002 Mike A. Harris <mharris@redhat.com> 2.1-1
597- Updated to version 2.1
598- Updated slighthint patch to fontconfig-2.1-slighthint.patch
599- Updated freetype version required to 2.1.2-7
600
601* Mon Sep  2 2002 Owen Taylor <otaylor@redhat.com>
602- Version 2.0
603- Correct capitalization/spacing for ZYSong18030 name (#73272)
604
605* Fri Aug 30 2002 Owen Taylor <otaylor@redhat.com>
606- Blacklist fonts from ghostscript-fonts that don't render correctly
607
608* Mon Aug 26 2002 Owen Taylor <otaylor@redhat.com>
609- Upgrade to fcpackage rc3
610- Fix bug in comparisons for xx_XX language tags
611- Compensate for a minor config file change in rc3
612
613* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
614- Add an explicit PreReq for freetype
615- Move fonts we don't ship to the end of the fonts.conf aliases so
616  installing them doesn't change the look.
617
618* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
619- Memory leak fix when parsing config files
620- Set rh_prefer_bitmaps for .ja fonts to key off of in Xft
621- Fix some groff warnings for fontconfig.man (#72138)
622
623* Thu Aug 15 2002 Owen Taylor <otaylor@redhat.com>
624- Try once more to get the right default Sans-serif font :-(
625- Switch the Sans/Monospace aliases for Korean to Gulim, not Dotum
626
627* Wed Aug 14 2002 Owen Taylor <otaylor@redhat.com>
628- Fix %%post
629
630* Tue Aug 13 2002 Owen Taylor <otaylor@redhat.com>
631- Fix lost Luxi Sans default
632
633* Mon Aug 12 2002 Owen Taylor <otaylor@redhat.com>
634- Upgrade to rc2
635- Turn off hinting for all CJK fonts
636- Fix typo in %%post
637- Remove the custom language tag stuff in favor of Keith's standard
638  solution.
639
640* Mon Jul 15 2002 Owen Taylor <otaylor@redhat.com>
641- Prefer Luxi Sans to Nimbus Sans again
642
643* Fri Jul 12 2002 Owen Taylor <otaylor@redhat.com>
644- Add FC_HINT_STYLE to FcBaseObjectTypes
645- Switch Chinese fonts to always using Sung-ti / Ming-ti, and never Kai-ti
646- Add ZYSong18030 to aliases (#68428)
647
648* Wed Jul 10 2002 Owen Taylor <otaylor@redhat.com>
649- Fix a typo in the langtag patch (caught by Erik van der Poel)
650
651* Wed Jul  3 2002 Owen Taylor <otaylor@redhat.com>
652- Add FC_HINT_STYLE tag
653
654* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
655- New upstream version, with fix for problems with
656  ghostscript-fonts (Fonts don't work for Qt+CJK,
657  etc.)
658
659* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
660- New upstream version, fixing locale problem
661
662* Mon Jun 24 2002 Owen Taylor <otaylor@redhat.com>
663- Add a hack where we set the "language" fontconfig property based on the locale, then
664  we conditionalize base on that in the fonts.conf file.
665
666* Sun Jun 23 2002 Owen Taylor <otaylor@redhat.com>
667- New upstream version
668
669* Tue Jun 18 2002 Owen Taylor <otaylor@redhat.com>
670- Fix crash from FcObjectSetAdd
671
672* Tue Jun 11 2002 Owen Taylor <otaylor@redhat.com>
673- make fonts.conf %%config, not %%config(noreplace)
674- Another try at the CJK aliases
675- Add some CJK fonts to the config
676- Prefer Luxi Mono to Nimbus Mono
677
678* Mon Jun 10 2002 Owen Taylor <otaylor@redhat.com>
679- New upstream version
680- Fix matching for bitmap fonts
681
682* Mon Jun  3 2002 Owen Taylor <otaylor@redhat.com>
683- New version, new upstream mega-tarball
684
685* Tue May 28 2002 Owen Taylor <otaylor@redhat.com>
686- Fix problem with FcConfigSort
687
688* Fri May 24 2002 Owen Taylor <otaylor@redhat.com>
689- Initial specfile
690
Note: See TracBrowser for help on using the repository browser.