source: projects/specs/branches/6/b/bind/bind-vl.spec @ 9966

Revision 9966, 22.1 KB checked in by iwamoto, 8 years ago (diff)

bind: fix CVE-2015-8704

Line 
1%define _localstatedir /var
2
3%define pversion 9.9.7.P3
4%define sversion 9.9.7-P3
5%define bind_epoch 1
6
7%define bind_uid  25
8%define bind_gid  25
9
10Summary: A DNS (Domain Name System) server.
11Summary(ja): DNS (Domain Name System) サーバ
12Name: bind
13Version: %{pversion}
14Release: 3%{?_dist_release}
15License: distributable
16Group: System Environment/Daemons
17Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{name}-%{sversion}.tar.gz
18Source1: bind-manpages.tar.bz2
19Source2: named.sysconfig
20Source3: named.init
21Source4: named.logrotate
22Source5: keygen.c
23URL: http://www.isc.org/bind.html
24
25Patch1: bind-9.3.3rc2-rndckey.patch
26
27Patch100: bind-9.9.7-P3_CVE-2015-8000.patch
28Patch110: bind-9.9.x_CVE-2015-8704.patch
29
30Buildroot: %{_tmppath}/%{name}-%{version}-root
31BuildRequires: openssl-devel glibc-devel libtool readline-devel
32BuildRequires: libxml2-devel libcap-devel
33Requires(pre): chkconfig, sh-utils, textutils, fileutils, shadow-utils, perl, sed
34Requires(pre): bind-utils = %{bind_epoch}:%{version}-%{release}
35Requires(pre): shadow-utils
36Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
37Requires(post): bind-utils = %{bind_epoch}:%{version}-%{release}
38Requires(post): coreutils, chkconfig
39Requires(preun): initscripts, chkconfig
40Conflicts: bind9 <= 9.2.1-0vl5, bind-current
41Obsoletes: bind9 <= 9.2.1-0vl5
42Epoch: %{bind_epoch}
43
44Vendor: Project Vine
45Distribution: Vine Linux
46
47%description
48BIND (Berkeley Internet Name Domain) is an implementation of the DNS
49(Domain Name System) protocols. BIND includes a DNS server (named),
50which resolves host names to IP addresses, and a resolver library
51(routines for applications to use when interfacing with DNS).  A DNS
52server allows clients to name resources or objects and share the
53information with other network machines.  The named DNS server can be
54used on workstations as a caching name server, but is generally only
55needed on one machine for an entire network.  Note that the
56configuration files for making BIND act as a simple caching nameserver
57are included in the caching-nameserver package. 
58
59Install the bind package if you need a DNS server for your network.  If
60you want bind to act a caching name server, you will also need to install
61the caching-nameserver package.
62
63
64%package libs
65Summary: Libraries used by various DNS packages
66Group: System Environment/Libraries
67Conflicts: bind-current-libs
68
69%description libs
70Contains libraries used by both the bind server package as well as the utils packages.
71
72
73%package utils
74Summary: Utilities for querying DNS name servers.
75Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
76Group: Applications/System
77Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
78Conflicts: bind9-utils <= 9.2.1-0vl5, bind-current-utils
79Obsoletes: bind9-utils <= 9.2.1-0vl5
80
81
82%description utils
83Bind-utils contains a collection of utilities for querying DNS (Domain
84Name Service) name servers to find out information about Internet hosts.
85These tools will provide you with the IP addresses for given host names,
86as well as other information about registered domains and network
87addresses.
88
89You should install bind-utils if you need to get information from DNS name
90servers.
91
92
93%package devel
94Summary: Include files and libraries needed for bind DNS development.
95Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
96Group: Development/Libraries
97Requires: bind = %{bind_epoch}:%{version}-%{release}
98Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
99Conflicts: bind9-devel <= 9.2.1-0vl5, bind-current-devel
100Obsoletes: bind9-devel <= 9.2.1-0vl5
101
102
103%description devel
104The bind-devel package contains all the include files and the
105library required for DNS (Domain Name Service) development for
106BIND versions 9.x.x.
107
108You should install bind-devel if you want to develop bind DNS
109applications. If you install bind-devel, you'll also need to install
110bind.
111#'
112
113%prep
114%setup -n bind-%{sversion} -q
115%patch1 -p1 -b .key
116
117%patch100 -p1 -b .CVE-2015-8000
118%patch110 -p1 -b .CVE-2015-8704
119
120perl -pi -e 's/^(SUBDIRS =.+)dlzexternal(.+)$/\1\2/' bin/tests/system/Makefile.in
121
122%build
123libtoolize --copy --force
124aclocal
125autoconf
126# %configure --with-libtool --with-openssl=/usr --enable-threads
127%configure \
128  --with-libtool \
129  --with-openssl=/usr \
130  --disable-openssl-version-ceck \
131  --enable-threads \
132  --enable-ipv6 \
133  --with-pic \
134  --with-dlz-dlopen \
135  --enable-filter-aaaa \
136  --enable-fixed-rrset
137make %{?_smp_mflags}
138
139%install
140rm -rf $RPM_BUILD_ROOT
141mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
142mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
143mkdir -p ${RPM_BUILD_ROOT}/var/named
144mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
145mkdir -p ${RPM_BUILD_ROOT}/var/run/named
146
147make DESTDIR=$RPM_BUILD_ROOT install
148install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
149install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
150install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
151install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
152touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
153gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
154cd $RPM_BUILD_ROOT%{_mandir}
155tar xjf %{SOURCE1}
156# newer version is contained in source
157rm -f man5/named.conf.5.gz
158mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
159cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
160
161chmod +x %{buildroot}%{_libdir}/*.so.*
162
163%pre
164if [ "$1" -eq 1 ]; then
165  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
166  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
167fi;
168:;
169
170%post
171/sbin/ldconfig
172/sbin/chkconfig --add named
173if [ "$1" -eq 1 ]; then
174  if [ ! -e /etc/rndc.key ]; then
175    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
176  fi
177  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
178  # rndc.key has to have correct perms and ownership, CVE-2007-6283
179  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
180  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
181
182  # Check DNSSEC settings if this is a fresh install
183  if [ -r /etc/sysconfig/dnssec ]; then
184    . /etc/sysconfig/dnssec
185    [ -x /usr/sbin/dnssec-configure ] && \
186      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
187        /dev/null 2>&1
188  fi;
189fi
190:;
191
192%preun
193if [ "$1" -eq 0 ]; then
194   /sbin/service named stop >/dev/null 2>&1 || :
195   /sbin/chkconfig --del named ||:
196fi
197exit 0
198
199
200%postun
201if [ "$1" -ge 1 ]; then
202        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
203fi
204/sbin/ldconfig
205
206%triggerpostun -- bind < 8.2.2_P5-15
207/sbin/chkconfig --add named
208/sbin/ldconfig
209
210%clean
211rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
212
213
214%post libs
215/sbin/ldconfig
216
217%postun libs
218/sbin/ldconfig
219
220
221%files
222%defattr(-,root,root)
223%doc CHANGES README
224%doc doc/arm doc/draft doc/rfc doc/misc
225%config(noreplace) %{_sysconfdir}/logrotate.d/named
226%config %{_sysconfdir}/rc.d/init.d/named
227%config(noreplace) %{_sysconfdir}/sysconfig/named
228%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
229%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
230%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
231
232%{_sbindir}/dnssec*
233%{_sbindir}/lwresd
234%{_sbindir}/named
235%{_sbindir}/named-bootconf
236%{_sbindir}/named-check*
237%{_sbindir}/named-compilezone
238%{_sbindir}/rndc*
239%{_sbindir}/dns-keygen
240%{_sbindir}/arpaname
241%{_sbindir}/ddns-confgen
242%{_sbindir}/genrandom
243%{_sbindir}/isc-hmac-fixup
244%{_sbindir}/named-journalprint
245%{_sbindir}/nsec3hash
246
247%{_mandir}/man1/arpaname.1*
248%{_mandir}/man5/resolv.conf.5*
249%{_mandir}/man5/named.conf.5*
250%{_mandir}/man5/rndc.conf.5*
251%{_mandir}/man8/rndc.8*
252%{_mandir}/man8/named.8*
253%{_mandir}/man8/lwresd.8*
254%{_mandir}/man8/dnssec*.8*
255%{_mandir}/man8/named-checkconf.8*
256%{_mandir}/man8/named-checkzone.8*
257%{_mandir}/man8/named-compilezone.8*
258%{_mandir}/man8/rndc-confgen.8*
259%{_mandir}/man8/ddns-confgen.8*
260%{_mandir}/man8/genrandom.8*
261%{_mandir}/man8/isc-hmac-fixup.8*
262%{_mandir}/man8/named-journalprint.8*
263%{_mandir}/man8/nsec3hash.8*
264
265%attr(-,named,named) %dir %{_var}/named
266%attr(-,named,named) %dir %{_var}/run/named
267     
268
269%files libs
270%defattr(-,root,root)
271%{_libdir}/*.so.*
272
273%files utils
274%defattr(-,root,root)
275%{_bindir}/dig
276%{_bindir}/host
277%{_bindir}/nslookup
278%{_bindir}/nsupdate
279%{_mandir}/man1/host.1*
280%{_mandir}/man1/nsupdate.1*
281%{_mandir}/man1/dig.1*
282%{_mandir}/man5/resolver.5*
283%{_mandir}/man1/nslookup.1*
284%{_mandir}/man8/nslookup.8*
285
286
287%files devel
288%defattr(-,root,root)
289%{_libdir}/*.so
290# %{_libdir}/*.la
291%{_libdir}/*.a
292%{_includedir}/*
293%{_mandir}/man3/*
294%{_mandir}/man1/isc-config.sh.1*
295%{_bindir}/isc-config.sh
296
297%changelog
298* Wed Jan 20 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P3-3vl6
299- add patch110 for fix CVE-2015-8704
300
301* Wed Dec 16 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P3-2vl6
302- add patch100 for fix CVE-2015-8000
303
304* Thu Sep  3 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P3-1vl6
305- new upstream release with secrity fix (CVE-2015-5722,5986)
306
307* Wed Jul 29 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P2-1vl6
308- new upstream release with secrity fix (CVE-2015-5477) 
309
310* Sat Jul 11 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P1-1vl6
311- new upstream release with secrity fix (CVE-2015-4620)
312
313* Thu Feb 19 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.6.P2-1vl6
314- new upstream release with secrity fix (CVE-2015-1349)
315- add BR: readline-devel
316
317* Sun Dec 21 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.6.P1-2vl6
318- rebuilt
319
320* Wed Dec 10 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.6.P1-1vl6
321- new upstream release with secrity fix (CVE-2014-8500) 
322
323* Sun May 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.5-1vl6
324- 9.9.x for Vine6.x
325
326* Tue Jan 14 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
327- 9.6.ESV.R10.P2-1
328- new upstream release with secrity fix (CVE-2014-0591)
329
330* Wed Oct 10 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R8-1
331- new upstream release with secrity fix (CVE-2012-5166)
332
333* Thu Sep 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R7.P3-1
334- new upstream release with secrity fix (CVE-2012-4244)
335
336* Wed Jul 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.ESV.R7.P2-1
337- new upstream release with secrity fix (CVE-2012-3817)
338
339* Tue Jun  5 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R7.P1-1
340- new upstream release with security fix (CVE-2012-1667)
341
342* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R5.P1-1
343- new upstream release with security fix (CVE-2011-4313)
344
345* Wed Jul  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R4.P3-1
346- new upstream release with security fix (CVE-2011-2464)
347- use hoge(pre) tags instead of old hogepre tags
348
349* Sat May 28 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R4.P1-1
350- new upstream release with security fix (CVE-2011-1910)
351
352* Thu Mar 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.6.ESV.R4-1
353- new upstream release
354
355* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R2-4
356- rebuild with openssl-1.0.0c
357
358* Fri Jan 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R2-3
359- rebuild package
360
361* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-2
362- change spec filename bind9-vl -> bind-vl
363
364* Thu Oct  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-1
365- new upstream ESV release
366- add BR: libxml2-devel libcap-devel
367
368* Wed Aug 18 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-2
369- add Conflicts bind-current
370
371* Tue Aug 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-1
372- new upstream ESV release
373- add epoch 1 to upgrade from exist bind package
374
375* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
376- add man1/isc-config.sh.1 into devel file list
377
378* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
379- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
380
381* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
382- new upstream release with security fix (CVE-2009-4022)
383
384* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
385- new upstream release with security fix
386
387* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
388- new upstream release
389- clean up %%post/%%pre scriptlet
390  - create named user and group in %%pre
391  - don't remove named user/group in %%preun
392  - use rndc-confgen to create rndc.key
393
394* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
395- new upstream release
396- drop patch0 and patch14, merged in upstream
397
398* Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
399- new upstream release with security fix
400
401* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
402- new upstream release with security fix
403- new versioning policy
404
405* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
406- new upstream release with security fix
407
408* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
409- new upstream release
410- build with new openssl/toolchain
411
412* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
413- new upstream release with security fix
414
415* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
416- new upstream release
417
418* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
419- add Prereq sed
420
421* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
422- new upstream release for security fix (CVE-2006-4095,4096)
423
424* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
425- separate -libs package
426- remove old named.conf.5.gz
427  - newer version is contained in source
428
429* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
430- add bsdcompat patch (Patch4)
431- add fix_h_errno patch from FC
432  - h_errno not being accessed / set correctly in libbind
433
434* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
435- new upstream release
436
437* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
438- added PreReq to bind-utils (see: [VineSeed:09555])
439
440* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
441- new upstream release
442
443* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
444- fix /etc/init.d/named to use rndc
445
446* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
447- rebuild to remove unneeded dependancy
448
449* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
450- new upstream release
451
452* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
453- new upstream release
454
455* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
456- fix dependancies.
457
458* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
459- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
460- change package name to bind for VineSeed.
461- use more macros.
462
463* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
464- fixed some macros
465- add conflicts: to bind-* in bind9-devel and bind9-utils
466- add provides: bind = %%{version}
467
468* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
469- use %%configure macros
470
471* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
472- fixed inconsistent dependency
473
474* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
475- updated to 9.2.2rc1
476
477* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
478- updated to bind9(9.2.1), test packages ;)
479        -- based on Rawhide's bind-9.2.0-8
480        -- changed name bind9
481        -- added Conflicts: bind
482
483* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
484- release 8.3.1 includes security fixes
485
486* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
487- Upgraded to current stable release 8.3.0
488
489* Mon Oct  8 2001 <zn@mbf.nifty.com>
490- 8.2.5-0vl0: Upgraded to new upstream version.
491
492* Thu May 24 2001 <sagami@vinelinux.org>
493- 8.2.4-0vl1: eliminate CVS related files from %%doc
494
495* Thu May 17 2001 <sagami@vinelinux.org>
496- 8.2.4-0vl0
497
498* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
499- 8.2.3-1vl2
500- built on VineSeed
501
502* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
503- add doc/old
504- build for Vine 2.1
505
506* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
507- 8.2.3, fixes several security problems
508
509* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
510- static libraries may be used in shared objects. Build with -fPIC on ia64
511
512* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
513- 8.2.2-P7 (fixes Bug #20546)
514
515* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
516- condrestart fixes
517
518* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
519- change the init script to take condrestart, not cond-restart
520- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
521  the %pre and %post scripts
522
523* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
524- Don't prereq /etc/init.d
525
526* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
527- move initscript back
528
529* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
530- automatic rebuild
531
532* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
533- add "exit 0" for uninstall case
534
535* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
536- add prereq init.d and cleanup install section
537
538* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
539- fix the init script
540
541* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
542- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
543
544* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
545- Fix up the initscript (Bug #13033)
546- Fix build with current glibc (Bug #12755)
547- /etc/rc.d/init.d -> /etc/init.d
548- use %%{_mandir} rather than /usr/share/man
549
550* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
551- fix conflict with man-pages
552- remove compatibilty chkconfig links
553- initscript munging
554
555* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
556- modify logrotate setup to use PID file
557- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
558- actually bump the release this time
559
560* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
561- FHS compliance
562
563* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
564- clean up restart patch
565
566* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
567- provide /var/named (fix for bugs #9847, #10205)
568- preserve args when restarted via ndc(8) (bug #10227)
569- make resolv.conf(5) a link to resolver(5) (bug #10245)
570- fix SYSTYPE bug in all makefiles
571- move creation of named user from %%post into %%pre
572
573* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
574- Fix TTL (patch from ISC, Bug #9820)
575
576* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
577- fix typo in spec (it's %post, without a leading blank) introduced in -6
578- change SYSTYPE to linux
579
580* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
581- pick a standard < 100 uid/gid for named
582
583* Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
584- Pass named a '-u named' parameter by default, and add/remove user.
585
586* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
587- fix host mx bug (Bug #9021)
588
589* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
590- rebuild to fix dependencies
591- man pages are compressed
592
593* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
594- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
595
596* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
597- Fix up location of named-bootconf.pl and make it executable
598  (Bug #8028)
599- bind-devel requires bind
600
601* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
602- update to 8.2.2-P5
603
604* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
605- update to 8.2.2-P3
606
607* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
608- add patch to stop a cache only server from complaining about lame servers
609  on every request.
610
611* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
612- use real stop and start in named.init for restart, not ndc restart, it has
613  problems when named has changed during a package update... (# 4890)
614
615* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
616- chkconfig --del in %preun, not %postun
617
618* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
619- initscript munging
620
621* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
622- fix installed chkconfig links to match init file
623
624* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
625- conflict with new (in man-1.24) man pages (#3876,#3877).
626
627* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
628- fix named.logrotate (wrong %SOURCE)
629
630* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
631- update to 8.2.1.
632- add named.logrotate (#3571).
633- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
634- vet file list.
635
636* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
637- don't run by default
638
639* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
640- nslookup fixes (#2463).
641- missing files (#3152).
642
643* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
644- nslookup patched:
645  to count numRecords properly
646  to fix subsequent calls to ls -d
647  to parse "view" and "finger" commands properly
648  the view hack updated for bind-8 (using sed)
649
650* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
651- add ISC patch
652- add quick hack to make host not crash
653- add more docs
654
655* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
656- add probing information in the init file to keep linuxconf happy
657- dont strip libbind
658
659* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
660- auto rebuild in the new build environment (release 3)
661
662* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
663- removed 'done' output at named shutdown.
664
665* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
666- version 8.2
667
668* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
669- patch to use the __FDS_BITS macro
670- build for glibc 2.1
671
672* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
673- change named.restart to /usr/sbin/ndc restart
674
675* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
676- install man pages correctly.
677- change K10named to K45named.
678
679* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
680- don't start if /etc/named.conf doesn't exist.
681
682* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
683- autmagically create /etc/named.conf from /etc/named.boot in %post
684- remove echo in %post
685
686* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
687- merge in 5.1 mods
688
689* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
690- Several essential modifications to build and install correctly.
691- Modified 'ndc' to avoid deprecated use of '-'
692
693* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
694- Used buildroot
695- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
696  on Redhat 5.0 instead of <nlist.h>
697
Note: See TracBrowser for help on using the repository browser.