source: projects/specs/branches/6/b/bind/bind-vl.spec @ 10724

Revision 10724, 22.7 KB checked in by tomop, 8 years ago (diff)

bind-9.9.7.P3-5

Line 
1%define _localstatedir /var
2
3%define pversion 9.9.7.P3
4%define sversion 9.9.7-P3
5%define bind_epoch 1
6
7%define bind_uid  25
8%define bind_gid  25
9
10Summary: A DNS (Domain Name System) server.
11Summary(ja): DNS (Domain Name System) サーバ
12Name: bind
13Version: %{pversion}
14Release: 5%{?_dist_release}
15License: distributable
16Group: System Environment/Daemons
17Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{name}-%{sversion}.tar.gz
18Source1: bind-manpages.tar.bz2
19Source2: named.sysconfig
20Source3: named.init
21Source4: named.logrotate
22Source5: keygen.c
23URL: http://www.isc.org/bind.html
24
25Patch1: bind-9.3.3rc2-rndckey.patch
26Patch50: bind-fix-include-order.patch
27
28Patch100: bind-9.9.7-P3_CVE-2015-8000.patch
29Patch110: bind-9.9.x_CVE-2015-8704.patch
30Patch120: bind-9.9.x_CVE-2016-1285.patch
31Patch130: bind-9.9.7-P3_CVE-2016-1286.patch
32Patch140: CVE-2016-2775.patch
33
34Buildroot: %{_tmppath}/%{name}-%{version}-root
35BuildRequires: openssl-devel glibc-devel libtool readline-devel
36BuildRequires: libxml2-devel libcap-devel
37Requires(pre): chkconfig, sh-utils, textutils, fileutils, shadow-utils, perl, sed
38Requires(pre): bind-utils = %{bind_epoch}:%{version}-%{release}
39Requires(pre): shadow-utils
40Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
41Requires(post): bind-utils = %{bind_epoch}:%{version}-%{release}
42Requires(post): coreutils, chkconfig
43Requires(preun): initscripts, chkconfig
44Conflicts: bind9 <= 9.2.1-0vl5, bind-current
45Obsoletes: bind9 <= 9.2.1-0vl5
46Epoch: %{bind_epoch}
47
48Vendor: Project Vine
49Distribution: Vine Linux
50
51%description
52BIND (Berkeley Internet Name Domain) is an implementation of the DNS
53(Domain Name System) protocols. BIND includes a DNS server (named),
54which resolves host names to IP addresses, and a resolver library
55(routines for applications to use when interfacing with DNS).  A DNS
56server allows clients to name resources or objects and share the
57information with other network machines.  The named DNS server can be
58used on workstations as a caching name server, but is generally only
59needed on one machine for an entire network.  Note that the
60configuration files for making BIND act as a simple caching nameserver
61are included in the caching-nameserver package. 
62
63Install the bind package if you need a DNS server for your network.  If
64you want bind to act a caching name server, you will also need to install
65the caching-nameserver package.
66
67
68%package libs
69Summary: Libraries used by various DNS packages
70Group: System Environment/Libraries
71Conflicts: bind-current-libs
72
73%description libs
74Contains libraries used by both the bind server package as well as the utils packages.
75
76
77%package utils
78Summary: Utilities for querying DNS name servers.
79Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
80Group: Applications/System
81Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
82Conflicts: bind9-utils <= 9.2.1-0vl5, bind-current-utils
83Obsoletes: bind9-utils <= 9.2.1-0vl5
84
85
86%description utils
87Bind-utils contains a collection of utilities for querying DNS (Domain
88Name Service) name servers to find out information about Internet hosts.
89These tools will provide you with the IP addresses for given host names,
90as well as other information about registered domains and network
91addresses.
92
93You should install bind-utils if you need to get information from DNS name
94servers.
95
96
97%package devel
98Summary: Include files and libraries needed for bind DNS development.
99Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
100Group: Development/Libraries
101Requires: bind = %{bind_epoch}:%{version}-%{release}
102Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
103Conflicts: bind9-devel <= 9.2.1-0vl5, bind-current-devel
104Obsoletes: bind9-devel <= 9.2.1-0vl5
105
106
107%description devel
108The bind-devel package contains all the include files and the
109library required for DNS (Domain Name Service) development for
110BIND versions 9.x.x.
111
112You should install bind-devel if you want to develop bind DNS
113applications. If you install bind-devel, you'll also need to install
114bind.
115#'
116
117%prep
118%setup -n bind-%{sversion} -q
119%patch1 -p1 -b .key
120%patch50 -p1 -b .include-order
121
122%patch100 -p1 -b .CVE-2015-8000
123%patch110 -p1 -b .CVE-2015-8704
124%patch120 -p1 -b .CVE-2016-1285
125%patch130 -p1 -b .CVE-2016-1286
126%patch140 -p1 -b .CVE-2016-2775
127
128perl -pi -e 's/^(SUBDIRS =.+)dlzexternal(.+)$/\1\2/' bin/tests/system/Makefile.in
129
130%build
131libtoolize --copy --force
132aclocal
133autoconf
134# %configure --with-libtool --with-openssl=/usr --enable-threads
135%configure \
136  --with-libtool \
137  --with-openssl=/usr \
138  --disable-openssl-version-ceck \
139  --enable-threads \
140  --enable-ipv6 \
141  --with-pic \
142  --with-dlz-dlopen \
143  --enable-filter-aaaa \
144  --enable-fixed-rrset
145make %{?_smp_mflags}
146
147%install
148rm -rf $RPM_BUILD_ROOT
149mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
150mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
151mkdir -p ${RPM_BUILD_ROOT}/var/named
152mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
153mkdir -p ${RPM_BUILD_ROOT}/var/run/named
154
155make DESTDIR=$RPM_BUILD_ROOT install
156install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
157install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
158install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
159install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
160touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
161gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
162cd $RPM_BUILD_ROOT%{_mandir}
163tar xjf %{SOURCE1}
164# newer version is contained in source
165rm -f man5/named.conf.5.gz
166mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
167cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
168
169chmod +x %{buildroot}%{_libdir}/*.so.*
170
171%pre
172if [ "$1" -eq 1 ]; then
173  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
174  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
175fi;
176:;
177
178%post
179/sbin/ldconfig
180/sbin/chkconfig --add named
181if [ "$1" -eq 1 ]; then
182  if [ ! -e /etc/rndc.key ]; then
183    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
184  fi
185  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
186  # rndc.key has to have correct perms and ownership, CVE-2007-6283
187  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
188  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
189
190  # Check DNSSEC settings if this is a fresh install
191  if [ -r /etc/sysconfig/dnssec ]; then
192    . /etc/sysconfig/dnssec
193    [ -x /usr/sbin/dnssec-configure ] && \
194      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
195        /dev/null 2>&1
196  fi;
197fi
198:;
199
200%preun
201if [ "$1" -eq 0 ]; then
202   /sbin/service named stop >/dev/null 2>&1 || :
203   /sbin/chkconfig --del named ||:
204fi
205exit 0
206
207
208%postun
209if [ "$1" -ge 1 ]; then
210        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
211fi
212/sbin/ldconfig
213
214%triggerpostun -- bind < 8.2.2_P5-15
215/sbin/chkconfig --add named
216/sbin/ldconfig
217
218%clean
219rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
220
221
222%post libs
223/sbin/ldconfig
224
225%postun libs
226/sbin/ldconfig
227
228
229%files
230%defattr(-,root,root)
231%doc CHANGES README
232%doc doc/arm doc/draft doc/rfc doc/misc
233%config(noreplace) %{_sysconfdir}/logrotate.d/named
234%config %{_sysconfdir}/rc.d/init.d/named
235%config(noreplace) %{_sysconfdir}/sysconfig/named
236%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
237%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
238%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
239
240%{_sbindir}/dnssec*
241%{_sbindir}/lwresd
242%{_sbindir}/named
243%{_sbindir}/named-bootconf
244%{_sbindir}/named-check*
245%{_sbindir}/named-compilezone
246%{_sbindir}/rndc*
247%{_sbindir}/dns-keygen
248%{_sbindir}/arpaname
249%{_sbindir}/ddns-confgen
250%{_sbindir}/genrandom
251%{_sbindir}/isc-hmac-fixup
252%{_sbindir}/named-journalprint
253%{_sbindir}/nsec3hash
254
255%{_mandir}/man1/arpaname.1*
256%{_mandir}/man5/resolv.conf.5*
257%{_mandir}/man5/named.conf.5*
258%{_mandir}/man5/rndc.conf.5*
259%{_mandir}/man8/rndc.8*
260%{_mandir}/man8/named.8*
261%{_mandir}/man8/lwresd.8*
262%{_mandir}/man8/dnssec*.8*
263%{_mandir}/man8/named-checkconf.8*
264%{_mandir}/man8/named-checkzone.8*
265%{_mandir}/man8/named-compilezone.8*
266%{_mandir}/man8/rndc-confgen.8*
267%{_mandir}/man8/ddns-confgen.8*
268%{_mandir}/man8/genrandom.8*
269%{_mandir}/man8/isc-hmac-fixup.8*
270%{_mandir}/man8/named-journalprint.8*
271%{_mandir}/man8/nsec3hash.8*
272
273%attr(-,named,named) %dir %{_var}/named
274%attr(-,named,named) %dir %{_var}/run/named
275     
276
277%files libs
278%defattr(-,root,root)
279%{_libdir}/*.so.*
280
281%files utils
282%defattr(-,root,root)
283%{_bindir}/dig
284%{_bindir}/host
285%{_bindir}/nslookup
286%{_bindir}/nsupdate
287%{_mandir}/man1/host.1*
288%{_mandir}/man1/nsupdate.1*
289%{_mandir}/man1/dig.1*
290%{_mandir}/man5/resolver.5*
291%{_mandir}/man1/nslookup.1*
292%{_mandir}/man8/nslookup.8*
293
294
295%files devel
296%defattr(-,root,root)
297%{_libdir}/*.so
298# %{_libdir}/*.la
299%{_libdir}/*.a
300%{_includedir}/*
301%{_mandir}/man3/*
302%{_mandir}/man1/isc-config.sh.1*
303%{_bindir}/isc-config.sh
304
305%changelog
306* Mon Aug  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.9.7.P3-5vl6
307- added Patch140 to fix CVE-2016-2775.
308
309* Fri Mar 11 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P3-4vl6
310- add Patch120 for fix CVE-2016-1285
311- add Patch130 for fix CVE-2016-1286
312
313* Wed Jan 20 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P3-3vl6
314- add patch110 for fix CVE-2015-8704
315
316* Wed Dec 16 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P3-2vl6
317- add patch100 for fix CVE-2015-8000
318
319* Thu Sep  3 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P3-1vl6
320- new upstream release with secrity fix (CVE-2015-5722,5986)
321
322* Wed Jul 29 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P2-1vl6
323- new upstream release with secrity fix (CVE-2015-5477) 
324
325* Sat Jul 11 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P1-1vl6
326- new upstream release with secrity fix (CVE-2015-4620)
327
328* Thu Feb 19 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.6.P2-1vl6
329- new upstream release with secrity fix (CVE-2015-1349)
330- add BR: readline-devel
331
332* Sun Dec 21 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.6.P1-2vl6
333- rebuilt
334
335* Wed Dec 10 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.6.P1-1vl6
336- new upstream release with secrity fix (CVE-2014-8500) 
337
338* Sun May 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.5-1vl6
339- 9.9.x for Vine6.x
340
341* Tue Jan 14 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
342- 9.6.ESV.R10.P2-1
343- new upstream release with secrity fix (CVE-2014-0591)
344
345* Wed Oct 10 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R8-1
346- new upstream release with secrity fix (CVE-2012-5166)
347
348* Thu Sep 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R7.P3-1
349- new upstream release with secrity fix (CVE-2012-4244)
350
351* Wed Jul 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.ESV.R7.P2-1
352- new upstream release with secrity fix (CVE-2012-3817)
353
354* Tue Jun  5 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R7.P1-1
355- new upstream release with security fix (CVE-2012-1667)
356
357* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R5.P1-1
358- new upstream release with security fix (CVE-2011-4313)
359
360* Wed Jul  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R4.P3-1
361- new upstream release with security fix (CVE-2011-2464)
362- use hoge(pre) tags instead of old hogepre tags
363
364* Sat May 28 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R4.P1-1
365- new upstream release with security fix (CVE-2011-1910)
366
367* Thu Mar 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.6.ESV.R4-1
368- new upstream release
369
370* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R2-4
371- rebuild with openssl-1.0.0c
372
373* Fri Jan 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R2-3
374- rebuild package
375
376* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-2
377- change spec filename bind9-vl -> bind-vl
378
379* Thu Oct  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-1
380- new upstream ESV release
381- add BR: libxml2-devel libcap-devel
382
383* Wed Aug 18 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-2
384- add Conflicts bind-current
385
386* Tue Aug 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-1
387- new upstream ESV release
388- add epoch 1 to upgrade from exist bind package
389
390* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
391- add man1/isc-config.sh.1 into devel file list
392
393* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
394- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
395
396* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
397- new upstream release with security fix (CVE-2009-4022)
398
399* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
400- new upstream release with security fix
401
402* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
403- new upstream release
404- clean up %%post/%%pre scriptlet
405  - create named user and group in %%pre
406  - don't remove named user/group in %%preun
407  - use rndc-confgen to create rndc.key
408
409* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
410- new upstream release
411- drop patch0 and patch14, merged in upstream
412
413* Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
414- new upstream release with security fix
415
416* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
417- new upstream release with security fix
418- new versioning policy
419
420* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
421- new upstream release with security fix
422
423* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
424- new upstream release
425- build with new openssl/toolchain
426
427* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
428- new upstream release with security fix
429
430* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
431- new upstream release
432
433* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
434- add Prereq sed
435
436* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
437- new upstream release for security fix (CVE-2006-4095,4096)
438
439* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
440- separate -libs package
441- remove old named.conf.5.gz
442  - newer version is contained in source
443
444* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
445- add bsdcompat patch (Patch4)
446- add fix_h_errno patch from FC
447  - h_errno not being accessed / set correctly in libbind
448
449* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
450- new upstream release
451
452* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
453- added PreReq to bind-utils (see: [VineSeed:09555])
454
455* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
456- new upstream release
457
458* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
459- fix /etc/init.d/named to use rndc
460
461* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
462- rebuild to remove unneeded dependancy
463
464* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
465- new upstream release
466
467* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
468- new upstream release
469
470* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
471- fix dependancies.
472
473* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
474- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
475- change package name to bind for VineSeed.
476- use more macros.
477
478* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
479- fixed some macros
480- add conflicts: to bind-* in bind9-devel and bind9-utils
481- add provides: bind = %%{version}
482
483* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
484- use %%configure macros
485
486* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
487- fixed inconsistent dependency
488
489* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
490- updated to 9.2.2rc1
491
492* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
493- updated to bind9(9.2.1), test packages ;)
494        -- based on Rawhide's bind-9.2.0-8
495        -- changed name bind9
496        -- added Conflicts: bind
497
498* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
499- release 8.3.1 includes security fixes
500
501* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
502- Upgraded to current stable release 8.3.0
503
504* Mon Oct  8 2001 <zn@mbf.nifty.com>
505- 8.2.5-0vl0: Upgraded to new upstream version.
506
507* Thu May 24 2001 <sagami@vinelinux.org>
508- 8.2.4-0vl1: eliminate CVS related files from %%doc
509
510* Thu May 17 2001 <sagami@vinelinux.org>
511- 8.2.4-0vl0
512
513* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
514- 8.2.3-1vl2
515- built on VineSeed
516
517* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
518- add doc/old
519- build for Vine 2.1
520
521* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
522- 8.2.3, fixes several security problems
523
524* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
525- static libraries may be used in shared objects. Build with -fPIC on ia64
526
527* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
528- 8.2.2-P7 (fixes Bug #20546)
529
530* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
531- condrestart fixes
532
533* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
534- change the init script to take condrestart, not cond-restart
535- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
536  the %pre and %post scripts
537
538* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
539- Don't prereq /etc/init.d
540
541* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
542- move initscript back
543
544* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
545- automatic rebuild
546
547* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
548- add "exit 0" for uninstall case
549
550* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
551- add prereq init.d and cleanup install section
552
553* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
554- fix the init script
555
556* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
557- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
558
559* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
560- Fix up the initscript (Bug #13033)
561- Fix build with current glibc (Bug #12755)
562- /etc/rc.d/init.d -> /etc/init.d
563- use %%{_mandir} rather than /usr/share/man
564
565* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
566- fix conflict with man-pages
567- remove compatibilty chkconfig links
568- initscript munging
569
570* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
571- modify logrotate setup to use PID file
572- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
573- actually bump the release this time
574
575* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
576- FHS compliance
577
578* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
579- clean up restart patch
580
581* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
582- provide /var/named (fix for bugs #9847, #10205)
583- preserve args when restarted via ndc(8) (bug #10227)
584- make resolv.conf(5) a link to resolver(5) (bug #10245)
585- fix SYSTYPE bug in all makefiles
586- move creation of named user from %%post into %%pre
587
588* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
589- Fix TTL (patch from ISC, Bug #9820)
590
591* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
592- fix typo in spec (it's %post, without a leading blank) introduced in -6
593- change SYSTYPE to linux
594
595* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
596- pick a standard < 100 uid/gid for named
597
598* Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
599- Pass named a '-u named' parameter by default, and add/remove user.
600
601* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
602- fix host mx bug (Bug #9021)
603
604* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
605- rebuild to fix dependencies
606- man pages are compressed
607
608* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
609- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
610
611* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
612- Fix up location of named-bootconf.pl and make it executable
613  (Bug #8028)
614- bind-devel requires bind
615
616* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
617- update to 8.2.2-P5
618
619* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
620- update to 8.2.2-P3
621
622* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
623- add patch to stop a cache only server from complaining about lame servers
624  on every request.
625
626* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
627- use real stop and start in named.init for restart, not ndc restart, it has
628  problems when named has changed during a package update... (# 4890)
629
630* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
631- chkconfig --del in %preun, not %postun
632
633* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
634- initscript munging
635
636* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
637- fix installed chkconfig links to match init file
638
639* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
640- conflict with new (in man-1.24) man pages (#3876,#3877).
641
642* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
643- fix named.logrotate (wrong %SOURCE)
644
645* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
646- update to 8.2.1.
647- add named.logrotate (#3571).
648- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
649- vet file list.
650
651* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
652- don't run by default
653
654* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
655- nslookup fixes (#2463).
656- missing files (#3152).
657
658* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
659- nslookup patched:
660  to count numRecords properly
661  to fix subsequent calls to ls -d
662  to parse "view" and "finger" commands properly
663  the view hack updated for bind-8 (using sed)
664
665* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
666- add ISC patch
667- add quick hack to make host not crash
668- add more docs
669
670* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
671- add probing information in the init file to keep linuxconf happy
672- dont strip libbind
673
674* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
675- auto rebuild in the new build environment (release 3)
676
677* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
678- removed 'done' output at named shutdown.
679
680* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
681- version 8.2
682
683* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
684- patch to use the __FDS_BITS macro
685- build for glibc 2.1
686
687* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
688- change named.restart to /usr/sbin/ndc restart
689
690* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
691- install man pages correctly.
692- change K10named to K45named.
693
694* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
695- don't start if /etc/named.conf doesn't exist.
696
697* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
698- autmagically create /etc/named.conf from /etc/named.boot in %post
699- remove echo in %post
700
701* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
702- merge in 5.1 mods
703
704* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
705- Several essential modifications to build and install correctly.
706- Modified 'ndc' to avoid deprecated use of '-'
707
708* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
709- Used buildroot
710- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
711  on Redhat 5.0 instead of <nlist.h>
712
Note: See TracBrowser for help on using the repository browser.