source: projects/specs/branches/6/b/bind/bind-vl.spec @ 10062

Revision 10062, 22.4 KB checked in by iwamoto, 8 years ago (diff)

bind: fix CVE-2016-1285,1286

Line 
1%define _localstatedir /var
2
3%define pversion 9.9.7.P3
4%define sversion 9.9.7-P3
5%define bind_epoch 1
6
7%define bind_uid  25
8%define bind_gid  25
9
10Summary: A DNS (Domain Name System) server.
11Summary(ja): DNS (Domain Name System) サーバ
12Name: bind
13Version: %{pversion}
14Release: 4%{?_dist_release}
15License: distributable
16Group: System Environment/Daemons
17Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{name}-%{sversion}.tar.gz
18Source1: bind-manpages.tar.bz2
19Source2: named.sysconfig
20Source3: named.init
21Source4: named.logrotate
22Source5: keygen.c
23URL: http://www.isc.org/bind.html
24
25Patch1: bind-9.3.3rc2-rndckey.patch
26
27Patch100: bind-9.9.7-P3_CVE-2015-8000.patch
28Patch110: bind-9.9.x_CVE-2015-8704.patch
29Patch120: bind-9.9.x_CVE-2016-1285.patch
30Patch130: bind-9.9.7-P3_CVE-2016-1286.patch
31
32Buildroot: %{_tmppath}/%{name}-%{version}-root
33BuildRequires: openssl-devel glibc-devel libtool readline-devel
34BuildRequires: libxml2-devel libcap-devel
35Requires(pre): chkconfig, sh-utils, textutils, fileutils, shadow-utils, perl, sed
36Requires(pre): bind-utils = %{bind_epoch}:%{version}-%{release}
37Requires(pre): shadow-utils
38Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
39Requires(post): bind-utils = %{bind_epoch}:%{version}-%{release}
40Requires(post): coreutils, chkconfig
41Requires(preun): initscripts, chkconfig
42Conflicts: bind9 <= 9.2.1-0vl5, bind-current
43Obsoletes: bind9 <= 9.2.1-0vl5
44Epoch: %{bind_epoch}
45
46Vendor: Project Vine
47Distribution: Vine Linux
48
49%description
50BIND (Berkeley Internet Name Domain) is an implementation of the DNS
51(Domain Name System) protocols. BIND includes a DNS server (named),
52which resolves host names to IP addresses, and a resolver library
53(routines for applications to use when interfacing with DNS).  A DNS
54server allows clients to name resources or objects and share the
55information with other network machines.  The named DNS server can be
56used on workstations as a caching name server, but is generally only
57needed on one machine for an entire network.  Note that the
58configuration files for making BIND act as a simple caching nameserver
59are included in the caching-nameserver package. 
60
61Install the bind package if you need a DNS server for your network.  If
62you want bind to act a caching name server, you will also need to install
63the caching-nameserver package.
64
65
66%package libs
67Summary: Libraries used by various DNS packages
68Group: System Environment/Libraries
69Conflicts: bind-current-libs
70
71%description libs
72Contains libraries used by both the bind server package as well as the utils packages.
73
74
75%package utils
76Summary: Utilities for querying DNS name servers.
77Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
78Group: Applications/System
79Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
80Conflicts: bind9-utils <= 9.2.1-0vl5, bind-current-utils
81Obsoletes: bind9-utils <= 9.2.1-0vl5
82
83
84%description utils
85Bind-utils contains a collection of utilities for querying DNS (Domain
86Name Service) name servers to find out information about Internet hosts.
87These tools will provide you with the IP addresses for given host names,
88as well as other information about registered domains and network
89addresses.
90
91You should install bind-utils if you need to get information from DNS name
92servers.
93
94
95%package devel
96Summary: Include files and libraries needed for bind DNS development.
97Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
98Group: Development/Libraries
99Requires: bind = %{bind_epoch}:%{version}-%{release}
100Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
101Conflicts: bind9-devel <= 9.2.1-0vl5, bind-current-devel
102Obsoletes: bind9-devel <= 9.2.1-0vl5
103
104
105%description devel
106The bind-devel package contains all the include files and the
107library required for DNS (Domain Name Service) development for
108BIND versions 9.x.x.
109
110You should install bind-devel if you want to develop bind DNS
111applications. If you install bind-devel, you'll also need to install
112bind.
113#'
114
115%prep
116%setup -n bind-%{sversion} -q
117%patch1 -p1 -b .key
118
119%patch100 -p1 -b .CVE-2015-8000
120%patch110 -p1 -b .CVE-2015-8704
121%patch120 -p1 -b .CVE-2016-1285
122%patch130 -p1 -b .CVE-2016-1286
123
124perl -pi -e 's/^(SUBDIRS =.+)dlzexternal(.+)$/\1\2/' bin/tests/system/Makefile.in
125
126%build
127libtoolize --copy --force
128aclocal
129autoconf
130# %configure --with-libtool --with-openssl=/usr --enable-threads
131%configure \
132  --with-libtool \
133  --with-openssl=/usr \
134  --disable-openssl-version-ceck \
135  --enable-threads \
136  --enable-ipv6 \
137  --with-pic \
138  --with-dlz-dlopen \
139  --enable-filter-aaaa \
140  --enable-fixed-rrset
141make %{?_smp_mflags}
142
143%install
144rm -rf $RPM_BUILD_ROOT
145mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
146mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
147mkdir -p ${RPM_BUILD_ROOT}/var/named
148mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
149mkdir -p ${RPM_BUILD_ROOT}/var/run/named
150
151make DESTDIR=$RPM_BUILD_ROOT install
152install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
153install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
154install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
155install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
156touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
157gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
158cd $RPM_BUILD_ROOT%{_mandir}
159tar xjf %{SOURCE1}
160# newer version is contained in source
161rm -f man5/named.conf.5.gz
162mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
163cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
164
165chmod +x %{buildroot}%{_libdir}/*.so.*
166
167%pre
168if [ "$1" -eq 1 ]; then
169  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
170  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
171fi;
172:;
173
174%post
175/sbin/ldconfig
176/sbin/chkconfig --add named
177if [ "$1" -eq 1 ]; then
178  if [ ! -e /etc/rndc.key ]; then
179    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
180  fi
181  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
182  # rndc.key has to have correct perms and ownership, CVE-2007-6283
183  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
184  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
185
186  # Check DNSSEC settings if this is a fresh install
187  if [ -r /etc/sysconfig/dnssec ]; then
188    . /etc/sysconfig/dnssec
189    [ -x /usr/sbin/dnssec-configure ] && \
190      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
191        /dev/null 2>&1
192  fi;
193fi
194:;
195
196%preun
197if [ "$1" -eq 0 ]; then
198   /sbin/service named stop >/dev/null 2>&1 || :
199   /sbin/chkconfig --del named ||:
200fi
201exit 0
202
203
204%postun
205if [ "$1" -ge 1 ]; then
206        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
207fi
208/sbin/ldconfig
209
210%triggerpostun -- bind < 8.2.2_P5-15
211/sbin/chkconfig --add named
212/sbin/ldconfig
213
214%clean
215rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
216
217
218%post libs
219/sbin/ldconfig
220
221%postun libs
222/sbin/ldconfig
223
224
225%files
226%defattr(-,root,root)
227%doc CHANGES README
228%doc doc/arm doc/draft doc/rfc doc/misc
229%config(noreplace) %{_sysconfdir}/logrotate.d/named
230%config %{_sysconfdir}/rc.d/init.d/named
231%config(noreplace) %{_sysconfdir}/sysconfig/named
232%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
233%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
234%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
235
236%{_sbindir}/dnssec*
237%{_sbindir}/lwresd
238%{_sbindir}/named
239%{_sbindir}/named-bootconf
240%{_sbindir}/named-check*
241%{_sbindir}/named-compilezone
242%{_sbindir}/rndc*
243%{_sbindir}/dns-keygen
244%{_sbindir}/arpaname
245%{_sbindir}/ddns-confgen
246%{_sbindir}/genrandom
247%{_sbindir}/isc-hmac-fixup
248%{_sbindir}/named-journalprint
249%{_sbindir}/nsec3hash
250
251%{_mandir}/man1/arpaname.1*
252%{_mandir}/man5/resolv.conf.5*
253%{_mandir}/man5/named.conf.5*
254%{_mandir}/man5/rndc.conf.5*
255%{_mandir}/man8/rndc.8*
256%{_mandir}/man8/named.8*
257%{_mandir}/man8/lwresd.8*
258%{_mandir}/man8/dnssec*.8*
259%{_mandir}/man8/named-checkconf.8*
260%{_mandir}/man8/named-checkzone.8*
261%{_mandir}/man8/named-compilezone.8*
262%{_mandir}/man8/rndc-confgen.8*
263%{_mandir}/man8/ddns-confgen.8*
264%{_mandir}/man8/genrandom.8*
265%{_mandir}/man8/isc-hmac-fixup.8*
266%{_mandir}/man8/named-journalprint.8*
267%{_mandir}/man8/nsec3hash.8*
268
269%attr(-,named,named) %dir %{_var}/named
270%attr(-,named,named) %dir %{_var}/run/named
271     
272
273%files libs
274%defattr(-,root,root)
275%{_libdir}/*.so.*
276
277%files utils
278%defattr(-,root,root)
279%{_bindir}/dig
280%{_bindir}/host
281%{_bindir}/nslookup
282%{_bindir}/nsupdate
283%{_mandir}/man1/host.1*
284%{_mandir}/man1/nsupdate.1*
285%{_mandir}/man1/dig.1*
286%{_mandir}/man5/resolver.5*
287%{_mandir}/man1/nslookup.1*
288%{_mandir}/man8/nslookup.8*
289
290
291%files devel
292%defattr(-,root,root)
293%{_libdir}/*.so
294# %{_libdir}/*.la
295%{_libdir}/*.a
296%{_includedir}/*
297%{_mandir}/man3/*
298%{_mandir}/man1/isc-config.sh.1*
299%{_bindir}/isc-config.sh
300
301%changelog
302* Fri Mar 11 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P3-4vl6
303- add Patch120 for fix CVE-2016-1285
304- add Patch130 for fix CVE-2016-1286
305
306* Wed Jan 20 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P3-3vl6
307- add patch110 for fix CVE-2015-8704
308
309* Wed Dec 16 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P3-2vl6
310- add patch100 for fix CVE-2015-8000
311
312* Thu Sep  3 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P3-1vl6
313- new upstream release with secrity fix (CVE-2015-5722,5986)
314
315* Wed Jul 29 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P2-1vl6
316- new upstream release with secrity fix (CVE-2015-5477) 
317
318* Sat Jul 11 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P1-1vl6
319- new upstream release with secrity fix (CVE-2015-4620)
320
321* Thu Feb 19 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.6.P2-1vl6
322- new upstream release with secrity fix (CVE-2015-1349)
323- add BR: readline-devel
324
325* Sun Dec 21 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.6.P1-2vl6
326- rebuilt
327
328* Wed Dec 10 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.6.P1-1vl6
329- new upstream release with secrity fix (CVE-2014-8500) 
330
331* Sun May 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.5-1vl6
332- 9.9.x for Vine6.x
333
334* Tue Jan 14 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
335- 9.6.ESV.R10.P2-1
336- new upstream release with secrity fix (CVE-2014-0591)
337
338* Wed Oct 10 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R8-1
339- new upstream release with secrity fix (CVE-2012-5166)
340
341* Thu Sep 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R7.P3-1
342- new upstream release with secrity fix (CVE-2012-4244)
343
344* Wed Jul 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.ESV.R7.P2-1
345- new upstream release with secrity fix (CVE-2012-3817)
346
347* Tue Jun  5 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R7.P1-1
348- new upstream release with security fix (CVE-2012-1667)
349
350* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R5.P1-1
351- new upstream release with security fix (CVE-2011-4313)
352
353* Wed Jul  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R4.P3-1
354- new upstream release with security fix (CVE-2011-2464)
355- use hoge(pre) tags instead of old hogepre tags
356
357* Sat May 28 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R4.P1-1
358- new upstream release with security fix (CVE-2011-1910)
359
360* Thu Mar 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.6.ESV.R4-1
361- new upstream release
362
363* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R2-4
364- rebuild with openssl-1.0.0c
365
366* Fri Jan 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R2-3
367- rebuild package
368
369* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-2
370- change spec filename bind9-vl -> bind-vl
371
372* Thu Oct  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-1
373- new upstream ESV release
374- add BR: libxml2-devel libcap-devel
375
376* Wed Aug 18 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-2
377- add Conflicts bind-current
378
379* Tue Aug 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-1
380- new upstream ESV release
381- add epoch 1 to upgrade from exist bind package
382
383* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
384- add man1/isc-config.sh.1 into devel file list
385
386* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
387- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
388
389* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
390- new upstream release with security fix (CVE-2009-4022)
391
392* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
393- new upstream release with security fix
394
395* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
396- new upstream release
397- clean up %%post/%%pre scriptlet
398  - create named user and group in %%pre
399  - don't remove named user/group in %%preun
400  - use rndc-confgen to create rndc.key
401
402* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
403- new upstream release
404- drop patch0 and patch14, merged in upstream
405
406* Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
407- new upstream release with security fix
408
409* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
410- new upstream release with security fix
411- new versioning policy
412
413* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
414- new upstream release with security fix
415
416* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
417- new upstream release
418- build with new openssl/toolchain
419
420* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
421- new upstream release with security fix
422
423* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
424- new upstream release
425
426* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
427- add Prereq sed
428
429* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
430- new upstream release for security fix (CVE-2006-4095,4096)
431
432* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
433- separate -libs package
434- remove old named.conf.5.gz
435  - newer version is contained in source
436
437* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
438- add bsdcompat patch (Patch4)
439- add fix_h_errno patch from FC
440  - h_errno not being accessed / set correctly in libbind
441
442* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
443- new upstream release
444
445* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
446- added PreReq to bind-utils (see: [VineSeed:09555])
447
448* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
449- new upstream release
450
451* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
452- fix /etc/init.d/named to use rndc
453
454* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
455- rebuild to remove unneeded dependancy
456
457* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
458- new upstream release
459
460* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
461- new upstream release
462
463* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
464- fix dependancies.
465
466* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
467- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
468- change package name to bind for VineSeed.
469- use more macros.
470
471* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
472- fixed some macros
473- add conflicts: to bind-* in bind9-devel and bind9-utils
474- add provides: bind = %%{version}
475
476* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
477- use %%configure macros
478
479* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
480- fixed inconsistent dependency
481
482* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
483- updated to 9.2.2rc1
484
485* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
486- updated to bind9(9.2.1), test packages ;)
487        -- based on Rawhide's bind-9.2.0-8
488        -- changed name bind9
489        -- added Conflicts: bind
490
491* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
492- release 8.3.1 includes security fixes
493
494* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
495- Upgraded to current stable release 8.3.0
496
497* Mon Oct  8 2001 <zn@mbf.nifty.com>
498- 8.2.5-0vl0: Upgraded to new upstream version.
499
500* Thu May 24 2001 <sagami@vinelinux.org>
501- 8.2.4-0vl1: eliminate CVS related files from %%doc
502
503* Thu May 17 2001 <sagami@vinelinux.org>
504- 8.2.4-0vl0
505
506* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
507- 8.2.3-1vl2
508- built on VineSeed
509
510* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
511- add doc/old
512- build for Vine 2.1
513
514* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
515- 8.2.3, fixes several security problems
516
517* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
518- static libraries may be used in shared objects. Build with -fPIC on ia64
519
520* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
521- 8.2.2-P7 (fixes Bug #20546)
522
523* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
524- condrestart fixes
525
526* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
527- change the init script to take condrestart, not cond-restart
528- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
529  the %pre and %post scripts
530
531* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
532- Don't prereq /etc/init.d
533
534* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
535- move initscript back
536
537* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
538- automatic rebuild
539
540* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
541- add "exit 0" for uninstall case
542
543* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
544- add prereq init.d and cleanup install section
545
546* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
547- fix the init script
548
549* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
550- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
551
552* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
553- Fix up the initscript (Bug #13033)
554- Fix build with current glibc (Bug #12755)
555- /etc/rc.d/init.d -> /etc/init.d
556- use %%{_mandir} rather than /usr/share/man
557
558* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
559- fix conflict with man-pages
560- remove compatibilty chkconfig links
561- initscript munging
562
563* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
564- modify logrotate setup to use PID file
565- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
566- actually bump the release this time
567
568* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
569- FHS compliance
570
571* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
572- clean up restart patch
573
574* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
575- provide /var/named (fix for bugs #9847, #10205)
576- preserve args when restarted via ndc(8) (bug #10227)
577- make resolv.conf(5) a link to resolver(5) (bug #10245)
578- fix SYSTYPE bug in all makefiles
579- move creation of named user from %%post into %%pre
580
581* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
582- Fix TTL (patch from ISC, Bug #9820)
583
584* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
585- fix typo in spec (it's %post, without a leading blank) introduced in -6
586- change SYSTYPE to linux
587
588* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
589- pick a standard < 100 uid/gid for named
590
591* Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
592- Pass named a '-u named' parameter by default, and add/remove user.
593
594* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
595- fix host mx bug (Bug #9021)
596
597* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
598- rebuild to fix dependencies
599- man pages are compressed
600
601* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
602- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
603
604* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
605- Fix up location of named-bootconf.pl and make it executable
606  (Bug #8028)
607- bind-devel requires bind
608
609* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
610- update to 8.2.2-P5
611
612* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
613- update to 8.2.2-P3
614
615* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
616- add patch to stop a cache only server from complaining about lame servers
617  on every request.
618
619* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
620- use real stop and start in named.init for restart, not ndc restart, it has
621  problems when named has changed during a package update... (# 4890)
622
623* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
624- chkconfig --del in %preun, not %postun
625
626* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
627- initscript munging
628
629* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
630- fix installed chkconfig links to match init file
631
632* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
633- conflict with new (in man-1.24) man pages (#3876,#3877).
634
635* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
636- fix named.logrotate (wrong %SOURCE)
637
638* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
639- update to 8.2.1.
640- add named.logrotate (#3571).
641- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
642- vet file list.
643
644* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
645- don't run by default
646
647* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
648- nslookup fixes (#2463).
649- missing files (#3152).
650
651* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
652- nslookup patched:
653  to count numRecords properly
654  to fix subsequent calls to ls -d
655  to parse "view" and "finger" commands properly
656  the view hack updated for bind-8 (using sed)
657
658* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
659- add ISC patch
660- add quick hack to make host not crash
661- add more docs
662
663* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
664- add probing information in the init file to keep linuxconf happy
665- dont strip libbind
666
667* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
668- auto rebuild in the new build environment (release 3)
669
670* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
671- removed 'done' output at named shutdown.
672
673* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
674- version 8.2
675
676* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
677- patch to use the __FDS_BITS macro
678- build for glibc 2.1
679
680* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
681- change named.restart to /usr/sbin/ndc restart
682
683* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
684- install man pages correctly.
685- change K10named to K45named.
686
687* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
688- don't start if /etc/named.conf doesn't exist.
689
690* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
691- autmagically create /etc/named.conf from /etc/named.boot in %post
692- remove echo in %post
693
694* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
695- merge in 5.1 mods
696
697* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
698- Several essential modifications to build and install correctly.
699- Modified 'ndc' to avoid deprecated use of '-'
700
701* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
702- Used buildroot
703- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
704  on Redhat 5.0 instead of <nlist.h>
705
Note: See TracBrowser for help on using the repository browser.