source: projects/specs/branches/6/b/bind/bind-vl.spec @ 9870

Revision 9870, 22.0 KB checked in by iwamoto, 9 years ago (diff)

bind: fix CVE-2015-8000

Line 
1%define _localstatedir /var
2
3%define pversion 9.9.7.P3
4%define sversion 9.9.7-P3
5%define bind_epoch 1
6
7%define bind_uid  25
8%define bind_gid  25
9
10Summary: A DNS (Domain Name System) server.
11Summary(ja): DNS (Domain Name System) サーバ
12Name: bind
13Version: %{pversion}
14Release: 2%{?_dist_release}
15License: distributable
16Group: System Environment/Daemons
17Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{name}-%{sversion}.tar.gz
18Source1: bind-manpages.tar.bz2
19Source2: named.sysconfig
20Source3: named.init
21Source4: named.logrotate
22Source5: keygen.c
23URL: http://www.isc.org/bind.html
24
25Patch1: bind-9.3.3rc2-rndckey.patch
26Patch100: bind-9.9.7-P3_CVE-2015-8000.patch
27
28Buildroot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: openssl-devel glibc-devel libtool readline-devel
30BuildRequires: libxml2-devel libcap-devel
31Requires(pre): chkconfig, sh-utils, textutils, fileutils, shadow-utils, perl, sed
32Requires(pre): bind-utils = %{bind_epoch}:%{version}-%{release}
33Requires(pre): shadow-utils
34Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
35Requires(post): bind-utils = %{bind_epoch}:%{version}-%{release}
36Requires(post): coreutils, chkconfig
37Requires(preun): initscripts, chkconfig
38Conflicts: bind9 <= 9.2.1-0vl5, bind-current
39Obsoletes: bind9 <= 9.2.1-0vl5
40Epoch: %{bind_epoch}
41
42Vendor: Project Vine
43Distribution: Vine Linux
44
45%description
46BIND (Berkeley Internet Name Domain) is an implementation of the DNS
47(Domain Name System) protocols. BIND includes a DNS server (named),
48which resolves host names to IP addresses, and a resolver library
49(routines for applications to use when interfacing with DNS).  A DNS
50server allows clients to name resources or objects and share the
51information with other network machines.  The named DNS server can be
52used on workstations as a caching name server, but is generally only
53needed on one machine for an entire network.  Note that the
54configuration files for making BIND act as a simple caching nameserver
55are included in the caching-nameserver package. 
56
57Install the bind package if you need a DNS server for your network.  If
58you want bind to act a caching name server, you will also need to install
59the caching-nameserver package.
60
61
62%package libs
63Summary: Libraries used by various DNS packages
64Group: System Environment/Libraries
65Conflicts: bind-current-libs
66
67%description libs
68Contains libraries used by both the bind server package as well as the utils packages.
69
70
71%package utils
72Summary: Utilities for querying DNS name servers.
73Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
74Group: Applications/System
75Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
76Conflicts: bind9-utils <= 9.2.1-0vl5, bind-current-utils
77Obsoletes: bind9-utils <= 9.2.1-0vl5
78
79
80%description utils
81Bind-utils contains a collection of utilities for querying DNS (Domain
82Name Service) name servers to find out information about Internet hosts.
83These tools will provide you with the IP addresses for given host names,
84as well as other information about registered domains and network
85addresses.
86
87You should install bind-utils if you need to get information from DNS name
88servers.
89
90
91%package devel
92Summary: Include files and libraries needed for bind DNS development.
93Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
94Group: Development/Libraries
95Requires: bind = %{bind_epoch}:%{version}-%{release}
96Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
97Conflicts: bind9-devel <= 9.2.1-0vl5, bind-current-devel
98Obsoletes: bind9-devel <= 9.2.1-0vl5
99
100
101%description devel
102The bind-devel package contains all the include files and the
103library required for DNS (Domain Name Service) development for
104BIND versions 9.x.x.
105
106You should install bind-devel if you want to develop bind DNS
107applications. If you install bind-devel, you'll also need to install
108bind.
109#'
110
111%prep
112%setup -n bind-%{sversion} -q
113%patch1 -p1 -b .key
114%patch100 -p1 -b .CVE-2015-8000
115
116perl -pi -e 's/^(SUBDIRS =.+)dlzexternal(.+)$/\1\2/' bin/tests/system/Makefile.in
117
118%build
119libtoolize --copy --force
120aclocal
121autoconf
122# %configure --with-libtool --with-openssl=/usr --enable-threads
123%configure \
124  --with-libtool \
125  --with-openssl=/usr \
126  --disable-openssl-version-ceck \
127  --enable-threads \
128  --enable-ipv6 \
129  --with-pic \
130  --with-dlz-dlopen \
131  --enable-filter-aaaa \
132  --enable-fixed-rrset
133make %{?_smp_mflags}
134
135%install
136rm -rf $RPM_BUILD_ROOT
137mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
138mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
139mkdir -p ${RPM_BUILD_ROOT}/var/named
140mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
141mkdir -p ${RPM_BUILD_ROOT}/var/run/named
142
143make DESTDIR=$RPM_BUILD_ROOT install
144install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
145install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
146install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
147install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
148touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
149gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
150cd $RPM_BUILD_ROOT%{_mandir}
151tar xjf %{SOURCE1}
152# newer version is contained in source
153rm -f man5/named.conf.5.gz
154mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
155cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
156
157chmod +x %{buildroot}%{_libdir}/*.so.*
158
159%pre
160if [ "$1" -eq 1 ]; then
161  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
162  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
163fi;
164:;
165
166%post
167/sbin/ldconfig
168/sbin/chkconfig --add named
169if [ "$1" -eq 1 ]; then
170  if [ ! -e /etc/rndc.key ]; then
171    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
172  fi
173  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
174  # rndc.key has to have correct perms and ownership, CVE-2007-6283
175  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
176  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
177
178  # Check DNSSEC settings if this is a fresh install
179  if [ -r /etc/sysconfig/dnssec ]; then
180    . /etc/sysconfig/dnssec
181    [ -x /usr/sbin/dnssec-configure ] && \
182      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
183        /dev/null 2>&1
184  fi;
185fi
186:;
187
188%preun
189if [ "$1" -eq 0 ]; then
190   /sbin/service named stop >/dev/null 2>&1 || :
191   /sbin/chkconfig --del named ||:
192fi
193exit 0
194
195
196%postun
197if [ "$1" -ge 1 ]; then
198        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
199fi
200/sbin/ldconfig
201
202%triggerpostun -- bind < 8.2.2_P5-15
203/sbin/chkconfig --add named
204/sbin/ldconfig
205
206%clean
207rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
208
209
210%post libs
211/sbin/ldconfig
212
213%postun libs
214/sbin/ldconfig
215
216
217%files
218%defattr(-,root,root)
219%doc CHANGES README
220%doc doc/arm doc/draft doc/rfc doc/misc
221%config(noreplace) %{_sysconfdir}/logrotate.d/named
222%config %{_sysconfdir}/rc.d/init.d/named
223%config(noreplace) %{_sysconfdir}/sysconfig/named
224%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
225%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
226%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
227
228%{_sbindir}/dnssec*
229%{_sbindir}/lwresd
230%{_sbindir}/named
231%{_sbindir}/named-bootconf
232%{_sbindir}/named-check*
233%{_sbindir}/named-compilezone
234%{_sbindir}/rndc*
235%{_sbindir}/dns-keygen
236%{_sbindir}/arpaname
237%{_sbindir}/ddns-confgen
238%{_sbindir}/genrandom
239%{_sbindir}/isc-hmac-fixup
240%{_sbindir}/named-journalprint
241%{_sbindir}/nsec3hash
242
243%{_mandir}/man1/arpaname.1*
244%{_mandir}/man5/resolv.conf.5*
245%{_mandir}/man5/named.conf.5*
246%{_mandir}/man5/rndc.conf.5*
247%{_mandir}/man8/rndc.8*
248%{_mandir}/man8/named.8*
249%{_mandir}/man8/lwresd.8*
250%{_mandir}/man8/dnssec*.8*
251%{_mandir}/man8/named-checkconf.8*
252%{_mandir}/man8/named-checkzone.8*
253%{_mandir}/man8/named-compilezone.8*
254%{_mandir}/man8/rndc-confgen.8*
255%{_mandir}/man8/ddns-confgen.8*
256%{_mandir}/man8/genrandom.8*
257%{_mandir}/man8/isc-hmac-fixup.8*
258%{_mandir}/man8/named-journalprint.8*
259%{_mandir}/man8/nsec3hash.8*
260
261%attr(-,named,named) %dir %{_var}/named
262%attr(-,named,named) %dir %{_var}/run/named
263     
264
265%files libs
266%defattr(-,root,root)
267%{_libdir}/*.so.*
268
269%files utils
270%defattr(-,root,root)
271%{_bindir}/dig
272%{_bindir}/host
273%{_bindir}/nslookup
274%{_bindir}/nsupdate
275%{_mandir}/man1/host.1*
276%{_mandir}/man1/nsupdate.1*
277%{_mandir}/man1/dig.1*
278%{_mandir}/man5/resolver.5*
279%{_mandir}/man1/nslookup.1*
280%{_mandir}/man8/nslookup.8*
281
282
283%files devel
284%defattr(-,root,root)
285%{_libdir}/*.so
286# %{_libdir}/*.la
287%{_libdir}/*.a
288%{_includedir}/*
289%{_mandir}/man3/*
290%{_mandir}/man1/isc-config.sh.1*
291%{_bindir}/isc-config.sh
292
293%changelog
294* Wed Dec 16 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P3-2vl6
295- add patch100 for fix CVE-2015-8000
296
297* Thu Sep  3 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P3-1vl6
298- new upstream release with secrity fix (CVE-2015-5722,5986)
299
300* Wed Jul 29 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P2-1vl6
301- new upstream release with secrity fix (CVE-2015-5477) 
302
303* Sat Jul 11 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P1-1vl6
304- new upstream release with secrity fix (CVE-2015-4620)
305
306* Thu Feb 19 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.6.P2-1vl6
307- new upstream release with secrity fix (CVE-2015-1349)
308- add BR: readline-devel
309
310* Sun Dec 21 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.6.P1-2vl6
311- rebuilt
312
313* Wed Dec 10 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.6.P1-1vl6
314- new upstream release with secrity fix (CVE-2014-8500) 
315
316* Sun May 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.5-1vl6
317- 9.9.x for Vine6.x
318
319* Tue Jan 14 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
320- 9.6.ESV.R10.P2-1
321- new upstream release with secrity fix (CVE-2014-0591)
322
323* Wed Oct 10 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R8-1
324- new upstream release with secrity fix (CVE-2012-5166)
325
326* Thu Sep 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R7.P3-1
327- new upstream release with secrity fix (CVE-2012-4244)
328
329* Wed Jul 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.ESV.R7.P2-1
330- new upstream release with secrity fix (CVE-2012-3817)
331
332* Tue Jun  5 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R7.P1-1
333- new upstream release with security fix (CVE-2012-1667)
334
335* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R5.P1-1
336- new upstream release with security fix (CVE-2011-4313)
337
338* Wed Jul  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R4.P3-1
339- new upstream release with security fix (CVE-2011-2464)
340- use hoge(pre) tags instead of old hogepre tags
341
342* Sat May 28 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R4.P1-1
343- new upstream release with security fix (CVE-2011-1910)
344
345* Thu Mar 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.6.ESV.R4-1
346- new upstream release
347
348* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R2-4
349- rebuild with openssl-1.0.0c
350
351* Fri Jan 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R2-3
352- rebuild package
353
354* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-2
355- change spec filename bind9-vl -> bind-vl
356
357* Thu Oct  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-1
358- new upstream ESV release
359- add BR: libxml2-devel libcap-devel
360
361* Wed Aug 18 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-2
362- add Conflicts bind-current
363
364* Tue Aug 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-1
365- new upstream ESV release
366- add epoch 1 to upgrade from exist bind package
367
368* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
369- add man1/isc-config.sh.1 into devel file list
370
371* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
372- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
373
374* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
375- new upstream release with security fix (CVE-2009-4022)
376
377* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
378- new upstream release with security fix
379
380* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
381- new upstream release
382- clean up %%post/%%pre scriptlet
383  - create named user and group in %%pre
384  - don't remove named user/group in %%preun
385  - use rndc-confgen to create rndc.key
386
387* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
388- new upstream release
389- drop patch0 and patch14, merged in upstream
390
391* Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
392- new upstream release with security fix
393
394* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
395- new upstream release with security fix
396- new versioning policy
397
398* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
399- new upstream release with security fix
400
401* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
402- new upstream release
403- build with new openssl/toolchain
404
405* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
406- new upstream release with security fix
407
408* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
409- new upstream release
410
411* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
412- add Prereq sed
413
414* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
415- new upstream release for security fix (CVE-2006-4095,4096)
416
417* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
418- separate -libs package
419- remove old named.conf.5.gz
420  - newer version is contained in source
421
422* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
423- add bsdcompat patch (Patch4)
424- add fix_h_errno patch from FC
425  - h_errno not being accessed / set correctly in libbind
426
427* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
428- new upstream release
429
430* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
431- added PreReq to bind-utils (see: [VineSeed:09555])
432
433* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
434- new upstream release
435
436* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
437- fix /etc/init.d/named to use rndc
438
439* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
440- rebuild to remove unneeded dependancy
441
442* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
443- new upstream release
444
445* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
446- new upstream release
447
448* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
449- fix dependancies.
450
451* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
452- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
453- change package name to bind for VineSeed.
454- use more macros.
455
456* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
457- fixed some macros
458- add conflicts: to bind-* in bind9-devel and bind9-utils
459- add provides: bind = %%{version}
460
461* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
462- use %%configure macros
463
464* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
465- fixed inconsistent dependency
466
467* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
468- updated to 9.2.2rc1
469
470* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
471- updated to bind9(9.2.1), test packages ;)
472        -- based on Rawhide's bind-9.2.0-8
473        -- changed name bind9
474        -- added Conflicts: bind
475
476* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
477- release 8.3.1 includes security fixes
478
479* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
480- Upgraded to current stable release 8.3.0
481
482* Mon Oct  8 2001 <zn@mbf.nifty.com>
483- 8.2.5-0vl0: Upgraded to new upstream version.
484
485* Thu May 24 2001 <sagami@vinelinux.org>
486- 8.2.4-0vl1: eliminate CVS related files from %%doc
487
488* Thu May 17 2001 <sagami@vinelinux.org>
489- 8.2.4-0vl0
490
491* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
492- 8.2.3-1vl2
493- built on VineSeed
494
495* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
496- add doc/old
497- build for Vine 2.1
498
499* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
500- 8.2.3, fixes several security problems
501
502* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
503- static libraries may be used in shared objects. Build with -fPIC on ia64
504
505* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
506- 8.2.2-P7 (fixes Bug #20546)
507
508* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
509- condrestart fixes
510
511* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
512- change the init script to take condrestart, not cond-restart
513- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
514  the %pre and %post scripts
515
516* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
517- Don't prereq /etc/init.d
518
519* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
520- move initscript back
521
522* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
523- automatic rebuild
524
525* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
526- add "exit 0" for uninstall case
527
528* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
529- add prereq init.d and cleanup install section
530
531* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
532- fix the init script
533
534* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
535- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
536
537* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
538- Fix up the initscript (Bug #13033)
539- Fix build with current glibc (Bug #12755)
540- /etc/rc.d/init.d -> /etc/init.d
541- use %%{_mandir} rather than /usr/share/man
542
543* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
544- fix conflict with man-pages
545- remove compatibilty chkconfig links
546- initscript munging
547
548* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
549- modify logrotate setup to use PID file
550- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
551- actually bump the release this time
552
553* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
554- FHS compliance
555
556* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
557- clean up restart patch
558
559* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
560- provide /var/named (fix for bugs #9847, #10205)
561- preserve args when restarted via ndc(8) (bug #10227)
562- make resolv.conf(5) a link to resolver(5) (bug #10245)
563- fix SYSTYPE bug in all makefiles
564- move creation of named user from %%post into %%pre
565
566* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
567- Fix TTL (patch from ISC, Bug #9820)
568
569* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
570- fix typo in spec (it's %post, without a leading blank) introduced in -6
571- change SYSTYPE to linux
572
573* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
574- pick a standard < 100 uid/gid for named
575
576* Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
577- Pass named a '-u named' parameter by default, and add/remove user.
578
579* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
580- fix host mx bug (Bug #9021)
581
582* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
583- rebuild to fix dependencies
584- man pages are compressed
585
586* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
587- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
588
589* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
590- Fix up location of named-bootconf.pl and make it executable
591  (Bug #8028)
592- bind-devel requires bind
593
594* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
595- update to 8.2.2-P5
596
597* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
598- update to 8.2.2-P3
599
600* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
601- add patch to stop a cache only server from complaining about lame servers
602  on every request.
603
604* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
605- use real stop and start in named.init for restart, not ndc restart, it has
606  problems when named has changed during a package update... (# 4890)
607
608* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
609- chkconfig --del in %preun, not %postun
610
611* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
612- initscript munging
613
614* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
615- fix installed chkconfig links to match init file
616
617* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
618- conflict with new (in man-1.24) man pages (#3876,#3877).
619
620* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
621- fix named.logrotate (wrong %SOURCE)
622
623* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
624- update to 8.2.1.
625- add named.logrotate (#3571).
626- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
627- vet file list.
628
629* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
630- don't run by default
631
632* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
633- nslookup fixes (#2463).
634- missing files (#3152).
635
636* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
637- nslookup patched:
638  to count numRecords properly
639  to fix subsequent calls to ls -d
640  to parse "view" and "finger" commands properly
641  the view hack updated for bind-8 (using sed)
642
643* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
644- add ISC patch
645- add quick hack to make host not crash
646- add more docs
647
648* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
649- add probing information in the init file to keep linuxconf happy
650- dont strip libbind
651
652* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
653- auto rebuild in the new build environment (release 3)
654
655* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
656- removed 'done' output at named shutdown.
657
658* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
659- version 8.2
660
661* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
662- patch to use the __FDS_BITS macro
663- build for glibc 2.1
664
665* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
666- change named.restart to /usr/sbin/ndc restart
667
668* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
669- install man pages correctly.
670- change K10named to K45named.
671
672* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
673- don't start if /etc/named.conf doesn't exist.
674
675* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
676- autmagically create /etc/named.conf from /etc/named.boot in %post
677- remove echo in %post
678
679* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
680- merge in 5.1 mods
681
682* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
683- Several essential modifications to build and install correctly.
684- Modified 'ndc' to avoid deprecated use of '-'
685
686* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
687- Used buildroot
688- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
689  on Redhat 5.0 instead of <nlist.h>
690
Note: See TracBrowser for help on using the repository browser.