source: projects/specs/branches/6/a/apache2/apache2-vl.spec @ 5345

Revision 5345, 25.4 KB checked in by iwamoto, 12 years ago (diff)

apache2: fix CVE-2011-4317

Line 
1%define contentdir /var/www
2%define suexec_caller apache
3%define mmn 20051115
4%define pkgname apache2
5
6Summary: Apache HTTP Server
7Name: %{pkgname}
8Version: 2.2.21
9Release: 5%{_dist_release}
10URL: http://httpd.apache.org/
11
12Vendor: Project Vine
13Distribution: Vine Linux
14Packager: daisuke
15
16Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
17Source1: index.html.ja
18Source3: apache2.logrotate
19Source4: apache2.init
20Source5: README.confd
21Source6: vine.png
22Source10: httpd.conf
23Source11: apache-ssl.conf
24Source12: migration.html
25Source13: migration.css
26Source14: mod_ssl-Makefile.crt
27Source15: mod_ssl-Makefile.crl
28# add vine entry to config.layout
29Source100: vine-config.layout
30# man files
31Source101: apache2.8
32Source102: apache2ctl.8
33#Source103: config_vars.mk
34# build/scripts patches
35Patch1: httpd-2.1.10-apctl.patch
36Patch2: httpd-2.2.3-apxs.patch
37Patch3: httpd-2.0.45-deplibs.patch
38Patch4: httpd-2.1.10-disablemods.patch
39# features/functional changes
40Patch21: httpd-2.0.40-xfsz.patch
41Patch22: httpd-2.1.10-pod.patch
42Patch23: httpd-2.0.45-export.patch
43Patch24: httpd-2.0.48-corelimit.patch
44# Bug fixes
45Patch54: httpd-2.2.0-authnoprov.patch
46Patch60: httpd-2.2.3-sslusername.patch
47Patch70: apache2-2.2.21-byterange_fix_1177080.patch
48
49# Security fixes
50# Patch100: httpd-2.2.19_CVE-2011-3192.patch
51# Patch101: httpd-2.2.20_CVE-2011-3192_regression_2.patch
52Patch100: apache2-2.2.21_CVE-2011-3368.patch
53Patch110: apache2-2.2.21_CVE-2011-3607-4415.patch
54Patch120: httpd-2.2.21_CVE-2011-4317.patch
55
56License: Apache Software License
57Group: System Environment/Daemons
58BuildRoot: %{_tmppath}/%{name}-%{version}-root
59BuildRequires: db4-devel, expat-devel
60BuildRequires: findutils, perl, openldap-devel, zlib-devel
61BuildRequires: apr-devel, apr-util-devel
62BuildRequires: pcre-devel, sqlite3-devel
63Requires: mailcap, gawk, file, findutils, apr, apr-util
64Requires(pre): chkconfig, mktemp, fileutils
65Requires(pre): sh-utils, textutils, shadow-utils
66Requires(post): alternatives
67Provides: webserver
68Provides: httpd = %{version}
69Provides: httpd-mmn = %{mmn}
70Obsoletes: apache2-apr, apache2-apr-devel
71
72%description
73Apache is a powerful, full-featured, efficient, and freely-available
74Web server. Apache is also the most popular Web server on the
75Internet.
76
77%package devel
78Group: Development/Libraries
79Summary: Development tools for the Apache HTTP server.
80Requires: libtool, httpd = %{version}
81Requires: apr-devel, apr-util-devel
82
83%description devel
84The httpd-devel package contains the APXS binary and other files
85that you need to build Dynamic Shared Objects (DSOs) for Apache.
86
87If you are installing the Apache HTTP server and you want to be
88able to compile or develop additional modules for Apache, you need
89to install this package.
90
91%package manual
92Group: Applications/Documentation
93Summary: Documentation for the Apache HTTP server.
94
95%description manual
96The httpd-manual package contains the complete manual and
97reference guide for the Apache HTTP server. The information can
98also be found at http://httpd.apache.org/docs/.
99
100%package -n mod_ssl-apache2
101Group: System Environment/Daemons
102Summary: SSL/TLS module for the Apache HTTP server
103Epoch: 1
104BuildRequires: openssl-devel
105Requires(pre): openssl, dev, /bin/cat
106Requires: httpd, make, httpd-mmn = %{mmn}
107
108%description -n mod_ssl-apache2
109The mod_ssl module provides strong cryptography for the Apache Web
110server via the Secure Sockets Layer (SSL) and Transport Layer
111Security (TLS) protocols.
112
113%prep
114%setup -q -n httpd-%{version}
115
116%patch1 -p1 -b .apctl
117%patch2 -p1 -b .apxs
118#patch3 -p1 -b .deplibs
119%patch4 -p1 -b .disablemods
120
121%patch21 -p0 -b .xfsz
122%patch22 -p1 -b .pod
123%patch23 -p1 -b .export
124%patch24 -p1 -b .corelimit
125
126%patch54 -p1 -b .authnoprov
127%patch60 -p1 -b .sslusername
128%patch70 -p4 -b .byterange_fix_1177080
129
130# %patch100 -p1 -b .CVE-2011-3192
131# %patch101 -p1 -b .CVE-2011-3192_regression
132%patch100 -p1 -b .CVE-2011-3368
133%patch110 -p1 -b .CVE-2011-3607-4415
134%patch120 -p1 -b .CVE-2011-4317
135
136# copy across the migration guide and sed it's location into apachectl
137cp $RPM_SOURCE_DIR/migration.{html,css} .
138%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
139        support/apachectl.in
140
141
142# add Vine configure's option to config.layout
143sed -e "s|${prefix}/lib|${prefix}/%{_lib}|" \
144  < $RPM_SOURCE_DIR/vine-config.layout >> config.layout
145
146# regenerate configure scripts
147./buildconf
148
149%build
150# remove bundled apr, apr-util, pcre
151rm -rf srclib/{apr,apr-util,pcre}
152
153#CFLAGS="$RPM_OPT_FLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
154#AP_LIBS="-lssl -lcrypto"
155#export CFLAGS AP_LIBS
156CFLAGS="$RPM_OPT_FLAGS"
157SH_LDFLAGS="-Wl,-z,relro"
158export CFLAGS SH_LDFLAGS
159
160%define mpms worker prefork
161%define prefer_mpm prefork
162
163AP_CONFOPTS="\
164        --prefix=%{_sysconfdir}/apache2 \
165        --exec-prefix=%{_prefix} \
166        --bindir=%{_bindir} \
167        --sbindir=%{_sbindir} \
168        --mandir=%{_mandir} \
169        --libdir=%{_libdir} \
170        --sysconfdir=%{_sysconfdir}/apache2/conf \
171        --includedir=%{_includedir}/apache2 \
172        --libexecdir=%{_libdir}/apache2/modules \
173        --datadir=%{contentdir} \
174        --with-installbuilddir=%{_libdir}/apache2/build \
175        --enable-layout=Vine \
176        --with-program-name=apache2 \
177        --with-ldap \
178        --enable-ldap --enable-authnz-ldap \
179        --enable-mods-shared=all \
180        --enable-cache=shared \
181        --enable-cgi=shared \
182        --enable-cgid=shared \
183        --enable-rewrite=shared \
184        --enable-disk-cache=shared \
185        --enable-file-cache=shared \
186        --enable-mem-cache=shared \
187        --enable-authn-anon --enable-authn-alias \
188        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
189        --enable-suexec --with-suexec \
190        --with-suexec-caller=%{suexec_caller} \
191        --with-suexec-docroot=%{contentdir} \
192        --with-suexec-logfile=%{_localstatedir}/log/apache2/suexec.log \
193        --with-suexec-bin=%{_libdir}/%{pkgname}/suexec \
194        --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
195        --with-pcre \
196        --enable-ssl --with-ssl \
197        --enable-deflate \
198        --enable-proxy --enable-proxy-connect \
199        --enable-proxy-http --enable-proxy-ftp"
200#all  mpm build
201for mpm in %{mpms}; do
202   mkdir mpm-$mpm;
203   cd mpm-$mpm;
204   ../configure $AP_CONFOPTS --with-mpm=$mpm --srcdir=../ ;
205   make %{?_smp_mflags} ;
206#   mv apache2 apache2.$mpm ;
207   cd ../
208done
209
210%install
211rm -rf $RPM_BUILD_ROOT
212
213# Classify ab and logresolve as section 1 commands, as they are in /usr/bin
214cp -p docs/man/ab.8 docs/man/ab.1
215sed -e "1s/logresolve 8/logresolve 1/" \
216  < docs/man/logresolve.8 > docs/man/logresolve.1
217#rm docs/man/logresolve.8
218
219# install mpms binary
220pushd mpm-prefork
221  make DESTDIR=$RPM_BUILD_ROOT install
222  rm -f $RPM_BUILD_ROOT/%{_sbindir}/apache2
223popd
224
225for mpm in %{mpms}; do
226    install -m755 mpm-$mpm/apache2 $RPM_BUILD_ROOT/%{_sbindir}/apache2.$mpm
227done
228
229# install conf file/directory
230mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d
231install -m 644 $RPM_SOURCE_DIR/README.confd \
232   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/README
233install -m 644 $RPM_SOURCE_DIR/apache-ssl.conf \
234   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/ssl.conf
235
236rm $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/*.conf
237install -m 644 $RPM_SOURCE_DIR/httpd.conf \
238   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/httpd.conf
239
240# mod_ssl bits
241for suffix in crl crt csr key prm; do
242   mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${suffix}
243done
244
245# Makefiles for certificate management
246for ext in crt crl; do
247  install -m 644 $RPM_SOURCE_DIR/mod_ssl-Makefile.${ext} \
248        $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${ext}/Makefile.${ext}
249done
250ln -s ../../../usr/share/ssl/certs/Makefile $RPM_BUILD_ROOT/etc/apache2/conf
251
252# for holding mod_dav lock database
253mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav
254
255# create a prototype session cache
256mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl
257touch $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl/scache.{dir,pag,sem}
258
259# move utilities to /usr/bin
260mv $RPM_BUILD_ROOT%{_sbindir}/{ab,htdbm,logresolve,htpasswd,htdigest} \
261   $RPM_BUILD_ROOT%{_bindir}
262
263# Make the MMN accessible to module packages
264echo %{mmn} > $RPM_BUILD_ROOT%{_includedir}/apache2/.mmn
265
266# docroot
267# mkdir $RPM_BUILD_ROOT%{contentdir}/html
268install -m 644 $RPM_SOURCE_DIR/index.html.ja \
269        $RPM_BUILD_ROOT%{contentdir}/error/noindex.html
270rm -r $RPM_BUILD_ROOT%{contentdir}/manual/style
271
272install -m 644 $RPM_SOURCE_DIR/vine.png \
273        $RPM_BUILD_ROOT%{contentdir}/icons
274
275# logs
276# rmdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/logs
277mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/apache2
278
279ln -sf %{_sysconfdir}/%{pkgname}/conf/httpd.conf $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/conf/apache2.conf
280
281
282# symlinks for /etc/apache2
283ln -s ../..%{_localstatedir}/log/apache2 $RPM_BUILD_ROOT/etc/apache2/logs
284ln -s ../..%{_localstatedir}/run $RPM_BUILD_ROOT/etc/apache2/run
285ln -s ../..%{_libdir}/apache2/modules $RPM_BUILD_ROOT/etc/apache2/modules
286ln -s ../..%{_libdir}/apache2/build $RPM_BUILD_ROOT/etc/apache2/build
287
288# install SYSV init stuff
289mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
290install -m755 $RPM_SOURCE_DIR/apache2.init \
291        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
292%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
293        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
294
295# install log rotation stuff
296mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
297install -m644 $RPM_SOURCE_DIR/apache2.logrotate \
298        $RPM_BUILD_ROOT/etc/logrotate.d/apache2
299
300mv $RPM_BUILD_ROOT/%{_sbindir}/apachectl $RPM_BUILD_ROOT/%{_sbindir}/apache2ctl
301
302# fix man page paths
303sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/apache2/conf/httpd.conf|" \
304    -e "s|/usr/local/apache2/conf/mime.types|/etc/mime.types|" \
305    -e "s|/usr/local/apache2/conf/magic|/etc/apache2/conf/magic|" \
306    -e "s|/usr/local/apache2/logs/error_log|/var/log/apache2/error_log|" \
307    -e "s|/usr/local/apache2/logs/access_log|/var/log/apache2/access_log|" \
308    -e "s|/usr/local/apache2/logs/httpd.pid|/var/run/apache2.pid|" \
309    -e "s|/usr/local/apache2|/etc/httpd|" < $RPM_SOURCE_DIR/apache2.8 \
310  > $RPM_BUILD_ROOT%{_mandir}/man8/apache2.8
311
312install -m644 $RPM_SOURCE_DIR/apache2ctl.8 \
313        $RPM_BUILD_ROOT%{_mandir}/man8/apache2ctl.8
314
315# change command name to avoid conflict with apache1 pacjage
316%define cflcmd /usr/bin/htdigest /usr/bin/htpasswd /usr/sbin/rotatelogs
317
318for i in %{cflcmd}; do \
319  echo $i
320  mv $RPM_BUILD_ROOT$i $RPM_BUILD_ROOT$i"2";
321done;
322
323mv $RPM_BUILD_ROOT/%{_sbindir}/apxs $RPM_BUILD_ROOT/%{_bindir}/apxs
324
325%define cflman usr/share/man/man1/dbmmanage.1 usr/share/man/man1/htdigest.1 usr/share/man/man1/htpasswd.1 usr/share/man/man8/rotatelogs.8 usr/share/man/man8/suexec.8 usr/share/man/man8/apxs.8 usr/share/man/man8/httpd.8
326
327(cd $RPM_BUILD_ROOT;
328for i in %{cflman}; do \
329    echo $i | sed -e "s|\.1|2\.1|" -e "s|\.8|2\.8|" |    xargs mv $i ;
330   
331done;
332)
333
334#cp $RPM_SOURCE_DIR/config_vars.mk $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/build/.
335mv $RPM_BUILD_ROOT/%{_sbindir}/suexec $RPM_BUILD_ROOT/%{_libdir}/%{pkgname}/suexec
336
337
338rm -f $RPM_BUILD_ROOT%{_mandir}/man1/ab*
339rm -f $RPM_BUILD_ROOT%{_mandir}/man1/logresolve*
340# conflict with apache 1, so removed...
341rm -f $RPM_BUILD_ROOT%{_mandir}/man8/ab*
342rm -f $RPM_BUILD_ROOT%{_mandir}/man8/logresolve*
343
344# remove unpackaged files
345rm -f $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/mime.types \
346      $RPM_BUILD_ROOT%{_libdir}/*.la \
347      $RPM_BUILD_ROOT%{_libdir}/*.exp \
348      $RPM_BUILD_ROOT%{_libdir}/apache2/modules/*.exp \
349      $RPM_BUILD_ROOT%{_libdir}/apache2/build/config.nice \
350      $RPM_BUILD_ROOT%{_sbindir}/{apache2,checkgid,dbmmanage,envvars*} \
351      $RPM_BUILD_ROOT%{contentdir}/html/* \
352      $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
353
354%pre
355# Add the "apache" user
356/usr/sbin/useradd -c "Apache" -u 48 \
357        -s /sbin/nologin -r -d %{contentdir} apache 2> /dev/null || :
358
359%triggerpostun -- apache < 2.0
360/sbin/chkconfig --add apache2
361
362
363%post
364# Register the httpd service
365for mpm in %{mpms}; do
366  /sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.$mpm 20;
367done
368/sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.%{prefer_mpm} 30
369/sbin/chkconfig --add apache2
370
371%preun
372if [ $1 = 0 ]; then
373        /sbin/service apache2 stop > /dev/null 2>&1
374        /sbin/chkconfig --del apache2
375        for mpm in %{mpms}; do
376          /sbin/update-alternatives --remove apache2 %{_sbindir}/apache2.$mpm;
377        done 
378fi
379
380%postun
381if [ "$1" -ge 1 ]; then
382        /sbin/service apache2 condrestart
383fi
384/sbin/ldconfig
385
386%post -n mod_ssl-apache2
387/sbin/ldconfig ### is this needed?
388umask 077
389
390if [ ! -f %{_sysconfdir}/apache2/conf/ssl.key/server.key ] ; then
391%{_bindir}/openssl genrsa -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime 1024 > %{_sysconfdir}/apache2/conf/ssl.key/server.key 2> /dev/null
392fi
393
394FQDN=`hostname`
395if [ "x${FQDN}" = "x" ]; then
396   FQDN=localhost.localdomain
397fi
398
399if [ ! -f %{_sysconfdir}/apache2/conf/ssl.crt/server.crt ] ; then
400cat << EOF | %{_bindir}/openssl req -new -key %{_sysconfdir}/apache2/conf/ssl.key/server.key -x509 -days 365 -out %{_sysconfdir}/apache2/conf/ssl.crt/server.crt 2>/dev/null
401--
402SomeState
403SomeCity
404SomeOrganization
405SomeOrganizationalUnit
406${FQDN}
407root@${FQDN}
408EOF
409fi
410
411%clean
412rm -rf $RPM_BUILD_ROOT
413
414%files
415%defattr(-,root,root)
416
417%doc ABOUT_APACHE README CHANGES LAYOUT LICENSE
418%doc migration.html migration.css
419
420%dir %{_sysconfdir}/apache2
421%{_sysconfdir}/apache2/modules
422%{_sysconfdir}/apache2/logs
423%{_sysconfdir}/apache2/run
424%dir %{_sysconfdir}/apache2/conf
425%config(noreplace) %{_sysconfdir}/apache2/conf/*.conf
426%config(noreplace) %{_sysconfdir}/apache2/conf/magic
427
428%config %{_sysconfdir}/logrotate.d/apache2
429%config %{_sysconfdir}/rc.d/init.d/apache2
430
431%dir %{_sysconfdir}/apache2/conf.d
432%{_sysconfdir}/apache2/conf.d/README
433
434%dir %{_sysconfdir}/apache2/conf/extra
435%config %{_sysconfdir}/apache2/conf/extra/*
436
437%dir %{_sysconfdir}/apache2/conf/original
438%{_sysconfdir}/apache2/conf/original/*
439
440%{_bindir}/ab
441%{_bindir}/ht*
442%{_bindir}/logresolve
443%{_sbindir}/ht*
444%{_sbindir}/apache2.*
445%{_sbindir}/apache2ctl
446%{_sbindir}/rotatelogs2
447%attr(4510,root,%{suexec_caller}) %{_libdir}/%{pkgname}/suexec
448
449%dir %{_libdir}/apache2
450%dir %{_libdir}/apache2/modules
451# everything but mod_ssl.so:
452%{_libdir}/apache2/modules/mod_[a-r]*.so
453%{_libdir}/apache2/modules/mod_s[petu]*.so
454%{_libdir}/apache2/modules/mod_[t-z]*.so
455
456%dir %{contentdir}
457%dir %{contentdir}/cgi-bin
458%dir %{contentdir}/html
459%dir %{contentdir}/icons
460%dir %{contentdir}/error
461%dir %{contentdir}/error/include
462%{contentdir}/icons/*
463%{contentdir}/error/README
464%{contentdir}/error/noindex.html
465%config(noreplace) %{contentdir}/error/*.var
466%config(noreplace) %{contentdir}/error/include/*.html
467
468%attr(0700,root,root) %dir %{_localstatedir}/log/apache2
469
470%attr(0700,apache,apache) %dir %{_localstatedir}/lib/dav
471
472%{_mandir}/man1/*
473
474%{_mandir}/man8/*
475
476%files manual
477%defattr(-,root,root)
478%{contentdir}/manual
479
480%files -n mod_ssl-apache2
481%defattr(-,root,root)
482%{_libdir}/apache2/modules/mod_ssl.so
483%config(noreplace) %{_sysconfdir}/apache2/conf.d/ssl.conf
484%attr(0700,root,root) %dir %{_sysconfdir}/apache2/conf/ssl.*
485%config %{_sysconfdir}/apache2/conf/Makefile
486%config %{_sysconfdir}/apache2/conf/ssl.*/*
487%attr(0700,apache,root) %dir %{_localstatedir}/cache/mod_ssl
488%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.dir
489%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.pag
490%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.sem
491
492%files devel
493%defattr(-,root,root)
494%{_includedir}/apache2
495%{_sysconfdir}/apache2/build
496%{_bindir}/apxs
497%{_mandir}/man8/apxs*
498%{_libdir}/apache2/build/*.mk
499%{_libdir}/apache2/build/*.sh
500
501%changelog
502* Fri Dec  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-5
503- add patch120 for fix CVE-2011-4317 (mod_rewrite/mod_proxy)
504
505* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-4
506- add patch110 for fix CVE-2011-3607-4415 (ModSetEnvIf)
507
508* Wed Oct 12 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-3
509- add patch70 for fix byterange filter
510
511* Tue Oct 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-2
512- add Patch100 for fix CVE-2011-3368 (mod_proxy)
513
514* Wed Sep 14 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-1
515- new upstream release with security fix (CVE-2011-3348)
516- regression fixes of CVE-2011-3192 byterange fix in 2.2.20
517
518* Tue Sep  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-3
519- update Patch101 (Thanks to debian team)
520
521* Sat Sep  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-2
522- add Patch101 for fix CVE-2011-3192 regression
523
524* Thu Sep  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-1
525- new upstream release with security fix (CVE-2011-3192)
526- drop patch100 (is included in new release)
527
528* Thu Aug 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.19-2
529- add patch100 for fix CVE-2011-3192 (Range Header DoS)
530
531* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.19-1
532- update to 2.2.19
533
534* Sat Apr 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-9
535- remove old Obsoletes/Conflicts
536
537* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-8
538- rebuild with openssl-1.0.0c
539
540* Sat Aug 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.14-7
541- add  patch120 for fix CVE-2010-1452 (mod_dav/mod_cache) from mdk2010
542
543* Wed Aug 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-6
544- add R(post): alternatives
545
546* Sat Mar 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-5
547- add patch110 for fix CVE-2010-0434 from mdk 2010
548
549* Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-4
550- add patch100 for fix CVE-2010-0408 (mod_proxy_ajp)
551
552* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.14-3
553- rebuilt with rpm-4.8.0-3 (on ppc)
554
555* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-2
556- rebuild with db4-4.8.0
557
558* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-1
559- new upstream release with security fix
560  (CVE-2009-2699, CVE-2009-3095, CVE-2009-3094)
561- fix ssl.conf (2.2.13-1 includes wrong file)
562
563* Sun Aug 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.13-1
564- new upstream release
565
566* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.12-1
567- new upstream release
568  (including security fix for CVE-2009-1890, CVE-2009-1191,
569   CVE-2009-1195, CVE-2009-1955, CVE-2009-1956, CVE-2009-0023)
570
571* Fri Jan 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-2
572- rebuilt with openldap-2.4.11
573
574* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-1
575- new upstream release
576
577* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-1
578- new upstream release (including security fix for CVE-2008-2939)
579
580* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-1
581- new upstream release (including security fix for CVE-2008-2364, CVE-2007-6420)
582- built with db4-4.6.21, apr 1.3.0
583
584* Sun Apr 27 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.8-1
585- add Patch60 (to fix bug#31418).
586
587* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.8-0vl2
588- rebuild with expat-2.0.1
589
590* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
591- new upstream release
592
593* Sat Nov  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-0vl2
594- added postun script from VinePlus/4.0 package
595  * Tue Sep 11 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.3-0vl3.2
596  - add postun script to restart daemon with message
597
598* Sun Jul 01 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl8
599- updated Patch2: httpd-2.2.3-apxs.patch
600
601* Sun Jun 24 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl7
602- modified libdir in config.layout for lib64 architecture
603
604* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
605- rebuilt with openssl-0.9.8e
606
607* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl5
608- rebuilt with new toolchain and db4-4.3.x
609
610* Tue Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl4
611- added BuildRequires: pcre-devel, sqlite3-devel <BTS:VineLinux:474>
612
613* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.3-0vl3
614- change manual Group to Applications/Documentation. <BTS:VineLinux:163>
615
616* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl2
617- rebuilt with openldap-2.3.27-0vl1
618
619* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
620- new upstream release including security fix (CVE-2006-3747)
621
622* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
623- new upstream release
624  - update to 2.2.2
625- remove apr/apr-devel subpackage,
626  use external apr/apr-util instead of internal one.
627
628* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.58-0vl1
629- new upstream release
630- use apache2.prefork as default.
631
632* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl3
633- rebuild to use new _localstatedir (rpm-4.4.2-0vl11)
634- remove unpackaged files in %%install section
635
636* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl2
637- fix logrotate configuration (use apache2.pid instead of httpd.pid)
638  (BTS:10)
639- use Epoch instead of Serial
640
641* Sat Oct 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl1
642- new upstream release
643- drop obsolete security patches which is merged in upstream
644
645* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.54-0vl1
646- new upstream release
647
648* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl2
649- added Patch122 to 125 for secutiry fix
650  (CAN-2004-{1268,2088,2700,2728})
651- fix %install section
652
653* Sun Apr 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl1
654- new upstream release
655
656* Sat Nov 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.52-0vl1
657- new upstream release
658
659* Sun Oct 24 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.50-0vl4
660- rebuilt with db4-4.2.52
661
662* Sat Sep  4 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.0.50-0vl3
663- separate apr, apr-devel packages
664- add BuildPreReq: zlib-devel
665
666* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.50-0vl2
667- fix %%files to include instdso.sh
668  thanks to jax <jax AT morejams DOT no-ip DOT com>
669- add %%{?_smp_mflags} to make option.
670
671* Sun Jul  4 2004 IWAI, Masaharu <iwai@alib.jp> 2.0.50-0vl1
672- new upstream version
673
674* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.48-0vl1
675- new upstream version
676
677* Mon Sep 15 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.47-0vl1
678- new upstream version
679- update apxs patch (Patch101)
680- fix dependency:
681    - change file name to package name in Requires and {Build,}Prereq
682- add BuildPrereq: openldap-devel
683- update %%files section
684- rename httpd.8 manpage
685
686* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.45-0vl1
687- new upstream version
688- used vine-config.layout in srclib
689
690* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.44-0vl9
691- rebuild
692
693* Sun Apr  6 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl8
694- change pkg name from mod_ssl to mod_ssl-apache2
695- remove "apache-manual" entry from Obsoletes:
696
697* Thu Apr  3 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl7
698- remove "mod_dav" and "apache-devel" from Obsoletes:
699- enable MPMS(worker %mpms )
700
701* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl6
702- add correct config_vars.mk
703
704* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl5
705- apply apxs's patch ( from Debian)
706
707* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl4
708- add apr-config,apu-config to devel's %file
709
710* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl3
711- change apxs path ( /usr/sbin -> /usr/bin
712- add symlink under /etc/apache2/conf
713  (logs, run), httpd.conf -> apache2.conf
714- fixed apache2 initscript.
715
716* Sat Mar 29 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl2
717- build Vine Linux
718- new upstream version
719- sharing with apache1
720
721* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
722- link httpd with libssl to avoid library loading/unloading weirdness
723
724* Tue Sep  3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
725- add LoadModule lines for proxy modules in httpd.conf (#73349)
726- fix permissions of conf/ssl.*/ directories; add Makefiles for
727  certificate management (#73352)
728
729* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
730- provide "httpd-mmn" to manage module ABI compatibility
731
732* Sun Sep  1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
733- fix SSL session cache (#69699)
734- revert addition of LDAP support to apr-util
735
736* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
737- set SIGXFSZ disposition to "ignored" (#69520)
738- make dummy connections to the first listener in config (#72692)
739
740* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
741- allow "apachectl configtest" on a 1.3 httpd.conf
742- add mod_deflate
743- enable LDAP support in apr-util
744- don't package everything in /var/www/error as config(noreplace)
745
746* Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
747- add trigger (#68657)
748
749* Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
750- update to 2.0.40
751
752* Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
753- improve comment on use of UserDir in default config (#66886)
754
755* Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
756- use /sbin/nologin as shell for apache user (#68371)
757- add patch from CVS to fix possible infinite loop when processing
758  internal redirects
759
760* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
761- modify init script to detect 1.3.x httpd.conf's and direct users
762  to the migration guide
763
764* Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
765- patch apachectl to detect 1.3.x httpd.conf's and direct users
766  to the migration guide
767- ship the migration guide
768
769* Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
770- move /etc/httpd2 back to /etc/httpd
771- add noindex.html page and poweredby logo; tweak default config
772  to load noindex.html if no default "/" page is present.
773- add patch to prevent mutex errors on graceful restart
774
775* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
776- automated rebuild
777
778* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
779- add patch to fix SSL mutex handling
780
781* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
782- improved config directory patch
783
784* Mon May 20 2002 Joe Orton <jorton@redhat.com>
785- initial build; based heavily on apache.spec and mod_ssl.spec
786- fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245
787
Note: See TracBrowser for help on using the repository browser.