source: projects/specs/branches/6/a/apache2/apache2-vl.spec @ 5164

Revision 5164, 25.2 KB checked in by iwamoto, 12 years ago (diff)

apache2: CVE-2011-3607-4415 (ModSetEnvIf?)

Line 
1%define contentdir /var/www
2%define suexec_caller apache
3%define mmn 20051115
4%define pkgname apache2
5
6Summary: Apache HTTP Server
7Name: %{pkgname}
8Version: 2.2.21
9Release: 4%{_dist_release}
10URL: http://httpd.apache.org/
11
12Vendor: Project Vine
13Distribution: Vine Linux
14Packager: daisuke
15
16Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
17Source1: index.html.ja
18Source3: apache2.logrotate
19Source4: apache2.init
20Source5: README.confd
21Source6: vine.png
22Source10: httpd.conf
23Source11: apache-ssl.conf
24Source12: migration.html
25Source13: migration.css
26Source14: mod_ssl-Makefile.crt
27Source15: mod_ssl-Makefile.crl
28# add vine entry to config.layout
29Source100: vine-config.layout
30# man files
31Source101: apache2.8
32Source102: apache2ctl.8
33#Source103: config_vars.mk
34# build/scripts patches
35Patch1: httpd-2.1.10-apctl.patch
36Patch2: httpd-2.2.3-apxs.patch
37Patch3: httpd-2.0.45-deplibs.patch
38Patch4: httpd-2.1.10-disablemods.patch
39# features/functional changes
40Patch21: httpd-2.0.40-xfsz.patch
41Patch22: httpd-2.1.10-pod.patch
42Patch23: httpd-2.0.45-export.patch
43Patch24: httpd-2.0.48-corelimit.patch
44# Bug fixes
45Patch54: httpd-2.2.0-authnoprov.patch
46Patch60: httpd-2.2.3-sslusername.patch
47Patch70: apache2-2.2.21-byterange_fix_1177080.patch
48
49# Security fixes
50# Patch100: httpd-2.2.19_CVE-2011-3192.patch
51# Patch101: httpd-2.2.20_CVE-2011-3192_regression_2.patch
52Patch100: apache2-2.2.21_CVE-2011-3368.patch
53Patch110: apache2-2.2.21_CVE-2011-3607-4415.patch
54
55License: Apache Software License
56Group: System Environment/Daemons
57BuildRoot: %{_tmppath}/%{name}-%{version}-root
58BuildRequires: db4-devel, expat-devel
59BuildRequires: findutils, perl, openldap-devel, zlib-devel
60BuildRequires: apr-devel, apr-util-devel
61BuildRequires: pcre-devel, sqlite3-devel
62Requires: mailcap, gawk, file, findutils, apr, apr-util
63Requires(pre): chkconfig, mktemp, fileutils
64Requires(pre): sh-utils, textutils, shadow-utils
65Requires(post): alternatives
66Provides: webserver
67Provides: httpd = %{version}
68Provides: httpd-mmn = %{mmn}
69Obsoletes: apache2-apr, apache2-apr-devel
70
71%description
72Apache is a powerful, full-featured, efficient, and freely-available
73Web server. Apache is also the most popular Web server on the
74Internet.
75
76%package devel
77Group: Development/Libraries
78Summary: Development tools for the Apache HTTP server.
79Requires: libtool, httpd = %{version}
80Requires: apr-devel, apr-util-devel
81
82%description devel
83The httpd-devel package contains the APXS binary and other files
84that you need to build Dynamic Shared Objects (DSOs) for Apache.
85
86If you are installing the Apache HTTP server and you want to be
87able to compile or develop additional modules for Apache, you need
88to install this package.
89
90%package manual
91Group: Applications/Documentation
92Summary: Documentation for the Apache HTTP server.
93
94%description manual
95The httpd-manual package contains the complete manual and
96reference guide for the Apache HTTP server. The information can
97also be found at http://httpd.apache.org/docs/.
98
99%package -n mod_ssl-apache2
100Group: System Environment/Daemons
101Summary: SSL/TLS module for the Apache HTTP server
102Epoch: 1
103BuildRequires: openssl-devel
104Requires(pre): openssl, dev, /bin/cat
105Requires: httpd, make, httpd-mmn = %{mmn}
106
107%description -n mod_ssl-apache2
108The mod_ssl module provides strong cryptography for the Apache Web
109server via the Secure Sockets Layer (SSL) and Transport Layer
110Security (TLS) protocols.
111
112%prep
113%setup -q -n httpd-%{version}
114
115%patch1 -p1 -b .apctl
116%patch2 -p1 -b .apxs
117#patch3 -p1 -b .deplibs
118%patch4 -p1 -b .disablemods
119
120%patch21 -p0 -b .xfsz
121%patch22 -p1 -b .pod
122%patch23 -p1 -b .export
123%patch24 -p1 -b .corelimit
124
125%patch54 -p1 -b .authnoprov
126%patch60 -p1 -b .sslusername
127%patch70 -p4 -b .byterange_fix_1177080
128
129# %patch100 -p1 -b .CVE-2011-3192
130# %patch101 -p1 -b .CVE-2011-3192_regression
131%patch100 -p1 -b .CVE-2011-3368
132%patch110 -p1 -b .CVE-2011-3607-4415
133
134# copy across the migration guide and sed it's location into apachectl
135cp $RPM_SOURCE_DIR/migration.{html,css} .
136%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
137        support/apachectl.in
138
139
140# add Vine configure's option to config.layout
141sed -e "s|${prefix}/lib|${prefix}/%{_lib}|" \
142  < $RPM_SOURCE_DIR/vine-config.layout >> config.layout
143
144# regenerate configure scripts
145./buildconf
146
147%build
148# remove bundled apr, apr-util, pcre
149rm -rf srclib/{apr,apr-util,pcre}
150
151#CFLAGS="$RPM_OPT_FLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
152#AP_LIBS="-lssl -lcrypto"
153#export CFLAGS AP_LIBS
154CFLAGS="$RPM_OPT_FLAGS"
155SH_LDFLAGS="-Wl,-z,relro"
156export CFLAGS SH_LDFLAGS
157
158%define mpms worker prefork
159%define prefer_mpm prefork
160
161AP_CONFOPTS="\
162        --prefix=%{_sysconfdir}/apache2 \
163        --exec-prefix=%{_prefix} \
164        --bindir=%{_bindir} \
165        --sbindir=%{_sbindir} \
166        --mandir=%{_mandir} \
167        --libdir=%{_libdir} \
168        --sysconfdir=%{_sysconfdir}/apache2/conf \
169        --includedir=%{_includedir}/apache2 \
170        --libexecdir=%{_libdir}/apache2/modules \
171        --datadir=%{contentdir} \
172        --with-installbuilddir=%{_libdir}/apache2/build \
173        --enable-layout=Vine \
174        --with-program-name=apache2 \
175        --with-ldap \
176        --enable-ldap --enable-authnz-ldap \
177        --enable-mods-shared=all \
178        --enable-cache=shared \
179        --enable-cgi=shared \
180        --enable-cgid=shared \
181        --enable-rewrite=shared \
182        --enable-disk-cache=shared \
183        --enable-file-cache=shared \
184        --enable-mem-cache=shared \
185        --enable-authn-anon --enable-authn-alias \
186        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
187        --enable-suexec --with-suexec \
188        --with-suexec-caller=%{suexec_caller} \
189        --with-suexec-docroot=%{contentdir} \
190        --with-suexec-logfile=%{_localstatedir}/log/apache2/suexec.log \
191        --with-suexec-bin=%{_libdir}/%{pkgname}/suexec \
192        --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
193        --with-pcre \
194        --enable-ssl --with-ssl \
195        --enable-deflate \
196        --enable-proxy --enable-proxy-connect \
197        --enable-proxy-http --enable-proxy-ftp"
198#all  mpm build
199for mpm in %{mpms}; do
200   mkdir mpm-$mpm;
201   cd mpm-$mpm;
202   ../configure $AP_CONFOPTS --with-mpm=$mpm --srcdir=../ ;
203   make %{?_smp_mflags} ;
204#   mv apache2 apache2.$mpm ;
205   cd ../
206done
207
208%install
209rm -rf $RPM_BUILD_ROOT
210
211# Classify ab and logresolve as section 1 commands, as they are in /usr/bin
212cp -p docs/man/ab.8 docs/man/ab.1
213sed -e "1s/logresolve 8/logresolve 1/" \
214  < docs/man/logresolve.8 > docs/man/logresolve.1
215#rm docs/man/logresolve.8
216
217# install mpms binary
218pushd mpm-prefork
219  make DESTDIR=$RPM_BUILD_ROOT install
220  rm -f $RPM_BUILD_ROOT/%{_sbindir}/apache2
221popd
222
223for mpm in %{mpms}; do
224    install -m755 mpm-$mpm/apache2 $RPM_BUILD_ROOT/%{_sbindir}/apache2.$mpm
225done
226
227# install conf file/directory
228mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d
229install -m 644 $RPM_SOURCE_DIR/README.confd \
230   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/README
231install -m 644 $RPM_SOURCE_DIR/apache-ssl.conf \
232   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/ssl.conf
233
234rm $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/*.conf
235install -m 644 $RPM_SOURCE_DIR/httpd.conf \
236   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/httpd.conf
237
238# mod_ssl bits
239for suffix in crl crt csr key prm; do
240   mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${suffix}
241done
242
243# Makefiles for certificate management
244for ext in crt crl; do
245  install -m 644 $RPM_SOURCE_DIR/mod_ssl-Makefile.${ext} \
246        $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${ext}/Makefile.${ext}
247done
248ln -s ../../../usr/share/ssl/certs/Makefile $RPM_BUILD_ROOT/etc/apache2/conf
249
250# for holding mod_dav lock database
251mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav
252
253# create a prototype session cache
254mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl
255touch $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl/scache.{dir,pag,sem}
256
257# move utilities to /usr/bin
258mv $RPM_BUILD_ROOT%{_sbindir}/{ab,htdbm,logresolve,htpasswd,htdigest} \
259   $RPM_BUILD_ROOT%{_bindir}
260
261# Make the MMN accessible to module packages
262echo %{mmn} > $RPM_BUILD_ROOT%{_includedir}/apache2/.mmn
263
264# docroot
265# mkdir $RPM_BUILD_ROOT%{contentdir}/html
266install -m 644 $RPM_SOURCE_DIR/index.html.ja \
267        $RPM_BUILD_ROOT%{contentdir}/error/noindex.html
268rm -r $RPM_BUILD_ROOT%{contentdir}/manual/style
269
270install -m 644 $RPM_SOURCE_DIR/vine.png \
271        $RPM_BUILD_ROOT%{contentdir}/icons
272
273# logs
274# rmdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/logs
275mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/apache2
276
277ln -sf %{_sysconfdir}/%{pkgname}/conf/httpd.conf $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/conf/apache2.conf
278
279
280# symlinks for /etc/apache2
281ln -s ../..%{_localstatedir}/log/apache2 $RPM_BUILD_ROOT/etc/apache2/logs
282ln -s ../..%{_localstatedir}/run $RPM_BUILD_ROOT/etc/apache2/run
283ln -s ../..%{_libdir}/apache2/modules $RPM_BUILD_ROOT/etc/apache2/modules
284ln -s ../..%{_libdir}/apache2/build $RPM_BUILD_ROOT/etc/apache2/build
285
286# install SYSV init stuff
287mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
288install -m755 $RPM_SOURCE_DIR/apache2.init \
289        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
290%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
291        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
292
293# install log rotation stuff
294mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
295install -m644 $RPM_SOURCE_DIR/apache2.logrotate \
296        $RPM_BUILD_ROOT/etc/logrotate.d/apache2
297
298mv $RPM_BUILD_ROOT/%{_sbindir}/apachectl $RPM_BUILD_ROOT/%{_sbindir}/apache2ctl
299
300# fix man page paths
301sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/apache2/conf/httpd.conf|" \
302    -e "s|/usr/local/apache2/conf/mime.types|/etc/mime.types|" \
303    -e "s|/usr/local/apache2/conf/magic|/etc/apache2/conf/magic|" \
304    -e "s|/usr/local/apache2/logs/error_log|/var/log/apache2/error_log|" \
305    -e "s|/usr/local/apache2/logs/access_log|/var/log/apache2/access_log|" \
306    -e "s|/usr/local/apache2/logs/httpd.pid|/var/run/apache2.pid|" \
307    -e "s|/usr/local/apache2|/etc/httpd|" < $RPM_SOURCE_DIR/apache2.8 \
308  > $RPM_BUILD_ROOT%{_mandir}/man8/apache2.8
309
310install -m644 $RPM_SOURCE_DIR/apache2ctl.8 \
311        $RPM_BUILD_ROOT%{_mandir}/man8/apache2ctl.8
312
313# change command name to avoid conflict with apache1 pacjage
314%define cflcmd /usr/bin/htdigest /usr/bin/htpasswd /usr/sbin/rotatelogs
315
316for i in %{cflcmd}; do \
317  echo $i
318  mv $RPM_BUILD_ROOT$i $RPM_BUILD_ROOT$i"2";
319done;
320
321mv $RPM_BUILD_ROOT/%{_sbindir}/apxs $RPM_BUILD_ROOT/%{_bindir}/apxs
322
323%define cflman usr/share/man/man1/dbmmanage.1 usr/share/man/man1/htdigest.1 usr/share/man/man1/htpasswd.1 usr/share/man/man8/rotatelogs.8 usr/share/man/man8/suexec.8 usr/share/man/man8/apxs.8 usr/share/man/man8/httpd.8
324
325(cd $RPM_BUILD_ROOT;
326for i in %{cflman}; do \
327    echo $i | sed -e "s|\.1|2\.1|" -e "s|\.8|2\.8|" |    xargs mv $i ;
328   
329done;
330)
331
332#cp $RPM_SOURCE_DIR/config_vars.mk $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/build/.
333mv $RPM_BUILD_ROOT/%{_sbindir}/suexec $RPM_BUILD_ROOT/%{_libdir}/%{pkgname}/suexec
334
335
336rm -f $RPM_BUILD_ROOT%{_mandir}/man1/ab*
337rm -f $RPM_BUILD_ROOT%{_mandir}/man1/logresolve*
338# conflict with apache 1, so removed...
339rm -f $RPM_BUILD_ROOT%{_mandir}/man8/ab*
340rm -f $RPM_BUILD_ROOT%{_mandir}/man8/logresolve*
341
342# remove unpackaged files
343rm -f $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/mime.types \
344      $RPM_BUILD_ROOT%{_libdir}/*.la \
345      $RPM_BUILD_ROOT%{_libdir}/*.exp \
346      $RPM_BUILD_ROOT%{_libdir}/apache2/modules/*.exp \
347      $RPM_BUILD_ROOT%{_libdir}/apache2/build/config.nice \
348      $RPM_BUILD_ROOT%{_sbindir}/{apache2,checkgid,dbmmanage,envvars*} \
349      $RPM_BUILD_ROOT%{contentdir}/html/* \
350      $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
351
352%pre
353# Add the "apache" user
354/usr/sbin/useradd -c "Apache" -u 48 \
355        -s /sbin/nologin -r -d %{contentdir} apache 2> /dev/null || :
356
357%triggerpostun -- apache < 2.0
358/sbin/chkconfig --add apache2
359
360
361%post
362# Register the httpd service
363for mpm in %{mpms}; do
364  /sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.$mpm 20;
365done
366/sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.%{prefer_mpm} 30
367/sbin/chkconfig --add apache2
368
369%preun
370if [ $1 = 0 ]; then
371        /sbin/service apache2 stop > /dev/null 2>&1
372        /sbin/chkconfig --del apache2
373        for mpm in %{mpms}; do
374          /sbin/update-alternatives --remove apache2 %{_sbindir}/apache2.$mpm;
375        done 
376fi
377
378%postun
379if [ "$1" -ge 1 ]; then
380        /sbin/service apache2 condrestart
381fi
382/sbin/ldconfig
383
384%post -n mod_ssl-apache2
385/sbin/ldconfig ### is this needed?
386umask 077
387
388if [ ! -f %{_sysconfdir}/apache2/conf/ssl.key/server.key ] ; then
389%{_bindir}/openssl genrsa -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime 1024 > %{_sysconfdir}/apache2/conf/ssl.key/server.key 2> /dev/null
390fi
391
392FQDN=`hostname`
393if [ "x${FQDN}" = "x" ]; then
394   FQDN=localhost.localdomain
395fi
396
397if [ ! -f %{_sysconfdir}/apache2/conf/ssl.crt/server.crt ] ; then
398cat << EOF | %{_bindir}/openssl req -new -key %{_sysconfdir}/apache2/conf/ssl.key/server.key -x509 -days 365 -out %{_sysconfdir}/apache2/conf/ssl.crt/server.crt 2>/dev/null
399--
400SomeState
401SomeCity
402SomeOrganization
403SomeOrganizationalUnit
404${FQDN}
405root@${FQDN}
406EOF
407fi
408
409%clean
410rm -rf $RPM_BUILD_ROOT
411
412%files
413%defattr(-,root,root)
414
415%doc ABOUT_APACHE README CHANGES LAYOUT LICENSE
416%doc migration.html migration.css
417
418%dir %{_sysconfdir}/apache2
419%{_sysconfdir}/apache2/modules
420%{_sysconfdir}/apache2/logs
421%{_sysconfdir}/apache2/run
422%dir %{_sysconfdir}/apache2/conf
423%config(noreplace) %{_sysconfdir}/apache2/conf/*.conf
424%config(noreplace) %{_sysconfdir}/apache2/conf/magic
425
426%config %{_sysconfdir}/logrotate.d/apache2
427%config %{_sysconfdir}/rc.d/init.d/apache2
428
429%dir %{_sysconfdir}/apache2/conf.d
430%{_sysconfdir}/apache2/conf.d/README
431
432%dir %{_sysconfdir}/apache2/conf/extra
433%config %{_sysconfdir}/apache2/conf/extra/*
434
435%dir %{_sysconfdir}/apache2/conf/original
436%{_sysconfdir}/apache2/conf/original/*
437
438%{_bindir}/ab
439%{_bindir}/ht*
440%{_bindir}/logresolve
441%{_sbindir}/ht*
442%{_sbindir}/apache2.*
443%{_sbindir}/apache2ctl
444%{_sbindir}/rotatelogs2
445%attr(4510,root,%{suexec_caller}) %{_libdir}/%{pkgname}/suexec
446
447%dir %{_libdir}/apache2
448%dir %{_libdir}/apache2/modules
449# everything but mod_ssl.so:
450%{_libdir}/apache2/modules/mod_[a-r]*.so
451%{_libdir}/apache2/modules/mod_s[petu]*.so
452%{_libdir}/apache2/modules/mod_[t-z]*.so
453
454%dir %{contentdir}
455%dir %{contentdir}/cgi-bin
456%dir %{contentdir}/html
457%dir %{contentdir}/icons
458%dir %{contentdir}/error
459%dir %{contentdir}/error/include
460%{contentdir}/icons/*
461%{contentdir}/error/README
462%{contentdir}/error/noindex.html
463%config(noreplace) %{contentdir}/error/*.var
464%config(noreplace) %{contentdir}/error/include/*.html
465
466%attr(0700,root,root) %dir %{_localstatedir}/log/apache2
467
468%attr(0700,apache,apache) %dir %{_localstatedir}/lib/dav
469
470%{_mandir}/man1/*
471
472%{_mandir}/man8/*
473
474%files manual
475%defattr(-,root,root)
476%{contentdir}/manual
477
478%files -n mod_ssl-apache2
479%defattr(-,root,root)
480%{_libdir}/apache2/modules/mod_ssl.so
481%config(noreplace) %{_sysconfdir}/apache2/conf.d/ssl.conf
482%attr(0700,root,root) %dir %{_sysconfdir}/apache2/conf/ssl.*
483%config %{_sysconfdir}/apache2/conf/Makefile
484%config %{_sysconfdir}/apache2/conf/ssl.*/*
485%attr(0700,apache,root) %dir %{_localstatedir}/cache/mod_ssl
486%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.dir
487%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.pag
488%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.sem
489
490%files devel
491%defattr(-,root,root)
492%{_includedir}/apache2
493%{_sysconfdir}/apache2/build
494%{_bindir}/apxs
495%{_mandir}/man8/apxs*
496%{_libdir}/apache2/build/*.mk
497%{_libdir}/apache2/build/*.sh
498
499%changelog
500* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-4
501- add patch110 for fix CVE-2011-3607-4415 (ModSetEnvIf)
502
503* Wed Oct 12 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-3
504- add patch70 for fix byterange filter
505
506* Tue Oct 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-2
507- add Patch100 for fix CVE-2011-3368 (mod_proxy)
508
509* Wed Sep 14 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-1
510- new upstream release with security fix (CVE-2011-3348)
511- regression fixes of CVE-2011-3192 byterange fix in 2.2.20
512
513* Tue Sep  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-3
514- update Patch101 (Thanks to debian team)
515
516* Sat Sep  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-2
517- add Patch101 for fix CVE-2011-3192 regression
518
519* Thu Sep  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-1
520- new upstream release with security fix (CVE-2011-3192)
521- drop patch100 (is included in new release)
522
523* Thu Aug 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.19-2
524- add patch100 for fix CVE-2011-3192 (Range Header DoS)
525
526* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.19-1
527- update to 2.2.19
528
529* Sat Apr 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-9
530- remove old Obsoletes/Conflicts
531
532* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-8
533- rebuild with openssl-1.0.0c
534
535* Sat Aug 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.14-7
536- add  patch120 for fix CVE-2010-1452 (mod_dav/mod_cache) from mdk2010
537
538* Wed Aug 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-6
539- add R(post): alternatives
540
541* Sat Mar 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-5
542- add patch110 for fix CVE-2010-0434 from mdk 2010
543
544* Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-4
545- add patch100 for fix CVE-2010-0408 (mod_proxy_ajp)
546
547* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.14-3
548- rebuilt with rpm-4.8.0-3 (on ppc)
549
550* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-2
551- rebuild with db4-4.8.0
552
553* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-1
554- new upstream release with security fix
555  (CVE-2009-2699, CVE-2009-3095, CVE-2009-3094)
556- fix ssl.conf (2.2.13-1 includes wrong file)
557
558* Sun Aug 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.13-1
559- new upstream release
560
561* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.12-1
562- new upstream release
563  (including security fix for CVE-2009-1890, CVE-2009-1191,
564   CVE-2009-1195, CVE-2009-1955, CVE-2009-1956, CVE-2009-0023)
565
566* Fri Jan 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-2
567- rebuilt with openldap-2.4.11
568
569* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-1
570- new upstream release
571
572* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-1
573- new upstream release (including security fix for CVE-2008-2939)
574
575* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-1
576- new upstream release (including security fix for CVE-2008-2364, CVE-2007-6420)
577- built with db4-4.6.21, apr 1.3.0
578
579* Sun Apr 27 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.8-1
580- add Patch60 (to fix bug#31418).
581
582* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.8-0vl2
583- rebuild with expat-2.0.1
584
585* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
586- new upstream release
587
588* Sat Nov  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-0vl2
589- added postun script from VinePlus/4.0 package
590  * Tue Sep 11 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.3-0vl3.2
591  - add postun script to restart daemon with message
592
593* Sun Jul 01 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl8
594- updated Patch2: httpd-2.2.3-apxs.patch
595
596* Sun Jun 24 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl7
597- modified libdir in config.layout for lib64 architecture
598
599* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
600- rebuilt with openssl-0.9.8e
601
602* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl5
603- rebuilt with new toolchain and db4-4.3.x
604
605* Tue Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl4
606- added BuildRequires: pcre-devel, sqlite3-devel <BTS:VineLinux:474>
607
608* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.3-0vl3
609- change manual Group to Applications/Documentation. <BTS:VineLinux:163>
610
611* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl2
612- rebuilt with openldap-2.3.27-0vl1
613
614* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
615- new upstream release including security fix (CVE-2006-3747)
616
617* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
618- new upstream release
619  - update to 2.2.2
620- remove apr/apr-devel subpackage,
621  use external apr/apr-util instead of internal one.
622
623* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.58-0vl1
624- new upstream release
625- use apache2.prefork as default.
626
627* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl3
628- rebuild to use new _localstatedir (rpm-4.4.2-0vl11)
629- remove unpackaged files in %%install section
630
631* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl2
632- fix logrotate configuration (use apache2.pid instead of httpd.pid)
633  (BTS:10)
634- use Epoch instead of Serial
635
636* Sat Oct 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl1
637- new upstream release
638- drop obsolete security patches which is merged in upstream
639
640* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.54-0vl1
641- new upstream release
642
643* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl2
644- added Patch122 to 125 for secutiry fix
645  (CAN-2004-{1268,2088,2700,2728})
646- fix %install section
647
648* Sun Apr 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl1
649- new upstream release
650
651* Sat Nov 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.52-0vl1
652- new upstream release
653
654* Sun Oct 24 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.50-0vl4
655- rebuilt with db4-4.2.52
656
657* Sat Sep  4 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.0.50-0vl3
658- separate apr, apr-devel packages
659- add BuildPreReq: zlib-devel
660
661* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.50-0vl2
662- fix %%files to include instdso.sh
663  thanks to jax <jax AT morejams DOT no-ip DOT com>
664- add %%{?_smp_mflags} to make option.
665
666* Sun Jul  4 2004 IWAI, Masaharu <iwai@alib.jp> 2.0.50-0vl1
667- new upstream version
668
669* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.48-0vl1
670- new upstream version
671
672* Mon Sep 15 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.47-0vl1
673- new upstream version
674- update apxs patch (Patch101)
675- fix dependency:
676    - change file name to package name in Requires and {Build,}Prereq
677- add BuildPrereq: openldap-devel
678- update %%files section
679- rename httpd.8 manpage
680
681* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.45-0vl1
682- new upstream version
683- used vine-config.layout in srclib
684
685* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.44-0vl9
686- rebuild
687
688* Sun Apr  6 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl8
689- change pkg name from mod_ssl to mod_ssl-apache2
690- remove "apache-manual" entry from Obsoletes:
691
692* Thu Apr  3 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl7
693- remove "mod_dav" and "apache-devel" from Obsoletes:
694- enable MPMS(worker %mpms )
695
696* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl6
697- add correct config_vars.mk
698
699* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl5
700- apply apxs's patch ( from Debian)
701
702* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl4
703- add apr-config,apu-config to devel's %file
704
705* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl3
706- change apxs path ( /usr/sbin -> /usr/bin
707- add symlink under /etc/apache2/conf
708  (logs, run), httpd.conf -> apache2.conf
709- fixed apache2 initscript.
710
711* Sat Mar 29 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl2
712- build Vine Linux
713- new upstream version
714- sharing with apache1
715
716* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
717- link httpd with libssl to avoid library loading/unloading weirdness
718
719* Tue Sep  3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
720- add LoadModule lines for proxy modules in httpd.conf (#73349)
721- fix permissions of conf/ssl.*/ directories; add Makefiles for
722  certificate management (#73352)
723
724* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
725- provide "httpd-mmn" to manage module ABI compatibility
726
727* Sun Sep  1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
728- fix SSL session cache (#69699)
729- revert addition of LDAP support to apr-util
730
731* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
732- set SIGXFSZ disposition to "ignored" (#69520)
733- make dummy connections to the first listener in config (#72692)
734
735* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
736- allow "apachectl configtest" on a 1.3 httpd.conf
737- add mod_deflate
738- enable LDAP support in apr-util
739- don't package everything in /var/www/error as config(noreplace)
740
741* Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
742- add trigger (#68657)
743
744* Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
745- update to 2.0.40
746
747* Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
748- improve comment on use of UserDir in default config (#66886)
749
750* Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
751- use /sbin/nologin as shell for apache user (#68371)
752- add patch from CVS to fix possible infinite loop when processing
753  internal redirects
754
755* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
756- modify init script to detect 1.3.x httpd.conf's and direct users
757  to the migration guide
758
759* Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
760- patch apachectl to detect 1.3.x httpd.conf's and direct users
761  to the migration guide
762- ship the migration guide
763
764* Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
765- move /etc/httpd2 back to /etc/httpd
766- add noindex.html page and poweredby logo; tweak default config
767  to load noindex.html if no default "/" page is present.
768- add patch to prevent mutex errors on graceful restart
769
770* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
771- automated rebuild
772
773* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
774- add patch to fix SSL mutex handling
775
776* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
777- improved config directory patch
778
779* Mon May 20 2002 Joe Orton <jorton@redhat.com>
780- initial build; based heavily on apache.spec and mod_ssl.spec
781- fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245
782
Note: See TracBrowser for help on using the repository browser.