source: projects/specs/branches/6/a/apache2/apache2-vl.spec @ 11196

Revision 11196, 26.9 KB checked in by iwamoto, 7 years ago (diff)

apache2: update to 2.2.34

Line 
1%define contentdir /var/www
2%define suexec_caller apache
3%define mmn 20051115
4%define pkgname apache2
5
6Summary: Apache HTTP Server
7Name: %{pkgname}
8Version: 2.2.34
9Release: 1%{_dist_release}
10URL: http://httpd.apache.org/
11
12Vendor: Project Vine
13Distribution: Vine Linux
14Packager: daisuke
15
16Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
17Source1: index.html.ja
18Source3: apache2.logrotate
19Source4: apache2.init
20Source5: README.confd
21Source6: vine.png
22Source10: httpd.conf
23Source11: apache-ssl.conf
24Source12: migration.html
25Source13: migration.css
26Source14: mod_ssl-Makefile.crt
27Source15: mod_ssl-Makefile.crl
28# add vine entry to config.layout
29Source100: vine-config.layout
30# man files
31Source101: apache2.8
32Source102: apache2ctl.8
33#Source103: config_vars.mk
34# build/scripts patches
35Patch1: httpd-2.1.10-apctl.patch
36Patch2: httpd-2.2.3-apxs.patch
37Patch3: httpd-2.0.45-deplibs.patch
38Patch4: httpd-2.1.10-disablemods.patch
39# features/functional changes
40Patch21: httpd-2.0.40-xfsz.patch
41# Patch22: httpd-2.1.10-pod.patch
42Patch22: httpd-2.2.23-pod.patch
43Patch23: httpd-2.0.45-export.patch
44Patch24: httpd-2.0.48-corelimit.patch
45# Bug fixes
46Patch54: httpd-2.2.0-authnoprov.patch
47Patch60: httpd-2.2.3-sslusername.patch
48
49# Security fixes
50# Patch1000: CVE-2016-5387.patch
51Patch1010: CVE-2017-9798-patch-2.2.patch
52
53License: Apache Software License
54Group: System Environment/Daemons
55BuildRoot: %{_tmppath}/%{name}-%{version}-root
56BuildRequires: db4-devel, expat-devel
57BuildRequires: findutils, perl, openldap-devel, zlib-devel
58BuildRequires: apr-devel, apr-util-devel
59BuildRequires: pcre-devel, sqlite3-devel
60Requires: mailcap, gawk, file, findutils, apr, apr-util
61Requires(pre): chkconfig, mktemp, fileutils
62Requires(pre): sh-utils, textutils, shadow-utils
63Requires(post): alternatives
64Provides: webserver
65Provides: httpd = %{version}
66Provides: httpd-mmn = %{mmn}
67Obsoletes: apache2-apr, apache2-apr-devel
68
69%description
70Apache is a powerful, full-featured, efficient, and freely-available
71Web server. Apache is also the most popular Web server on the
72Internet.
73
74%package devel
75Group: Development/Libraries
76Summary: Development tools for the Apache HTTP server.
77Requires: libtool, httpd = %{version}
78Requires: apr-devel, apr-util-devel
79
80%description devel
81The httpd-devel package contains the APXS binary and other files
82that you need to build Dynamic Shared Objects (DSOs) for Apache.
83
84If you are installing the Apache HTTP server and you want to be
85able to compile or develop additional modules for Apache, you need
86to install this package.
87
88%package manual
89Group: Applications/Documentation
90Summary: Documentation for the Apache HTTP server.
91
92%description manual
93The httpd-manual package contains the complete manual and
94reference guide for the Apache HTTP server. The information can
95also be found at http://httpd.apache.org/docs/.
96
97%package -n mod_ssl-apache2
98Group: System Environment/Daemons
99Summary: SSL/TLS module for the Apache HTTP server
100Epoch: 1
101BuildRequires: openssl-devel
102Requires(pre): openssl, dev, /bin/cat
103Requires: httpd, make, httpd-mmn = %{mmn}
104
105%description -n mod_ssl-apache2
106The mod_ssl module provides strong cryptography for the Apache Web
107server via the Secure Sockets Layer (SSL) and Transport Layer
108Security (TLS) protocols.
109
110%prep
111%setup -q -n httpd-%{version}
112
113%patch1 -p1 -b .apctl
114%patch2 -p1 -b .apxs
115#patch3 -p1 -b .deplibs
116%patch4 -p1 -b .disablemods
117
118%patch21 -p0 -b .xfsz
119%patch22 -p1 -b .pod
120%patch23 -p1 -b .export
121%patch24 -p1 -b .corelimit
122
123%patch54 -p1 -b .authnoprov
124%patch60 -p1 -b .sslusername
125
126# security fixes
127# %patch1000 -p1 -b .CVE-2016-5387
128%patch1010 -p0 -b .CVE-2017-9798
129
130# copy across the migration guide and sed it's location into apachectl
131cp $RPM_SOURCE_DIR/migration.{html,css} .
132%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
133        support/apachectl.in
134
135
136# add Vine configure's option to config.layout
137sed -e "s|${prefix}/lib|${prefix}/%{_lib}|" \
138  < $RPM_SOURCE_DIR/vine-config.layout >> config.layout
139
140# regenerate configure scripts
141./buildconf
142
143%build
144# remove bundled apr, apr-util, pcre
145rm -rf srclib/{apr,apr-util,pcre}
146
147#CFLAGS="$RPM_OPT_FLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
148#AP_LIBS="-lssl -lcrypto"
149#export CFLAGS AP_LIBS
150CFLAGS="$RPM_OPT_FLAGS"
151SH_LDFLAGS="-Wl,-z,relro"
152export CFLAGS SH_LDFLAGS
153
154%define mpms worker prefork
155%define prefer_mpm prefork
156
157AP_CONFOPTS="\
158        --prefix=%{_sysconfdir}/apache2 \
159        --exec-prefix=%{_prefix} \
160        --bindir=%{_bindir} \
161        --sbindir=%{_sbindir} \
162        --mandir=%{_mandir} \
163        --libdir=%{_libdir} \
164        --sysconfdir=%{_sysconfdir}/apache2/conf \
165        --includedir=%{_includedir}/apache2 \
166        --libexecdir=%{_libdir}/apache2/modules \
167        --datadir=%{contentdir} \
168        --with-installbuilddir=%{_libdir}/apache2/build \
169        --enable-layout=Vine \
170        --with-program-name=apache2 \
171        --with-ldap \
172        --enable-ldap --enable-authnz-ldap \
173        --enable-mods-shared=all \
174        --enable-cache=shared \
175        --enable-cgi=shared \
176        --enable-cgid=shared \
177        --enable-rewrite=shared \
178        --enable-disk-cache=shared \
179        --enable-file-cache=shared \
180        --enable-mem-cache=shared \
181        --enable-authn-anon --enable-authn-alias \
182        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
183        --enable-suexec --with-suexec \
184        --with-suexec-caller=%{suexec_caller} \
185        --with-suexec-docroot=%{contentdir} \
186        --with-suexec-logfile=%{_localstatedir}/log/apache2/suexec.log \
187        --with-suexec-bin=%{_libdir}/%{pkgname}/suexec \
188        --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
189        --with-pcre \
190        --enable-ssl --with-ssl \
191        --enable-deflate \
192        --enable-proxy --enable-proxy-connect \
193        --enable-proxy-http --enable-proxy-ftp"
194#all  mpm build
195for mpm in %{mpms}; do
196   mkdir mpm-$mpm;
197   cd mpm-$mpm;
198   ../configure $AP_CONFOPTS --with-mpm=$mpm --srcdir=../ ;
199   make %{?_smp_mflags} ;
200#   mv apache2 apache2.$mpm ;
201   cd ../
202done
203
204%install
205rm -rf $RPM_BUILD_ROOT
206
207# install mpms binary
208pushd mpm-prefork
209  make DESTDIR=$RPM_BUILD_ROOT install
210  rm -f $RPM_BUILD_ROOT/%{_sbindir}/apache2
211popd
212
213for mpm in %{mpms}; do
214    install -m755 mpm-$mpm/apache2 $RPM_BUILD_ROOT/%{_sbindir}/apache2.$mpm
215done
216
217# install conf file/directory
218mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d
219install -m 644 $RPM_SOURCE_DIR/README.confd \
220   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/README
221install -m 644 $RPM_SOURCE_DIR/apache-ssl.conf \
222   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/ssl.conf
223
224rm $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/*.conf
225install -m 644 $RPM_SOURCE_DIR/httpd.conf \
226   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/httpd.conf
227
228# mod_ssl bits
229for suffix in crl crt csr key prm; do
230   mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${suffix}
231done
232
233# Makefiles for certificate management
234for ext in crt crl; do
235  install -m 644 $RPM_SOURCE_DIR/mod_ssl-Makefile.${ext} \
236        $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${ext}/Makefile.${ext}
237done
238ln -s ../../../usr/share/ssl/certs/Makefile $RPM_BUILD_ROOT/etc/apache2/conf
239
240# for holding mod_dav lock database
241mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav
242
243# create a prototype session cache
244mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl
245touch $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl/scache.{dir,pag,sem}
246
247# move utilities to /usr/bin
248mv $RPM_BUILD_ROOT%{_sbindir}/{ab,htdbm,logresolve,htpasswd,htdigest} \
249   $RPM_BUILD_ROOT%{_bindir}
250
251# Make the MMN accessible to module packages
252echo %{mmn} > $RPM_BUILD_ROOT%{_includedir}/apache2/.mmn
253
254# docroot
255# mkdir $RPM_BUILD_ROOT%{contentdir}/html
256install -m 644 $RPM_SOURCE_DIR/index.html.ja \
257        $RPM_BUILD_ROOT%{contentdir}/error/noindex.html
258rm -r $RPM_BUILD_ROOT%{contentdir}/manual/style
259
260install -m 644 $RPM_SOURCE_DIR/vine.png \
261        $RPM_BUILD_ROOT%{contentdir}/icons
262
263# logs
264# rmdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/logs
265mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/apache2
266
267ln -sf %{_sysconfdir}/%{pkgname}/conf/httpd.conf $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/conf/apache2.conf
268
269
270# symlinks for /etc/apache2
271ln -s ../..%{_localstatedir}/log/apache2 $RPM_BUILD_ROOT/etc/apache2/logs
272ln -s ../..%{_localstatedir}/run $RPM_BUILD_ROOT/etc/apache2/run
273ln -s ../..%{_libdir}/apache2/modules $RPM_BUILD_ROOT/etc/apache2/modules
274ln -s ../..%{_libdir}/apache2/build $RPM_BUILD_ROOT/etc/apache2/build
275
276# install SYSV init stuff
277mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
278install -m755 $RPM_SOURCE_DIR/apache2.init \
279        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
280%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
281        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
282
283# install log rotation stuff
284mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
285install -m644 $RPM_SOURCE_DIR/apache2.logrotate \
286        $RPM_BUILD_ROOT/etc/logrotate.d/apache2
287
288mv $RPM_BUILD_ROOT/%{_sbindir}/apachectl $RPM_BUILD_ROOT/%{_sbindir}/apache2ctl
289
290# fix man page paths
291sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/apache2/conf/httpd.conf|" \
292    -e "s|/usr/local/apache2/conf/mime.types|/etc/mime.types|" \
293    -e "s|/usr/local/apache2/conf/magic|/etc/apache2/conf/magic|" \
294    -e "s|/usr/local/apache2/logs/error_log|/var/log/apache2/error_log|" \
295    -e "s|/usr/local/apache2/logs/access_log|/var/log/apache2/access_log|" \
296    -e "s|/usr/local/apache2/logs/httpd.pid|/var/run/apache2.pid|" \
297    -e "s|/usr/local/apache2|/etc/httpd|" < $RPM_SOURCE_DIR/apache2.8 \
298  > $RPM_BUILD_ROOT%{_mandir}/man8/apache2.8
299
300install -m644 $RPM_SOURCE_DIR/apache2ctl.8 \
301        $RPM_BUILD_ROOT%{_mandir}/man8/apache2ctl.8
302
303# change command name to avoid conflict with apache1 pacjage
304%define cflcmd /usr/bin/htdigest /usr/bin/htpasswd /usr/sbin/rotatelogs
305
306for i in %{cflcmd}; do \
307  echo $i
308  mv $RPM_BUILD_ROOT$i $RPM_BUILD_ROOT$i"2";
309done;
310
311mv $RPM_BUILD_ROOT/%{_sbindir}/apxs $RPM_BUILD_ROOT/%{_bindir}/apxs
312
313%define cflman usr/share/man/man1/dbmmanage.1 usr/share/man/man1/htdigest.1 usr/share/man/man1/htpasswd.1 usr/share/man/man8/rotatelogs.8 usr/share/man/man8/suexec.8 usr/share/man/man8/apxs.8 usr/share/man/man8/httpd.8
314
315(cd $RPM_BUILD_ROOT;
316for i in %{cflman}; do \
317    echo $i | sed -e "s|\.1|2\.1|" -e "s|\.8|2\.8|" |    xargs mv $i ;
318   
319done;
320)
321
322#cp $RPM_SOURCE_DIR/config_vars.mk $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/build/.
323mv $RPM_BUILD_ROOT/%{_sbindir}/suexec $RPM_BUILD_ROOT/%{_libdir}/%{pkgname}/suexec
324
325
326rm -f $RPM_BUILD_ROOT%{_mandir}/man1/ab*
327rm -f $RPM_BUILD_ROOT%{_mandir}/man1/logresolve*
328# conflict with apache 1, so removed...
329rm -f $RPM_BUILD_ROOT%{_mandir}/man8/ab*
330rm -f $RPM_BUILD_ROOT%{_mandir}/man8/logresolve*
331
332# remove unpackaged files
333rm -f $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/mime.types \
334      $RPM_BUILD_ROOT%{_libdir}/*.la \
335      $RPM_BUILD_ROOT%{_libdir}/*.exp \
336      $RPM_BUILD_ROOT%{_libdir}/apache2/modules/*.exp \
337      $RPM_BUILD_ROOT%{_libdir}/apache2/build/config.nice \
338      $RPM_BUILD_ROOT%{_sbindir}/{apache2,checkgid,dbmmanage,envvars*} \
339      $RPM_BUILD_ROOT%{contentdir}/html/* \
340      $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
341
342%pre
343# Add the "apache" user
344/usr/sbin/useradd -c "Apache" -u 48 \
345        -s /sbin/nologin -r -d %{contentdir} apache 2> /dev/null || :
346
347%triggerpostun -- apache < 2.0
348/sbin/chkconfig --add apache2
349
350
351%post
352# Register the httpd service
353for mpm in %{mpms}; do
354  /sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.$mpm 20;
355done
356/sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.%{prefer_mpm} 30
357/sbin/chkconfig --add apache2
358
359%preun
360if [ $1 = 0 ]; then
361        /sbin/service apache2 stop > /dev/null 2>&1
362        /sbin/chkconfig --del apache2
363        for mpm in %{mpms}; do
364          /sbin/update-alternatives --remove apache2 %{_sbindir}/apache2.$mpm;
365        done 
366fi
367
368%postun
369if [ "$1" -ge 1 ]; then
370        /sbin/service apache2 condrestart
371fi
372/sbin/ldconfig
373
374%post -n mod_ssl-apache2
375/sbin/ldconfig ### is this needed?
376umask 077
377
378if [ ! -f %{_sysconfdir}/apache2/conf/ssl.key/server.key ] ; then
379%{_bindir}/openssl genrsa -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime 1024 > %{_sysconfdir}/apache2/conf/ssl.key/server.key 2> /dev/null
380fi
381
382FQDN=`hostname`
383if [ "x${FQDN}" = "x" ]; then
384   FQDN=localhost.localdomain
385fi
386
387if [ ! -f %{_sysconfdir}/apache2/conf/ssl.crt/server.crt ] ; then
388cat << EOF | %{_bindir}/openssl req -new -key %{_sysconfdir}/apache2/conf/ssl.key/server.key -x509 -days 365 -out %{_sysconfdir}/apache2/conf/ssl.crt/server.crt 2>/dev/null
389--
390SomeState
391SomeCity
392SomeOrganization
393SomeOrganizationalUnit
394${FQDN}
395root@${FQDN}
396EOF
397fi
398
399%clean
400rm -rf $RPM_BUILD_ROOT
401
402%files
403%defattr(-,root,root)
404
405%doc ABOUT_APACHE README CHANGES LAYOUT LICENSE
406%doc migration.html migration.css
407
408%dir %{_sysconfdir}/apache2
409%{_sysconfdir}/apache2/modules
410%{_sysconfdir}/apache2/logs
411%{_sysconfdir}/apache2/run
412%dir %{_sysconfdir}/apache2/conf
413%config(noreplace) %{_sysconfdir}/apache2/conf/*.conf
414%config(noreplace) %{_sysconfdir}/apache2/conf/magic
415
416%config %{_sysconfdir}/logrotate.d/apache2
417%config %{_sysconfdir}/rc.d/init.d/apache2
418
419%dir %{_sysconfdir}/apache2/conf.d
420%{_sysconfdir}/apache2/conf.d/README
421
422%dir %{_sysconfdir}/apache2/conf/extra
423%config %{_sysconfdir}/apache2/conf/extra/*
424
425%dir %{_sysconfdir}/apache2/conf/original
426%{_sysconfdir}/apache2/conf/original/*
427
428%{_bindir}/ab
429%{_bindir}/ht*
430%{_bindir}/logresolve
431%{_sbindir}/ht*
432%{_sbindir}/apache2.*
433%{_sbindir}/apache2ctl
434%{_sbindir}/rotatelogs2
435%attr(4510,root,%{suexec_caller}) %{_libdir}/%{pkgname}/suexec
436
437%dir %{_libdir}/apache2
438%dir %{_libdir}/apache2/modules
439# everything but mod_ssl.so:
440%{_libdir}/apache2/modules/mod_[a-r]*.so
441%{_libdir}/apache2/modules/mod_s[petu]*.so
442%{_libdir}/apache2/modules/mod_[t-z]*.so
443
444%dir %{contentdir}
445%dir %{contentdir}/cgi-bin
446%dir %{contentdir}/html
447%dir %{contentdir}/icons
448%dir %{contentdir}/error
449%dir %{contentdir}/error/include
450%{contentdir}/icons/*
451%{contentdir}/error/README
452%{contentdir}/error/noindex.html
453%config(noreplace) %{contentdir}/error/*.var
454%config(noreplace) %{contentdir}/error/include/*.html
455
456%attr(0700,root,root) %dir %{_localstatedir}/log/apache2
457
458%attr(0700,apache,apache) %dir %{_localstatedir}/lib/dav
459
460%{_mandir}/man1/*
461
462%{_mandir}/man8/*
463
464%files manual
465%defattr(-,root,root)
466%{contentdir}/manual
467
468%files -n mod_ssl-apache2
469%defattr(-,root,root)
470%{_libdir}/apache2/modules/mod_ssl.so
471%config(noreplace) %{_sysconfdir}/apache2/conf.d/ssl.conf
472%attr(0700,root,root) %dir %{_sysconfdir}/apache2/conf/ssl.*
473%config %{_sysconfdir}/apache2/conf/Makefile
474%config %{_sysconfdir}/apache2/conf/ssl.*/*
475%attr(0700,apache,root) %dir %{_localstatedir}/cache/mod_ssl
476%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.dir
477%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.pag
478%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.sem
479
480%files devel
481%defattr(-,root,root)
482%{_includedir}/apache2
483%{_sysconfdir}/apache2/build
484%{_bindir}/apxs
485%{_mandir}/man?/apxs*
486%{_libdir}/apache2/build/*.mk
487%{_libdir}/apache2/build/*.sh
488
489%changelog
490* Wed Oct  4 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.34-1
491- new upstream release 2.2.34
492- add patch1010 for fix CVE-2017-9798
493- drop patch1000 (is included in new release)
494
495* Fri Jul 22 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.31-3
496- added Patch1000 to fix CVE-2016-5387.
497
498* Wed Mar  2 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.31-2
499- rebuilt with openssl 1.0.1s (no sslv2)
500
501* Sun Aug  2 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.31-1
502- new upstream release with security fixes
503
504* Sat Jan  3 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.29-1
505- new upstream release with security fixes
506  (drop patch100-120, which are included in new release)
507
508* Wed Aug 13 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.27-2
509- add Patch100 for fix CVE-2014-0118 (mod_deflate)
510- add Patch110 for fix CVE-2014-0226 (mod_status)
511- add Patch120 for fix CVE-2014-0231 (mod_cgid)
512  these patches are from debian wheezy, thanks
513
514* Fri Mar 28 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.27-1
515- new upstream release with security fix (CVE-2013-6438, 2014-0098)
516
517* Fri Jan 24 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.26-1
518- new upstream release
519
520* Sat Sep 28 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.25-1
521- new upstream release with security fix (CVE-2013-1862,1896)
522- drop patch100 (is included in new release)
523
524* Fri May 17 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-2
525- add patch100 for fix CVE-2013-1862 (mod_rewrite)
526
527* Wed Feb 27 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-1
528- new upstream release with security fix (CVE-2012-3499, 4558)
529
530* Sun Sep 16 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.23-1
531- new upstream release with security fix (CVE-2012-3502,CVE-2012-2687)
532- update patch22 to fit new release
533- update man filename convert list
534
535* Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.22-1
536- update to 2.2.22
537  - CVE-2012-0021 (mod_log_config)
538  - CVE-2012-0031
539  - CVE-2012-0053
540- remove upstreamed patches
541
542* Fri Dec  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-5
543- add patch120 for fix CVE-2011-4317 (mod_rewrite/mod_proxy)
544
545* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-4
546- add patch110 for fix CVE-2011-3607-4415 (ModSetEnvIf)
547
548* Wed Oct 12 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-3
549- add patch70 for fix byterange filter
550
551* Tue Oct 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-2
552- add Patch100 for fix CVE-2011-3368 (mod_proxy)
553
554* Wed Sep 14 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-1
555- new upstream release with security fix (CVE-2011-3348)
556- regression fixes of CVE-2011-3192 byterange fix in 2.2.20
557
558* Tue Sep  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-3
559- update Patch101 (Thanks to debian team)
560
561* Sat Sep  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-2
562- add Patch101 for fix CVE-2011-3192 regression
563
564* Thu Sep  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-1
565- new upstream release with security fix (CVE-2011-3192)
566- drop patch100 (is included in new release)
567
568* Thu Aug 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.19-2
569- add patch100 for fix CVE-2011-3192 (Range Header DoS)
570
571* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.19-1
572- update to 2.2.19
573
574* Sat Apr 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-9
575- remove old Obsoletes/Conflicts
576
577* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-8
578- rebuild with openssl-1.0.0c
579
580* Sat Aug 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.14-7
581- add  patch120 for fix CVE-2010-1452 (mod_dav/mod_cache) from mdk2010
582
583* Wed Aug 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-6
584- add R(post): alternatives
585
586* Sat Mar 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-5
587- add patch110 for fix CVE-2010-0434 from mdk 2010
588
589* Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-4
590- add patch100 for fix CVE-2010-0408 (mod_proxy_ajp)
591
592* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.14-3
593- rebuilt with rpm-4.8.0-3 (on ppc)
594
595* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-2
596- rebuild with db4-4.8.0
597
598* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-1
599- new upstream release with security fix
600  (CVE-2009-2699, CVE-2009-3095, CVE-2009-3094)
601- fix ssl.conf (2.2.13-1 includes wrong file)
602
603* Sun Aug 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.13-1
604- new upstream release
605
606* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.12-1
607- new upstream release
608  (including security fix for CVE-2009-1890, CVE-2009-1191,
609   CVE-2009-1195, CVE-2009-1955, CVE-2009-1956, CVE-2009-0023)
610
611* Fri Jan 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-2
612- rebuilt with openldap-2.4.11
613
614* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-1
615- new upstream release
616
617* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-1
618- new upstream release (including security fix for CVE-2008-2939)
619
620* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-1
621- new upstream release (including security fix for CVE-2008-2364, CVE-2007-6420)
622- built with db4-4.6.21, apr 1.3.0
623
624* Sun Apr 27 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.8-1
625- add Patch60 (to fix bug#31418).
626
627* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.8-0vl2
628- rebuild with expat-2.0.1
629
630* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
631- new upstream release
632
633* Sat Nov  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-0vl2
634- added postun script from VinePlus/4.0 package
635  * Tue Sep 11 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.3-0vl3.2
636  - add postun script to restart daemon with message
637
638* Sun Jul 01 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl8
639- updated Patch2: httpd-2.2.3-apxs.patch
640
641* Sun Jun 24 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl7
642- modified libdir in config.layout for lib64 architecture
643
644* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
645- rebuilt with openssl-0.9.8e
646
647* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl5
648- rebuilt with new toolchain and db4-4.3.x
649
650* Tue Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl4
651- added BuildRequires: pcre-devel, sqlite3-devel <BTS:VineLinux:474>
652
653* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.3-0vl3
654- change manual Group to Applications/Documentation. <BTS:VineLinux:163>
655
656* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl2
657- rebuilt with openldap-2.3.27-0vl1
658
659* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
660- new upstream release including security fix (CVE-2006-3747)
661
662* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
663- new upstream release
664  - update to 2.2.2
665- remove apr/apr-devel subpackage,
666  use external apr/apr-util instead of internal one.
667
668* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.58-0vl1
669- new upstream release
670- use apache2.prefork as default.
671
672* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl3
673- rebuild to use new _localstatedir (rpm-4.4.2-0vl11)
674- remove unpackaged files in %%install section
675
676* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl2
677- fix logrotate configuration (use apache2.pid instead of httpd.pid)
678  (BTS:10)
679- use Epoch instead of Serial
680
681* Sat Oct 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl1
682- new upstream release
683- drop obsolete security patches which is merged in upstream
684
685* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.54-0vl1
686- new upstream release
687
688* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl2
689- added Patch122 to 125 for secutiry fix
690  (CAN-2004-{1268,2088,2700,2728})
691- fix %install section
692
693* Sun Apr 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl1
694- new upstream release
695
696* Sat Nov 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.52-0vl1
697- new upstream release
698
699* Sun Oct 24 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.50-0vl4
700- rebuilt with db4-4.2.52
701
702* Sat Sep  4 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.0.50-0vl3
703- separate apr, apr-devel packages
704- add BuildPreReq: zlib-devel
705
706* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.50-0vl2
707- fix %%files to include instdso.sh
708  thanks to jax <jax AT morejams DOT no-ip DOT com>
709- add %%{?_smp_mflags} to make option.
710
711* Sun Jul  4 2004 IWAI, Masaharu <iwai@alib.jp> 2.0.50-0vl1
712- new upstream version
713
714* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.48-0vl1
715- new upstream version
716
717* Mon Sep 15 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.47-0vl1
718- new upstream version
719- update apxs patch (Patch101)
720- fix dependency:
721    - change file name to package name in Requires and {Build,}Prereq
722- add BuildPrereq: openldap-devel
723- update %%files section
724- rename httpd.8 manpage
725
726* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.45-0vl1
727- new upstream version
728- used vine-config.layout in srclib
729
730* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.44-0vl9
731- rebuild
732
733* Sun Apr  6 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl8
734- change pkg name from mod_ssl to mod_ssl-apache2
735- remove "apache-manual" entry from Obsoletes:
736
737* Thu Apr  3 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl7
738- remove "mod_dav" and "apache-devel" from Obsoletes:
739- enable MPMS(worker %mpms )
740
741* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl6
742- add correct config_vars.mk
743
744* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl5
745- apply apxs's patch ( from Debian)
746
747* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl4
748- add apr-config,apu-config to devel's %file
749
750* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl3
751- change apxs path ( /usr/sbin -> /usr/bin
752- add symlink under /etc/apache2/conf
753  (logs, run), httpd.conf -> apache2.conf
754- fixed apache2 initscript.
755
756* Sat Mar 29 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl2
757- build Vine Linux
758- new upstream version
759- sharing with apache1
760
761* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
762- link httpd with libssl to avoid library loading/unloading weirdness
763
764* Tue Sep  3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
765- add LoadModule lines for proxy modules in httpd.conf (#73349)
766- fix permissions of conf/ssl.*/ directories; add Makefiles for
767  certificate management (#73352)
768
769* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
770- provide "httpd-mmn" to manage module ABI compatibility
771
772* Sun Sep  1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
773- fix SSL session cache (#69699)
774- revert addition of LDAP support to apr-util
775
776* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
777- set SIGXFSZ disposition to "ignored" (#69520)
778- make dummy connections to the first listener in config (#72692)
779
780* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
781- allow "apachectl configtest" on a 1.3 httpd.conf
782- add mod_deflate
783- enable LDAP support in apr-util
784- don't package everything in /var/www/error as config(noreplace)
785
786* Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
787- add trigger (#68657)
788
789* Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
790- update to 2.0.40
791
792* Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
793- improve comment on use of UserDir in default config (#66886)
794
795* Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
796- use /sbin/nologin as shell for apache user (#68371)
797- add patch from CVS to fix possible infinite loop when processing
798  internal redirects
799
800* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
801- modify init script to detect 1.3.x httpd.conf's and direct users
802  to the migration guide
803
804* Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
805- patch apachectl to detect 1.3.x httpd.conf's and direct users
806  to the migration guide
807- ship the migration guide
808
809* Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
810- move /etc/httpd2 back to /etc/httpd
811- add noindex.html page and poweredby logo; tweak default config
812  to load noindex.html if no default "/" page is present.
813- add patch to prevent mutex errors on graceful restart
814
815* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
816- automated rebuild
817
818* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
819- add patch to fix SSL mutex handling
820
821* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
822- improved config directory patch
823
824* Mon May 20 2002 Joe Orton <jorton@redhat.com>
825- initial build; based heavily on apache.spec and mod_ssl.spec
826- fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245
827
Note: See TracBrowser for help on using the repository browser.