source: projects/specs/branches/6/a/apache2/apache2-vl.spec @ 4953

Revision 4953, 25.0 KB checked in by iwamoto, 13 years ago (diff)

apache2: fix CVE-2011-3368/byterange issue

Line 
1%define contentdir /var/www
2%define suexec_caller apache
3%define mmn 20051115
4%define pkgname apache2
5
6Summary: Apache HTTP Server
7Name: %{pkgname}
8Version: 2.2.21
9Release: 3%{_dist_release}
10URL: http://httpd.apache.org/
11
12Vendor: Project Vine
13Distribution: Vine Linux
14Packager: daisuke
15
16Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
17Source1: index.html.ja
18Source3: apache2.logrotate
19Source4: apache2.init
20Source5: README.confd
21Source6: vine.png
22Source10: httpd.conf
23Source11: apache-ssl.conf
24Source12: migration.html
25Source13: migration.css
26Source14: mod_ssl-Makefile.crt
27Source15: mod_ssl-Makefile.crl
28# add vine entry to config.layout
29Source100: vine-config.layout
30# man files
31Source101: apache2.8
32Source102: apache2ctl.8
33#Source103: config_vars.mk
34# build/scripts patches
35Patch1: httpd-2.1.10-apctl.patch
36Patch2: httpd-2.2.3-apxs.patch
37Patch3: httpd-2.0.45-deplibs.patch
38Patch4: httpd-2.1.10-disablemods.patch
39# features/functional changes
40Patch21: httpd-2.0.40-xfsz.patch
41Patch22: httpd-2.1.10-pod.patch
42Patch23: httpd-2.0.45-export.patch
43Patch24: httpd-2.0.48-corelimit.patch
44# Bug fixes
45Patch54: httpd-2.2.0-authnoprov.patch
46Patch60: httpd-2.2.3-sslusername.patch
47Patch70: apache2-2.2.21-byterange_fix_1177080.patch
48
49# Security fixes
50# Patch100: httpd-2.2.19_CVE-2011-3192.patch
51# Patch101: httpd-2.2.20_CVE-2011-3192_regression_2.patch
52Patch100: apache2-2.2.21_CVE-2011-3368.patch
53
54License: Apache Software License
55Group: System Environment/Daemons
56BuildRoot: %{_tmppath}/%{name}-%{version}-root
57BuildRequires: db4-devel, expat-devel
58BuildRequires: findutils, perl, openldap-devel, zlib-devel
59BuildRequires: apr-devel, apr-util-devel
60BuildRequires: pcre-devel, sqlite3-devel
61Requires: mailcap, gawk, file, findutils, apr, apr-util
62Requires(pre): chkconfig, mktemp, fileutils
63Requires(pre): sh-utils, textutils, shadow-utils
64Requires(post): alternatives
65Provides: webserver
66Provides: httpd = %{version}
67Provides: httpd-mmn = %{mmn}
68Obsoletes: apache2-apr, apache2-apr-devel
69
70%description
71Apache is a powerful, full-featured, efficient, and freely-available
72Web server. Apache is also the most popular Web server on the
73Internet.
74
75%package devel
76Group: Development/Libraries
77Summary: Development tools for the Apache HTTP server.
78Requires: libtool, httpd = %{version}
79Requires: apr-devel, apr-util-devel
80
81%description devel
82The httpd-devel package contains the APXS binary and other files
83that you need to build Dynamic Shared Objects (DSOs) for Apache.
84
85If you are installing the Apache HTTP server and you want to be
86able to compile or develop additional modules for Apache, you need
87to install this package.
88
89%package manual
90Group: Applications/Documentation
91Summary: Documentation for the Apache HTTP server.
92
93%description manual
94The httpd-manual package contains the complete manual and
95reference guide for the Apache HTTP server. The information can
96also be found at http://httpd.apache.org/docs/.
97
98%package -n mod_ssl-apache2
99Group: System Environment/Daemons
100Summary: SSL/TLS module for the Apache HTTP server
101Epoch: 1
102BuildRequires: openssl-devel
103Requires(pre): openssl, dev, /bin/cat
104Requires: httpd, make, httpd-mmn = %{mmn}
105
106%description -n mod_ssl-apache2
107The mod_ssl module provides strong cryptography for the Apache Web
108server via the Secure Sockets Layer (SSL) and Transport Layer
109Security (TLS) protocols.
110
111%prep
112%setup -q -n httpd-%{version}
113
114%patch1 -p1 -b .apctl
115%patch2 -p1 -b .apxs
116#patch3 -p1 -b .deplibs
117%patch4 -p1 -b .disablemods
118
119%patch21 -p0 -b .xfsz
120%patch22 -p1 -b .pod
121%patch23 -p1 -b .export
122%patch24 -p1 -b .corelimit
123
124%patch54 -p1 -b .authnoprov
125%patch60 -p1 -b .sslusername
126%patch70 -p4 -b .byterange_fix_1177080
127
128# %patch100 -p1 -b .CVE-2011-3192
129# %patch101 -p1 -b .CVE-2011-3192_regression
130%patch100 -p1 -b .CVE-2011-3368
131
132# copy across the migration guide and sed it's location into apachectl
133cp $RPM_SOURCE_DIR/migration.{html,css} .
134%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
135        support/apachectl.in
136
137
138# add Vine configure's option to config.layout
139sed -e "s|${prefix}/lib|${prefix}/%{_lib}|" \
140  < $RPM_SOURCE_DIR/vine-config.layout >> config.layout
141
142# regenerate configure scripts
143./buildconf
144
145%build
146# remove bundled apr, apr-util, pcre
147rm -rf srclib/{apr,apr-util,pcre}
148
149#CFLAGS="$RPM_OPT_FLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
150#AP_LIBS="-lssl -lcrypto"
151#export CFLAGS AP_LIBS
152CFLAGS="$RPM_OPT_FLAGS"
153SH_LDFLAGS="-Wl,-z,relro"
154export CFLAGS SH_LDFLAGS
155
156%define mpms worker prefork
157%define prefer_mpm prefork
158
159AP_CONFOPTS="\
160        --prefix=%{_sysconfdir}/apache2 \
161        --exec-prefix=%{_prefix} \
162        --bindir=%{_bindir} \
163        --sbindir=%{_sbindir} \
164        --mandir=%{_mandir} \
165        --libdir=%{_libdir} \
166        --sysconfdir=%{_sysconfdir}/apache2/conf \
167        --includedir=%{_includedir}/apache2 \
168        --libexecdir=%{_libdir}/apache2/modules \
169        --datadir=%{contentdir} \
170        --with-installbuilddir=%{_libdir}/apache2/build \
171        --enable-layout=Vine \
172        --with-program-name=apache2 \
173        --with-ldap \
174        --enable-ldap --enable-authnz-ldap \
175        --enable-mods-shared=all \
176        --enable-cache=shared \
177        --enable-cgi=shared \
178        --enable-cgid=shared \
179        --enable-rewrite=shared \
180        --enable-disk-cache=shared \
181        --enable-file-cache=shared \
182        --enable-mem-cache=shared \
183        --enable-authn-anon --enable-authn-alias \
184        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
185        --enable-suexec --with-suexec \
186        --with-suexec-caller=%{suexec_caller} \
187        --with-suexec-docroot=%{contentdir} \
188        --with-suexec-logfile=%{_localstatedir}/log/apache2/suexec.log \
189        --with-suexec-bin=%{_libdir}/%{pkgname}/suexec \
190        --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
191        --with-pcre \
192        --enable-ssl --with-ssl \
193        --enable-deflate \
194        --enable-proxy --enable-proxy-connect \
195        --enable-proxy-http --enable-proxy-ftp"
196#all  mpm build
197for mpm in %{mpms}; do
198   mkdir mpm-$mpm;
199   cd mpm-$mpm;
200   ../configure $AP_CONFOPTS --with-mpm=$mpm --srcdir=../ ;
201   make %{?_smp_mflags} ;
202#   mv apache2 apache2.$mpm ;
203   cd ../
204done
205
206%install
207rm -rf $RPM_BUILD_ROOT
208
209# Classify ab and logresolve as section 1 commands, as they are in /usr/bin
210cp -p docs/man/ab.8 docs/man/ab.1
211sed -e "1s/logresolve 8/logresolve 1/" \
212  < docs/man/logresolve.8 > docs/man/logresolve.1
213#rm docs/man/logresolve.8
214
215# install mpms binary
216pushd mpm-prefork
217  make DESTDIR=$RPM_BUILD_ROOT install
218  rm -f $RPM_BUILD_ROOT/%{_sbindir}/apache2
219popd
220
221for mpm in %{mpms}; do
222    install -m755 mpm-$mpm/apache2 $RPM_BUILD_ROOT/%{_sbindir}/apache2.$mpm
223done
224
225# install conf file/directory
226mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d
227install -m 644 $RPM_SOURCE_DIR/README.confd \
228   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/README
229install -m 644 $RPM_SOURCE_DIR/apache-ssl.conf \
230   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/ssl.conf
231
232rm $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/*.conf
233install -m 644 $RPM_SOURCE_DIR/httpd.conf \
234   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/httpd.conf
235
236# mod_ssl bits
237for suffix in crl crt csr key prm; do
238   mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${suffix}
239done
240
241# Makefiles for certificate management
242for ext in crt crl; do
243  install -m 644 $RPM_SOURCE_DIR/mod_ssl-Makefile.${ext} \
244        $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${ext}/Makefile.${ext}
245done
246ln -s ../../../usr/share/ssl/certs/Makefile $RPM_BUILD_ROOT/etc/apache2/conf
247
248# for holding mod_dav lock database
249mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav
250
251# create a prototype session cache
252mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl
253touch $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl/scache.{dir,pag,sem}
254
255# move utilities to /usr/bin
256mv $RPM_BUILD_ROOT%{_sbindir}/{ab,htdbm,logresolve,htpasswd,htdigest} \
257   $RPM_BUILD_ROOT%{_bindir}
258
259# Make the MMN accessible to module packages
260echo %{mmn} > $RPM_BUILD_ROOT%{_includedir}/apache2/.mmn
261
262# docroot
263# mkdir $RPM_BUILD_ROOT%{contentdir}/html
264install -m 644 $RPM_SOURCE_DIR/index.html.ja \
265        $RPM_BUILD_ROOT%{contentdir}/error/noindex.html
266rm -r $RPM_BUILD_ROOT%{contentdir}/manual/style
267
268install -m 644 $RPM_SOURCE_DIR/vine.png \
269        $RPM_BUILD_ROOT%{contentdir}/icons
270
271# logs
272# rmdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/logs
273mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/apache2
274
275ln -sf %{_sysconfdir}/%{pkgname}/conf/httpd.conf $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/conf/apache2.conf
276
277
278# symlinks for /etc/apache2
279ln -s ../..%{_localstatedir}/log/apache2 $RPM_BUILD_ROOT/etc/apache2/logs
280ln -s ../..%{_localstatedir}/run $RPM_BUILD_ROOT/etc/apache2/run
281ln -s ../..%{_libdir}/apache2/modules $RPM_BUILD_ROOT/etc/apache2/modules
282ln -s ../..%{_libdir}/apache2/build $RPM_BUILD_ROOT/etc/apache2/build
283
284# install SYSV init stuff
285mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
286install -m755 $RPM_SOURCE_DIR/apache2.init \
287        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
288%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
289        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
290
291# install log rotation stuff
292mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
293install -m644 $RPM_SOURCE_DIR/apache2.logrotate \
294        $RPM_BUILD_ROOT/etc/logrotate.d/apache2
295
296mv $RPM_BUILD_ROOT/%{_sbindir}/apachectl $RPM_BUILD_ROOT/%{_sbindir}/apache2ctl
297
298# fix man page paths
299sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/apache2/conf/httpd.conf|" \
300    -e "s|/usr/local/apache2/conf/mime.types|/etc/mime.types|" \
301    -e "s|/usr/local/apache2/conf/magic|/etc/apache2/conf/magic|" \
302    -e "s|/usr/local/apache2/logs/error_log|/var/log/apache2/error_log|" \
303    -e "s|/usr/local/apache2/logs/access_log|/var/log/apache2/access_log|" \
304    -e "s|/usr/local/apache2/logs/httpd.pid|/var/run/apache2.pid|" \
305    -e "s|/usr/local/apache2|/etc/httpd|" < $RPM_SOURCE_DIR/apache2.8 \
306  > $RPM_BUILD_ROOT%{_mandir}/man8/apache2.8
307
308install -m644 $RPM_SOURCE_DIR/apache2ctl.8 \
309        $RPM_BUILD_ROOT%{_mandir}/man8/apache2ctl.8
310
311# change command name to avoid conflict with apache1 pacjage
312%define cflcmd /usr/bin/htdigest /usr/bin/htpasswd /usr/sbin/rotatelogs
313
314for i in %{cflcmd}; do \
315  echo $i
316  mv $RPM_BUILD_ROOT$i $RPM_BUILD_ROOT$i"2";
317done;
318
319mv $RPM_BUILD_ROOT/%{_sbindir}/apxs $RPM_BUILD_ROOT/%{_bindir}/apxs
320
321%define cflman usr/share/man/man1/dbmmanage.1 usr/share/man/man1/htdigest.1 usr/share/man/man1/htpasswd.1 usr/share/man/man8/rotatelogs.8 usr/share/man/man8/suexec.8 usr/share/man/man8/apxs.8 usr/share/man/man8/httpd.8
322
323(cd $RPM_BUILD_ROOT;
324for i in %{cflman}; do \
325    echo $i | sed -e "s|\.1|2\.1|" -e "s|\.8|2\.8|" |    xargs mv $i ;
326   
327done;
328)
329
330#cp $RPM_SOURCE_DIR/config_vars.mk $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/build/.
331mv $RPM_BUILD_ROOT/%{_sbindir}/suexec $RPM_BUILD_ROOT/%{_libdir}/%{pkgname}/suexec
332
333
334rm -f $RPM_BUILD_ROOT%{_mandir}/man1/ab*
335rm -f $RPM_BUILD_ROOT%{_mandir}/man1/logresolve*
336# conflict with apache 1, so removed...
337rm -f $RPM_BUILD_ROOT%{_mandir}/man8/ab*
338rm -f $RPM_BUILD_ROOT%{_mandir}/man8/logresolve*
339
340# remove unpackaged files
341rm -f $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/mime.types \
342      $RPM_BUILD_ROOT%{_libdir}/*.la \
343      $RPM_BUILD_ROOT%{_libdir}/*.exp \
344      $RPM_BUILD_ROOT%{_libdir}/apache2/modules/*.exp \
345      $RPM_BUILD_ROOT%{_libdir}/apache2/build/config.nice \
346      $RPM_BUILD_ROOT%{_sbindir}/{apache2,checkgid,dbmmanage,envvars*} \
347      $RPM_BUILD_ROOT%{contentdir}/html/* \
348      $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
349
350%pre
351# Add the "apache" user
352/usr/sbin/useradd -c "Apache" -u 48 \
353        -s /sbin/nologin -r -d %{contentdir} apache 2> /dev/null || :
354
355%triggerpostun -- apache < 2.0
356/sbin/chkconfig --add apache2
357
358
359%post
360# Register the httpd service
361for mpm in %{mpms}; do
362  /sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.$mpm 20;
363done
364/sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.%{prefer_mpm} 30
365/sbin/chkconfig --add apache2
366
367%preun
368if [ $1 = 0 ]; then
369        /sbin/service apache2 stop > /dev/null 2>&1
370        /sbin/chkconfig --del apache2
371        for mpm in %{mpms}; do
372          /sbin/update-alternatives --remove apache2 %{_sbindir}/apache2.$mpm;
373        done 
374fi
375
376%postun
377if [ "$1" -ge 1 ]; then
378        /sbin/service apache2 condrestart
379fi
380/sbin/ldconfig
381
382%post -n mod_ssl-apache2
383/sbin/ldconfig ### is this needed?
384umask 077
385
386if [ ! -f %{_sysconfdir}/apache2/conf/ssl.key/server.key ] ; then
387%{_bindir}/openssl genrsa -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime 1024 > %{_sysconfdir}/apache2/conf/ssl.key/server.key 2> /dev/null
388fi
389
390FQDN=`hostname`
391if [ "x${FQDN}" = "x" ]; then
392   FQDN=localhost.localdomain
393fi
394
395if [ ! -f %{_sysconfdir}/apache2/conf/ssl.crt/server.crt ] ; then
396cat << EOF | %{_bindir}/openssl req -new -key %{_sysconfdir}/apache2/conf/ssl.key/server.key -x509 -days 365 -out %{_sysconfdir}/apache2/conf/ssl.crt/server.crt 2>/dev/null
397--
398SomeState
399SomeCity
400SomeOrganization
401SomeOrganizationalUnit
402${FQDN}
403root@${FQDN}
404EOF
405fi
406
407%clean
408rm -rf $RPM_BUILD_ROOT
409
410%files
411%defattr(-,root,root)
412
413%doc ABOUT_APACHE README CHANGES LAYOUT LICENSE
414%doc migration.html migration.css
415
416%dir %{_sysconfdir}/apache2
417%{_sysconfdir}/apache2/modules
418%{_sysconfdir}/apache2/logs
419%{_sysconfdir}/apache2/run
420%dir %{_sysconfdir}/apache2/conf
421%config(noreplace) %{_sysconfdir}/apache2/conf/*.conf
422%config(noreplace) %{_sysconfdir}/apache2/conf/magic
423
424%config %{_sysconfdir}/logrotate.d/apache2
425%config %{_sysconfdir}/rc.d/init.d/apache2
426
427%dir %{_sysconfdir}/apache2/conf.d
428%{_sysconfdir}/apache2/conf.d/README
429
430%dir %{_sysconfdir}/apache2/conf/extra
431%config %{_sysconfdir}/apache2/conf/extra/*
432
433%dir %{_sysconfdir}/apache2/conf/original
434%{_sysconfdir}/apache2/conf/original/*
435
436%{_bindir}/ab
437%{_bindir}/ht*
438%{_bindir}/logresolve
439%{_sbindir}/ht*
440%{_sbindir}/apache2.*
441%{_sbindir}/apache2ctl
442%{_sbindir}/rotatelogs2
443%attr(4510,root,%{suexec_caller}) %{_libdir}/%{pkgname}/suexec
444
445%dir %{_libdir}/apache2
446%dir %{_libdir}/apache2/modules
447# everything but mod_ssl.so:
448%{_libdir}/apache2/modules/mod_[a-r]*.so
449%{_libdir}/apache2/modules/mod_s[petu]*.so
450%{_libdir}/apache2/modules/mod_[t-z]*.so
451
452%dir %{contentdir}
453%dir %{contentdir}/cgi-bin
454%dir %{contentdir}/html
455%dir %{contentdir}/icons
456%dir %{contentdir}/error
457%dir %{contentdir}/error/include
458%{contentdir}/icons/*
459%{contentdir}/error/README
460%{contentdir}/error/noindex.html
461%config(noreplace) %{contentdir}/error/*.var
462%config(noreplace) %{contentdir}/error/include/*.html
463
464%attr(0700,root,root) %dir %{_localstatedir}/log/apache2
465
466%attr(0700,apache,apache) %dir %{_localstatedir}/lib/dav
467
468%{_mandir}/man1/*
469
470%{_mandir}/man8/*
471
472%files manual
473%defattr(-,root,root)
474%{contentdir}/manual
475
476%files -n mod_ssl-apache2
477%defattr(-,root,root)
478%{_libdir}/apache2/modules/mod_ssl.so
479%config(noreplace) %{_sysconfdir}/apache2/conf.d/ssl.conf
480%attr(0700,root,root) %dir %{_sysconfdir}/apache2/conf/ssl.*
481%config %{_sysconfdir}/apache2/conf/Makefile
482%config %{_sysconfdir}/apache2/conf/ssl.*/*
483%attr(0700,apache,root) %dir %{_localstatedir}/cache/mod_ssl
484%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.dir
485%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.pag
486%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.sem
487
488%files devel
489%defattr(-,root,root)
490%{_includedir}/apache2
491%{_sysconfdir}/apache2/build
492%{_bindir}/apxs
493%{_mandir}/man8/apxs*
494%{_libdir}/apache2/build/*.mk
495%{_libdir}/apache2/build/*.sh
496
497%changelog
498* Wed Oct 12 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-3
499- add patch70 for fix byterange filter
500
501* Tue Oct 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-2
502- add Patch100 for fix CVE-2011-3368 (mod_proxy)
503
504* Wed Sep 14 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-1
505- new upstream release with security fix (CVE-2011-3348)
506- regression fixes of CVE-2011-3192 byterange fix in 2.2.20
507
508* Tue Sep  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-3
509- update Patch101 (Thanks to debian team)
510
511* Sat Sep  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-2
512- add Patch101 for fix CVE-2011-3192 regression
513
514* Thu Sep  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-1
515- new upstream release with security fix (CVE-2011-3192)
516- drop patch100 (is included in new release)
517
518* Thu Aug 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.19-2
519- add patch100 for fix CVE-2011-3192 (Range Header DoS)
520
521* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.19-1
522- update to 2.2.19
523
524* Sat Apr 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-9
525- remove old Obsoletes/Conflicts
526
527* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-8
528- rebuild with openssl-1.0.0c
529
530* Sat Aug 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.14-7
531- add  patch120 for fix CVE-2010-1452 (mod_dav/mod_cache) from mdk2010
532
533* Wed Aug 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-6
534- add R(post): alternatives
535
536* Sat Mar 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-5
537- add patch110 for fix CVE-2010-0434 from mdk 2010
538
539* Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-4
540- add patch100 for fix CVE-2010-0408 (mod_proxy_ajp)
541
542* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.14-3
543- rebuilt with rpm-4.8.0-3 (on ppc)
544
545* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-2
546- rebuild with db4-4.8.0
547
548* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-1
549- new upstream release with security fix
550  (CVE-2009-2699, CVE-2009-3095, CVE-2009-3094)
551- fix ssl.conf (2.2.13-1 includes wrong file)
552
553* Sun Aug 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.13-1
554- new upstream release
555
556* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.12-1
557- new upstream release
558  (including security fix for CVE-2009-1890, CVE-2009-1191,
559   CVE-2009-1195, CVE-2009-1955, CVE-2009-1956, CVE-2009-0023)
560
561* Fri Jan 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-2
562- rebuilt with openldap-2.4.11
563
564* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-1
565- new upstream release
566
567* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-1
568- new upstream release (including security fix for CVE-2008-2939)
569
570* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-1
571- new upstream release (including security fix for CVE-2008-2364, CVE-2007-6420)
572- built with db4-4.6.21, apr 1.3.0
573
574* Sun Apr 27 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.8-1
575- add Patch60 (to fix bug#31418).
576
577* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.8-0vl2
578- rebuild with expat-2.0.1
579
580* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
581- new upstream release
582
583* Sat Nov  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-0vl2
584- added postun script from VinePlus/4.0 package
585  * Tue Sep 11 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.3-0vl3.2
586  - add postun script to restart daemon with message
587
588* Sun Jul 01 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl8
589- updated Patch2: httpd-2.2.3-apxs.patch
590
591* Sun Jun 24 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl7
592- modified libdir in config.layout for lib64 architecture
593
594* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
595- rebuilt with openssl-0.9.8e
596
597* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl5
598- rebuilt with new toolchain and db4-4.3.x
599
600* Tue Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl4
601- added BuildRequires: pcre-devel, sqlite3-devel <BTS:VineLinux:474>
602
603* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.3-0vl3
604- change manual Group to Applications/Documentation. <BTS:VineLinux:163>
605
606* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl2
607- rebuilt with openldap-2.3.27-0vl1
608
609* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
610- new upstream release including security fix (CVE-2006-3747)
611
612* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
613- new upstream release
614  - update to 2.2.2
615- remove apr/apr-devel subpackage,
616  use external apr/apr-util instead of internal one.
617
618* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.58-0vl1
619- new upstream release
620- use apache2.prefork as default.
621
622* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl3
623- rebuild to use new _localstatedir (rpm-4.4.2-0vl11)
624- remove unpackaged files in %%install section
625
626* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl2
627- fix logrotate configuration (use apache2.pid instead of httpd.pid)
628  (BTS:10)
629- use Epoch instead of Serial
630
631* Sat Oct 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl1
632- new upstream release
633- drop obsolete security patches which is merged in upstream
634
635* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.54-0vl1
636- new upstream release
637
638* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl2
639- added Patch122 to 125 for secutiry fix
640  (CAN-2004-{1268,2088,2700,2728})
641- fix %install section
642
643* Sun Apr 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl1
644- new upstream release
645
646* Sat Nov 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.52-0vl1
647- new upstream release
648
649* Sun Oct 24 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.50-0vl4
650- rebuilt with db4-4.2.52
651
652* Sat Sep  4 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.0.50-0vl3
653- separate apr, apr-devel packages
654- add BuildPreReq: zlib-devel
655
656* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.50-0vl2
657- fix %%files to include instdso.sh
658  thanks to jax <jax AT morejams DOT no-ip DOT com>
659- add %%{?_smp_mflags} to make option.
660
661* Sun Jul  4 2004 IWAI, Masaharu <iwai@alib.jp> 2.0.50-0vl1
662- new upstream version
663
664* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.48-0vl1
665- new upstream version
666
667* Mon Sep 15 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.47-0vl1
668- new upstream version
669- update apxs patch (Patch101)
670- fix dependency:
671    - change file name to package name in Requires and {Build,}Prereq
672- add BuildPrereq: openldap-devel
673- update %%files section
674- rename httpd.8 manpage
675
676* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.45-0vl1
677- new upstream version
678- used vine-config.layout in srclib
679
680* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.44-0vl9
681- rebuild
682
683* Sun Apr  6 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl8
684- change pkg name from mod_ssl to mod_ssl-apache2
685- remove "apache-manual" entry from Obsoletes:
686
687* Thu Apr  3 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl7
688- remove "mod_dav" and "apache-devel" from Obsoletes:
689- enable MPMS(worker %mpms )
690
691* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl6
692- add correct config_vars.mk
693
694* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl5
695- apply apxs's patch ( from Debian)
696
697* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl4
698- add apr-config,apu-config to devel's %file
699
700* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl3
701- change apxs path ( /usr/sbin -> /usr/bin
702- add symlink under /etc/apache2/conf
703  (logs, run), httpd.conf -> apache2.conf
704- fixed apache2 initscript.
705
706* Sat Mar 29 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl2
707- build Vine Linux
708- new upstream version
709- sharing with apache1
710
711* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
712- link httpd with libssl to avoid library loading/unloading weirdness
713
714* Tue Sep  3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
715- add LoadModule lines for proxy modules in httpd.conf (#73349)
716- fix permissions of conf/ssl.*/ directories; add Makefiles for
717  certificate management (#73352)
718
719* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
720- provide "httpd-mmn" to manage module ABI compatibility
721
722* Sun Sep  1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
723- fix SSL session cache (#69699)
724- revert addition of LDAP support to apr-util
725
726* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
727- set SIGXFSZ disposition to "ignored" (#69520)
728- make dummy connections to the first listener in config (#72692)
729
730* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
731- allow "apachectl configtest" on a 1.3 httpd.conf
732- add mod_deflate
733- enable LDAP support in apr-util
734- don't package everything in /var/www/error as config(noreplace)
735
736* Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
737- add trigger (#68657)
738
739* Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
740- update to 2.0.40
741
742* Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
743- improve comment on use of UserDir in default config (#66886)
744
745* Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
746- use /sbin/nologin as shell for apache user (#68371)
747- add patch from CVS to fix possible infinite loop when processing
748  internal redirects
749
750* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
751- modify init script to detect 1.3.x httpd.conf's and direct users
752  to the migration guide
753
754* Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
755- patch apachectl to detect 1.3.x httpd.conf's and direct users
756  to the migration guide
757- ship the migration guide
758
759* Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
760- move /etc/httpd2 back to /etc/httpd
761- add noindex.html page and poweredby logo; tweak default config
762  to load noindex.html if no default "/" page is present.
763- add patch to prevent mutex errors on graceful restart
764
765* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
766- automated rebuild
767
768* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
769- add patch to fix SSL mutex handling
770
771* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
772- improved config directory patch
773
774* Mon May 20 2002 Joe Orton <jorton@redhat.com>
775- initial build; based heavily on apache.spec and mod_ssl.spec
776- fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245
777
Note: See TracBrowser for help on using the repository browser.