source: projects/specs/branches/6/a/apache2/apache2-vl.spec @ 10666

Revision 10666, 26.6 KB checked in by tomop, 8 years ago (diff)

apache2-2.2.31-3

Line 
1%define contentdir /var/www
2%define suexec_caller apache
3%define mmn 20051115
4%define pkgname apache2
5
6Summary: Apache HTTP Server
7Name: %{pkgname}
8Version: 2.2.31
9Release: 3%{_dist_release}
10URL: http://httpd.apache.org/
11
12Vendor: Project Vine
13Distribution: Vine Linux
14Packager: daisuke
15
16Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
17Source1: index.html.ja
18Source3: apache2.logrotate
19Source4: apache2.init
20Source5: README.confd
21Source6: vine.png
22Source10: httpd.conf
23Source11: apache-ssl.conf
24Source12: migration.html
25Source13: migration.css
26Source14: mod_ssl-Makefile.crt
27Source15: mod_ssl-Makefile.crl
28# add vine entry to config.layout
29Source100: vine-config.layout
30# man files
31Source101: apache2.8
32Source102: apache2ctl.8
33#Source103: config_vars.mk
34# build/scripts patches
35Patch1: httpd-2.1.10-apctl.patch
36Patch2: httpd-2.2.3-apxs.patch
37Patch3: httpd-2.0.45-deplibs.patch
38Patch4: httpd-2.1.10-disablemods.patch
39# features/functional changes
40Patch21: httpd-2.0.40-xfsz.patch
41# Patch22: httpd-2.1.10-pod.patch
42Patch22: httpd-2.2.23-pod.patch
43Patch23: httpd-2.0.45-export.patch
44Patch24: httpd-2.0.48-corelimit.patch
45# Bug fixes
46Patch54: httpd-2.2.0-authnoprov.patch
47Patch60: httpd-2.2.3-sslusername.patch
48
49# Security fixes
50Patch1000: CVE-2016-5387.patch
51
52License: Apache Software License
53Group: System Environment/Daemons
54BuildRoot: %{_tmppath}/%{name}-%{version}-root
55BuildRequires: db4-devel, expat-devel
56BuildRequires: findutils, perl, openldap-devel, zlib-devel
57BuildRequires: apr-devel, apr-util-devel
58BuildRequires: pcre-devel, sqlite3-devel
59Requires: mailcap, gawk, file, findutils, apr, apr-util
60Requires(pre): chkconfig, mktemp, fileutils
61Requires(pre): sh-utils, textutils, shadow-utils
62Requires(post): alternatives
63Provides: webserver
64Provides: httpd = %{version}
65Provides: httpd-mmn = %{mmn}
66Obsoletes: apache2-apr, apache2-apr-devel
67
68%description
69Apache is a powerful, full-featured, efficient, and freely-available
70Web server. Apache is also the most popular Web server on the
71Internet.
72
73%package devel
74Group: Development/Libraries
75Summary: Development tools for the Apache HTTP server.
76Requires: libtool, httpd = %{version}
77Requires: apr-devel, apr-util-devel
78
79%description devel
80The httpd-devel package contains the APXS binary and other files
81that you need to build Dynamic Shared Objects (DSOs) for Apache.
82
83If you are installing the Apache HTTP server and you want to be
84able to compile or develop additional modules for Apache, you need
85to install this package.
86
87%package manual
88Group: Applications/Documentation
89Summary: Documentation for the Apache HTTP server.
90
91%description manual
92The httpd-manual package contains the complete manual and
93reference guide for the Apache HTTP server. The information can
94also be found at http://httpd.apache.org/docs/.
95
96%package -n mod_ssl-apache2
97Group: System Environment/Daemons
98Summary: SSL/TLS module for the Apache HTTP server
99Epoch: 1
100BuildRequires: openssl-devel
101Requires(pre): openssl, dev, /bin/cat
102Requires: httpd, make, httpd-mmn = %{mmn}
103
104%description -n mod_ssl-apache2
105The mod_ssl module provides strong cryptography for the Apache Web
106server via the Secure Sockets Layer (SSL) and Transport Layer
107Security (TLS) protocols.
108
109%prep
110%setup -q -n httpd-%{version}
111
112%patch1 -p1 -b .apctl
113%patch2 -p1 -b .apxs
114#patch3 -p1 -b .deplibs
115%patch4 -p1 -b .disablemods
116
117%patch21 -p0 -b .xfsz
118%patch22 -p1 -b .pod
119%patch23 -p1 -b .export
120%patch24 -p1 -b .corelimit
121
122%patch54 -p1 -b .authnoprov
123%patch60 -p1 -b .sslusername
124
125# security fixes
126%patch1000 -p1 -b .CVE-2016-5387
127
128# copy across the migration guide and sed it's location into apachectl
129cp $RPM_SOURCE_DIR/migration.{html,css} .
130%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
131        support/apachectl.in
132
133
134# add Vine configure's option to config.layout
135sed -e "s|${prefix}/lib|${prefix}/%{_lib}|" \
136  < $RPM_SOURCE_DIR/vine-config.layout >> config.layout
137
138# regenerate configure scripts
139./buildconf
140
141%build
142# remove bundled apr, apr-util, pcre
143rm -rf srclib/{apr,apr-util,pcre}
144
145#CFLAGS="$RPM_OPT_FLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
146#AP_LIBS="-lssl -lcrypto"
147#export CFLAGS AP_LIBS
148CFLAGS="$RPM_OPT_FLAGS"
149SH_LDFLAGS="-Wl,-z,relro"
150export CFLAGS SH_LDFLAGS
151
152%define mpms worker prefork
153%define prefer_mpm prefork
154
155AP_CONFOPTS="\
156        --prefix=%{_sysconfdir}/apache2 \
157        --exec-prefix=%{_prefix} \
158        --bindir=%{_bindir} \
159        --sbindir=%{_sbindir} \
160        --mandir=%{_mandir} \
161        --libdir=%{_libdir} \
162        --sysconfdir=%{_sysconfdir}/apache2/conf \
163        --includedir=%{_includedir}/apache2 \
164        --libexecdir=%{_libdir}/apache2/modules \
165        --datadir=%{contentdir} \
166        --with-installbuilddir=%{_libdir}/apache2/build \
167        --enable-layout=Vine \
168        --with-program-name=apache2 \
169        --with-ldap \
170        --enable-ldap --enable-authnz-ldap \
171        --enable-mods-shared=all \
172        --enable-cache=shared \
173        --enable-cgi=shared \
174        --enable-cgid=shared \
175        --enable-rewrite=shared \
176        --enable-disk-cache=shared \
177        --enable-file-cache=shared \
178        --enable-mem-cache=shared \
179        --enable-authn-anon --enable-authn-alias \
180        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
181        --enable-suexec --with-suexec \
182        --with-suexec-caller=%{suexec_caller} \
183        --with-suexec-docroot=%{contentdir} \
184        --with-suexec-logfile=%{_localstatedir}/log/apache2/suexec.log \
185        --with-suexec-bin=%{_libdir}/%{pkgname}/suexec \
186        --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
187        --with-pcre \
188        --enable-ssl --with-ssl \
189        --enable-deflate \
190        --enable-proxy --enable-proxy-connect \
191        --enable-proxy-http --enable-proxy-ftp"
192#all  mpm build
193for mpm in %{mpms}; do
194   mkdir mpm-$mpm;
195   cd mpm-$mpm;
196   ../configure $AP_CONFOPTS --with-mpm=$mpm --srcdir=../ ;
197   make %{?_smp_mflags} ;
198#   mv apache2 apache2.$mpm ;
199   cd ../
200done
201
202%install
203rm -rf $RPM_BUILD_ROOT
204
205# install mpms binary
206pushd mpm-prefork
207  make DESTDIR=$RPM_BUILD_ROOT install
208  rm -f $RPM_BUILD_ROOT/%{_sbindir}/apache2
209popd
210
211for mpm in %{mpms}; do
212    install -m755 mpm-$mpm/apache2 $RPM_BUILD_ROOT/%{_sbindir}/apache2.$mpm
213done
214
215# install conf file/directory
216mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d
217install -m 644 $RPM_SOURCE_DIR/README.confd \
218   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/README
219install -m 644 $RPM_SOURCE_DIR/apache-ssl.conf \
220   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/ssl.conf
221
222rm $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/*.conf
223install -m 644 $RPM_SOURCE_DIR/httpd.conf \
224   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/httpd.conf
225
226# mod_ssl bits
227for suffix in crl crt csr key prm; do
228   mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${suffix}
229done
230
231# Makefiles for certificate management
232for ext in crt crl; do
233  install -m 644 $RPM_SOURCE_DIR/mod_ssl-Makefile.${ext} \
234        $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${ext}/Makefile.${ext}
235done
236ln -s ../../../usr/share/ssl/certs/Makefile $RPM_BUILD_ROOT/etc/apache2/conf
237
238# for holding mod_dav lock database
239mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav
240
241# create a prototype session cache
242mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl
243touch $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl/scache.{dir,pag,sem}
244
245# move utilities to /usr/bin
246mv $RPM_BUILD_ROOT%{_sbindir}/{ab,htdbm,logresolve,htpasswd,htdigest} \
247   $RPM_BUILD_ROOT%{_bindir}
248
249# Make the MMN accessible to module packages
250echo %{mmn} > $RPM_BUILD_ROOT%{_includedir}/apache2/.mmn
251
252# docroot
253# mkdir $RPM_BUILD_ROOT%{contentdir}/html
254install -m 644 $RPM_SOURCE_DIR/index.html.ja \
255        $RPM_BUILD_ROOT%{contentdir}/error/noindex.html
256rm -r $RPM_BUILD_ROOT%{contentdir}/manual/style
257
258install -m 644 $RPM_SOURCE_DIR/vine.png \
259        $RPM_BUILD_ROOT%{contentdir}/icons
260
261# logs
262# rmdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/logs
263mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/apache2
264
265ln -sf %{_sysconfdir}/%{pkgname}/conf/httpd.conf $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/conf/apache2.conf
266
267
268# symlinks for /etc/apache2
269ln -s ../..%{_localstatedir}/log/apache2 $RPM_BUILD_ROOT/etc/apache2/logs
270ln -s ../..%{_localstatedir}/run $RPM_BUILD_ROOT/etc/apache2/run
271ln -s ../..%{_libdir}/apache2/modules $RPM_BUILD_ROOT/etc/apache2/modules
272ln -s ../..%{_libdir}/apache2/build $RPM_BUILD_ROOT/etc/apache2/build
273
274# install SYSV init stuff
275mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
276install -m755 $RPM_SOURCE_DIR/apache2.init \
277        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
278%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
279        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
280
281# install log rotation stuff
282mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
283install -m644 $RPM_SOURCE_DIR/apache2.logrotate \
284        $RPM_BUILD_ROOT/etc/logrotate.d/apache2
285
286mv $RPM_BUILD_ROOT/%{_sbindir}/apachectl $RPM_BUILD_ROOT/%{_sbindir}/apache2ctl
287
288# fix man page paths
289sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/apache2/conf/httpd.conf|" \
290    -e "s|/usr/local/apache2/conf/mime.types|/etc/mime.types|" \
291    -e "s|/usr/local/apache2/conf/magic|/etc/apache2/conf/magic|" \
292    -e "s|/usr/local/apache2/logs/error_log|/var/log/apache2/error_log|" \
293    -e "s|/usr/local/apache2/logs/access_log|/var/log/apache2/access_log|" \
294    -e "s|/usr/local/apache2/logs/httpd.pid|/var/run/apache2.pid|" \
295    -e "s|/usr/local/apache2|/etc/httpd|" < $RPM_SOURCE_DIR/apache2.8 \
296  > $RPM_BUILD_ROOT%{_mandir}/man8/apache2.8
297
298install -m644 $RPM_SOURCE_DIR/apache2ctl.8 \
299        $RPM_BUILD_ROOT%{_mandir}/man8/apache2ctl.8
300
301# change command name to avoid conflict with apache1 pacjage
302%define cflcmd /usr/bin/htdigest /usr/bin/htpasswd /usr/sbin/rotatelogs
303
304for i in %{cflcmd}; do \
305  echo $i
306  mv $RPM_BUILD_ROOT$i $RPM_BUILD_ROOT$i"2";
307done;
308
309mv $RPM_BUILD_ROOT/%{_sbindir}/apxs $RPM_BUILD_ROOT/%{_bindir}/apxs
310
311%define cflman usr/share/man/man1/dbmmanage.1 usr/share/man/man1/htdigest.1 usr/share/man/man1/htpasswd.1 usr/share/man/man8/rotatelogs.8 usr/share/man/man8/suexec.8 usr/share/man/man8/apxs.8 usr/share/man/man8/httpd.8
312
313(cd $RPM_BUILD_ROOT;
314for i in %{cflman}; do \
315    echo $i | sed -e "s|\.1|2\.1|" -e "s|\.8|2\.8|" |    xargs mv $i ;
316   
317done;
318)
319
320#cp $RPM_SOURCE_DIR/config_vars.mk $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/build/.
321mv $RPM_BUILD_ROOT/%{_sbindir}/suexec $RPM_BUILD_ROOT/%{_libdir}/%{pkgname}/suexec
322
323
324rm -f $RPM_BUILD_ROOT%{_mandir}/man1/ab*
325rm -f $RPM_BUILD_ROOT%{_mandir}/man1/logresolve*
326# conflict with apache 1, so removed...
327rm -f $RPM_BUILD_ROOT%{_mandir}/man8/ab*
328rm -f $RPM_BUILD_ROOT%{_mandir}/man8/logresolve*
329
330# remove unpackaged files
331rm -f $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/mime.types \
332      $RPM_BUILD_ROOT%{_libdir}/*.la \
333      $RPM_BUILD_ROOT%{_libdir}/*.exp \
334      $RPM_BUILD_ROOT%{_libdir}/apache2/modules/*.exp \
335      $RPM_BUILD_ROOT%{_libdir}/apache2/build/config.nice \
336      $RPM_BUILD_ROOT%{_sbindir}/{apache2,checkgid,dbmmanage,envvars*} \
337      $RPM_BUILD_ROOT%{contentdir}/html/* \
338      $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
339
340%pre
341# Add the "apache" user
342/usr/sbin/useradd -c "Apache" -u 48 \
343        -s /sbin/nologin -r -d %{contentdir} apache 2> /dev/null || :
344
345%triggerpostun -- apache < 2.0
346/sbin/chkconfig --add apache2
347
348
349%post
350# Register the httpd service
351for mpm in %{mpms}; do
352  /sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.$mpm 20;
353done
354/sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.%{prefer_mpm} 30
355/sbin/chkconfig --add apache2
356
357%preun
358if [ $1 = 0 ]; then
359        /sbin/service apache2 stop > /dev/null 2>&1
360        /sbin/chkconfig --del apache2
361        for mpm in %{mpms}; do
362          /sbin/update-alternatives --remove apache2 %{_sbindir}/apache2.$mpm;
363        done 
364fi
365
366%postun
367if [ "$1" -ge 1 ]; then
368        /sbin/service apache2 condrestart
369fi
370/sbin/ldconfig
371
372%post -n mod_ssl-apache2
373/sbin/ldconfig ### is this needed?
374umask 077
375
376if [ ! -f %{_sysconfdir}/apache2/conf/ssl.key/server.key ] ; then
377%{_bindir}/openssl genrsa -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime 1024 > %{_sysconfdir}/apache2/conf/ssl.key/server.key 2> /dev/null
378fi
379
380FQDN=`hostname`
381if [ "x${FQDN}" = "x" ]; then
382   FQDN=localhost.localdomain
383fi
384
385if [ ! -f %{_sysconfdir}/apache2/conf/ssl.crt/server.crt ] ; then
386cat << EOF | %{_bindir}/openssl req -new -key %{_sysconfdir}/apache2/conf/ssl.key/server.key -x509 -days 365 -out %{_sysconfdir}/apache2/conf/ssl.crt/server.crt 2>/dev/null
387--
388SomeState
389SomeCity
390SomeOrganization
391SomeOrganizationalUnit
392${FQDN}
393root@${FQDN}
394EOF
395fi
396
397%clean
398rm -rf $RPM_BUILD_ROOT
399
400%files
401%defattr(-,root,root)
402
403%doc ABOUT_APACHE README CHANGES LAYOUT LICENSE
404%doc migration.html migration.css
405
406%dir %{_sysconfdir}/apache2
407%{_sysconfdir}/apache2/modules
408%{_sysconfdir}/apache2/logs
409%{_sysconfdir}/apache2/run
410%dir %{_sysconfdir}/apache2/conf
411%config(noreplace) %{_sysconfdir}/apache2/conf/*.conf
412%config(noreplace) %{_sysconfdir}/apache2/conf/magic
413
414%config %{_sysconfdir}/logrotate.d/apache2
415%config %{_sysconfdir}/rc.d/init.d/apache2
416
417%dir %{_sysconfdir}/apache2/conf.d
418%{_sysconfdir}/apache2/conf.d/README
419
420%dir %{_sysconfdir}/apache2/conf/extra
421%config %{_sysconfdir}/apache2/conf/extra/*
422
423%dir %{_sysconfdir}/apache2/conf/original
424%{_sysconfdir}/apache2/conf/original/*
425
426%{_bindir}/ab
427%{_bindir}/ht*
428%{_bindir}/logresolve
429%{_sbindir}/ht*
430%{_sbindir}/apache2.*
431%{_sbindir}/apache2ctl
432%{_sbindir}/rotatelogs2
433%attr(4510,root,%{suexec_caller}) %{_libdir}/%{pkgname}/suexec
434
435%dir %{_libdir}/apache2
436%dir %{_libdir}/apache2/modules
437# everything but mod_ssl.so:
438%{_libdir}/apache2/modules/mod_[a-r]*.so
439%{_libdir}/apache2/modules/mod_s[petu]*.so
440%{_libdir}/apache2/modules/mod_[t-z]*.so
441
442%dir %{contentdir}
443%dir %{contentdir}/cgi-bin
444%dir %{contentdir}/html
445%dir %{contentdir}/icons
446%dir %{contentdir}/error
447%dir %{contentdir}/error/include
448%{contentdir}/icons/*
449%{contentdir}/error/README
450%{contentdir}/error/noindex.html
451%config(noreplace) %{contentdir}/error/*.var
452%config(noreplace) %{contentdir}/error/include/*.html
453
454%attr(0700,root,root) %dir %{_localstatedir}/log/apache2
455
456%attr(0700,apache,apache) %dir %{_localstatedir}/lib/dav
457
458%{_mandir}/man1/*
459
460%{_mandir}/man8/*
461
462%files manual
463%defattr(-,root,root)
464%{contentdir}/manual
465
466%files -n mod_ssl-apache2
467%defattr(-,root,root)
468%{_libdir}/apache2/modules/mod_ssl.so
469%config(noreplace) %{_sysconfdir}/apache2/conf.d/ssl.conf
470%attr(0700,root,root) %dir %{_sysconfdir}/apache2/conf/ssl.*
471%config %{_sysconfdir}/apache2/conf/Makefile
472%config %{_sysconfdir}/apache2/conf/ssl.*/*
473%attr(0700,apache,root) %dir %{_localstatedir}/cache/mod_ssl
474%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.dir
475%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.pag
476%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.sem
477
478%files devel
479%defattr(-,root,root)
480%{_includedir}/apache2
481%{_sysconfdir}/apache2/build
482%{_bindir}/apxs
483%{_mandir}/man?/apxs*
484%{_libdir}/apache2/build/*.mk
485%{_libdir}/apache2/build/*.sh
486
487%changelog
488* Fri Jul 22 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.31-3
489- added Patch1000 to fix CVE-2016-5387.
490
491* Wed Mar  2 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.31-2
492- rebuilt with openssl 1.0.1s (no sslv2)
493
494* Sun Aug  2 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.31-1
495- new upstream release with security fixes
496
497* Sat Jan  3 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.29-1
498- new upstream release with security fixes
499  (drop patch100-120, which are included in new release)
500
501* Wed Aug 13 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.27-2
502- add Patch100 for fix CVE-2014-0118 (mod_deflate)
503- add Patch110 for fix CVE-2014-0226 (mod_status)
504- add Patch120 for fix CVE-2014-0231 (mod_cgid)
505  these patches are from debian wheezy, thanks
506
507* Fri Mar 28 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.27-1
508- new upstream release with security fix (CVE-2013-6438, 2014-0098)
509
510* Fri Jan 24 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.26-1
511- new upstream release
512
513* Sat Sep 28 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.25-1
514- new upstream release with security fix (CVE-2013-1862,1896)
515- drop patch100 (is included in new release)
516
517* Fri May 17 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-2
518- add patch100 for fix CVE-2013-1862 (mod_rewrite)
519
520* Wed Feb 27 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-1
521- new upstream release with security fix (CVE-2012-3499, 4558)
522
523* Sun Sep 16 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.23-1
524- new upstream release with security fix (CVE-2012-3502,CVE-2012-2687)
525- update patch22 to fit new release
526- update man filename convert list
527
528* Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.22-1
529- update to 2.2.22
530  - CVE-2012-0021 (mod_log_config)
531  - CVE-2012-0031
532  - CVE-2012-0053
533- remove upstreamed patches
534
535* Fri Dec  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-5
536- add patch120 for fix CVE-2011-4317 (mod_rewrite/mod_proxy)
537
538* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-4
539- add patch110 for fix CVE-2011-3607-4415 (ModSetEnvIf)
540
541* Wed Oct 12 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-3
542- add patch70 for fix byterange filter
543
544* Tue Oct 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-2
545- add Patch100 for fix CVE-2011-3368 (mod_proxy)
546
547* Wed Sep 14 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-1
548- new upstream release with security fix (CVE-2011-3348)
549- regression fixes of CVE-2011-3192 byterange fix in 2.2.20
550
551* Tue Sep  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-3
552- update Patch101 (Thanks to debian team)
553
554* Sat Sep  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-2
555- add Patch101 for fix CVE-2011-3192 regression
556
557* Thu Sep  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-1
558- new upstream release with security fix (CVE-2011-3192)
559- drop patch100 (is included in new release)
560
561* Thu Aug 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.19-2
562- add patch100 for fix CVE-2011-3192 (Range Header DoS)
563
564* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.19-1
565- update to 2.2.19
566
567* Sat Apr 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-9
568- remove old Obsoletes/Conflicts
569
570* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-8
571- rebuild with openssl-1.0.0c
572
573* Sat Aug 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.14-7
574- add  patch120 for fix CVE-2010-1452 (mod_dav/mod_cache) from mdk2010
575
576* Wed Aug 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-6
577- add R(post): alternatives
578
579* Sat Mar 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-5
580- add patch110 for fix CVE-2010-0434 from mdk 2010
581
582* Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-4
583- add patch100 for fix CVE-2010-0408 (mod_proxy_ajp)
584
585* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.14-3
586- rebuilt with rpm-4.8.0-3 (on ppc)
587
588* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-2
589- rebuild with db4-4.8.0
590
591* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-1
592- new upstream release with security fix
593  (CVE-2009-2699, CVE-2009-3095, CVE-2009-3094)
594- fix ssl.conf (2.2.13-1 includes wrong file)
595
596* Sun Aug 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.13-1
597- new upstream release
598
599* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.12-1
600- new upstream release
601  (including security fix for CVE-2009-1890, CVE-2009-1191,
602   CVE-2009-1195, CVE-2009-1955, CVE-2009-1956, CVE-2009-0023)
603
604* Fri Jan 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-2
605- rebuilt with openldap-2.4.11
606
607* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-1
608- new upstream release
609
610* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-1
611- new upstream release (including security fix for CVE-2008-2939)
612
613* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-1
614- new upstream release (including security fix for CVE-2008-2364, CVE-2007-6420)
615- built with db4-4.6.21, apr 1.3.0
616
617* Sun Apr 27 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.8-1
618- add Patch60 (to fix bug#31418).
619
620* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.8-0vl2
621- rebuild with expat-2.0.1
622
623* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
624- new upstream release
625
626* Sat Nov  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-0vl2
627- added postun script from VinePlus/4.0 package
628  * Tue Sep 11 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.3-0vl3.2
629  - add postun script to restart daemon with message
630
631* Sun Jul 01 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl8
632- updated Patch2: httpd-2.2.3-apxs.patch
633
634* Sun Jun 24 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl7
635- modified libdir in config.layout for lib64 architecture
636
637* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
638- rebuilt with openssl-0.9.8e
639
640* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl5
641- rebuilt with new toolchain and db4-4.3.x
642
643* Tue Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl4
644- added BuildRequires: pcre-devel, sqlite3-devel <BTS:VineLinux:474>
645
646* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.3-0vl3
647- change manual Group to Applications/Documentation. <BTS:VineLinux:163>
648
649* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl2
650- rebuilt with openldap-2.3.27-0vl1
651
652* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
653- new upstream release including security fix (CVE-2006-3747)
654
655* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
656- new upstream release
657  - update to 2.2.2
658- remove apr/apr-devel subpackage,
659  use external apr/apr-util instead of internal one.
660
661* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.58-0vl1
662- new upstream release
663- use apache2.prefork as default.
664
665* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl3
666- rebuild to use new _localstatedir (rpm-4.4.2-0vl11)
667- remove unpackaged files in %%install section
668
669* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl2
670- fix logrotate configuration (use apache2.pid instead of httpd.pid)
671  (BTS:10)
672- use Epoch instead of Serial
673
674* Sat Oct 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl1
675- new upstream release
676- drop obsolete security patches which is merged in upstream
677
678* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.54-0vl1
679- new upstream release
680
681* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl2
682- added Patch122 to 125 for secutiry fix
683  (CAN-2004-{1268,2088,2700,2728})
684- fix %install section
685
686* Sun Apr 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl1
687- new upstream release
688
689* Sat Nov 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.52-0vl1
690- new upstream release
691
692* Sun Oct 24 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.50-0vl4
693- rebuilt with db4-4.2.52
694
695* Sat Sep  4 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.0.50-0vl3
696- separate apr, apr-devel packages
697- add BuildPreReq: zlib-devel
698
699* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.50-0vl2
700- fix %%files to include instdso.sh
701  thanks to jax <jax AT morejams DOT no-ip DOT com>
702- add %%{?_smp_mflags} to make option.
703
704* Sun Jul  4 2004 IWAI, Masaharu <iwai@alib.jp> 2.0.50-0vl1
705- new upstream version
706
707* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.48-0vl1
708- new upstream version
709
710* Mon Sep 15 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.47-0vl1
711- new upstream version
712- update apxs patch (Patch101)
713- fix dependency:
714    - change file name to package name in Requires and {Build,}Prereq
715- add BuildPrereq: openldap-devel
716- update %%files section
717- rename httpd.8 manpage
718
719* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.45-0vl1
720- new upstream version
721- used vine-config.layout in srclib
722
723* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.44-0vl9
724- rebuild
725
726* Sun Apr  6 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl8
727- change pkg name from mod_ssl to mod_ssl-apache2
728- remove "apache-manual" entry from Obsoletes:
729
730* Thu Apr  3 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl7
731- remove "mod_dav" and "apache-devel" from Obsoletes:
732- enable MPMS(worker %mpms )
733
734* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl6
735- add correct config_vars.mk
736
737* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl5
738- apply apxs's patch ( from Debian)
739
740* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl4
741- add apr-config,apu-config to devel's %file
742
743* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl3
744- change apxs path ( /usr/sbin -> /usr/bin
745- add symlink under /etc/apache2/conf
746  (logs, run), httpd.conf -> apache2.conf
747- fixed apache2 initscript.
748
749* Sat Mar 29 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl2
750- build Vine Linux
751- new upstream version
752- sharing with apache1
753
754* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
755- link httpd with libssl to avoid library loading/unloading weirdness
756
757* Tue Sep  3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
758- add LoadModule lines for proxy modules in httpd.conf (#73349)
759- fix permissions of conf/ssl.*/ directories; add Makefiles for
760  certificate management (#73352)
761
762* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
763- provide "httpd-mmn" to manage module ABI compatibility
764
765* Sun Sep  1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
766- fix SSL session cache (#69699)
767- revert addition of LDAP support to apr-util
768
769* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
770- set SIGXFSZ disposition to "ignored" (#69520)
771- make dummy connections to the first listener in config (#72692)
772
773* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
774- allow "apachectl configtest" on a 1.3 httpd.conf
775- add mod_deflate
776- enable LDAP support in apr-util
777- don't package everything in /var/www/error as config(noreplace)
778
779* Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
780- add trigger (#68657)
781
782* Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
783- update to 2.0.40
784
785* Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
786- improve comment on use of UserDir in default config (#66886)
787
788* Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
789- use /sbin/nologin as shell for apache user (#68371)
790- add patch from CVS to fix possible infinite loop when processing
791  internal redirects
792
793* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
794- modify init script to detect 1.3.x httpd.conf's and direct users
795  to the migration guide
796
797* Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
798- patch apachectl to detect 1.3.x httpd.conf's and direct users
799  to the migration guide
800- ship the migration guide
801
802* Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
803- move /etc/httpd2 back to /etc/httpd
804- add noindex.html page and poweredby logo; tweak default config
805  to load noindex.html if no default "/" page is present.
806- add patch to prevent mutex errors on graceful restart
807
808* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
809- automated rebuild
810
811* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
812- add patch to fix SSL mutex handling
813
814* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
815- improved config directory patch
816
817* Mon May 20 2002 Joe Orton <jorton@redhat.com>
818- initial build; based heavily on apache.spec and mod_ssl.spec
819- fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245
820
Note: See TracBrowser for help on using the repository browser.