source: projects/specs/branches/6/a/apache2/apache2-vl.spec @ 10054

Revision 10054, 26.5 KB checked in by iwamoto, 8 years ago (diff)

apache2: rebuilt with openssl 1.0.1s (no sslv2)

Line 
1%define contentdir /var/www
2%define suexec_caller apache
3%define mmn 20051115
4%define pkgname apache2
5
6Summary: Apache HTTP Server
7Name: %{pkgname}
8Version: 2.2.31
9Release: 2%{_dist_release}
10URL: http://httpd.apache.org/
11
12Vendor: Project Vine
13Distribution: Vine Linux
14Packager: daisuke
15
16Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
17Source1: index.html.ja
18Source3: apache2.logrotate
19Source4: apache2.init
20Source5: README.confd
21Source6: vine.png
22Source10: httpd.conf
23Source11: apache-ssl.conf
24Source12: migration.html
25Source13: migration.css
26Source14: mod_ssl-Makefile.crt
27Source15: mod_ssl-Makefile.crl
28# add vine entry to config.layout
29Source100: vine-config.layout
30# man files
31Source101: apache2.8
32Source102: apache2ctl.8
33#Source103: config_vars.mk
34# build/scripts patches
35Patch1: httpd-2.1.10-apctl.patch
36Patch2: httpd-2.2.3-apxs.patch
37Patch3: httpd-2.0.45-deplibs.patch
38Patch4: httpd-2.1.10-disablemods.patch
39# features/functional changes
40Patch21: httpd-2.0.40-xfsz.patch
41# Patch22: httpd-2.1.10-pod.patch
42Patch22: httpd-2.2.23-pod.patch
43Patch23: httpd-2.0.45-export.patch
44Patch24: httpd-2.0.48-corelimit.patch
45# Bug fixes
46Patch54: httpd-2.2.0-authnoprov.patch
47Patch60: httpd-2.2.3-sslusername.patch
48
49# Security fixes
50
51License: Apache Software License
52Group: System Environment/Daemons
53BuildRoot: %{_tmppath}/%{name}-%{version}-root
54BuildRequires: db4-devel, expat-devel
55BuildRequires: findutils, perl, openldap-devel, zlib-devel
56BuildRequires: apr-devel, apr-util-devel
57BuildRequires: pcre-devel, sqlite3-devel
58Requires: mailcap, gawk, file, findutils, apr, apr-util
59Requires(pre): chkconfig, mktemp, fileutils
60Requires(pre): sh-utils, textutils, shadow-utils
61Requires(post): alternatives
62Provides: webserver
63Provides: httpd = %{version}
64Provides: httpd-mmn = %{mmn}
65Obsoletes: apache2-apr, apache2-apr-devel
66
67%description
68Apache is a powerful, full-featured, efficient, and freely-available
69Web server. Apache is also the most popular Web server on the
70Internet.
71
72%package devel
73Group: Development/Libraries
74Summary: Development tools for the Apache HTTP server.
75Requires: libtool, httpd = %{version}
76Requires: apr-devel, apr-util-devel
77
78%description devel
79The httpd-devel package contains the APXS binary and other files
80that you need to build Dynamic Shared Objects (DSOs) for Apache.
81
82If you are installing the Apache HTTP server and you want to be
83able to compile or develop additional modules for Apache, you need
84to install this package.
85
86%package manual
87Group: Applications/Documentation
88Summary: Documentation for the Apache HTTP server.
89
90%description manual
91The httpd-manual package contains the complete manual and
92reference guide for the Apache HTTP server. The information can
93also be found at http://httpd.apache.org/docs/.
94
95%package -n mod_ssl-apache2
96Group: System Environment/Daemons
97Summary: SSL/TLS module for the Apache HTTP server
98Epoch: 1
99BuildRequires: openssl-devel
100Requires(pre): openssl, dev, /bin/cat
101Requires: httpd, make, httpd-mmn = %{mmn}
102
103%description -n mod_ssl-apache2
104The mod_ssl module provides strong cryptography for the Apache Web
105server via the Secure Sockets Layer (SSL) and Transport Layer
106Security (TLS) protocols.
107
108%prep
109%setup -q -n httpd-%{version}
110
111%patch1 -p1 -b .apctl
112%patch2 -p1 -b .apxs
113#patch3 -p1 -b .deplibs
114%patch4 -p1 -b .disablemods
115
116%patch21 -p0 -b .xfsz
117%patch22 -p1 -b .pod
118%patch23 -p1 -b .export
119%patch24 -p1 -b .corelimit
120
121%patch54 -p1 -b .authnoprov
122%patch60 -p1 -b .sslusername
123
124# security fixes
125
126# copy across the migration guide and sed it's location into apachectl
127cp $RPM_SOURCE_DIR/migration.{html,css} .
128%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
129        support/apachectl.in
130
131
132# add Vine configure's option to config.layout
133sed -e "s|${prefix}/lib|${prefix}/%{_lib}|" \
134  < $RPM_SOURCE_DIR/vine-config.layout >> config.layout
135
136# regenerate configure scripts
137./buildconf
138
139%build
140# remove bundled apr, apr-util, pcre
141rm -rf srclib/{apr,apr-util,pcre}
142
143#CFLAGS="$RPM_OPT_FLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
144#AP_LIBS="-lssl -lcrypto"
145#export CFLAGS AP_LIBS
146CFLAGS="$RPM_OPT_FLAGS"
147SH_LDFLAGS="-Wl,-z,relro"
148export CFLAGS SH_LDFLAGS
149
150%define mpms worker prefork
151%define prefer_mpm prefork
152
153AP_CONFOPTS="\
154        --prefix=%{_sysconfdir}/apache2 \
155        --exec-prefix=%{_prefix} \
156        --bindir=%{_bindir} \
157        --sbindir=%{_sbindir} \
158        --mandir=%{_mandir} \
159        --libdir=%{_libdir} \
160        --sysconfdir=%{_sysconfdir}/apache2/conf \
161        --includedir=%{_includedir}/apache2 \
162        --libexecdir=%{_libdir}/apache2/modules \
163        --datadir=%{contentdir} \
164        --with-installbuilddir=%{_libdir}/apache2/build \
165        --enable-layout=Vine \
166        --with-program-name=apache2 \
167        --with-ldap \
168        --enable-ldap --enable-authnz-ldap \
169        --enable-mods-shared=all \
170        --enable-cache=shared \
171        --enable-cgi=shared \
172        --enable-cgid=shared \
173        --enable-rewrite=shared \
174        --enable-disk-cache=shared \
175        --enable-file-cache=shared \
176        --enable-mem-cache=shared \
177        --enable-authn-anon --enable-authn-alias \
178        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
179        --enable-suexec --with-suexec \
180        --with-suexec-caller=%{suexec_caller} \
181        --with-suexec-docroot=%{contentdir} \
182        --with-suexec-logfile=%{_localstatedir}/log/apache2/suexec.log \
183        --with-suexec-bin=%{_libdir}/%{pkgname}/suexec \
184        --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
185        --with-pcre \
186        --enable-ssl --with-ssl \
187        --enable-deflate \
188        --enable-proxy --enable-proxy-connect \
189        --enable-proxy-http --enable-proxy-ftp"
190#all  mpm build
191for mpm in %{mpms}; do
192   mkdir mpm-$mpm;
193   cd mpm-$mpm;
194   ../configure $AP_CONFOPTS --with-mpm=$mpm --srcdir=../ ;
195   make %{?_smp_mflags} ;
196#   mv apache2 apache2.$mpm ;
197   cd ../
198done
199
200%install
201rm -rf $RPM_BUILD_ROOT
202
203# install mpms binary
204pushd mpm-prefork
205  make DESTDIR=$RPM_BUILD_ROOT install
206  rm -f $RPM_BUILD_ROOT/%{_sbindir}/apache2
207popd
208
209for mpm in %{mpms}; do
210    install -m755 mpm-$mpm/apache2 $RPM_BUILD_ROOT/%{_sbindir}/apache2.$mpm
211done
212
213# install conf file/directory
214mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d
215install -m 644 $RPM_SOURCE_DIR/README.confd \
216   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/README
217install -m 644 $RPM_SOURCE_DIR/apache-ssl.conf \
218   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/ssl.conf
219
220rm $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/*.conf
221install -m 644 $RPM_SOURCE_DIR/httpd.conf \
222   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/httpd.conf
223
224# mod_ssl bits
225for suffix in crl crt csr key prm; do
226   mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${suffix}
227done
228
229# Makefiles for certificate management
230for ext in crt crl; do
231  install -m 644 $RPM_SOURCE_DIR/mod_ssl-Makefile.${ext} \
232        $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${ext}/Makefile.${ext}
233done
234ln -s ../../../usr/share/ssl/certs/Makefile $RPM_BUILD_ROOT/etc/apache2/conf
235
236# for holding mod_dav lock database
237mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav
238
239# create a prototype session cache
240mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl
241touch $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl/scache.{dir,pag,sem}
242
243# move utilities to /usr/bin
244mv $RPM_BUILD_ROOT%{_sbindir}/{ab,htdbm,logresolve,htpasswd,htdigest} \
245   $RPM_BUILD_ROOT%{_bindir}
246
247# Make the MMN accessible to module packages
248echo %{mmn} > $RPM_BUILD_ROOT%{_includedir}/apache2/.mmn
249
250# docroot
251# mkdir $RPM_BUILD_ROOT%{contentdir}/html
252install -m 644 $RPM_SOURCE_DIR/index.html.ja \
253        $RPM_BUILD_ROOT%{contentdir}/error/noindex.html
254rm -r $RPM_BUILD_ROOT%{contentdir}/manual/style
255
256install -m 644 $RPM_SOURCE_DIR/vine.png \
257        $RPM_BUILD_ROOT%{contentdir}/icons
258
259# logs
260# rmdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/logs
261mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/apache2
262
263ln -sf %{_sysconfdir}/%{pkgname}/conf/httpd.conf $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/conf/apache2.conf
264
265
266# symlinks for /etc/apache2
267ln -s ../..%{_localstatedir}/log/apache2 $RPM_BUILD_ROOT/etc/apache2/logs
268ln -s ../..%{_localstatedir}/run $RPM_BUILD_ROOT/etc/apache2/run
269ln -s ../..%{_libdir}/apache2/modules $RPM_BUILD_ROOT/etc/apache2/modules
270ln -s ../..%{_libdir}/apache2/build $RPM_BUILD_ROOT/etc/apache2/build
271
272# install SYSV init stuff
273mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
274install -m755 $RPM_SOURCE_DIR/apache2.init \
275        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
276%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
277        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
278
279# install log rotation stuff
280mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
281install -m644 $RPM_SOURCE_DIR/apache2.logrotate \
282        $RPM_BUILD_ROOT/etc/logrotate.d/apache2
283
284mv $RPM_BUILD_ROOT/%{_sbindir}/apachectl $RPM_BUILD_ROOT/%{_sbindir}/apache2ctl
285
286# fix man page paths
287sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/apache2/conf/httpd.conf|" \
288    -e "s|/usr/local/apache2/conf/mime.types|/etc/mime.types|" \
289    -e "s|/usr/local/apache2/conf/magic|/etc/apache2/conf/magic|" \
290    -e "s|/usr/local/apache2/logs/error_log|/var/log/apache2/error_log|" \
291    -e "s|/usr/local/apache2/logs/access_log|/var/log/apache2/access_log|" \
292    -e "s|/usr/local/apache2/logs/httpd.pid|/var/run/apache2.pid|" \
293    -e "s|/usr/local/apache2|/etc/httpd|" < $RPM_SOURCE_DIR/apache2.8 \
294  > $RPM_BUILD_ROOT%{_mandir}/man8/apache2.8
295
296install -m644 $RPM_SOURCE_DIR/apache2ctl.8 \
297        $RPM_BUILD_ROOT%{_mandir}/man8/apache2ctl.8
298
299# change command name to avoid conflict with apache1 pacjage
300%define cflcmd /usr/bin/htdigest /usr/bin/htpasswd /usr/sbin/rotatelogs
301
302for i in %{cflcmd}; do \
303  echo $i
304  mv $RPM_BUILD_ROOT$i $RPM_BUILD_ROOT$i"2";
305done;
306
307mv $RPM_BUILD_ROOT/%{_sbindir}/apxs $RPM_BUILD_ROOT/%{_bindir}/apxs
308
309%define cflman usr/share/man/man1/dbmmanage.1 usr/share/man/man1/htdigest.1 usr/share/man/man1/htpasswd.1 usr/share/man/man8/rotatelogs.8 usr/share/man/man8/suexec.8 usr/share/man/man8/apxs.8 usr/share/man/man8/httpd.8
310
311(cd $RPM_BUILD_ROOT;
312for i in %{cflman}; do \
313    echo $i | sed -e "s|\.1|2\.1|" -e "s|\.8|2\.8|" |    xargs mv $i ;
314   
315done;
316)
317
318#cp $RPM_SOURCE_DIR/config_vars.mk $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/build/.
319mv $RPM_BUILD_ROOT/%{_sbindir}/suexec $RPM_BUILD_ROOT/%{_libdir}/%{pkgname}/suexec
320
321
322rm -f $RPM_BUILD_ROOT%{_mandir}/man1/ab*
323rm -f $RPM_BUILD_ROOT%{_mandir}/man1/logresolve*
324# conflict with apache 1, so removed...
325rm -f $RPM_BUILD_ROOT%{_mandir}/man8/ab*
326rm -f $RPM_BUILD_ROOT%{_mandir}/man8/logresolve*
327
328# remove unpackaged files
329rm -f $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/mime.types \
330      $RPM_BUILD_ROOT%{_libdir}/*.la \
331      $RPM_BUILD_ROOT%{_libdir}/*.exp \
332      $RPM_BUILD_ROOT%{_libdir}/apache2/modules/*.exp \
333      $RPM_BUILD_ROOT%{_libdir}/apache2/build/config.nice \
334      $RPM_BUILD_ROOT%{_sbindir}/{apache2,checkgid,dbmmanage,envvars*} \
335      $RPM_BUILD_ROOT%{contentdir}/html/* \
336      $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
337
338%pre
339# Add the "apache" user
340/usr/sbin/useradd -c "Apache" -u 48 \
341        -s /sbin/nologin -r -d %{contentdir} apache 2> /dev/null || :
342
343%triggerpostun -- apache < 2.0
344/sbin/chkconfig --add apache2
345
346
347%post
348# Register the httpd service
349for mpm in %{mpms}; do
350  /sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.$mpm 20;
351done
352/sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.%{prefer_mpm} 30
353/sbin/chkconfig --add apache2
354
355%preun
356if [ $1 = 0 ]; then
357        /sbin/service apache2 stop > /dev/null 2>&1
358        /sbin/chkconfig --del apache2
359        for mpm in %{mpms}; do
360          /sbin/update-alternatives --remove apache2 %{_sbindir}/apache2.$mpm;
361        done 
362fi
363
364%postun
365if [ "$1" -ge 1 ]; then
366        /sbin/service apache2 condrestart
367fi
368/sbin/ldconfig
369
370%post -n mod_ssl-apache2
371/sbin/ldconfig ### is this needed?
372umask 077
373
374if [ ! -f %{_sysconfdir}/apache2/conf/ssl.key/server.key ] ; then
375%{_bindir}/openssl genrsa -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime 1024 > %{_sysconfdir}/apache2/conf/ssl.key/server.key 2> /dev/null
376fi
377
378FQDN=`hostname`
379if [ "x${FQDN}" = "x" ]; then
380   FQDN=localhost.localdomain
381fi
382
383if [ ! -f %{_sysconfdir}/apache2/conf/ssl.crt/server.crt ] ; then
384cat << EOF | %{_bindir}/openssl req -new -key %{_sysconfdir}/apache2/conf/ssl.key/server.key -x509 -days 365 -out %{_sysconfdir}/apache2/conf/ssl.crt/server.crt 2>/dev/null
385--
386SomeState
387SomeCity
388SomeOrganization
389SomeOrganizationalUnit
390${FQDN}
391root@${FQDN}
392EOF
393fi
394
395%clean
396rm -rf $RPM_BUILD_ROOT
397
398%files
399%defattr(-,root,root)
400
401%doc ABOUT_APACHE README CHANGES LAYOUT LICENSE
402%doc migration.html migration.css
403
404%dir %{_sysconfdir}/apache2
405%{_sysconfdir}/apache2/modules
406%{_sysconfdir}/apache2/logs
407%{_sysconfdir}/apache2/run
408%dir %{_sysconfdir}/apache2/conf
409%config(noreplace) %{_sysconfdir}/apache2/conf/*.conf
410%config(noreplace) %{_sysconfdir}/apache2/conf/magic
411
412%config %{_sysconfdir}/logrotate.d/apache2
413%config %{_sysconfdir}/rc.d/init.d/apache2
414
415%dir %{_sysconfdir}/apache2/conf.d
416%{_sysconfdir}/apache2/conf.d/README
417
418%dir %{_sysconfdir}/apache2/conf/extra
419%config %{_sysconfdir}/apache2/conf/extra/*
420
421%dir %{_sysconfdir}/apache2/conf/original
422%{_sysconfdir}/apache2/conf/original/*
423
424%{_bindir}/ab
425%{_bindir}/ht*
426%{_bindir}/logresolve
427%{_sbindir}/ht*
428%{_sbindir}/apache2.*
429%{_sbindir}/apache2ctl
430%{_sbindir}/rotatelogs2
431%attr(4510,root,%{suexec_caller}) %{_libdir}/%{pkgname}/suexec
432
433%dir %{_libdir}/apache2
434%dir %{_libdir}/apache2/modules
435# everything but mod_ssl.so:
436%{_libdir}/apache2/modules/mod_[a-r]*.so
437%{_libdir}/apache2/modules/mod_s[petu]*.so
438%{_libdir}/apache2/modules/mod_[t-z]*.so
439
440%dir %{contentdir}
441%dir %{contentdir}/cgi-bin
442%dir %{contentdir}/html
443%dir %{contentdir}/icons
444%dir %{contentdir}/error
445%dir %{contentdir}/error/include
446%{contentdir}/icons/*
447%{contentdir}/error/README
448%{contentdir}/error/noindex.html
449%config(noreplace) %{contentdir}/error/*.var
450%config(noreplace) %{contentdir}/error/include/*.html
451
452%attr(0700,root,root) %dir %{_localstatedir}/log/apache2
453
454%attr(0700,apache,apache) %dir %{_localstatedir}/lib/dav
455
456%{_mandir}/man1/*
457
458%{_mandir}/man8/*
459
460%files manual
461%defattr(-,root,root)
462%{contentdir}/manual
463
464%files -n mod_ssl-apache2
465%defattr(-,root,root)
466%{_libdir}/apache2/modules/mod_ssl.so
467%config(noreplace) %{_sysconfdir}/apache2/conf.d/ssl.conf
468%attr(0700,root,root) %dir %{_sysconfdir}/apache2/conf/ssl.*
469%config %{_sysconfdir}/apache2/conf/Makefile
470%config %{_sysconfdir}/apache2/conf/ssl.*/*
471%attr(0700,apache,root) %dir %{_localstatedir}/cache/mod_ssl
472%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.dir
473%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.pag
474%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.sem
475
476%files devel
477%defattr(-,root,root)
478%{_includedir}/apache2
479%{_sysconfdir}/apache2/build
480%{_bindir}/apxs
481%{_mandir}/man?/apxs*
482%{_libdir}/apache2/build/*.mk
483%{_libdir}/apache2/build/*.sh
484
485%changelog
486* Wed Mar  2 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.31-2
487- rebuilt with openssl 1.0.1s (no sslv2)
488
489* Sun Aug  2 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.31-1
490- new upstream release with security fixes
491
492* Sat Jan  3 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.29-1
493- new upstream release with security fixes
494  (drop patch100-120, which are included in new release)
495
496* Wed Aug 13 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.27-2
497- add Patch100 for fix CVE-2014-0118 (mod_deflate)
498- add Patch110 for fix CVE-2014-0226 (mod_status)
499- add Patch120 for fix CVE-2014-0231 (mod_cgid)
500  these patches are from debian wheezy, thanks
501
502* Fri Mar 28 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.27-1
503- new upstream release with security fix (CVE-2013-6438, 2014-0098)
504
505* Fri Jan 24 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.26-1
506- new upstream release
507
508* Sat Sep 28 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.25-1
509- new upstream release with security fix (CVE-2013-1862,1896)
510- drop patch100 (is included in new release)
511
512* Fri May 17 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-2
513- add patch100 for fix CVE-2013-1862 (mod_rewrite)
514
515* Wed Feb 27 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-1
516- new upstream release with security fix (CVE-2012-3499, 4558)
517
518* Sun Sep 16 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.23-1
519- new upstream release with security fix (CVE-2012-3502,CVE-2012-2687)
520- update patch22 to fit new release
521- update man filename convert list
522
523* Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.22-1
524- update to 2.2.22
525  - CVE-2012-0021 (mod_log_config)
526  - CVE-2012-0031
527  - CVE-2012-0053
528- remove upstreamed patches
529
530* Fri Dec  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-5
531- add patch120 for fix CVE-2011-4317 (mod_rewrite/mod_proxy)
532
533* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-4
534- add patch110 for fix CVE-2011-3607-4415 (ModSetEnvIf)
535
536* Wed Oct 12 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-3
537- add patch70 for fix byterange filter
538
539* Tue Oct 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-2
540- add Patch100 for fix CVE-2011-3368 (mod_proxy)
541
542* Wed Sep 14 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-1
543- new upstream release with security fix (CVE-2011-3348)
544- regression fixes of CVE-2011-3192 byterange fix in 2.2.20
545
546* Tue Sep  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-3
547- update Patch101 (Thanks to debian team)
548
549* Sat Sep  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-2
550- add Patch101 for fix CVE-2011-3192 regression
551
552* Thu Sep  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-1
553- new upstream release with security fix (CVE-2011-3192)
554- drop patch100 (is included in new release)
555
556* Thu Aug 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.19-2
557- add patch100 for fix CVE-2011-3192 (Range Header DoS)
558
559* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.19-1
560- update to 2.2.19
561
562* Sat Apr 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-9
563- remove old Obsoletes/Conflicts
564
565* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-8
566- rebuild with openssl-1.0.0c
567
568* Sat Aug 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.14-7
569- add  patch120 for fix CVE-2010-1452 (mod_dav/mod_cache) from mdk2010
570
571* Wed Aug 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-6
572- add R(post): alternatives
573
574* Sat Mar 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-5
575- add patch110 for fix CVE-2010-0434 from mdk 2010
576
577* Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-4
578- add patch100 for fix CVE-2010-0408 (mod_proxy_ajp)
579
580* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.14-3
581- rebuilt with rpm-4.8.0-3 (on ppc)
582
583* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-2
584- rebuild with db4-4.8.0
585
586* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-1
587- new upstream release with security fix
588  (CVE-2009-2699, CVE-2009-3095, CVE-2009-3094)
589- fix ssl.conf (2.2.13-1 includes wrong file)
590
591* Sun Aug 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.13-1
592- new upstream release
593
594* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.12-1
595- new upstream release
596  (including security fix for CVE-2009-1890, CVE-2009-1191,
597   CVE-2009-1195, CVE-2009-1955, CVE-2009-1956, CVE-2009-0023)
598
599* Fri Jan 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-2
600- rebuilt with openldap-2.4.11
601
602* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-1
603- new upstream release
604
605* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-1
606- new upstream release (including security fix for CVE-2008-2939)
607
608* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-1
609- new upstream release (including security fix for CVE-2008-2364, CVE-2007-6420)
610- built with db4-4.6.21, apr 1.3.0
611
612* Sun Apr 27 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.8-1
613- add Patch60 (to fix bug#31418).
614
615* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.8-0vl2
616- rebuild with expat-2.0.1
617
618* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
619- new upstream release
620
621* Sat Nov  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-0vl2
622- added postun script from VinePlus/4.0 package
623  * Tue Sep 11 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.3-0vl3.2
624  - add postun script to restart daemon with message
625
626* Sun Jul 01 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl8
627- updated Patch2: httpd-2.2.3-apxs.patch
628
629* Sun Jun 24 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl7
630- modified libdir in config.layout for lib64 architecture
631
632* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
633- rebuilt with openssl-0.9.8e
634
635* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl5
636- rebuilt with new toolchain and db4-4.3.x
637
638* Tue Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl4
639- added BuildRequires: pcre-devel, sqlite3-devel <BTS:VineLinux:474>
640
641* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.3-0vl3
642- change manual Group to Applications/Documentation. <BTS:VineLinux:163>
643
644* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl2
645- rebuilt with openldap-2.3.27-0vl1
646
647* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
648- new upstream release including security fix (CVE-2006-3747)
649
650* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
651- new upstream release
652  - update to 2.2.2
653- remove apr/apr-devel subpackage,
654  use external apr/apr-util instead of internal one.
655
656* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.58-0vl1
657- new upstream release
658- use apache2.prefork as default.
659
660* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl3
661- rebuild to use new _localstatedir (rpm-4.4.2-0vl11)
662- remove unpackaged files in %%install section
663
664* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl2
665- fix logrotate configuration (use apache2.pid instead of httpd.pid)
666  (BTS:10)
667- use Epoch instead of Serial
668
669* Sat Oct 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl1
670- new upstream release
671- drop obsolete security patches which is merged in upstream
672
673* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.54-0vl1
674- new upstream release
675
676* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl2
677- added Patch122 to 125 for secutiry fix
678  (CAN-2004-{1268,2088,2700,2728})
679- fix %install section
680
681* Sun Apr 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl1
682- new upstream release
683
684* Sat Nov 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.52-0vl1
685- new upstream release
686
687* Sun Oct 24 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.50-0vl4
688- rebuilt with db4-4.2.52
689
690* Sat Sep  4 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.0.50-0vl3
691- separate apr, apr-devel packages
692- add BuildPreReq: zlib-devel
693
694* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.50-0vl2
695- fix %%files to include instdso.sh
696  thanks to jax <jax AT morejams DOT no-ip DOT com>
697- add %%{?_smp_mflags} to make option.
698
699* Sun Jul  4 2004 IWAI, Masaharu <iwai@alib.jp> 2.0.50-0vl1
700- new upstream version
701
702* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.48-0vl1
703- new upstream version
704
705* Mon Sep 15 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.47-0vl1
706- new upstream version
707- update apxs patch (Patch101)
708- fix dependency:
709    - change file name to package name in Requires and {Build,}Prereq
710- add BuildPrereq: openldap-devel
711- update %%files section
712- rename httpd.8 manpage
713
714* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.45-0vl1
715- new upstream version
716- used vine-config.layout in srclib
717
718* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.44-0vl9
719- rebuild
720
721* Sun Apr  6 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl8
722- change pkg name from mod_ssl to mod_ssl-apache2
723- remove "apache-manual" entry from Obsoletes:
724
725* Thu Apr  3 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl7
726- remove "mod_dav" and "apache-devel" from Obsoletes:
727- enable MPMS(worker %mpms )
728
729* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl6
730- add correct config_vars.mk
731
732* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl5
733- apply apxs's patch ( from Debian)
734
735* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl4
736- add apr-config,apu-config to devel's %file
737
738* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl3
739- change apxs path ( /usr/sbin -> /usr/bin
740- add symlink under /etc/apache2/conf
741  (logs, run), httpd.conf -> apache2.conf
742- fixed apache2 initscript.
743
744* Sat Mar 29 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl2
745- build Vine Linux
746- new upstream version
747- sharing with apache1
748
749* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
750- link httpd with libssl to avoid library loading/unloading weirdness
751
752* Tue Sep  3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
753- add LoadModule lines for proxy modules in httpd.conf (#73349)
754- fix permissions of conf/ssl.*/ directories; add Makefiles for
755  certificate management (#73352)
756
757* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
758- provide "httpd-mmn" to manage module ABI compatibility
759
760* Sun Sep  1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
761- fix SSL session cache (#69699)
762- revert addition of LDAP support to apr-util
763
764* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
765- set SIGXFSZ disposition to "ignored" (#69520)
766- make dummy connections to the first listener in config (#72692)
767
768* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
769- allow "apachectl configtest" on a 1.3 httpd.conf
770- add mod_deflate
771- enable LDAP support in apr-util
772- don't package everything in /var/www/error as config(noreplace)
773
774* Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
775- add trigger (#68657)
776
777* Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
778- update to 2.0.40
779
780* Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
781- improve comment on use of UserDir in default config (#66886)
782
783* Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
784- use /sbin/nologin as shell for apache user (#68371)
785- add patch from CVS to fix possible infinite loop when processing
786  internal redirects
787
788* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
789- modify init script to detect 1.3.x httpd.conf's and direct users
790  to the migration guide
791
792* Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
793- patch apachectl to detect 1.3.x httpd.conf's and direct users
794  to the migration guide
795- ship the migration guide
796
797* Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
798- move /etc/httpd2 back to /etc/httpd
799- add noindex.html page and poweredby logo; tweak default config
800  to load noindex.html if no default "/" page is present.
801- add patch to prevent mutex errors on graceful restart
802
803* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
804- automated rebuild
805
806* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
807- add patch to fix SSL mutex handling
808
809* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
810- improved config directory patch
811
812* Mon May 20 2002 Joe Orton <jorton@redhat.com>
813- initial build; based heavily on apache.spec and mod_ssl.spec
814- fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245
815
Note: See TracBrowser for help on using the repository browser.