source: projects/specs/branches/6/R/R/R-vl.spec @ 2788

Revision 2788, 12.5 KB checked in by Takemikaduchi, 13 years ago (diff)

add BR: libicu-devel

Line 
1%define pkg_version 2.12.1
2%define pkg_release 3%{?_dist_release}
3
4Summary:          A language for data analysis and graphics
5Summary(ja):      データ解析・グラフィック化の言語
6Name:             R
7Version:          %{pkg_version}
8Release:          %{pkg_release}
9Source0:          ftp://cran.r-project.org/pub/R/src/base/R-2/%{name}-%{version}.tar.gz
10#Patch0:           R-release.diff.gz
11License:          GPLv2+
12Group:            Applications/Engineering
13URL:              http://www.r-project.org
14
15Requires: libgfortran
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: gcc-c++
19BuildRequires: gcc-gfortran libgfortran
20%if %{?_dist_release} == "vl5"
21BuildRequires: tetex
22%else
23BuildRequires: texlive
24BuildRequires: texlive-collection-basic
25BuildRequires: texlive-collection-texinfo
26%endif
27BuildRequires: texinfo tcl tk
28BuildRequires: libpng-devel libjpeg-devel libtiff-devel
29BuildRequires: readline-devel libtermcap-devel
30BuildRequires: zlib-devel bzip2-devel
31BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
32BuildRequires: cairo-devel pango-devel
33BuildRequires: libicu-devel
34
35Vendor: Project Vine
36Distribution: Vine Linux
37Packager: Toshiaki Ara <ara_t@384.jp>
38
39%description
40'GNU S' - A language and environment for statistical computing and
41graphics. R is similar to the award-winning S system, which was
42developed at Bell Laboratories by John Chambers et al. It provides
43a wide variety of statistical and graphical techniques (linear and
44nonlinear modelling, statistical tests, time series analysis,
45classification, clustering, ...).
46
47R is designed as a true computer language with control-flow
48constructions for iteration and alternation, and it allows users to
49add additional functionality by defining new functions.
50For computationally intensive tasks, C, C++ and Fortran code
51can be linked and called at run time.
52
53%description -l ja
54'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
55Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
56線形・非線型モデル、統計検定、時系列分析、クラスター分析など
57幅広い統計解析・視覚化手法を提供する。
58Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
59として設計されており、ユーザが新たに関数を組み込むことが可能である。
60また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
61使用することができる。
62
63%package devel
64Summary:          files for development of R packages.
65Summary(ja):      Rパッケージ開発用ファイル
66Group:            Development/Libraries
67Requires:         R = %{version}-%{release}
68
69%description devel
70Install R-devel if you are going to develop or compile R packages.
71
72This is just a stub package containing the documentation on "Writing R
73Extensions".  However, installing it will ensure that the build
74environment for R packages is correct.
75
76%description -l ja devel
77Rパッケージを開発したりコンパイルする場合には、このR-develを
78インストールします。R-exts.pdf ("Writing R Extensions": 英文)
79が含まれているだけのサブパッケージですが、正しくRパッケージを
80開発するための助けになるでしょう。
81
82%package -n libRmath
83Summary:          standalone math library from the R project
84Summary(ja):      単独で動作するRプロジェクトの数理ライブラリ
85Group:            System Environment/Libraries
86
87%description -n libRmath
88A standalone library of mathematical and statistical functions derived
89from the R project.  This packages provides the shared libRmath library.
90
91%description -l ja -n libRmath
92単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
93共有ライブラリを提供する。
94
95%package -n libRmath-devel
96Summary:          standalone math library from the R project
97Summary(ja):      libRmathの開発ライブラリ
98Group:            Development/Libraries
99Requires:         libRmath = %{version}-%{release}
100
101%description -n libRmath-devel
102A standalone library of mathematical and statistical functions derived
103from the R project.  This packages provides the header files.
104
105%description -l ja -n libRmath-devel
106libRmathのヘッダファイル(Rmath.h)
107
108%package -n libRmath-static
109Summary: Static R Standalone math library
110Summary(ja): libRmath の静的ライブラリ
111Group: Development/Libraries
112Requires: libRmath-devel = %{version}-%{release}
113
114%description -n libRmath-static
115A standalone library of mathematical and statistical functions derived
116from the R project.  This package provides the static libRmath library.
117
118
119%prep
120%{__rm} -rf ${RPM_BUILD_ROOT}
121%setup -q
122#%patch0 -p1
123
124%build
125export R_PDFVIEWER="%{_bindir}/xdg-open"
126export R_PRINTCMD="lpr"
127export R_BROWSER="%{_bindir}/xdg-open"
128%configure --enable-R-shlib
129%{__make} %{?_smp_mflags}
130(cd src/nmath/standalone; %{__make} %{?_smp_mflags})
131LANG=C make check-all
132%{__make} pdf
133#We can only "make info" if we have an up to date version of texinfo
134%{?INFO: %{__make} info}
135
136
137%install
138%{__make} install DESTDIR=${RPM_BUILD_ROOT} install-pdf %{?INFO:install-info}
139%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
140%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
141
142#Install libRmath files
143(cd src/nmath/standalone; %{__make} install DESTDIR=${RPM_BUILD_ROOT})
144
145mkdir -p ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
146echo "%{_libdir}/R/lib" > ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
147
148#Fix lication of R_HOME_DIR in shell wrapper
149sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
150  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
151chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
152sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
153  > ${RPM_BUILD_ROOT}%{_bindir}/R
154chmod 755 ${RPM_BUILD_ROOT}%{_bindir}/R
155
156
157%files
158%defattr(-, root, root)
159%{_bindir}/R
160%{_bindir}/Rscript
161%{_libdir}/R
162%{?INFO:%{_infodir}/R-*.info*}
163%{_mandir}/man1/*
164/etc/ld.so.conf.d/*
165
166%files devel
167%defattr(-, root, root)
168%doc doc/manual/R-exts.pdf
169
170%files -n libRmath
171%defattr(-, root, root)
172%{_libdir}/libRmath.so
173
174%files -n libRmath-devel
175%defattr(-, root, root)
176%{_libdir}/pkgconfig/*.pc
177%{_includedir}/Rmath.h
178
179%files -n libRmath-static
180%defattr(-, root, root)
181%{_libdir}/libRmath.a
182
183%clean
184%{__rm} -rf ${RPM_BUILD_ROOT}
185
186
187%post
188%if 0%{?INFO}
189   # Create directory entries for info files
190   # (optional doc files, so we must check that they are installed)
191   for doc in admin data exts FAQ intro lang; do
192      file=%{_infodir}/R-${doc}.info.gz
193      if [ -e $file ]; then
194         /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
195      fi
196   done
197%endif
198%{_syssbindir}/ldconfig
199
200%preun
201%if 0%{?INFO}
202   if [ $1 = 0 ]; then
203      # Delete directory entries for info files (if they were installed)
204      for doc in admin data exts FAQ intro lang; do
205         file=%{_infodir}/R-${doc}.info.gz
206         if [ -e ${file} ]; then
207            /sbin/install-info --delete R-${doc} %{_infodir}/dir 2>/dev/null
208         fi
209      done
210   fi
211%endif
212
213%postun -p %{_syssbindir}/ldconfig
214
215%post -n libRmath -p %{_syssbindir}/ldconfig
216
217%postun -n libRmath -p %{_syssbindir}/ldconfig
218
219
220%changelog
221* Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
222- add BuildRequires: libicu-devel
223
224* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
225- synchronized to VinePlus/5 package
226  * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
227  - Updated to 2.12.1
228- added --enable-R-shlib option to %%configure
229- added static subpackage
230- use BR: texlive instead of tetex on VineSeed
231
232* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
233- rebuilt with rpm-4.8.1 for pkg-config
234
235* Thu Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
236- recompiled because tcl/tk were not linked
237
238* Thu Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
239- Updated to 2.11.0
240- added Requires: libgfortran
241
242* Thu Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
243- Updated to 2.10.1
244
245* Thu Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
246- patched to 2.10.0
247
248* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
249- spec in UTF-8
250
251* Thu Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
252- Updated to 2.10.0
253
254* Thu Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
255- Updated to 2.9.2
256- deleted BuildRequires: lapack-devel blas-devel
257- rewrote SPEC file
258
259* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
260- Updated to 2.5.1
261- added BuildRequires: gcc-gfortran for VineSeed
262- added BuildRequires: lapack-devel blas-devel
263- fixed %preun script
264
265* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
266- Updated to 2.4.1
267- Added INFO option
268- Exclude Japanese Rprofile.site
269
270* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
271- Updated to 2.4.0
272
273* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
274- Added optimization flags
275
276* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
277- Packaged for VineLinux3.2
278
279* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
280- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
281
282* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
283- Packaged for VineLinux3.2
284- Slipped texinfo
285- Fixed preun error
286- Preset Japanese fonts
287
288* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
289- Packaged for VineLinux3.2
290
291* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
292- Restored CAPABILITIES file lost in 2.2.1beta
293
294* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
295- Configure uses --without-blas by default.
296- Install pdf manuals.
297- All toplevel documentation files are installed into _libdir/R
298  as they may be required by R (qv note on AUTHORS and THANKS below).
299- Legacy scripts for rebuilding package indices removed.
300
301* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
302- R now compiles with gcc 4.0.1 and default rpm optimization flags.
303
304* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
305- The files AUTHORS and THANKS need to be installed into _libdir/R
306  as they are required by the function contributors().  Previously
307  they were installed only as documentation files.
308
309* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
310- Corrected date error in SPEC file.
311
312* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
313- Dropped support for Red Hat boxed set.
314- Synchronized with Fedora Extras 4 RPM by Tom Calloway
315  including support for shared R library.
316- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
317  with the default optimization flags, so there is a temporary work-around.
318
319* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
320- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
321
322* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
323- Install R-data.info file as well.
324- Make info processing conditional on texinfo version, not platform release,
325  so that if a new enough version is installed, we will build and install info.
326
327* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
328- Built R 2.1.0.  R now supports internationalization, so the patch
329  to set the locale to "C" is now dropped.
330- install.packages() exits gracefully with a helpful message if
331  the file INSTALL is not present, so this is now included in the
332  R-devel package.
333
334* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
335- Added support for Scientific Linux (http://www.scientificlinux.org)
336  A distribution based on RHEL. Thanks to Jon Peatfield.
337
338* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
339- Fixed file ownership in R-devel and libRmath packages
340
341* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
342- R-devel package is now a stub package with no files, except a documentation
343  file (RPM won't accept sub-packages with no files). R now conflicts
344  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
345- Created libRmath subpackage with shared library.
346
347* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
348- Created R-devel and libRmath-devel subpackages
349
350* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
351- Built R 2.0.1
352
353* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
354- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
355  gives "lpr".
356- Define macro fcx for all Fedora distributions. This replaces Rinfo
357
358* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
359- Info support is now conditional on the macro Rinfo, which is only
360  defined for Fedora 1 and 2.
361
362* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
363- Built R 2.0.0
364- There is no longer a BUGS file, so this is not installed as a
365  documentation file.
Note: See TracBrowser for help on using the repository browser.