source: projects/specs/trunk/R/R/R-vl.spec @ 4745

Revision 4745, 12.9 KB checked in by inagaki, 13 years ago (diff)

update: R

Line 
1%define pkg_version 2.13.1
2%define pkg_release 2%{?_dist_release}
3
4Summary:          A language for data analysis and graphics
5Summary(ja):      データ解析・グラフィック化の言語
6Name:             R
7Version:          %{pkg_version}
8Release:          %{pkg_release}
9
10License:          GPLv2+
11Group:            Applications/Engineering
12URL:              http://www.r-project.org
13
14Source0:          ftp://cran.r-project.org/pub/R/src/base/R-2/%{name}-%{version}.tar.gz
15#Patch0:           R-release.diff.gz
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: gcc-c++
19BuildRequires: gcc-gfortran libgfortran
20%if %{?_dist_release} == "vl5"
21BuildRequires: tetex
22%else
23BuildRequires: texlive
24BuildRequires: texlive-collection-basic
25BuildRequires: texlive-collection-texinfo
26%endif
27BuildRequires: texinfo tcl tk
28BuildRequires: libpng-devel libjpeg-devel libtiff-devel
29BuildRequires: readline-devel libtermcap-devel
30BuildRequires: zlib-devel bzip2-devel
31BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
32BuildRequires: cairo-devel pango-devel
33BuildRequires: libicu-devel
34Requires: libgfortran
35
36Vendor: Project Vine
37Distribution: Vine Linux
38Packager: Toshiaki Ara <ara_t@384.jp>
39
40%description
41'GNU S' - A language and environment for statistical computing and
42graphics. R is similar to the award-winning S system, which was
43developed at Bell Laboratories by John Chambers et al. It provides
44a wide variety of statistical and graphical techniques (linear and
45nonlinear modelling, statistical tests, time series analysis,
46classification, clustering, ...).
47
48R is designed as a true computer language with control-flow
49constructions for iteration and alternation, and it allows users to
50add additional functionality by defining new functions.
51For computationally intensive tasks, C, C++ and Fortran code
52can be linked and called at run time.
53
54%description -l ja
55'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
56Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
57線形・非線型モデル、統計検定、時系列分析、クラスター分析など
58幅広い統計解析・視覚化手法を提供する。
59Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
60として設計されており、ユーザが新たに関数を組み込むことが可能である。
61また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
62使用することができる。
63
64%package devel
65Summary:          files for development of R packages.
66Summary(ja):      Rパッケージ開発用ファイル
67Group:            Development/Libraries
68Requires:         R = %{version}-%{release}
69
70%description devel
71Install R-devel if you are going to develop or compile R packages.
72
73This is just a stub package containing the documentation on "Writing R
74Extensions".  However, installing it will ensure that the build
75environment for R packages is correct.
76
77%description -l ja devel
78Rパッケージを開発したりコンパイルする場合には、このR-develを
79インストールします。R-exts.pdf ("Writing R Extensions": 英文)
80が含まれているだけのサブパッケージですが、正しくRパッケージを
81開発するための助けになるでしょう。
82
83%package -n libRmath
84Summary:          standalone math library from the R project
85Summary(ja):      単独で動作するRプロジェクトの数理ライブラリ
86Group:            System Environment/Libraries
87
88%description -n libRmath
89A standalone library of mathematical and statistical functions derived
90from the R project.  This packages provides the shared libRmath library.
91
92%description -l ja -n libRmath
93単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
94共有ライブラリを提供する。
95
96%package -n libRmath-devel
97Summary:          standalone math library from the R project
98Summary(ja):      libRmathの開発ライブラリ
99Group:            Development/Libraries
100Requires:         libRmath = %{version}-%{release}
101
102%description -n libRmath-devel
103A standalone library of mathematical and statistical functions derived
104from the R project.  This packages provides the header files.
105
106%description -l ja -n libRmath-devel
107libRmathのヘッダファイル(Rmath.h)
108
109%package -n libRmath-static
110Summary: Static R Standalone math library
111Summary(ja): libRmath の静的ライブラリ
112Group: Development/Libraries
113Requires: libRmath-devel = %{version}-%{release}
114
115%description -n libRmath-static
116A standalone library of mathematical and statistical functions derived
117from the R project.  This package provides the static libRmath library.
118
119
120%prep
121%{__rm} -rf ${RPM_BUILD_ROOT}
122%setup -q
123#%patch0 -p1
124
125%build
126export R_PDFVIEWER="%{_bindir}/xdg-open"
127export R_PRINTCMD="lpr"
128export R_BROWSER="%{_bindir}/xdg-open"
129%configure --enable-R-shlib
130%{__make} %{?_smp_mflags}
131(cd src/nmath/standalone; %{__make} %{?_smp_mflags})
132LANG=C make check-all
133%{__make} pdf
134#We can only "make info" if we have an up to date version of texinfo
135%{?INFO: %{__make} info}
136
137
138%install
139%{__make} install DESTDIR=${RPM_BUILD_ROOT} install-pdf %{?INFO:install-info}
140%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
141%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
142
143#Install libRmath files
144(cd src/nmath/standalone; %{__make} install DESTDIR=${RPM_BUILD_ROOT})
145
146mkdir -p ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
147echo "%{_libdir}/R/lib" > ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
148
149#Fix lication of R_HOME_DIR in shell wrapper
150sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
151  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
152chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
153sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
154  > ${RPM_BUILD_ROOT}%{_bindir}/R
155chmod 755 ${RPM_BUILD_ROOT}%{_bindir}/R
156
157
158%files
159%defattr(-, root, root)
160%{_bindir}/R
161%{_bindir}/Rscript
162%{_libdir}/R
163%{?INFO:%{_infodir}/R-*.info*}
164%{_mandir}/man1/*
165/etc/ld.so.conf.d/*
166
167%files devel
168%defattr(-, root, root)
169%doc doc/manual/R-exts.pdf
170
171%files -n libRmath
172%defattr(-, root, root)
173%{_libdir}/libRmath.so
174
175%files -n libRmath-devel
176%defattr(-, root, root)
177%{_libdir}/pkgconfig/*.pc
178%{_includedir}/Rmath.h
179
180%files -n libRmath-static
181%defattr(-, root, root)
182%{_libdir}/libRmath.a
183
184%clean
185%{__rm} -rf ${RPM_BUILD_ROOT}
186
187
188%post
189%if 0%{?INFO}
190   # Create directory entries for info files
191   # (optional doc files, so we must check that they are installed)
192   for doc in admin data exts FAQ intro lang; do
193      file=%{_infodir}/R-${doc}.info.gz
194      if [ -e $file ]; then
195         /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
196      fi
197   done
198%endif
199%{_syssbindir}/ldconfig
200
201%preun
202%if 0%{?INFO}
203   if [ $1 = 0 ]; then
204      # Delete directory entries for info files (if they were installed)
205      for doc in admin data exts FAQ intro lang; do
206         file=%{_infodir}/R-${doc}.info.gz
207         if [ -e ${file} ]; then
208            /sbin/install-info --delete R-${doc} %{_infodir}/dir 2>/dev/null
209         fi
210      done
211   fi
212%endif
213
214%postun -p %{_syssbindir}/ldconfig
215
216%post -n libRmath -p %{_syssbindir}/ldconfig
217
218%postun -n libRmath -p %{_syssbindir}/ldconfig
219
220
221%changelog
222* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
223- synchronized to VinePlus/5 package
224  * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
225  - Updated to 2.13.1
226  * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
227  - Updated to 2.13.0
228  * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
229  - Updated to 2.12.2
230
231* Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
232- add BuildRequires: libicu-devel
233
234* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
235- synchronized to VinePlus/5 package
236  * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
237  - Updated to 2.12.1
238- added --enable-R-shlib option to %%configure
239- added static subpackage
240- use BR: texlive instead of tetex on VineSeed
241
242* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
243- rebuilt with rpm-4.8.1 for pkg-config
244
245* Thu Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
246- recompiled because tcl/tk were not linked
247
248* Thu Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
249- Updated to 2.11.0
250- added Requires: libgfortran
251
252* Thu Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
253- Updated to 2.10.1
254
255* Thu Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
256- patched to 2.10.0
257
258* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
259- spec in UTF-8
260
261* Thu Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
262- Updated to 2.10.0
263
264* Thu Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
265- Updated to 2.9.2
266- deleted BuildRequires: lapack-devel blas-devel
267- rewrote SPEC file
268
269* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
270- Updated to 2.5.1
271- added BuildRequires: gcc-gfortran for VineSeed
272- added BuildRequires: lapack-devel blas-devel
273- fixed %preun script
274
275* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
276- Updated to 2.4.1
277- Added INFO option
278- Exclude Japanese Rprofile.site
279
280* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
281- Updated to 2.4.0
282
283* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
284- Added optimization flags
285
286* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
287- Packaged for VineLinux3.2
288
289* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
290- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
291
292* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
293- Packaged for VineLinux3.2
294- Slipped texinfo
295- Fixed preun error
296- Preset Japanese fonts
297
298* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
299- Packaged for VineLinux3.2
300
301* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
302- Restored CAPABILITIES file lost in 2.2.1beta
303
304* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
305- Configure uses --without-blas by default.
306- Install pdf manuals.
307- All toplevel documentation files are installed into _libdir/R
308  as they may be required by R (qv note on AUTHORS and THANKS below).
309- Legacy scripts for rebuilding package indices removed.
310
311* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
312- R now compiles with gcc 4.0.1 and default rpm optimization flags.
313
314* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
315- The files AUTHORS and THANKS need to be installed into _libdir/R
316  as they are required by the function contributors().  Previously
317  they were installed only as documentation files.
318
319* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
320- Corrected date error in SPEC file.
321
322* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
323- Dropped support for Red Hat boxed set.
324- Synchronized with Fedora Extras 4 RPM by Tom Calloway
325  including support for shared R library.
326- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
327  with the default optimization flags, so there is a temporary work-around.
328
329* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
330- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
331
332* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
333- Install R-data.info file as well.
334- Make info processing conditional on texinfo version, not platform release,
335  so that if a new enough version is installed, we will build and install info.
336
337* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
338- Built R 2.1.0.  R now supports internationalization, so the patch
339  to set the locale to "C" is now dropped.
340- install.packages() exits gracefully with a helpful message if
341  the file INSTALL is not present, so this is now included in the
342  R-devel package.
343
344* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
345- Added support for Scientific Linux (http://www.scientificlinux.org)
346  A distribution based on RHEL. Thanks to Jon Peatfield.
347
348* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
349- Fixed file ownership in R-devel and libRmath packages
350
351* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
352- R-devel package is now a stub package with no files, except a documentation
353  file (RPM won't accept sub-packages with no files). R now conflicts
354  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
355- Created libRmath subpackage with shared library.
356
357* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
358- Created R-devel and libRmath-devel subpackages
359
360* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
361- Built R 2.0.1
362
363* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
364- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
365  gives "lpr".
366- Define macro fcx for all Fedora distributions. This replaces Rinfo
367
368* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
369- Info support is now conditional on the macro Rinfo, which is only
370  defined for Fedora 1 and 2.
371
372* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
373- Built R 2.0.0
374- There is no longer a BUGS file, so this is not installed as a
375  documentation file.
Note: See TracBrowser for help on using the repository browser.