source: projects/specs/trunk/R/R/R-vl.spec @ 2765

Revision 2765, 12.4 KB checked in by inagaki, 13 years ago (diff)

updated: R

Line 
1%define pkg_version 2.12.1
2%define pkg_release 2%{?_dist_release}
3
4Summary:          A language for data analysis and graphics
5Summary(ja):      データ解析・グラフィック化の言語
6Name:             R
7Version:          %{pkg_version}
8Release:          %{pkg_release}
9Source0:          ftp://cran.r-project.org/pub/R/src/base/R-2/%{name}-%{version}.tar.gz
10#Patch0:           R-release.diff.gz
11License:          GPLv2+
12Group:            Applications/Engineering
13URL:              http://www.r-project.org
14
15Requires: libgfortran
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: gcc-c++
19BuildRequires: gcc-gfortran libgfortran
20%if %{?_dist_release} == "vl5"
21BuildRequires: tetex
22%else
23BuildRequires: texlive
24BuildRequires: texlive-collection-basic
25BuildRequires: texlive-collection-texinfo
26%endif
27BuildRequires: texinfo tcl tk
28BuildRequires: libpng-devel libjpeg-devel libtiff-devel
29BuildRequires: readline-devel libtermcap-devel
30BuildRequires: zlib-devel bzip2-devel
31BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
32BuildRequires: cairo-devel pango-devel
33
34Vendor: Project Vine
35Distribution: Vine Linux
36Packager: Toshiaki Ara <ara_t@384.jp>
37
38%description
39'GNU S' - A language and environment for statistical computing and
40graphics. R is similar to the award-winning S system, which was
41developed at Bell Laboratories by John Chambers et al. It provides
42a wide variety of statistical and graphical techniques (linear and
43nonlinear modelling, statistical tests, time series analysis,
44classification, clustering, ...).
45
46R is designed as a true computer language with control-flow
47constructions for iteration and alternation, and it allows users to
48add additional functionality by defining new functions.
49For computationally intensive tasks, C, C++ and Fortran code
50can be linked and called at run time.
51
52%description -l ja
53'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
54Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
55線形・非線型モデル、統計検定、時系列分析、クラスター分析など
56幅広い統計解析・視覚化手法を提供する。
57Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
58として設計されており、ユーザが新たに関数を組み込むことが可能である。
59また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
60使用することができる。
61
62%package devel
63Summary:          files for development of R packages.
64Summary(ja):      Rパッケージ開発用ファイル
65Group:            Development/Libraries
66Requires:         R = %{version}-%{release}
67
68%description devel
69Install R-devel if you are going to develop or compile R packages.
70
71This is just a stub package containing the documentation on "Writing R
72Extensions".  However, installing it will ensure that the build
73environment for R packages is correct.
74
75%description -l ja devel
76Rパッケージを開発したりコンパイルする場合には、このR-develを
77インストールします。R-exts.pdf ("Writing R Extensions": 英文)
78が含まれているだけのサブパッケージですが、正しくRパッケージを
79開発するための助けになるでしょう。
80
81%package -n libRmath
82Summary:          standalone math library from the R project
83Summary(ja):      単独で動作するRプロジェクトの数理ライブラリ
84Group:            System Environment/Libraries
85
86%description -n libRmath
87A standalone library of mathematical and statistical functions derived
88from the R project.  This packages provides the shared libRmath library.
89
90%description -l ja -n libRmath
91単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
92共有ライブラリを提供する。
93
94%package -n libRmath-devel
95Summary:          standalone math library from the R project
96Summary(ja):      libRmathの開発ライブラリ
97Group:            Development/Libraries
98Requires:         libRmath = %{version}-%{release}
99
100%description -n libRmath-devel
101A standalone library of mathematical and statistical functions derived
102from the R project.  This packages provides the header files.
103
104%description -l ja -n libRmath-devel
105libRmathのヘッダファイル(Rmath.h)
106
107%package -n libRmath-static
108Summary: Static R Standalone math library
109Summary(ja): libRmath の静的ライブラリ
110Group: Development/Libraries
111Requires: libRmath-devel = %{version}-%{release}
112
113%description -n libRmath-static
114A standalone library of mathematical and statistical functions derived
115from the R project.  This package provides the static libRmath library.
116
117
118%prep
119%{__rm} -rf ${RPM_BUILD_ROOT}
120%setup -q
121#%patch0 -p1
122
123%build
124export R_PDFVIEWER="%{_bindir}/xdg-open"
125export R_PRINTCMD="lpr"
126export R_BROWSER="%{_bindir}/xdg-open"
127%configure --enable-R-shlib
128%{__make} %{?_smp_mflags}
129(cd src/nmath/standalone; %{__make} %{?_smp_mflags})
130LANG=C make check-all
131%{__make} pdf
132#We can only "make info" if we have an up to date version of texinfo
133%{?INFO: %{__make} info}
134
135
136%install
137%{__make} install DESTDIR=${RPM_BUILD_ROOT} install-pdf %{?INFO:install-info}
138%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
139%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
140
141#Install libRmath files
142(cd src/nmath/standalone; %{__make} install DESTDIR=${RPM_BUILD_ROOT})
143
144mkdir -p ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
145echo "%{_libdir}/R/lib" > ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
146
147#Fix lication of R_HOME_DIR in shell wrapper
148sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
149  > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
150chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
151sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
152  > ${RPM_BUILD_ROOT}%{_bindir}/R
153chmod 755 ${RPM_BUILD_ROOT}%{_bindir}/R
154
155
156%files
157%defattr(-, root, root)
158%{_bindir}/R
159%{_bindir}/Rscript
160%{_libdir}/R
161%{?INFO:%{_infodir}/R-*.info*}
162%{_mandir}/man1/*
163/etc/ld.so.conf.d/*
164
165%files devel
166%defattr(-, root, root)
167%doc doc/manual/R-exts.pdf
168
169%files -n libRmath
170%defattr(-, root, root)
171%{_libdir}/libRmath.so
172
173%files -n libRmath-devel
174%defattr(-, root, root)
175%{_libdir}/pkgconfig/*.pc
176%{_includedir}/Rmath.h
177
178%files -n libRmath-static
179%defattr(-, root, root)
180%{_libdir}/libRmath.a
181
182%clean
183%{__rm} -rf ${RPM_BUILD_ROOT}
184
185
186%post
187%if 0%{?INFO}
188   # Create directory entries for info files
189   # (optional doc files, so we must check that they are installed)
190   for doc in admin data exts FAQ intro lang; do
191      file=%{_infodir}/R-${doc}.info.gz
192      if [ -e $file ]; then
193         /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
194      fi
195   done
196%endif
197%{_syssbindir}/ldconfig
198
199%preun
200%if 0%{?INFO}
201   if [ $1 = 0 ]; then
202      # Delete directory entries for info files (if they were installed)
203      for doc in admin data exts FAQ intro lang; do
204         file=%{_infodir}/R-${doc}.info.gz
205         if [ -e ${file} ]; then
206            /sbin/install-info --delete R-${doc} %{_infodir}/dir 2>/dev/null
207         fi
208      done
209   fi
210%endif
211
212%postun -p %{_syssbindir}/ldconfig
213
214%post -n libRmath -p %{_syssbindir}/ldconfig
215
216%postun -n libRmath -p %{_syssbindir}/ldconfig
217
218
219%changelog
220* Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
221- synchronized to VinePlus/5 package
222  * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
223  - Updated to 2.12.1
224- added --enable-R-shlib option to %%configure
225- added static subpackage
226- use BR: texlive instead of tetex on VineSeed
227
228* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
229- rebuilt with rpm-4.8.1 for pkg-config
230
231* Thu Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
232- recompiled because tcl/tk were not linked
233
234* Thu Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
235- Updated to 2.11.0
236- added Requires: libgfortran
237
238* Thu Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
239- Updated to 2.10.1
240
241* Thu Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
242- patched to 2.10.0
243
244* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
245- spec in UTF-8
246
247* Thu Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
248- Updated to 2.10.0
249
250* Thu Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
251- Updated to 2.9.2
252- deleted BuildRequires: lapack-devel blas-devel
253- rewrote SPEC file
254
255* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
256- Updated to 2.5.1
257- added BuildRequires: gcc-gfortran for VineSeed
258- added BuildRequires: lapack-devel blas-devel
259- fixed %preun script
260
261* Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
262- Updated to 2.4.1
263- Added INFO option
264- Exclude Japanese Rprofile.site
265
266* Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
267- Updated to 2.4.0
268
269* Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
270- Added optimization flags
271
272* Tue Jun  6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
273- Packaged for VineLinux3.2
274
275* Tue May  9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
276- Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
277
278* Mon May  8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
279- Packaged for VineLinux3.2
280- Slipped texinfo
281- Fixed preun error
282- Preset Japanese fonts
283
284* Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
285- Packaged for VineLinux3.2
286
287* Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
288- Restored CAPABILITIES file lost in 2.2.1beta
289
290* Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
291- Configure uses --without-blas by default.
292- Install pdf manuals.
293- All toplevel documentation files are installed into _libdir/R
294  as they may be required by R (qv note on AUTHORS and THANKS below).
295- Legacy scripts for rebuilding package indices removed.
296
297* Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
298- R now compiles with gcc 4.0.1 and default rpm optimization flags.
299
300* Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
301- The files AUTHORS and THANKS need to be installed into _libdir/R
302  as they are required by the function contributors().  Previously
303  they were installed only as documentation files.
304
305* Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
306- Corrected date error in SPEC file.
307
308* Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
309- Dropped support for Red Hat boxed set.
310- Synchronized with Fedora Extras 4 RPM by Tom Calloway
311  including support for shared R library.
312- Added gfortran support. However, gcc 4.0.0 will not compile R correctly
313  with the default optimization flags, so there is a temporary work-around.
314
315* Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
316- Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
317
318* Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
319- Install R-data.info file as well.
320- Make info processing conditional on texinfo version, not platform release,
321  so that if a new enough version is installed, we will build and install info.
322
323* Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
324- Built R 2.1.0.  R now supports internationalization, so the patch
325  to set the locale to "C" is now dropped.
326- install.packages() exits gracefully with a helpful message if
327  the file INSTALL is not present, so this is now included in the
328  R-devel package.
329
330* Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
331- Added support for Scientific Linux (http://www.scientificlinux.org)
332  A distribution based on RHEL. Thanks to Jon Peatfield.
333
334* Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
335- Fixed file ownership in R-devel and libRmath packages
336
337* Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
338- R-devel package is now a stub package with no files, except a documentation
339  file (RPM won't accept sub-packages with no files). R now conflicts
340  with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
341- Created libRmath subpackage with shared library.
342
343* Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
344- Created R-devel and libRmath-devel subpackages
345
346* Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
347- Built R 2.0.1
348
349* Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
350- Set R_PRINTCMD at configure times so that by default getOption(printcmd)
351  gives "lpr".
352- Define macro fcx for all Fedora distributions. This replaces Rinfo
353
354* Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
355- Info support is now conditional on the macro Rinfo, which is only
356  defined for Fedora 1 and 2.
357
358* Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
359- Built R 2.0.0
360- There is no longer a BUGS file, so this is not installed as a
361  documentation file.
Note: See TracBrowser for help on using the repository browser.