source: projects/specs/branches/6/I/ImageMagick/ImageMagick-vl.spec @ 6124

Revision 6124, 28.5 KB checked in by iwamoto, 12 years ago (diff)

ImageMagick?: security fixes

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.6.8
5%define Patchlevel 5
6
7Name: ImageMagick
8Summary: X application for displaying and manipulating images.
9Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 4%{?_dist_release}
17
18License: freeware
19Group: Applications/Graphics
20%if "%{Patchlevel}" != ""
21Source: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.bz2
22%else
23Source: ftp://ftp.ImageMagick.org/ImageMagick/ImageMagick-%{version}.tar.bz2
24%endif
25
26Patch100: ImageMagick-6.6.8-5_CVE-2012-0247-0248.patch
27Patch101: ImageMagick-6.6.8-5_CVE-2012-0247-0248-2.patch
28Patch110: ImageMagick-CVE-2012-0259-0260-1798.patch
29Patch120: ImageMagick-6.6.8-5_CVE-2012-1610.patch 
30
31URL: http://www.imagemagick.org/
32
33Buildroot: %{_tmppath}/%{name}-%{version}-root
34BuildRequires: bzip2-devel
35BuildRequires: cairo-devel
36BuildRequires: freetype2-devel >= 2.1.7
37BuildRequires: fontconfig-devel
38BuildRequires: giflib-devel
39BuildRequires: graphviz-devel
40BuildRequires: lcms-devel
41BuildRequires: libjpeg-turbo-devel
42BuildRequires: libpng-devel >= 1.2.5
43BuildRequires: librsvg2-devel
44BuildRequires: libtiff-devel
45BuildRequires: libxml2-devel
46BuildRequires: libSM-devel
47BuildRequires: libX11-devel
48BuildRequires: libXext-devel
49BuildRequires: OpenEXR-devel
50BuildRequires: perl
51BuildRequires: xorg-x11-server-utils
52BuildRequires: zlib-devel
53BuildRequires: libXt-devel
54BuildRequires: xz-devel
55BuildRequires: xz-lzma-compat
56BuildRequires: libtool-ltdl-devel
57
58Requires: bzip2
59Requires: freetype2
60Requires: giflib
61Requires: graphviz
62Requires: lcms
63Requires: libjpeg-turbo
64Requires: libpng
65Requires: libtiff
66Requires: libxml2
67Requires: OpenEXR-libs
68Requires: xorg-x11-server-utils
69Requires: zlib
70
71Vendor: Project Vine
72Distribution: Vine Linux
73Packager: inagaki, iwamoto
74
75%description
76ImageMagick(TM) is an image display and manipulation tool for the X
77Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
78and Photo CD image formats. It can resize, rotate, sharpen, color
79reduce, or add special effects to an image, and when finished you can
80either save the completed work in the original format or a different
81one. ImageMagick also includes command line programs for creating
82animated or transparent .gifs, creating composite images, creating
83thumbnail images, and more.
84
85ImageMagick is one of your choices if you need a program to manipulate
86and dis play images. If you want to develop your own applications
87which use ImageMagick code or APIs, you need to install
88ImageMagick-devel as well.
89
90
91%description -l ja
92ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
93ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
94イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
95出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
96オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
97また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
98サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
99
100画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
101も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
102アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
103インストールして下さい.
104
105%package devel
106Summary: Static libraries and header files for ImageMagick app development.
107Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
108Group: Development/Libraries
109Requires: ImageMagick = %{version}-%{release}
110
111%description devel
112Image-Magick-devel contains the static libraries and header files you'll
113need to develop ImageMagick applications. ImageMagick is an image
114manipulation program.
115
116If you want to create applications that will use ImageMagick code or
117APIs, you need to install ImageMagick-devel as well as ImageMagick.
118You do noy need to install it if you just want to use ImageMagick,
119however.
120
121%description devel -l ja
122ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
123これらは ImageMagick アプリケーションの開発の際に必要となります.
124ImageMagick は画像処理プログラムです.
125
126ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
127この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
128する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
129インストールする必要はありません.
130
131%package c++
132Summary: ImageMagick Magick++ library (C++ bindings)
133Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
134Group: System Environment/Libraries
135Requires: ImageMagick = %{version}-%{release}
136
137%description c++
138This package contains the Magick++ library, a C++ binding to the ImageMagick
139graphics manipulation library.
140
141Install ImageMagick-c++ if you want to use any applications that use Magick++.
142
143%description c++
144このパッケージには Magick++ ライブラリが収められています.
145Magick++ とは ImageMagick ライブラリの C++ バインディングです.
146
147Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
148パッケージをインストールして下さい.
149
150%package c++-devel
151Summary: C++ bindings for the ImageMagick library
152Summary(ja): ImageMagick ライブラリの C++ バインディング
153Group: Development/Libraries
154Requires: ImageMagick = %{version}-%{release}
155Requires: ImageMagick-c++ = %{version}-%{release}
156Requires: ImageMagick-devel = %{version}-%{release}
157
158%description c++-devel
159ImageMagick-devel contains the static libraries and header files you'll
160need to develop ImageMagick applications using the Magick++ C++ bindings.
161ImageMagick is an image manipulation program.
162
163If you want to create applications that will use Magick++ code
164or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
165ImageMagick.
166You don't need to install it if you just want to use ImageMagick, or if you
167want to develop/compile applications using the ImageMagick C interface,
168however.
169
170%description c++-devel -l ja
171ImageMagick-c++-devel には Magick++ C++ バインディングを使った
172ImageMagick アプリケーション開発に必要なスタティックライブラリと
173ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
174
175Magick++ コードや API を使ったアプリケーションを開発する場合は,
176ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
177インストールする必要があります.
178ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
179を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
180インストールする必要はありません.
181
182%package -n perl-Image-Magick
183Summary: ImageMagick perl bindings
184Summary(ja): ImageMagick の Perl バインディング
185Group: Development/Libraries
186Requires: ImageMagick = %{version}-%{release}
187Requires: perl >= 5.8.0
188Obsoletes: ImageMagick-perl < %{version}-%{release}
189Provides: ImageMagick-perl = %{version}-%{release}
190
191%description -n perl-Image-Magick
192Perl bindings to ImageMagick.
193
194Install ImageMagick-perl if you want to use any perl scripts that use
195ImageMagick.
196
197%description -n perl-Image-Magick -l ja
198このパッケージは ImageMagick の Perl バインディングです.
199
200ImageMagick を利用する perl スクリプトを使いたい場合は
201ImageMagick-perl パッケージをインストールして下さい.
202
203
204%prep
205%setup -q -n %{name}-%{VER}-%{Patchlevel}
206
207%patch100 -p1 -b .CVE-2012-0247-0248
208%patch101 -p1 -b .CVE-2012-0247-0248-2
209%patch110 -p1 -b .CVE-2012-0259-0260-1798
210%patch120 -p1 -b .CVE-2012-1610
211
212%build
213%configure \
214    --enable-silent-rules \
215    --enable-shared \
216    --disable-static \
217    --with-modules \
218    --with-quantum-depth=16 \
219    --without-frozenpaths \
220    --with-x \
221    --without-djvu \
222    --without-fftw \
223    --without-jbig \
224    --without-jp2 \
225    --without-lcms2 \
226    --without-wmf \
227    --with-perl \
228    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
229
230# Disable rpath
231sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
232sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
233
234make %{?_smp_mflags}
235
236%install
237rm -rf $RPM_BUILD_ROOT
238
239make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
240
241# perlmagick: fix perl path of demo files
242%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
243
244find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
245find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
246find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
247
248echo "%defattr(-,root,root)" > perl-pkg-files
249find $RPM_BUILD_ROOT%{_libdir}/perl?/vendor_perl/* -type d -name Image >> perl-pkg-files.orig
250sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
251
252# remove duplicated doc files
253rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
254
255# remove files conflict with libtools
256rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
257rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
258
259# remove *.la files
260find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
261
262%clean
263rm -rf $RPM_BUILD_ROOT
264
265%post -p /sbin/ldconfig
266
267%post c++ -p /sbin/ldconfig
268
269%postun -p /sbin/ldconfig
270
271%postun c++ -p /sbin/ldconfig
272
273
274%files
275%defattr(-,root,root)
276%doc www images
277%doc ChangeLog LICENSE NOTICE QuickStart.txt README.txt index.html
278%dir %{_libdir}/ImageMagick-%{VER}
279%{_libdir}/ImageMagick-%{VER}/config
280%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16
281%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16/*
282%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.so
283%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.la
284%{_libdir}/libMagickCore.so.*
285%{_libdir}/libMagickWand.so.*
286%{_bindir}/[a-z]*
287%dir %{_datadir}/ImageMagick-%{VER}
288%dir %{_datadir}/ImageMagick-%{VER}/config
289%{_datadir}/ImageMagick-%{VER}/config/*.xml
290%{_datadir}/ImageMagick-%{VER}/config/*.icm
291%{_mandir}/man1/ImageMagick.*
292%{_mandir}/man1/[a-z]*
293
294%files devel
295%defattr(-,root,root)
296%{_bindir}/Magick-config
297%{_bindir}/Wand-config
298%{_bindir}/MagickCore-config
299%{_bindir}/MagickWand-config
300#{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.a
301#{_libdir}/libMagickCore.a
302%{_libdir}/libMagickCore.so
303#{_libdir}/libMagickWand.a
304%{_libdir}/libMagickWand.so
305%{_libdir}/pkgconfig/ImageMagick.pc
306%{_libdir}/pkgconfig/Wand.pc
307%{_libdir}/pkgconfig/MagickCore.pc
308%{_libdir}/pkgconfig/MagickWand.pc
309%{_includedir}/ImageMagick/magick
310%{_includedir}/ImageMagick/wand
311%{_mandir}/man1/Magick-config*
312%{_mandir}/man1/Wand-config*
313%{_mandir}/man1/MagickCore-config*
314%{_mandir}/man1/MagickWand-config*
315
316%files c++
317%defattr(-,root,root)
318%{_libdir}/libMagick++.so.*
319
320%files c++-devel
321%defattr(-,root,root)
322%{_bindir}/Magick++-config
323%{_includedir}/ImageMagick/Magick++
324%{_includedir}/ImageMagick/Magick++.h
325#{_libdir}/libMagick++.a
326%{_libdir}/libMagick++.so
327%{_libdir}/pkgconfig/ImageMagick++.pc
328%{_libdir}/pkgconfig/Magick++.pc
329%{_mandir}/man1/Magick++-config*
330
331%files -n perl-Image-Magick -f perl-pkg-files
332%defattr(-,root,root)
333%{_mandir}/man3/*
334
335%changelog
336* Thu May  3 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.6.8.5-4
337- patch100 for fix CVE-2012-0247-0248
338- patch101 for fix CVE-2012-0247-0248 complited fixes
339- patch110 for fix CVE-2012-0259-0260-1798
340- patch120 for fix CVE-2012-1610
341
342* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.8.5-3
343- add BuildRequires: libXt-devel, xz-devel, xz-lzma-compat, libtool-ltdl-devel
344
345* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-2
346- built with perl-5.12.3
347- changed perl subpackage name
348
349* Sat Mar 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-1
350- new upstream release
351
352* Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.4.9-2
353- rebuilt with graphviz-2.26.3 again
354
355* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.9-1
356- new upstream release
357- rebuilt with graphviz-2.26.3
358
359* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.8-1
360- new upstream release
361
362* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.1.5-2
363- rebuild with rpm-4.8.1 for pkg-config file
364- change BuildRequires: libjpeg-turbo-devel instead of libjpeg-devel
365- change Requires: libjpeg-turbo instead of libjpeg
366
367* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
368- new upstream release
369- built with new toolchain
370- added --disable-static to %%configure, removed static libraries
371
372* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
373- added --without-djvu --without-fftw
374
375* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
376- new upstream release
377
378* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
379- new upstream release
380
381* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
382- new upstream release
383- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
384- add R: graphviz, OpenEXR-libs, ilmbase
385
386* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
387- new upstream release
388- added Packager tag
389
390* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
391- new upstream release
392
393* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
394- new upstream release
395- updated BuildRequires
396
397* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
398- enabled lcms as default.
399
400* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
401- new upstream release
402
403* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
404- new upstream release
405
406* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
407- new upstream release
408
409* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
410- new upstream release
411
412* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
413- new upstream release
414- spec in UTF-8
415
416* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
417- enabled to build with lcms (use '--with lcms' to enable).
418
419* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
420- new upstream release
421- rebuilt with perl-5.10.0
422
423* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
424- new upstream release
425- removed *.la files from devel packages
426
427* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
428- new upstream release
429- change files section to fit new release
430- build under new versioning policy
431
432* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
433- new upstream release
434
435* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
436- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
437- add BuildPrereq: librsvg2-devel
438- add %%{?_smp_mflags} to make command arg
439
440* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
441- new upstream release
442- changed Group to Applications/Graphics
443
444* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
445- rebuilt for VineSeed
446
447* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
448- update patch1 for fix CVE-2007-0770
449
450* Wed Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
451- upstream release
452- add patch1 for fix CVE-2006-5456
453
454* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
455- rebuilt (for ppc) to resolve reference to invalid *la files
456
457* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
458- new upstream release
459
460* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
461- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
462
463* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
464- new upstream release
465- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
466- add --with-perl-options to configure option
467
468* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
469- new upstream release
470- build with XOrg-6.9.0
471
472* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
473- new upstream release
474- add %%{_mandir}/man1/ImageMagick.* to main package
475
476* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
477- source upgrade
478- remove patch1
479- update %%files
480
481* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
482- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
483  (CAN-2004-0981)
484
485* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
486- move $(pkglibdir)/modules-Q16/*/*.la to main package.
487
488* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
489- source upgrade
490- Patch: change default menu font so display can work without XOrg-75dpi-fonts
491- add missing docs
492- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
493- *.pc should be in -devel package
494- add missing pkg{lib,data}dirs to %%files
495
496* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
497- source upgrade
498- add --without-dot to %%configure option
499- update %%files section
500
501* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
502- source upgrade
503
504* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
505- source upgrade
506
507* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
508- add --without-jbig to %%configure option
509
510* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
511- add --without-lcms to %%configure option
512
513* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
514- source upgrade
515- remove commented lines
516
517* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
518- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
519
520* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
521- source upgrade
522- remove patch for freetype2, no need
523- remove commented lines
524- add --with-quantum-depth=16 --with-modules --enable-lzw
525  --without-frozenpaths to %%configure option
526- remove --with-threads --without-xml from %%configure option
527- update %%files
528
529* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
530- patch update
531- add --without-jp2 to configure option
532- change PerlMagick build method
533
534* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
535- rebuild without jasper-devel
536
537* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
538- source upgrade to 5.5.7-15
539
540* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
541- source upgrade to 5.5.7-13
542- add patch0 to build against freetype2-2.1.7
543
544* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
545- source upgrade to 5.5.7-11
546- clean up spec
547- build without previous package (do not require libMagick.so.0)
548
549* Sun Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
550- source upgrade to 5.5.7-9
551- revised name of pkgconfig files
552- remove BuildPrereq: freetype-devel
553
554* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
555- source upgrade to 5.5.7-6
556- disable all patches
557- revised %%files section
558- disable libtoolize and autotools
559- change PerlMagick build method
560- build without previous package (do not require libMagick.so.5)
561
562* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
563- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
564  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
565
566* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
567- rebuild
568
569* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
570- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
571- FIXME: rpm's macro problem?
572
573- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
574  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
575
576  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
577  - remove unnecessary duplicated %%doc files
578  - --without-xml instead of --without-ttf
579  - eliminate libungif(-devel) from BuildReq/Requires
580  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
581
582  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
583  - add delegetes.mgk (and %%{_libdir}/%%{name})
584
585  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
586  - 5.2.9-0vl4
587  - Sorry, the spec was in Shift_JIS. Fixed.
588
589  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
590  - 5.2.9-0vl3
591  - rebuilt with perl-5.6.1
592  - added Japanese summary and description :-P
593  - added --without-ttf in order to disable freetype2 (SeedPlus) support
594  - added --without-wmf in order to disable libwmf (SeedPlus) support
595
596  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
597  - 5.2.9-0vl2
598  - rebuild on Perl-5.6
599  - use %%{perl_sitearch}
600  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
601
602  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
603  - 5.2.9-0vl1
604  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
605
606* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
607- fix perl paths in file list
608
609* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
610- lib64'ize
611- don't throw stuff in /usr/X11R6, that's for X only
612- remove files we aren't shipping
613
614* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
615- rebuilt with gcc-3.2 (we hope)
616
617* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
618- build using gcc-3.2-0.1
619
620* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
621- fix non-cpp headers in -devel package
622- fix #62157 (wrong path for include files in ImageMagick-devel)
623- fix #63897 (use _target instead of _arch) in libtool workaround
624- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
625
626* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
627- update
628- fix localdoc patch
629- fix %%files section
630- disable nonroot patch
631- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
632- fix libtool workaround
633- moved Magick*-config into -devel package (#64249)
634
635* Sun May 26 2002 Tim Powers <timp@redhat.com>
636- automated rebuild
637
638* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
639- 5.4.6
640
641* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
642- Update to pl 11
643
644* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
645- Update to 5.4.3 pl5; this fixes #58080
646
647* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
648- Patchlevel 3
649
650* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
651- automated rebuild
652
653* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
654- Update to 5.4.2-2
655- Fix #57923, also don't hardcode netscape as html viewer
656
657* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
658- 5.4.1
659- Link against new libstdc++
660
661* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
662- 5.4.0.5
663- Make the error message when trying to display an hpgl file more
664  explicit (#55875)
665
666* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
667- 5.4.0.3
668- Fix names of man pages
669
670* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
671- 5.4.0
672- work around build system breakage causing applications to be named
673  %{_arch}-redhat-linux-foo rather than foo
674
675* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
676- 5.3.9
677
678* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
679- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
680  (#52611)
681
682* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
683- Remove Magick++ includes from -devel, they're already in -c++-devel
684  (#51590)
685
686* Sun Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
687- 5.3.8 (bugfix release)
688
689* Sat Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
690- fix to build Perlmagic on s390 s390x
691
692* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
693- Add delegates.mgk to the package (#50725)
694
695* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
696- 5.3.7
697- Fix build without previously installed ImageMagick-devel (#49816)
698- Move perl bindings to a separate package.
699
700* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
701- Fix build as non-root again
702- Shut up rpmlint
703
704* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
705- 5.3.6
706- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
707
708* Sat Jun 16 2001 Than Ngo <than@redhat.com>
709- update to 5.3.5
710- cleanup specfile
711
712* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
713- 5.3.3-respin, fixes #41196
714
715* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
716- 5.3.3
717- Add a desktop file for "display" (RFE#17417)
718
719* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
720- 5.3.2
721- work around bugs in ia64 glibc headers
722
723* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
724- remove patch for s390, it is not necessary
725
726* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
727- 5.2.7
728
729* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
730- 5.2.6
731
732* Mon Dec 18 2000 Than Ngo <than@redhat.com>
733- ported to s390
734
735* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
736- 5.2.4
737- Fix up and package the C++ bindings in the new c++/c++-devel packages.
738
739* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
740- rebuild against new libpng
741
742* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
743- include images with docs (#10312)
744
745* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
746- don't build with -ggdb, use -g instead.
747
748* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
749- automatic rebuild
750
751* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
752- update to 5.2.2 beta
753
754* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
755- update to 5.2.1, redone patches as they failed
756
757* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
758- remove hacks to move perl man pages
759- don't include the perl*/man stuff, these files go in /usr/share/man now.
760
761* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
762- disable optimization on Alpha and Sparc
763
764* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
765- update to 5.2.0
766- update URL
767- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
768
769* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
770- bootstrap rebuilt to nuke broken libbz2 deps
771- add Prefix: tag such that the FHS macros work properly
772
773* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
774- now compiles with bzip2 1.0
775- changed buildroot to include version
776
777* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
778- fix compilation with new perl
779
780* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
781- 5.1.1
782
783* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
784- Rebuild to get compressed man pages
785
786* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
787- ugly hack to print with lpr instead of lp
788
789* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
790- update to 4.2.9
791
792* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
793- update to 4.2.8
794
795* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
796- include the perl man pages as well
797
798* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
799- remove --enable-16bit because it damages interoperability
800
801* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
802- update to 4.2.2
803- change ChangeLog to refer to actual dates.
804- strip binaries
805
806* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
807- add more files. Oops.
808
809* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
810- auto rebuild in the new build environment (release 2)
811
812* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
813- version 4.2.1
814
815* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
816- changed group
817
818* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
819- hacks to make it work with the new perl
820- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
821- make sure the libraries have the x bit on
822
823* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
824- translations modified for de, fr
825
826* Thu May 07 1998 Prospector System <bugs@redhat.com>
827- translations modified for de, fr, tr
828
829* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
830- updated to 4.0.5
831
832* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
833- updated to 4.0.4
834- added BuildRoot
835
836* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
837- updated from 3.8.3 to 3.9.1
838- removed PNG patch (appears to be fixed)
839
840* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
841- build against new libpng
842
843* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
844- built against glibc
845
846* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
847- updated to version 3.8.3.
848- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.