source: projects/specs/branches/6/I/ImageMagick/ImageMagick-vl.spec @ 8276

Revision 8276, 28.9 KB checked in by iwamoto, 10 years ago (diff)

ImageMagick?: fix CVE-2014-1958,2030 and commit old spec

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.6.8
5%define Patchlevel 5
6
7Name: ImageMagick
8Summary: X application for displaying and manipulating images.
9Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 6%{?_dist_release}
17
18License: freeware
19Group: Applications/Graphics
20%if "%{Patchlevel}" != ""
21Source: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.bz2
22%else
23Source: ftp://ftp.ImageMagick.org/ImageMagick/ImageMagick-%{version}.tar.bz2
24%endif
25
26Patch100: ImageMagick-6.6.8-5_CVE-2012-0247-0248.patch
27Patch101: ImageMagick-6.6.8-5_CVE-2012-0247-0248-2.patch
28Patch110: ImageMagick-6.6.0-CVE-2012-0259-0260-1798-2.patch
29Patch120: ImageMagick-6.6.8-5_CVE-2012-1610.patch 
30Patch130: ImageMagick-6-CVE-2014-1958.patch
31Patch140: ImageMagick-6.6.8-5_CVE-2014-2030.patch
32
33URL: http://www.imagemagick.org/
34
35Buildroot: %{_tmppath}/%{name}-%{version}-root
36BuildRequires: bzip2-devel
37BuildRequires: cairo-devel
38BuildRequires: freetype2-devel >= 2.1.7
39BuildRequires: fontconfig-devel
40BuildRequires: giflib-devel
41BuildRequires: graphviz-devel
42BuildRequires: lcms-devel
43BuildRequires: libjpeg-turbo-devel
44BuildRequires: libpng-devel >= 1.2.5
45BuildRequires: librsvg2-devel
46BuildRequires: libtiff-devel
47BuildRequires: libxml2-devel
48BuildRequires: libSM-devel
49BuildRequires: libX11-devel
50BuildRequires: libXext-devel
51BuildRequires: OpenEXR-devel
52BuildRequires: perl
53BuildRequires: xorg-x11-server-utils
54BuildRequires: zlib-devel
55BuildRequires: libXt-devel
56BuildRequires: xz-devel
57BuildRequires: xz-lzma-compat
58BuildRequires: libtool-ltdl-devel
59
60Requires: bzip2
61Requires: freetype2
62Requires: giflib
63Requires: graphviz
64Requires: lcms
65Requires: libjpeg-turbo
66Requires: libpng
67Requires: libtiff
68Requires: libxml2
69Requires: OpenEXR-libs
70Requires: xorg-x11-server-utils
71Requires: zlib
72
73Vendor: Project Vine
74Distribution: Vine Linux
75Packager: inagaki, iwamoto
76
77%description
78ImageMagick(TM) is an image display and manipulation tool for the X
79Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
80and Photo CD image formats. It can resize, rotate, sharpen, color
81reduce, or add special effects to an image, and when finished you can
82either save the completed work in the original format or a different
83one. ImageMagick also includes command line programs for creating
84animated or transparent .gifs, creating composite images, creating
85thumbnail images, and more.
86
87ImageMagick is one of your choices if you need a program to manipulate
88and dis play images. If you want to develop your own applications
89which use ImageMagick code or APIs, you need to install
90ImageMagick-devel as well.
91
92
93%description -l ja
94ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
95ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
96イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
97出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
98オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
99また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
100サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
101
102画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
103も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
104アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
105インストールして下さい.
106
107%package devel
108Summary: Static libraries and header files for ImageMagick app development.
109Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
110Group: Development/Libraries
111Requires: ImageMagick = %{version}-%{release}
112
113%description devel
114Image-Magick-devel contains the static libraries and header files you'll
115need to develop ImageMagick applications. ImageMagick is an image
116manipulation program.
117
118If you want to create applications that will use ImageMagick code or
119APIs, you need to install ImageMagick-devel as well as ImageMagick.
120You do noy need to install it if you just want to use ImageMagick,
121however.
122
123%description devel -l ja
124ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
125これらは ImageMagick アプリケーションの開発の際に必要となります.
126ImageMagick は画像処理プログラムです.
127
128ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
129この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
130する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
131インストールする必要はありません.
132
133%package c++
134Summary: ImageMagick Magick++ library (C++ bindings)
135Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
136Group: System Environment/Libraries
137Requires: ImageMagick = %{version}-%{release}
138
139%description c++
140This package contains the Magick++ library, a C++ binding to the ImageMagick
141graphics manipulation library.
142
143Install ImageMagick-c++ if you want to use any applications that use Magick++.
144
145%description c++
146このパッケージには Magick++ ライブラリが収められています.
147Magick++ とは ImageMagick ライブラリの C++ バインディングです.
148
149Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
150パッケージをインストールして下さい.
151
152%package c++-devel
153Summary: C++ bindings for the ImageMagick library
154Summary(ja): ImageMagick ライブラリの C++ バインディング
155Group: Development/Libraries
156Requires: ImageMagick = %{version}-%{release}
157Requires: ImageMagick-c++ = %{version}-%{release}
158Requires: ImageMagick-devel = %{version}-%{release}
159
160%description c++-devel
161ImageMagick-devel contains the static libraries and header files you'll
162need to develop ImageMagick applications using the Magick++ C++ bindings.
163ImageMagick is an image manipulation program.
164
165If you want to create applications that will use Magick++ code
166or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
167ImageMagick.
168You don't need to install it if you just want to use ImageMagick, or if you
169want to develop/compile applications using the ImageMagick C interface,
170however.
171
172%description c++-devel -l ja
173ImageMagick-c++-devel には Magick++ C++ バインディングを使った
174ImageMagick アプリケーション開発に必要なスタティックライブラリと
175ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
176
177Magick++ コードや API を使ったアプリケーションを開発する場合は,
178ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
179インストールする必要があります.
180ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
181を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
182インストールする必要はありません.
183
184%package -n perl-Image-Magick
185Summary: ImageMagick perl bindings
186Summary(ja): ImageMagick の Perl バインディング
187Group: Development/Libraries
188Requires: ImageMagick = %{version}-%{release}
189Requires: perl >= 5.8.0
190Obsoletes: ImageMagick-perl < %{version}-%{release}
191Provides: ImageMagick-perl = %{version}-%{release}
192
193%description -n perl-Image-Magick
194Perl bindings to ImageMagick.
195
196Install ImageMagick-perl if you want to use any perl scripts that use
197ImageMagick.
198
199%description -n perl-Image-Magick -l ja
200このパッケージは ImageMagick の Perl バインディングです.
201
202ImageMagick を利用する perl スクリプトを使いたい場合は
203ImageMagick-perl パッケージをインストールして下さい.
204
205
206%prep
207%setup -q -n %{name}-%{VER}-%{Patchlevel}
208
209%patch100 -p1 -b .CVE-2012-0247-0248
210%patch101 -p1 -b .CVE-2012-0247-0248-2
211%patch110 -p1 -b .CVE-2012-0259-0260-1798-2
212%patch120 -p1 -b .CVE-2012-1610
213%patch130 -p4 -b .CVE-2014-1958
214%patch140 -p1 -b .CVE-2014-2030
215
216%build
217%configure \
218    --enable-silent-rules \
219    --enable-shared \
220    --disable-static \
221    --with-modules \
222    --with-quantum-depth=16 \
223    --without-frozenpaths \
224    --with-x \
225    --without-djvu \
226    --without-fftw \
227    --without-jbig \
228    --without-jp2 \
229    --without-lcms2 \
230    --without-wmf \
231    --with-perl \
232    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
233
234# Disable rpath
235sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
236sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
237
238make %{?_smp_mflags}
239
240%install
241rm -rf $RPM_BUILD_ROOT
242
243make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
244
245# perlmagick: fix perl path of demo files
246%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
247
248find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
249find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
250find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
251
252echo "%defattr(-,root,root)" > perl-pkg-files
253find $RPM_BUILD_ROOT%{_libdir}/perl?/vendor_perl/* -type d -name Image >> perl-pkg-files.orig
254sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
255
256# remove duplicated doc files
257rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
258
259# remove files conflict with libtools
260rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
261rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
262
263# remove *.la files
264find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
265
266%clean
267rm -rf $RPM_BUILD_ROOT
268
269%post -p /sbin/ldconfig
270
271%post c++ -p /sbin/ldconfig
272
273%postun -p /sbin/ldconfig
274
275%postun c++ -p /sbin/ldconfig
276
277
278%files
279%defattr(-,root,root)
280%doc www images
281%doc ChangeLog LICENSE NOTICE QuickStart.txt README.txt index.html
282%dir %{_libdir}/ImageMagick-%{VER}
283%{_libdir}/ImageMagick-%{VER}/config
284%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16
285%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16/*
286%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.so
287%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.la
288%{_libdir}/libMagickCore.so.*
289%{_libdir}/libMagickWand.so.*
290%{_bindir}/[a-z]*
291%dir %{_datadir}/ImageMagick-%{VER}
292%dir %{_datadir}/ImageMagick-%{VER}/config
293%{_datadir}/ImageMagick-%{VER}/config/*.xml
294%{_datadir}/ImageMagick-%{VER}/config/*.icm
295%{_mandir}/man1/ImageMagick.*
296%{_mandir}/man1/[a-z]*
297
298%files devel
299%defattr(-,root,root)
300%{_bindir}/Magick-config
301%{_bindir}/Wand-config
302%{_bindir}/MagickCore-config
303%{_bindir}/MagickWand-config
304#{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.a
305#{_libdir}/libMagickCore.a
306%{_libdir}/libMagickCore.so
307#{_libdir}/libMagickWand.a
308%{_libdir}/libMagickWand.so
309%{_libdir}/pkgconfig/ImageMagick.pc
310%{_libdir}/pkgconfig/Wand.pc
311%{_libdir}/pkgconfig/MagickCore.pc
312%{_libdir}/pkgconfig/MagickWand.pc
313%{_includedir}/ImageMagick/magick
314%{_includedir}/ImageMagick/wand
315%{_mandir}/man1/Magick-config*
316%{_mandir}/man1/Wand-config*
317%{_mandir}/man1/MagickCore-config*
318%{_mandir}/man1/MagickWand-config*
319
320%files c++
321%defattr(-,root,root)
322%{_libdir}/libMagick++.so.*
323
324%files c++-devel
325%defattr(-,root,root)
326%{_bindir}/Magick++-config
327%{_includedir}/ImageMagick/Magick++
328%{_includedir}/ImageMagick/Magick++.h
329#{_libdir}/libMagick++.a
330%{_libdir}/libMagick++.so
331%{_libdir}/pkgconfig/ImageMagick++.pc
332%{_libdir}/pkgconfig/Magick++.pc
333%{_mandir}/man1/Magick++-config*
334
335%files -n perl-Image-Magick -f perl-pkg-files
336%defattr(-,root,root)
337%{_mandir}/man3/*
338
339%changelog
340* Tue Feb 25 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.6.8.5-6
341- add Patch130 for fix CVE-2014-1958 (psd.c)
342- add Patch140 for fix CVE-2014-2030 (psd.c)
343
344* Fri May  4 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.6.8.5-5
345- update patch110 (regression was found)
346
347* Thu May  3 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.6.8.5-4
348- patch100 for fix CVE-2012-0247-0248
349- patch101 for fix CVE-2012-0247-0248 complited fixes
350- patch110 for fix CVE-2012-0259-0260-1798
351- patch120 for fix CVE-2012-1610
352
353* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.8.5-3
354- add BuildRequires: libXt-devel, xz-devel, xz-lzma-compat, libtool-ltdl-devel
355
356* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-2
357- built with perl-5.12.3
358- changed perl subpackage name
359
360* Sat Mar 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-1
361- new upstream release
362
363* Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.4.9-2
364- rebuilt with graphviz-2.26.3 again
365
366* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.9-1
367- new upstream release
368- rebuilt with graphviz-2.26.3
369
370* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.8-1
371- new upstream release
372
373* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.1.5-2
374- rebuild with rpm-4.8.1 for pkg-config file
375- change BuildRequires: libjpeg-turbo-devel instead of libjpeg-devel
376- change Requires: libjpeg-turbo instead of libjpeg
377
378* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
379- new upstream release
380- built with new toolchain
381- added --disable-static to %%configure, removed static libraries
382
383* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
384- added --without-djvu --without-fftw
385
386* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
387- new upstream release
388
389* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
390- new upstream release
391
392* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
393- new upstream release
394- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
395- add R: graphviz, OpenEXR-libs, ilmbase
396
397* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
398- new upstream release
399- added Packager tag
400
401* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
402- new upstream release
403
404* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
405- new upstream release
406- updated BuildRequires
407
408* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
409- enabled lcms as default.
410
411* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
412- new upstream release
413
414* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
415- new upstream release
416
417* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
418- new upstream release
419
420* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
421- new upstream release
422
423* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
424- new upstream release
425- spec in UTF-8
426
427* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
428- enabled to build with lcms (use '--with lcms' to enable).
429
430* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
431- new upstream release
432- rebuilt with perl-5.10.0
433
434* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
435- new upstream release
436- removed *.la files from devel packages
437
438* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
439- new upstream release
440- change files section to fit new release
441- build under new versioning policy
442
443* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
444- new upstream release
445
446* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
447- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
448- add BuildPrereq: librsvg2-devel
449- add %%{?_smp_mflags} to make command arg
450
451* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
452- new upstream release
453- changed Group to Applications/Graphics
454
455* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
456- rebuilt for VineSeed
457
458* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
459- update patch1 for fix CVE-2007-0770
460
461* Wed Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
462- upstream release
463- add patch1 for fix CVE-2006-5456
464
465* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
466- rebuilt (for ppc) to resolve reference to invalid *la files
467
468* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
469- new upstream release
470
471* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
472- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
473
474* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
475- new upstream release
476- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
477- add --with-perl-options to configure option
478
479* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
480- new upstream release
481- build with XOrg-6.9.0
482
483* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
484- new upstream release
485- add %%{_mandir}/man1/ImageMagick.* to main package
486
487* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
488- source upgrade
489- remove patch1
490- update %%files
491
492* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
493- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
494  (CAN-2004-0981)
495
496* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
497- move $(pkglibdir)/modules-Q16/*/*.la to main package.
498
499* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
500- source upgrade
501- Patch: change default menu font so display can work without XOrg-75dpi-fonts
502- add missing docs
503- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
504- *.pc should be in -devel package
505- add missing pkg{lib,data}dirs to %%files
506
507* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
508- source upgrade
509- add --without-dot to %%configure option
510- update %%files section
511
512* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
513- source upgrade
514
515* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
516- source upgrade
517
518* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
519- add --without-jbig to %%configure option
520
521* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
522- add --without-lcms to %%configure option
523
524* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
525- source upgrade
526- remove commented lines
527
528* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
529- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
530
531* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
532- source upgrade
533- remove patch for freetype2, no need
534- remove commented lines
535- add --with-quantum-depth=16 --with-modules --enable-lzw
536  --without-frozenpaths to %%configure option
537- remove --with-threads --without-xml from %%configure option
538- update %%files
539
540* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
541- patch update
542- add --without-jp2 to configure option
543- change PerlMagick build method
544
545* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
546- rebuild without jasper-devel
547
548* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
549- source upgrade to 5.5.7-15
550
551* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
552- source upgrade to 5.5.7-13
553- add patch0 to build against freetype2-2.1.7
554
555* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
556- source upgrade to 5.5.7-11
557- clean up spec
558- build without previous package (do not require libMagick.so.0)
559
560* Sun Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
561- source upgrade to 5.5.7-9
562- revised name of pkgconfig files
563- remove BuildPrereq: freetype-devel
564
565* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
566- source upgrade to 5.5.7-6
567- disable all patches
568- revised %%files section
569- disable libtoolize and autotools
570- change PerlMagick build method
571- build without previous package (do not require libMagick.so.5)
572
573* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
574- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
575  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
576
577* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
578- rebuild
579
580* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
581- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
582- FIXME: rpm's macro problem?
583
584- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
585  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
586
587  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
588  - remove unnecessary duplicated %%doc files
589  - --without-xml instead of --without-ttf
590  - eliminate libungif(-devel) from BuildReq/Requires
591  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
592
593  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
594  - add delegetes.mgk (and %%{_libdir}/%%{name})
595
596  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
597  - 5.2.9-0vl4
598  - Sorry, the spec was in Shift_JIS. Fixed.
599
600  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
601  - 5.2.9-0vl3
602  - rebuilt with perl-5.6.1
603  - added Japanese summary and description :-P
604  - added --without-ttf in order to disable freetype2 (SeedPlus) support
605  - added --without-wmf in order to disable libwmf (SeedPlus) support
606
607  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
608  - 5.2.9-0vl2
609  - rebuild on Perl-5.6
610  - use %%{perl_sitearch}
611  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
612
613  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
614  - 5.2.9-0vl1
615  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
616
617* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
618- fix perl paths in file list
619
620* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
621- lib64'ize
622- don't throw stuff in /usr/X11R6, that's for X only
623- remove files we aren't shipping
624
625* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
626- rebuilt with gcc-3.2 (we hope)
627
628* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
629- build using gcc-3.2-0.1
630
631* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
632- fix non-cpp headers in -devel package
633- fix #62157 (wrong path for include files in ImageMagick-devel)
634- fix #63897 (use _target instead of _arch) in libtool workaround
635- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
636
637* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
638- update
639- fix localdoc patch
640- fix %%files section
641- disable nonroot patch
642- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
643- fix libtool workaround
644- moved Magick*-config into -devel package (#64249)
645
646* Sun May 26 2002 Tim Powers <timp@redhat.com>
647- automated rebuild
648
649* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
650- 5.4.6
651
652* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
653- Update to pl 11
654
655* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
656- Update to 5.4.3 pl5; this fixes #58080
657
658* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
659- Patchlevel 3
660
661* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
662- automated rebuild
663
664* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
665- Update to 5.4.2-2
666- Fix #57923, also don't hardcode netscape as html viewer
667
668* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
669- 5.4.1
670- Link against new libstdc++
671
672* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
673- 5.4.0.5
674- Make the error message when trying to display an hpgl file more
675  explicit (#55875)
676
677* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
678- 5.4.0.3
679- Fix names of man pages
680
681* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
682- 5.4.0
683- work around build system breakage causing applications to be named
684  %{_arch}-redhat-linux-foo rather than foo
685
686* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
687- 5.3.9
688
689* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
690- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
691  (#52611)
692
693* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
694- Remove Magick++ includes from -devel, they're already in -c++-devel
695  (#51590)
696
697* Sun Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
698- 5.3.8 (bugfix release)
699
700* Sat Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
701- fix to build Perlmagic on s390 s390x
702
703* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
704- Add delegates.mgk to the package (#50725)
705
706* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
707- 5.3.7
708- Fix build without previously installed ImageMagick-devel (#49816)
709- Move perl bindings to a separate package.
710
711* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
712- Fix build as non-root again
713- Shut up rpmlint
714
715* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
716- 5.3.6
717- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
718
719* Sat Jun 16 2001 Than Ngo <than@redhat.com>
720- update to 5.3.5
721- cleanup specfile
722
723* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
724- 5.3.3-respin, fixes #41196
725
726* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
727- 5.3.3
728- Add a desktop file for "display" (RFE#17417)
729
730* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
731- 5.3.2
732- work around bugs in ia64 glibc headers
733
734* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
735- remove patch for s390, it is not necessary
736
737* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
738- 5.2.7
739
740* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
741- 5.2.6
742
743* Mon Dec 18 2000 Than Ngo <than@redhat.com>
744- ported to s390
745
746* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
747- 5.2.4
748- Fix up and package the C++ bindings in the new c++/c++-devel packages.
749
750* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
751- rebuild against new libpng
752
753* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
754- include images with docs (#10312)
755
756* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
757- don't build with -ggdb, use -g instead.
758
759* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
760- automatic rebuild
761
762* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
763- update to 5.2.2 beta
764
765* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
766- update to 5.2.1, redone patches as they failed
767
768* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
769- remove hacks to move perl man pages
770- don't include the perl*/man stuff, these files go in /usr/share/man now.
771
772* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
773- disable optimization on Alpha and Sparc
774
775* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
776- update to 5.2.0
777- update URL
778- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
779
780* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
781- bootstrap rebuilt to nuke broken libbz2 deps
782- add Prefix: tag such that the FHS macros work properly
783
784* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
785- now compiles with bzip2 1.0
786- changed buildroot to include version
787
788* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
789- fix compilation with new perl
790
791* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
792- 5.1.1
793
794* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
795- Rebuild to get compressed man pages
796
797* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
798- ugly hack to print with lpr instead of lp
799
800* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
801- update to 4.2.9
802
803* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
804- update to 4.2.8
805
806* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
807- include the perl man pages as well
808
809* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
810- remove --enable-16bit because it damages interoperability
811
812* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
813- update to 4.2.2
814- change ChangeLog to refer to actual dates.
815- strip binaries
816
817* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
818- add more files. Oops.
819
820* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
821- auto rebuild in the new build environment (release 2)
822
823* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
824- version 4.2.1
825
826* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
827- changed group
828
829* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
830- hacks to make it work with the new perl
831- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
832- make sure the libraries have the x bit on
833
834* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
835- translations modified for de, fr
836
837* Thu May 07 1998 Prospector System <bugs@redhat.com>
838- translations modified for de, fr, tr
839
840* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
841- updated to 4.0.5
842
843* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
844- updated to 4.0.4
845- added BuildRoot
846
847* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
848- updated from 3.8.3 to 3.9.1
849- removed PNG patch (appears to be fixed)
850
851* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
852- build against new libpng
853
854* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
855- built against glibc
856
857* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
858- updated to version 3.8.3.
859- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.