source: projects/specs/branches/6/I/ImageMagick/ImageMagick-vl.spec @ 10667

Revision 10667, 30.0 KB checked in by tomop, 8 years ago (diff)

ImageMagick?-6.6.8.5-8

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.6.8
5%define Patchlevel 5
6
7Name: ImageMagick
8Summary: X application for displaying and manipulating images.
9Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 8%{?_dist_release}
17
18License: freeware
19Group: Applications/Graphics
20%if "%{Patchlevel}" != ""
21Source: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.bz2
22%else
23Source: ftp://ftp.ImageMagick.org/ImageMagick/ImageMagick-%{version}.tar.bz2
24%endif
25
26Patch100: ImageMagick-6.6.8-5_CVE-2012-0247-0248.patch
27Patch101: ImageMagick-6.6.8-5_CVE-2012-0247-0248-2.patch
28Patch110: ImageMagick-6.6.0-CVE-2012-0259-0260-1798-2.patch
29Patch120: ImageMagick-6.6.8-5_CVE-2012-1610.patch 
30Patch130: ImageMagick-6-CVE-2014-1958.patch
31Patch140: ImageMagick-6.6.8-5_CVE-2014-2030.patch
32Patch150: 0011-Prevent-buffer-overflow-in-messaging-system-CVE-2014.patch
33
34# imported from ubuntu
35Patch200: 0076-Disable-EPHEMERAL-URL-HTTPS-MVG-MSL-TEXT-SHOW-WIN-and-PLT-coders.patch
36Patch201: 0077-Remove-PLT-Gnuplot-decoder.patch
37Patch202: 0078-Sanitize-input-filename-for-http-and-https-delegates.patch
38Patch203: 0079-Indirect-filename-must-be-authorized-by-policy.patch
39Patch204: 0080-Prevent-indirect-reads-with-label-at.patch
40Patch205: 0081-Less-secure-coders-require-explicit-reference.patch
41Patch206: 0082-Disable-MAGICKCORE_HAVE_POPEN.patch
42
43URL: http://www.imagemagick.org/
44
45Buildroot: %{_tmppath}/%{name}-%{version}-root
46BuildRequires: bzip2-devel
47BuildRequires: cairo-devel
48BuildRequires: freetype2-devel >= 2.1.7
49BuildRequires: fontconfig-devel
50BuildRequires: giflib-devel
51BuildRequires: graphviz-devel
52BuildRequires: lcms-devel
53BuildRequires: libjpeg-turbo-devel
54BuildRequires: libpng-devel >= 1.2.5
55BuildRequires: librsvg2-devel
56BuildRequires: libtiff-devel
57BuildRequires: libxml2-devel
58BuildRequires: libSM-devel
59BuildRequires: libX11-devel
60BuildRequires: libXext-devel
61BuildRequires: OpenEXR-devel
62BuildRequires: perl
63BuildRequires: xorg-x11-server-utils
64BuildRequires: zlib-devel
65BuildRequires: libXt-devel
66BuildRequires: xz-devel
67BuildRequires: xz-lzma-compat
68BuildRequires: libtool-ltdl-devel
69
70Requires: bzip2
71Requires: freetype2
72Requires: giflib
73Requires: graphviz
74Requires: lcms
75Requires: libjpeg-turbo
76Requires: libpng
77Requires: libtiff
78Requires: libxml2
79Requires: OpenEXR-libs
80Requires: xorg-x11-server-utils
81Requires: zlib
82
83Vendor: Project Vine
84Distribution: Vine Linux
85Packager: inagaki, iwamoto
86
87%description
88ImageMagick(TM) is an image display and manipulation tool for the X
89Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
90and Photo CD image formats. It can resize, rotate, sharpen, color
91reduce, or add special effects to an image, and when finished you can
92either save the completed work in the original format or a different
93one. ImageMagick also includes command line programs for creating
94animated or transparent .gifs, creating composite images, creating
95thumbnail images, and more.
96
97ImageMagick is one of your choices if you need a program to manipulate
98and dis play images. If you want to develop your own applications
99which use ImageMagick code or APIs, you need to install
100ImageMagick-devel as well.
101
102
103%description -l ja
104ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
105ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
106イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
107出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
108オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
109また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
110サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
111
112画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
113も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
114アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
115インストールして下さい.
116
117%package devel
118Summary: Static libraries and header files for ImageMagick app development.
119Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
120Group: Development/Libraries
121Requires: ImageMagick = %{version}-%{release}
122
123%description devel
124Image-Magick-devel contains the static libraries and header files you'll
125need to develop ImageMagick applications. ImageMagick is an image
126manipulation program.
127
128If you want to create applications that will use ImageMagick code or
129APIs, you need to install ImageMagick-devel as well as ImageMagick.
130You do noy need to install it if you just want to use ImageMagick,
131however.
132
133%description devel -l ja
134ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
135これらは ImageMagick アプリケーションの開発の際に必要となります.
136ImageMagick は画像処理プログラムです.
137
138ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
139この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
140する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
141インストールする必要はありません.
142
143%package c++
144Summary: ImageMagick Magick++ library (C++ bindings)
145Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
146Group: System Environment/Libraries
147Requires: ImageMagick = %{version}-%{release}
148
149%description c++
150This package contains the Magick++ library, a C++ binding to the ImageMagick
151graphics manipulation library.
152
153Install ImageMagick-c++ if you want to use any applications that use Magick++.
154
155%description c++
156このパッケージには Magick++ ライブラリが収められています.
157Magick++ とは ImageMagick ライブラリの C++ バインディングです.
158
159Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
160パッケージをインストールして下さい.
161
162%package c++-devel
163Summary: C++ bindings for the ImageMagick library
164Summary(ja): ImageMagick ライブラリの C++ バインディング
165Group: Development/Libraries
166Requires: ImageMagick = %{version}-%{release}
167Requires: ImageMagick-c++ = %{version}-%{release}
168Requires: ImageMagick-devel = %{version}-%{release}
169
170%description c++-devel
171ImageMagick-devel contains the static libraries and header files you'll
172need to develop ImageMagick applications using the Magick++ C++ bindings.
173ImageMagick is an image manipulation program.
174
175If you want to create applications that will use Magick++ code
176or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
177ImageMagick.
178You don't need to install it if you just want to use ImageMagick, or if you
179want to develop/compile applications using the ImageMagick C interface,
180however.
181
182%description c++-devel -l ja
183ImageMagick-c++-devel には Magick++ C++ バインディングを使った
184ImageMagick アプリケーション開発に必要なスタティックライブラリと
185ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
186
187Magick++ コードや API を使ったアプリケーションを開発する場合は,
188ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
189インストールする必要があります.
190ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
191を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
192インストールする必要はありません.
193
194%package -n perl-Image-Magick
195Summary: ImageMagick perl bindings
196Summary(ja): ImageMagick の Perl バインディング
197Group: Development/Libraries
198Requires: ImageMagick = %{version}-%{release}
199Requires: perl >= 5.8.0
200Obsoletes: ImageMagick-perl < %{version}-%{release}
201Provides: ImageMagick-perl = %{version}-%{release}
202
203%description -n perl-Image-Magick
204Perl bindings to ImageMagick.
205
206Install ImageMagick-perl if you want to use any perl scripts that use
207ImageMagick.
208
209%description -n perl-Image-Magick -l ja
210このパッケージは ImageMagick の Perl バインディングです.
211
212ImageMagick を利用する perl スクリプトを使いたい場合は
213ImageMagick-perl パッケージをインストールして下さい.
214
215
216%prep
217%setup -q -n %{name}-%{VER}-%{Patchlevel}
218
219%patch100 -p1 -b .CVE-2012-0247-0248
220%patch101 -p1 -b .CVE-2012-0247-0248-2
221%patch110 -p1 -b .CVE-2012-0259-0260-1798-2
222%patch120 -p1 -b .CVE-2012-1610
223%patch130 -p4 -b .CVE-2014-1958
224%patch140 -p1 -b .CVE-2014-2030_1947
225%patch150 -p1 -b .CVE-2014
226
227%patch200 -p1 -b .CVE-2016-371x-1
228%patch201 -p1 -b .CVE-2016-3714-1
229%patch202 -p1 -b .CVE-2016-3714-2
230%patch203 -p1 -b .CVE-2016-3714-3
231%patch204 -p1 -b .CVE-2016-3717
232%patch205 -p1 -b .CVE-2016-371x-2
233
234%patch206 -p1 -b .CVE-2016-5118
235
236
237%build
238%configure \
239    --enable-silent-rules \
240    --enable-shared \
241    --disable-static \
242    --with-modules \
243    --with-quantum-depth=16 \
244    --without-frozenpaths \
245    --with-x \
246    --without-djvu \
247    --without-fftw \
248    --without-jbig \
249    --without-jp2 \
250    --without-lcms2 \
251    --without-wmf \
252    --with-perl \
253    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
254
255# Disable rpath
256sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
257sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
258
259make %{?_smp_mflags}
260
261%install
262rm -rf $RPM_BUILD_ROOT
263
264make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
265
266# perlmagick: fix perl path of demo files
267%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
268
269find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
270find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
271find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
272
273echo "%defattr(-,root,root)" > perl-pkg-files
274find $RPM_BUILD_ROOT%{_libdir}/perl?/vendor_perl/* -type d -name Image >> perl-pkg-files.orig
275sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
276
277# remove duplicated doc files
278rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
279
280# remove files conflict with libtools
281rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
282rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
283
284# remove *.la files
285find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
286
287%clean
288rm -rf $RPM_BUILD_ROOT
289
290%post -p /sbin/ldconfig
291
292%post c++ -p /sbin/ldconfig
293
294%postun -p /sbin/ldconfig
295
296%postun c++ -p /sbin/ldconfig
297
298
299%files
300%defattr(-,root,root)
301%doc www images
302%doc ChangeLog LICENSE NOTICE QuickStart.txt README.txt index.html
303%dir %{_libdir}/ImageMagick-%{VER}
304%{_libdir}/ImageMagick-%{VER}/config
305%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16
306%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16/*
307%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.so
308%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.la
309%{_libdir}/libMagickCore.so.*
310%{_libdir}/libMagickWand.so.*
311%{_bindir}/[a-z]*
312%dir %{_datadir}/ImageMagick-%{VER}
313%dir %{_datadir}/ImageMagick-%{VER}/config
314%{_datadir}/ImageMagick-%{VER}/config/*.xml
315%{_datadir}/ImageMagick-%{VER}/config/*.icm
316%{_mandir}/man1/ImageMagick.*
317%{_mandir}/man1/[a-z]*
318
319%files devel
320%defattr(-,root,root)
321%{_bindir}/Magick-config
322%{_bindir}/Wand-config
323%{_bindir}/MagickCore-config
324%{_bindir}/MagickWand-config
325#{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.a
326#{_libdir}/libMagickCore.a
327%{_libdir}/libMagickCore.so
328#{_libdir}/libMagickWand.a
329%{_libdir}/libMagickWand.so
330%{_libdir}/pkgconfig/ImageMagick.pc
331%{_libdir}/pkgconfig/Wand.pc
332%{_libdir}/pkgconfig/MagickCore.pc
333%{_libdir}/pkgconfig/MagickWand.pc
334%{_includedir}/ImageMagick/magick
335%{_includedir}/ImageMagick/wand
336%{_mandir}/man1/Magick-config*
337%{_mandir}/man1/Wand-config*
338%{_mandir}/man1/MagickCore-config*
339%{_mandir}/man1/MagickWand-config*
340
341%files c++
342%defattr(-,root,root)
343%{_libdir}/libMagick++.so.*
344
345%files c++-devel
346%defattr(-,root,root)
347%{_bindir}/Magick++-config
348%{_includedir}/ImageMagick/Magick++
349%{_includedir}/ImageMagick/Magick++.h
350#{_libdir}/libMagick++.a
351%{_libdir}/libMagick++.so
352%{_libdir}/pkgconfig/ImageMagick++.pc
353%{_libdir}/pkgconfig/Magick++.pc
354%{_mandir}/man1/Magick++-config*
355
356%files -n perl-Image-Magick -f perl-pkg-files
357%defattr(-,root,root)
358%{_mandir}/man3/*
359
360%changelog
361* Wed Jul 20 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.6.8.5-8
362- imported Patch200-206 from Ubuntu to fix vulnerabilities.
363  - CVE-2016-3714
364  - CVE-2016-3715
365  - CVE-2016-3716
366  - CVE-2016-3717
367  - CVE-2016-3718
368  - CVE-2016-5118
369
370* Thu Apr 10 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.6.8.5-7
371- add patch150 from debian, thanks
372
373* Tue Feb 25 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.6.8.5-6
374- add Patch130 for fix CVE-2014-1958 (psd.c)
375- add Patch140 for fix CVE-2014-2030 (psd.c)
376
377* Fri May  4 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.6.8.5-5
378- update patch110 (regression was found)
379
380* Thu May  3 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.6.8.5-4
381- patch100 for fix CVE-2012-0247-0248
382- patch101 for fix CVE-2012-0247-0248 complited fixes
383- patch110 for fix CVE-2012-0259-0260-1798
384- patch120 for fix CVE-2012-1610
385
386* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.8.5-3
387- add BuildRequires: libXt-devel, xz-devel, xz-lzma-compat, libtool-ltdl-devel
388
389* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-2
390- built with perl-5.12.3
391- changed perl subpackage name
392
393* Sat Mar 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-1
394- new upstream release
395
396* Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.4.9-2
397- rebuilt with graphviz-2.26.3 again
398
399* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.9-1
400- new upstream release
401- rebuilt with graphviz-2.26.3
402
403* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.8-1
404- new upstream release
405
406* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.1.5-2
407- rebuild with rpm-4.8.1 for pkg-config file
408- change BuildRequires: libjpeg-turbo-devel instead of libjpeg-devel
409- change Requires: libjpeg-turbo instead of libjpeg
410
411* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
412- new upstream release
413- built with new toolchain
414- added --disable-static to %%configure, removed static libraries
415
416* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
417- added --without-djvu --without-fftw
418
419* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
420- new upstream release
421
422* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
423- new upstream release
424
425* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
426- new upstream release
427- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
428- add R: graphviz, OpenEXR-libs, ilmbase
429
430* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
431- new upstream release
432- added Packager tag
433
434* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
435- new upstream release
436
437* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
438- new upstream release
439- updated BuildRequires
440
441* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
442- enabled lcms as default.
443
444* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
445- new upstream release
446
447* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
448- new upstream release
449
450* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
451- new upstream release
452
453* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
454- new upstream release
455
456* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
457- new upstream release
458- spec in UTF-8
459
460* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
461- enabled to build with lcms (use '--with lcms' to enable).
462
463* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
464- new upstream release
465- rebuilt with perl-5.10.0
466
467* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
468- new upstream release
469- removed *.la files from devel packages
470
471* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
472- new upstream release
473- change files section to fit new release
474- build under new versioning policy
475
476* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
477- new upstream release
478
479* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
480- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
481- add BuildPrereq: librsvg2-devel
482- add %%{?_smp_mflags} to make command arg
483
484* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
485- new upstream release
486- changed Group to Applications/Graphics
487
488* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
489- rebuilt for VineSeed
490
491* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
492- update patch1 for fix CVE-2007-0770
493
494* Wed Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
495- upstream release
496- add patch1 for fix CVE-2006-5456
497
498* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
499- rebuilt (for ppc) to resolve reference to invalid *la files
500
501* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
502- new upstream release
503
504* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
505- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
506
507* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
508- new upstream release
509- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
510- add --with-perl-options to configure option
511
512* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
513- new upstream release
514- build with XOrg-6.9.0
515
516* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
517- new upstream release
518- add %%{_mandir}/man1/ImageMagick.* to main package
519
520* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
521- source upgrade
522- remove patch1
523- update %%files
524
525* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
526- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
527  (CAN-2004-0981)
528
529* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
530- move $(pkglibdir)/modules-Q16/*/*.la to main package.
531
532* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
533- source upgrade
534- Patch: change default menu font so display can work without XOrg-75dpi-fonts
535- add missing docs
536- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
537- *.pc should be in -devel package
538- add missing pkg{lib,data}dirs to %%files
539
540* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
541- source upgrade
542- add --without-dot to %%configure option
543- update %%files section
544
545* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
546- source upgrade
547
548* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
549- source upgrade
550
551* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
552- add --without-jbig to %%configure option
553
554* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
555- add --without-lcms to %%configure option
556
557* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
558- source upgrade
559- remove commented lines
560
561* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
562- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
563
564* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
565- source upgrade
566- remove patch for freetype2, no need
567- remove commented lines
568- add --with-quantum-depth=16 --with-modules --enable-lzw
569  --without-frozenpaths to %%configure option
570- remove --with-threads --without-xml from %%configure option
571- update %%files
572
573* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
574- patch update
575- add --without-jp2 to configure option
576- change PerlMagick build method
577
578* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
579- rebuild without jasper-devel
580
581* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
582- source upgrade to 5.5.7-15
583
584* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
585- source upgrade to 5.5.7-13
586- add patch0 to build against freetype2-2.1.7
587
588* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
589- source upgrade to 5.5.7-11
590- clean up spec
591- build without previous package (do not require libMagick.so.0)
592
593* Sun Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
594- source upgrade to 5.5.7-9
595- revised name of pkgconfig files
596- remove BuildPrereq: freetype-devel
597
598* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
599- source upgrade to 5.5.7-6
600- disable all patches
601- revised %%files section
602- disable libtoolize and autotools
603- change PerlMagick build method
604- build without previous package (do not require libMagick.so.5)
605
606* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
607- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
608  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
609
610* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
611- rebuild
612
613* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
614- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
615- FIXME: rpm's macro problem?
616
617- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
618  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
619
620  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
621  - remove unnecessary duplicated %%doc files
622  - --without-xml instead of --without-ttf
623  - eliminate libungif(-devel) from BuildReq/Requires
624  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
625
626  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
627  - add delegetes.mgk (and %%{_libdir}/%%{name})
628
629  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
630  - 5.2.9-0vl4
631  - Sorry, the spec was in Shift_JIS. Fixed.
632
633  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
634  - 5.2.9-0vl3
635  - rebuilt with perl-5.6.1
636  - added Japanese summary and description :-P
637  - added --without-ttf in order to disable freetype2 (SeedPlus) support
638  - added --without-wmf in order to disable libwmf (SeedPlus) support
639
640  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
641  - 5.2.9-0vl2
642  - rebuild on Perl-5.6
643  - use %%{perl_sitearch}
644  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
645
646  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
647  - 5.2.9-0vl1
648  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
649
650* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
651- fix perl paths in file list
652
653* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
654- lib64'ize
655- don't throw stuff in /usr/X11R6, that's for X only
656- remove files we aren't shipping
657
658* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
659- rebuilt with gcc-3.2 (we hope)
660
661* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
662- build using gcc-3.2-0.1
663
664* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
665- fix non-cpp headers in -devel package
666- fix #62157 (wrong path for include files in ImageMagick-devel)
667- fix #63897 (use _target instead of _arch) in libtool workaround
668- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
669
670* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
671- update
672- fix localdoc patch
673- fix %%files section
674- disable nonroot patch
675- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
676- fix libtool workaround
677- moved Magick*-config into -devel package (#64249)
678
679* Sun May 26 2002 Tim Powers <timp@redhat.com>
680- automated rebuild
681
682* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
683- 5.4.6
684
685* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
686- Update to pl 11
687
688* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
689- Update to 5.4.3 pl5; this fixes #58080
690
691* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
692- Patchlevel 3
693
694* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
695- automated rebuild
696
697* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
698- Update to 5.4.2-2
699- Fix #57923, also don't hardcode netscape as html viewer
700
701* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
702- 5.4.1
703- Link against new libstdc++
704
705* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
706- 5.4.0.5
707- Make the error message when trying to display an hpgl file more
708  explicit (#55875)
709
710* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
711- 5.4.0.3
712- Fix names of man pages
713
714* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
715- 5.4.0
716- work around build system breakage causing applications to be named
717  %{_arch}-redhat-linux-foo rather than foo
718
719* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
720- 5.3.9
721
722* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
723- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
724  (#52611)
725
726* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
727- Remove Magick++ includes from -devel, they're already in -c++-devel
728  (#51590)
729
730* Sun Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
731- 5.3.8 (bugfix release)
732
733* Sat Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
734- fix to build Perlmagic on s390 s390x
735
736* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
737- Add delegates.mgk to the package (#50725)
738
739* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
740- 5.3.7
741- Fix build without previously installed ImageMagick-devel (#49816)
742- Move perl bindings to a separate package.
743
744* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
745- Fix build as non-root again
746- Shut up rpmlint
747
748* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
749- 5.3.6
750- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
751
752* Sat Jun 16 2001 Than Ngo <than@redhat.com>
753- update to 5.3.5
754- cleanup specfile
755
756* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
757- 5.3.3-respin, fixes #41196
758
759* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
760- 5.3.3
761- Add a desktop file for "display" (RFE#17417)
762
763* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
764- 5.3.2
765- work around bugs in ia64 glibc headers
766
767* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
768- remove patch for s390, it is not necessary
769
770* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
771- 5.2.7
772
773* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
774- 5.2.6
775
776* Mon Dec 18 2000 Than Ngo <than@redhat.com>
777- ported to s390
778
779* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
780- 5.2.4
781- Fix up and package the C++ bindings in the new c++/c++-devel packages.
782
783* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
784- rebuild against new libpng
785
786* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
787- include images with docs (#10312)
788
789* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
790- don't build with -ggdb, use -g instead.
791
792* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
793- automatic rebuild
794
795* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
796- update to 5.2.2 beta
797
798* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
799- update to 5.2.1, redone patches as they failed
800
801* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
802- remove hacks to move perl man pages
803- don't include the perl*/man stuff, these files go in /usr/share/man now.
804
805* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
806- disable optimization on Alpha and Sparc
807
808* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
809- update to 5.2.0
810- update URL
811- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
812
813* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
814- bootstrap rebuilt to nuke broken libbz2 deps
815- add Prefix: tag such that the FHS macros work properly
816
817* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
818- now compiles with bzip2 1.0
819- changed buildroot to include version
820
821* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
822- fix compilation with new perl
823
824* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
825- 5.1.1
826
827* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
828- Rebuild to get compressed man pages
829
830* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
831- ugly hack to print with lpr instead of lp
832
833* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
834- update to 4.2.9
835
836* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
837- update to 4.2.8
838
839* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
840- include the perl man pages as well
841
842* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
843- remove --enable-16bit because it damages interoperability
844
845* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
846- update to 4.2.2
847- change ChangeLog to refer to actual dates.
848- strip binaries
849
850* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
851- add more files. Oops.
852
853* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
854- auto rebuild in the new build environment (release 2)
855
856* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
857- version 4.2.1
858
859* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
860- changed group
861
862* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
863- hacks to make it work with the new perl
864- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
865- make sure the libraries have the x bit on
866
867* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
868- translations modified for de, fr
869
870* Thu May 07 1998 Prospector System <bugs@redhat.com>
871- translations modified for de, fr, tr
872
873* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
874- updated to 4.0.5
875
876* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
877- updated to 4.0.4
878- added BuildRoot
879
880* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
881- updated from 3.8.3 to 3.9.1
882- removed PNG patch (appears to be fixed)
883
884* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
885- build against new libpng
886
887* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
888- built against glibc
889
890* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
891- updated to version 3.8.3.
892- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.