source: projects/specs/trunk/z/zsh/zsh-vl.spec @ 8097

Revision 8097, 14.3 KB checked in by iwaim, 10 years ago (diff)

zsh 5.0.2-2

Line 
1# -*- Mode: rpm-spec -*-
2
3%define name zsh
4%define version 5.0.2
5%define rversion %{version}
6%define dversion %{version}
7%define release 2%{?_dist_release}
8%define url ftp://ftp.zsh.org/pub/
9## %define _sysconfdir /etc
10
11Summary: A shell with lots of features.
12Summary(ja): 多機能シェル
13Name: %{name}
14Version: %{version}
15Release: %{release}
16License: distributable (see LICENCE file)
17Group: System Environment/Shells
18Url: http://www.zsh.org
19Source0: %{url}/%{name}-%{rversion}.tar.bz2
20Source1: zcfg-vine.tar.bz2
21Source3: http://www.pwstephenson.fsnet.co.uk/computing/zshguide.tar.bz2
22# fixed that _apt fail  completions rpm package name.
23Patch0: zsh-4.3.4-apt4rpm.patch
24Patch1: zsh-4.3.4-sshcomp.patch
25Patch2: zsh-4.2.0-completion_tar_archive.patch
26Patch3: zsh-4.3.10-fixpath.patch
27Requires(post,preun): /sbin/install-info
28Requires(post,postun): grep
29BuildRoot: %{_tmppath}/%{name}-buildroot
30BuildRequires: texinfo, ncurses-devel
31BuildRequires: findutils grep
32
33Vendor: Project Vine
34Distribution: Vine Linux
35Packager: iwaim
36Epoch: 1
37
38%description
39Zsh is a UNIX command interpreter (shell) usable as an
40interactive login shell and as a shell script command
41processor. Of the standard shells, zsh most closely resembles
42ksh but includes many enhancements. Zsh has command-line editing,
43built-in spelling correction, programmable command completion,
44shell functions (with autoloading), a history mechanism, and a
45lots of other features
46
47Install the zsh package if you'd like to try out a different shell.
48
49%description -l ja
50Zsh 対話的に使える コマンドラインインタプリタ(シェル)です。
51規格上Zsh はksh ににているが多くの拡張がされている。
52スペルコレクション,プログラマブル補完,
53シェルファンクションズ(オートロード),等の多くの機能がある。
54
55%prep
56%setup -q -a 1 -n %{name}-%{rversion}
57#%patch0 -p1
58#%patch1 -p1
59#%patch2 -p1
60%patch3 -p1
61
62# remove temporary files
63find|grep '~$'|xargs rm -f
64
65%build
66
67%ifnarch sparc
68%configure \
69           --enable-etcdir=%{_sysconfdir} \
70           --enable-fndir=%{_datadir}/zsh/functions \
71           --enable-site-fndir=%{_datadir}/zsh/site-functions \
72           --enable-function-subdirs \
73           --enable-scriptdir=%{_datadir}/zsh/scripts \
74           --enable-site-scriptdir=%{_datadir}/zsh/site-scripts \
75           --with-tcsetpgrp
76%else
77%configure \
78           --enable-etcdir=%{_sysconfdir} \
79           --enable-fndir=%{_datadir}/zsh/functions \
80           --enable-site-fndir=%{_datadir}/zsh/site-functions \
81           --enable-function-subdirs \
82           --enable-scriptdir=%{_datadir}/zsh/scripts \
83           --enable-site-scriptdir=%{_datadir}/zsh/site-scripts
84           --disable-lfs
85%endif
86make
87
88%install
89rm -rf $RPM_BUILD_ROOT
90%makeinstall fndir=%{buildroot}%{_datadir}/zsh/functions sitefndir=%{buildroot}%{_datadir}/zsh/site-functions scriptdir=%{buildroot}%{_datadir}/zsh/scripts sitescriptdir=%{buildroot}%{_datadir}/zsh/site-scripts
91
92make install.info DESTDIR=$RPM_BUILD_ROOT
93
94mkdir -p %{buildroot}%{_sysbindir}
95pushd %{buildroot}%{_sysbindir} && {
96    ln -s ..%{_bindir}/zsh ./zsh
97} && popd
98
99# copy Mandrake Configuration files.
100mkdir -p %{buildroot}%{_sysconfdir}
101cp -a zcfg/* %{buildroot}%{_sysconfdir}
102
103# Copy documentation.
104#rm -rf docroot
105mkdir -p docroot/{Info_html,Examples,Documentation}/
106cp -a README docroot/
107cp -a Functions/Misc/* Misc/* Util/* docroot/Examples/
108cp -a INSTALL ChangeLog* docroot/Documentation
109cp -a StartupFiles docroot/
110cp -a Etc/* docroot/Documentation
111cp -a NEWS docroot/
112#cp -a Doc/*html docroot/Info_html/
113
114mkdir -p docroot/Zsh_Guide
115bzcat %{SOURCE3}|tar xf - -C docroot/Zsh_Guide
116mv docroot/Zsh_Guide/zshguide/*html docroot/Zsh_Guide/
117rmdir docroot/Zsh_Guide/zshguide
118
119find docroot/ -type f|xargs perl -p -i -e 's|^#!%{prefix}/local/bin/zsh|#!%{_bi
120ndir}/zsh|'
121find docroot/ -type f|xargs perl -p -i -e 's|^#!%{prefix}/local/bin/perl|#!%{_b
122indir}/perl|'
123
124rm -f docroot/StartupFiles/.distfiles
125rm -f docroot/Examples/{Makefile*,*.yo}
126rm -f docroot/Documentation/{Makefile*,*.yo}
127mv docroot/Examples/compctl-examples docroot/StartupFiles
128
129#Build Helpdir
130mkdir -p %{buildroot}%{_datadir}/zsh/
131
132rm -rf help && mkdir help/ && pushd help && {
133    echo "Build Documentation"
134    make -C ../Doc/ zshbuiltins.1
135    man ../Doc/zshbuiltins.1|colcrt -|perl ../Util/helpfiles
136} && popd
137
138mv help %{buildroot}%{_datadir}/zsh
139
140find docroot/ -name 'Makefile*' -o -name '.yo'|xargs rm -f
141
142%clean
143rm -rf %{buildroot}
144
145%post
146if [ ! -f %{_sysconfdir}/shells ]; then
147        echo "/bin/zsh" > %{_sysconfdir}/shells
148else
149        grep '^/bin/zsh' %{_sysconfdir}/shells > /dev/null || echo "/bin/zsh" >> /etc/shells
150fi
151/sbin/install-info %{_infodir}/zsh.info.gz %{_infodir}/dir
152
153%preun
154if [ "$1" = 0 ]; then
155    /sbin/install-info --delete %{_infodir}/zsh.info.gz %{_infodir}/dir
156fi
157
158%postun
159if [ ! -x /bin/zsh ]; then
160        grep -v '^/bin/zsh$' %{_sysconfdir}/shells | grep -v '^/bin/zsh$'> /etc/shells.rpm
161        mv %{_sysconfdir}/shells.rpm /etc/shells
162fi
163
164%files
165%defattr(-,root,root,0755)
166%doc LICENCE
167%doc docroot/README docroot/NEWS
168%doc docroot/Documentation/ docroot/Examples/ docroot/Info_html/ docroot/StartupFiles/
169%doc docroot/Zsh_Guide
170%config %{_sysconfdir}/z*
171%{_sysbindir}/zsh
172%{_bindir}/zsh*
173%{_libdir}/zsh
174%{_infodir}/*.info*
175%exclude %{_infodir}/dir*
176%{_mandir}/man*/*
177%{_datadir}/zsh
178
179%changelog
180* Tue Dec 31 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 5.0.2-2
181- rebuild with current VineSeed
182
183* Tue Dec 25 2012 IWAI, Masaharu <iwai@alib.jp> 5.0.2-1
184- new upstream release
185
186* Thu Nov 29 2012 IWAI, Masaharu <iwai@alib.jp> 5.0.0-1
187- new upstream release
188
189* Sat Aug  6 2011 IWAI, Masaharu <iwai@alib.jp> 4.3.12-1
190- new upstream release
191
192* Tue Dec 21 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.11-1
193- new upstream release
194
195* Sun Aug 15 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.10-2
196- rebuild with new toolchain
197
198* Tue Feb 23 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.10-1
199- new upstream release
200- update fixpath patch (Patch3)
201- drop unnecessary patch: fix subversion completion patch (Patch4)
202- fix '--with-tcsetpgrp' option: apply besides SPARC arch
203- add LICENCE file in %%doc directory: fixed typo
204- exclude %%{_infodir}/dir* in %%files section
205- drop Prefix tag
206- replace Prereq to Requires(*)
207- BuildRequires: findutils grep
208
209* Wed Jan 27 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.3.4-4
210- fix files error (LICENSE is no longer exist)
211
212* Wed Jan 27 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.3.4-3
213- add --with-tcsetpgrp into configure section
214- add BR: texinfo, ncurses-devel
215
216* Thu Jan  7 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.4-2
217- add fix subversion completion patch (Patch4): <BTS:VineLinux:869>
218  - see http://svn.haxx.se/users/archive-2008-06/0095.shtml
219- add Packager tag
220- add LICENSE file in %%doc directory
221- fix License tag's value
222
223* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 4.3.4-1vl5
224- applied new versioning policy, spec in utf-8
225
226* Wed Oct 31 2007 IWAI, Masaharu <iwai@alib.jp> 4.3.4-0vl1
227- new upstream release
228- update apt4rpm patch ( Patch0 )
229- update sshcomp patch ( Patch1 )
230- add fixpath patch ( Patch3 )
231- update %%build and %%install section
232
233* Tue Apr 12 2005 IWAI, Masaharu <iwai@alib.jp> 4.2.5-0vl1
234- new upstream release
235
236* Tue Mar  8 2005 IWAI, Masaharu <iwai@alib.jp> 4.2.4-0vl1
237- new upstream release
238
239* Sat Aug 14 2004 IWAI, Masaharu <iwai@alib.jp> 4.2.1-0vl1
240- new upstream release
241- update apt4rpm patch ( Patch0 )
242- drop unnecessary patch for fixed upstream: job_table_full patch ( Patch3 )
243- update 'Copy documentation' script: moved NEWS document in upstream archive
244
245* Sat Jul 7 2004 HAYASHI Kentarou <linjian@gigo-ice.org> 4.2.0-0vl2
246- add job_table_full.patch (Patch3)
247  see Zsh Mailing List 2004/msg00488.html
248
249* Mon Mar 29 2004 IWAI, Masaharu <iwai@alib.jp> 4.2.0-0vl1
250- new upstream release
251- update completion tar archive patch (Patch2)
252- update file list: include directories in %%{_libdir} and %%{_datadir}
253
254* Sun Dec 28 2003 IWAI, Masaharu <iwai@alib.jp> 4.0.9-0vl1
255- upstream update
256- update apt4rpm.patch (Patch0)
257
258* Fri Jun 20 2003 IWAI Masaharu <iwai@alib.jp> 4.0.7-0vl1
259- upstream update
260- update apt4rpm.patch(Patch0)
261
262* Sat May  3 2003 IWAI Masaharu <iwai@alib.jp> 4.0.6-0vl3
263- add completion_tar_archive.patch (Patch2)
264  for tar's "z" option to accept bz2 tarball with zsh completion.
265
266* Mon Dec  2 2002 IWAI Masaharu <iwai@alib.jp> 4.0.6-0vl2
267- add apt-cache showsrc option in apt4rpm patch (Patch0)
268
269* Thu Aug 15 2002 IWAI Masaharu <iwai@alib.jp> 4.0.6-0vl1
270- upstream update
271
272* Sun Aug 11 2002 IWAI Masaharu <iwai@alib.jp> 4.0.5-0vl1
273- upstream update
274- apt-cache showsrc option changed unavailable in apt4rpm patch (Patch0)
275
276* Tue Dec  4 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.4-0vl1
277- loading vine specific profile scripts moved from zshrc to zprofile
278- fixed other bug($PATH,zmodload)
279
280
281* Mon Aug 27 2001 Shoji Matsumoto <shom@vinelinux.org> 4.0.2-0vl3
282- rebuilding current Seed
283- change ssh completion (Patch1)
284
285* Thu Aug 16 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.2-0vl2
286- fixed bug rpm package name completions in _apt
287
288* Thu Jul 19 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.2-0vl1
289- 4.0.2
290
291* Sun Jun  3 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl1
292- upstream 4.0.1 release
293- fixed bug zshrc( add /usr/X11R6/bin $PATH)
294- fixed lack 'Epoch:'
295
296* Thu Apr 26 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl0.4.pre.3
297- fixed version number invalid
298
299* Fri Apr 20 2001 <sagami@vinelinux.org>
300- 4.0.1-0vl0.3.pre.4
301- install infopage/manpage and added PreReq = /sbin/install-info
302- fixed/added scripts in post/postun/preun for install-info
303
304* Fri Apr 13 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl0.3.pre.3
305- upstream update
306- fixed /etc/zshrc bugs
307
308* Tue Apr  3 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl0.0.pre.2
309- upstream update
310- remove all patches
311
312* Tue Oct  3 2000 Kazuhisa TAKEI<takei@vinelinux.org> 3.1.9-4vl1
313- can read /etc/profile.d/*.sh
314
315* Wed Sep 13 2000 Kazuhisa TAKEI<takei@vinelinux.org>
316- 3.1.9-4vl0
317- convert from Mandrake Linux to Vine Linux
318- add Japanise Summary and description
319
320* Sat Aug 26 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-4mdk
321- Set some %config file to (noreplace).
322- Make -A to complete spec file for _rpm.
323
324* Thu Jul 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-3mdk
325- Get /usr/share/man also in the completion for perl manpages.
326- BM.
327
328* Wed Jul  5 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-2mdk
329- Fix buildroot hardcoded in binary.
330
331* Wed Jun 21 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-1mdk
332- Use makeinstall macros (not easy this one :\).
333- 3.1.9.
334
335* Mon Jun  5 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.8-1mdk
336- 3.1.8.
337
338* Sun May 28 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev22-3mdk
339- Fix path (%{prefix}/ucb -> %{_bindir}/X11)
340- Fix keys (home-end-suppr-delete) directly in the zsh binary.
341
342* Sun Apr 16 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev22-2mdk
343- Remove doble .so in %{_libdir}/zsh/*.
344
345* Thu Apr 13 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev22-1mdk
346- 3.1.6dev22.
347
348* Fri Mar 31 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev20-3mdk
349- Fix completion of rpm with -qp*.
350
351* Mon Mar 27 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev20-2mdk
352- Upgrade zshguide.
353
354* Sat Mar 25 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev20-1mdk
355- 3.1.6-dev20
356
357* Wed Mar 22 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev19-3mdk
358- Move global configuration here.
359- Adjust groups.
360
361* Tue Feb 22 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev19-2mdk
362- Add new zshguide from pws.
363- Separate the doc to the doc package
364
365* Sun Feb 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev19-1mdk
366- Clean Up spec (thanks specs-helper).
367- Remove all our patchs (now all is commited to upstream main).
368- 3.1.6dev19.
369
370* Fri Feb 18 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev18-3mdk
371- Recompile with glibc2.1.3 (first one).
372
373* Thu Feb 17 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev18-2mdk
374- Add --freshen completion.
375
376* Tue Feb 15 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev18-1mdk
377- Fix descriptions and summary.
378- 3.1.6dev18.
379
380* Thu Feb 10 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev17-2mdk
381- Remove Makefile in %doc.
382- BuildRequires: autoconf tetex.
383- Lot of modications in the default config as suggested by Bart
384  Schaefer <schaefer@zsh.org>.
385- 3.1.6dev17.
386
387* Mon Jan 24 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev16-1mdk
388- dev16.
389- Redo the tar_archive patchs.
390
391* Tue Jan 18 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev15-1mdk
392- dev15.
393- Fix doc generation with dev15.
394- remove META-FAQ.
395- disable lfs on sparc.
396
397* Thu Jan  6 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev14-1mdk
398- dev14 (note the name change).
399
400* Mon Jan  3 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6pws13-3mdk
401- Remove temporary files.
402
403* Fri Dec 31 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
404- 3.1.6pws13 (mainly bug fixes).
405- fix %post.
406- fix rpm completion
407
408* Thu Dec 09 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
409- 3.1.6pws11 (mainly bug fixes).
410
411* Tue Dec  7 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
412- Add run-help and perl-build the documentation.
413
414* Tue Nov 30 1999 Francis Galiegue <francis@mandrakesoft.com>
415
416- Completion machine patch - we use GNU make and GNU tar
417- Small fix to %post script
418
419* Tue Nov 30 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
420- 3.1.6pws10
421- Fix zprofile.
422- Clean-up Franciseries.
423- Clean-up specs.
424
425* Mon Nov 29 1999 Francis Galiegue <francis@mandrakesoft.com>
426- Grrr... Rebuilt on kenobi, toy ain't a cooker
427
428* Mon Nov 29 1999 Francis Galiegue <francis@mandrakesoft.com>
429
430- Completion system now handles bzip2'ed manpages and tarballs
431- Some cool options
432
433* Wed Nov 10 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
434- Add zshguide.txt to documentation.
435
436* Thu Oct 07 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
437
438- Fix bug in %{_sysconfdir}/zsh use USERNAME instead of USER.
439- Improve %{_sysconfdir}/z* to source the /etc/profile.d/ files.
440
441* Mon Oct 04 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
442
443- 3.1.6-pws6
444- Fix bad link.
445- Fix bad manpages.
446
447* Tue Aug 17 1999 Thierry Vignaud <tvignaud@mandrakesoft.com>
448- fix typo in examples directory name
449
450* Sun Aug  8 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
451
452- Copy documentation (yes a lot).
453- Remove the completion machine and put them in [[ {etc,root}(skel|files) ]] package.
454
455* Sat Aug  7 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
456
457- By defaut we launch the completion machine.
458- Put zsh in %{_bindir}/
459- Rewrite of Spec file for this new major version.
460
461# end of file
Note: See TracBrowser for help on using the repository browser.