source: projects/specs/trunk/z/zsh/zsh-vl.spec @ 9925

Revision 9925, 14.1 KB checked in by iwaim, 8 years ago (diff)

zsh 5.0.7-1

Line 
1# -*- Mode: rpm-spec -*-
2
3%define name zsh
4%define version 5.0.7
5%define rversion %{version}
6%define dversion %{version}
7%define release 1%{?_dist_release}
8%define url ftp://ftp.zsh.org/pub/
9## %define _sysconfdir /etc
10
11Summary: A shell with lots of features.
12Summary(ja): 多機能シェル
13Name: %{name}
14Version: %{version}
15Release: %{release}
16License: distributable (see LICENCE file)
17Group: System Environment/Shells
18Url: http://www.zsh.org
19Source0: %{url}/%{name}-%{rversion}.tar.bz2
20Source1: zcfg-vine.tar.bz2
21# fixed that _apt fail  completions rpm package name.
22Patch0: zsh-4.3.4-apt4rpm.patch
23Patch1: zsh-4.3.4-sshcomp.patch
24Patch2: zsh-4.2.0-completion_tar_archive.patch
25Patch3: zsh-5.0.7-fixpath.patch
26Requires(post,preun): /sbin/install-info
27Requires(post,postun): grep
28BuildRoot: %{_tmppath}/%{name}-buildroot
29BuildRequires: texinfo, ncurses-devel
30BuildRequires: findutils grep
31BuildRequires: man-db
32
33Vendor: Project Vine
34Distribution: Vine Linux
35Packager: iwaim
36Epoch: 1
37
38%description
39Zsh is a UNIX command interpreter (shell) usable as an
40interactive login shell and as a shell script command
41processor. Of the standard shells, zsh most closely resembles
42ksh but includes many enhancements. Zsh has command-line editing,
43built-in spelling correction, programmable command completion,
44shell functions (with autoloading), a history mechanism, and a
45lots of other features
46
47Install the zsh package if you'd like to try out a different shell.
48
49%description -l ja
50Zsh 対話的に使える コマンドラインインタプリタ(シェル)です。
51規格上Zsh はksh ににているが多くの拡張がされている。
52スペルコレクション,プログラマブル補完,
53シェルファンクションズ(オートロード),等の多くの機能がある。
54
55%prep
56%setup -q -a 1 -n %{name}-%{rversion}
57#%patch0 -p1
58#%patch1 -p1
59#%patch2 -p1
60%patch3 -p1
61
62# remove temporary files
63find|grep '~$'|xargs rm -f
64
65%build
66
67%ifnarch sparc
68%configure \
69           --enable-etcdir=%{_sysconfdir} \
70           --enable-fndir=%{_datadir}/zsh/functions \
71           --enable-site-fndir=%{_datadir}/zsh/site-functions \
72           --enable-function-subdirs \
73           --enable-scriptdir=%{_datadir}/zsh/scripts \
74           --enable-site-scriptdir=%{_datadir}/zsh/site-scripts \
75           --with-tcsetpgrp
76%else
77%configure \
78           --enable-etcdir=%{_sysconfdir} \
79           --enable-fndir=%{_datadir}/zsh/functions \
80           --enable-site-fndir=%{_datadir}/zsh/site-functions \
81           --enable-function-subdirs \
82           --enable-scriptdir=%{_datadir}/zsh/scripts \
83           --enable-site-scriptdir=%{_datadir}/zsh/site-scripts
84           --disable-lfs
85%endif
86make
87
88%install
89rm -rf $RPM_BUILD_ROOT
90%makeinstall fndir=%{buildroot}%{_datadir}/zsh/functions sitefndir=%{buildroot}%{_datadir}/zsh/site-functions scriptdir=%{buildroot}%{_datadir}/zsh/scripts sitescriptdir=%{buildroot}%{_datadir}/zsh/site-scripts \
91             runhelpdir=%{buildroot}%{_datadir}/zsh/${VERSION}/help
92
93make install.info DESTDIR=$RPM_BUILD_ROOT
94
95mkdir -p %{buildroot}%{_sysbindir}
96pushd %{buildroot}%{_sysbindir} && {
97    ln -s ..%{_bindir}/zsh ./zsh
98} && popd
99
100# copy Mandrake Configuration files.
101mkdir -p %{buildroot}%{_sysconfdir}
102cp -a zcfg/* %{buildroot}%{_sysconfdir}
103
104# Copy documentation.
105#rm -rf docroot
106mkdir -p docroot/{Info_html,Examples,Documentation}/
107cp -a README docroot/
108cp -a Functions/Misc/* Misc/* Util/* docroot/Examples/
109cp -a INSTALL ChangeLog* docroot/Documentation
110cp -a StartupFiles docroot/
111cp -a Etc/* docroot/Documentation
112cp -a NEWS docroot/
113#cp -a Doc/*html docroot/Info_html/
114
115find docroot/ -type f|xargs perl -p -i -e 's|^#!%{prefix}/local/bin/zsh|#!%{_bi
116ndir}/zsh|'
117find docroot/ -type f|xargs perl -p -i -e 's|^#!%{prefix}/local/bin/perl|#!%{_b
118indir}/perl|'
119
120rm -f docroot/StartupFiles/.distfiles
121rm -f docroot/Examples/{Makefile*,*.yo}
122rm -f docroot/Documentation/{Makefile*,*.yo}
123mv docroot/Examples/compctl-examples docroot/StartupFiles
124
125find docroot/ -name 'Makefile*' -o -name '.yo'|xargs rm -f
126
127%clean
128rm -rf %{buildroot}
129
130%post
131if [ ! -f %{_sysconfdir}/shells ]; then
132        echo "/bin/zsh" > %{_sysconfdir}/shells
133else
134        grep '^/bin/zsh' %{_sysconfdir}/shells > /dev/null || echo "/bin/zsh" >> /etc/shells
135fi
136/sbin/install-info %{_infodir}/zsh.info.gz %{_infodir}/dir
137
138%preun
139if [ "$1" = 0 ]; then
140    /sbin/install-info --delete %{_infodir}/zsh.info.gz %{_infodir}/dir
141fi
142
143%postun
144if [ ! -x /bin/zsh ]; then
145        grep -v '^/bin/zsh$' %{_sysconfdir}/shells | grep -v '^/bin/zsh$'> /etc/shells.rpm
146        mv %{_sysconfdir}/shells.rpm /etc/shells
147fi
148
149%files
150%defattr(-,root,root,0755)
151%doc LICENCE
152%doc docroot/README docroot/NEWS
153%doc docroot/Documentation/ docroot/Examples/ docroot/Info_html/ docroot/StartupFiles/
154%config %{_sysconfdir}/z*
155%{_sysbindir}/zsh
156%{_bindir}/zsh*
157%{_libdir}/zsh
158%{_infodir}/*.info*
159%exclude %{_infodir}/dir*
160%{_mandir}/man*/*
161%{_datadir}/zsh
162
163%changelog
164* Thu Jan  1 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 5.0.7-1
165- update to 5.0.7
166- add BuildRequires: man-db
167- update fixpath patch (Patch3)
168- add install path 'runhelpdir'
169- add help files
170- drop too old Zsh Guide (Source3)
171
172* Tue Dec 31 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 5.0.2-2
173- rebuild with current VineSeed
174
175* Tue Dec 25 2012 IWAI, Masaharu <iwai@alib.jp> 5.0.2-1
176- new upstream release
177
178* Thu Nov 29 2012 IWAI, Masaharu <iwai@alib.jp> 5.0.0-1
179- new upstream release
180
181* Sat Aug  6 2011 IWAI, Masaharu <iwai@alib.jp> 4.3.12-1
182- new upstream release
183
184* Tue Dec 21 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.11-1
185- new upstream release
186
187* Sun Aug 15 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.10-2
188- rebuild with new toolchain
189
190* Tue Feb 23 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.10-1
191- new upstream release
192- update fixpath patch (Patch3)
193- drop unnecessary patch: fix subversion completion patch (Patch4)
194- fix '--with-tcsetpgrp' option: apply besides SPARC arch
195- add LICENCE file in %%doc directory: fixed typo
196- exclude %%{_infodir}/dir* in %%files section
197- drop Prefix tag
198- replace Prereq to Requires(*)
199- BuildRequires: findutils grep
200
201* Wed Jan 27 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.3.4-4
202- fix files error (LICENSE is no longer exist)
203
204* Wed Jan 27 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.3.4-3
205- add --with-tcsetpgrp into configure section
206- add BR: texinfo, ncurses-devel
207
208* Thu Jan  7 2010 IWAI, Masaharu <iwai@alib.jp> 4.3.4-2
209- add fix subversion completion patch (Patch4): <BTS:VineLinux:869>
210  - see http://svn.haxx.se/users/archive-2008-06/0095.shtml
211- add Packager tag
212- add LICENSE file in %%doc directory
213- fix License tag's value
214
215* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 4.3.4-1vl5
216- applied new versioning policy, spec in utf-8
217
218* Wed Oct 31 2007 IWAI, Masaharu <iwai@alib.jp> 4.3.4-0vl1
219- new upstream release
220- update apt4rpm patch ( Patch0 )
221- update sshcomp patch ( Patch1 )
222- add fixpath patch ( Patch3 )
223- update %%build and %%install section
224
225* Tue Apr 12 2005 IWAI, Masaharu <iwai@alib.jp> 4.2.5-0vl1
226- new upstream release
227
228* Tue Mar  8 2005 IWAI, Masaharu <iwai@alib.jp> 4.2.4-0vl1
229- new upstream release
230
231* Sat Aug 14 2004 IWAI, Masaharu <iwai@alib.jp> 4.2.1-0vl1
232- new upstream release
233- update apt4rpm patch ( Patch0 )
234- drop unnecessary patch for fixed upstream: job_table_full patch ( Patch3 )
235- update 'Copy documentation' script: moved NEWS document in upstream archive
236
237* Sat Jul 7 2004 HAYASHI Kentarou <linjian@gigo-ice.org> 4.2.0-0vl2
238- add job_table_full.patch (Patch3)
239  see Zsh Mailing List 2004/msg00488.html
240
241* Mon Mar 29 2004 IWAI, Masaharu <iwai@alib.jp> 4.2.0-0vl1
242- new upstream release
243- update completion tar archive patch (Patch2)
244- update file list: include directories in %%{_libdir} and %%{_datadir}
245
246* Sun Dec 28 2003 IWAI, Masaharu <iwai@alib.jp> 4.0.9-0vl1
247- upstream update
248- update apt4rpm.patch (Patch0)
249
250* Fri Jun 20 2003 IWAI Masaharu <iwai@alib.jp> 4.0.7-0vl1
251- upstream update
252- update apt4rpm.patch(Patch0)
253
254* Sat May  3 2003 IWAI Masaharu <iwai@alib.jp> 4.0.6-0vl3
255- add completion_tar_archive.patch (Patch2)
256  for tar's "z" option to accept bz2 tarball with zsh completion.
257
258* Mon Dec  2 2002 IWAI Masaharu <iwai@alib.jp> 4.0.6-0vl2
259- add apt-cache showsrc option in apt4rpm patch (Patch0)
260
261* Thu Aug 15 2002 IWAI Masaharu <iwai@alib.jp> 4.0.6-0vl1
262- upstream update
263
264* Sun Aug 11 2002 IWAI Masaharu <iwai@alib.jp> 4.0.5-0vl1
265- upstream update
266- apt-cache showsrc option changed unavailable in apt4rpm patch (Patch0)
267
268* Tue Dec  4 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.4-0vl1
269- loading vine specific profile scripts moved from zshrc to zprofile
270- fixed other bug($PATH,zmodload)
271
272
273* Mon Aug 27 2001 Shoji Matsumoto <shom@vinelinux.org> 4.0.2-0vl3
274- rebuilding current Seed
275- change ssh completion (Patch1)
276
277* Thu Aug 16 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.2-0vl2
278- fixed bug rpm package name completions in _apt
279
280* Thu Jul 19 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.2-0vl1
281- 4.0.2
282
283* Sun Jun  3 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl1
284- upstream 4.0.1 release
285- fixed bug zshrc( add /usr/X11R6/bin $PATH)
286- fixed lack 'Epoch:'
287
288* Thu Apr 26 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl0.4.pre.3
289- fixed version number invalid
290
291* Fri Apr 20 2001 <sagami@vinelinux.org>
292- 4.0.1-0vl0.3.pre.4
293- install infopage/manpage and added PreReq = /sbin/install-info
294- fixed/added scripts in post/postun/preun for install-info
295
296* Fri Apr 13 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl0.3.pre.3
297- upstream update
298- fixed /etc/zshrc bugs
299
300* Tue Apr  3 2001 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.1-0vl0.0.pre.2
301- upstream update
302- remove all patches
303
304* Tue Oct  3 2000 Kazuhisa TAKEI<takei@vinelinux.org> 3.1.9-4vl1
305- can read /etc/profile.d/*.sh
306
307* Wed Sep 13 2000 Kazuhisa TAKEI<takei@vinelinux.org>
308- 3.1.9-4vl0
309- convert from Mandrake Linux to Vine Linux
310- add Japanise Summary and description
311
312* Sat Aug 26 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-4mdk
313- Set some %config file to (noreplace).
314- Make -A to complete spec file for _rpm.
315
316* Thu Jul 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-3mdk
317- Get /usr/share/man also in the completion for perl manpages.
318- BM.
319
320* Wed Jul  5 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-2mdk
321- Fix buildroot hardcoded in binary.
322
323* Wed Jun 21 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.9-1mdk
324- Use makeinstall macros (not easy this one :\).
325- 3.1.9.
326
327* Mon Jun  5 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.8-1mdk
328- 3.1.8.
329
330* Sun May 28 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev22-3mdk
331- Fix path (%{prefix}/ucb -> %{_bindir}/X11)
332- Fix keys (home-end-suppr-delete) directly in the zsh binary.
333
334* Sun Apr 16 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev22-2mdk
335- Remove doble .so in %{_libdir}/zsh/*.
336
337* Thu Apr 13 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev22-1mdk
338- 3.1.6dev22.
339
340* Fri Mar 31 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev20-3mdk
341- Fix completion of rpm with -qp*.
342
343* Mon Mar 27 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev20-2mdk
344- Upgrade zshguide.
345
346* Sat Mar 25 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev20-1mdk
347- 3.1.6-dev20
348
349* Wed Mar 22 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev19-3mdk
350- Move global configuration here.
351- Adjust groups.
352
353* Tue Feb 22 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev19-2mdk
354- Add new zshguide from pws.
355- Separate the doc to the doc package
356
357* Sun Feb 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev19-1mdk
358- Clean Up spec (thanks specs-helper).
359- Remove all our patchs (now all is commited to upstream main).
360- 3.1.6dev19.
361
362* Fri Feb 18 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev18-3mdk
363- Recompile with glibc2.1.3 (first one).
364
365* Thu Feb 17 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev18-2mdk
366- Add --freshen completion.
367
368* Tue Feb 15 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev18-1mdk
369- Fix descriptions and summary.
370- 3.1.6dev18.
371
372* Thu Feb 10 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev17-2mdk
373- Remove Makefile in %doc.
374- BuildRequires: autoconf tetex.
375- Lot of modications in the default config as suggested by Bart
376  Schaefer <schaefer@zsh.org>.
377- 3.1.6dev17.
378
379* Mon Jan 24 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev16-1mdk
380- dev16.
381- Redo the tar_archive patchs.
382
383* Tue Jan 18 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev15-1mdk
384- dev15.
385- Fix doc generation with dev15.
386- remove META-FAQ.
387- disable lfs on sparc.
388
389* Thu Jan  6 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6dev14-1mdk
390- dev14 (note the name change).
391
392* Mon Jan  3 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 3.1.6pws13-3mdk
393- Remove temporary files.
394
395* Fri Dec 31 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
396- 3.1.6pws13 (mainly bug fixes).
397- fix %post.
398- fix rpm completion
399
400* Thu Dec 09 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
401- 3.1.6pws11 (mainly bug fixes).
402
403* Tue Dec  7 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
404- Add run-help and perl-build the documentation.
405
406* Tue Nov 30 1999 Francis Galiegue <francis@mandrakesoft.com>
407
408- Completion machine patch - we use GNU make and GNU tar
409- Small fix to %post script
410
411* Tue Nov 30 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
412- 3.1.6pws10
413- Fix zprofile.
414- Clean-up Franciseries.
415- Clean-up specs.
416
417* Mon Nov 29 1999 Francis Galiegue <francis@mandrakesoft.com>
418- Grrr... Rebuilt on kenobi, toy ain't a cooker
419
420* Mon Nov 29 1999 Francis Galiegue <francis@mandrakesoft.com>
421
422- Completion system now handles bzip2'ed manpages and tarballs
423- Some cool options
424
425* Wed Nov 10 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
426- Add zshguide.txt to documentation.
427
428* Thu Oct 07 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
429
430- Fix bug in %{_sysconfdir}/zsh use USERNAME instead of USER.
431- Improve %{_sysconfdir}/z* to source the /etc/profile.d/ files.
432
433* Mon Oct 04 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
434
435- 3.1.6-pws6
436- Fix bad link.
437- Fix bad manpages.
438
439* Tue Aug 17 1999 Thierry Vignaud <tvignaud@mandrakesoft.com>
440- fix typo in examples directory name
441
442* Sun Aug  8 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
443
444- Copy documentation (yes a lot).
445- Remove the completion machine and put them in [[ {etc,root}(skel|files) ]] package.
446
447* Sat Aug  7 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
448
449- By defaut we launch the completion machine.
450- Put zsh in %{_bindir}/
451- Rewrite of Spec file for this new major version.
452
453# end of file
Note: See TracBrowser for help on using the repository browser.