source: projects/specs/trunk/z/zlib/zlib-vl.spec @ 8311

Revision 8311, 9.8 KB checked in by kudoh, 10 years ago (diff)

rebuilt and new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary: The zlib compression and decompression library.
3Summary(ja): zlib 圧縮/展開ライブラリ
4Name: zlib
5Version: 1.2.8
6Release: 1%{?_dist_release}
7Group: System Environment/Libraries
8Source: http://www.zlib.net/zlib-%{version}.tar.xz
9# Patch0: zlib-1.2.5-lfs-decls.patch
10
11Requires(post): /sbin/ldconfig
12Requires(postun): /sbin/ldconfig
13
14URL: http://www.zlib.net/
15License: zlib and Boost
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18%description
19The zlib compression library provides in-memory compression and
20decompression functions, including integrity checks of the
21uncompressed data.  This version of the library supports only one
22compression method (deflation), but other algorithms may be added
23later, which will have the same stream interface.  The zlib library is
24used by many different system programs.
25
26%description -l ja
27zlib圧縮ライブラリーは、メモリ内で圧縮と解凍を行う関数や、解凍後
28のデータの整合性チェックを行う関数を提供します。今バージョンのラ
29イブラリは「デフレーション(deflation)」という圧縮方法のみをサポ
30ートしていますが、今後同じストリームインターフェースを持つ他の圧
31縮方法も追加する予定です。zlibライブラリーは多種のプログラムで使
32用されています。
33
34%package devel
35Summary: Header files and libraries for developing apps which will use zlib.
36Summary(ja): zlib を使ったプログラム開発に必要なヘッダファイル/ライブラリ
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39
40%description devel
41The zlib-devel package contains the header files and libraries needed
42to develop programs that use the zlib compression and decompression
43library.
44
45%package static
46Summary: Static libraries for  %{name}
47Summary(ja): %{name} のスタティックライブラリ
48Group: Development/Libraries
49Requires: %{name}-devel = %{version}-%{release}
50
51%description static
52The zlib-static package contains the static library for %{name}
53
54## to build compat32 for x86_64 architecture support
55%package -n compat32-%{name}
56Summary: The zlib compression and decompression library.
57Summary(ja): zlib 圧縮/展開ライブラリ
58Group: System Environment/Libraries
59Requires: %{name} = %{version}-%{release}
60Requires(post): /sbin/ldconfig
61Requires(postun): /sbin/ldconfig
62
63%description -n compat32-%{name}
64The zlib compression library provides in-memory compression and
65decompression functions, including integrity checks of the
66uncompressed data.  This version of the library supports only one
67compression method (deflation), but other algorithms may be added
68later, which will have the same stream interface.  The zlib library is
69used by many different system programs.
70
71%description -n compat32-%{name} -l ja
72zlib圧縮ライブラリーは、メモリ内で圧縮と解凍を行う関数や、解凍後
73のデータの整合性チェックを行う関数を提供します。今バージョンのラ
74イブラリは「デフレーション(deflation)」という圧縮方法のみをサポ
75ートしていますが、今後同じストリームインターフェースを持つ他の圧
76縮方法も追加する予定です。zlibライブラリーは多種のプログラムで使
77用されています。
78
79%package -n compat32-%{name}-devel
80Summary: Header files and libraries for developing apps which will use zlib.
81Summary(ja): zlib を使ったプログラム開発に必要なヘッダファイル/ライブラリ
82Group: Development/Libraries
83Requires: %{name} = %{version}-%{release}
84Requires: %{name}-devel = %{version}-%{release}
85
86%description -n compat32-%{name}-devel
87The zlib-devel package contains the header files and libraries needed
88to develop programs that use the zlib compression and decompression
89library.
90
91Install the zlib-devel package if you want to develop applications that
92will use the zlib library.
93
94
95%prep
96%setup -q
97# %patch0 -p1
98
99%build
100mkdir static shared
101
102# build shared lib
103CFLAGS="$RPM_OPT_FLAGS -fPIC" ./configure --shared --prefix=%{_prefix}
104
105make %{?_smp_mflags}
106mv -f Makefile zconf.h *.o *.so* shared/
107
108# build static lib
109CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix}
110make %{?_smp_mflags}
111mv -f Makefile zconf.h *.o *.a static/
112
113
114%install
115rm -rf ${RPM_BUILD_ROOT}
116mkdir -p ${RPM_BUILD_ROOT}%{_prefix}
117
118mv -f shared/* .
119make install prefix=${RPM_BUILD_ROOT}%{_prefix}
120
121mv -f Makefile zconf.h *.o *.so* shared/
122mv -f static/* .
123make install prefix=${RPM_BUILD_ROOT}%{_prefix}
124
125install -m644 zutil.h ${RPM_BUILD_ROOT}%{_includedir}/zutil.h
126mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man3
127install -m644 zlib.3 ${RPM_BUILD_ROOT}%{_mandir}/man3
128
129if [ "%{_prefix}/lib" != "%{_libdir}" ]; then
130    mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
131    mv ${RPM_BUILD_ROOT}%{_prefix}/lib/* ${RPM_BUILD_ROOT}%{_libdir}
132    rmdir ${RPM_BUILD_ROOT}%{_prefix}/lib
133fi
134
135%clean
136rm -rf ${RPM_BUILD_ROOT}
137
138%post -p /sbin/ldconfig
139
140%postun -p /sbin/ldconfig
141
142%post -n compat32-%{name} -p /sbin/ldconfig
143
144%postun -n compat32-%{name} -p /sbin/ldconfig
145
146%files
147%defattr(-,root,root)
148%doc README
149%{_libdir}/libz.so.*
150
151%files devel
152%defattr(-,root,root)
153%doc ChangeLog doc/algorithm.txt
154%{_libdir}/*.so
155%{_libdir}/pkgconfig/zlib.pc
156%{_includedir}/*
157%{_mandir}/man3/zlib.3*
158
159%files static
160%defattr(-,root,root)
161%{_libdir}/*.a
162
163%if %{build_compat32}
164%files -n compat32-%{name}
165%defattr(-,root,root)
166%{_libdir}/libz.so.*
167
168%files -n compat32-%{name}-devel
169%defattr(-,root,root)
170%{_libdir}/*.so
171%{_libdir}/pkgconfig/zlib.pc
172%endif
173
174%changelog
175* Fri Mar 21 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.8-1
176- new upstream release
177- changed archive type bz2 to xz
178
179* Fri Oct 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.2.7-1
180- new upstream release
181- drop patch0 (resolved by upstream)
182- use smp flag in make section
183
184* Fri Oct 1 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.5-2
185- added patch0 from gentoo to fix zlib.h errors on i686 compiling some applications
186
187* Wed Sep 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.5-1
188- new upstream release (built with rpm-4.8.1-1 for pkg-config file)
189- changed License: BSD to zlib and Boost
190- added %%{_libdir}/pkgconfig/zlib.pc in -devel package
191- fixed %%doc files in -devel package
192
193* Fri Mar 05 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-7
194- add Requires(post,pre): /sbin/ldconfig
195
196* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-6
197- rebuilt with gcc-4.4.3-3 on ppc
198
199* Mon Feb  8 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-5
200- rebuilt with new toolchain
201
202* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-4
203- split static library to zlib-static
204  - needed by tuxonice-userui
205
206* Wed Dec 17 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-3
207- change spec into UTF-8
208
209* Sun May 18 2008 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.3-2
210- removed %%if !%%{build_compat32} case condition
211
212* Sat May 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
213- applied new versioning policy
214- rebuilt with new toolchains
215
216* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.3-0vl5
217- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
218
219* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.3-0vl4
220- added compat32-* packages for x86_64 architecture support
221
222* Tue Oct 25 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.2.3-0vl3
223- added compat32- packages for x86_64 architecture support
224
225* Tue Oct 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl2
226- clean up specfile (do not build twice..)
227
228* Tue Jul 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
229- new upstream release
230
231* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2.2-0vl1
232- new upstream release
233- add Patch1 for CAN-2005-2096
234
235* Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
236- new upstream version
237- add translated descriptions (thanks to spec file translation project)
238
239* Sun Apr 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.1.4-0vl3
240- fixed buffer overrun on gzprintf
241        -- added zlib-1.1.4-vsnprintf.patch from http://archives.neohapsis.com/archives/bugtraq/2003-02/0290.html
242
243* Fri Sep 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.4-0vl2
244- changed URL to more preferable site
245
246* Tue Mar 12 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.4-0vl1
247- upstream release
248
249* Tue Dec 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
250- 1.1.3-14vl1
251- based on 1.1.3-14 from Rawhide
252- added Japanese summary
253
254* Fri Sep 15 2000 Florian La Roche <Florian.LaRoche@redhat.de>
255- add -fPIC for shared libs (patch by Fritz Elfert)
256
257* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
258- on 64bit systems, make sure libraries are located correctly.
259
260* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
261- summaries from specspo.
262
263* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
264- automatic rebuild
265
266* Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
267- rebuild
268
269* Tue Jun 13 2000 Jeff Johnson <jbj@redhat.com>
270- FHS packaging to build on solaris2.5.1.
271
272* Wed Jun 07 2000 Trond Eivind Glomsr <teg@redhat.com>
273- use %%{_mandir} and %%{_tmppath}
274
275* Fri May 12 2000 Trond Eivind Glomsr <teg@redhat.com>
276- updated URL and source location
277- moved README to main package
278
279* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
280- compress man page.
281
282* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
283- auto rebuild in the new build environment (release 5)
284
285* Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
286- link against glibc
287
288* Mon Jul 27 1998 Jeff Johnson <jbj@redhat.com>
289- upgrade to 1.1.3
290
291* Fri May 08 1998 Prospector System <bugs@redhat.com>
292- translations modified for de, fr, tr
293
294* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
295- upgraded to 1.1.2
296- buildroot
297
298* Tue Oct 07 1997 Donnie Barnes <djb@redhat.com>
299- added URL tag (down at the moment so it may not be correct)
300- made zlib-devel require zlib
301
302* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
303- built against glibc
Note: See TracBrowser for help on using the repository browser.